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1. Introduction

This chapter describes Documents Xpress — Xerox Web Document
Submission Software Version 2.0 and how to use this manual.

Documents Xpress — Xerox Web Document Submission Software

Documents Xpress allows end users to submit print jobs electronically
using industry standard browsers. Once submitted, production personnel
efficiently update job status as documents move through the production
cycle, providing users with information about their jobs. Web-based
printing generates cost savings and improvements in quality, productivity,
and turnaround time.

The system uses several services that can be loaded on one or more
servers, depending on the print shop configuration.

Intended Audience

This manual is intended for use by personnel who are responsible for the
administration of the Documents Xpress 2.0 system.
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Assumptions

The person administering Documents Xpress should have experience in
the following areas:

• Documents Xpress 2.0
• Windows NT server and / or Windows 2000 server administration
• Applicable workstation operating systems experience
• Hypertext Markup Language (HTML)
• Extensible Markup Language (XML)
• JavaServer Pages (JSP)
• Structured Query Language (SQL)

Conventions

This guide uses the following conventions:

• Menu items and buttons appear in bold text.
• Screen, text box, and drop-down list titles are spelled and punctuated

exactly as they appear on the screen.
• Document titles appear in italics.
• Content representative of text that is displayed on a computer monitor

is displayed in Courier New font and enclosed in a shaded table as
shown in Table 1-1.

Table 1-1. Example of text displayed on a computer monitor

INSERT INTO Field {field_name,custom_name}
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Related Documentation

The following manuals provide further information on the
Documents Xpress system:

• Documents Xpress — Xerox Web Document Submission Software
Version 2.0 Product Overview Guide – 701P37980

• Documents Xpress — Xerox Web Document Submission Software
Version 2.0 Installation Planning Guide – 701P37977

• Documents Xpress — Xerox Web Document Submission Software
Version 2.0 Installation and Configuration Guide – 701P37978

• Documents Xpress — Xerox Web Document Submission Software
Version 2.0 Product Overview Training – 701P37981

Note: Operator / Administrator and User instructions are available as
online help while using the Documents Xpress system.
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2. Product Overview

Documents Xpress is a web-based application used to submit and track
jobs.

System users access the software via three web interfaces:

• A User interface for submitting print jobs
• An Operator interface for printing jobs
• A Printer Administrator interface for setting up printers and templates,

customizing the user interface, and establishing pricing

Responsibilities

System Administrator

The System Administrator manages user, operator, and print shop
administrative permissions for a print shop installation. Specific tasks
include:

• Managing Documents Xpress software
• Customizing the Documents Xpress user interface
• Managing user / operator permissions for a single print shop

The System Administrator will have a detailed understanding how the
Documents Xpress software works.
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Print Shop Administrator

The Printer Administrator is a user who manages a print shop. Specific
tasks include:

• Establishing specific print shop policies
• Configuring printers
• Generating reports using Documents Xpress tools
• Load pricing data into Documents Xpress

The Print Shop Administrator must understand how to configure a printer
and how printer communications work.

Print Shop Operator

The Print Shop Operator is a user who manages the printing workflow in
a print shop. Specific tasks include:

• Printing jobs sent by end users
• Modifying the job status as jobs move through the workflow
• Distributing printed materials

The Print Shop Operator must have detailed knowledge of scheduling
and prioritizing print jobs as well as a solid understanding of the
capabilities and capacities of the print shop.
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User

The User submits documents and jobs to Documents Xpress over the
Internet using a web browser, the Xpress Print Driver (XPD), or through
DocuShare. Specific tasks include:

• Using Documents Xpress as the interface to the print shop
• Uploading documents into Documents Xpress
• Requesting printing and conversion services using

Documents Xpress
• Converting documents to PDF format using Documents Xpress

The User must be knowledgeable about basic web browser use, general
Internet use (downloading, uploading, and navigation), and printer driver
installation.
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3. Installation Requirements

Documents Xpress requires a specific combination of hardware, software,
and information to ensure a successful installation. These requirements
are documented in the Documents Xpress — Xerox Web Document
Submission Software Installation Planning Guide.

These installation instructions assume that the Documents Xpress server
has had the proper operating system installed and has a working
connection to the Internet.

Hardware Requirements

Server Requirements

• One Windows NT 4.0 or Windows 2000 server
• 9-GB hard disk
• 512-MB random access memory (RAM)
• One 10 / 100 MBPS network interface card (NIC)
• One available drop on a 100-MBPS network
• Simple Mail Transfer Protocol (SMTP) server supporting Anonymous

SMTP connections for outgoing mail
• An uninterruptible power supply (UPS) for the server

Client Requirements

• Workstation capable of using a supported operating system and a
supported browser
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Software Requirements

Server Requirements

• Microsoft Windows NT Server 4.0 or Microsoft Windows 2000 Server
• Microsoft TCP / IP Printing service (LPR service) installed (Windows

NT Server 4.0 only)
• Microsoft Office XP
• Adobe Acrobat Reader
• Documents Xpress software
• Internet Explorer 5.5 (or later) or Netscape Navigator 4.75 (or later)
• WinZip or equivalent

Client Requirements

• Any one of the following operating systems:
• Windows NT Workstation 4.0
• Windows 2000 Professional
• Windows 95 / 98 / ME

• Adobe Acrobat Reader
• Internet Explorer 5.5 (or later) or Netscape Navigator 4.75 (or later)
• WinZip or equivalent

Information Requirements

• See the Documents Xpress — Xerox Web Document Submission
Software Version 2.0 – Installation Planning Guide for a complete list
of the information requirements.
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4. System Administration Tasks

This chapter outlines tasks that must take place after installation. Most of
these are ongoing System Administrator tasks. Figure 4-1 shows the post
installation process.

Figure 4-1. Post installation process

Post installation
process

1. Add users to the system

2. Customize the User
Interface

3. Establish back up
procedures

4. Set / modify system
parameters

5. Maintain XDX system

6. Install XPD on client
workstations
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Adding users to the system (Chapter 6 – Managing Users)

Users must be added to the system and assigned proper Group
Memberships and Permissions. These tasks are accomplished through
the User Group Directory (UGD) Admin tool in the Xerox Documents
Xpress (XDX) Control Center.

Customizing the User Interface (Chapter 7 – Customizing the User
Interface)

As installed, Documents Xpress has a generic user interface. The existing
interface can be customized by using the User Interface (UI) Config tool
in the XDX Control Center.

Establishing a backup strategy (Chapter 9 – System Backup)

It is important to establish a backup strategy to protect the system and the
customers using Documents Xpress. The instructions given in the System
Backup chapter are generic, but provide enough information to back up
the correct files.

Setting or modifying system parameters (Chapter 10 – Configuring
System Parameters)

The Configuration Manager tool in the XDX Control Center allows system
parameters must be modified should the need arise. The Configuring
Parameters chapter details how to make these changes.
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Creating or Modifying Templates (Chapter 12 – Modifying Job
Templates)

The Template Manager tool allows the System Administrator to create or
modify cover sheet and delivery sheet templates. The templates can be
modified at any time to meet the needs of a customer

Maintaining the Documents Xpress System

There is no chapter dedicated to this topic, as everything in this guide
relates to the care and maintenance of the Documents Xpress system. It
is the responsibility of the System Administrator to ensure the system is
operating properly.

Installing the Xpress Print Driver on client workstations
(Chapter 8 – Installing the Xpress Print Driver)

Instructions are available online for users to install the Xpress Print Driver
(XPD) on their own client workstation. For users that are uneasy with the
process, it is repeated here for the System Administrator.

The XPD driver for Windows 95 / 98 / ME must be updated on the
Documents Xpress server before any of these clients can use the driver.
See Chapter 8 for more details.
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5. Starting Up and Shutting Down

The XDX Control Center application is used to start and stop the various
Documents Xpress components. When starting Documents Xpress it is
necessary to go the server and run the Control Center.

A tab appears in the Control Center for each component as it is
accessed. Tab names are red if the component is loading, black if the
component is waiting to be loaded, and blue if the component has loaded
properly. An example of the Control Center appears in Figure 5-1.

CAUTION: After using the Control Center to start Documents Xpress
services, minimize the Control Center but DO NOT close it.
Closing the Control Center shuts down Documents
Xpress.

Figure 5-1. XDX Control Center as it appears on the Documents
Xpress server



 STARTING UP AND SHUTTING DOWN DOCUMENTS XPRESS — XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0

5-2 SYSTEM ADMINISTRATION GUIDE

Starting Documents Xpress

Starting Documents Xpress requires using the XDX Control Center
application on the Documents Xpress server.

Note: Documents Xpress checks for the status of the current license at
startup. The system will warn the System Administrator if the
license is within one month of expiring.

Starting Documents Xpress

Perform the following to start Documents Xpress:

1. On the Documents Xpress server, double-click My Computer. Go to
C:\xdx\scripts and double-click ControlCenter.

2. Once the Control Center has started, click
1 : Database Server > 2 : Web Application Server > 3 : Services.

Note: After starting the processes, wait approximately one minute before
starting access from any client machines.

The following figure, Figure 5-2, describes the components started with
the Control Center.

Figure 5-2. Description of components started with the Control Center

Component Description

RMID (Remote Method
Invocation Daemon)

A utility that XDX services use for activation

MySQL (Database Server) The database management system that tracks
users and jobs in the system

Tomcat (used by Web
Server)

Tomcat is a servlet container with a Java Server
Pages (JSP) environment. A servlet container is a
runtime shell that manages and invokes servlets
on behalf of users.

Apache (Web Server) The web server for the Documents Xpress system
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Shutting Down Documents Xpress

To shut down the system, first close the Documents Xpress components
from the Control Center and then close the Control Center.

Shutting Down Documents Xpress

Perform the following to shut down Documents Xpress using the
Control Center:

1. On the Documents Xpress server, click in the following order:
1 : Database Server > 2 : Web Application Server > 3 : Services.

2. Close the Control Center by clicking X.
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6. Managing Users

Once the Documents Xpress system has been installed, users
must be added. This chapter describes the processes for:

• importing users
• adding users
• modifying user information
• deleting / inactivating users
• setting permissions and group memberships

User Group Directory Administration Tool (UGD Tool)

All user management is done through the use of the UGD tool, which is
found in the XDX Control Center. The tool is shown in Figure 6-1.

Figure 6-1. User Group Directory Administration Tool
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Users are added to the Documents Xpress system in two ways:

• By importing an external user data file.
• By entering users on a one-by-one basis through the UGD Admin tool.

Importing Users from an External User Data File

Users may be imported from an external data file. This data file can be
used to initially place users in the Documents Xpress system, and then to
keep the system updated. Using the Update Users, Synchronization
Mode, and Create Batch File functions of the import module, an external
file can be set up to automatically add, update, and inactivate users.

Importing an External User Data File

The following instructions assume Documents Xpress has been installed
and is operating correctly.

Note: When importing a customer data file for Documents Xpress users,
work on a small sample of the file if possible. This allows for rapid
error detection without the delay of a long user file load.

Perform the following steps to import a user data file:

1. Modify or build the user file

2. Modify the User Field Configuration to add required user fields to
those that Documents Xpress uses.

3. Modify or build the User Import Mappings to either add additional
fields from the user file that are not already present in the Documents
Xpress fields or to create mappings from scratch.

4. Import the user data.
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Data File Format for the User File

Comma-delimited is the only data format Documents Xpress uses for
importing user files. Each customer will have a different set of
requirements for the user file and the default set of fields for the user
database will have to be modified.

Comma-delimited File Format

Use a plain text editor, such as Notepad, or a spreadsheet, such as
Excel, to create or modify the user file. Ensure that there is only one line
break at the end of each line. An example file is shown in Figure 6-2.

Figure 6-2. Example of a comma-delimited user file

User Name,Email Address,First Name,Last Name,Phone
istravinsky,igor.stravinsky@tasc.sk.edu,Igor,Stravinsky,513-366-1015
jthorsteinson,jeff.thorsteinson@tasc.sk.edu,Jeff,Thorsteinson,513-366-1016
slaing,scott.laing@tasc.sk.edu,Scott,Laing,513-366-1018

The first line of the data file is the data definition for the lines that follow
as shown in Figure 6-3.

Figure 6-3. Data definition for comma-delimited file

User Name,Email Address,First Name,Last Name,Phone

In the example above, the first field is User Name. Each line that follows
represents a new record for a user, istravinsky for example. This means
that the first data element (field) in a line must always be the user name.
Email Address is the next field name in the first line, so in every line that
follows the second data element (field) is the user’s e-mail address.
Figure 6-4 shows this pattern repetition.
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Figure 6-4. Pattern for records and fields in comma-delimited file
User Name Email Address

istravinsky igor.stravinsky@tasc.sk.edu

jthorsteinson jeff.thorsteinson@tasc.sk.edu

slaing scott.laing@tasc.sk.edu

This pattern repeats with a line break at the end of each user to be
included. There may be fewer or more fields required for any particular
customer.

Note: Ensure there are no trailing blank lines in any of the files to be
modified in this chapter. Blank lines may appear harmless, but can
cause large problems later.

Step 1 – Modifying or Building the User File

Using the information from the previous section, ensure that the user data
file that is modified or built is clean of extra line breaks. If possible, select
a small sample to test the import of the data. Once the test data file has
loaded successfully, load the entire user file.

Note: All users must have a unique user name or ID number.

The new user file can be located anywhere on the file system.

Have a printed copy of the first page of the new user data file available for
reference. Ensure that the first line of the file includes the file’s field
names.
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 Step 2 – Modifying the User Field Configuration

System User Fields

Documents Xpress has the following system user fields that cannot be
changed:

user_id
first_name
last_name
phone
email

A user file can be built using these default fields but it is more likely that a
customer wants other fields included.

Added Default User Fields

As installed, Documents Xpress 2.0 has the following user fields added:

address_line_1
address_line_2
mail_code
city
state
zip
e-mail
phone
ext
location
department
cost_center

Note: Any of these fields may be modified or deleted as required to meet
customer specifications.
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Examine which fields in the new user file will map to existing fields in the
system. Any fields that cannot be mapped must be added to the user file.

If the previous example of a comma-delimited file shown in Figure 6-2 on
page 6-3 is expanded to include an extra field, supervisor, the file would
look like Figure 6-5 shown below.

Figure 6-5: Sample user file
User Name,Email Address,First Name,Last Name,Phone,Supervisor
istravinsky,igor.stravinsky@tasc.sk.edu,Igor,Stravinsky,513-366-1015,A. Jones
jthorsteinson,jeff.thorsteinson@tasc.sk.edu,Jeff,Thorsteinson,513-366-1016,B. Bo
slaing,scott.laing@tasc.sk.edu,Scott,Laing,513-366-1018,C. Clements

Upon examination, all the fields map to existing fields in Documents
Xpress with the exception of Supervisor. This field will have to be added
to Documents Xpress.

Adding a Field to the User Field Configuration

This example will add Supervisor to the list of User Fields.

Perform the following to add a field to the User Field configuration:

Note: Ensure the Database Server is started in the XDX Control Center.
1. From the XDX Control Center click Tools > UDG Admin.

2. Click Tools > User Field Config.

3. The User Field Configuration window appears. The 11 User Field
Mappings listed in the previous section are present if this is the first
time this tool is being used. These fields can be ignored or deleted if
they will not be used.
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Double-click in the next available blank line under the User Field
Mapping column. Type supervisor as the field name.

There can be a maximum of 20 user fields.

Note: User Field Mapping names must contain no spaces. In place of a
space, use an underscore.

4. Press Enter on the keyboard. Documents Xpress accepts the entry.

Note: When the last field has been added, ensure that Enter is pressed
on the keyboard to force Documents Xpress to accept the entry. If
Enter is not pressed, the last entry will be lost.

CAUTION: The Clear Data button erases all data for all users in the user
field where the cursor appears. It does not clear a field name
that has been typed.

5. To accept the User Field Configuration additions, click Save. The
UGD Admin – User Field Config window appears saying that the
mappings are updated. Click OK. Click Close.

The User Group Directory Admin window refreshes to show the
modifications to the user fields. In this example, supervisor appears
as the last field listed.
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Removing a Field from the User Field Configuration

Unneeded user fields, or fields that were added in error, can be removed.

Perform the following to remove fields from the User Field
Configuration:

Note: Ensure that the Database Server has been started in the XDX
Control Center.

1. From the XDX Control Center click Tools > UDG Admin.

2. Click Tools > User Field Config.

3. The User Field Configuration window appears. Double-click the
name of the field that is to be removed.

4. Delete the name of the field that is to be removed and press Enter on
the keyboard.

5. Click Save. The UDG Admin – User Field Config window appears
stating that field mappings have been removed. Click Yes to complete
the deletion of the field.

6. A window appears to confirm the deletion of the field. Click OK. Click
Close.

Step 3 – Building or Modifying the User Import Mappings

Once the desired fields have been added to Documents Xpress, the field
names in the user data file need to be mapped to field names that
Documents Xpress uses.

Continuing to use the data file example from the last step, a new Import
Mapping will be created.
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Creating and Saving New Mappings

The default mapping is provided as a starting point for development of a
user database. If a different mapping is needed, it can be created and
saved.

Figure 6-6 shows the user data file field names and how they will map to
Documents Xpress names.

Figure 6-6. User file field names that map to Documents Xpress field
names

User File Field Names Documents Xpress
Field Names

User Name maps to user_id*

Email Address maps to email*

First Name maps to first_name*

Last Name maps to last_name*

Phone maps to phone*

Supervisor maps to supervisor

* system fields

Perform the following to create and save a new mapping:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens.
Click Tools > User Import Mappings.
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3. The UGD Admin - User Import Mappings Window opens. The
screen is divided into three sections: a window showing any saved
mappings, the Import Field Label, and the User Field Mapping.

4. Click Add under the column where the default mapping is listed.

5. The UGD Admin - New User Mapping window appears. Type a
mapping name. For this example, type Test as the mapping name.
Click OK.

6. A blank UGD Admin - User Import Mappings window appears. Click
Add.

7. The UGD Admin - User Field Import Mapping window appears. The
field names from the user data file must be entered, one at a time,
and matched with a Documents Xpress field. Using the chart in figure
6-6, six import mappings must be created. Type the field name as it
appears in the user file in the Imported field name text box.
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8. Scroll through the list of UGD User Defined Fields to find the
Documents Xpress field that maps to Imported field name. Use the
>> button to move the field into the Import Mapping window. Use the
<< button to remove a field moved in error. Click OK.

9. The updated UGD Admin - User Import Mappings window
reappears. Click Add to add an additional mapping. Repeat steps 7
and 8 to add all the required mappings.

Note: Fields can be combined. An example of this is where the import file
has both first and last names contained a single field. In a case like
this, create a mapping and move one name field and then the other
name field, in the order used in the import file.

10. To save the mappings, click Actions > Save. A confirmation message
appears that the mappings were saved. Click OK.
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11. Click X to exit the UGD Admin – User Import Mappings window.

Modifying User Import Mappings

If additional fields are added or removed from a user import file, the
mapping for that import file will have to be modified.

Perform the following to modify the default User Import Mappings:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens.
Click Tools > User Import Mappings.

3. The UGD Admin - User Import Mappings Window opens as shown
below. The screen is divided into three sections: a window showing
any saved mappings, the Import Field Label, and the User Field
Mapping.

The Import Field Label matches the field name in the import file. The
User Field Mapping is the Documents Xpress field where the user
data will be placed.
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To see the structure of the mappings, click the line that begins with
First Name and then click Modify.

4. A new UGD Admin - User Field Import Mapping window opens.
This window is where the field names in the import file are matched
with the Documents Xpress system uses for field names internally.
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Type the name of any new Import filed name and then scroll through
the list of UGD User Defined Fields to find the Documents Xpress field
into which that particular field will be imported. Use the >> button to
move the field into the Import Mapping window. Use the << button to
remove a field moved in error.

5. When finished modifying the mappings, click OK.

Note: Fields can be combined. An example of this is where the import file
has both first and last names contained a single field. In a case like
this, create a mapping and move one name field and then the other
name field, in the order used in the import file.

6. The UGD Admin - User Import Mappings window reappears.

7. To save the mappings, click Actions > Save. A confirmation message
appears that the mappings were saved. Click OK.
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8. Click X to exit the UGD Admin - User Import Mappings window.

Additional Menus in UGD Admin – Import Mappings Window

There are two additional menu choices listed under the Actions menu.

1. Reload – reloads the default user mappings.

2. Default Mapping – allows the selection of which mapping will be the
default mapping on the UGD Admin - Import Users window.

Step 4 – Import Users

Once the user file has been mapped to data that Documents Xpress will
use, importing the file is the last step.

Perform the following to import users:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens.
Click Tools > Import Users.
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3. The UGD Admin - Import Users window opens.

4. Click Browse and locate the user file to be imported.

5. Click the User mapping drop-down menu and select the mapping to
be used for the import. Continuing with the example file, select test.

Click View to ensure this is the correct mapping to be used for the
import. Click X to close the view window.

6. Click Import. A summary screen appears when the process is
complete. Click OK.

7. The User Group Directory Admin window reappears. All imported
users appear and are active.
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8. Click X to exit the User Group Directory Admin window.

Note: Users that are imported from the system are in the database
permanently. Once they are made inactive, they still appear in the
user list unless their names are filtered. Filtering is accomplished
by right-clicking on any user name. A Filter Users menu appears.
Clear the Inactive Users choice and only the active users will
appear.

Choices Available in the Import Users Window

• User mapping – Allow the selection of a previously configured
mapping if other than the default mapping is required.

• View – View the selected User mapping.
• Update users – If selected, any users information that already exists

in the database will be updated if the user is listed in the import file.
• Synchronization mode – If selected, any users that exist in the

database, but are not listed in the import file will be inactivated. This
synchronizes the database users with the import file users.

• Import – Begin the import process.
• Create Batch File – If clicked, creates a batch file that can be used to

run the import process outside of the UGD Admin tool. This file can be
used to schedule imports on Windows by the System Administrator.
The batch file stores the information selected in the import dialog.

• Cancel – Exit from this window without taking any action.
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Troubleshooting a Faulty Import

If the user file did not import properly, there may be a database of users
with incorrect or incomplete information. Documents Xpress does not
allow these users to be deleted. They can only be inactivated.

If the system has not been put into production, all the Documents Xpress
databases, including users and jobs, can be re-initialized. Read, and use
with caution, the Re-initializing the User Database section in
Chapter 14 – Troubleshooting  on page 14-2 of this guide.

Adding Users One at a Time

The UGD tool can also add users one at a time. This procedure assumes
that the user database has already been configured. If it has not been
configured, use Step 2 Modifying the User Field Configuration on page
6-5 in this chapter.

Adding a User to Documents Xpress

Perform the following to add a user to Documents Xpress:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens.

3. Click Add User.

4. Select Active in the top left corner of the New User window.
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5. Click in the user-id field and type a unique user identification for the
user being entered.

6. Press the Tab key twice to move to the next field. Type in all the
required user information.

Note: Clicking the mouse in the Field Value column will also allow data
entry for a particular field. This may speed up data entry if not all
the fields are required for a user.

7. When the last field value is typed for a user, press Enter on the
keyboard. Pressing Enter forces Documents Xpress to accept the last
field entered.

8. Click OK. A confirmation message appears. Click OK. The User
Group Directory Admin window reappears and refreshes to show
the newly added user.

Modifying User Information

User information can be modified in a batch by importing an updated user
file, or one at a time.

Modifying User Information for a Group of Users

If there are a large number of users to be modified, Documents Xpress
can import a modified user list and update users whose user profiles have
changed.

Perform the following to modify a group of users:

1. Open the latest version of the user list and modify the user profile for
any user that requires updating.

2. From the XDX Control Center click Tools > UDG Admin.
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3. The User Group Directory Admin window opens.
Click Tools > Import Users.

4. The UGD Admin - Import Users window opens. Click Browse and
locate the updated user file.

5. Select the correct User mapping.

6. Ensure that Yes is selected for Update Users.

7. Ensure that No is selected for Synchronization mode.

8. Click Import. A summary screen appears when the process is
complete. Click OK.

9. The User Group Directory Admin window reappears. All users with
new profile information are updated.

10. Click X to exit the User Group Directory Admin window.

Modifying User Information for a Single User

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Click the line
where the user to be modified appears. The line becomes highlighted.

3. Click Modify User. The Modify User window opens.

4. Click in the Field Value and change any information that requires
modification. Press Enter on the keyboard when the last modification
has been made to force Documents Xpress to accept the last change
made to a field.

5. Click Update. A confirmation window appears. Click OK.
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6. To exit the Modify User window, click Close.

7. The User Group Directory Admin window reappears. The user with
the updated profile information appears with the updated information.

8. Click X to exit the User Group Directory Admin window.

Changing a User Password

Users select their own password during registration. If they forget their
password, or require it changed, the System Administrator must change it
for them. Users cannot change their own password.

Perform the following to change a user password:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Click the line
where the user to be modified appears. The line becomes highlighted.

3. Click Modify User.  The Modify User window opens.

4. Click Change Password.

5. The UGD Admin - Modify User window opens. Type the new
password for the user and click OK.

6. A confirmation window appears. Click OK.

7. To exit the Modify User window, click Close.

8. The User Group Directory Admin window reappears.
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9. Click X to exit the User Group Directory Admin window.

Deleting / Inactivating Users

Documents Xpress users are never deleted from the system. Since there
may still be jobs in process associated with the user, they are inactivated
instead.

Inactivating Users

Users may be inactivated individually, or in a group by re-importing the
user file.

Inactivating an Individual User

Perform the following to inactivate individual users:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Locate the user to
be inactivated and click on the line containing their name. The line
should be highlighted. Click Inactivate User.

3. The UGD - Inactivate User window appears. Click Yes.

4. A confirmation window appears. Click OK. If the user list is set to filter
out inactivated users, the name just inactivated will disappear.
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Inactivating a Group of Users

If there are a large number of users to be inactivated Documents Xpress
can import a user list and inactivate users not in the updated user list.

Note: If selected, any users that exist in the database, but are not listed in
the import file will be inactivated. This synchronizes the database
users with the import file users

Perform the following to inactivate a group of users:

1. Open the latest version of the user list that was imported and remove
any users that should be inactivated.

2. From the XDX Control Center click Tools > UDG Admin.

3. The User Group Directory Admin window opens. Click
Tools > Import Users.

4. The UGD Admin - Import Users window opens. Click Browse and
locate the updated user file.

5. Select the correct User mapping.

6. For the Synchronization mode select Yes.

7. Click Import. A summary screen appears when the process is
complete. Click OK.

8. The User Group Directory Admin window reappears. All imported
users should appear and be active while those removed from the
imported user file should be inactivated.

9. Click X to exit the User Group Directory Admin window.
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Assigning Privileges and Groups to Users

By default, there are only two accounts established during installation:

• admin, the administrator account
• operator, the print operator account

These two accounts are placed, respectively, into the Xerox Business
Systems (XBS) Admin and XBS Operator groups.

Users, when they register for access to the Documents Xpress system,
are placed in the user group. Because users should not have access to
the admin or operator accounts directly, users can be reassigned to to
one of these groups to better reflect their job position.

Figure 6-6 shows the default list of user groups and permissions available
in the Documents Xpress system. If these groupings are insufficient, they
can be added to or modified.

Figure 6-6. Default list of user groups and permissions
Permissions

User Groups Resource
Type Resource Name Right

printshop default Printer Administration

printshop default Run JobsXBS Admin

system system Use

printshop default Run JobsXBS
Operator system system Use

user system system Use
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Resource Types

System – The system resource type refers to resources using the
Documents Xpress system via the Documents Xpress user interface.

Printshop – The printshop resource type refers to resources related to
the printshop itself such as adding printers.

Rights

Printer Administration – A user with this right can add printers to
Documents Xpress.

Run Jobs – A user with this right can perform tasks using the
Administrator interface.

Use – A user with this right can perform any tasks using the User
interface.

Viewing the Permissions and Group Memberships Assigned to a
User

Users may be members of more than one group. It is possible to view
what permissions a user has and what groups they are associated with.

Perform the following to view the permissions and group
memberships assigned to a user:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens.

3. Click on the name of the user. The line becomes highlighted.

4. Click Group Membership to view the groups a user has been
assigned. Click X to close the User Group Membership window.
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5. Click Permissions to view the permissions a user has been assigned.
Click X to close the User Permissions window.

Assigning a User to a Group

All users, when they register for access to the system, are placed in the
user group. Any user can be reassigned to a new group. This example
will place a user in the XBS Operator group. To place a user in the XBS
Admin group follow the same steps except choose XBS Admin as the
Group Name.

Perform the following to assign a user to a group:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Click the Groups
tab.

3. The window refreshes and the user groups appear. Click XBS
Operator. The XBS Operator line becomes highlighted. Click Users.

4. The User Group Membership window opens. Locate the user, or
users, that need the rights of an operator. Click the user name to
select the user or hold the Ctrl key down and click to select multiple
user names.

5. Click >> to move the user names to the Group User Names column.
If an error is made, select the erroneous name in the Group User
Names column and click <<.

6. Click Save. A confirmation message appears. Click OK. Click Close.
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7. The User Group Directory Admin window reappears. To exit the
User Group Directory Admin window, click X.

Removing Users from a Group

Perform the following to remove a user from a group:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Click the Groups
tab.

3. The window refreshes and the user groups appear. Click the name of
the group from which the user is to be removed. The selected line
becomes highlighted. Click Users.

4. The User Group Membership window opens. Locate the user, or
users in the Group User Names window. Click the user name to
select the user or hold the Ctrl key down and click to select multiple
user names.

5. Click << to move the user names to the User Names column. If an
error is made, select the erroneous name in the User Names column
and click >>.

6. Click Save. A confirmation message appears. Click OK. Click Close.
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7. The User Group Directory Admin window reappears. To exit the
User Group Directory Admin window, click X.

Adding a New User Group

New user groups can be added to the Documents Xpress system.

Perform the following to add a new user group:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Click the Groups
tab.

3. The window refreshes and the user groups appear. Click Add Group.

4. The UGD - Add Group window appears. Type the name of the new
user group and click OK.

5. A confirmation window appears. Click OK.

Note: This user group will have no users or permissions assigned to it.
6. The User Group Directory Admin window reappears. To exit the

User Group Directory Admin window, click X.
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Adding Permissions to a Group

Once a group is established, it needs to have permissions assigned.

Perform the following to add permissions to a group:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Click the Groups
tab.

3. The window refreshes and the user groups appear. Click the name of
the group that requires permissions. The line becomes highlighted.
Click Permissions.

4. The Group Permissions window opens.

Click Add Permission.
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5. The UGD - Permissions window opens. Using Figure 6-5, on page
6-6 as a guide, along with the explanation of Resource Types that
follow it, construct a new permission for this type of user.

6. When done adding permissions, click Save.

7. A confirmation window appears. Click OK. Click Close.

8. Add users to this group by following the instructions on assigning a
user to a group given above.

Deleting a User Group

If a group is no longer required, it can be deleted.

CAUTION:  DO NOT delete XBS Admin, XBS Operator, or user groups.

Perform the following to delete a user group:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Click the Groups
tab.

3. The window refreshes and the user groups appear. Click the name of
the group that is to be deleted. The name of the group becomes
highlighted. Click Delete Group.

4. A confirmation window appears. Click Yes.

5. A second confirmation window appears confirming the removal of the
user group. Click OK.
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6. The User Group Directory Admin window reappears. To exit the
User Group Directory Admin window, click X.

Modifying a Group Name

An existing group name can be modified.

CAUTION:  Do NOT delete XBS Admin, XBS Operator, or user groups.

Perform the following to modify a group name:

1. From the XDX Control Center click Tools > UDG Admin.

2. The User Group Directory Admin window opens. Click the Groups
tab.

3. The window refreshes and the user groups appear. Click the name of
the group that is to be modifed. The name of the group becomes
highlighted. Click Modify Group.

4. The UGD - Modify Group window appears with the existing group
name. Press the Backspace key on the keyboard to clear the existing
name. Type the new group name and click OK.

5. A confirmation window appears. Click OK.
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6. The User Group Directory Admin window reappears. To exit the
User Group Directory Admin window, click X.
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7. Customizing the User Interface

The User Interface (UI) Configuration tool in the XDX Control Center
customizes the user interface for Documents Xpress. There are four
areas of the user interface that can be customized:

• Colors – Text, links, and navigation bars can have colors modified.
• Image – The header image can be changed to a new image.
• Text – Any text visible on the screen in the user interface can be

modified for font, font size and font style.
• Main Page Text – Once logged on to the system, there is a section of

the Home page where text can be modified.

If unsatisfied with changes, the original interface configuration can be
restored.

Starting the UI Configuration Tool

Perform the following to start the UI Configuration tool:

1. From the XDX Control Center click Tools > UI Config.
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2. The uiconfi_control_panel window opens.
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Configurable Sections of the User Interface

The sections of the user interface referred to in the UI Configuration Tool
are shown below in Figures 7-1 and 7-2.

Figure 7-1. User Interface Items that can be selected in the UI Configuration Tool
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Figure 7-2. User Interface Items that can be selected in the UI Configuration Tool

Configuring Colors

To change colors for any of the configurable user interface sections follow
the general procedure outlined below. This procedure assumes that the
User Interface Configuration tool has been opened.

The default values for the Configure Colors section of the User Interface
Configuration tool follow at the end of this chapter.
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Perform the following to modify a configurable color item:

1. From the Configure Colors drop-down menu, select the item to be
changed. This example will change the Main Page Text Color.

2. The Current Color text box refreshes to show the color currently
selected for the Main Page Text Color. Click Color Browse.

3. The Color Chooser opens. There are three methods of choosing a
color, each selectable by clicking their respective tab.

Swatches – Select a color from the palette presented.
HSB – Move the slider up or down to select a hue, then click the
mouse in the color block to select the saturation and brightness
desired.
RGB – If the red, blue, and green values are known for a desired
color, move the sliders or type the values to obtain that color.
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Note: Only the Foreground color can be selected.
4. Once the desired color has been selected, click OK. The Current

Color text box refreshes to show the modification.

5. To see the modification, click Commit Changes. A Login window will
appear if this is the first modification made this session. Type Admin
for the Username and 22222 for the Password. Click OK.

6. Open a browser window and go to the Documents Xpress 2.0 home
page. Logon and move to the page where the change has been
made. If the change is unsatisfactory, repeat the steps to choose a
new color.

Note: If a new color is selected to replace a color that was selected in the
procedure above, commit the changes and click Refresh on the
browser window to see the new changes. A new browser window
does not have to be opened.
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7. When the desired color changes are completed, click X to exit the
User Interface Configuration tool.

Configuring the Header Image

The header image can be changed to a different image with these
restrictions:

• The image must be 700 X 82 pixels.
• The image must be saved as either a GIF or JPG format picture.
• The image may be located outside of the Documents Xpress program

folder but should reside on the Documents Xpress server.

When creating an image for the header, be aware that large company
logos will not scale well to the small size required in the header. Use an
image-editing program to create the best possible header image.

This procedure assumes that the User Interface Configuration tool has
been opened.

The default value for the Configure Image section of the User Interface
Configuration tool follows at the end of this chapter.

Perform the following to modify a header image item:

1. From the Configure Image drop-down menu, select Header Image.

2. The Current Color text box refreshes to show the color currently
selected for the Main Page Text Color. Click Color Browse.

3. The Open dialog box appears. Browse to the folder where the new
image is located by clicking the Look in drop-down menu.
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4. When the image has been located, click the name of the image. The
image name appears in the File name text box. Click Open.

5. The Current Image text box refreshes with the new image file name.
Click Commit Changes. A Login window will appear if this is the first
modification made this session. Type Admin for the Username and
22222 for the Password. Click OK.

6. Open a browser window and go to the Documents Xpress 2.0 home
page. The new header image is now present. If the change is
unsatisfactory, repeat the steps to choose a different header image.

Note: If a browser window is already open and on a Documents Xpress
2.0 page, click Refresh on the browser window to see the new
header image. A new browser window does not have to be opened.

7. When the desired header changes are complete, click X to exit the
User Interface Configuration tool.

Configuring Text

To change the text attributes for any of the configurable user interface
sections follow the general procedure outlined below. This procedure
assumes that the User Interface Configuration tool has been opened.

The default values for the Configure Text section of the User Interface
Configuration tool follow at the end of this chapter.



 DOCUMENTS XPRESS — XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0 CUSTOMIZING THE USER INTERFACE

SYSTEM ADMINISTRATION GUIDE 7-9

Perform the following to modify a configurable text item:

1. From the Configure Text drop-down menu, select the item to be
changed. This example will change the Main Page Text Weight.

2. The Current Value text box refreshes to show the color currently
selected for the Main Page Text Weight. Type the new text weight
desired into the Current Value text box.

3. Click Commit Changes. A Login window will appear if this is the first
modification made this session. Type Admin for the Username and
22222 for the Password. Click OK.

4. Open a browser window and go to the Documents Xpress 2.0 home
page. The new change in text weight is now present. If the change is
unsatisfactory, repeat the steps to choose a different text weight.

Note: If a browser window is already open and on a Documents Xpress
2.0 page, click Refresh on the browser window to see the new
change. A new browser window does not have to be opened.

5. When the desired text changes are complete, click X to exit the User
Interface Configuration tool.
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Table 7-1 shows acceptable attribute values for text.

Table 7-1. Values that can be used for Text attributes

Acceptable Values for Text

Text Family Text Weight Text Size

Use standard
browser fonts such
as arial and times
roman
Note: There is no
capitalization of font
names

bold
normal

xx-small
x-small
small

normal
large

x-large

Configuring the Main Page Text

The Main Page Text is a configurable section of text that appears on the
user home page. Using the User Interface Configuration tool modifies this
text. This procedure assumes that the UI Configuration tool has been
opened.

Figure 7-3 illustrates a home page that has been modified by changing
colors, header image, and main page text. This procedure will illustrate
how to modify the main page text.
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Figure 7-3. Home page with modified header image and modified main page text

Perform the following to modify the main page text:

1. Below the Configure Text section of the UI Configuration tool is the
Main Page Text section of the tool. Using standard HTML, modify the
code to reflect any required customer text.

2. When the code changes have been completed, click Commit
Changes. A Login window will appear if this is the first modification
made this session. Type Admin for the Username and 22222 for the
Password. Click OK.

3. Open a browser window and go to the Documents Xpress 2.0 home
page. The changes to the main page text are now present. If the
change is unsatisfactory, repeat the steps to change the HTML code.
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Note: If a browser window is already open and on a Documents Xpress
2.0 page, click Refresh on the browser window to see the new
change. A new browser window does not have to be opened.

4. When the desired changes are complete, click X to exit the User
Interface Configuration tool.

Tips about creating the Main Page Text

• HTML code can be entered directly into the Main Page Text window in
the User Interface Configuration tool, but it is much quicker to create
the code in a visual HTML editor like, Dreamweaver.

• Create the code needed, including any desired images. The code
created in a visual editor can be cut and pasted directly into the Main
Page Text window.

• Save all images for Main Page Text as GIF or JPG images and in the
following folder on the Documents Xpress server –
c:\xdx\etc\Apache\tomcat\webroot\images\2_0_images.
Save a copy of these files outside the c:\xdx folder.

• The font for the Main Page Text is controlled in the Configure Text
part of the UI Configuration tool. Do not change fonts in the HTML
text.

• Allowable changes inside the HTML code include:
• color and size of text
• justification of text and images
• insertion of images

• Use a utility, like Eye Dropper, to assist with picking colors. These
utilities allow a user to obtain color values for any onscreen images
making color matching a simpler process.

• The code for the sample Main Page Text in Figure 7-3 follows in
Figure 7-4.
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Figure 7-4. HTML code sample for the Main Page Text in Figure 7-3.

<br/>
<font size="+1"> &nbsp;<font color="#A8C8FF">Welcome to the Telephone
Laboratories Print Shop</font></font><br/><br/>
<img src="/images/2_0_images/finger2.jpg" width="60" height="58" align="left"
hspace="2">Remember that the main printing facility will be closed for printer
upgrades on March 2 and 3. Ensure that all your print jobs are forwarded to
the Suffolk printers.<br/><br/>
Additionally, remember that even print jobs with hard copies need to be
entered through this system. If you need assistance, consult the online Help
system or ring our Help Desk staff at the Marshall Frank Building: 0171 888
5555<br/>

<p align="center"><i>Thank you for letting us be of assistance to you.</i>

• Do not include any of the standard required HTML tags in the Main
Page Text. These tags include <html>, <head>, <title>, and <body>.

Restoring the Default User Interface Configuration

If the need arises, the default interface can be restored to the Documents
Xpress system. This procedure assumes that the UI Configuration tool
has been opened.

CAUTION: This procedure will cancel all changes made to the user
interface. It is not a reversible procedure.

Perform the following to restore the default user interface:

1. Click Restore Defaults.

2. A Confirm window appears. Click Yes to restore the default system
values.
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3. Close the UI Configuration tool window by clicking X.

4. Reopen the UI Configuration tool and click Commit Changes. A
Login window will appear if this is the first modification made this
session. Type Admin for the Username and 22222 for the Password.
Click OK.

5. Open a browser window and go to the Documents Xpress 2.0 home
page. The default user interface is now present.

Note: If a browser window is already open and on a Documents Xpress
2.0 page, click Refresh on the browser window to see the restored
default interface. A new browser window does not have to be
opened.

User Interface Configuration Defaults

The following tables contain the default values for the User Interface.

Table 7-2. Configure Colors

Configure Colors

Configurable Section Default

Default Text Color #000000

Main Page Text Color #000000

Warnings and Information Text
Color

#FF0000

Top Navigational Links Text Color #000000
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Figure 7-2. Configure Colors (continued)
Configure Colors

Configurable Section Default

Title Bar Text Color #FF0000

Sub Title Bar Text Color #000000

Title Bar Color #FF0000

Title Bar Link Hover Color #0000FF

Sub Title Bar Color #EFEFEF

Alternating Colored Bars I #EFEFEF

Alternating Colored Bars II #CCCCCC

Button Bar #666666

Link Color #0000FF

Active Link Color #0000FF

Visited Link Color #0000FF

Link Hover Color #9999FF

Table 7-3. Configure Image

Configure Image

Configurable Section Default

Header Image 2_0_images/
logo.gif
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Table 7-4. Configure Text

Configure Text

Configurable Section Default

Default Text Family arial

Default Text Weight bold

Default Text Size x-small

Main Page Text Family arial

Main Page Text Weight bold

Main Page Text Size x-small

Warnings and Informational
Text Family

arial

Warnings and Informational
Text Weight

bold

Copyright Text Family arial

Copyright Text Weight normal

Copyright Text Size xx-small

Top Navigational Links Text
Family

arial

Top Navigational Links Text
Weight

bold

Top Navigational Links Text
Size

x-small

Title Bar Text Family arial

Title Bar Text Weight bold

Title Bar Text Size x-small

Sub Title Bar Text Family arial

Sub Title Bar Text Weight bold
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Table 7-4. Configure Text (continued)
Configure Text

Configurable Section Default

Sub Title Bar Text Size small
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8. Installing the Xpress Print Driver

The Xpress Print Driver (XPD) allows the uploading and conversion of
documents from within a Windows application. There are three separate
setups:

• Windows 2000 client machines
• Windows NT Workstation client machines
• Windows 95 / 98 / ME client machines (this client needs the XPD file

configured on the server before allowing users to download it).

The System Administrator should set this driver up on client workstations
for users to send jobs to Documents Xpress directly from Windows
applications.

Note: WinZip or equivalent is needed for installing the XPD.  A copy of
WinZip may be downloaded from www.winzip.com.
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Windows 2000 Workstation XPD Setup

Windows NT / Windows 2000 Server Setup

No setup on the server is required.

Windows 2000 Professional Client Setup

This procedure assumes that WinZip, or equivalent, is installed on the
client workstation.

Installing the XPD print driver

Perform the following to install the XPD print driver on a Window
2000 Professional client machine:

1. Create a folder named XPD on the C: drive of the workstation.

2. From the Documents Xpress home page, click Download Driver and
download the Windows 2000 XPD driver to the newly created XPD
folder.

3. Unzip Xpdy2k.zip to C:\XPD on the client workstation.

4. Click Start > Settings > Printers.

5. Double-click Add Printer.

6. The Add Printer Wizard appears. Click Next.

7. The Local or Network Printer window appears. Click Local Printer.
Clear Automatically detect and install my Plug and Play Printer.
Click Next.

8. For the port select File. Click Next.
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9. The list of manufacturers of printers appears. Click Have Disk.

10. The Install from Disk dialog box appears. Click Browse and browse
to C:\XPD.

11. When in the XPD folder, the file name webxpd.inf will appear in the
File name text box. Click Open.

12. The Install From Disk dialog box reappears. Click OK.

13. Select DocumentsXpress PS Color Plugin. Click Next.

Note: Only the color driver needs to be selected since it will handle both
color and black and white jobs.

14. Keep the default printer name. Click Next.

15. Click Do not share this printer. Click Next.

16. To ensure that a test page is not printed click No. Click Next

17. The Completing the Add Printer Wizard window appears. Click
Finish.

18. A warning that the Digital Signature not found appears. Click Yes.

19. Close all open windows. The XPD print driver has been installed.

Setting the Printer Properties

Perform the following to set the printer properties:

1. Right-click the installed printer name in the Printer folder
(Start > Settings > Printers). Click Properties.

2. Select the Configuration tab from the Properties Dialog box.
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3. Select Server is Available.
In the appropriate fields, type the following:

Server Name = <Documents Xpress server IP address>

Port =

80

URL Post Path =

/xdx/servlet/simple?request.action=upd.action.upload

URL Get Path =

/xdx/upd.jsp?request.action=upd.action.dt&DT=%s&AG
=%s&PD=%s&PK=%s&NP=%d&NC=%d

Write to Spool = do not select

4. Click OK.

5. Configure the default browser by selecting Internet Explorer or
Netscape before using the driver, especially if using a proxy server on
the network.

Note: Test the installation by opening up a Windows application. Print to
Documents Xpress with the XPD driver by using
File > Print and then selecting the DocumentsXpress PS Color
Plugin driver.
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Windows NT Workstation XPD Setup

Windows NT Server Setup

No setup on the server is required.

Windows NT Workstation Client Setup

Installing the XPD

Perform the following to install the XPD print driver on a Windows
NT Workstation client machine:

1. Create a folder named XPD on the C: drive of the workstation.

2. From the Documents Xpress home page, click Download Driver and
download the Windows NT XPD driver to the newly created XPD
folder.

3. Unzip xpd-1.1.3.zip to C:\XPD on the client workstation.

4. Click Start > Settings > Printers. Double-click Add Printer.

5. Click My Computer to install a local printer. Click Next.

6. Choose an unused local printer port (LPT1 for example). Click Next.

7. Click Have Disk and browse to C:\XPD.

8. Click webxpd.inf. Click Open.

9. Click OK.

10. Select DocumentsXpress PS Color Plugin. Click Next.
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Note: Only the color driver needs to be selected since it will handle both
color and black and white jobs.

11. To complete the installation click Next.

12. Keep the default printer name. Click Next.

13. Click Not Shared. Click Next.

14. Click No to skip printing a test page. Click Finish.

Setting the Printer Properties

Perform the following to set the printer properties:

1. Right-click the installed printer name in the Printer folder
(Start > Settings > Printers). Click Properties.

2. Select the Configuration tab from the Properties Dialog box.

3. Select Server is Available.
In the appropriate fields, type the following:

Server Name = <Documents Xpress server IP address>

Port =

80

URL Post Path =

/xdx/servlet/simple?request.action=upd.action.upload

URL Get Path =

/xdx/upd.jsp?request.action=upd.action.dt&DT=%s&AG=%
s&PD=%s&PK=%s&NP=%d&NC=%d

Write to Spool = do not select
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4. Click OK.

5. Configure the default browser by selecting Internet Explorer or
Netscape before using the driver, especially if using a proxy server on
the network.

Note: Test the installation by opening up a Windows application. Print to
Documents Xpress with the XPD printer driver by using File > Print
and then selecting the DocumentsXpress PS Color Plugin printer
driver.
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Windows 95 / 98 / ME XPD Setup

The Windows 95 / 98 / ME XPD installation files must be configured on
the server before they can be downloaded by each individual workstation.
This is a one-time change on the server.

Windows NT Server Setup

Modifying Windows NT Server File For Windows 95 / 98 / ME
Installation

This procedure assumes that WinZip, or equivalent, is installed on the
server.

Perform the following to modify the Windows NT Server file for
Windows 95 / 98 XPD installation:

1. On the Documents Xpress server, locate and double-click
C:\xdx\webroot\xpd\UPD.zip. The zip file will open in a window and
list all files contained in the zip file.

2. Double-click Docsxprs.inf. A text editor opens the inf file.
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3. Scroll down to the end of the file to the [AddReg.Url] header. Replace
both instances of MACHINE2 with the IP address for the Documents
Xpress server. See the example below:

[AddReg.Url]

HKLM,"Software\Xerox\Documents Xpress\Post
URL",,0,"http://MACHINE2:80/xdx/servlet/simple?request.action=upd.a
ction.upload"

HKLM,"Software\Xerox\Documents Xpress\Get
URL",,0,http://MACHINE2:80/xdx/upd.jsp?request.action=upd.action.dt
&DT=%s&AG=%s&PD=%s&PK=%s&NP=%d&NC=%d”

Note: If the [AddReg.Url] section does not resemble the text above,
replace the existing [AddReg.Url] section with the one above.

4. Click File > Save to save the modified file in the Zip archive. Close
the text editor.

5. A confirmation window appears asking to Update archive with this
file. Click Yes. Close Winzip. The UPD.zip file is now ready to be
downloaded by Windows 95 / 98 / ME users.

Windows 95 / 98 / ME Client Setup

Once the installation files have been saved on the Windows NT Server,
install the client software for Windows 95 / 98 / ME.

Installing the XPD

Perform the following to install the XPD on a Windows 95 / 98 client
machine:

1. Create a folder named XPD on the C: drive of the workstation.

2. From the Documents Xpress home page, click Download Driver and
download the Windows 95/98/ME XPD driver to the newly created
XPD folder.



 INSTALLING THE XPD DOCUMENTS XPRESS — XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0

8-10 SYSTEM ADMINISTRATION GUIDE

3.  Unzip UPD.zip to C:\XPD on the client PC.

4. Click Start > Settings > Printers. Double-click Add Printer. Click
Next.

5. Choose Local Printer. Click Next.

6. Click Have Disk and browse to C:\XPD.

7. Highlight Docsxprs.inf. Click OK.

8. Click OK.

9. Select the DocumentsXpress Color Plugin for color printing or black
and white printing and click Next.

10. Select LPT1 for the printer port. Click Next.

11. Leave the default printer name. Ensure that No for the default printer
choice is selected. Click Next.

12. Select No to skip printing a test page. Click Finish.

At this point, the XPD installation is now complete.

13. Test the installation by opening up a Windows application. Print to
Documents Xpress with the XPD driver by using File > Print and then
selecting the DocumentsXpress Color Plugin driver.
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9. System Backup

The System Administrator is responsible for ensuring regular completion
of backups for Documents Xpress. Schedule backups to occur at
non-peak hours. Depending upon the backup method chosen, system
performance may be degraded or clients may be prevented from using
Documents Xpress.

The instructions in this chapter are generic backup instructions. Specific
instructions depend on the type of backup software and hardware used.

Backing up Documents Xpress

Perform the following to back up Documents Xpress:

1. On the Documents Xpress server, shut down all the Documents
Xpress services and close the XDX Control Center.

CAUTION: Any files flagged as in use will not be backed up, therefore all
software programs on the Documents Xpress server should
be closed.

2. Follow the instructions provided by the backup software and perform a
backup of the complete server. At a minimum the C:\xdx folder needs
to be backed up.

3. Once the backup is complete, restart Documents Xpress by restarting
the XDX Control Center and services on the server.
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Restoring Documents Xpress from a Backup

Perform the following to restore Documents Xpress:

1. Following the instructions included with the backup software, restore
all hard drives from the backup.

2. Reboot all the servers.

3. Restart the XDX Control Center and services on each server.

4. Test the system to confirm a user can perform tasks such as logging
on, printing, and converting.
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10. Configuring System Parameters

This chapter outlines how to use the Configuration Manager to make
changes to the default system parameter values in Documents Xpress.

All configurable values are modified through the XDX Control Center.
Configuration tools are outlined in Figure 10-1.

Figure 10-1. Configuration Tools in Documents Xpress
XDX Control Center Tools

UGD Admin
(see Chapter 6)

User Group Directory Administration – Users are
imported, added, modified, and inactivated here. Group
memberships can be established and users can be
moved into groups. This tool can also import user
database information from customer supplied files.

UI Config
(see Chapter 7)

User Interface Configuration – The User interface can
be customized using the UI Config tool.

Configuration
Manager
(this chapter)

The Configuration Manager allows changes to system
parameters, to the Documents Xpress system.

Job Control Panel
(see Chapter 11)

The Job Control Panel allows an administrator to define
customer-specific print shop and accounting options,
such as finishing and billing.

Template Control
Panel
(see Chapter 12)

Creation and editing of printable sheets such as print
job delivery sheets and coversheets, used as job
tickets.
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Parameter Locations

Use Figure 10-2 to help reconfigure commonly modified system
parameters. These directions assume that at the XDX Control Center, the
Configuration Manager has been started, and that the xdxConf folder has
been opened.

Figure 10-2. Common configuration parameter changes

To change: Go to:

Server IP address properties > System Properties > Server IP

Mail server IP address properties > Email > Email Server (two instances)

Administrator e-mail address properties > Email > Admin Email Address (two
instances)

Footer in e-mail messages properties > Email > Email Footer

Enabling / Disabling of email
messages to users

properties > Email > Email Enabled

Print shop name properties > Email > Printshop Name

Database access user name properties > Database > Database Username

Database access user password properties > Database > Database Password

User data file properties > Users > User Import File

Number of days the system keeps
documents before deletion

properties > Documents > Document Lifetime (two
instances)

Number of days the system holds user
documents before deletion

properties > Web Server > Document Lifetime

Error message Exceptions

Job statuses System Job States

DocuShare address <optional> properties > DocuShare

Licensing warnings properties > Licensing
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Configuration Manager Tool

The Configuration Manager Tool is used to modify system parameters in
Documents Xpress.

Perform the following to start the Configuration Manager Tool:

1. From the XDX Control Center click Tools > Configuration Manager.

2. The configuration_control_panel window appears. Using the
mouse, adjust the vertical bar so that the left side pane can be
completely seen.

3. Click the + beside xdxConf to open the configuration folder.

4. The configuration tool divides itself into four major categories:
• properties – Allows configuration of Documents Xpress
• Exceptions – Allows customization of Documents Xpress

error messages
• System Job States – Allows customization of job state

messages
• Launcher – Handles settings for processes started by the

Control Center

Each section varies in how it is configured and will be dealt with
separately in the following sections.
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5. After any configuration changes are made, ensure the changes are
saved. Stop and restart the system for the changes to take effect.

Modifying the Configuration Categories

Each major category in the Configuration Control Panel differs from the
next in how settings are changed. Refer to these following sections, along
with Appendix A – Default Configuration Manager Values to change
configuration values. These instructions will illustrate how to change
values in each section, and how to save those changes.

Properties

The properties section in the Configuration Control Panel is the section
where most of the settings for Documents Xpress are found. Figure 10-3
shows the sub-folders that contain the settings for this section.
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Figure 10-3. Subfolders in the properties configuration folder

Configuring a Properties Parameter

This example will show how to modify and then save a properties
parameter. The example used is changing the IP address of the
Documents Xpress server. All other Properties parameters are changed
in the same manner.

Perform the following to configure a properties parameter:

1. Locate the parameter to be changed. In this example, the server IP
address. The server IP address can be found in the System
Properties folder. Click the + beside System Properties to open the
folder.

2. The System Properties folder opens. Click Server IP.
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Note: Be careful to only single-click a parameter name.
Double-clicking a name allows the name to be changed. If a
parameter name is changed, and then saved, the system will not
function properly.

3. The right side of the Configuration Control Panel refreshes and lists
the current settings for the Server IP address parameter

4. As shown in the illustration above, this Property Value can be
changed because the Editable check box is selected. If the Editable
check box does not have a check mark, the value cannot be changed.
Type a new value.

5. When the value has been changed, either select another value to
change from the properties list on the left, or click File > Save to
save any changes.

6. A Login window appears. Enter the Administrator Username and
Password and click OK.
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7. If there are no additional changes to be made, close the
configuration_control_panel by clicking X.

For the changes to take effect, the Documents Xpress system must be
shut down and restarted.

Exceptions

The Exceptions section in the Configuration Control Panel is the section
where the error messages for Documents Xpress can be modified. For a
listing of all the error messages, see Appendix A – Default Configuration
Manager Values.

Configuring an Exceptions Parameter

This example will show how to modify and then save an Exceptions
parameter. The example used is changing the message that appears
when there is an error when canceling a job. All other Exceptions
parameters are changed in the same manner.

Perform the following to configure an Exceptions parameter:

1. Locate the parameter to be changed. In this example, the
CancelJobException error message is being changed. Click the +
beside Exceptions to open the folder.

2. The Exceptions folder opens. Click the parameter name to be
changed. In this example, the CancelJobException parameter will be
changed.
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3. The right side of the Configuration Control Panel refreshes and lists
the current settings for CancelJobException parameter.

4. Type the new error message in the Error Message text box.

5. When the value has been changed, either select another value to
change from the list on the left, or click File > Save to save any
changes. If this is the first time a modification has been made to a
configuration property value in this session, a Login window appears.
Enter the Username and Password and click OK.

6. If there are no additional changes to be made, close the
configuration_control_panel by clicking X.
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System Job States

The System Job States section of the Configuration Control Panel allows
customization of the text that displays to show job notification states.

Configuring System Job States Parameters

This example will show how to modify and then save a System Job States
parameter. In this example, the createdState property will be changed.
All other System Job States parameters are changed in the same
manner.

Note: Any job states added will appear in the Status pull-down on the
Administrator side of Documents Xpress.

Perform the following to configure a System Jobs States parameter:

1. Locate the parameter to be changed. In this example, the
createdState display string is being changed. Click the + beside
System Job Strings to open the folder.

2. The System Job States folder opens. Click the parameter name to
be changed.
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3. The right side of the Configuration Control Panel refreshes and lists
the current settings for CancelJobException parameter.

4. Click the Display Strings drop-down so see if any other Display
Strings have been added.

5. If the desired string is present in the drop-down menu, select it. The
selected string appears in the Display Strings drop-down box. If the
desired string is not present type the new string in the Display Strings
box and click Add.

6. If a string has been created in error or is no longer needed, select it
from the drop-down box. Click Del to removed the string from the list.
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7. When the value has been changed, either select another value to
change from the list on the left, or click File > Save to save any
changes. If this is the first time a modification has been made to a
configuration property value in this session, a Login window appears.
Enter the Username and Password and click OK.

8. If there are no additional changes to be made, close the
configuration_control_panel by clicking X.

Launcher

The Launcher section of the Configuration Control Panel contains no user
modifiable choices.





 SYSTEM ADMINISTRATION GUIDE 11-1

11. Modifying Job and Document
Options

This chapter outlines how to use the Job Control Panel to make changes
to the default system parameter values in Documents Xpress. Use
Appendix B – Default Job and Document Values to assist with modifying
a Documents Xpress installation.

Job Control Panel Tool

The Job Control Panel tool allows an administrator to define
customer-specific print shop and accounting options such as finishing and
billing.

Perform the following to start the Job Control Panel Tool:

1. From the XDX Control Center click Tools > Job Control Panel.

2. The job_control_panel window appears. Maximize the window.

3. Click the + beside Printshop Print Job.

4. The Job Control Panel tool divides itself into two major categories with
minor sub-categories:
• Job Options – Options that pertain to a job, rather than a

document.
• optionNames – Variable names for job options. optionNames

can be added or removed.
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• hold – Jobs that require operator intervention can be
specified here.

• HTML – HTML code that specifies interface menu options.

• Document Options – Options that pertain to a document,
rather than a job.
• optionNames – Variable names for document options.

These optionNames can be added to or removed.
• hold – Jobs that require operator intervention can be

specified here.
• HTML code – HTML code that specifies interface menu

options

Line Printer Remote and Xerox Job Ticket sections
customize how Documents Xpress sends jobs to printers,
and how to translate a Documents Xpress job into a XJT

• LPR configuration – Line Printer Remote translation
values.

• XJT configuration – Xerox Job Ticket translation values

Each section varies in how it is configured and will be dealt with
separately in the following sections.

5. After any configuration changes are made, ensure the changes are
saved. Stop and restart the system for the changes to take effect.

Modifying the Job Control Categories

The two major categories in the Job Control Panel are similar to each
other in how they are modified. Where methods to change Job Options
and Document Options are the same, only Job Options will be referred to.
Use the same method to change Document Options.
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These instructions will illustrate how to change values in each
section, and how to save those changes.

Job Options: optionNames

The optionNames subsection in the Job Options section of the
Job Control Panel is where the variable names fields for
non-document data reside. Figure 11-1 shows the folder structure
that contains the settings for this section.

Figure 11-1. optionNames section in Job Options
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optionNames Properties

All optionNames in Documents Xpress 2.0 have the same structure. An
example optionName, payment_method is shown below in Figure 11-2.

Figure 11-2. Example optionNames

Operator Editable – The Print Operator or Print Administrator can edit
this field if this box is selected.

Null Allowed – A blank field is allowed if this box is selected. As installed,
all fields can be blank for a job. Decide what types of optionNames are
required, such as first and last names and clear the check in Null
Allowed.

Data Type – The Data Type drop-down menu defines what kind of data is
expected in the field. Choices are string, integer, number, character, date,
or time.

CAUTION: Typically, existing optionName variables are not changed
since the Documents Xpress data structure is based on these
fields. If required, additional optionName fields can be added.
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Adding an optionName

This example will add an optionName to Job Options. The following
procedure works for both the Job Option and the Document Option
sections.

This procedure assumes the Job Control Panel is already open.

Perform the following to add an optionName:

1. Click the folder beside optionNames. optionNames becomes
highlighted.

2. Right-click optionNames. A pop-up menu appears. Select
add > Item.

3. At the bottom of the current list of optionNames, New Option
appears. Double-click New Option and move the cursor to the end of
the line.
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4. Delete the words New Option and type the new optionName. Press
Enter on the keyboard to accept the new name.

Note: optionNames must be lower case and contain no spaces. Replace
any needed spaces with underscores.

5. While the new optionName is highlighted, decide if the field just added
is operator editable, if a null value will be accepted, and what type of
data will be entered into this field.

6. When finished adding new optionNames, click File > Save. Changes
take effect when Documents Xpress is next restarted.

Removing an optionName

Perform the following to remove an optionName:

1. Click the optionName to be removed. The optionName becomes
highlighted.



 DOCUMENTS XPRESS — XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0 MODIFYING OPTIONS

SYSTEM ADMINISTRATION GUIDE 11-7

2. Right-click the highlighted optionName. A pop-up menu appears.
Select remove.

3. The highlighted optionName disappears. When finished removing
optionNames, click File > Save. Changes take effect when
Documents Xpress is next restarted.

Adding a Hold Value

Jobs passing through the Documents Xpress 2.0 system can be set to be
held for operator intervention as opposed to passing directly through to a
printer.

Installed with the system is a single hold value – last_name. The system
will hold for operator intervention any job that has a last name. Since all
valid jobs will have a last name, all jobs must be examined by an operator
in this scenario.

Other types of options that might be added to the Hold values are fields
like payment_method. If there were no indication of how a job is to be
funded, it would be held for operator examination before being passed on
for printing.

This procedure assumes the Job Control Panel is already open.

Perform the following to add a Hold value:

1. Click hold to highlight it.
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2. Right-click hold. A pop-up menu appears. Select add > Selection.

3. At the bottom of the current list of held values, New Selection
appears. Double-click New Selection and move the cursor to the end
of the line.

4. Delete the words New Selection and type the new hold name. Press
Enter on the keyboard to accept the new name.

Note: Hold names must be lower case and contain no spaces. Replace
any needed spaces with underscores.

5. While the new hold is highlighted, decide if a null value will be used or
if a value will be entered, and if a job will be held if it is Not Equal to
the value entered.

7. When finished adding new hold values, click File > Save. Changes
take effect when Documents Xpress is next restarted.
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Removing a Hold value

This procedure assumes the Job Control Panel is already open.

Perform the following to remove a hold value:

1. Click the hold value to be removed. The hold value becomes
highlighted.

2. Right-click the highlighted hold value. A pop-up menu appears. Select
remove.

3. The highlighted hold disappears. When finished removing
optionNames, click File > Save. Changes take effect when
Documents Xpress is next restarted.

HTML Properties

The HTML section of Job Options contains the code that is needed to
display the required screens and drop-down menus on the user and print
shop operator / administrator user interfaces.
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Attention must be paid to how code is added or changed. Watch for the
following when making any changes:

Tags

Ensure that all tags are closed.

If writing HTML the following break tag must not be used:

<br> (this break tag is open and is an illegal tag)

Instead, use this type of tag:

<br/> (this break tag is properly closed – notice the ending slash)

 Format

HTML must be properly nested for the file to work.

The following example has opening and closing bold tags outside the font
tags:

<b><font face=arial>howdy!</font></b> (properly nested
tags)

The following example will not work because the closing tags are not
nested properly:

<b><font face=arial>howdy!</b></font>

(improperly nested
tags – the closing
tags are in the
wrong order)
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Case Sensitivity

Use lower case in all tags. This helps reduce the amount of debug time
needed when looking for errors.

Cut and Paste Method

Whenever possible, cut and paste sections that are correct and modify
the pasted section. This will ensure that the correct tag structure is being
used.

HTML Tags for Variables

The HTML tag <select name=…> refers to an optionName variable.

The HTML tag <option value=…> specifies all the values that appear in
the drop-down menu for an optionName.

Adding a Drop-down Menu Choice

This procedure assumes the Job Control Panel is already open.

In the following example, an additional payment method will be added to
HTML:xbsJobScreen in the Job Options section. The instructions are
the same for modifying HTML in the Document Options section.

CAUTION: Before making any modifications to the HTML, copy the code
to Notepad. Open the section to be modified, press Ctrl A,
Ctrl C, open Notepad and press Ctrl V. The code will be
pasted into the new Notepad file. Save the file. If an error is
made, copy the code from the Notepad file back into the
incorrect HTML window.
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Perform the following to add an drop-down menu choice:

1. Click + beside the Printshop Print Job folder.

2. Click the options folder where a change is required. Click + beside the
Job Options folder.

3. Click HTML:xbsJobScreen.

4. The right pane refreshes with the code for the xbsJobScreen. The
pane opens at the bottom of the code so scroll to the top.

5. Locate the Payment Method section and the tag <select
name=”payment_method”>.

6. Highlight the last line <option value=”Other”>Other</option> and
press Ctrl+C to copy the line.

7. Move the cursor to the end of the line just copied and press Ctrl+V to
paste the code.

8. Press the Enter key to move the pasted code to a new line and use
the Tab key to line up the code with the existing  option value tags.

9. Modify the option value tag the new value desired. In this case the
copied tag was modified to
<option value=”Web Payment”>Web Payment</option>.
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10. When finished editing the HTML code, click File > Save. For the
changes take effect, stop and restart the Documents Xpress system
from the XDX Control Center. Confirm to see that the changes were
made properly.
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Document Options: optionNames

The optionNames subsection in the Document Options section of
the Job Control Panel is where the variable names fields for
document specific data reside. Figure 11-3 shows the folder
structure that contains the settings for this section.

Figure 11-3. optionNames section in Document Options
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The instructions for modifying Document Options sections in the Job
Control Panel are the same as for the Job Options sections. Consult the
Job Options sections for specific procedures.

LPR Settings

The Line Printer Remote section customizes how Documents Xpress
sends jobs to printers and how to translate a Documents Xpress job into a
XJT. Figure 11-4 illustrates the settings.

Figure 11-4. LPR settings in Document Options

Modifying an LPR setting

This procedure assumes the Job Control Panel is already open. This
example will modify the Translate:Duplex section.

Perform the following to modify an LPR setting:

1. Click + beside the LPR: page_sides folder.

2. Click Translate: Duplex.

3. The right pane refreshes. The Translated Value text box appears
with the current translation value.

4. Modify the value and press Enter.
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5. When finished editing, click File > Save. Changes take effect when
Documents Xpress is next restarted.

Adding an LPR setting

This procedure assumes the Job Control Panel is already open. This
example will add a setting to the LPR:page_sides section.

Perform the following to add an LPR setting:

1. Right-click LPR: page_sides folder. A pop-up menu appears. Select
add > Value Translation.

2. At the bottom of the current list of values, Translate: null appears.
Double-click New Selection and move the cursor to the end of the
line.

3. Delete the word null and type the new translation name. Press Enter
on the keyboard to accept the new name.

4. While the new value is highlighted, type the new Translated Value in
the text box in the right pane.

5. When finished adding translations, click File > Save. Changes take
effect when Documents Xpress is next restarted.

Removing an LPR setting

This procedure assumes the Job Control Panel is already open. This
example will remove a setting from the LPR:page_sides section.
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Perform the following to remove an LPR setting:

1. Click the Translate value to be removed. The Translate value
becomes highlighted.

2. Right-click the highlighted translate value. A pop-up menu appears.
Select remove.

3. The highlighted Translate value disappears. When finished removing
Translate values, click File > Save. Changes take effect when
Documents Xpress is next restarted.

XJT Settings

The Xerox Job Ticket section customizes how Documents Xpress
translates a Documents Xpress job into an XJT. Figure 11-5 illustrates the
settings.

Figure 11-5. XJT settings in Document Options
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To modify, add or remove XJT values, follow the procedures outlined on
the preceding page for LPR settings.
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12. Modifying Templates

The Template Manager allows the System Administrator to modify
existing cover sheet and delivery sheet templates. New versions of the
cover sheet and delivery sheet templates can be created, either by using
the Template Manager or an external HTML editor.

Back up copies of the template files need to be made before modifying
them. The templates are located at c:\xdx\properties. They are named
coversheet.tpl and deliverysheet.tpl.

Template Manager Tool

The Template Manager tool is used to view and modify the cover sheet
and delivery sheet templates.

Modifying a Template

Perform the following to modify a template:

1. From the XDX Control Center click Tools > Template Manager.

2. The template_control_panel window appears. Click
File > Open.

3. The Open window appears. Navigate to c:\xdx\properties. The
coversheet.tpl and deliverysheet.tpl files are listed. Select one of
the template files and click Open.
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4. The template_control_panel window opens with the HTML code for
the selected template file.

The code may be viewed or modified in this window.

Note: It is recommended that only simple edits be done in the
template_control_panel window. Use a full featured text editor or
HTML editor if extensive code changes need to be made.

4. When all editing is complete, click File > Save. The modified template
is saved. Click X to close the template editor window.

About Templates

The two templates in Documents Xpress, coversheet.tpl and
deliverysheet.tpl, are simple HTML documents. Each template contains
the information required by a customer to be printed as either a job ticket
or a delivery sheet.
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Use the supplied templates as guides and make any required changes.

Note: Any changes made to these files will take effect after stopping and
restarting the Documents Xpress system.

Value Names

Value names are derived from the optionNames in the Job Control
Panel. In the file coversheet.tpl, which is the layout for the job ticket, the
value name job_required_date appears.

An example of the code is shown in Figure 12-1.

Figure 12-1. Example of coversheet.tpl code
<tr>

<td width="25%">Required Date:</td>
<td width="25%">&amp;nbsp;<value name="job_required_date"/></td>
<td width="25%">Time:</td>
<td width="25%">&amp;nbsp;<value name="job_required_time"/></td>

</tr>

The tag value name= is used to access the values as shown in
Figure 12-2.

Figure 12-2. Example use of value name tag

<value name="job_required_date"/>

Note: Remember to close all tags.

Looping the HTML code in coversheet.tpl and deliverysheet.tpl

Simple looping is accomplished with the following tag as shown in Figure
12-3.
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Figure 12-3. The ‘foreach context’ tag begins looping in a template

<foreach context="documents">

For each document being printed, print all the values between the
<foreach> and </foreach> tags. For example, Figure 12-4 displays a
fragment of the coversheet.tpl code that illustrates a loop.

Figure 12-4. Use of <foreach context> and closing </foreach> tags

<foreach context="documents">
  <table width="100%" cellpadding="2" cellspacing="0" border="1">

<tr>
     <td width="100%" colspan="4"><value name="doc_title" /></td>
</tr>
<tr>
     <td width="25%">Description:</td>
     <td colspan="3"><value name="document_description"  /></td>
</tr>
<tr>
      <td width="25%">Number of Copies:</td>
      <td width="25%">&amp;nbsp;<value name="copies" value="1"

/></td>
      <td width="25%">Color Image: </td>
      <td width="25%">&amp;nbsp;<value name="color_image"  /></td>
</tr>

       <tr>
      <td colspan="2">If Special Order please specify:</td>

         <td colspan="2">&amp;nbsp;<value name="special_order_tabs" />
</td>
</tr>

  </table>
</foreach>

Ensure that copies of any modified templates are saved and kept
separate from the server.
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13. Installing the Documents Xpress Link
to DocuShare (Optional)

DocuShare 2.2 (or 2.2 SP1) users can gain direct access to Documents
Xpress by installing additional Documents Xpress software components
to the DocuShare server. Obtain administrative access to the DocuShare
server in order to complete the following installation. These steps assume
that installation is taking place at the DocuShare server.

Copying Documents Xpress Files to DocuShare

The Documents Xpress CD contains two files that must be installed on
DocuShare server. One of the files, dslib.vdf, requires a modification to
point to the current Documents Xpress installation.

CAUTION: The dslib.vdf file is quite often already modified on an
operational DocuShare server. If the Documents Xpress
version of the dslib.vdf file is being installed on a new
DocuShare server, proceed with the steps detailed in the
following section.

CAUTION: If modifications have already been made to an existing
dslib.vdf file, replacing it with the Documents Xpress
customized file will lose all other customizations. If the
Documents Xpress link to DocuShare is being installed on a
DocuShare server with a previously customized dslib.vdf,
proceed to the section Modifying an existing dslib.vdf file.
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Copying the customized Documents Xpress files to DocuShare

Note: Make a back up copy of the dslib.vdf file that is on the DocuShare
server before performing this procedure.

Perform the following to copy the custom Documents Xpress files to
DocuShare:

1. At the DocuShare server, insert the Documents Xpress CD into the
CD drive.

2. Go to My Computer\<CD ROM Drive>
\install\dist\docs\docushare_integration.

3. Copy the file dslib.vdf to
C:\Program Files\Xerox Corporation\DocuShare\templates\en-us.

4. Copy the file printer.gif to
C:\Program Files\Xerox Corporation\DocuShare\root
\images\small.

5. Go to
C:\Program Files\Xerox Corporation\DocuShare\templates\en-us.

6. Open dslib.vdf with a text editor. Search for xdx. The line that
appears should be as follows (fragment of the line shown in
Figure 13-1):

Figure 13-1. Fragment of dslib.vdf showing the line to be edited

<TD VALIGN="TOP"><FONT SIZE="-1"><A HREF="http://13.231.196.18/xdx/docushare_display.jsp?

7. Change the IP address 13.231.196.18 to the current Documents
Xpress IP address.

8. On the same line as the one modified above is an ALT tag for the
printer icon on the DocuShare screen. This may be modified to reflect
any customization required such as – Print with Documents Xpress.



 DOCUMENTS XPRESS — XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0 DOCUSHARE LINK INSTALLATION

SYSTEM ADMINISTRATION GUIDE 13-3

The example below, Figure 13-2, shows the line with the text as was
originally installed.

Figure 13-2. ALT tag with original installed text

<IMG BORDER="0" ALT="Print with WebXPress"

9. Save the file dslib.vdf, overwriting the old file.

10. Close all open windows. Remove the Documents Xpress CD.

11. Proceed to the Changing the DocuShare Schema section.

Modifying an existing dslib.vdf file

Perform the following to modify an existing DocuShare dslib.vdf:

1. At the DocuShare server, insert the Documents Xpress CD into the
CD drive.

2. Go to My Computer\<CD ROM Drive>
\install\dist\docs\docushare_integration.

3. Copy the file printer.gif to
C:\Program Files\Xerox Corporation\DocuShare\root
\images\small.

4. Go to
C:\Program Files\Xerox Corporation\DocuShare\templates\en-us.
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5. Open dslib.vdf with a text editor. Search for:

 /small/html.gif"/

The line where  this text appears is at the end of the first full line of
code in Figure 13-3:

Figure 13-3. Searched text and added Documents Xpress code

The underlined red text  is the code to be added to the existing
dslib.vdf file. This text can be found in the dslib.vdf file on the
Documents Xpress installation CD.

The first red text that has been crossed out   </if> is code from the
existing dslib.vdf file that must be removed.

6. Change the IP address shown in Figure 13-4 to the current
Documents Xpress web server IP address.
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Figure 13-4. Fragment of dslib.vdf showing the line to be edited

<TD VALIGN="TOP"><FONT SIZE="-1"><A HREF="http://13.213.196.18/xdx/docushare_display.jsp?

7. On the same line as the one modified above is an ALT tag for the
printer icon on the DocuShare screen. This may be modified to reflect
any customization required such as – Print with Documents Xpress.
The example below, Figure 13-5, shows the line with the text as was
originally installed.

Figure 13-5. ALT tag with original installed text

<IMG BORDER="0" ALT="Print with WebXPress"

8. Save the file dslib.vdf, overwriting the old file.

9. Close all open windows. Remove the Documents Xpress CD.

Changing the DocuShare Schema

User properties must be modified on DocuShare for the Documents
Xpress printer icon to appear.

Perform the following to make changes to the DocuShare schema:

1. Log in to DocuShare as an administrator.

2. Go to the Administration interface by clicking Administration or click
the screwdriver icon in the navigation bar.

3. Click Object Properties > User.

4. Click Add… Select Boolean.

5. In the Name text box type edocument.

6. In the Label text box type Documents Xpress User.
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7. Click Add.

8. A message appears to Rebuild Schema. Click the word here.

Perform the following to rebuild the DocuShare Schema:

1. Click Server Maintenance.

2. Under Server Maintenance, on the left side of the screen, click
Rebuild Search Schema.

3. An informational screen appears. Click Rebuild Schema.

4. The message The schema has been successfully rebuilt appears.
Run dsindex to rebuild search databases.

5. Click Start > Programs > Command Prompt. Click Command
Prompt. A Command Prompt window appears.

6. Type:

dsindex index_all

7. Press Enter on the keyboard.

8. An informational screen appears. Press Enter on the keyboard to
continue.

9. A confirmation appears on the screen indicating completion of the
re-indexing process. Click X to close the Command Prompt window.

Perform the following to change Default User Property:

1. Click Object Properties > User. The User Default Property Values
window appears.

2.  At the bottom of the window is a choice for Documents Xpress User.
Change the default for this property to No (the default will be Yes).
Click Apply.
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Note: Changing this default to No is important. If it remained as Yes, all
users would be assumed to be Documents Xpress users by
default.

Close all open windows.
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14. Troubleshooting

This section describes two methods for helping to diagnose problems that
may occur. For further assistance with troubleshooting problems, consult
Chapter 15 – Contacts and Escalation Process.

Debugging Apache and Tomcat

The Apache server logs (access.log and error.log) are located in
C:\xdx\etc\Apache\logs and the Tomcat servlet engine logs (jasper.log,
servlet.log, and tomcat.log) are located in C:\xdx\etc\Apache\tomcat\logs.
These logs provide valuable troubleshooting information if the software is
not operating properly.

In addition, at c:\xdx are two additional log files –  RMID.log and
Tomcat.log.

Note: Each time Apache is started, the previous error log is reopened
and new information is appended to the end of the file.
If there is an error in the system, the logs will contain debugging
information.



 TROUBLESHOOTING DOCUMENTS XPRESS — XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0

14-2 SYSTEM ADMINISTRATION GUIDE

Debugging Documents Xpress Services

Debugging output is saved to file and displayed by each Documents
Xpress service. If there is an error with the system, examine the XDX
Control Panel window of the appropriate service to determine where the
error has occurred. If there is a problem, a Java exception will be
displayed in the window. This message can be used to determine exactly
what errors have occurred in the system.

Re-initializing the User Database

CAUTION: Use the following instructions with caution since they cannot
be reversed. All existing Documents Xpress user data will be
lost and all jobs associated with the user. System
configuration changes and user interface changes are
unaffected.

If a user list is imported in error, the standard method of cleaning up the
list is to inactivate the undesired users.

If a user list is imported incorrectly BEFORE the system has been placed
into production, the entire user database, along with the repository and
any Documents Xpress information can be removed. NEVER use this
procedure on an operational system.

Note: Re-initialization can also be accomplished by reinstalling the
complete Documents Xpress system. All system configuration and
user interface changes will be lost.
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Ensure that 1 : Database Server in the XDX Control Center is running in
order to perform the next procedure.

Perform the following to re-initialize all the Documents Xpress
databases:

1. Go to C:/xdx/scripts and click, in order:

Init-02-EraseAllTables.bat
Init-01-ConfigMySQL.bat
Admin-LoadPricing.bat

Executing these batch files will restore all databases to the state
they were in when the system was first installed.

2. Field configuration and mappings will have to be redone.
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15. Contacts and Escalation Process

This chapter describes the support process and support contacts
available for Documents Xpress.

Documents Xpress Support Process

At the time of installation, a Customer Solution Administrator (CSA) will
be identified. The CSA is available to manage all software-related issues.
The CSA, who has the skills of a system administrator, handles the
day-to-day service and support operations at the customer site. The CSA
is the main interface to the Documents Xpress Support Center.

Note: If a problem relates to a Xerox output device and not the software
please contact the appropriate Xerox Support Center for that
product. If a problem relates to the computer server hardware,
contact the manufacturer of the server.

Here is the process for initiating support:

1. When the end user or operator encounters an error with the software,
they should contact the CSA.

2. The CSA performs system level isolation and problem resolution for
Documents Xpress.

3. If the CSA is not able to resolve the problem, the problem is escalated
to Documents Xpress Support Center for support.

Note: Only the CSA can call the hotline for support.
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Support Contacts

Documents Xpress has an e-Support website available at
http://www.xerox.com/webdocumentsubmission/support. The e-Support
website provides a searchable knowledge base, Frequently Asked
Questions (FAQ’s), and the ability to submit a support request via e-mail.

Contact the designated CSA for support. The CSA will contact the
Documents Xpress Support Center if they require additional assistance.
The Support Center can be reached at
1-888-508-5244, 8:00 a.m. to 5:00 p.m., Monday through Friday, local
time.
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16. Removing Documents Xpress 2.0

This chapter describes how to remove Documents Xpress 2.0.

CAUTION: This procedure will delete the entire Documents Xpress
system and all documents, jobs, and user files that are
currently in the system.

Removing Documents Xpress 2.0

Perform the following to remove Documents Xpress 2.0:

1. On the Documents Xpress server, click in the following order:
1: Database Server > 2: Web Application Server > 3: Services.

2. Close the Control Center by clicking X.

3. Restart the server to ensure all programs associated with Documents
Xpress have been terminated.

4. After the Documents Xpress server has restarted, double-click My
Computer. Double-click the C: drive.

5. Locate the xdx folder. Click once on the folder to highlight it. Press
the Delete key on the keyboard.

6. The Confirm Folder Delete window appears. Click Yes

7. If a Confirm File Delete window appears, click Yes to All.

The removal of Documents Xpress is complete.
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Removing Third-party Software

Installed with Documents Xpress were:

• Microsoft Office
• Adobe Acrobat Reader
• WinZip (or equivalent)

Use the Add / Remove Programs Control Panel application to remove
these programs.
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A. Default Configuration Manager
Values

This section details the default values of all the fields in the XDX Control
Center – Configuration Manager. To view or alter any of these default
values, start the XDX Control Center. Click Tools > Configuration
Manager.

When the desired modifications have been made, ensure that the
modifications have been saved from within the Configuration Manager.
For the changes to take effect, from the XDX Control Center main
window, click File > Reload XML. Confirm stopping all the processes and
reloading of the XML file by clicking Yes. Restart the services to
implement any changes.

The following tables follow the tree structure of the Configuration Control
Center.
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xdxConf: properties: System Properties

These properties contain the most basic information about the system,
such as the server’s IP address and the directory where
DocumentsXpress 2.0 is installed. Table A-1 contains the most basic
information about the system.

Table A-1. xdx:Conf: properties: System Properties

Property Name Default Value Description Editable?

Install Directory C:/xdx The directory path where
DocumentsXpress is installed

no

Server IP <Server IP address> The IP address of the server yes

Temp Dir ${WXPRESS_Home}/temp The directory used to store
temporary files

yes

XDX Version <software version number> The current release version
number

no
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xdxConf: properties: Application Homes

Information about where various applications are installed that
Documents Xpress depends on. Table A-2 contains information where
the various applications are installed.

Table A-2. xdx:Conf: properties: Application Homes

Property Name Default Value Description Editable?

MySQL Home ${WXPRESS_HOME}/etc/my
sql

Location where MySQL is
installed

no

Apache Home ${WXPRESS_HOME}/etc/Ap
ache

Location where Apache is
installed

yes

Tomcat Home ${WXPRESS_HOME}/etc/Ap
ache/tomcat

Location where Tomcat is
installed

no

Java Runtime
Home

${WXPRESS_HOME}/etc/jre Location where the Java
runtime environment is
installed

no

Java Executable ${JRE_HOME}/bin/java.exe Path to the Java executable
file

no
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xdxConf: properties: Users

Table A-3 contains information about managing the User Group Directory
database.

Table A-3. xdx:Conf: properties: Users

Property Name Default Value Description Editable?

User Import File ${WXPRESS_HOME}/scripts
/cousins.txt

Location of file that holds
information about users to be
imported into the Documents
Xpress system

yes

User Mappings
File

${WXPRESS_HOME}/proper
ties/UserMappings.xml

Location of file that hold
information about user import
field mappings

no
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xdxConf: properties: Database

Table A-4 contains Database Configuration properties.

Table A-4. xdx:Conf: properties: Database

Property Name Default Value Description Editable?

Database Server ${SERVER_IP} IP address of the database
server

no

Database
Username

dxroot Username used to log into
database

no

Database
Password

dxroot Password used to log into the
database

no

JDBC Protocol mysql Protocol used to connect to
the database

no

JDBC Driver org.gjt.mm.mysql.Driver Driver used to connect to
database

no

Max Database
Connections

20 Maximum number of allowed
open concurrent database
connections

yes

Max Database
Connection Usage

1000 Maximum number of allowed
times a database connection
can be used before closing the
connection

yes

Document Table DOCUMENTS Name of the table in the
database that stores document
information

no

Accounting
Database

DocumentsXpress Name of the database used to
store job information

no
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Table A-4. xdx:Conf: properties: Database (continued)

Property Name Default Value Description Editable?

Accounting Table ACCT Name of the table used to
store job info

no

Address Book
Database

UserGroupDirectory Name of the database used to
store personal address book
information

no

Authorization
Database

DocumentsXpress Name of the database used to
store user passwords

no

Authorization
Table

AUTH Name of the table used to
store user passwords

no

Printer Table PRINTERS Name of the table used to
store information about
printers

no

Printer Database DocumentsXpress Name of the database used to
store information about
printers

no

Pricing Database DocumentsXpress Name of the database used to
store pricing information

no

Pricing Table PRICING Name of the table used to
store information about pricing

no

User Database UserGroupDirectory Name of the database used to
store information about users

no

User Table GROUPS Name of table used to store
information about users

no

Document
Database

Repository Name of database used to
store information about
documents

no
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xdxConf: properties: Documents

Table A-5 contains properties having to do with document management.
These properties control what types of documents DocumentsXpress
accepts, what conversions are available, how long documents are stored,
warning day limits, and where the document directory resides.

Table A-5. xdx:Conf: properties: Documents

Property Name Default Value Description Editable?

Mime Types * List of document mimetypes
the server will allow users to
upload

yes

Conversions text/html|application
/pdf,text/html|applic
ation/postscript,text
/rtf|application/pdf,
text/rtf|application/
postscript,applicatio
n/excel|application/p
df,application/excel|
application/postscrip
t,text/plain|applicat
ion/pdf,text/plain|ap
plication/postscript,
application/msword|ap
plication/pdf,applica
tion/msword|applicati
on/postscript,applica
tion/powerpoint|appli
cation/pdf,applicatio
n/powerpoint|applicat
ion/postscript,applic
ation/postscript|appl
ication/pdf,applicati
on/pdf|application/po
stscript

List of conversions the system
is able to perform

no
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Table A-5. xdx:Conf: properties: Documents (continued)

Property Name Default Value Description Editable?

Document Lifetime 2 Number of days the system
keeps documents before
deleting

yes

Warning Days 2 The system sends a warning
message to users prior to
deleting their documents. This
property determines how this
message is sent (number of
days before the document is
deleted)

yes

Document
Directory

${WXPRESS_HOME}/reposit
ory

The directory where the
system stores uploaded
documents

no

xdxConf: properties: Web Server

Table A-6 contains properties that control the behavior of the web server.

Table A-6. xdx:Conf: properties: Web Server

Property Name Default Value Description Editable?

Admin URL http://${SERVER_IP}/xdx/ad
min

URL to the Admin login page no

Default Due Date 5 Default number of days
between a job request’s start
date and its due date

yes

User Page Size 40 Number of users to display per
page for the global address

yes

Error Page ${WXPRESS_HOME}/log/we
b_stderr.log

Web page to redirect users to
in the event of an error
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Table A-6. xdx:Conf: properties: Web Server (continued)

Property Name Default Value Description Editable?

User URL http://${SERVER_IP}/xdx URL to the User login page no

Servlet URL http://${SERVER_IP}/xdx/ser
vlet

URL to the servlet directory
where all the utility servlets are
located

no

Log File http://${WXPRESS_HOME}/l
og/web_stdout.log

File where system logs are
archived

no

Login Page login.jsp Default login page no

Routing false Flag to indicate whether
routing is enabled

no

Fetch Servlet fetch Name of servlet used to
download documents

no

Password
Required

true Flag indicated whether users
are required to have
passwords to get into the
system

no

Root Directory ${WXPRESS_HOME} DocumentsXpress install
directory

no

Display Variables false Flag to indicated whether
debug information should be
displayed in the user’s browser

yes

Session Timeout 30 The number of minutes a web
session lasts before timing out,
and thus requiring the user to
re-logon

yes
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xdxConf: properties: Logging

Table A-7 contains properties that control what information is logged by
Documents Xpress.

Table A-7. xdx:Conf: properties: Logging

Property Name Default Value Description Editable?

Printer Logging warn, appender1 Properties to control what
information is logged for
printing

no

Log Layout org.apache.log4j.PatternLayo
ut

<blank> no

Log File System.out Location where logs are
written

no

Appender org.apache.log4j.FileAppend
er

Appender no

Log Status info, appender1 This allows changing what log
messages are printed.
Possible values are: info –
only informational messages
are printed, error – error and
informational messages are
printed, debug – debug, error,
and informational messages
are printed

yes

Output Pattern %d{ABSOLUTE} %-5p :
%c{1} : %m%n

Format of log messages no
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xdxConf: properties: Configuration Files

Table A-8 contains additional configuration files that the system requires.

Table A-8. xdx:Conf: properties: Configuration Files

Property Name Default Value Description Editable?

Template Directory ${WXPRESS_HOME}/templa
tes

Directory where job templates
are stored

no

Job Descriptions ${WXPRESS_HOME}/proper
ties/job.xml

File that describes print jobs
for the print shop

no

UI Default Values ${WXPRESS_HOME}/proper
ties/uiconfig.properties

File where the default UI
configuration values are stored

no

Delivery Sheet
Template

${WXPRESS_HOME}/proper
ties/deliverysheet.tpl

File that describes format of
printed delivery sheets

no

Job Ticket
Template

${WXPRESS_HOME}/proper
ties/coversheet.tpl

File that describes format for
printed job ticket

no

XSL Cache ${WXPRESS_HOME}/proper
ties/xslt-cache.xml

XSL Cache file keeps list of xsl
files available for use by the
system

no



 DEFAULT JOB CONTROL VALUES DOCUMENTS XPRESS — XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0

A-12 SYSTEM ADMINISTRATION GUIDE

XdxConf: properties: Email

Table A-9 contains properties to control how the system sends e-mail.

Table A-9. xdx:Conf: properties: Email

Property Name Default Value Description Editable?

Email Subject DocumentsXpress courtesy
warning

The subject line of e-mail
messages sent to warn users
that their documents will be
deleted

yes

Admin Email
Address

user@domain.com The from e-mail address used
by the system when sending
e-mail to users

yes

Email Enabled true Flag to indicate the
enabling/disabling of e-mail
messages to users

yes

Email footer <blank> Text appended to the end of
every outgoing e-mail
message

yes

Printshop Name XBS Name of the print shop, used
in e-mails to users

yes

Email Server <IP address of email server> IP address of an e-mail server
that can forward e-mail

yes
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xdxConf: properties: DocuShare

Table A-10 contains information about DocuShare integration.

Table A-10. xdx:Conf: properties: DocuShare

Property Name Default Value Description Editable?

DocuShare Server <blank> URL for the Docushare server yes

DocuShare
Username

<blank> Username used to log into
DocuShare

yes

DocuShare
Password

<blank> Password used to log into
DocuShare

yes

DocuShare
Timeout

3000 Timeout (in milliseconds) for
retrieval of DocuShare
document from the DocuShare
system

yes

xdxConf: properties: Conversion

Table A-11 contains conversion properties.

Table A-11. xdx:Conf: properties: Conversion

Property Name Default Value Description Editable?

Conversion
Service Name

ConversionService Registered service name with
RMI registry

No
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Table A-11. xdx:Conf: properties: Conversion (continued)

Property Name Default Value Description Editable?

Conversion
Service Pool

${SERVER_IP} Comma delimited list of server
ip addresses, where the
conversion service is installed
The format of the ip address
token is: ip_address:port. If no
port is specified, then the
value of the
conversion.rmiregistry.port
property is used

yes

Conversion Port 1098 Port used to communicate to a
conversion service on another
machine

no

xdxConf: properties: Printing

Table A-12 contains configurable printing properties.

Table A-12. xdx:Conf: properties: Printing

Property Name Default Value Description Editable?

CPS Deliverer com.xerox.xdx.services.print.
deliver.cps.CpsDeliverer

CPS print deliverer no

CPS Deliverer
Config

${WXPRESS_HOME}/proper
ties/cps.deliverer.xml

Configuration file for CPS print
deliverer

no

Default Deliverer com.xerox.xdx.services.print.
deliver.StandardDeliverer

Default printer deliverer no

Default Deliverer
Config

${WXPRESS_HOME}/proper
ties/standard_deliverer.xml

Configuration file for the
default print deliverer

no
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Table A-12. xdx:Conf: properties: Printing (continued)

Property Name Default Value Description Editable?

Printing Dropbox ${WXPRESS_HOME}/temp Directory where print jobs are
archived for downloading from
the web server. Used primarily
for remote printshops that
want to print jobs

yes

Job Ticket Auto
Print

false If true, then job tickets will
automatically be printed for
every job when the user
submits it

yes

xdxConf: properties: Pricing

Table A-13 contains configurable pricing properties.

Table A-13. xdx:Conf: properties: Pricing

Property Name Default Value Description Editable?

Pricing Dropbox ${WXPRESS_HOME}/temp Location where pricing files
are stored

yes
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xdxConf: properties: Launcher

Table A-14 cointains properties used to start and stop Documents
Xpress.

Table A-14. xdx:Conf: properties: Launcher

Property Name Default Value Description Editable?

Classpath ${WXPRESS_HOME}\lib;${
WXPRESS_HOME}\lib\gnu.j
ar;${WXPRESS_HOME}\lib\j
avax.jar;${WXPRESS_HOM
E}\lib\mysql_2_uncomp.jar;${
WXPRESS_HOME}\lib\qe2re
po.jar;${WXPRESS_HOME}\l
ib\servlet2_2.jar;${WXPRES
S_HOME}\lib\Mako-
core.jar;${WXPRESS_HOME
}\lib\Mako-
webclient.jar;${WXPRESS_H
OME}\lib\Mako.jar;${WXPRE
SS_HOME}\lib\Mako-
launcher.jar;${WXPRESS_H
OME}\lib\xerces.jar;${WXPR
ESS_HOME}\lib\xalan.jar;${
WXPRESS_HOME}\lib\jdi.jar;
${WXPRESS_HOME}\lib\log
4j-
core.jar;${WXPRESS_HOME
}\lib\commons-cactus.jar

Java executables required by
core DocumentsXpress
system

no
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Table A-14. xdx:Conf: properties: Launcher (continued)

Property Name Default Value Description Editable?

Tomcat Classpath ${WXPRESS_HOME}/etc/jre/
lib/rt.jar;${WXPRESS_HOME
}\lib\tomcat-
jasper.jar;${WXPRESS_HO
ME}\lib\tomcat-
servlet.jar;${WXPRESS_HO
ME}\lib\tomcat-
webserver.jar;${WXPRESS_
HOME}\lib\tools.jar;${WXPR
ESS_HOME}\lib\Mako-
webclient.jar;${CLASSPATH}
;${WXPRESS_HOME}\lib\to
mcat-xml.jar

Java executables required by
Tomcat

no

Java Security ${WXPRESS_HOME}\proper
ties\policy.all

Policy file for Java security
configuration

no
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xdxConf: properties: Licensing

Table A-15 contains properties used to modify how Documents Xpress
warns about the license expiration.

Table A-15. xdx:Conf: properties: Licensing

Property Name Default Value Description Editable?

Expiration Warning
Period

1 Indicates the number of
months prior to license
expiration

no

Email Reminder true If set to true, an e-mail
reminder will be sent to the
registered administrator upon
entering the expiration warning
period. Valid values for this
property are {true,false}

no
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xdxConf: properties: Exceptions

Table A-16 contains configurable error messages for exceptions that may
occur in Documents Xpress. Any of these messages may be modified.

Note: All values are editable in the following table. The Property Name
and Default Values provide enough information that a description is
not necessary for this section.

Table A-16. xdx:Conf: properties: Exceptions

Property Name Default Value

CancelJobException Error while canceling job

XDXConversionFailedException Document conversin failed. Please verify the
format is valid

DataCorruptedException The database may be corrupted

DuplicatePrinterInfoException This printer already exists

EmptyResourceListException Empty resource list

FileUploadFailedException File upload failed

InactiveUserException This user has been marked as inactive

InvalidDocumentHandleException Invalid document handle

InvalidEmailException Invalid email address

InvalidJobException Invalid job selections

InvalidJobIdException Invalid job ID

InvalidLoginException Your logon information was incorrect

InvalidPageCountException Invalid page count

InvalidPrintShopException Invalid print shop

InvalidRecipientException Invalid recipient

InvalidRegistrationException Invalid registration information
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Table A-16. xdx:Conf: properties: Exceptions (continued)

Property Name Default Value

JobStatusUpdateFailedException The system failed to update the job status

MultipleLoginException Multiple login exception

NoAccountingServiceException The accounting service was not found

NoAddressBookInformationException The address book for this user was not found

NoAddressBookServiceException The address book service was not found

NoAuthenticatorServiceException The authenticator service was not found

NoConverterServiceException The converter service was not found

NoDistributorServiceException The distributor service was not found

NoDocumentSelectedException No document was selected

NoJobCreatedException The system could not create the job

NoPrinterInfoException No information for the printer was found

NoPrintManagerServiceException The print manager service was not found

NoRecipientsException No recipients have been chosen

NoRepositoryServiceException The repository service was not found

NoSuchAddressBookEntryException The address book entry could not be found

NoSuchPropertyException There is no such property

NoSuchUserException There is no such user in the system

NotLoggedInException You are not currently logged on

NoUGDServiceException The user group directory service was not found

PasswordConfirmException Your password entries didn’t match

PrinterAddFailedException The system failed to add the printer

RecipientInUseException Recipient not deleted. Cannot delete a recipient
assigned to an active job

RepositoryFailedException Error in the document repository

RequiredFieldNullException You left blank a required field
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Table A-16. xdx:Conf: properties: Exceptions (continued)

Property Name Default Value

TemplateNameInUseException A template already exists with that name

UnknownEntryException Unknown address book entry

UnknownSystemErrorException An unknown error occurred

UnsupportedFileTypeException That file type is not supported by this system

UpdatePropertiesFailedException The system failed to update the properties

UserAlreadyRegisteredException That user is already registered

UserDoesNotOwnException You are not the owner of this job

UserUnregisteredException You are not a registered user

xdxConf: properties: System Job States

Table A-17 contains information on the nine possible states a job can be
in while moving through the Documents Xpress system. These values
may mean different things in different print shops and will require
modification.

Table A-17. xdx:Conf: properties: System Job States

Property Name Default Value Description Editable?

createdState Created yes

heldState Received in Print Shop yes

failedState Failed yes

processingState Processing yes

unroutedState Unrouted yes

remoteSpooledState Remotely Spooled yes

cancelledState Cancelled yes
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Table A-17. xdx:Conf: properties: System Job States (continued)

Property Name Default Value Description Editable?

succeededState Succeeded yes

deletedState Deleted yes

xdxConf: properties: Launcher

Table A-18 contains the settings for services started by the Control Panel,
formerly known as the Launcher.

Table A-18. xdx:Conf: properties: Launcher

Property Name Default Value Description Editable?

Start Command: MySQL yes

${MYSQL_HOME}\bin\mysqld --basedir=${MYSQL_HOME}--
datadir=${MYSQL_HOME}/data

Stop Command: yes

${MYSQL_HOME}\bin\mysqladmin -u root --password=root shutdown

Transition Type: yes

<blank>

Transitional Parameter: yes

<blank>

Alert On Stop: yes

<selected>

Capture Output: yes

<selected>

Share One JVM: yes

MySQL

<not selected>
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Table A-18. xdx:Conf: properties: Launcher (continued)

Property Name Default Value Description Editable?

Start Command: Tomcat yes

${JAVA} -server -cp ${TOMCAT_CLASSPATH}
${STD_SECURITY_POLICY} -Xms32m -Xmx128m
-Djava.library.path=${WXPRESS_HOME}/lib
-Dgs.home=${WXPRESS_HOME}/etc/gs
-Dtomcat.home=${TOMCAT_HOME}
-Djdbc.drivers=org.gjt.mm.mysql.Driver org.apache.tomcat.startup.Tomcat

Stop Command: yes

${JAVA} -cp ${TOMCAT_CLASSPATH}
-Dtomcat.home=${TOMCAT_HOME}
org.apache.tomcat.startup.Tomcat -stop

Transition Type: yes

waitText

Transitional Parameter: yes

Ajp12ConnectionHandler

Alert On Stop: yes

<selected>

Capture Output: yes

<selected>

Share One JVM: yes

Tomcat

<not selected>
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Table A-18. xdx:Conf: properties: Launcher (continued)

Property Name Default Value Description Editable?

Start Command: Apache yes

${APACHE_HOME}\apache.exe -d "${APACHE_HOME}" -k start

Stop Command: yes

${APACHE_HOME}\apache.exe -d "${APACHE_HOME}" -k shutdown

Transition Type: yes

<blank>

Transitional Parameter: yes

<blank>

Alert On Stop: yes

<selected>

Capture Output: yes

<selected>

Share One JVM: yes

Apache

<not selected>
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Table A-18. xdx:Conf: properties: Launcher (continued)

Property Name Default Value Description Editable?

Start Command: ShareJVM yes

${JAVA} -cp "${WXPRESS_HOME}\lib\Mako-launcher.jar";${CLASSPATH}
${STD_SECURITY_POLICY}
com.xerox.dispatch.util.launcher.CommonJVMProcess

Stop Command: yes

<blank>

Transition Type: yes

<blank>

Transitional Parameter: yes

<blank>

Alert On Stop: yes

<selected>

Capture Output: yes

<selected>

Share One JVM: yes

ShareJVM

<selected>
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Table A-18. xdx:Conf: properties: Launcher (continued)

Property Name Default Value Description Editable?

Start Command: ClassServer yes

${JAVA} -jar ${WXPRESS_HOME}\lib\jini-tools.jar -port 8082 –dir
${TOMCAT_HOME}\webroot -verbose

Stop Command: yes

<blank>

Transition Type: yes

<blank>

Transitional Parameter: yes

<blank>

Alert On Stop: yes

<selected>

Capture Output: yes

<selected>

Share One JVM: yes

ClassServer

<not selected>
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xdxConf: properties: Launcher: Database Server

Table A-19 contains the switch for designating whether or not the
database server is a stoppable process.

Table A-19. xdx:Conf: properties: Database Server

Property Name Default Value Description Editable?

Database Server <selected> If selected, MySQL is a
stoppable process in the
Control Center.

yes

xdxConf: properties: Launcher: Web Application Server

Table A-20 contains the switch for designating whether or not the web
application server is a stoppable process.

Table A-20. xdx:Conf: properties: Web Application Server

Property Name Default Value Description Editable?

Web Application
Server

<selected> If selected, Tomcat and
Apache are stoppable
processes in the Control
Center.

yes
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xdxConf: properties: Launcher: Services

Table A-21 contains the switch for designating whether or not the RMID is
a stoppable process.

Table A-21. xdx:Conf: properties: Launcher Services

Property Name Default Value Description Editable?

Services <selected> If selected, RMID is a
stoppable process in the
Control Center.

yes
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B. Default Job Control Panel Values

This section details the default values of all the fields in the XDX Control
Center – Job Control Panel. To view or alter any of these default values,
start the XDX Control Center. Click Tools > Job Control Panel.

When the desired modifications have been made, ensure that the
modifications have been saved from within the Job Control Panel. For the
changes to take effect, from the XDX Control Center main window, click
File > Reload XML. Confirm stopping all the processes and reloading of
the XML file by clicking Yes. Restart the services to implement any
changes.

The following tables follow the tree structure of the Configuration Control
Center.
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Jobs: Printshop Print Job: Job Options: optionNames

These properties contain the defined variable names used in the
Documents Xpress system for jobs. Table B-1 shows optionNames.

Table B-1. Jobs: Printshop Print Job: Job Options: optionNames

Property Name Operator
Editable? Null Allowed Data Type

payment_method yes yes string

expiration_date yes yes date

account_number yes yes string

account_name yes yes string

first_name yes yes string

last_name yes yes string

phone yes yes string

ext yes yes string

job_description yes yes string

job_required_time yes yes time

job_required_date yes yes date

rush_job yes yes string

special_job_instructions yes yes string

proof_required yes yes string

date_proof_required yes yes date
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Table B-1. Jobs: Printshop Print Job: Job Options: optionNames
(continued)

Property Name Operator
Editable?

Null Allowed Data Type

time_proof_required yes yes time

contact_me yes yes string

shipping_type yes yes string

shipping_method yes yes string

delivery_method yes yes string

delivery_location yes yes string

printer_type yes yes string

Jobs: Printshop Print Job: Job Options: hold

These properties define what criteria the Documents Xpress system uses
to hold jobs. Table B-2 shows the properties that define the criteria the
system uses to hold jobs.

Table B-2. Jobs: Printshop Print Job: Job Options: hold

Property Name Operator
Editable? Null Allowed Data Type

last_name yes yes string
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Jobs: Printshop Print Job: Job Options: HTML

Table B-3 shows the properties that define the HTML Documents Xpress
uses to define user and administrator screens and drop-down menu
choices.

Table B-3. Jobs: Printshop Print Job: Job Options: HTML

Property Name

HTML: xbsAddPrinterTypeJobScreen

HTML: xbsJobScreen

HTML: xbsJobSummaryScreen

HTML: advancedDelivery

HTML: getDescription

HTML: billing

HTML: advancedBilling

HTML: delivery

HTML: accounting

Before modifying any of these files, press Ctrl A
on the keyboard to select all the HTML code.
Press Ctrl C to copy the code. Press Ctrl V to
paste the HTML text into an empty text file and
save it. If modifications made to the HTML code
cause problems, past the code back into the
section modified to restore the system to the
state before modification.
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Jobs: Printshop Print Job: Document Options: optionNames

Table B-4 shows the properties that contain the defined variable names
used in the Documents Xpress system for documents.

Table B-4. Jobs: Printshop Print Job: Document Options:
optionNames

Property Name Operator
Editable? Null Allowed Data Type

copies yes yes number

document_description yes yes string

paper_size yes yes string

produce_on_color_device yes yes string

paper_color yes yes string

paper_weight yes yes string

page_sides yes yes string

orientation yes yes string

imposition yes yes string

additional_specification yes yes string

stapling yes yes string

saddle_stitch yes yes string

slip_sheets yes yes string

binding yes yes string
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Table B-4. Jobs: Printshop Print Job: Document Options: optionNames
(continued)

Property Name Operator
Editable?

Null Allowed Data Type

stock_weight yes yes string

drilling yes yes string

front_cover yes yes string

drill_front_cover yes yes string

front_cover_weight yes yes string

front_cover_color yes yes string

back_cover yes yes string

drill_back_cover yes yes string

back_cover_weight yes yes string

back_cover_color yes yes string

tabs yes yes string

special_order_tabs yes yes string
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Jobs: Printshop Print Job: Document Options: hold

Table B-5 shows the properties that define what criteria the Documents
Xpress system uses to hold jobs.

Table B-5. Jobs: Printshop Print Job: Document Options: hold

Property Name Operator
Editable? Null Allowed Data Type

<no properties defined>

Jobs: Printshop Print Job: Document Options: HTML

Table B-6 shows the properties that define the HTML that Documents
Xpress system uses to define user and administrator screens and
drop-down menu choices.

Table B-6. Jobs: Printshop Print Job: Job Options: HTML

Property Name

HTML: xbsPrintOptions

HTML: xbsPrintOptionsSummary

HTML: printOptions

HTML: editableFinishingOptions

HTML: advancedPrintOptions

Before modifying any of these files, press Ctrl A
on the keyboard to select all the HTML code.
Press Ctrl C to copy the code. Press Ctrl V to
paste the HTML text into an empty text file and
save it. If modifications made to the HTML code
cause problems, past the code back into the
section modified to restore the system to the
state before modification.
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Jobs: Printshop Print Job: Document Options: LPR: page_sides

Table B-7 shows properties that define the LPR translation values.

Table B-7. Jobs: Printshop Print Job: Document Options: LPR:
page_sides

Property Name Translated Name / Translated Value

LPR: page_sides page_sides

Translate: Duplex duplex

Translate: Simples simplex
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Jobs: Printshop Print Job: Document Options: LPR: paper_size

Table B-8 shows the properties that define the LPR translation values.

Table B-8. Jobs: Printshop Print Job: Document Options: LPR:
paper_size

Property Name Translated Name / Translation Value

LPR: paper_size mediaSize

Translate: 8.5 X 11 USLetter

Translate: 8.5 X 14 USLegal

Translate: 11 X 17 USLedger

Jobs: Printshop Print Job: Document Options: XJT: paper_size

Table B-9 shows the properties that define the XJT translation values.

Table B-9. Jobs: Printshop Print Job: Document Options: XJT:
paper_size

Property Name Translated Name / Translation Value

XJT: paper_size %XRXpaperType-size:

Translate: 8.5 X 11 216 279

Translate: 8.5 X 14 216 356

Translate: 11 X 17 279 432
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Table B-9. Jobs: Printshop Print Job: Document Options: XJT: paper_size
(continued)

Property Name Translated Name / Translation Value

Translate : A4 210 297

Jobs: Printshop Print Job: Document Options: XJT: paper_color

Table B-10 shows the properties that define the XJT translation values.

Table B-10. Jobs: Printshop Print Job: Document Options: XJT:
paper_color

Property Name Translated Name / Translation Value

XJT: paper_color %XRXpaperType-color:

Translate: 8.5 X 11 216 279

Translate: 8.5 X 14 216 356

Translate: 11 X 17 279 432

Translate: A4 210 297
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Jobs: Printshop Print Job: Document Options: XJT: page_sides

Table B-11 shows the properties that define the XJT translation values.

Table B-11. Jobs: Printshop Print Job: Document Options: XJT:
page_sides

Property Name Translated Name / Translation Value

XJT: page_sides %XRXpageExceptions-plex:

Translate: Simplex simplex

Translate: Duplex duplex

Jobs: Printshop Print Job: Document Options: XJT: paper_weight

Table B-12 shows the properties that define the XJT translation values.

Table B-12. Jobs: Printshop Print Job: Document Options: XJT:
paper_weight

Property Name Translated Name / Translation Value

XJT: paper_weight %XRXpaperType-weight:

Translate: 20 lb 20 lb

Translate: 24 lb 24 lb

Translate: 90 lb 90 lb

Translate: Transparencies Transparencies
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Jobs: Printshop Print Job: Document Options: XJT: stapling

Table B-13 shows the properties that define the XJT translation values.

Table B-13. Jobs: Printshop Print Job: Document Options: XJT:
stapling

Property Name Translated Name / Translation Value

XJT: stapling %XRXedgeStitching:

Translate: None None

Translate: Portrait Staple SinglePortrait

Translate: Landscape Staple SingleLandscape

Translate: Double Staple DualLandscape

Translate: Saddle Stitch DualPortrait

Jobs: Printshop Print Job: Document Options: XJT:
front_cover_paper_color

Table B-14 shows the properties that define the XJT translation values.

Table B-14. Jobs: Printshop Print Job: Document Options: XJT:
front_cover_paper_color

Property Name Translated Name / Translation Value

XJT: front_cover_paper_color %XRXcover-front:

Translate: None noColor
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Table B-14. Jobs: Printshop Print Job: Document Options: XJT:
front_cover_paper_color (continued)

Property Name Translated Name / Translation Value

Translate: White white

Translate: Buff custom

Translate: Yellow yellow

Translate: Cherry custom

Jobs: Printshop Print Job: Document Options: XJT:
back_cover_paper_color

Table B-15 shows the properties that define the XJT translation values.

Table B-15. Jobs: Printshop Print Job: Document Options: XJT:
back_cover_paper_color

Property Name Translated Name / Translation Value

XJT: back_cover_paper_color %XRXcover-back:

Translate: White white

Translate: Buff buff

Translate: Yellow yellow

Translate: Cherry custom
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changing, 13-5
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creation, 6-4
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