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4 Glossary



1 About This Guide

Thank you for purchasing the WorkCentre Pro 421. The
WorkCentre Pro 421 is designed for ease of use, but to use

your machine to its fullest potential, take some time to read the
User Documentation.



Finding Information in the System Administrator’s Guide

The System Administrator's Guide contains the following
sections:

Table of Contents
Use the Table of Contents to find topics easily.
About This Guide - Chapter 1

Describes the information in this System Administrator’s
Guide.

Network Setup - Chapter 2

Describes how to make the WorkCentre Pro 421
available across a network.

Remote Configuration - Chapter 3

Provides information on external facilities provided to let
you configure the printer remotely.

Glossary - Chapter 4
Index

Refer to the Index to locate specific information.



Related Information Sources

Information available for the WorkCentre Pro 421 consists of:

This WorkCentre Pro 421 System Administrator's Guide
The WorkCentre Pro 421 User Guide

The WorkCentre Pro 421 Quick Start Guide

The WorkCentre Pro 421 Customer training CD
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2 Network Setup

Before you start

This chapter provides information on the settings that can be
made to enable the machine to reside on a network.

The process is in three parts:

1.
2.
3.

The printer needs to be configured for the network.
The network need to be configured for the printer.

The printer driver needs to be installed and configured on
each workstation with access to the printer.

These procedures are all described in this chapter.

Before starting please read the following information.

1.

Print a Menu Map to help you navigate to the locations you
need to set up (see “Printing a menu map” on page 2-2).

Print a status page to help you configure the printer driver
(see “Printing a status page” on page 2-2).

Print an NIC status page to help you configure the printer
for the network (see “Printing an NIC status page” on page
2-2).

Collect all of the information that you require to set up the
network. This includes addresses and protocol
information.

The installation procedures assume that the WorkCentre
Pro 421 is being installed on an existing, operational
network.



Printing a menu map

To print the menu map:

1.
2.

Press the Machine Status button.
Highlight [Menu map] and press the [Enter] key.
The WorkCentre Pro 421 will print the menu map.

Printing a status page

To print the status page:

1.

SAE I

Press the Machine Status button.

Highlight [Default settings] and press the [Enter] key.
Highlight [Printer defaults] and press the [Enter] key.
Highlight [Test print] and press the [Enter] key.
Highlight [Status print] and press the [Enter] key.
The WorkCentre Pro 421 will print the status page.

Printing an NIC status page

To print the NIC status page:

1.

o s~ oD

Press the Machine Status button.

Highlight [Default settings] and press the [Enter] key.
Highlight [Printer defaults] and press the [Enter] key.
Highlight [Test print] and press the [Enter] key.
Highlight [NIC status print] and press the [Enter] key.
The WorkCentre Pro 421 will print the NIC status page.



Configuring the printer

The printer needs to be configured to allow other users on the
network to communicate with it. The settings set the TCP/IP
and Novell characteristics. Apple Talk networks can be
connected to the Windows environment using CentreWare. In
future you will be able to configure the printer to be able to
reside on a UNIX-based network.

Setting the TCP/IP parameters

For the machine to be available as a resource on the network,
a number of parameters may need to be set up. These are the
configuration protocol, IP address, subnet mask, default
gateway and the host name. The settings for these will depend
on the specific requirements of the network and changes
should only be made in consultation with the network
administrator.

To set up the TCP/IP parameters:

1. Connect the WorkCentre Pro 421 to your network outlet or
cable.

2. Ifyou have not yet done so, print a Menu Map to help you
navigate to the locations you need to set up.

Press the Machine Status button.

Highlight [Initial setup] and press the [Enter] key.
Highlight [Network] and press the [Enter] key.
Highlight [TCP/IP] and press the [Enter] key.

I



» Choose [Bootp/DHCP] and
press the [Enter] key.

TCP/IP

[01. Bootp/DHCP A
02. IP address

03. Subnet mask v

04. Default gateway

Bootp/DHCP
01. Enable A

02. Disable

> Choose [Enable] to enable
the protocol and press the
[Enter] key.

> You can choose [Disable] to
disable the protocol.

7. Highlight [IP address] and press the [Enter] key.
This allows you to enter the IP address for the Workstation.

» Use the numeric buttons to
enter the IP address and r IPadd SS
press the [Enter] key. A
192.168.010.007 v

8. Highlight [Subnet mask] and press the [Enter] key.

This allows you to enter the address of the subnet mask for
the Workstation, if required.



» Use the numeric buttons to
enter the subnet mask
address and press the [Enter]
key.

» Use the numeric buttons to
enter the default gateway
address and press the [Enter]
key.

Subnet mask

255.255.255.000 v

9. Highlight [Default gateway] and press the [Enter] key.

This allows you to enter the address of the default gateway
for the Workstation.

192.168.010.012 v

10. Press the [Exit] button to return to the Network setup menu
entry.
11. Highlight [Done] and press the [Enter] key.

The WorkCentre Pro 421 will reboot and print a
Configuration Sheet in approximately 3 minutes.

12. Check the settings on the Configuration Sheet against the
information that was entered.



Setting Novell parameters

For a Novell network, you will need to set whether or not you
are using the IPX/SPX protocol and choose the network frame

type.
To set up the Novell parameters:

1. Connect the WorkCentre Pro 421 to your network outlet or
cable.

If you have not yet done so, print a Menu Map to help you
navigate to the locations you need to set up.

Press the Machine Status button.

Highlight [Initial setup] and press the [Enter] key.
Highlight [Network] and press the [Enter] key.
Highlight [Novell settings] and press the [Enter] key.

N
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» Choose [IPX/SPX protocol]

and press the [Enter] key. .I'OtOCO| . A )

02. Frame type
v

7. Highlight [IPX/SPX protocol] and press the [Enter] key.
This allows you to enable or disable the IPX/SPX protocol.

> Choose [Enable] to enable
the protocol and press the
[Enter] key.

02. Disable

> You can choose [Disable] to

disable the protocol. v




» Choose the Frame Type
required or [Auto] to allow the
machine to determine the
Frame Type and press the
[Enter] key.

8. Highlight [Frame type] and press the [Enter] key.
This allows you to set the network Frame Type.

' Frame type

2.802.2
3.802.3 v

4. Ethernet Il
5. Ethernet SNAP

9. Press the [Exit] button to return the Network setup menu
entry.

10. Highlight [Done] and press the [Enter] key.

The WorkCentre Pro 421 will reboot and print a
Configuration Sheet in approximately 3 minutes.

11. Check the settings on the Configuration Sheet against the
information that was entered.

Setting Apple Talk parameters

The printer can be configured for an Apple Talk network where
the client workstation is operating under Windows using
CentreWare but it must be enabled from the printer.

To enable up the Apple Talk network:

1. Connect the WorkCentre Pro 421 to your network outlet or
cable.

2. Ifyou have not yet done so, print a Menu Map to help you
navigate to the locations you need to set up.

Press the Machine Status button.

Highlight [Initial setup] and press the [Enter] key.
Highlight [Network] and press the [Enter] key.
Highlight [Apple talk] and press the [Enter] key.

I



» Choose [Apple talk protocol]
and press the [Enter] key.

v

7. Highlight [Apple talk protocol] and press the [Enter] key.

This allows you to enable or disable the Apple talk
protocol.

» Choose [Enable] to enable
the protocol and press the
[Enter] key.

02. Disable

> You can choose [Disable] to

disable the protocol. v

8. Highlight [Done] and press the [Enter] key.

The WorkCentre Pro 421 will reboot and print a
Configuration Sheet in approximately 3 minutes.

9. Check the settings on the Configuration Sheet against the
information that was entered.



Configuring the network

Setup with CentreWare

Configuring the network will vary according to the kind of
network to which are installing. The choices are:

> Novell Netware (see “Configuring Netware” on page 2-10)

> Windows Peer-to Peer Printing (see “Printing in a Windows
peer-to peer environment” on page 2-44)

> TCP/IP (see “Configuring TCP/IP” on page 2-53)

The procedures for configuring the printer on the network are
described in the appropriate network documentation.

The CentreWare software supplied on your Printer
Management Software CD will provide you with the quickest
and easiest method for installing your printer on a network. See
“Using CentreWare” on page 3-2.



Configuring Netware

This section explains how to install the WorkCentre Pro 421
using:

» PCONSOLE with NetWare 3.2

» PCONSOLE with NetWare 4.x Bindery Services (there is no
bindery function in Version 5.x)

> NWADMIN with NetWare 4.x and 5.x Directory Services
> MAP or a Web browser to access parameters for NetWare

> Standard NetWare utilities to change the configuration

Configuring NetWare 3.2

Before configuring NetWare, use MAP or a Web browser to
determine if the WorkCentre Pro 421 has the name you want
— either the default name or a user-defined name.

The general procedure for configuring the WorkCentre Pro 421
for NetWare is as follows. Refer to the relevant sections in this
chapter for detailed information.

Use PCONSOLE to select the file server you want to use
Create the print queues

Specify the WorkCentre Pro 421 as a print server
Configure the print server and printer

Assign the print queues

Set Notify options

L o



Before you begin:

> Verify that you have supervisor privileges on the file servers
on which you are entering the WorkCentre Pro 421 print
server and queue.

> Verify that your version of PCONSOLE is later than 1.0.

Using PCONSOLE to select a file server

1. Log in as a supervisor or ADMIN.
2. Atthe command prompt, enter the PCONSOLE command.

3. Choose Change Current File Server from the Available
Options menu.

A list of file servers is displayed.

4. Select the file server on which you want to install the print
server. If the name of the file server you want is not
displayed, type h to display a list of file servers.

5. Login to the file server.
6. Press the Esc key to return to the Available Options menu.

Creating print queues

A print server takes the print jobs from queues and sends them
to the printer. The print server must be assigned to at least one
print queue on the file server.

If the print queue that you want the WorkCentre Pro 421 to
service already exists, and you know the name of this queue,
enter the Print Server Name (see “Entering the print server
name” on page 2-12).

If you do not know the name of the queue or it does not exist,
create a queue.

To create a queue:

1. In PCONSOLE, choose Print Queue Information from the
Available Options menu.

A list of existing queues is displayed.
2. Press the Insert key.
3. Enter the name of the queue.
4. Press the Esc key to return to the Available Options menu.



Entering the print server name

1.

In PCONSOLE, choose Print Server Information from the
Available Options menu.

A list of existing print servers is displayed.
Press the Insert key.

The New Print Server Name box is displayed.
Enter the name of the print server.

On the printer status sheet, the print server name will
appear under NetWare information.

Configuring the print server

1.

In PCONSOLE, choose the print server name from the
Print Servers list.

The Print Server Information menu is displayed.
Choose Print Server Configuration from the menu.
Choose Printer Configuration.

The Configured Printers menu appears. Since this is a new
Print Server entry, all printers are labelled “Not Installed.”

Choose Printer 0.

The Printer 0 Configuration screen appears with a title of
“Printer 0.”

To change the name that the print server uses in its
messages in the Notify list to users, select Name and enter
a name.

This name helps you identify the printer — for example,
XEROX_WC421.

Choose Type.
A list of printer types is displayed.
In the list of printer types, choose Remote Other/Unknown.

This creates default entries in the other fields. These
defaults are usually optimal, so do not change them
without specific knowledge of the effects.



Press the Esc key and save your changes. Then continue
to press Esc to return to the Print Server Configuration
menu. If you have finished the configuration, save your
changes and exit from PCONSOLE.

Assigning print queues to the printer

When you assign queues to the defined printer, you authorize
the print server to service these queues.

To assign print queues to the printer:

1.

In PCONSOLE, choose Queues Serviced By Printer from
the Print Server Configuration menu.

Choose the printer name from the list of defined printers.
The Available Queues list for the printer is displayed.

Choose the queue you want and then assign a priority level
from 1 to 10 (where 1 is the highest priority. It is also the
default).

The queue is displayed on the list for the printer.
You can press Enter again to assign additional queues.

When you finish assigning queues, press the Esc key and
save your changes. Then continue to press Esc to return
to the Print Server Configuration menu. If you have
finished the configuration, save your changes and exit from
PCONSOLE.



Setting up notify options for the printer

You can specify users or groups of users that are notified if a
problem occurs when a print job is sent to the printer. The print
server supports the enhanced Notify options for printers,
including informing users when the WorkCentre Pro 421:

> Is off-line, jammed, opened, or out of paper

> Requires a manual paper feed or a form change

> Has had an engine failure

If the print server services queues on multiple file servers, you
must set up a Notify list for each file server.

To configure the Notify options:

1. In PCONSOLE, choose Notify List for Printer on the Print
Server Configuration menu.

Choose the printer from the Defined Printers list.
Press Enter to view a list of Notify Candidates.
Select the user or group from the list.

Set the First and Next intervals in the Notify Intervals
screen by entering a number for each interval.

The First interval is the number of seconds the network
waits before it notifies candidates about a print job
problem. The Next interval specifies how often, in seconds,
candidates are notified.

6. After entering the intervals, press the Esc key and save
your changes. Then continue to press Esc to return to the
Print Server Configuration menu. If you have finished the
configuration, save your changes and exit from
PCONSOLE.
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Installing the print server on multiple file servers

To install the print server on more than one file server, perform
the procedures previously described for each file server. You
must use the same name and password (or no password) on
all file servers. You can set the password for the WorkCentre
Pro 421 using MAP. If you use a password, specify it on each
file server using the Change Password option on the Print
Server Information menu of the PCONSOLE utility.

A hop is an intermediate connection in a string of connections
linking two network devices. For example, on a network, some
data packets must go through several routers before reaching
their final destination. Each time a packet is forwarded to the

next router, a hop occurs. The more hops, the longer it takes

the data to go from the source to the destination.

A tick is 1/100 of a second for the WorkCentre Pro 421 (Novell
has a different value). Propagation delay is the time it takes for
the data to travel through the network, from the source to the
destination.

At startup, the WorkCentre Pro 421 automatically searches for
and attaches to the file servers that are no more than four hops
away and that have no more than eight ticks propagation
delay. For extremely large or complex networks, this allows a
bounded search time on startup.

If the print server must attach to file servers beyond this range,
or if you want to accelerate start up by eliminating the need to
search all file servers within the four hops/eight ticks radius,
enter the name of the file server operating with the print server
in the Print Server Configuration of a primary file server. The
primary file server is a server close to the printer and contains
a list of file servers that it services. The primary file server can
be any file server within the four hops/eight ticks propagation
time limits but ideally is as close as possible to the print server.
Once the print server locates the primary file server and the list
of file servers to be serviced, the automatic search stops and
the print server goes directly to those file servers listed (and to
no others).



Setting up a primary file server

1.

Log in to the server you want to designate as the primary
server and run PCONSOLE on that server.

Choose File Server To Be Serviced from the Print Server
Configuration menu.

Press the Insert key to display the Available File Servers
list.

Select the name of each file server to be serviced and
press Enter to add it to the list.

When the list is complete, press Esc to return to the menu.
Install the WorkCentre Pro 421 on each primary file server.

Setting up preferred file servers

You can specify a preferred file server on the WorkCentre Pro
421. If a preferred file server is listed, the WorkCentre Pro 421
attaches to this identified file server instead of initiating the
automatic search. If the preferred file server is also a primary
file server (for example, there are file servers listed under File
Servers to Be Serviced), the WorkCentre Pro 421 connects
directly to these file servers.



Configuring NetWare Bindery emulation

NetWare 4.x can operate in two modes:
> NetWare Directory Services (NDS)
> Bindery Services Emulation

For NDS, refer to “NDS and the WorkCentre Pro 421” on page
2-19.

These services run simultaneously and transparently to each
other. You can configure the WorkCentre Pro 421 to operate
with Bindery Services Mode only or to operate under NDS.
When configured under NDS, the WorkCentre Pro 421 also
services older file servers operating in Bindery Mode.

Confirming Bindery context

Before installing the WorkCentre Pro 421 on a Novell NetWare
4 x server in Bindery Emulation Mode, check that the server
has a Bindery Context (name for the server in Bindery Services
Mode). If the server does not have a Bindery Context, you can
install the WorkCentre Pro 421 in NDS mode. If the
WorkCentre Pro 421 must be installed in Bindery Emulation
Mode, the server must have a Bindery Context.

1. At the system console on the 4.x server, enter the load
install command.

Choose Maintenance/Selective Install from the menu.
Choose NCF Files Options from the menu.

Choose Edit AUTOEXEC.NCF from the menu.

Search the file to see if you have a statement similar to the
following:

SET BINDERY CONTEXT=0U=context

where context is the name of your file server context. If this

string is not present, you can enter it in the autoexec.ncf
file.

o h b

6. If you entered a new string in autoexec.ncf, then at the



console prompt, enter the SET BINDERY CONTEXT
statement that you entered in the file.

Configuring in Bindery mode with PCONSOLE

Once you confirm the server has Bindery Context, use the
following procedures to configure the WorkCentre Pro 421.

To configure the WorkCentre Pro 421 with PCONSOLE:

1. Log in as a supervisor or ADMIN.

2. Atthe command prompt, enter the PCONSOLE command.
3. Press the F4 key to switch to Bindery mode.

4. Choose Quick Setup from the Available Options list.

5. Use Quick Setup to connect your print server, print queue,
and printer correctly. You can modify these later if
necessary.

6. Select Print Server and press F3 or Insert to modify the
entry.

7. Enter the name of the print server in the Print Server field.

The print server name appears under Novell Network
Information on the Status and Configuration report. The
default name is the WorkCentre Pro 421 serial number (six
digits with a three-letter prefix).

8. Enter a name in the New Printer field.
9. Enter a name in the New Print Queue field.

10. In the Printer Type field, choose Other/Unknown from the
list of printer types.

11. When you are finished, press Esc to save the
configuration.

12. Repeat steps 5 through 11 for each file server that the print



Server services.

To view, add, delete, or modify print servers or queues
after the initial setup, select either Print Queues or Print
Servers on the Available Options menu.

NDS and the WorkCentre Pro 421

NDS offers a more advanced approach to network
management than previous NetWare versions. It stores and
tracks all network objects. As a rule, all NetWare 4.x and 5.x
servers must have NDS loaded in order to function. In this way,
every 4.x or 5.x server is a directory server, because it services
named directory objects such as printers, print servers, and
print queues. With the appropriate privileges, you can create a
print server object which, once configured in its context (or
location) on the network, eliminates the cumbersome setup of
print servers on every network server. NDS provides true
enterprise networking based on a shared network database
rather than an individually defined physical site. The result is
greatly improved print server setup and management.

The Directory Information Base (DIB) stores information about
servers and services, users, printers, gateways, and so on. It
is a distributed database, allowing access to data anywhere on
the network wherever it is stored. NetWare versions earlier
than 4.x provide the same data found in the DIB, but the
NetWare Bindery stores the data. The DIB was designed with
more flexible access and more specific security; moreover,
since itis distributed, it was designed to be partitioned. The DIB
uses an object-oriented structure rather than the flat-file
structure of the Bindery, and offers network-oriented access
rather than the server-oriented access found in the Bindery.



The DIB is backward-compatible with the NetWare Bindery
through Bindery Emulation Mode. “Configuring NetWare
Bindery emulation” on page 2-17 describes Print Server
Operation with a NetWare 4.x system in Bindery Emulation
Mode. When Bindery Emulation is enabled, Directory Services
accept Bindery requests and respond as if a Bindery exists on
the NetWare server being accessed. Information obtained from
the Bindery query may not be stored in the server because the
DIB is a partitioned and distributed database. Even though the
4 x server is not operating from a Bindery, the applications
making Bindery requests do not know the difference.

You can use NWADMIN to configure the printer in NDS. Before
you can print, NDS must be set up as described in the following
sections and the WorkCentre Pro 421 must be set up with NDS
Context and Tree. See “Configuring the WorkCentre Pro 421”
on page 2-23.

The following sections describe using NWADMIN to create
printer, print server, and print queue objects. You can assign or
associate these objects with each other. You can keep Bindery
resources on any server on NetWare 4.x if you include a SET
statement in your autoexec.ncf file.

Alternatively, you can use PCONSOLE to set up static
information about print servers, such as the queues to service
and whom to notify in the event of a problem. Refer to the
NetWare documentation for more information about the use of
PCONSOLE for NDS.

Creating the printer object

1. Start NWADMIN. (For example, double-click the
NWADMIN icon in the NetWare Tools group.)

The NetWare Administrator window opens.
2. Choose Object>Browse.
Your directory tree is displayed.

3. Select the Organizational Unit or Organization where you
want to create the printer in the Directory Tree, and choose
Object>Create.

The New Object windows appears.

4. In the Class of New Object list, choose Printer and click
OK.



5.

When the Create Printer window appears, enter a value in
the Printer Name field and click Create.

Creating the print server object

To create a print server object:

1.
2.

In NWADMIN, choose Object>Browse.

Select the Organizational Unit where you want to create
the print server in the directory tree and choose
Object>Create.

In the New Object window, scroll down the Class of New
Object list, choose Print Server and click OK.

When the Create Printer window appears, enter a value in
the Print Server Name field and click Create.

Creating the print queue object

Start NWADMIN.
Choose Object>Browse.

Select the Organizational Unit where you want to create
the print queue in the directory tree and choose
Object>Create.

In the New Object window, scroll down the Class of New
Object list, choose Print Queue and click OK.

In the Create Print Queue window, click Directory Service
Queue, enter values for Print Queue Name and Print
Queue Volume, and click Create.

If you do not know the Print Queue Volume name (the hard
drive you are accessing), click the icon to the right of the
volume field. The Select Object window opens with the
volume listed in Objects. If the volume is not listed, scroll
through the Directory Context items to find the volume
where you want the queue to reside.

Click the object (hard drive) of your choice.
The object appears in the Selected Object field.
Click OK and then click Create.



Assigning the printer object

In NWADMIN, choose Object>Browse.

2. In the NWADMIN directory tree, double-click the printer
object previously created.

The Printer window opens.
3. Click Assignments and then click Add.

4. When the Select Object window opens, find the print
queue object just created and select it.

5. Click OK.

The print queue just created appears in the Print Queues
list in the Printer window.

6. Click OK.

Assigning print server object

1. In NWADMIN, choose Object>Browse.

2. Inthe NWADMIN directory tree, double-click the print
server object you just created.

The Print Server window opens.
3. Click Assignments and then click Add.

4. When the Select Object window opens, select the printer
object just created in the Objects list and click OK.

The printer (with its context) appears in the Printers list.
5. Click OK.

Checking assignments

1. In NWADMIN, choose Object>Browse.

2. In the NWADMIN directory tree, double-click the print
queue object.

The Print Queue window opens.
3. Click Assignments.

If you configured the print queue and printer correctly, they
will appear in the proper boxes in the Print Queue window.

4. Click Cancel.



Setting up and resetting the printer

After completing the NWADMIN configuration, you must set up
and reset (power cycle) the printer before you can begin
printing.

Configuring the WorkCentre Pro 421

Use the MAP utility or a Web browser to:

> Define the context and tree of the Print Server
> Change the Print Server name

> Set a password

> Modify scan and frame search parameters

> Set values for Bindery Mode

To configure the WorkCentre Pro 421:

1. Access the setup pages for the WorkCentre Pro 421 using
MAP or a Web browser.

2. Once you have accessed the Network Administration
pages or the Main Menu, choose Setup NetWare under
Protocols.

3. Confirm that there is a check mark in the Enable NetWare
option. If necessary, put a checkmark in that option.

4. Optionally, enter a name in the Print Server Name field.
To use the default name, leave the field blank.

The default name is the WorkCentre Pro 421 serial number
(six digits with a three-letter prefix). This is also the default
name of the printer in peer-to-peer mode.



5. Optionally, to secure the WorkCentre Pro 421 with a
password, enter a password in the Print Server Password
field and again in the Password Retype field.

If you are using a password, use the same password for all
bindery-based and NDS-based Print Server entries.

If you enter a password, you must also enter the same
password in the password field on your file server setup
using PCCONSOLE or NWADMIN.

6. For Bindery emulation, enter the name of a preferred
bindery-based file server in the Preferred File Server field.

The Preferred File Server entry applies only for Bindery- or
Bindery Emulation-based operations. See “Setting up
preferred file servers” on page 2-16 for the significance of
a Preferred File Server. The Print Server must be
configured on the preferred file server. Incorrect setup of a
Preferred File Server can interfere with NetWare printing.

7. If the Print Server operates under Novell Directory
Services, enter a Context and Preferred NDS Tree in the
appropriate fields.

Be sure to give the whole context, whether typed or
typeless, and do not begin your context path with a leading
period.

An example of a typed context name is
ou=standard.ou=organization 1.

(If you do not know your tree, open a DOS command box
and enter the whoami command.)

An example of a typeless context name is organization 1.
You must use a typeless context if the WorkCentre Pro 421
is on the same network segment as the file server.

8. Enter the time intervals, in seconds, in which the Print
Server will scan the queues that it services in the Print
Queue Scan Rate field.

The default scan rate is once per second.



10.

11.

If your network uses multiple frame types for Novell, you
can bias the frame search to the desired type by setting the
radio button next to the designation under Ethernet Frame
Type.

The WorkCentre Pro 421 normally monitors the network to
determine which frame type is used for Novell. When it
recognizes a type, it assumes the same frame type. Once
it selects a frame type, the WorkCentre Pro 421 only
operates over that Novell frame type. Monitoring normally
starts looking for IEEE 802.3, then Ethernet II, then 802.3
SNAP, and so on.

If you are operating in NDS mode only, you can disable
Bindery Mode on the Print Server by putting a checkmark
in the Disable Bindery checkbox.

If you disable Bindery Mode, the WorkCentre Pro 421 does
not support Print Servers on a Bindery file server.

Once you have selected all desired settings and entered
the desired NetWare information, click Accept Settings to
save this information in the WorkCentre Pro 421 NVRAM.

If you have not entered the WorkCentre Pro 421
Management password previously during this session, you
must enter it in the appropriate space before clicking
Accept Settings.

The values you entered do not take effect until the WorkCentre
Pro 421 is reset or power cycled. You can reset from MAP or
the Web browser by returning to the home page or Network
Administration page, and clicking Reset under System, and
then clicking Reset Unit. Alternatively, you can power cycle the
printer. The new NetWare values are now in effect.



Using the Novell PCONSOLE utility

You can use the PCONSOLE utility to:

> * Attach and select a file server

> « Select or delete queues for the print server
» « Set up the Notify function

See the NetWare Print Server Manual for detailed information
on this utility.

Changing the file server

1. Login to the file server and run PCONSOLE on that server.

2. Choose Change Current File Server from the Available
Options menu.

3. Press the Insert key to display the available file servers.
4. Select the file server you want.
5. Enter your username.

If the username requires a password, the Password screen
appears. Enter the password.

The name of the file server appears in the status header at
the top of the PCONSOLE window.

Changing print queues

When you print a file, your system sends the file to a print
queue. The print server assigned to that queue extracts the
print job and sends it to the assigned printer. If a print server
services queues on multiple file servers, you must assign
queues to the printer on each file server.

To change the print queues:

Log in to the file server and run PCONSOLE on that server.
2. Choose Print Servers from the Available Options menu.
3. Select the print server you want.

4. Choose Printers from the Print Server Information window.

—_



5. Select the printer you want.

6. In the Configuration menu for that printer, choose Print
Queues Assigned.

7. Select a queue from the list.
8. Select the priority for the print queue.

The highest priority queue is 1 (which is the default); the
lowest is 10.

9. Press Esc and save all changes.

Setting up a notify list

You can specify users or groups of users that are notified if a
problem occurs when a print job is sent to the printer. The print
server supports the enhanced Notify options for printers,
including informing users when the printer:

> |Is off-line, jammed, opened, or out of paper

> Requires a manual paper feed or a form change

> Has had an engine failure

If the print server services queues on multiple file servers, you
must set up a Notify list for each file server.

To set up a Notify list:

Log in to the file server and run PCONSOLE on that server.
Choose Print Servers from the Available Options menu.
Select the print server you want.

Choose Printers from the Print Server Information window.
Select the printer you want.

In the Configuration menu for that printer, choose
Notification and press Enter.

7. Press the Insert key to get a list of available options.
The Notify Candidates screen appears.

8. Select the notification candidate you want.
The Notify Interval screen appears.

o g bh wN =



9. Enter the notify intervals you want.

The First interval is the time the network waits before it
notifies users about a print job problem. The Next interval
specifies how often users are notified.

10. Press Esc and save all changes.



Configuring NetWare Distributed Print Services (NDPS)

NetWare Enterprise Print Services is a Novell software solution
built on the Novell Distributed Print Services (NDPS)
architecture. NDPS is an advanced printing architecture that
can be run on either an IPX or an IP network. NDPS over IP is
the native printing approach for NetWare 5.x systems.

NDPS is not yet implemented on printer resident print servers.
Instead, a NetWare server includes a gateway that translates
between NDPS and a printer-supported protocol or protocols.
Gateways exist for PSERVER on IPX, for LPD, and for raw

binary sockets printing on IP. Some gateways support NDPS
configuration and status information capabilities using SNMP.

The following sections describe the NDPS configuration using
Novell-supplied gateways. For networks running NDS over
IPX, the gateways use the NetWare PSERVER function
implemented on the printer NICs. For networks using IP, the
Novell-supplied gateway uses the printer LPD capability.
Novell is developing an NDPS gateway for printers
implementing the IPP protocol; update information on how to
set this up will be provided when the capability is released and
verified with these printers.

Creating NDPS manager

An NDPS Manager provides a platform for Printer Agents that
reside on the server. An NDPS Manager must be created as an
object in the NDS tree before you can create server-based
Printer Agents. This procedure is necessary regardless of the
gateway or underlying network protocol used.

To create an NDPS Manager object:

1. In NetWare Administrator, select the container where you
want the NDPS Manager object to reside.

2. Choose Object>Create>NDPS Manager.
The Create NDPS Manager dialog box opens.
3. Type a name in the NDPS Manager Name field.



4. Browse for the Resident Server where you want this
manager assigned.

This can be any server in the current NDS tree in which you
have installed NDPS. This will be the only server on which
you will be able to load this NDPS Manager. The NDPS

Manager will store its database on a volume of this server.

Configuring an NDPS gateway for IPX

The Novell NDPS is compatible with queue-based NetWare
printing technologies. The following procedure describes how
to set up and configure NDPS to interface with the printer via
queue-based printing.

Prerequisites

> Install the Xerox NDPS Gateway. To obtain the Xerox
Gateway and documentation go to www.xerox.com and
enter "NDPS" in the search field. Select the item returned
from the search "Novell Distributed Print Services(NDPS)".

> The print queue you want to reference must already exist.

> On a Novell 4.x or 5.x network using IPX, install the printer
and the print server.

> If you need 3.x or bindery-based printing compatibility, see
“Bindery reference queues” on page 2-32.

Configuring queue-based printers

1. In NetWare Administrator, select the container where you
want the NDPS Manager object to reside.

2. Choose Object>Create>NDPS Printer.
The Create NDPS Printer dialog box opens.

3. Type a name in the NDPS Printer Name field.

4. In the Printer Agent Source field, select Create a New
Printer Agent and click Create.

The Create Printer Agent dialog box opens.

5. Confirm the Printer Agent name (default is the name of the
new printer you are creating) and browse to select the
NDPS Manager you want to assign it to.



10.

11.

In the Gateway Types window, select the Novell Printer
Gateway.

The Novell PDS dialog box opens.

Configure the Novell PDS by selecting the Printer Type
and Port Handler Type and click OK.

The Configure Novell Port Handler configuration wizard
opens.

In the Connection Type field, click Forward Jobs to a
Queue and then click the [Next] button. (The Port Type
options are grayed out when you select the Queue
connection type.)

A screen with the Queue Name and Queue User Name
fields appears.

Provide the queue name and queue user name.

Browse for the target print queue. If no queues are listed,
no queues exist in the current context. Browse the tree to
find a queue in a different context. The queue you select
must exist in the current tree; otherwise, you will need to
create a “bindery reference queue” in your own container
to allow access to the actual queue. See “Bindery
reference queues” on page 2-32.

Click Finish.
The Select Printer Drivers dialog box opens.
Select the printer driver for each client operating system.

When users install this printer, these drivers will be
automatically downloaded to their workstations.

If you choose a Windows 3.x driver but not a Windows 95
or Windows NT driver, a 16-bit driver will be selected.
Normally this does not create problems.

If the driver you need is not listed, rather than adding the
driver to the RMS, you can choose [None] from the top of
each list. Users will then be asked to provide a disk with the
appropriate driver the first time they install this printer on
their workstations.



12. Click Continue.

The main browser window appears with your new
controlled-access printer listed.

Bindery reference queues

Novell suggests that you upgrade all of your printers to NDPS
as soon as possible. However, you may still want to provide
your users with access to queue-based printing resources for
a variety of reasons. While connecting to queue-based printers
controlled by NetWare 4 or NetWare 5 servers in the current
NDS tree can be accomplished directly when you configure a
Printer Agent, you may need to create one or more “bindery
reference queues” to provide access to printers controlled by a
NetWare 3 file server or printers controlled by a NetWare 4 or
NetWare 5 server in a different NDS tree.

A bindery reference queue serves as a pointer to a real
NetWare queue on both types of servers. After you have
created a bindery reference queue to point to a real bindery
queue on a target server, you can then configure a Printer
Agent to send jobs to that queue just as you would if the queue
actually resided on a NetWare 4.x or NetWare 5.x server in the
same tree.

The following section explains how to accomplish this
procedure using NetWare Administrator.

Prerequisites

Before you can create a bindery reference queue, the following
requirements must be met:

» The print queue you want to reference must already exist
on the server you want to point to.

> A bindery object of the same name as the one you are
using must exist on that server and must have rights to the
print queue you are referencing.



Configuring Bindery reference queues

1.

10.

In NetWare Administrator, select the container where you
want the reference queue to reside.

Choose Object>Create.

The New Object dialog box opens.

Select Print Queue.

The Create Print Queue dialog box opens.

Select Reference a Bindery Queue. (Notice that the dialog
box changes when you select this option.)

If you want to assign a bindery reference queue name
different from the queue’s name on the legacy server,
enter the reference name in the Print Queue Name field.

If you do not want to assign a different reference name,
leave the field blank.

Browse for a bindery server and queue.
The Network Server and Queue dialog box opens.

Click List Only Attached Servers to specify whether you
want this option turned on or off.

To see a list of all available servers, turn off this option.
Select the name of the server you want to attach to. Log in
to this server at the prompt.

Double-click the server you want to use.

A list of queues available on that server appears in the
Queues list. If you are not attached, you must authenticate
to that server.

Select the queue for which you want to create a reference
and click OK.

The Create Print Queue dialog box opens again.
Click Create.

The bindery reference queue now appears in your NDS
tree.



11. Return to Step 10 of the procedure for configuring a queue-

based printer as a controlled-access printer (see
“Configuring queue-based printers” on page 2-30).

Now that this queue is created, you can configure a Printer
Agent to service jobs from a queue or to submit jobs to a
queue.

Configuring the queue-based printer option at the server
console

1.

Do the steps described in “Creating public-access printers
in NetWare administrator” on page 2-37.

Choose Connection Type>Queue-Based Printer.

The Port Handler Configuration: Queue-Based Printing
Mode screen appears.

Select Distinguished Queue Name, press Enter, and type
an existing queue name. This is the name of the print
queue where you want the Printer Agent to place jobs.

If you press Enter or Insert again, you can browse the
network tree to search for a queue.

Highlight User Name, press Enter or Insert, and type the
name of the user who will manage the queue just specified.

To browse the network tree for a valid user, press Enter or
Insert.

Click Accept and Exit.

The Printer Agent with its associated Print Device
Subsystem (PDS) and Port Handler string are then loaded.

The Port Handler configuration utility closes and control
returns to the NDPS Manager.



Configuring an NDPS gateway for IP

Configuring remote printers running in Ipr mode

1. From the browser’'s Object menu for the organization or
organizational unit, choose Create.

The New Object dialog box opens.
2. Choose Object>Create>NDPS Manager.
The Create NDPS Manager dialog box opens.
3. Type a name of your choice in the Printer Name field.

4. At the Printer Agent Source field, select Create a New
Printer Agent and click Create.

The Create Printer Agent dialog box opens.

5. Confirm the Printer Agent name (default is the name of the
new printer you are creating) and browse to select the
NDPS Manager you want to assign it to.

6. Inthe Gateway Types window, select the Xerox Gateway.
The Configure Novell PDS dialog box opens.

7. Configure the Novell PDS by selecting the Printer Type
and Port Type. Then click OK.

The Configure Novell Port Handler configuration wizard
appears.

8. Configure the Connection Type as Remote (LPR on IP)
and click the [Next] button.

9. Enter the IP address of your host and click Finish.



10. Select the printer driver for each client operating system.

11.

When users install this printer, these drivers will be
automatically downloaded to their workstations.

If you choose a Windows 3.x driver but not a Windows 95
or Windows NT driver, a 16-bit driver will be selected.
Normally this does not create problems.

If the driver you need is not listed, rather than adding the

driver to the RMS, you can choose [None] from the top of
each list. Users will then be asked to provide a disk with the
appropriate driver the first time they install this printer on

their workstations.

Click Continue.

The main browser window appears with your new
controlled-access printer listed.

Using the remote printer Ipr/TCPIP option at the server
console

At the server console, you can create a Printer Agent to
represent a printer attached to one of the following:

» A workstation or a remote file server

> Directly to the network, running in Ipr mode in a TCP/IP

environment and for which no gateway is available

A Printer Agent configured in this mode will emulate a legacy
print server (PServer Emulation), and will no longer require the
pserver.nim file.

1.

Perform the steps described in “Creating public-access
printers in NetWare administrator” on page 2-37.

Choose Connection Type ->Remote Printer LPR/TCPIP.
The Port Handler Configuration: Remote Printer LPR/
TCPIP Mode screen appears.

Choose IP Host, select Host Type, and provide the
information requested.

Click Accept and Exit.

The Printer Agent with its associated Print Device
Subsystem and Port Handler string are then loaded. The
Port Handler configuration utility closes and control returns
to the NDPS Manager.



Public-access printers and controlled-access
printers

Creating public-access printers in NetWare administrator
1. Double-click the NDPS Manager object you will be using to
control this Printer Agent.

2. Inthe ldentification page for the NDPS Manager object you
want to use, choose the Printer Agent List and click New.

The Create Printer Agent dialog box opens.

3. Type the name of the printer in the NDPS Printer Name
field.

4. Atthe Gateway Types window, select the Novell Printer
Gateway.

The Novell PDS dialog box opens.

5. Configure the Novell PDS by selecting the Printer Type
and Port Handler Type and click OK.

6. Select the printer driver for each client operating system.

When users install this printer, these drivers will be
automatically downloaded to their workstations.

If you choose a Windows 3.x driver but not a Windows 95
or Windows NT driver, a 16-bit driver will be selected.
Normally this does not create problems.

If the driver you need is not listed, rather than adding the
driver to the RMS, you can choose [None] from the top of
each list. Users will then be asked to provide a disk with the
appropriate driver the first time they install this printer on
their workstations.

7. Click Continue.

The new Printer Agent will now appear in the Printer Agent
List window.



Converting public-access printers to controlled-access
printers

To take full advantage of the security and management
features provided by NDS, you may want to convert public-
access printers to controlled-access printers.

For example, if you have used a third-party gateway to get a
printer up and running immediately (plug-and-print), the
gateway automatically creates a public-access printer. Later,
you may want to convert that printer to a controlled-access
printer. The following procedure explains how to convert a
public-access printer to controlled-access.

Prerequisites
To create a controlled-access printer on your network, you
must meet the following prerequisites:

» Have at least Read, Write, Modify, and Create rights for the
destination container where its associated Printer object will
reside

> Be designated as a manager of the NDPS Manager that will
control this Printer Agent

» Have a Broker running
» Have an NDPS Manager object
> Have a public-access printer created

Procedure

1. In NetWare Administrator, select the container where you
want the printer to reside.

2. Choose Object>Create>NDPS Printer.
The Create NDPS Printer dialog box opens.
3. Type a name in the Printer Name field.

4. In the Printer Agent Source field, select Public Access
Printer.

5. When the Select Public Access Printers list appears, click
Create.

A warning message appears saying that all clients will
need to reinstall this printer after it is converted.
6. Click OK.

7. Select the public-access printer you want to convert to a
controlled-access printer and click OK.



8. Click Create.

Adding NDPS printers from Windows clients

Once an NDPS printer had been created, you can add it to the
available printer resources of Windows clients as follows.

To add a printer from a Windows NT 4.x workstation:

1. Choose Start>Settings>Printers.

2. Double-click Add Printer.

3. Select Network Print Server and click the [Next] button.
4

Select NDPS Printers, find the name of your printer, and
click OK.

5. Finish your printer configuration.

NetWare troubleshooting

Troubleshooting for the Windows-based PC consists of both
hardware and software procedures.

The steps in each of these procedures should eliminate
cabling, communication, and connection problems associated
with direct-connected ports.

Complete one of these procedures (based on the type of port
being used), then run a test print from your software
application. If the job prints, no further system troubleshooting
will be necessary.

Requirements

> You are operating a Windows-based system with the
CentreWare software and at least one print driver installed.

> You are a NetWare Network Administrator OR
administrative person with ADMIN/SUPERVISOR or
ADMIN/SUPERVISOR EQUIVALENT login rights to the
NetWare Server(s) servicing the WorkCentre Pro 421.



> The instructions for these troubleshooting tasks assume a

base knowledge of NetWare.

NetWare troubleshooting quick check

1.

Verify that the printer is plugged in, turned on, and
connected to an active network.

Verify that the printer is receiving network traffic by
monitoring the LEDs on the back of the printer. When the
printer is connected to a functioning network receiving
traffic, its link LED will be green, and its orange traffic LED
will be flashing rapidly.

Verify that the client is logged into the network and printing
to the correct print queue. Also verify that the user has
access to the WorkCentre Pro 421 queue.

Verify that the WorkCentre Pro 421 NetWare print queue
exists, is accepting jobs, and has a Print Server attached.
If not, try using Setup Wizard in CentreWare to reconfigure
the print queue.

Print out a Configuration Sheet. Verify that Printer Server
is enabled. Try setting the frame type to the frame type
your NetWare Server is using.

For Bindery only verify that the Primary Server is set.
(Primary Server should have been set during initial queue
setup and installed using CentreWare.) If it is not set, use
CentreWare to set it and reset the printer.

If the above quick checks fail to fix the printing problem,
contact Xerox Customer Service.

Novell NetWare troubleshooting step-by-step

The steps in this procedure should eliminate cabling,
communication, and connection problems associated with
network connected printers.

The steps are divided into two groups:

» Hardware Step-by-Step



> Software Step-by-Step

Software Step-by-Step assumes that you are connected to a
Novell NetWare network with a Windows OS loaded on the
client workstation.

Complete both of these procedures, then run a test print from
your software application. If the job prints, no further system
troubleshooting will be necessary.

Novell NetWare hardware step-by-step

1.

6.

Check LED activity on the printer. Link (green) LED should
be ON whenever it is connected to an active network.
Traffic (orange) LED should flicker with data reception.

Verify cable connections. If possible, substitute a new
cable or connectors from a known good system or printer.

Check the port to which your printer is attached. Connect
a known good network device to it and test.

Print a Configuration Sheet from your printer.
Review the Connectivity Settings and check for these
things:

. NetWare is enabled.

¢ Frame Type matches the frame type of the
desired fileserver.

. PDL is set to your desired PDL (PostScript or
PCL 5e) or to Auto.

e Primary Server (for NetWare 3.1X only) is set
to the name of the server which serves the
print queue you have assigned to the
WorkCentre Pro 421.

*  NDS Tree (for NetWare 4.1X NDS and later) is
set for the correct NDS tree name.

*  NDS Context (for NetWare 4.1X NDS and later)
is set for the correct NDS Context.

e Print Server (PServer) Name is set for the
name selected for this WorkCentre Pro 421 to
act as a print server.

. Novell Mode is correctly set.

If any changes are made, reset the printer from the Control
Panel and allow two minutes for the printer to reattach to



7.

the desired fileserver.

Print out another Configuration Sheet to verify the items
you modified were set and retained.

Novell NetWare software step-by-step

1.

Verify that CentreWare and a WorkCentre Pro 421 driver
have been loaded on the workstation.

In Windows 95/98, WindowsNT 4.0 or Windows 2000,
double click on My Computer (you may have changed this
name). Open the Printers folder to verify that there is an
entry for the type of printer you installed.

Launch the CentreWare software.

In Windows 95/98, WindowsNT 4.0 or Windows 2000, click
on the Start button and slide the highlight up to the
Programs entry. In the next fold-out window, slide the
highlight up or down until you reach the CentreWare entry.
Release the mouse button to launch.

If the desired printer's name appears, your printer is
communicating through the network. Select the desired
printer. If a communications error message appears, your
printer is not able to communicate with your workstation.
Verify your printer's settings, then return to this procedure.

With the printer still selected, select the Printer drop-down
menu and highlight the Advanced Setup entry.

Under this menu will be a sub-menu for NetWare. Select
this option.



10.
11.

12.

13.
14.

15.

16.

17.

When the Advanced Setup dialog appears, verify the
information contained on this screen against the
information contained on the Configuration Sheet. Check
for both of these items:

. Primary Server has the server name listed on
the Configuration Sheet.

. Check the queue name the WorkCentre Pro
421 is set to service. If necessary, create a
new queue to test the printer.

¢ If your printer is configured to service both
NDS and Bindery mode queues, make sure
the Primary Server is not in the NDS tree the
printer is configured for.

Exit this window and select the Tools drop-down menu.
Select the Send File... menu item.

When the dialog box appears, select the proper directory
and file for downloading. Be sure this is a known good file
with no errors.

Click OK to download the file to your printer.

Check the printer to verify that the print job has printed. If
the job has not printed, check the Novell Menu settings on
the Configuration Sheet.

At the CentreWare main screen, select the Printer drop-
down menu. Highlight the Properties entry.

Once Properties is selected, highlight Connections.

Select the Network Card Tab. A new dialog box is brought
to the front and displays information about frame type and
connectors.

Be certain the printer is enabled and the connector and
frame type are correct.

If any changes are made, reset the printer from the Control
Panel and allow two minutes for the printer to reattach to
the desired fileserver.

Run a test print again. If the test print does not print,
contact Xerox Customer Service.



Printing in a Windows peer-to peer environment

This section describes:

» Windows IPX Peer-to-Peer Printing, including preparing for
the installation, installing, operating, setting up printing, and
adding printers.

Windows IP Peer-to-Peer printing allows Windows 95/98/ME
or NT 4 workstations to print to WorkCentre Pro 421 printers
without an intervening server.

IP 192.168.10.7

HUB

WorkCentre Pro 421

Introduction and preparation

The Peer-to-Peer implementation uses the TCP/IP protocol
provided with Windows 95/98/ME or Windows NT. The Xerox
TCP/IP Port Monitor establishes a direct connection with the
printer.

When configuring the network capabilities for the Windows
computer, you must include the TCP/IP Protocol.
To include TCP/IP after the initial Windows installation, from

within Windows choose Settings>Control Panel>Network from
the Start menu. You will also need the Windows CD-ROM.

For more detailed information on TCP/IP setup and printing,
see “Configuring TCP/IP” on page 2-53.



Print Driver Installation

If you are moving the WorkCentre Pro 421 from a site that had
active TCP/IP to a site that does not, you should disconnect the
WorkCentre Pro 421 from its existing network. Ascertain the
network setting requirements for the new site, reconfigure the
WorkCentre Pro 421 then connect the WorkCentre Pro 421 to
the new site.

You must first install your WorkCentre Pro 421 printer drivers
before adding the Xerox TCP/IP Port Monitor software. read
the note below and then refer to “Installing and configuring the
printer driver” on page 2-94.



Xerox TCPI/IP port monitor installation

1. Insert the WorkCentre Pro 421 Printer Driver CD.

2. When the opening screen is displayed, choose Additional
Software Utilities and then double click the TCP/IP Port
Monitor.

4 Xerox WorkCentre Pro 416 =10lx]

workeentre

PRO 421

Printer Drivers

Additional Software Utilities

N ‘TCPIIP Port Monitor
Xerox Online

Browse CD Directory

(=114

THE DOGUMENT COMPANY
XEROX

The Xerox TCP/IP Port Monitor Setup dialog is displayed.

Xerox TCP/IP Port
-
k & Install/Upgrade Port Maonitor Ok |

" Remove Port Manitor
I About |

3. Ensure that the Install/Upgrade Port Monitor option is
selected and click OK.

4. Click OK once the software is successfully installed.




Configuring the printer port for Windows 95/98/ME

1. Choose Settings>Printers from the Start menu.
2. Click on the WorkCentre Pro 421 printer icon and choose
Properties from the right mouse button menu.
3. Click the Details tab.
Xerox WorkCentre Pro 421 PCL 5e Properties EE3
Overlays | Fonts I ‘watermarks I About I
General Details | Faper/Output I Layout I Image Dptions I Frinter Configuration
Ferox WaorkCentre Pro 421 PCL 5e
Frint to the following port:
LPT1: [ECF Printer Port) Add Part.... |
Delete Port... |
PFrint uzing the following driver:
werox WorkCentre Pro 421 PCL Be j Mew Driver... |
Lapture Printer Part... | End Capture... |
Timeout setting:
Mot zelected: |1 5 zeconds
Tranzmizzion retry: |45 zeconds
Spool Settings... | Fart Settings... |
QK I Cancel | Lol | Helg |

4. Click [Add Port].
The Add Port dialog is displayed.

Add Port 7| X

Select the type of port you want to add:

© Metwork
Specify the netwaork path to the printer:

& Other
Click. the type of port you want to add:

Local Part
ox TCE/F Port

[ o ]

Cancel I




5. Make sure Other option is selected and highlight Xerox
TCP/IP Port.

6. Click OK.
The TCP/IP Printer Port Wizard screen is displayed.
7. Click the [Next] button.

Add Xerox TCP/IP Port

Enter a name to identify the port. This can be any name pou wizh but
must be unique. You may not have duplicate port names.

Then enter a printer name or P addrezs, You may also uze the auto
dizcoveny feature, which will search the netwark and display a list of
available printers.

—Enter a port name

—Enter a printer name or IP addre

I Auta Printer Discovery |

¢ Back I HERES | Cancel |

8. Enter the name by which you want to identify the port.

9. If you know the printer name or TCP/IP address of the
WorkCentre Pro 421 enter it. Otherwise, click the [Auto
Printer Discovery] button to display a list of available
printers on the network and double click the required
printer from the list.

The Printer Type dialog is displayed.

Printer Type
" Standard ILInknc-wn j

& Custom

< Back | Mest > | Cancel |

10. Select the Custom option and click the [Setup] button.



The Port Configuration screen is displayed.

Xerox TCP/IP Port - Configuration

Network Setup

11. Check the Select Bi-directional communication enabled

box.
12. Click OK to complete the Xerox TCP/IP Port installation.
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Configuring the printer port for Windows NT

4

1. Choose Settings>Printers from the Start menu.
2. Click on the WorkCentre Pro 421 printer icon and choose
Properties from the right mouse button menu.
3. Click the Ports tab.
QXemx WorkCentre Pro 421 PS5 Properties EHE
Security | Device Settings I Configuration I
General Ports Scheduling I Sharing
y Ferox Work Centre Pro 421 PS
FErrint to the following port(z). Documents will print ta the first free
checked port.
Fort | Description | Frinter |:|
Oipra Local Port
[ comt: Local Port
[ comz: Local Port
[ comz: Local Port
[ coma: Local Port
Local Port
Add Part... | Delete Port LConfigure Part...
I | Enatile bidirectional suppar
" Enable prirter pooling
()8 I Cancel |

Click the [Add Port] button.

The printer ports dialog is displayed.

Double click Xerox TCP/IP Port.

The TCP/IP Printer Port Wizard screen is displayed.
Click the [Next] button.



The TCP/IP Printer Port Wizard screen is displayed.

Add Xerox TCP/IP Port

7. Enter the name by which you want to identify the port.

8. If you know the printer name or TCP/IP address of the
WorkCentre Pro 421 enter it. Otherwise, click the [Auto
Printer Discovery] button to display a list of available
printers on the network and double click the required

printer from the list.
The Printer Type dialog is displayed.

9. Select the Custom option and click the [Setup] button.

Network Setup
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The Port Configuration screen is displayed.

Xerox TCP/IP Port - Configuration

10. Check the Select Bi-directional communication enabled
box.

11. Click OK to complete the Xerox TCP/IP Port installation.

2-52 Xerox WorkCentre Pro 421 System Administrator’s Guide



Configuring TCP/IP

This section describes configuring the WorkCentre Pro 421
and your network for use with TCP/IP communication in
various environments. This includes:

Installing in a Windows environment
Dynamic Host Configuration Protocol (DHCP)

Windows Internet Name Service (WINS)

Printing on UNIX-based systems, including Linux

»
»

»

> FTP printing
»

> Running Telnet
»

Using the Internet Printing Protocol (IPP)

The WorkCentre Pro 421 TCP/IP capability also operates with
Ipr spoolers on other systems, and with spooler/supervisor
capabilities that communicate raw print jobs to the TCP/IP port.

The IP Peer-to-Peer redirector provided with the WorkCentre
Pro 421 uses this TCP/IP port. The default port number is
10001 but can be changed by using Telnet or SNMP or by
accessing the WorkCentre Pro 421 HTML pages with MAP or
a Web browser. For information on using Telnet, see “Running
Telnet” on page 2-88.

Installing in a Windows environment

Several versions and variations of Windows can be used on
NetWare and TCP/IP networks, as well as in a native Windows
network. This flexibility provides you with various options for
setting up the network printing system even though this
WorkCentre Pro 421 does not support NetBEUI.

If the Windows workstations are connected to a NetWare
network, configure the printer interfaces for NetWare and use
standard Windows and NetWare utilities to provide access to
the printer. See “Configuring Netware” on page 2-10.

If you are not using NetWare, you can access the printer using
TCPI/IP.



If you are using Windows 95/98 or Windows NT 4.x, you can
also use the WorkCentre Pro 421 Peer-to-Peer capability
described in “Printing in a Windows peer-to peer environment”
on page 2-44.

Installing TCP/IP on Windows

Windows NT and Windows 95/98/ME/2000 come with TCP/IP
and Ipr capabilities, although these must be installed when the
unitis configured. You must install the TCP/IP Protocol, Simple
TCP/IP Services, and Microsoft TCP/IP Printing prior to
entering the network printer on the workstation.

Once lpr is installed on a Windows system and you have
allowed printer sharing, other workstations can use the printer
through the Microsoft Windows Network without having to have
separate lpr queues installed on each workstation.

Setting up the WorkCentre Pro 421

1. Power up the printer.

2. Configure the WorkCentre Pro 421 for the network. See
“Configuring the printer” on page 2-3

Keep the status sheet handy for the Ethernet (MAC) address.

It shows that TCP/IP is enabled but that the IP address is not

configured.

If the WorkCentre Pro 421 already has an IP address, these

procedures do not work. However, you can use Telnet to

access the WorkCentre Pro 421 and change the IP parameters

(see “Running Telnet” on page 2-88).

Assigning an IP address

The WorkCentre Pro 421 must be given an IP address and
routing information to be used with TCP/IP. To do this:

> If you have a NetWare connection, use MAP

> Otherwise, use arp (see “Using arp” on page 2-55) or
BootPL32 (see “Using BootPL32” on page 2-56)



Using arp

The WorkCentre Pro 421 must be on the same network
segment as the workstation you are using to configure it.
To assign an IP Address with arp:

1. Open a DOS command box and enter the following
command:

ping psc-ip-address
where psc-ip-address is the IP address you want to use for

the WorkCentre Pro 421. The request should time out with
no response (which indicates that the address is unused).

2. Enter the following command.
ping ip-address
where ip-address is any valid IP address on your network.
The identified unit should reply.
3. After the response, enter the following command.
arp -s psc-ip-address mac-address

where psc-ip-address is the IP address of the WorkCentre
Pro 421 and mac-address is its MAC address.

The entry should be accepted.

4. Enter the ping command from Step 1 again. The request
should time out.

5. Let the WorkCentre Pro 421 reset itself.
The WorkCentre Pro 421 generates a status page that
should include the entered IP address.

6. When the WorkCentre Pro 421 is up again, re-issue the
ping command from Step 1. Continue until you get a reply.



Using BootPL32
Using BootPL32, you can specify the IP address and other IP
parameters on TCP/IP.

The bootpl32.exe program uses the BootP protocol. The
WorkCentre Pro 421 must be on the same network segment as
the workstation you are using to configure it. The TCP/IP stack
must be installed and operating. The system cannot be
operating as an active DHCP Server.

To assign an IP address with BootPL32:
1. Reset the WorkCentre Pro 421.

2. Choose Start>Run.
3. Enter bootpl32.exe and click OK.
4. Choose Admin>Configure.
The BootP Parameters window appears.
5. Enter the following information.

- IP Address you want to assign to the WorkCentre Pro 421

- Subnet Mask (Make sure this matches what you are using
on your subnet. If you are unsure of the correct subnet
mask ask the system administrator.

- Default Gateway (IP address of your router or leave
blank)

- Hardware Address of the WorkCentre Pro 421 - listed on
the status sheet as the Ethernet address (for example,
00:40:af:13:¢9:f0)



6. Click Go and wait about 5 minutes.

The WorkCentre Pro 421 should recycle and produce a
status sheet showing the IP parameters you have just
entered. If the status page does not print, check the
Hardware Address entry in the BootP Parameters window.

7. Choose Admin>Verify.

A message should appear stating that the unit is active. If
you do not get this message, check the status sheet to see
if TCP/IP is enabled.

When you get a response that your unit is active, you
should be able to use ping and Telnet to access the
WorkCentre Pro 421.

Setting other IP parameters

The WorkCentre Pro 421 provides for a setup connection
through the standard Telnet port. To make changes to a unit
with factory default settings, you must log in as the system
administrator. You can change this password using Telnet (see
“Running Telnet” on page 2-88).
To set up IP and Ipr parameters:
1. Use Telnet to access the WorkCentre Pro 421.

The default login and password are both sysadm.
2. Turn off the protocols you are not using (Option 3).

3. Set up the subnet mask and default gateway for the
WorkCentre Pro 421, if applicable (Option 1).

4. Exit, save, and reset the WorkCentre Pro 421.

Alternatively, you can set up IP and Ipr parameters by
accessing the WorkCentre Pro 421 HTML pages with MAP or
a Web browser (see Chapter 3, Monitoring the WorkCentre Pro
421). The password to change parameters with the HTML
pages is the same as the Telnet password.



Setting up Ipr on Windows NT

11.

12.
13.

14.

15.
16.

Choose Settings>Printers from the Start menu.
Double click Add Printer.
The Add Printer wizard appears.

Choose the My Computer option and click the [Next]
button.

Click Add Port. A list of printer ports is displayed.

Select LPR Port in the list of ports and click New Port. The
Add LPR Compatible Printer window appears.

Enter the IP address of the WorkCentre Pro 421 in the
Name or address of server providing Ipd field.

Enter a name for the printer in the name of printer or printer
queue on that server field.

Click OK.
Click [Close] then [Next].

. If the driver is available then choose it. If not click [Have

disk] and browse to the driver.

This can be found on the Printer driver/documentation CD
at Install>(0S)>(PDL)>(Language) folder, where:

. OS is the operating system of the workstation,
Windows 9x, Windows 2000, Windows xp or

Windows NT.

. PDL is the Print Description Language, PCL or
PostScript.

. Language is the language in which the driver
functions.

Choose the XW421 driver and click the [OK] button.

The files are copied to the hard disk and the installation
completes.

Click the [Next] button.

Change the printer name, if required and click the [Next]
button.

Choose Shared or Not Shared according to your
requirements. If you are not sure, choose Not Shared.
Click the [Next] button then the [Finish] Button.

Configure the printer. See “Configuring the printer” on
page 2-99.



Setting up Ipr Windows 2000

11.

12.
13.

14.

15.
16.

Choose Settings>Printers from the Start menu.
Click Add Printer.

The Add Printer wizard appears. Click the [Next] button to
proceed.

Choose the Local Printer option and click the [Next] button.

Choose Create a New Port and select LPR Port from the
drop-down list.

Click the [Next] button.

Enter the IP address of the WorkCentre Pro 421 in the
Name or address of server providing Ipd field.

Enter a name for the printer in the name of printer or printer
gueue on that server field.

Click OK.
Click [Close] then [Next].

. If the driver is available then choose it. If not click [Have

disk] and browse to the driver.

This can be found on the Printer driver/documentation CD
at Install>(0S)>(PDL)>(Language) folder, where:

. OS is the operating system of the workstation,
Windows 9x, Windows 2000, Windows xp or

Windows NT.

. PDL is the Print Description Language, PCL or
PostScript.

. Language is the language in which the driver
functions.

Choose the XW421 driver and click the [OK] button.

The files are copied to the hard disk and the installation
completes.

Click the [Next] button.

Change the printer name, if required and click the [Next]
button.

Choose Shared or Not Shared according to your
requirements. If you are not sure, choose Not Shared.
Click the [Next] button then the [Finish] Button.

Configure the printer. See “Configuring the printer” on
page 2-99.



Dynamic Host Configuration Protocol (DHCP)

Dynamic Host Configuration Protocol (DHCP) is a service that
provides a method for assigning and maintaining IP addresses.
The WorkCentre Pro 421 obtains IP information from this
service.

There are two user-defined variables related to the DHCP
function:

» DHCP enable
» Use IP info in NVRAM

These variables are accessible in the TCP section of Network
Administration, in the HTML pages.

If DHCP is not enabled:

» The WorkCentre Pro 421 makes no DHCP requests under
any circumstances.

> If the WorkCentre Pro 421 does not have an IP address
stored, orif “Use IP info in NVRAM” is OFF, the WorkCentre
Pro 421 issues BootP requests.

If DHCP is enabled:

» The WorkCentre Pro 421 makes DHCP requests when the
WorkCentre Pro 421 is reset or on powerup, provided that
the WorkCentre Pro 421 does not have an IP address
stored or that “Use IP info in NVRAM” is OFF. These DHCP
requests are in addition to BootP requests.

> If the WorkCentre Pro 421 has an IP address in NVRAM
and “Use IP info in NVRAM” is ON, the WorkCentre Pro 421
uses the IP information from NVRAM and there is no DHCP
activity on the part of the WorkCentre Pro 421.

The factory default is DHCP enabled and “Use IP info in
NVRAM’” set ON. In this case, the WorkCentre Pro 421 issues
DHCP requests if it does not already have IP identification
information stored in NVRAM.



Windows Internet Name Service (WINS/DHCP)

Windows Internet Name Service (WINS) allows a device, such
as your print server, to register a NetBIOS name such as the
WorkCentre Pro 421 serial number (six digits with a three-letter
prefix) along with its current IP address (for example,
192.168.10.7). A client that wants to contact the printer uses
the WINS server to match the NetBIOS name with an IP
address. Most users find it easier to remember the NetBIOS
name for the printer rather than its IP address.

Using WINS with your print server

To use WINS with your Print Server, enter the IP address of the
WINS Server on the TCP/IP configuration screen. You can
access this screen with a Web browser or MAP utility.

Configuring the WINS server

You can configure your DHCP Server to automatically provide
WINS Server information to the print server, or you can use the
print server's TCP/IP Configuration Menu to manually enter the
necessary information. Refer to your DHCP Server's
documentation for further information on automatic
configuration through the DHCP Server.

To manually configure your print server to work with the
WINS server:

1. Assign an IP address to the print server.

To assign the address, you can use MAP, Address
Resolution Protocol (arp), DHCP, Reverse Address
Resolution Protocol (rarp), or BootP.

2. Run your Web browser - Internet Explorer or Netscape
Navigator.



Choose File>Open.
The Open dialog box opens.

Enter the print server’s IP address to access the print
server's TCP/IP Configuration Menu.

Choose TCP/IP Configuration from the main menu.

The NetBIOS Name for the print server is shown on this
screen. The default name is the WorkCentre Pro 421 serial
number (six digits with a three-letter prefix) unless you
have previously configured a name for the print server with
DHCP.

Optionally, enter a new NetBIOS name (15 characters or
less).

If you have previously configured a DHCP Server to
provide the print server with the IP address of the Primary
WINS Server, the address is shown on the TCP/IP
Configuration Menu. Otherwise, enter the IP address of the
Primary NetBIOS Name Server here.

Optionally enter the IP address of a Secondary NetBIOS
Name Server as well. If you have configured your DHCP
Server to provide the address of a Secondary WINS
Server to the print server, the address fields are
automatically completed for you.

Reboot the printer/print server.

The printer’s status page now shows that the print server
has successfully registered with the WINS server. The
checkboxes labelled “Primary Server Logged in” and
“Secondary Server Logged in” on the TCP/IP
Configuration Menu now indicate any WINS Servers with
which the print server has registered.

Normally, the print server automatically renews its
registration with the WINS Server before its lease expires.



FTP printing

FTP printing using Netscape

FTP printing with Netscape requires Navigator 2.0 or higher.
To print from Netscape:

1.

Connect to the port you want to send the print job to on
your print server.

Enter the following command.
ftp://PORT1@dest-srvr-addr

where dest-srvr-addr is the IP address of the print server to
which you want to send the print job.

Run Netscape.

Choose File>Upload File and specify the file, or drag and
drop the file to your browser window and click OK.

Printing from an FTP client

1.

Open a DOS Command window and enter the following
command.

ftp dest-srvr-addr

where dest-srvr-addr is the IP address of the print server to
which you want to send the print job.

Enter port1 as the login name.

Enter port1 as the password.

Enter the following command.

put filename

where filename is the file you want to print.



UNIX printing

The WorkCentre Pro 421 can support UNIX TCP/IP printing in
the following modes:

> Host-based Ipd where a supplied line printer daemon is run
on one or more workstations and print data is
communicated to the WorkCentre Pro 421 through a TCP/
IP port

> Printer-based Ipd where the printer appears as a host
running a line printer daemon

In general, printer-based Ipd is easiest to use on BSD UNIX
systems, requiring an entry in the printcap file once the
WorkCentre Pro 421 has its IP information. Some UNIX-based
systems have restrictions on support of remote Ipd/lpr printers,
requiring that the host-based Ipd/Ipr approach be used.

For many operating systems, you choose host-resident
printing or print server-resident printing. Each mode has
certain advantages:

> The host-resident method can print the username and
filename on its banner page; the print server-resident
method prints a banner page with the host name.

> The print server-resident method requires you to configure
the printer only one time - when you install the print server.
The host-resident method requires a printing daemon
installed on each host you want to be able to print jobs.



Between the host-based and printer-based TCP/IP printing
capabilities, the WorkCentre Pro 421 works with:

> All UNIX-based systems that support Ipd/lpr
> System V Rel. 4 (on 386 platforms)
» ULTRIXRISC 4.3 0r4.4
> OSF/12.00r 3.0
> Solaris:
- Version 1.1.3 (SunOS 4.1.3)
- Version 2.3 (SunOS 5.3)
- Version 2.4 0or2.5
» HP-UX Series 700 or 800 Versions 9.01 or 10.0
» IBMAIX 3.2.5
» SCO UNIX 3.2
» AS/400

The TCP/IP directory also includes source code that you can
recompile into host-based code for configuring on other
System V platforms.

Configuring the IP address on the WorkCentre
Pro 421

Regardless of the printing mode selected, the WorkCentre Pro
421 must be given IP address and routing parameters. You can
configure the IP address for the WorkCentre Pro 421 in one of
the following ways:

> Using MAP, as described in Chapter 3, Monitoring the
WorkCentre Pro 421

> Using the Internet Boot Protocol (BootP)

> Using the Reverse Address Resolution Protocol (rarp)
capability (Ethernet Il frame type only)

> Using arp and ping



For each method, you need to provide the Ethernet address of
the WorkCentre Pro 421. The Ethernet address is the 12-
character code that appears under Network Address on the
configuration status report each time the printer is turned on.
You can use the BootP, rarp, or ping procedures only when the
Print Server is in its factory default state (no IP information
entered.) After the Print Server has an IP address, you can
change the IP address, subnet mask, and default gateway by
using Telnet, MAP, or a Web browser.

Using BootP

The BootP daemon is a native TCP/IP option for configuring
the IP address of a diskless network device.

To communicate the IP address:

1. Turn off the printer.

2. Log in as superuser on a host on the same subnet as the
print server.
If the server resides on another subnet, complete this
procedure to store the IP address in the print server.
Reconnect the print server anywhere on the network, and
then change the IP address by using Telnet (see “Running
Telnet” on page 2-88) or by using MAP or a Web browser.

3. Find the Ethernet address of the WorkCentre Pro 421.

The address is printed on the configuration status report
each time you turn the printer on.

4. Edit the hosts file (usually /etc/hosts) or use NIS or DIS to
add the IP address and WorkCentre Pro 421’s node name.
Check with your network administrator for the IP address.

For example, a printer named printfast with an IP address
of 192.168.10.7 has the following entry.

192.168.10.7 printfast
5. Stop the BootP daemon if it is running.



Edit the /etc/BOOTP file and add the following information:
nic_host:\

:ht = hardware_type:\

:ha = ethernet_address:\

:ip = ip_address:\

:sm = subnet_mask:\

:gw = gateway address:

For example, for an RFC 1048 system:
printfast:\

:ht = ether:\

:ha = 0040AF03AF6E:\

:ip = 192.168.10.7:\

:sm = 255.0.0.0:\

:gw = 192.168.10.6:\

If you are running with a more recent BootP
implementation, such as on SCO UNIX, add:

:'vm = rfc1048:

The same information uses the following format on an RFC

951system.
host htype haddr iaddr bootfile
printfast 1 00:40:af.03:af:6e [192.168.10.7 defaultboot

7.

8.

Start the BootP daemon by entering the bootpd -s
command.

Check the printer to verify that the WorkCentre Pro 421 is
connected to the network and turn on the printer.

Wait until the printer powers up and finishes initializing to
allow enough time for the IP address to become known
and to be saved in non-volatile memory.

The WorkCentre Pro 421 should reinitialize itself.




9. After the WorkCentre Pro 421 has reinitialized, use the
ping command to verify that the print server obtained its IP
address.

For example:
ping 192.168.10.7

If the server has the address, the result is a confirmation
message such as:

192.168.10.7 is alive

10. Remove or comment out your changes to the /etc/BOOTP
file.

11. Stop the BootP daemon and, if you want it to run, restart it.



Using the Reverse Address Resolution Protocol (rarp)

The Reverse Address Resolution Protocol (rarp) allows
network devices to query a server for their IP addresses on
start up. For this procedure, there needs to be a workstation
with a rarp server.

To store the IP address:

1. Turn off the printer.

2. Login as superuser on a host on the same subnet as the
print server.
If the server resides on another subnet, complete this
procedure to store the IP address in the print server.
Reconnect the print server anywhere on the network and
change the IP address.
To make the change, you can use Telnet (see “Running
Telnet” on page 2-88) or use MAP or a Web browser.

3. Find the Ethernet address of the WorkCentre Pro 421.
The address is printed on the configuration status report
when you power on the printer.

4. Edit the hosts file (usually /etc/hosts) or use NIS or DIS to
add the IP Address and WorkCentre Pro 421’s node name.
See the network administrator for the IP address.

For example, a print server with the name of printfast has
the following entry:

192.168.10.7 printfast

5. Edit the /etc/ethers file or use NIS or DIS to add the
Ethernet address.

For example, in the case of the printfast server with an
Ethernet address of 00:40:¢8:00:00:ff, enter the following:
0:40:¢8:0:0:1f printfast

6. If the rarp daemon is running, stop and restart it. Then
verify that the daemon is running.

7. Check the printer to make sure the print server is
connected to the network. Turn on the printer.
Wait until the printer powers up and finishes initializing to
allow enough time for the IP address to become known
and to be saved in non-volatile memory. The Printer should
then reset itself.

8. After the WorkCentre Pro 421 has reset, use the ping
command to verify that the print server obtained its IP



address. For example:
ping 192.168.10.7

If the server has the address, the result is a confirmation
message such as:

192.168.10.7 is alive

Remove, or comment out, your changes to the /etc/ethers
file.

10. Stop the rarp daemon and, if you want it to run, restart it.

Using arp to enter an IP address

1.
2.

Turn off the printer.
Log in as superuser on a host on the same subnet as the
print server.

If the server resides on another subnet, complete this
procedure to store the IP address in the print server.
Reconnect the print server anywhere on the network and
change the IP address.

To make the change, you can use Telnet (see “Running
Telnet” on page 2-88) or use MAP or a Web browser.

Find the Ethernet address of the WorkCentre Pro 421.

The address is printed on the configuration status report
each time you turn the printer on.

Edit the hosts file (usually /etc/hosts) or use NIS or DIS to
add the IP address and print server's node name. See the
network administrator for the IP address.

For example, a print server with the name of printfast has
the following entry:

192.168.10.7 printfast

Add an entry to the arp cache for the Print Server’s IP
address and Ethernet address.

For example:
arp -s 192.168.10.7 0:40:¢8:0:0:ff

Check the printer to see that the Print Server is connected
to the network. Turn on the printer.



7. Use the ping command to verify that the WorkCentre Pro
421 is running on the network. You can enter the IP
address or the print server name.

For example, entering the IP address:
ping 192.168.10.7

Or, entering the print server name:
ping printfast

The WorkCentre Pro 421 does not respond to this ping
command but reads its IP address from the packets.

8. Turn the printer off and restart it. Then repeat Step 7 (send
the ping command again) to verify that the print server
obtained its IP address.

If the server has the address, the result is a confirmation
message such as:

192.168.10.7 is alive

9. Remove the entry from the arp cache. Enter the Print
Server either by its IP address or by its name.

For example:

arp -d 192.168.10.7
or:

arp -d printfast

Printing with Ipd/lpr

The Ipd/lpr commands are an implementation of the standard
UNIX line printer daemon which lets you print across a TCP/IP
network without installing software on your workstation and
with all filtering and banners done by the WorkCentre Pro 421.
Remote printing uses the same commands (lpr, Ipq, Ipc) as
local printing.

The process begins when the Ipr call finds a printer on a remote
system by looking at the remote (rm) entry in the /etc/printcap
file for that printer. The Ipr handles a print job for a remote
printer by opening a connection with the Ipd/lpr process on the
remote system and sending the data file (followed by the
control file containing control information for this job) to the
remote system. The printer-based Ipd then filters the data and
prints the job according to information contained in the control
file and its own printcap file.



The WorkCentre Pro 421 Ipd recognizes the format of certain
printer emulations and filters the data, if possible, so the data
can be printed on the printer type you specify.

To tell the WorkCentre Pro 421 Ipd the type of printer attached
to it, do one of the following:
> Accept the default port setting (PCL, PostScript, and other)

» Change the listed emulations by using Telnet, MAP, or a
Web browser

The following sections give specific Ipd/Ipr setup instructions
for various systems.

Printing on a BSD remote printer

To set up a remote printer on the host that sends jobs to
WorkCentre Pro 421 using printer-resident Ipd, add an entry to
the /etc/printcap file on your host for each printer you use:

1. Open the /etc/printcap file.

2. Enter the name of the WorkCentre Pro 421 as the remote
host and PORT1 as the remote printer name. A typical
printcap entry is:
printer name\
dp=:\

:rm=remote_host:\
rp=PORT1:\
:sd=/ust/spool/Ipd/printer name:

This entry sends jobs spooled at /usr/spool/lpd/
printer_name to the printer designated printer_name, to be
printed at PORT1 (the internal connection to the printer) of
the WorkCentre Pro 421 designated as remote_host. (All
printcap entries must begin with a tab except the one on
the first line.)

3. Use mkdir to create the spooler directory. For example:
mkdir /usr/spool/lpd/printer name

4. To print using the spooler, use the Ipr command as follows:

lpr-P printer_name file_name



Printing on an AIX version 2.5 remote printer

To set up a remote printer on the host that sends jobs
using the WorkCentre Pro 421’s Ipd:

1. At the prompt, enter the following command to run the
System Management Interface Tool (SMIT):

#smit spooler

2. When a window opens, select Manage Remote Printers.

3. When a menu appears, select Client Services, then select
Remote Printer Queues, and then select Add a Remote
Queue.

4. When a window opens, change the values shown to
configure the WorkCentre Pro 421. The values displayed

are default values. You must replace the short and long
form filter values with the values shown in the following

table.

Input Requested Example Description of Input Data
Name of queue to add print1 Name of local printer
Queue destination host printfast WorkCentre Pro 421 IP hostname
Short form filter /ust/lpd/bsdshort Required value
Long form filter /usr/Ipd/bsdlong Required value
Name of remote printer queue |PORT1 WorkCentre Pro 421
Name of device to add print1 Name of local queue

5. After you have entered all values, press Enter. Now you
can print.

Printing on AIX 4.0

Run SMIT Printer.

Select Print Spooling.
Select Add a Print Queue.
Select Remote.

Use Standard Processing.
Assign a queue name.

Use the host address of the WorkCentre Pro 421 for the
Remote System.
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8. For the queue on the remote system, use PORT1.

9. Optionally, add a description.

10. Press Enter to generate.

11. Test your printer by executing the following command:
Ip -d queue name file name

Printing on an HP-UX remote printer

To set up a remote printer on the host that sends jobs to a
WorkCentre Pro 421 using the Printer Ipd:

At the prompt, type sam.

When a window appears, choose Printer/Plotter Manager.
When the menu appears, choose List printer and plotters.
When a list appears, select Actions in the title bar.

From the pull-down menu, choose Add Remote Printer.

When a window appears, add values to configure
WorkCentre Pro 421.

For example:

L e

Input Requested

Example Description of Input Data

Printer Name

myprinter Name to be used in Ip command

Remote System Name

fastprint WorkCentre Pro 421 hostname as in /etc/
hosts

Remote Printer Name

PORTI Ipd queue name

7. At the bottom of the screen, select Remote Printer is on
BSD system from the choices available and click OK.

8. Use the ping command to test communications:
ping ip-address

where ip-address is the IP address of the WorkCentre Pro
421.

If the server has the address, the result is a confirmation
message such as:

192.168.10.7 is alive.




Printing on AS/400

When create (CRTOUTQ) or modify (WRKOUTQ) the output
queue description, there are several fields that must be defined
for the WorkCentre Pro 421 to function properly as a remote
printer device.

To define the fields for the WorkCentre Pro 421:

1. When prompted for the remote system, type INTNETADR
so the AS/400 recognizes the device as an IP device.

2. Enter the following:
- Port must be PORT1.
- Connection type must be IP.

- Internet address must be the IP address of the
WorkCentre Pro 421 device.
- Destination type must be OTHER.

3. When prompted for transforming SCS to ASCII, type YES
to allow the AS/400 to do the character translation.

4. For the manufacturer type and model, specify the print
driver that goes with your printer.

Printing on ULTRIX RISC or OSF1

You can set up ULTRIX 4.3 RISC or OSF1 remote printers on
the host that sends jobs to a WorkCentre Pro 421, as follows:
1. At the prompt, enter the Iprsetup command.

2. Select add.

3. Enter a name for your printer.

4

At the “Do you want more information on specific printer
types?” prompt, press Enter.

A list of ULTRIX-supported printers appears.

Enter remote.

Enter a printer synonym (alias).

Optionally, designate a spooler directory.

Designate PORT1 as the remote system printer name.

You are asked to enter the name of a printcap symbol from
a displayed list. Type Q and press Enter.

© © N o o



Your configuration appears. For example:

Printer #7 Symbol Type Representative Value
Ip (line printer) STR
rm (remote host) STR Printer Server Card host
rp (remote printer) STR PORT1
sd (spooler directory) STR /usr/spool/Ipd7
10. When prompted whether these values are final, type Y or
N and press Enter.
11. Add comments to the printcap file and press Enter.
For example, you can type a comment like, “Tom’s printer
down the hall.”
12. Select exit to save your configuration and press Enter.

Printing on SCO UNIX remote printers

You can set a remote printer on the host that sends jobs to a
WorkCentre Pro 421 using Ipd as follows:

At the prompt, enter the mkdev rlp command.

1.

2. You are now asked a series of questions. Respond as
follows (shown in bold type):

Please enter a printer name: lprprinterl

Is Iprprinter] a remote printer or a local printer? R

Enter remote host name: Iprprinter

Confirm the information you entered: Y

Confirm the preceding connection as your system default: Y

Enter another printer name or quit setup: Q
If necessary, stop and restart your remote daemon.

4. Using a line editor of your choice, edit the /etc/printcap file
and change the:rp=entry to PORT1.

3.




Printing on System V release 4 or Solaris 2.3 (or earlier)

If your system recognizes the Ipsystem command, you can use
Ipd/lpr. The admintool is another option, if your system
supports it.

To install Ipsystem, enter the following commands:

Ipsystem -t bsd ip_address
Ipadmin -p local print_name -s remote_host name!PORT1
enable local print name

accept local_print_name

where local_print_name is the WorkCentre Pro 421 host name
in the /etc/hosts file. Your system may want the IP address
instead of the remote host name.

Printing on Linux

1. Start x terminal.

2. At the command prompt, enter the printtool command.
The Red Hat Print System Manager window opens.

3. Click the Add button.
The Add Printer Entry window opens.

4. Choose Remote Unix (Ipd) Queue and click OK.
The Edit Remote Unix Queue Entry window opens.

5. Enter the following:

- The printer name

- The spooler directory (typically, /usr/spool/lpd/prntr-
name)

- The IP address of the WorkCentre Pro 421 (in the Remote
Host field)

- PORT1 (in In the Remote Queue field)
- An input filter (optional)
When you finish, click OK.

6. Restart the daemon by choosing Ipd>Restart Ipd in the
Print Server Manager.



Setting up a printcap file

Use the following command to set up a printcap file on SCO,
IRIX, Linux, or any BSD system:
prntr-name:lp=:rm=ip-addr:rp=PORT1:sd/usr/spool/lpd/prntr-name

where prntr-name is the name of the printer and ip-addr is the
IP address of the WorkCentre Pro 421.

After entering the command, you must shut down and restart
the Ipd daemon.

Installing TCP/IP for WorkCentre Pro 421 (no Ipd/
Ipr)

The TCP/IP directory provided with the WorkCentre Pro 421
includes install scripts for various UNIX systems. This section

describes how to install TCP/IP printing to the WorkCentre Pro
421 on any of the following operating systems:

> ULTRIX RISC 4.3
> System V Rel. 4
> Solaris (1.x, 2.x)
» SCO UNIX

> OSF1

> AIX

» HP-UX

After you have loaded the IP information onto the WorkCentre

Pro 421, the following steps are necessary for Host-Side TCP/

IP printing:

1. Load the print server software on your workstation. It is a
tar file in the TCP/IP directory.

2. Run the appropriate installation script, if available.

3. Complete the configuration for your operating system.



Installing the software

The following procedures are only necessary if you are using
the supplied host-based Ipr capability. Installing the software is
not necessary if you are using printer-based lpr.

1.

Log in as superuser to the system that spools directly to
the print server.

Insert the print server's CD-ROM in the host drive.

Go to the directory in which you want to install the
software. If necessary, create the directory. For example:

mkdir /usr/PSC _install

Use the tar command to load the software from the CD-
ROM. Choose your UNIX version from the following table
or if your version is not shown, consult the manpages or
check with your system administrator.

Operating System tar Command Example

BSD, ULTRIX, AlX, or SCO |tar -xvf/dev/rfd0

System V tar -xvf/dev/rdsk/f13ht
System V/Solaris 2.3 tar -xvf/dev/rdiskette
5. After performing the tar command, the system displays a

list of WorkCentre Pro 421 files copied. Go to the specific
section for your system for instructions on running the
installation script.




Selecting filters using a script

There are certain options for executing the script on various
systems.

One question that the install script asks is whether the printer
is a PostScript printer. If you answer No, the install script uses
an input filter (infilter) that supplies CR/LF translation to print
ASCII files on a PCL printer.

If you answer Yes, your printcap file references psfilter, which
offers easy ASCII-to-PostScript conversion. Normal PostScript
format files are not affected. Proprietary and public domain
filters are available for broader filtering capabilities.

Selecting filters manually

The WorkCentre Pro 421 comes with an input filter called
psfilter and an output filter called psbanner to print PostScript
banners.

You may want to change infilter or outfilter entries in the /etc/
printcap file. The following is a sample printcap entry using
these filters:

print_name | WorkCentre Pro 421 printer:\

:Ip=/dev/nic/printer_name:\

.if=/usr/nic/psfilter:\

:of=/usr/nic/psbanner:\

:sd=/usr/spool/printer _name:

(All printcap entries must be begin with a tab except the one on
the first line.)

Printing on Solaris V.1, OSF1, and ULTRIX 4.3

1. Enter the nicinst command to run the installation script.

The script automatically downloads the correct
WorkCentre Pro 421 utilities for your particular system and
prompts you for information as needed.

2. Atthe prompts, enter the node name entered in /etc/hosts
and the printer name.
Your screen now displays the information you provided to
the install script. You are asked to OK this configuration.
Type Yes or No and press Enter.

3. At the prompt, “Is this printer PostScript?” type Yes or No
and press Enter.



4. The script creates a printcap entry for the printer just
configured. The screen displays the entry and asks if you
want the script to append it to your printcap file. (See below
for a sample printcap file.)

Type Yes or No and press Enter. If you type No, you can
manually edit the file.

In your printcap file, be sure not to change the name of the
device given to the Printer in Step 2. You must reference
the same:lp entry you wrote on the Ip command line of the
printcap file. For example:

printer_name | WorkCentre Pro 421 printer:\

:Ip=/dev/printer_name:\

:if=/usr/nic/infilter:\

:sd=/usr/spool/printer_name:

(All printcap entries must be begin with a tab except the
one on the first line.)

The script creates a spooler directory in /usr/spool and
starts the daemon for the newly configured printer. It also
displays the path used in case you need to restart the
daemon.

/usr/nic/lpr_print /dev/nic/printer_ name node name 10001 &
5. Run the ps command to view all your Ipd/lpr processes:
ps -ax | grep Ipd
6. Kill all Ipd/lpr processes. (Note that this stops all printing.)
kill -9 process_id
7. Restart the daemon:
/ust/lib/Ipd
You are prompted to configure additional printers.
8. Type Yes or No and press Enter.
9. Use the ping command to test communications:
ping ip-address
where ip-address is the IP address of the WorkCentre Pro
421.

If the server has the address, the result is a confirmation
message such as:

192.168.10.7 is alive.



Printing on HP-UX
1. Enter the nicinst command to run the installation script.

The script automatically downloads the correct
WorkCentre Pro 421 utilities for your particular system and
prompts you for information as needed.

2. Atthe prompts, enter the node name entered in /etc/hosts
and the printer name.

At the prompt asking for the printer name, enter the desired
printer name and press Enter.

Your screen now displays the information you provided to
the install script. You are asked to OK this configuration.

3. Type Yes or No and press Enter.

The script starts the daemon for the newly configured
printer automatically. It also displays the path used in case
you need to restart the daemon. For example:

/usr/nic/lpr_print /dev/nic/printer name node_name 10001 &

When the installation script is complete, you must configure the
printer and make it known to the Ip system. The HP-UX Ip
system uses the Ipadmin command to configure a printer
(there is no printcap file).

To configure the printer, use the following commands:

Ipadmin -p printer_name -v /dev/nic/printer_name
enable printer_name
accept printer_name

You can also use other options for the Ipadmin command. See
your system documentation for details.

Hewlett-Packard supplies the same program as an alternative
to configure the printer. When using sam, enter everything as
if the printer were directly connected to /dev/Iprprinter/
printer_name.

Hewlett-Packard supplies ASCII-to-PostScript filters and the
system invokes them automatically if you define the content
type of the printer as PostScript. The HP-UX Ip system also
supplies interface scripts that produce PostScript banners. Use
the Ipfilter command to define new filters and content types if
necessary.



Printing on System V, Solaris V.2, or Rel. 4 386

The WorkCentre Pro 421 solution uses a network direct filter
called nicfilter which the system invokes directly from the
printer interface file.

To load the software, create a /usr/nic directory and use the tar
command to copy the TCP/IP software to this directory.

To install and print on System V, Solaris V.2, or Rel. 4 386:

1.

Go to the /usr/nic directory by entering the following
command:

cd /usr/nic
Enter the nicinst command to run the installation script.

The script automatically downloads the files for your
particular system to the /usr/nic directory, and prompts you
for information as needed.

Enter the following command to copy the default interface
to the /usr/nic directory:

cp /usr/spool/lp/model/standard /usr/nic/portl_interface

Go to the /usr/nic directory and using a text editor, edit the
port1_interface file.

Search for FILTER=0 and insert the following line above or
below the # FILTER=0${LPCAT} section of the file.
Remark out (using the # sign) any other FILTER entries in
this section of the file.

FILTER="/usr/nic/infilter| /usr/nic/nicfilter node-name 10001”
The node-name must be the same as in the /etc/hosts file.

For information on optional arguments, see the System V
Release 4 System Administration Manual

Save the file and close the editor.



7. To configure the host-side printer using Ipadmin, enter the

following command:
Ipadmin -p printer-name -v /dev/null -i /usr/nic/port]_interface

Initialize the printer by entering the following commands:
enable printer name

accept printer name

Test your printer by entering the following commands:

Ip -d queue name /etc/hosts

Ipstat printer name

Printing on SCO UNIX

Installation and setup is similar for HP-UX and SCO UNIX
systems. The WorkCentre Pro 421 solution uses a network
direct filter called nicfilter which the system invokes directly
from the printer interface file.

After completing software download in section 7.6.3.1
Installing the Software, you must configure the printer and
make it known to the Ip system. Follow the steps below:

1.

Enter the nicinst command to run the installation script.

The script automatically downloads the correct
WorkCentre Pro 421 utilities for your particular system and
prompts you for information as needed.

When asked to select your system, choose one of the
following options:

1) AT&T/SVR4; 386

2) SCO UNIX System V

3) None of the above

Type 1, 2, or 3, and press Enter.

At the prompt asking for the node name of the WorkCentre
Pro 421, enter the name assigned in the /etc/hosts file.



4. Atthe promptasking for the printer name, enter the desired
printer name.

Your screen now displays the information you provided to
the install script. You are asked to OK this configuration.

5. Type Yes or No, and press Enter.

6. At the prompt, “Is this printer PostScript?” type Yes or No
and press Enter.

The script starts the daemon for the newly configured
printer automatically. It also displays the path used in case
you need to restart the daemon. For example:

/usr/nic/lpr_print /dev/nic/printer_ name node name 10001 &

When the installation script is complete, you must still
configure the printer and make it known to the Ip system.

The SCO UNIX Ip system uses the Ipadmin command to
configure a printer (there is no printcap file). To configure the
printer, use the following commands:

Ipadmin -p printer_name -v /dev/nic/printer_name
enable printer_name

accept printer_name

You can also use other options for the [padmin command. See
your operating system documentation for details. Note that the
printer name must be the same as the one you entered during
WorkCentre Pro 421 installation.

SCO supplies the sam program as an alternative to configure
the printer. When using sam, enter everything as if the printer
were directly connected to /dev/lprprinter/printer_name.

The software installed with your SCO system can satisfy most
of your printing needs. SCO supplies ASCII-to-PostScript
filters and the system invokes them automatically if you define
the content type of the printer as PostScript. The SCO UNIX Ip
system also supplies interface scripts that produce PostScript
banners. Use the Ipfilter command to define new filters and
content types, if necessary.



Printing on AIX RISC System/6000

The AIX printing subsystem is driven by the gdaemon program
which uses configuration information stored in the /usr/lpd/
gconfig file to manage queues and route jobs to the proper
devices. This information includes entries for each virtual
printer and physical device known to the system.

An AlX virtual printer is simply a high-level software view of a
data stream, queue, and device that controls how a given job
is processed. A different virtual printer should be defined for
each data stream that a real printer supports. For example, you
use different virtual printers for PostScript and PCL jobs even
though they are destined for the same physical printer.

Configuring a WorkCentre Pro 421 printer on an AIX system
approximates configuration of a local printer as closely as
possible. The only difference is that the physical device
associated with your WorkCentre Pro 421 printer must be a
named pipe used by the print daemon to route data to the
WorkCentre Pro 421.

To add a printer to your system:
1. Enter the nicinst command to run the installation script.

The script automatically downloads the correct
WorkCentre Pro 421 utilities for your particular system and
prompts you for information as needed.

2. Atthe prompts, enter the node name entered in /etc/hosts
and the printer name.

Your screen now displays the information you provided to
the install script. You are asked to OK this configuration.
Type Yes or No and press Enter.

3. Configure a virtual printer. For the physical device enter
the printer_name (that is, the same printer name chosen
during install).

4. Shut down gdaemon by entering the following command:
stopsrc -s qdaemon

5. Edit /usr/lpd/qconfig to change the special file for the
printer_name device from /dev/printer_name to /dev/nic/
printer_name.

6. Restart the gdaemon by entering the following command:

startsrc -s qdaemon



The installation script then creates the named pipe and starts
the print daemon using the information you supplied. Since the
AIX System Management Interface Tool (smit) does not accept
a named pipe as a printer device, the installation script also
creates a null device in /dev/printer_name.

Using virtual printer commands

You can add virtual printers through SMIT or by using the
mkvirprt command, entering the device name printer_name for
configuration purposes. During this process you also select a
particular printer type for the new printer, which inherits the set
of predefined attributes for that printer type. In most cases, this
set of attributes is sufficient, but it can be changed through
SMIT or by using the chvirprt command. If you need more
extensive changes on your printer, refer to the AIX RISC
System/6000 documentation.

After the virtual printer has been added, there is a stanza in the
lusr/Ipd/qconfig file for device printer_name that looks like the
following:

printer_name:
file=/dev/printer name
backend=/usr/Ipd/piobe

Edit the file and change file=/dev/printer_name to file=/dev/nic/
printer_name.
Output spooled on the virtual printer as defined above, goes to
the named pipe and is routed to the WorkCentre Pro 421.
Before you edit the files listed above, make sure the following
daemon is running:
fust/nic/lpr_print /dev/nic/printer name node name 10001 &
Using AIX print commands
The Ip command on AlX works slightly differently from other
System V Rel. 4 systems. To print on AlX, you can use the
following Ip commands:

lp -d queue name file name

lp -d queue_name:device name file name



Running Telnet

The Telnet utility uses the standard remote terminal protocol to
configure the IP address, Ipd/ Ipr printers, and other
parameters on your system. You have the same functionality
with Telnet as with accessing the WorkCentre Pro 421 HTML
pages with MAP or a Web browser.

Use the following guidelines to run Telnet:

> Typically you make selections from menus by toggling
between one choice or another, by selecting/deselecting or
enabling/disabling an item.

> Press Enter when not selecting an item. This returns you to
a previous menu.

> If you do not make a menu selection for two minutes, you
get a two-minute warning that within two more minutes your
Telnet session ends. This ensures that no one user leaves a
session idle for too long.

Making the connection and accessing the main
menu

1. In the Start>Run dialog or at the DOS prompt, type the
following command:

telnet ip-address

where ip-address is the IP address of the WorkCentre Pro
421,

2. When the login prompt appears, type guest if you are
interested in only browsing the menus, or type sysadm if
you want to change the configuration.

3. When the password prompt appears, again type guest or
sysadm.

The main menu is displayed. This utility lets you change
the IP parameters, lpd/lpr printers, protocols, and
password, and lets you restore to factory defaults.



4. Type the number for the parameter you want to check or
change and press Enter.

1. IP Parameters

. LPD Printers

. Protocols

. Restore Factory Defaults

. Change Password

. Exit

5. To end your Telnet session, type E at the Main Menu.

If you have made any changes you are prompted to either
Save Changes and Exit or Exit Without Saving Changes.
Choose the appropriate option and press Enter.
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Configuring IP parameters

Although the WorkCentre Pro 421 must have an IP address
before a Telnet connection can be made, you can use the
Telnet utility to change the address or the other IP parameters.
The Printer automatically initiates a soft reset when it senses
the IP address change.

To configure IP parameters:

1. Atthe main menu, type 1 and press Enter to display the IP
Parameters menu.

2. Type 1 again and press Enter.
The IP Address submenu is displayed:

1. IP Address 192.168.10.7
2. Subnet Mask 255.255.255.0
3. Default Gateway 192.168.10.12
4. Base Port Number 10000

3. Type the number for the parameter you want to change
and press Enter.



Selecting printer languages

Selection 2 in the main menu lets you designate the emulations
(printer interpreter languages) that the printer supports. This
lets the resident Ipd/Ipr modify files intended for other
emulations so they can be printed. The menu also allows you
to enable or disable banners attached to Ipd/Ipr handled jobs.

The emulation choices are:
> Printer Control Language (PCL)
> PostScript (PS)

> ASCII (simple text)
» Other (any print job not recognized as PCL, PS, or ASCII)

The file modifications and conditions are:

Print Server Setup Job detected as Action
PCL, (PostScript) ASCII <CR> changed to <CR><LF>
PostScript PCL, Other PostScript header added
not PostScript PostScript Job discarded
PostScript ASCII PostScript header added, <CR> changed
to <CR><LF>
PCL, PS, ASCII any No action

To select the printer language:
1. Toaccess the LPD Printers menu, type 2 and press Enter.
For a unit at factory default, the following menu appears.

LPD Printers

1. Printer 1

2. Banners

PCL PS OTHER
DISABLED




2. To change the set of emulations, type 1 and press Enter.
The following options are displayed.

Printer 1 PCL PS OTHER

1. PCL
2.PS

3. ASCII
4. OTHER

3. To delete an emulation, select the number opposite the
language listed and press Enter.

4. From the LPD Printers menu, type 2 to toggle Banners
between Enabled/Disabled.

Enabling/disabling network protocols

To enable network protocols, type 3 at the main menu.

You are given the choice of disabling either NetWare or
AppleTalk since both network OSs are enabled by default. For
example, to disable Appletalk, type 2 and press Enter.

Restoring factory defaults

When you need to restore factory defaults on your print server,
type 4 at the Main Menu and press Enter. All NVRAM stored
parameters are returned to their factory default values. The
factory default values do not take effect until you exit the Telnet
program or the unit is powered off and on.

Changing a password

1. Type 5 at the main menu.

2. Type up to eight characters at the New Password query
and press Enter.

3. Retype the same characters at the Retype New Password
query and press Enter.



4. Choose the Save Changes and Exit option.

Once you have set your password, the sysadm password
is no longer valid.

Exiting Telnet

1. Type E at the main menu.
If you have made any changes, the exit menu is displayed:

Exit
1. Save Changes and Exit

2. Save Changes and Reset

3. Exit Without Saving Changes

2. Choose an exiting option and press Enter.

Using the Internet Printing Protocol (IPP)

Setting up a printer with IPP

Before you set up a printer with IPP configuration on Windows
ME or 2000, install the Microsoft IPP Client (WPNPINS.EXE).
This can be found on the Windows CD and is installed as
standard with Windows 2000. WPNPINS.EXE is not supplied
with Windows 95/98 or Windows NT.

To set up a printer for IPP printing:

1. Assign an IP address to your print server.

2. Reset the print server.

3. Use the ping command to make sure the print server
responds.



Setting up the IPP functions of the printer

You can set up the IPP functions of the printer by using MAP
or a Web browser. For IPP printing, your workstation must
have an IPP client installed (either from Microsoft or a third-
party).

To configure the printer for printing:

1.
2.

Choose Start>Settings>Printers.
Click Add Printer.

The Add Printer wizard appears. Click the [Next] button to
proceed.

Choose the Network Printer option and click the [Next]
button.

On the Locate Your Printer screen, select Connect to a
printer on the Internet or on your intranet and type the
correct printer path.

The format is:

URL: http://ip-addr/:631/Print

where ip-addr is the IP address of the printer. For example:
URL: http://192.168.10.7:631/Print

Click the [Next] button and finish printer setup.
For example, select the appropriate printer type.

Perform a Test Print from your printer and check the printer
for the test page.

The printer configuration is complete.



Installing and configuring the printer driver

Installing from the CD

The printer driver will need to be installed at each workstation
that will use it. There are four ways in which you can install the
driver:

> Using the setup program on the CD.
» Adding a printer.
> Using CentreWare

> From the Windows NT, Windows 2000 or Windows xp
network server.

Once installed, you will need to configure the printer at each of
workstations where you installed the driver.

1. Insert the Printer driver/documentation CD into the CD
drive.

2. Installation should start automatically but, if not, choose
Run from the Start menu, browse to the CD drive, double
click on Setup32 and click OK to start the installation
process.

3. Click on the Language required.

4. Click Printer Drivers and click on Install WorkCentre Pro
421 Printer Drivers.

The installation starts.
5. Read the welcome screen and click the [Next] button.

6. Read the License Agreement and click [Yes] to accept the
terms of the license.

7. Read the ReadMe text displayed and click the [Next]
button.

8. Choose whether you want to continue with the installation
or download the latest printer driver from the internet and
click the [Next] button.

9. Choose Network or Local Printer from the Select
Connection screen according to your connection type and
click the [Next] button.

10. Enter the Network path or browse and select the required



11.
12.

13.

14.
15.

path from the list and click the [Next] button.
Click the [Typical] button.
Click the [Next] button to clear the Information screen.

The files are copied to the hard disk and the installation
completes.

Click the [Finish] button to complete the installation of the
printer driver.

Close the opening dialog.

Configure the printer (see “Configuring the printer” on page
2-99).

Adding a network printer (Windows 95/98/ME)

1.

Choose Settings>Printers from the Start menu.

The Printers dialog is displayed.

Double click on [Add Printer].

The Install Wizard starts.

Click the [Next] button.

Choose Network Printer and click the [Next] button.

Enter the Network path or click on the [Browse] button, and
locate the printer.

Choose whether or not you want to print from MS-DOS
programs and click the [Next] button.

At this point the driver may be downloaded from the
network server and the installation completed.

Otherwise, click the [Have Disk...] button.

Insert the Printer driver/documentation CD in the CD drive.
Browse to the location of the driver. On the CD this is to be

found in the Install>(0S)>(PDL)>(Language) folder,
where:

. OS is the operating system of the workstation,
Windows 9x, Windows 2000, Windows xp or
Windows NT.

. PDL is the Print Description Language, PCL or
PostScript.

. Language is the language in which the driver
functions.



10. Choose the XW421 driver and click the [OK] button.

11.

The files are copied to the hard disk and the installation
completes.

Click the [Finish] button.

Configure the printer (see “Configuring the printer” on page
2-99).

Adding a network printer (Windows NT)

1.

A S

10.

Choose Settings>Printers from the Start menu.
The Printers dialog is displayed.

Double click on [Add Printer].

Choose Network Printer and click the [Next] button.
Choose the network path and click OK.

Choose whether or not you want to print from MS-DOS
programs and click the [Next] button.

At this point the driver may be downloaded from the
network server and the installation completed.

Otherwise, click the [Have Disk...] button.
Insert the Printer driver/documentation CD in the CD drive.

Browse to the location of the driver. On the CD this is to be
found in the Install>(0OS)>(PDL)>(Language) folder,
where:

e OSis the operating system of the workstation,
Windows 9x, Windows 2000, Windows xp or
Windows NT.

. PDL is the Print Description Language, PCL or
PostScript.

. Language is the language in which the driver
functions.

Choose the XW421 driver and click the [OK] button.
The files are copied to the hard disk and the installation
completes.

Click the [Finish] button.

Configure the printer (see “Configuring the printer” on page
2-99).



Adding a network printer (Windows 2000)

1.

o~ N

10.

11.

Choose Settings>Printers from the Start menu.
The Printers dialog is displayed.

Double click on [Add Printer].

Choose Network Printer and click the [Next] button.
Choose the network path and click OK.

Find the printer in the directory. Either type the printer
name or click the [Next] button to browse for the
appropriate printer name (this is the recommended
procedure).

Choose whether or not you want to print from MS-DOS
programs and click the [Next] button.

At this point the driver may be downloaded from the
network server and the installation completed.

Otherwise, click the [Have Disk...] button.
Insert the Printer driver/documentation CD in the CD drive.

Browse to the location of the driver. On the CD this is to be
found in the Install>(0S)>(PDL)>(Language) folder,
where:

. OS is the operating system of the workstation,
Windows 9x, Windows 2000, Windows xp or
Windows NT.

. PDL is the Print Description Language, PCL or
PostScript.

. Language is the language in which the driver
functions.
Choose the XW421 driver and click the [OK] button.

The files are copied to the hard disk and the installation
completes.

Click the [Finish] button.

Configure the printer (see “Configuring the printer” on page
2-99).



Adding a network printer (Windows xp)

1.

10.

1.

Choose Control Panel>Printers and Faxes from the
Start menu.

The Printers and faxes dialog is displayed.
Double click on [Add Printer].

The Add Printer Wizard is displayed.

Click the [Next] button.

Choose A network printer or a printer attached to another
computer and click the [Next] button.

Specify the printer to connect to and click the [Next] button.

You can browse the network for the printer, enter the
network printer name or enter a URL where the printer can
be found (this is the recommended procedure).

Choose whether or not you want to print from MS-DOS
programs and click the [Next] button.

At this point the driver may be downloaded from the
network server and the installation completed.

Otherwise, click the [Have Disk...] button.
Insert the Printer driver/documentation CD in the CD drive.

Browse to the location of the driver. On the CD this is to be
found in the Install>(0S)>(PDL)>(Language) folder,
where:

. OS is the operating system of the workstation,
Windows 9x, Windows 2000, Windows xp or
Windows NT.

. PDL is the Print Description Language, PCL or
PostScript.

. Language is the language in which the driver
functions.

Choose the XW421 driver and click the [OK] button.

The files are copied to the hard disk and the installation
completes.

Click the [Finish] button.

Configure the printer (see “Configuring the printer’ on page
2-99).



Configuring the printer

Configuring the printer will vary according to the operating
system used. For ease of use and clarity, the procedures are
separated into:

» Windows 95/98/ME
» Windows NT
» Windows 2000

> Windows xp



Windows 95/98/ME

®erox WorkCentre Pro 421 PCL Se Properties
QOverlays Fonts I watermarks I About I
General | Dietails I Paper/Output I Lapout I Image Options I PFrinter Configuration

“%  Merox WorkCentre Pro 421 PCL Be

Print out a status page to see the installed options (see
“Printing a status page” on page 2-2)

Choose Settings>Printers from the Start menu.

The Printers dialog is displayed.

Point to the Xerox WorkCentre Pro 421 icon, click the right
mouse button and choose properties from the menu or
choose Properties from the File menu.

The Properties dialog is displayed with the General tab
open.

The General tab lets you enter any relevant comments,
generate a separator page to be inserted between jobs or
print a test page.

LComment:

Separator page: |[aE)]

Browse...

Print Test Page

ak. I Cancel | Apply | HElE |

This dialog has ten other tabs used to configure the printer.

5. Click the Printer Configuration tab.



The Printer Configuration tab is used to configure the
installed options in order to make them available to users.
Check the status page previously printed to see which
options have been installed.

Herox WorkCentre Pro 421 PCL 5e Propeirties

6. Check the boxes relating to the options installed on the
WorkCentre Pro.

7. Click the Paper/Output tab
The Paper Output tab lets you determine how the job will
be printed.
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Herox WorkCentre Pro 421 PCL 5e Properties

Offset Function CFf .

o N —

Standard Bin

__ Dol | Deuis |
[ o ] e | e |

8. Choose the default Output functions required.

9. Make changes to the remaining tabbed pages as required.
Refer to the on-line help for details.

Each of these are described below.
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Herox WorkCentre Pro 421 PCL 5e Propeirties

Network Setup

LPT1: [ECF Printer Port]

The Details tab lets you change the connection and driver
details for the printer.

The Layout tab is used to determine how a job will be
imposed on the paper (PostScript only).
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Herox WorkCentre Pro 421 PCL 5e Properties

The Image Options tab lets you determine the output
quality for individual job components.

The Overlays tab lets you manage the overlays that will be
applied to a print job when selected.
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Herox WorkCentre Pro 421 PCL 5e Properties

—

Mo fonts installed

The Fonts tab lets you manage the fonts that will be
downloaded to your printer.

The Watermarks tab lets you choose and position a
watermark that will be applied to your printed jobs.

Network Setup
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Xerox WorkCentre Pro 421 PCL 5e Properties

e

workeentre

PRO 421

The About tab provides information about the printer
driver.

10. Click the [Apply] button to save your configuration.
11. Click the [OK] button to close the dialog.

Windows NT

Configuring the printer for Windows NT requires you to set the
Printer Properties and the Document Defaults.

NOTE: At installation, it is important to configure the printer
options or they will not be available to application programs.
This is carried out under printer properties. It is also important
to define the default settings for the paper in the printer and for
how the printed output will be delivered.
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Setting the printer properties

1.

Print out a status page to see the installed options (see
“Printing a status page” on page 2-2)

Choose Settings>Printers from the Start menu.

The Printers dialog is displayed.

Point to the Xerox WorkCentre Pro 421 icon, click the right

mouse button and choose Properties from the menu or
choose properties from the File menu.

The Properties dialog is displayed with the General tab
open.

The General tab lets you enter any relevant comments,
state the physical location of the printer, choose or load a
new driver generate a separator page to be inserted
between jobs or print a test page.

QXemx WorkCentre Pro 421 PS5 Froperties HE

Security
General

y erox WaorkCentre Pro 421 PS

I Device Settings I Configuration I
Farts I Scheduling I Sharing

LComment:

Location: I

Driver: IXerox wéork Centre Pro 421 PS j Mew Driver... |

Separator Page. .. I Frint Processor... I Print Test Page I

Ok I Cancel I

This dialog has six other tabs used to configure the printer.
Click the Printer Configuration tab.

The Printer Configuration tab is used to configure the
installed options in order to make them available to users.
Check the status page previously printed to see which
options have been installed.



# Xerox WorkCentre Pro 421 PS Properties EHE

o Geneal | Pots | Scheduing | Shaig |

I
I
I
I
I

6. Check the boxes relating to the options installed on the
WorkCentre Pro.

7. Make changes to the remaining tabbed pages as required.
Refer to the on-line help for details.

Each of these are described below.
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erox WorkCentre Pro 416 PS Properties HE

Security | Device Settings | Corfiguration |
General Parts | Scheduling I Sharing

Herox WorkCentre Pro 416 PS

Frrirt to the following portfs]. Documents will print to the first free

checked part
Fart | Description | Frinter |:|
[J13.211.108.148:...
Cl1azit0ater. . J
[ EeReh =R =

[J13.211.108.117....

HerowWorkCenlre

|_amal Part j

Add Part.... Delete Part LConfigure Part... |

I= | Enatile Bidiestiona suppor
™ Enatle pritter pacling

Cancel |

The Ports tab lets you choose the ports to print to. You can
add a new port, delete an existing port and configure a port
from this tab.

# Zerox WorkCentre Pro 421 PS Properties HE
Security I Device Settings | Configuration I
General | Parts Scheduling | Sharing
Available: o~ H

€ From ’|12:DDAM:| To [1z:00 8 =]

Frriorit

Lowest J Highest

Current Priority: 1

€ Spool print documents so program finishes printing faster
" Start printing after |ast page is spooled

% Start printing immediately

= Print directly to the printer

™ Hold mismatched documnerts
™ Print spooled documents first

™ Keep documents after they have printed

Ok I Cancel |

The Scheduling tab is used to determine how jobs will be
scheduled to the printer.



# Zerox WorkCentre Pro 421 PS Properties

Wwindows 95
‘windows MT 4.0 x86 [Inztalled)
“windows NT 4.0 MIPS

The Sharing Options tab lets you set the printer to be
shared or not shared across the network.

The Security tab lets you manage the security aspects of
the printer.
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# Zerox WorkCentre Pro 421 PS Properties HE

General I Parts | Scheduling I Sharing I
Securty Device Settings I Configuration
ﬁg Herox WoarkCentre Pro 421 PS Device Settings -

E@ Form To Tray Assignment

@ Autn Select: A4

@ Trap 1: <Ads

@ Trap 2 <Moot Available:

LA Tray 3 <Mat Available:

[]..@3 Font Substitution T able

g Awvailable PostScript Memony: <3713 KB

&i Output Pratocaol: <A5CI:

----- K_ Send CTRL-D Before Each Job: <Mox LI

= Ehange T anual Feed] Setting

& Mot Available

@ =] 10214
By 117
[E1 210 330 mm

Bl -

Ok I Cancel |

The Device settings tab lets you manage the forms and

fonts that will be downloaded to your printer.
8. Click the [OK] button to close the dialog.

Setting the document defaults

1. Print out a status page to see the installed options (see
“Printing a status page” on page 2-2)

2. Choose Settings>Printers from the Start menu.

The Printers dialog is displayed.

3. Point to the Xerox WorkCentre Pro 421 icon, click the right
mouse button and choose Document defaults from the
menu or choose Document Defaults from the File menu.

4. The Default Document Properties dialog is displayed with

the Page Setup tab open.

The Page Setup tab lets you determine the default print
settings that will be used by the printer.



%% Xerox WorkCentre Pro 421 PS Default Document Properties i E3

Page Setup | Advanced I

Paper Size: RG] 'l

Paper Source: I é Automnatically Select j
2
LCopy Count: 1 3: Copy 'v] "} Callate Eopies
[1-9939)
Orientation

& Poitrait ' Landscape " Rotated

Cancel |

This dialog has one other tab used to configure the
advanced settings for the printer.

5. Click the Advanced tab.
The Advanced tab is used to configure the WorkCentre
Pro.

(‘! Xerox WorkCentre Pro 421 PS Default Document Properties [ B4

Page Setyp  Advanced |

k&, Xenos Work Centre Pro 421 PS Document Settings =
EQQ Paper/Output

Oiientation: <Portraity
é Paper Source: <Automatically Select>
@ Media: <Plain Paper:
Copy Count: <1 Copy»
=1-[a] Graphic
Resolution: <E00xE00 dpix
[ Sealing: <100 %>

l% TrueType Font: <Substitute with Device Fants ;I
— Change 'Paper Size' Setting
210 % 330 mrm -
i3 B
A5 J

B-JIS[257mm % 36dmm]
B5-JIS[182mm % 257mm] =l

Cancel

6. Click the [OK] button to close the dialog.




Windows 2000

Configuring the printer for Windows 2000 requires you to set
the Printer Properties and the Printing Preferences.

Setting the printer properties

1.

Print out a status page to see the installed options (see
“Printing a status page” on page 2-2)

Choose Settings>Printers from the Start menu.

The Printers dialog is displayed.

Point to the Xerox WorkCentre Pro 421 icon, click the right

mouse button and choose Properties from the menu or
choose properties from the File menu.

The Properties dialog is displayed with the General tab
open.

The General tab lets you enter any relevant comments,
state the physical location of the printer, choose or load a
new driver generate a separator page to be inserted
between jobs or print a test page.



QXemx WorkCentre Pro 421 PS5 Properties EHE

Security I Device Settings I Configuration I
General | Ports I Scheduling I Sharing

y Herox WorkCentre Pra 421 PS

LComment:

Location: I

Driver: IXerox workCentre Pro 421 PS j Mew Diriver... |
Separator Page... | Frint Processor... | Frint Test Page |

()8 I Cancel |

This dialog has seven other tabs used to configure the

printer.
5. Click the Configuration tab.

The Configuration tab is used to configure the installed
options in order to make them available to users. Check
the status page previously printed to see which options

have been installed.



&% IMOLA-01_0Q on PICASSO Properties il |

General I Sharing I Ports Advanced |
MNefw/are Settings I Security I Device Settings Configuration

Installable Options

I~ Trap2

I~ Tray3

™ Bypass Trap

I Duplex

I Dffset Catch Tray

THE DOCUMENT COMPANY
XERCX VYersion 1.12.0.0

oK I Cancel | Apply |

6. Check the boxes relating to the options installed on the

WorkCentre Pro.

7. Make changes to the remaining tabbed pages as required.
Refer to the on-line help for details.

Each of these are described below.

&% IMOLA-01_0Q on PICASSO Properties el |
General | Sharing I Ports I Advanced I
Meti/are Settings | Security I Device Settings I Configuration
— Dutput Setting:
Mumber of copies: =
Type of form: | LI
I Form feed

I~ Enable tabs Murnber of spaces: IS _l;

— Banner Setting:
™ Enable banner

15t banner name: I

2nd banner name: I

— Other Setting:
I~ Haold
I~ Keep
¥ Matify

0K I Cancel Apply




The Netware Settings tab lets you set default values for
copies, forms, banners and what happens after

processing.
%" IMOLA-01_0Q on PICASSO Properties 2=l
General I Sharing I Ports I Advanced I
Metware Settings Security | Device Settings I Configuration
Mame | add
€7} CREATOR DWNER ml
!ﬁ Everyone

!ﬁ Power Uzers [LOCSYS114Power Uzers)

Permizzions: Allow Deny
Frint O
Manage Printers O
Manage Documents O

Advanced.. |

QK I Cancel | Apply |

The Security tab lets you manage the security aspects of
the printer.

From this tab you can click the [Advanced] button to set a
number of printer defaults.




&% IMOLA-01_0 on PICASSO Properties x|

General I Sharing | Ports | Advanced I
Metwiare Setings I Security Device Settings | Configuration

ﬁs Herow WorkCentre Pro 421 PS Device Sethings
|_5_| @ Forrn Tao Tray Assignment

Manual Feed: I Mok Available =l
Auto Seleck: A4
Tray 1 &4

Tray & Mot Available
Tray 3¢ Mok Available
Fonk Substitution Table
- Available PostScript Memory: 3713 KB
Oukput Protacal: ASCIT
Send CTRL-D Before Each Job: No
Send CTRL-D After Each Job: Yes
Job Timeout: 0 seconds
- Walt Timeout: 300 seconds
Minimurm Fonk Size ko Download as Qutline: 100 pixel(s)
- Maximum Font Size to Download as Bitmap: 600 pixel{s)
Installable Options
- Memory Configuration: 16 ME RAM

oK I Cancel | Apply |

The Device settings tab lets you manage the forms and
fonts that will be downloaded to your printer.

&% IMOLA-01_0Q on PICASSO Properties el |
Metware Settings | Security | Device Settings I Configuration I
General Sharing | Parts I Advanced
IMOLA-01_0
' Not shared
" Shared as:

Drrivers for different versions of Windo

If this printer is shared with users running different versions of
‘Windows then you will need ta install additional drivers for it.

Additional Drivers |

0K I Cancel | Apply |

The Sharing Options tab lets you set the printer to be
shared or not shared across the network.



&% IMOLA-01_Q on PICASSO Properties el |

Metwfare Settings I Security Device Settings I Configuration I
General I Sharing Parts Advanced

IMOLA-01_0

Print to the following port(z). D ocuments will print to the first free
checked part.

Port | Drescription | Frinter |;|
O CoM1: Serial Part
O coMz Serial Part
O com3:  Serial Port
O COM4:  Serial Port
O FIL Frint to File

Add Port.... [elete Port Configure Fart...

I™ | Enable bidirectional support
I™ | Enable printer pooling

oK I Cancel | Apply |

The Ports tab lets you choose the ports to printto. You can
add a new port, delete an existing port and configure a port
from this tab.

&% IMOLA-01_Q on PICASSO Properties el |
Metwfare Settings I Security I Device Settings | Configuration |
General I Sharing I Parts Advanced

i+ Always available
= Awailable from IUU:UU j‘ To IDD;DU j‘

Priority: |1 _|:;'
Driver: IXerox ‘whorkCentre Pro 421 PS LI Mew Driver... |

* Spool print documents o program finishes printing Faster

" Stark printing after last page is spooled
% Start printing immediately

" Print directly to the printer

™ Held mismatched documents
I Prirt spocled documents first
™ Keep printed documents

¥ Enable advanced printing features

Printing Defaults... | Print Processar... | Separatar Page... |

0K I Cancel | Apply |

The Advanced tab is used to determine how jobs will be
scheduled and spooled to the printer.




8. Click the [OK] button to close the dialog.

Setting the printing preferences

1. Print out a status page to see the installed options (see
“Printing a status page” on page 2-2)

2. Choose Settings>Printers from the Start menu.
The Printers dialog is displayed.

3. Point to the Xerox WorkCentre Pro 421 icon, click the right
mouse button and choose Printing Preferences from the
menu or from the File menu.

4. The Printing Preferences dialog is displayed with the
Layout tab open.

The Layout tab lets you determine the default rotation and
number of pages to be printed.

ﬁ' IMOLA-01_0) on PICASSO Printing Preference: ﬂﬂ

Layout | Paper/Quality I

Orientation

& Portrait

" Landscape

" Rotated Landscape

Pages Per Sheet: I 1 'l

QK | Cancel | Apply |

From this tab you can click the [Advanced] button to set a
number of printer defaults.

This dialog has one other tab used to configure the
advanced settings for the printer.

5. Click the Paper Quality tab.



The Paper Quality tab is used to determine the default tray
selection and type of media that this contains.

%% IMOLA-01_Q on PICASSO Printing Preferences 2=l

Layout  Paper/Quality |

Tray Selection
Paper Source: &5 Automatically Select
Media: Flain Paper j

Advanced.. |
QK I Cancel | Apply |

6. Click the [OK] button to close the dialog.

Windows xp

Configuring the printer for Windows xp requires you to set the
Printer Properties and the Printing Preferences.

Setting the printer properties

1. Print out a status page to see the installed options (see
“Printing a status page” on page 2-2)

2. Choose Control Panel>Printers and Faxes from the
Start menu.
The Printers dialog is displayed.

3. Point to the Xerox WorkCentre Pro 421 icon, click the right
mouse button and choose [Properties] from the menu or



choose properties from the File menu.

The Properties dialog is displayed with the General tab
open.

The General tab lets you enter any relevant comments,
state the physical location of the printer, choose or load a
new driver generate a separator page to be inserted
between jobs or print a test page.

& Xerox WorkCentre Pro 421 PCL6 Properties

General |Sharing Portz || Advanced | Color Management | Printer Configuration || About

Location: |

LComment; ‘

Features

Color: Yes
Double-sided: Mo
Staple: Unknown
Speed: Unknown

M axirum resolution: 1200 dpi

Model: erox WorkCentre Pro 421 PCLE

FPaper available:

Frinting Preferences...] [ Print Test Page ]

[ Ok ][ Cancel ]

This dialog has six other tabs used to configure the printer.
Click the Printer Configuration tab.

The Printer Configuration tab is used to configure the
installed options in order to make them available to users.
Check the status page previously printed to see which
options have been installed.



& Xerox WorkCentre Pro 421 PCL6 Properties

General | Sharing | Ports

Advanced EolorManagement| Prirter Configuration | About

Inztallable Options

Memary [ME]:
16 MB -

-
[ Bypass Tray

™ Duplex [2 Sided Printing] Maodule
[ Offset Catch Tray

THE DOCUMENT COMPANY
HERCH

o) (oo ]

6. Check the boxes relating to the options installed on the
WorkCentre Pro.

Make changes to the remaining tabbed pages as required.
Refer to the on-line help for details.



Each of these are described below.

& Xerox WorkCentre Pro 421 PCL6 Properties

General| Sharing |F'orts Advanced | Color Management | Printer Configuration | &bout

5
E;::'\é Herox WorkCentre Pro 421 PCLE

Az a security measure, Windows has disabled remote access to this

computer. Howewver, coess and safely share
printers by runking the

If you understand the security risks but want to share printers without
1unning the wizard, click here.

l oK H Cancel ]

The Sharing tab lets you set the printer to be shared or not
shared across the network.



& Xerox WorkCentre Pro 421 PCL6 Properties

| General | Sharing| Ports |Advanced | Color Management | Printer Canfiguration | About |

5
E‘{é Herox WorkCentre Pro 421 PCLE

Frint to the following port[z). Documents will print to the first free
checked port.

|

Part Description Frinter
O LPTZ: Prirter Port
O LPTZ  Printer Part
I comt: Serial Port L3
O oMz Serial Part
O comM2: Serial Port

[J comM4: Serial Port bl
[ Add Port... ] [ Delete Part ] [ LConfigure Port...
Enable bidirectional suppart
[ Enable printer poaling
I ok l [ Cancel ] Apply Help

The Ports tab lets you choose the ports to printto. You can
add a new port, delete an existing port and configure a port

from this tab.



& Xerox WorkCentre Pro 421 PCL6 Properties

General | Sharing | Ports | Advanced | Color Management | Printer Configuration | About

@@l
O Awvailable from

1 “

Pricrity:

Diiger: [ eron WorkCentre Pro 421 PCLE v

(&) Spoal print documents so program finishes printing Faster
() Start printing after last page is spoaled
(&) Start printing jrmediately

() Print directly to the prinker

[ Hold mismatched documents

Fiint zpooled documents first

[ Keep printed documents

Enable advanced printing features

[ Printing Defaults... ][ Print Processor... ][ Separator Page... ]

[ Ok ][ Cancel ]

The Advanced tab lets you determine how jobs will be
scheduled and spooled to the printer and manage all
aspects of printing. Pressing the Printing Defaults button
will give rise to a multiple tabbed page which allows you to:

¢ set spooling requirements

. how the paper will be output

. how the image will be laid out on the page
¢ set a number of image options

. define watermarks



& Xerox WorkCentre Pro 421 PCL6 Properties

General | Sharing | Parts Advanced| Colar Managernent |Printer Configuration | Abaut

& Thee settings let vou azzociate colar prafile(z] with yaur colar
| printer. Color profiles control the colar on waur plinte_r bazed on the

type of media being uzed and the printer configuration.

windows will automatically select the best calor profile from
the list of associated color profiles [Recommended]

o @

=

anual  Manually select the default colar prafile for all output fram
thiz device from the list of aszociated calor profiles

Default color profile;— <Nonex

Color Profiles currently associated with this printer:

Add...

l oK H Cancel ]

The Color Management tab is used to determine the
appropriate color profile to be used.

8. Click the [OK] button to close the dialog.



Making a test print from a workstation

1.

Make sure that the driver is installed and configured on
every workstation that will be sending jobs to the
WorkCentre Pro 421 (see “Installing and configuring the
printer driver” on page 2-94).

Open a document on a client workstation.

Select the WorkCentre Pro 421 as the printer to which you
want to send the selected document.

Print the document on the WorkCentre Pro 421 and verify
that it prints correctly.

Repeat the test for all workstations that will be sending jobs
to the WorkCentre Pro 421.
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3 Remote Configuration

This chapter provides information on external facilities
provided to let you configure the printer remotely.

There are three external facilities provided:

1. CentreWare

2. CentreWare Internet Services

3. Xerox PrinterMap

The procedures are described in this chapter.



Using CentreWare

Xerox CentreWare is the easy-to-use group device discovery
and management software for Xerox printers and multiple-
vendor devices with embedded web servers. Thanks to the
ease of point-and-click navigation, you will be able to install,
connect, and configure Xerox network devices immediately
and quickly. Xerox CentreWare makes use of the Microsoft
Management Console (MMC) as the framework for interface
functionality. Xerox CentreWare has Electronic Help available
at all times by simply pressing Fl or clicking the Help button.

The CentreWare software for the WorkCentre Pro 421,
communicates through the Network connection.

For information concerning CentreWare, refer to the Online
Help feature or the documentation found on the CentreWare
CD. If you prefer, a User Guide in several languages is
provided in pdf form on the Printer Management software CD
in the \Doc\ folder. Please take a minute to examine this
software. You will be pleasantly surprised at how easy the
installation of your printer on your network can be.

Advanced setup in Bindery Mode or for NDS
(NetWare Directory Services) network

The Advanced Setup option of CentreWare gives you an
additional tool to control how your printers are configured in
your Novell NetWare network environment. This tool is only
necessary for connecting your printer to more than one file
server or queue.

Netware (NDPS/ NEPS) Novell Distributed Print
Services™

In order to access Xerox printers in this environment you will
need the Xerox Gateway software installed on your system.
The latest version of the Xerox Gateway Software is available
on the Xerox Web site, www.xerox.com

Instruction are available on the web site on how to install your
printer for use with NDPS. They are contained in the
CentreWare for NDPS User Guide.



Using CentreWare Internet Services

CentreWare Internet Services is an interactive service that
uses Internet technology to extend the capabilities of your
WorkCentre Pro 421. An HTTP server application developed
by Xerox is resident, on your network-enabled WorkCentre Pro
421. This HTTP server provides access to advanced services
for the installation, configuration, and management of your
WorkCentre Pro 421.

The features of CentreWare Internet Services can be
accessed through client-resident software interfaces such as
Netscape Navigator or Microsoft Internet Explorer version 3 x,
or later, browsers. A browser allows users access to a
WorkCentre Pro 421 on a network through the HTTP server by
using the TCP/IP protocol.

You will need to access information in all of the chapters of this
document, to initially select options, and change others as
desired.

To perform administrative tasks, you must have access to your
network and possess System Administrator (Admin) rights for
the WorkCentre Pro 421. In addition, you should refer to the
User and this guide for more information about your printer.
You may also need information from sources provided by
network and client workstation vendors.

System Administrators with proper Admin rights can perform
the following activities using Internet Services:

> Cause the WorkCentre Pro 421 to print status and test
pages.

» Monitor the status of the WorkCentre Pro 421 and the
network.

> Configure the network setting on the WorkCentre Pro 421.

> Reset the WorkCentre Pro 421 parameters and change the
access password.

> Go to internet links providing support and assistance.

> Access Help and Documentation information for your
printer.



Accessing CentreWare Internet Services

To gain access to the WorkCentre Pro 421 from a workstation:

1.
2.

Start your network browser.

Enter the printer's IP address as the URL (Universal
Resource Locator) in your browser's Address or Location
field.

The IP address is printed on the Status page.
The WorkCentre Pro 421 Home page is displayed.

rox WorkCentre Pro 416 - Printer Home - Microsoft Internet E xplorer

Internet Services

Pro 421

Name: Xerox
WorkCentre Fro

IP: 13.210.125.98
Location:
Status: ldle

|N0ne

-

Xerox WorkCentré

Festures
B001200 dpi Monochrome Laser
Frinting

FCL & Printer Language

FCL Se Printer Language
FostScript 2 Language

Hetwork Enabled [10/100 BaseT)
Eurcpean Paper Sizes from A5 to A%

Morth Arnerican Paper Sizes to 11"<17"

Metwork Print and Copy [421 P, 421 Fi)]
Frint, Copy, Soan (421 5]

Optional Features
Single or 3 tray configurations
1ZEME of additional RAk
Conwenience Stapler

IFF
Internset Prirting Protocol
Unternet Printing Installation]

& & ¢ €

=

J Fil=  Edit “Wiew Favorites  Toolz Help |
R o B
Back Farsand Stop Refresh Home Search Fawvoritez  History Frint
| Addiess [ hitpe13.210.128.98/homel =] @5o |J Links >
CentrelWare = =

Printer
Index

e

Print

print st=tustest pages

Status

check status

Properties

wiewe and set properties

Maintenance

reset printer / change password

Assistance

assistance and support links

Refresh
Status

THE DOCUMENT COMPANY
XEROX
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Corporation. Any other named products profiled herein are trademars of their
respective companies.

?J help

[ [ [EE Local intranet G




i
Click to access the CentreWare Internet
Services on-line user documentation.

F-
Click - to refresh the screen after changes have

been made.

The CentreWare Internet Services home page for the
WorkCentre Pro 421 is divided into the following application
pages, or tabs:

> Print

> Status

> Properties

> Maintenance

» Assistance.



Print page

1. Click @ from the home page or click the [print] tab
from any other page. The print page is displayed.

43 Xerox WorkCentre Pro 416 - Network Print Dptions - Microsoft Internet Explorer

J Fil=  Edit “iew Favaortes Toolz Help

= s @D | 8 G 8o
Back Eanward Stop Refresh Home Seach Favortes  History Print
| Address [&] hitp:213.210.128.98/prirt_options | @G0 |J Links
CantreWare_‘ . .:r) =
Internet Services | = ) Printer & . Printer
Xerox WorkCentre " Home L& Index
Pro 421

([~ pm | mmm ) sroneotes |malmenance | smimance

Network Print Options

NIC Settings
Print Status Page on Startup ~
LPD Settings
Enable LED Banner r
Name: Xerox
WorkCentre Pro
IP: :‘Iig_‘]210_ 128.93 A password is required to perform this function

Location:

Status: |dle I
Mane
; Apply | Clearl

Refresh
Status Print Status Page | Print Demo & Faonts Page |

Copyriaght @ Xerow Cofperation 1907, 1668, 1000, 2000, 2001, All Aghts reserved.
o . XERO#®, The Decument Company® and the stylized . are trademaris of XEROX =
THE DOCUMENT COMPANY N - N -
enort . CORFORATION. Produst and service names profiled herein are trademans of Xerax f) help
Corparation. Any other named products profiled harein are trademaks of thair

=l
|@ ,_ ,_ =5 Local intranet .

From here you can cause the WorkCentre Pro 421 to
print a status page on start up, insert an LPD banner
sheet between jobs and print a status page or test page.



2. Enter your password. The default password is “sysadm”
A. Check the Print Options boxes.
B. Click the [Clear] button to clear any settings made.
C. Click the [Apply] button to apply your print options.
D

Click [Print Status Page] or [Print test Page] to submit
this job to the WorkCentre Pro 421.

3. If the page is automatically refreshed, reset the network
interface to implement the changes (see “Maintenance
page” on page 3-11 for details).



Status page

1. Click y from the home page or click the [status] tab
from any other page. The status page is displayed.

4} Xerox WorkCentre Pro 416 - Unit Information - Microsoft Internet Explorer
J File Edit iew Fawvorites Toole Help |
& s @D AN B
Back FEaward Stop  Refresh  Home Search Favortes  History Frint
| Address [&] hitp//13.210.128 98/info =] @60 |J Links >
CentrelWare . . '.&} =
Internet Services | & ) Printer & . Printer
Xerox WorkCentre “ Home L& Index
Pro 421
print status \E properties }mainte \E assistance ]
(7 unit information (" network status
Unit Information
Printer Herox WorkCentre Pro 421
Printer Status Ldle
Error Message Mone
Printer Message Printer Ready
Name: xerox
WorkCentre Pro
1P 13.210.128.98 ROM Version 6.234 XB
Location:
Status: |dle NIC Serial Number | 108898
Mone
; MAC Address 00:20:91:2La%62
F“ Refresh Network Speed 10 Megabitsisec
Status
Copyright @ Xerox Corperation 1997, 1988, 1999, 2000, 2001. All rights reserved.
3]

|
l_l_ 25 Local intranet i

The Status page, or tab, provides information on the
status of the WorkCentre Pro 421 or the network.

2. Click the appropriate radio button in order to view the
status information that you require.




Properties page

1
% an

1. Click u from the home page or click the [properties]
tab from any other page. The properties page is displayed.

3 Xerox WorkCentre Pro 416 - TCP/IP Configuration - Microsoft Internet Explorer

J Fil=  Edit “iew Favaortes Tools Help |

.- D A= e .

Back Fariard Stop Refresh  Home Search Favorites  History Frint
| Address [@]1 hitp./13.210.128 98/cpip | @60 |J Links
CentrelVare .:r =

et Serpices 5

Internet Services | & ) Printer B & Printer

Xerox WorkCentre 0 Home LS index
Pro 421
f print \E status T properties \Emaintenance\g assistance ]

@ teplip (I netware () appletalk (lipp printer

TCP/TIP Configuration

IP Settings
P Address |'|3 _|2'IE| _I'IZB _IQB
Subnet hask |255 ) |255 ) |252 ) ID e
Default Gateway |13 B 3 O ] _|1
Name: serox Base Port Number 9099
WarkCentre Pro
421
IP: 13.210.1258.98
Location: Print Services
Status: [dl
s e Enable Sockets I
Paper Empty
Enable LFD I
Refresh
i o rest Enable TPP 4
Enable FTP Server I =l
|@ Done ’7’7 25, Local intranet L

This page is used to set or change the TCP/IP, Netware,
Appletalk or IPP Printer properties for the WorkCentre
Pro 421.



I

i

Enter your password. The default password is “sysadm’
Click the appropriate radio button.

Enter or change the information displayed as required.
Click the [Clear] button to clear any settings made.
Click the [Apply] button to apply your new settings.

If the page is automatically refreshed, reset the network
interface to implement the changes (see “Maintenance
page” on page 3-11 for details).



Maintenance page

1. Click M from the home page or click the

[maintenance] tab from any other page. The maintenance
page is displayed.

4} Xerox WorkCentre Pro 416 - Reset - Microzoft Internel Explorer

J File Edit “iew Favortes Toolz Help |
. =
- > . D a | Q | S
Back Fanvard Stop Refresh Home Search Fawvorites  History Print
J Address I@ hittp: /413,210,128 98/ reset

CentreWare

Pro 421

. i =
Internet Services | —
Xerox WorkCentre

-

=] @5o ||Links >

(2

Printer
Index

& ¢ Printer
J',s Home

oY

status \E properties Tmaimenance\E assistance \I

(I reset network interface () change password ()remote access

Name: Xerox

41
IP:
Location:
Status: dle

Refresh
Status

wem

WarkCentre Pro

13.210.128.98

Reset
A password is required to perform this function

—

Feset | Festore Factory Defaults
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The Maintenance page, or tab lets you reset the network
interface, reset the factory defaults, change your
password or disable remote maintenance access.

The Reset button lets you reset the print server to allow
newly set parameter values to take effect. Reset does
not re-initialize the interface with the printer. The
network interface, however, is fully re-initialized.



TmMO O W

A.
B.

C.

Most of the settings done through the web pages
change values in non-volatile memory, but do not
change the currently used values. When a setting is
made, requiring a reset to take effect, has been
accepted by the network interface, the displayed page
will be refreshed automatically indicating that the printer
should be reset for the change to take effect. In general,
all desired changes should be made before resetting the
printer network interface.

For the Network Interface:
Click the [reset network interface] radio button.

Enter your password. The default password is
“sysadm”

Click the [Reset] button to reset the network interface
or the [Restore Factory Defaults] button to reconfigure
the printer to its original settings.

To change your password:
Click the [change password] radio button.
Enter your old password.
Enter a new password.
Retype the new password to confirm it.
Click the [Clear] button to cancel the process.
Click the [Apply] button to set your new password.

To disable remote maintenance access:
Click the [remote access] radio button.

Enter your password. The default password is
“sysadm”

Click the [Disable] button to prevent remote
maintenance access.



Assistance page

1. Click éﬁ

from the home page or click the [assistance]

tab from any other page. The assistance page is displayed.

=) Xerox WorkCentre Pro 416 - Assistance - Microsoft Internet Explorer

J File Edit Miew Favoites JTools Help

J<:=v->-

@ [ @ | A Gd S

Pro 421

Back Foryard Stop  Refiesh  Home | Search Favortes  History Print
| Address [&]7 witpesn13.210128 98/5ssist =] 6o |J Links >
CentrelWare = =
" - i < »
Internet Services | — E) Printer & Printer
Xerox WorkCentre % Home & Index

o )

status \E properties \Emaintenance]’ assistance |

Name: Xerox

421

Location:
Status: ldle

- Refresh
Status

WarkCentre Pro

IP: 13.210.128.93

Assistance

Printer Registration
‘ Register Printer ‘

Product Home Pages
WorkCentre Pro 421 Product Horme Page
Internet Sewvices Home Page

Software Upgrades

Printer Drivers
Printer Software

Documentation

User Documentation
Technical Documentation

Supplies
‘ Printing Supplies
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The Assistance page, or tab, provides a listing of links to
websites that can be accessed directly from this page.



The links include:
* The ability to register the WorkCentre Pro 421.

 Alink to your WorkCentre Pro 421 product home page, or
pages.

* Links to printer driver and printer software upgrade sites.
* Links to access the product documentation.
2. Click the appropriate link.



Using Xerox PrinterMap

Xerox PrinterMap is an administrative and management
software platform providing access to a heterogeneous printer
environment at the enterprise level. PrinterMap delivers
expanded capacity for network personnel by giving the
operator a graphical topology, and granting easy access to
status and report information for every SNMP-enabled
enterprise network printer.

Plug-ins for Unicentre and Tivoli are provided with this
software.

Xerox PrinterMap has Electronic Help available at all times by
simply pressing Fl or clicking the Help button.
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4 Glossary

10Base2

10BaseT

100BaseT

ASCII

DHCP

Driver

Ethernet

Ethernet Address

File Server

A cable used for networking. It is a coaxial cable consisting of a
centre wire and a shield separated by an insulating material. It
is commonly called “thinnet”.

A cable used for networking that transfers data at 10 Mega-bits
per second. It is also called “twisted-pair” because it is com-
prised of two insulated wires twisted together. 10BaseT cable
can be shielded or unshielded. Shielded cable provides more
protection from noise than unshielded cable.

A cable similar to 10BbaseT that transfers data at 100 Mega-
bits per second. It is also called fast Ethernet.

An acronym for American Standard Code for Information Inter-
change. A coding scheme that assigns numeric values to let-
ters, numbers, punctuation, and certain other characters.

An acronym for Dynamic Host Configuration Protocol. A proto-
col allowing the principal parameters of network devices (includ-
ing IP Addresses) to be configured by central DHCP servers.

Software that is loaded on the client workstation that prepares
data to be sent to or received from the. Also called a “printer
driver’. The drivers are designed specifically for this Xerox
device.

Network transport technology commonly used to send data
from one node to another.

The Ethernet Address is a unique address that identifies a
device on a network. The Ethernet Address is built into the
device when it is manufactured. The Ethernet Address consists
of six bytes of information and is expressed as hexadecimal
numbers with the bytes separated by colons.

(Example: 00:00:08:D4:05:14)

A network environment in which the nodes communicate with a
file server, and not directly with other nodes. NetWare 3.12 and
Banyan VINES are file server networking products.



Frame

Gateway Address

IEEE

Internetwork Packet
Exchange

IP
IP Address
IPX

ISO

LAN

Local Area Network
Message

NCP

NetWare

NetBIOS/NetBEUI
NetBIOS/IP
NetWare Core Protocol

Node

Packet

A group of data sent through the network. Also called a
“packet’ or a “message”. There are several different types of
frames. The data is arranged differently in different types of
frames. Nodes on a network must be set up for the same
Frame Type in order to communicate.

The Gateway Address is the IP Address of the gateway, or
router, that the will be used to access devices on other subnets.

An acronym for Institute of Electrical and Electronics Engineers.
This is an organization of engineering and electronics profes-
sionals notable for developing the IEEE 802 standards for the
physical and data-link layers of local area networks, following
the ISO Open Systems Interconnection (OSI) model.

See IPX.

See TCP/IP
See TCP/IP

Internetwork Packet Exchange. IPX is part of NetWare. It routes
packets to the correct node and to the correct process within
the node.

An acronym for International Standards Organization. An inter-
national organization that specifies network standards. The
ISO developed the Open Systems Interconnection (OSI) model.

An acronym for Local Area Network. This is a network that
serves a relatively small area, such as one building, and does
not require telecommunications services to reach all of the
nodes. See also WAN.

See LAN.
See Frame.
See NetWare Core Protocol.

A network operating system from Novell. Clients log onto one or
more file servers which provide services such as mail, printing,
and filing.

A peer-to-peer networking system using the NetBEUI protocol.
A peer-to-peer networking system using the IP protocol.

A protocol used by a NetWare client to request services from a
NetWare server.

A device on a network that has an address and can send and/or
receive data to and from other devices on the network.

See Frame.



PCL

PCL5e

PDL

Peer-to-Peer

Print driver
Protocol
Queue

RJ45
Router

Sequenced Packet
Exchange

SPX

Subnet Mask

An acronym for Printer Control Language, which is used by
Hewlett-Packard. This is a set of commands that tell a printer
and printer driver how to print a document.

A Hewlett-Packard Printer Control Language (PCL) that was the
first version of PCL to support bi-directional communication
between printer and computer.

An acronym for Page-Description Language. This refers to a
programming language, such as PostScript, that is used to
describe output to a printer or a display device, which then uses
the instructions from the PDL to construct text and graphics to
create the required page image.

A network environment in which the nodes communicate
directly with other nodes. Windows for Workgroups, NetWare
Lite, and Macintosh System 7 are examples of peer-to-peer net-
working products.

See Driver.
The rules that control the transmitting and receiving of data.

A place where jobs are stored temporarily, while they are wait-
ing to be processed. A print queue will hold several print jobs.
A printer that is attached to the print queue will print the jobs
one at a time.

A connector used to connect a 10BaseT cable to a device.

A device that directs network packets to the segment of the net-
work for which the packet is intended, and excludes packets
that are not intended for a segment. Routers reduce unneces-
sary network traffic and control access to segments of the net-
work.

See SPX.

An acronym for Sequenced Packet Exchange. SPX is part of
NetWare. It ensures that packets are received in the correct
order and that there are no errors.

There are approximately 4.3 billion different addresses in the IP
Address range of 000.000.000.000 to 255.255.255.255. These
addresses can be divided into smaller, and much more man-
ageable subnetworks, or subnets. The Subnet Mask identifies
which part of the IP Address contains the Subnet Address and
which part contains the host (or device) address.



TCP/IP

Thinnet
Twisted-pair
WAN

Wide Area Network

An acronym for Transmission Control Protocol / Internet Proto-
col. TCP/IP is a set of communications protocols that is sup-
ported by a variety of computer platforms. TCP controls the
data transfer and IP controls the routing of the data. The IP
Address is a unique address that identifies a device in a net-
work. The IP Address has to be set by the System Administra-
tor. The IP Address consists of four bytes of information and is
expressed as decimal numbers with the bytes separated by
dots.

(Example: 13.1.188.2)

See 10Base?2.
See 10BaseT.

An acronym for Wide Area Network. This is a network that
serves a relatively large area, such as buildings in different cit-
ies and requires telecommunications services to reach all the
nodes. See also LAN.

See WAN.
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