WorkCentre Pro 232/238

WorkCentre Pro 232/238 Support & Drivers

Effective May 2019, this product will require the use of a device manager application to connect for remote services. Read the Security Bulletin and visit the Remote Services support page for more information.

Supported Platforms: Linux, Mac OS X 10.5 or lower, Macintosh 9, SAP R/3, Sun OS, Sun Solaris, UNIX, Windows 2000, Windows Server 2003, Windows Vista, Windows Vista x64, Windows XP

Supported Languages: Brazilian Portuguese, Bulgarian, Catalan, Czech, Danish, Dutch, English (Global), English (N. America), Finnish, French, French Canadian, German, Greek, Hungarian, Italian, Norwegian, Polish, Portuguese, Romanian, Russian, Spanish, Swedish, Turkish, Ukrainian

File Download: System software set 13.60.22.000

Network installation upgrade from 13.27.24.000 or later.

Note: This upgrade requires that the current software version is 13.27.24.000 or later. Ensure you read the Install Instructions for important upgrade information before attempting the upgrade.

Caution: If you require Common Criteria Certified System software, do not download this file. Please contact your local Customer Support Center to receive the Common Criteria Certified release.

End User License Agreement

Click "Accept" to download, click "Decline" to cancel.

AcceptDecline