WorkCentre PE220

WorkCentre PE220 Asistencia y controladores

Plataformas admitidas Linux, Mac OS X 10.5 or lower, Windows 2000, Windows 7, Windows 7 x64, Windows 95, Windows 98, Windows Me, Windows NT 4.0, Windows Server 2003, Windows Server 2003 x64, Windows Server 2008, Windows Server 2008 x64, Windows Vista, Windows Vista x64, Windows XP, Windows XP x64

Idiomas disponibles Brazilian Portuguese, Czech, Danish, Dutch, English (Global), English (N. America), Finnish, French, French Canadian, German, Greek, Hungarian, Italian, Norwegian, Polish, Russian, Spanish, Swedish, Turkish

Descarga del archivo: Firmware v4.14

Firmware for the WorkCentre PE 220.

Nota: Recommended for use with Vista. Upgrade firmware using Control Centre.

Acuerdo de licencia de usuario final

Haga clic en "Aceptar" para descargar o en "Declinar" para cancelar

AceptarDeclinar