WorkCentre PE120/120i

WorkCentre PE120/120i Support & Drivers

Supported Platforms: Mac OS X 10.5 or lower, Windows 2000, Windows 98, Windows Me, Windows NT 4.0, Windows Server 2003, Windows XP

Supported Languages: English (Global), English (N. America)

File Download: 4.15 Firmware for WorkCentre PE 120/120i

General/Manufacturing Release. The zip file contains software upgrade files as well as installation instructions.

Note: The files in the zip file will need to be extracted before installation.

End User License Agreement

Click "Accept" to download, click "Decline" to cancel.

AcceptDecline