WorkCentre 7755/7765/7775 with EFI Fiery Controller

WorkCentre 7755/7765/7775 with EFI Fiery Controller Support & Drivers

Your device software may require a SHA2 security certificate update to direct-connect for remote services. Read the Security Bulletin and visit the Remote Services support page for more information.

Supported Platforms: IBM AS/400, Linux, Mac OS X 10.5 or lower, Sun Solaris, UNIX, Windows 7, Windows 7 x64, Windows Server 2003, Windows Server 2003 x64, Windows Server 2008, Windows Server 2008 x64, Windows Vista, Windows Vista x64, Windows XP, Windows XP x64

Supported Languages: Brazilian Portuguese, Catalan, Czech, Danish, Dutch, English (Global), English (N. America), Finnish, French, German, Greek, Hungarian, Italian, Norwegian, Polish, Romanian, Russian, Spanish, Swedish, Turkish

Supported Products: WorkCentre 7755 EFI Fiery Controller, WorkCentre 7755 built-in controller

File Download: WorkCentre 7755/7765/7775 System Software version 061.090.220.19700

The .zip file includes a PSCrashFixv4.dlm patch file which addresses an issue with PostScript files that may cause unexpected device behavior. Please see the Installation Instructions for steps on how to install the patch file.

End User License Agreement

Click "Accept" to download, click "Decline" to cancel.

AcceptDecline