WorkCentre 3315/3325

WorkCentre 3315/3325 Support & Drivers

Supported Platforms: Mac OS X 10.10 - Yosemite, Mac OS X 10.11 - El Capitan, Mac OS X 10.6 - Snow Leopard, Mac OS X 10.7 - Lion, Mac OS X 10.8 - Mountain Lion, Mac OS X 10.9 - Mavericks, macOS 10.12 - Sierra, macOS 10.13 - High Sierra

Supported Languages: Dutch, English (Global), English (N. America), French, French Canadian, German, Italian, Spanish

File Download: Mac OSX Drivers and Utilities Installer for WC 3325

Both the WC 3315 and the WC 3325 Mac OSX software packages are now signed for Mac OSX 10.13.x. There is no customer facing version change.

Caution: The Vise X installer, built for this product, is no longer supported when running on MAc OS 10.12.5 or higher.

End User License Agreement

Click "Accept" to download, click "Decline" to cancel.

AcceptDecline