Phaser 560

Phaser 560 Support & Drivers

This product is no longer supported. Xerox continues to provide Online Support and Drivers where available.

Supported Platforms: IBM OS/2, MS-DOS, Mac OS X 10.5 or lower, Macintosh 7, Macintosh 8, Macintosh 9, UNIX, Windows 2000, Windows 3.1x, Windows 3.x, Windows 95, Windows 98, Windows Me, Windows NT 3.5x, Windows NT 4.0, Windows Server 2003, Windows XP

Supported Languages: English (Global), English (N. America)

File Download: Utility to Adjust Font Cache for Collation

Utility to adjust Font Cache for Collation on a 350/550

Click "Start" to download

Start