Phaser 3600

Phaser 3600 Support & Drivers

Resultaten verfijnen

Opmerking: als het besturingssysteem en/of de taal niet staat vermeld, zijn er bij ons geen gegevens over de beschikbaarheid van drivers bekend.
Opmerking: Einde van ondersteuning voor Windows XP -- Wat u moet weten (PDF-Engels)
  • Drivers

      • Datum: jun 27, 2019
      • Versie:
      • Indeling: WWW

      Xerox Global Print Driver

      • Global/Mobile
      • Package-Aware
      • V3 Driver
      • WHQL
      Beschrijving
      Met de kosteloze Xerox Global Print Driver kunnen printers van Xerox en van derde partijen die zich op uw netwerk bevinden via een enkele, eenvoudig te gebruiken interface worden beheerd. Dankzij deze driver is het beheren van zakelijke printerparken voor systeembeheerders veel eenvoudiger geworden; printers kunnen gemakkelijk worden toegevoegd en bijgewerkt zonder dat er andere drivers hoeven te worden gebruikt.

      Opmerking: Selecteer uw besturingssysteem en taal nogmaals nadat u bent doorgestuurd naar de Global Print Driver webpagina.

      Ga voor meer informatie over de voordelen en functies van de Xerox Global Print Driver naar: www.xerox.com/global

      • Datum: apr 27, 2018
      • Versie: 3.04.96.01
      • Grootte: 13,1 MB
      • Indeling: ZIP

      Phaser 3600 Win8 & 10 32-bit and 64-bit PCL6 Print Driver

      • PCL
      • V3 Driver
      • WHQL
      Beschrijving
      Phaser 3600 Windows 8 & 10 32-bit and 64-bit PCL6 Print Driver

      • Datum: jul 1, 2009
      • Versie: 6-30-09
      • Grootte: 113,8 MB
      • Indeling: ZIP

      Phaser 3600 Windows Drivers and Utilities

      • PCL
      • PostScript
      • WHQL
      BeschrijvingLet op:
      Microsoft WHQL certified. Installation package includes PCL6, and PS drivers. Also includes Printer Settings Utility, SetIP Utility, and Status Monitor.
      Let op: Earlier driver versions MUST be uninstalled before installation of these print drivers.
      These drivers require minimum firmware version of 1.70.02.40.
      Firmware version 1.70.02.40 and higher requires use of these drivers.

      • Datum: jun 30, 2009
      • Versie: 3.04.86
      • Grootte: 2,6 MB
      • Indeling: EXE

      PCL6 Driver - 32-bit

      • PCL
      • WHQL
      BeschrijvingLet op:
      32-bit PCL6 Driver for the Phaser 3600. Supports Windows Server 2003, XP and Vista. Microsoft WHQL certified. This driver uses the Add Printer Wizard.
      Let op: Earlier driver versions MUST be uninstalled before installation of these print drivers. These drivers require minimum firmware version of 1.70.02.40. Firmware version 1.70.02.40 and higher requires use of these drivers.

      • Datum: mei 20, 2008
      • Versie: 1.6
      • Grootte: 1 MB
      • Indeling: ZIP

      PS Driver - Microsoft Certified

      • PostScript
      • WHQL
      BeschrijvingLet op:
      32 bit PostScript print driver for the Phaser 3600. Supports Windows 2000, Server 2003/2008, XP, and Vista 32 bit Operating Systems. Microsoft WHQL Certified.
      Opmerking: Extract to a local folder and install using the Add Printer Wizard.
      Let op: This driver is ONLY for use with Firmware versions prior to v1.70.02.40. For firmware version 1.70.02.40 and newer, use drivers dated 6/30/09 or later.

      • Datum: mei 19, 2008
      • Versie: 3.04.54.09
      • Grootte: 2,8 MB
      • Indeling: ZIP

      PCL Print Driver - Microsoft Certified

      • WHQL
      • PCL
      BeschrijvingLet op:
      32 bit PCL Print Driver for the Phaser 3600. Supports Windows 2000, Server 2003/2008, XP, and Vista Operating 32-bit Operating Systems. Microsoft WHQL Certified.
      Opmerking: Extract to a local folder and install using the Add Printer Wizard.
      Let op: This driver is ONLY for use with Firmware versions prior to v1.70.02.40. For firmware version 1.70.02.40 and newer, use drivers dated 6/30/09 or later.

  • Firmware

      Note: Raadpleeg uw netwerkbeheerder of systeembeheerder voordat u een software (firmware) update uitvoert. Bepaalde updates zijn van invloed op de compatibiliteit van het systeem, waardoor het niet meer kan goed functioneert in de omgeving waarin het is geïnstalleerd.