Phaser 3117

Phaser 3117 Support & Drivers

Supported Platforms: Linux

Supported Languages: Brazilian Portuguese, Chinese (Simplified), Chinese (Traditional), Czech, Danish, Dutch, English (Global), English (N. America), Finnish, French, French Canadian, German, Greek, Hungarian, Italian, Japanese, Korean, Norwegian, Polish, Portuguese, Romanian, Russian, Spanish, Swedish, Turkish

File Download: Linux Printer Package

Integrated suite of utilities for the Linux operating system, allowing you to configure and manage Linux laser printers in a user-friendly way.

Note: - Linux distributions : Redhat 6.x, Mandrake 7.x, SuSE 6.x, Debian 2.2, Caldera OpenLinux 3.x, TurboLinux, Slackware 7.x, Linux/PPC, Yellow Dog, and newer versions. - Linux kernel 2.2 and up - GNU Libc version 2.1 and up

End User License Agreement

Click "Accept" to download, click "Decline" to cancel.

AcceptDecline