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Chapter 1: Introduction 

Welcome to the Vitesse Getting Started Guide.  This guide is designed to get you up 
and running with Vitesse – an enterprise solution for a highly visual, user-friendly, 
and powerful rapid-application-design tool for creating documents for VIPP printing.  
This guide will familiarize you with the Vitesse design environment and introduce 
you to the many useful Vitesse features that will make designing VIPP applications a 
breeze. 

As you go through this guide and start using Vitesse’s user friendly and visual 
environment, you will observe greater flexibility, ease of use, and superior 
productivity.  Creating VIPP applications was never this much fun! 

Who Should Use This Guide?  
This guide is for anyone who needs to create and edit applications for a VIPP printing 
environment.  

What’s in This Guide 
This guide will introduce you to the basic Vitesse (Variable Data Intelligent 
PostScript Printware) functions and features.  It also provides assistance with system 
installation and configuration and gives several exercises to help you feel confident 
when using Vitesse.  This guide is divided into three sections: 

! Installation 
Includes system requirements, along with instructions for registering and 
installing your software.  

! Configuration 
Includes setting up system settings for Vitesse.  

! A Vitesse Tour 
This integrated tour leads you through each of the VIPP project modes using a set 
of sample applications.  Includes form and segment creation and adding data in 
Line, Database, and XML modes. 

 

Resources and completed projects for the Vitesse Tour are installed 
with Vitesse.  These are located in drive:\program files\elixir 
technologies\vitesse\clients\gs.  The tour includes exercises that are 
designed to introduce you to creating forms using Line Data (Line mode 
with a line data file), Line Prefix (Line mode with a prefixed line data 
file),DBM (Database mode) and XML (XML mode).  The resources for 
each exercise are located in separate folders at the path specified 
above. 
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Assumptions in Creating this Guide 
This guide assumes you are already familiar with Windows XP, Windows 2000, or 
Windows NT, VIPP (formerly known as XGF), and/or PostScript printer operations 
including how to use a mouse and standard menus and commands, how to open, save, 
and close applications. 

You should be familiar with PC devices such as disk drives, printers and modems and 
have access to reference manuals for PC software and hardware, including printers. 

Conventions 
Conventions are the same or similar to Windows conventions, including: 

! Display conventions 
! Typographic conventions 

Display Conventions 

Elixir products adhere to Microsoft Windows conventions for using menus, menu 
commands, dialog boxes, command buttons, icons, and the mouse.  See your 
Windows manual for more information. 

Typographic Conventions 

This guide uses the following typographic conventions to identify special 
information: 

Convention Information Type/Example 

Bold type Keystrokes and user selections. 
Ex: Enter 
Key combinations are denoted by a plus sign 
between keys. 

Italic type - References to other guides. 

Ex: Elixir Scout Guide. 

- Dialog names. 
Ex: Page Properties dialog displays. 
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Symbols Used in This Guide 
Look for the following symbols as you read through this guide: 

Symbol Information Type 

 

Note 
This symbol calls your attention to additional 
information. 

 

Shortcut 
This symbol shows a shortcut for a procedure you just 
learned. 

 

Tip 
This symbol highlights a helpful tip. 

 

Warning 
This symbol emphasizes an important note and/or 
warning. 

Introduction to Vitesse 
Vitesse is a Windows-based, visual design environment for rapid and cost-effective 
creation of variable applications and resources for B/W, Highlight and Full color 
VIPP printing.  

You can visually map XML, database resident or host-based line data on your 
applications, design professional looking forms with the extensive drawing toolbar, 
create data driven graphics and apply conditional logic on text, images and page 
layout properties. Vitesse provides both a visual and a source code environment for 
designing applications. Adequate support to import and modify hand-coded VIPP 
applications and resources is also provided. For newly designed applications in 
Vitesse or imported ones, Vitesse provides a source view of the VIPP code. For 
VIPP-savvy programmers, this feature allows them to view, edit and compile code 
changes in an integrated environment. You can also import Xerox native format 
objects, such as forms (FRMs), fonts (FNT) and images (IMGs and LGOs) for 
migration from LCDS and Metacode environments.. 
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Vitesse fully supports the creation of all VIPP project modes: Native, Database, Line 
and XML, along with the creation of VIPP forms and segments. Additionally, the 
VIPP application code from Vitesse can be sent to Xerox’s VIPP Thin Printer, which 
is a special distiller for distilling and converting VIPP code to PDF. The VIPP Thin 
Printer can be resident on the PostScript print controller or any server or client 
machine running Windows NT or Windows 2000. For more information on the VIPP 
Thin Printer, please contact your local Xerox Representative. For complete step-by-
step instructions on creating bookmarks in Vitesse, refer to online help or the Vitesse 
User Guide. 

Vitesse also extends Xerox PDF workflow functionality by providing the following 
features: 

! Drag and drop workflow for creating PDF bookmarks. 
! PDF bookmark creation in all three VIPP modes. 
! Creation of single-level bookmarks or sub-bookmarks for hierarchical bookmark 

levels within a PDF. 
! PDF splitting based on the bookmarks. 

Understanding the VIPP Modes 
Vitesse supports the following VIPP modes for designing and testing your projects: 

! Native mode 
! Line mode 
! Database mode 
! XML mode 
These modes or project types are based on the various VIPP input data formats and 
are discussed in the following sections. 

What is Native Mode? 

You can use the Native mode for creating, positioning and printing static data on a 
physical page, such as text, images, lines, boxes, forms and segments.  

Both Native mode and VIPP forms are used to build static designs with no merging of 
variable data.  A Native mode document can include one or many forms in its 
definition, where a VIPP form is a single page Native mode document.  In this mode, 
you can create applications that support fully composed Native mode data streams.  
For example, you can create application forms or promotional flyers using this mode.  
Native mode is not intended for variable data handling. 
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What is Line Mode?   

Line mode creates and manages legacy data streams for transactional documents, such 
as telephone bills, banking statements, credit card statements, insurance invoices and 
sales reports. Legacy data streams can be either line data or print-ready data. 

You can use Line mode to read, process and format line printer data on a line-by-line 
(record) or column-by-column (field) basis. You can also import Job Descriptor 
Tickets (JDT) for editing within Vitesse. 

Line mode accepts line data, which can be organized in either of these two ways: 

Prefixed data file 

A prefixed data file contains prefixes at the beginning of each record to identify the 
record contents. Vitesse uses this prefix to locate and define each record type for 
printing. All records with the same prefix use the same properties for printing. 

Non-prefixed data file 

A non-prefixed data file does not have prefixes, so Vitesse uses a start line number 
and end line number to locate records. Vitesse counts the records, or lines, in the data 
file to locate a specific record for printing.  

Either of these two file formats can use fixed or delimited records to identify field 
information. Fixed records identify field information using a start byte and length, 
where delimited records use a field number. 

What is Database Mode?  

Database mode documents are used for processing files containing field-delimited 
records.  Database mode can create documents such as mailers, promotional flyers 
and insurance contracts. Data for these documents is extracted from a database file.  
In a database file, records can be either fixed or variable length, separated by a 
delimiter. The first line of the data file contains the field names. The remaining lines 
contain variable data in order of the field names. 

What is XML Mode?  

Extensible Markup Language (XML) mode creates VIPP applications using data from 
XML data files.  XML mode documents process data files containing tags, attributes, 
and values.  Tags, attributes, and values identify the data file content.  All information 
is enclosed between bounding tags. 

 

Delimited and/or prefixed data files are not supported in XML mode. 
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Frequently Asked Questions 

What is VIPP? 
Variable-data Intelligent PostScript Printware (VIPP) is a Xerox proprietary print 
stream. VIPP is a superset of PostScript, an open system solution allowing users to 
efficiently create Xerox printer applications. It was originally called Xerox Generic 
Format (XGF) as a Xerox response to customer requirements for creating dynamic 
documents.  The key purpose of VIPP is to enable line printer and database data to be 
formatted and printed using PostScript features at production speeds using Dynamic 
Document Construction (DDC). DDC is based on real time composition of the 
document at the printer or imaging device.  Components such as images, fonts, and 
forms can be stored locally on disk drives or accessed from networked disk drives.  
The DDC model also improves performance by enabling a “RIP once / Use many” 
capability.  In short, this functionality allows you to reuse various components of a 
document with other documents. 

How is VIPP different from traditional PostScript? 
Unlike PostScript, the VIPP file relies on external resources such as VIPP code, 
forms, Job Descriptor Tickets (JDTs), or images. These external resources must be 
accessible to the PostScript interpreter through external devices, such as a disk or 
cartridge, or loaded in memory when the job is processed. VIPP features and 
functions provide enhanced variable data printing performance through the use of 
cached object elements, dynamic text flow, data driven graphics, data formatting, 
conditional processing, and workflow improvements. 

Which printers can be used for printing VIPP? 
VIPP is supported on these printers: 

! DocuColor 
! DocuPrint 
! DocuTech 
! PDF  viewing and printing of Vitesse generated VIPP applications using VIPP 

Thin Printer. 
Contact your Xerox representative for information about limited support on these 
printers: 

! DocuPrint N-series 
! DocumentCenter 
! Phaser printers 

Which types of fonts are supported in Vitesse? 
Vitesse supports True Type or PostScript Type 1 fonts. These fonts are associated 
with a VIPP font name using a font map, which is editable. The VIPP font name is 
used to locate the appropriate PostScript Type 1 or Type 3 font on the printer at print 
time. 
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Vitesse installs with the most common VIPP font names already set up 
to match their True Type equivalent in the font map. You can install 
PostScript fonts on your operating system and add them to the font map 
so that Vitesse uses the same font for displaying as the printer uses to 
print. You can also change the default mappings if necessary to match 
your font usage. 
If both True Type and PostScript fonts are available, Vitesse will use the 
PostScript font for display. 

Which types of images are supported in Vitesse? 
Vitesse supports most contemporary image file formats, including BMP, JPEG, TIFF, 
etc. Vitesse automatically packages formats not compatible with VIPP printing in the 
correct format into the zipped VPC during the export process. 

PostScript files and forms, including Encapsulated PostScript (EPS) resources, can be 
inserted as a segment for use within a form or project file. You can use high-level 
document processing applications (such as Word, FrameMaker, Excel and 
PageMaker) to create a PostScript file for inserting into a Vitesse segment. 

 

PostScript files and forms are not editable in Vitesse. 

What is a VIPP segment? 
A segment is a VIPP Native mode or a PostScript fragment intended to be reproduced 
once or several times at specific locations on a page. Segments can include PostScript 
files or forms and Encapsulated PostScript (EPS) files, as well as other image 
formats. 

What is a VIPP form? 
A form is a single-page VIPP Native mode document intended to be reproduced 
identically in the background on each page of a job. 

How is Resource Caching Done on the Printer? 
VIPP supports resource pre-rasterization and caching on the printer. CACHE is the 
VIPP command to cache an object within a job. This means that as the job processes, 
the first time an object is found, VIPP will cache it and the next time the object is 
called, the ripped object will be used. Objects cached this way only stay active for the 
length of the job.  

An object that is cached, when called again within the job using different orientation, 
rotation, or scale parameters, will force the object to be re-ripped and cached. So if 
you use a logo in two scales on the page, you will not get the benefit of caching and 
the object will be forced to rip each time it is called. 
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All printers, assuming current software levels, with the exception of the monochrome 
DocuSP controllers, the N-Series and Phasers and the Document Centers support 
VIPP caching. This includes all Creo and EFI DFE's - (2045, 2060, 6060, iGEN3), 
NPS 8.0 systems – both monochrome, highlight and full color. Color DocuSP 
supports VIPP caching. 

What is the VPC export format?  
VIPP Project Container (VPC) is a mechanism that simplifies the handling of a job’s 
components by logically and physically grouping components as part of a single 
entity. The logical grouping is the VIPP Project. The physical grouping is referred to 
as the VIPP Project Container (VPC).  

When using VPC, you can track and store the files that make up the project as a single 
entity. In addition, VPC can be used to identify, organize, and store the components 
of a job under a single name (the project) and can also group jobs by categories (the 
folder). This allows you to package all of the project components in a single file (the 
container), as well as to use and transfer them among applications, devices, and 
locations. 

 

This container is the project resources and a VIPP project file zipped 
into a standard ZIP container. The contents of a VPC can be 
decompressed using WinZip. 

Getting the Answers You Need 
Elixir Technologies provides the following resources to help you learn and use 
Vitesse: 

! Customer Support 
! Elixir Training 
! Help 
! Related Guides 

Customer Support 
If you purchased this product directly from Elixir Technologies, you can contact the 
Customer Support Center for your region at the number listed below: 

North and South America: 

! +1 805 641 5900 ext. 3 
Monday – Friday, 7:00 am to 4:00 pm Pacific Standard Time; if closed, press 2 to 
reach Elixir’s extended support coverage. 

! Elx_support@elixir.com 
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Asia Pacific:  

! Asia_support@elixir.com 
Europe: 

! +44 (0) 207 993 4811 
Monday – Friday, 6:00 am to 4:00 pm Central European Time 

! +1 805 5900 ext. 3 
Monday – Friday, 4:00 pm to 2:00 am Central European Time 

! Europe_support@elixir.com 
If you have a problem with your Elixir product, contact the Elixir Customer Support 
Center for your region.  An Elixir Product Specialist will answer your call and ask for 
the following information: 

! Your name, organization, telephone number, and address. 
! Elixir product name and version number. 
! A complete description of the problem, including any error messages printed or 

displayed on your monitor. 

Elixir Website Support 

You can also obtain product support by accessing the Elixir web page at 
http://www.elixir.com and selecting Support.   

The Elixir website allows you to: 

! Select your preferred support method. 
! Identify support centers. 
! Access web support. 
! Register Elixir products. 
! Renew Elixir licenses. 
! Learn through the User Group how others are using Elixir products. 
! Download the latest patches. 
! Contact Elixir Partner Support. 
! Ask a question to Elixir Support.  To submit a question, select Questions> 

Submit a Question here.  Please complete the question form. 
! Find answers in the list of Frequently Asked Questions.  
! Access the Elixir Knowledge Base. 

mailto:Asia_support@elixir.com
mailto:Europe_support@elixir.com
http://www.elixir.com/


 

16 Vitesse Getting Started Guide 

Elixir Training 
Elixir Technologies offers training for its full-range of Windows-based products.  For 
more information, contact: 

Elixir Learning 
(805) 641-5900 ext.4 

Using Help 
Elixir software uses the Microsoft Windows Help program to provide help for all 
product functions. 

What’s This? Help 

Selecting a dialog control such as an input field, radio button, or drop-down list, and 
then pressing Shift + F1 displays a pop-up window containing information about that 
control.  You can also get this information by right-clicking the control and selecting 
What’s This? from the pop-up window or clicking  on the dialog title bar if 
available. 

Help Pop-ups and Jumps 

The help can be opened using Help>Contents from the application menu bar.  Within 
the Help topic text, words or phrases in blue are drop-down hotspots and underlined 
words or phrases in blue are jumps or hyperlinks.  Clicking a hotspot displays images 
and links directly below the hotspot within the same topic.  Clicking a jump displays 
an associated Help topic within the same window. 

Release Notes 
Release Notes display at the start of product installation so you can review them 
before beginning the installation process.  Once installation completes, you can access 
Release Notes from the product CD at drive:\relnotes.  There are two formats of the 
Release Notes file: relnotes.pdf and relnotes.txt.  The TXT file can be viewed using 
either Notepad or WordPad.  The PDF file can be viewed using Adobe Reader.  

Related Guides 
If you require further information about a specific topic or wish to obtain product 
background information, reference the Vitesse User Guide which is part of the Vitesse 
documentation package. 
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Chapter 2: Installation 

This chapter guides you through the installation and registration process for Vitesse.   
It describes the minimum system requirements necessary to install and run Vitesse on 
your computer.  It also lists procedures for reinstalling and uninstalling Vitesse 1.30. 

System Requirements 
The minimum system requirements for running Vitesse are as follows: 

Software Requirements 

To run Vitesse, you need one of the following operating systems installed on your 
computer: 

! Windows XP with Service Pack 1.0a or higher. 
! Windows 2000 Professional with Service Pack 3.0 or higher. 
The application also requires Internet Explorer 5.5 or above.  

Hardware Requirements 

You need the following minimum hardware requirements to run Vitesse on your 
computer: 

! Processor: Intel Pentium III 
! Ram: 128 MB required, 256 MB recommended 
! Hard disk space: 20 GB recommended 
! CD-ROM Drive 
! Any monitor that supports Windows with 1024 x 768 screen resolution 
! Microsoft mouse or compatible pointing device 

Other Requirements 

If you would like to register Vitesse using the Internet, you will need to be connected 
to the Internet at the end of installation. 
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Installing Vitesse 
This section provides instructions for installing Vitesse 1.30.  

 

If you have previously installed Vitesse, you should manually delete the 
drive:\program files\elixir technologies\vitesse\clients\gs folder.  The 
new installation will overwrite the original resources and can also install 
new folders, due to changes made in the applications in this guide 
between versions.  If you have already worked with the applications in 
this folder for the previous version, you may keep this folder, but be 
aware that new folders and/or resources will be added. 

 

It is highly recommended that you close all programs before you install 
or uninstall any software. 

To install Vitesse: 

1 Insert the Vitesse CD into your CD-ROM drive. 
If your computer is set up to automatically run a CD, the Vitesse – Install 
Shield Wizard opens. 

If your computer is not set up to automatically run a CD, you will need to run the 
installation manually. 

1 From the Start menu, select Run to open the Run dialog. 
2 Type drive:\setup\setup.exe in the Open entry box, (replace drive with the 

letter of your CD-ROM drive) and then click OK. 
The Vitesse – Install Shield Wizard displays. 
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The Vitesse Wizard guides you through the install process. 

3 Select Run password registration process. 
Selecting this option runs the password registration process runs 
automatically after the installation. 
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4 Click Next. 
The License Agreement dialog displays 

 
 Read the License Agreement carefully before proceeding. 

5 Read the License Agreement carefully.  
6 If you agree, click Yes. 

The Select the type of Installation dialog displays. 

 
The installation options are displayed in Select the type of Installation dialog. 
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7 Select Full (Vitesse is installed with the import functionality of Xerox 
native resources).  
Minimum installation does not accommodate Legacy resources.  Full 
installation includes both Vitesse and Legacy resources.  You can customize 
filter options by selecting the Custom option. 

8 Click Next. 
The Choose Destination Location dialog displays. 

 
Choose a destination folder to install Vitesse and specify a location for its 
resources. 

9 Browse to select the location for installing Vitesse executable and DLLs if 
you want to change the default directory. 

10 Browse to select the location for Elixir resources if you want to change the 
default directory. 
The Elixir folder is used for storing Legacy resources, such as FRM, ELX, 
etc. 
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11 Click Next.  
The Choose Document Folder dialog displays. 

 
Select the program folder where you want the Vitesse documents to be saved.  

12 Browse to a new location if you want to change the default location of 
Vitesse documents. 

13 Click Next. 
The Select Program Folder dialog displays with Elixir Applications\Vitesse 
set as the default folder for placing application files. 
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Select the program folder where you want the Vitesse shortcut to display in the 
Start menu. 

 

In this dialog, you can either create a new program folder for Vitesse 
shortcut or select from the existing list of folders. 

14 Select the required program folder where you want the Vitesse shortcut to 
display in the Programs menu.  

15 Click Next. 
The Start Copying Files dialog displays, confirming the settings you have 
entered.  
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16 If you want to change any of the settings, click Back. 

 
Review the listed install settings before beginning the installation. 

17 Click Next to install Vitesse. 
The Setup Status dialog displays, showing the installation progress.  This 
might take a few minutes.  

 
Setup Status displays the installation progress. 
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After all files have been copied into the destination folder, the InstallShield Wizard 
Complete dialog displays. 

 
The installation is complete. 

 

Sometimes, you are prompted to restart your computer after the Vitesse 
installation completes.  Select Yes, I want to restart my computer now, 
and then click Finish.  In this case, the License Wizard dialog does not 
open automatically and you will have to launch this dialog using 
Start>All Programs>Elixir Applications>Vitesse>License Wizard.   

18 Click Finish. 
The License Wizard dialog displays. 
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Registering Vitesse 
Once the installation completes, you will be prompted to register Vitesse for use.  The 
License Wizard dialog displays for this purpose, which guides you through the 
software registration process. 

 
The License Wizard dialog guides you through the software registration process. 

 

This License Wizard dialog displays only if Run password registration 
process is selected at the start of the installation process. 

 

If you want to run registration as a separate process, click Close.  When 
you are ready to register, open the Start menu and choose 
Programs>Elixir Applications>Vitesse>Liscence Wizard. 
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19 Select Show advanced options. 
The License Wizard dialog displays all the licensing options. 

 
The License Wizard displays all licensing options. 

You can select any of the available licensing options to register Vitesse and unlock it 
for use on your machine. 

 

The View license information option displays product licenses available 
on your computer. The Deactivate license option deactivates a 
previously registered license. The Install license option allows you to 
select a password file for installing. 

Downloading a Product License 
This section covers downloading a license from the Internet to register Vitesse.  If 
you do not want to register Vitesse on the Internet, continue on to the next section. 

To download a product license using the Internet: 

20 Select Download product license and click Next. 
The Login information dialog displays.  If you are not already connected to 
the Internet, then you will need to connect before continuing with registration. 
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Specify your Customer Number, PC Number, and Password to continue. 

21 Enter your customer number in the Customer Number  entry box. 
22 Enter your PC number in the PC Number entry box. 
23 Enter your password in the Password entry box. 

If you do not know your Customer Number or PC Number, or if you have 
forgotten your password, click the links next to their respective entry boxes to 
retrieve this information from the Elixir website. 

24 Click Next. 
The Contact Information dialog displays.  Make sure all information is 
correct before proceeding.  
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Check the Contact Information carefully before clicking Next. 

25 If the information displayed in the dialog is not correct, click the link on top 
of the information box, or click Back to change the information. 

26 Click Next. 
The Download progress dialog displays. 

 
The dialog displays the progress of the registration process. 

Once your registration has been completed, the Registration Completed dialog 
displays your license information.  
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The dialog lists items unlocked by the registration process. 

27 Click Finish to complete your registration. 
Vitesse is registered. 

28 The InstallShield Wizard Complete dialog displays and prompts you to restart 
your computer to complete the installation. 

 
Restart your computer to complete the install process. 

29 Select Yes, I want to restart my computer now. 
30 Click Finish. 
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You have completed the Vitesse install and registration process. 

Selecting a License Source 
This section covers selecting an existing license or a key, from your machine or your 
local network, to register Vitesse. 

 
Selecting the Select license source option. 

31 Select Select license source and click Next. 
The License Key Selection dialog displays.  

 
Selecting a license from the drop-down list. 
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32 Select Please select a license key from the drop-down list, and then click 
 to locate the license key.  

If you already have a Legacy Softkey in your system, the path is displayed in 
the drop-down list.  You can then select the Legacy Softkey, password.epw 
directly from the drop-down menu. 

33 Click Next. 
The Registration Completed dialog displays. 

 
The dialog lists items unlocked by the registration process. 

34 Click Finish to complete your registration. 
Vitesse is registered. 

35 The InstallShield Wizard Complete dialog displays and prompts you to restart 
your computer to complete the installation. 
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Restart your computer to complete the install process. 

36 Select Yes, I want to restart my computer now. 
37 Click Finish. 

You have completed the Vitesse install and registration process. 

Repairing Vitesse 
To repair Vitesse or reinstall missing files, you can run the Repair procedure. 

1 Insert the CD containing the Vitesse install into your CD-ROM drive. 
If your computer is set up to automatically run a CD, the Vitesse – 
InstallShield displays. 

If your computer is not set up to automatically run CDs, you will need to run the 
installation manually: 

1 Open the Start menu and select Run to open the Run dialog. 
2 Type drive:\setup\Setup.exe in the Open entry box, (replace drive with the 

letter of your CD-ROM drive) and then click OK. 
The Vitesse – InstallShield Wizard displays.  The wizard searches your 
computer to detect the previous Vitesse version and extracts all the files 
needed to reinstall or repair Vitesse on your computer from the install 
package. 
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The Modify, Repair or Remove the program dialog displays.  

 
Select Repair to reinstall Vitesse. 

3 Select Repair, and then click Next.  
The Setup Status dialog displays, showing the repair progress. 

 
Setup Status displays the repair progress. 
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After missing files are copied into your Vitesse folder, the Maintenance Complete 
dialog displays. 

 
Vitesse maintenance is complete. 

 

Sometimes, you are prompted to restart your computer after the Vitesse 
maintenance process completes.  Select Yes, I want to restart my 
computer now, and then click Finish. 

4 Click Finish to complete the maintenance process. 
You have repaired or reinstalled Vitesse. 

Uninstalling Vitesse 
To uninstall Vitesse from your computer, you can run the Remove procedure. 

1 Insert the CD containing the Vitesse install into your CD-ROM drive. 
If your computer is set up to automatically run a CD, the Vitesse – 
InstallShield displays. 

If your computer is not set up to automatically run CDs, you will need to run the 
installation manually: 

1 Open the Start menu and select Run to open the Run dialog. 
2 Type drive:\setup\Setup.exe in the Open entry box, (replace drive with the 

letter of your CD-ROM drive) and then click OK. 
The Vitesse – InstallShield Wizard displays.  The wizard searches your 
computer to detect if Vitesse is installed and extracts all the files needed to 
uninstall Vitesse from your computer from the install package. 
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The Modify, Repair, or Remove the program dialog displays. 

 
Select Remove to uninstall Vitesse. 

3 Select Remove, and then click Next. 
The Confirm Uninstall dialog displays, prompting you to confirm the removal 
of Vitesse and all its components from your computer. 

 
Clicking OK will completely remove Vitesse from your computer. 
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4 Click OK to completely remove Vitesse from your computer. 
The Setup Status dialog displays to show the uninstall progress. 

 
Setup Status displays the uninstall progress. 

Once all Vitesse files have been uninstalled from your computer, the Maintenance 
Complete dialog displays. 

 
Vitesse has been uninstalled. 

5 Click Finish to complete uninstalling Vitesse. 
You have removed Vitesse from your computer. 
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User Notes:
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Chapter 3: Configuration 

In this chapter, you will configure Vitesse preferences to suit the requirements of an 
individual user, workgroup, or enterprise. 

The Basic Configuration 
For basic configuration settings: 

1 From the Start menu, select Programs>Elixir Applications>Vitesse>Vitesse. 
Vitesse opens. 

2 From the menu, choose Tools>Preferences. 
The Preferences dialog displays.  

 

You can also click  on the Standard toolbar to view the Preferences 
dialog.  

General Category 
To set the preferences in the General category:  

1 Browse to select a working folder in the Working Folder entry box. 
This folder is the default path used for storing your application designs.  You 
can, of course, browse to another location during the saving process. 

 
The working folder is the default save location. 
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If your project is graphic-intensive, and you are using many high-
resolution images, you may wish to check the Use low resolution 96 dpi 
images for optimized preview in Designer option.  This renders any 
graphics over 96 dpi as low resolution in the design area.  This 
conserves memory and speeds the application processes.  The actual 
print job will still use the high-resolution images, even if this is checked. 

2 Select Show font names in font combo box. 
This option displays the font names along with the font samples in the Name 
drop-down list, available in the Font tab of the Property View window.  

 

The Show font family members in font combo box option is used to 
display the regular, bold, and italicized styles for each font in the Name 
drop-down list of the Font tab (depending on the font type).  The B, I, 
and U features in the Font tab become disabled when this option is 
selected. 

 
The Font tab with the B, I, and U options enabled as the Show font family 
members in font combo box option is deselected in the Preferences dialog. 

You have set up the General preferences.  

 

All tutorials in this guide use the default path of drive:\program files\elixir 
technologies\Vitesse\clients. 
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View Category 
Select the View category.  You will not make any changes to this category at this 
time. 

 
Check all items you want to display in your workspace. 

All checked items in the View category display in your workspace.  You can set the 
items to display according to your own preferences and change these settings at any 
time. 

You have finished setting up the View preferences. 

Workspace Category 
There are four categories under the Workspace category: 

! Designer 
! Tree View 
! Source 
! Data 

Designer 

To set the Designer preferences: 

1 Under the Workspace category, select Designer. 
The Designer preferences page displays. 

2 In the Guides area, select the Color and Style of the guides. . 
Guides help place and align objects in the design area accurately.  You can 
also set objects to Snap to Guidelines. 
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3 In the Nudge area,  set the Nudge and Super Nudge setting in inches.  
If you want to choose a different unit of measurement, right-click the spin 
arrow control next to the Nudge and Super Nudge options and select a unit 
from the pop-up menu. 

 

Nudge and Super Nudge options position objects with the arrow keys or 
the arrow and Shift keys, respectively, on your keyboard. 

4 In the Grids area,  select the Color, Style, and Spacing settings of the grids. 
Grids help place and align objects in the design area accurately.  You can also 
set objects to Snap to Grids.  

5 In the View area, select all design helps you want to view in the design area. 
6 Select Page Color and Page Background Color.  
7 You can select objects falling outside the page boundaries to automatically be 

clipped by selecting the Clip Objects Outside Page option. 
8 In the Default Units  drop-down list, select Inches as the default unit of 

measurement. 

 

This guide uses the default measurement of Inches throughout the 
exercises. 

 
Customizing the design tools for document creation. 
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Tree View 

To set the Tree view preferences 

1 Under the Workspace category, select Tree View. 
The Tree View preferences page displays. 

2 Select Switch panel view.  
This option is on by default.  This displays the Switch Panel in the Project 
Tree View window.  The switch panel allows you to view or hide a particular 
object in your application, lock a resource for modifications, or mark an 
object for not printing. 

3 Select Scope specific resource view. 
This option is off by default.  When you add new objects to your project tree, 
they are added under the Resources node and sorted by the resource type, i.e. 
forms, fonts, images, and segments.  Selecting this option sorts the new 
resources under Global,  Local, or Shared nodes that defines the sharing 
attributes of a particular resource. 

4 From the Open resources scope drop-down list, select what node (Global, 
Local, or Shared) you want new design objects to be added to. 
Local resources are stored in the Clients default folder, where the application 
is stored.  Shared resources are stored in the fshared folder.  Global resources 
are stored in the resource lib folders, which include formlib, seglib, imglib, 
etc. 

5 Select Tree Filters and check all the graphical objects that you want listed in 
the project tree. 
If you uncheck any of the object types, that object’s nodes will not be visible 
in the design tree. 
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Customizing the view of the design tree. 

Source 

To set the Source view preferences: 

1 Under the Workspace category, select Source. 
The Source preferences page displays.  Here you can set display settings for 
different elements within the Source window. 

2 From the Source area, select a source element. 
Each source element refers to different types of information displayed in the 
Source View of the design area. 

3 Using the drop-down lists, select a Back Ground and Fore Ground color for 
the selected element. 

4 Select a font and point size for the selected element from the Source View 
Font area. 
The colors and font selected are used to display the source element in the 
Source View of the design area.  Sample preview of the selected settings can 
be viewed in the Preview area. 
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Customizing the Source window view. 

Data 

To set the Data view preferences 

1 Under the Workspace category, select Data. 
The Data preferences page displays.  Here you can set display settings for the 
Data View window. 

2 Using the drop-down lists, select a Background and Foreground color for the 
Data View window. 

3 Select a Font Name and Font Size. 
The colors and font selected are used to display information in the Data View 
window. 
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Customizing the Data View window view. 

Print Category 
You can specify your default settings for printing in the Print category. 

1 Select the Print category. 
The Print preferences page displays. 

2 From the Paper Size drop-down list, select the default paper size for printing. 
This is only a default setting; when printing, you have the option to set any 
page size you want. 

3 From the Orientation drop-down list, select the default orientation for 
printing. 
This is only a default setting; when printing, you have the option to set any 
orientation you want. 

4 Select Print Grids, if you would like the grids to print. 
5 In the Cycle Copy entry box, specify the number of document copies to print. 
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Setting default print properties. 

You have completed setting Print properties. 

Import Category 
You can specify your default settings for importing projects in the Import category. 

1 Select the Import category. 
The Import preferences page displays. 

2 In the Text Grouping area, select Group.  Group enables the text grouping of 
similar text objects.  The other options are: 
! None – disables the text grouping. 
! Maximum – enables text grouping for all text objects, including those with 

spaces. 
3 Select Process Elixir Comments if not already selected. . 

This option automatically processes the non-VIPP comments.  This option is 
used when importing a previously exported Vitesse design. 

4 Select Process Legacy Comments if not already selected. . 
This option processes the inherent comments in a legacy project.  For 
example, VIPP comments in a native VIPP project.   
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Setting default import properties. 

You have completed setting Import properties. 

Export Category 
You can specify your default settings for exporting projects in the Export category. 

1 Select the Export category. 
The Export preferences page displays. 

2 In the Comments area, select Lightly Commented that displays Elixir 
comments for selected objects in the Source View of the design area. 
The No Comments option will not display comments, whereas selecting the 
Heavily Commented option displays general comments in the Source View of 
the design area. 

3 Select Generate Elixir Comments. . 
This option processes non-VIPP commands automatically.  This option is 
used when the project contains Elixir or non-VIPP objects.  These non-VIPP 
objects will be converted into VIPP objects during export. 

4 Select the Default unit of your choice.   
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Generally VIPP uses the Dot3 unit of measurement. 

 
Setting default export properties. 

You have completed setting Export properties. 

Legacy Fonts Category 
When designing projects or resources in Vitesse, you can use legacy fonts.  Legacy 
refers to FNTs or Elixir fonts used previously, either on printers or in the Elixir 
Application Suite.   If you select a legacy font for use in Vitesse, it will be used for 
display and is termed a render font.  When the project or resource is complete, you 
will export it to VIPP format for printing.  The export process uses the Legacy Fonts 
table to equate the render  font with a VIPP font name.  The printer then uses the 
VIPP font name to locate a printer font for printing. 

The Legacy Fonts table associates render fonts with printer fonts.  There are two 
major columns in the Legacy Fonts table: Legacy and VIPP.  Vitesse installs with 
some common VIPP font names already set up to match legacy fonts.  The Legacy 
Font table is editable, allowing you to add and change the default mappings if 
necessary to match your font usage. . 

1 Select the Legacy Fonts category. 
The Legacy Fonts preferences page displays. 

2 Scroll to the bottom of the table. 

3 In the Legacy Fonts table, click  
A new, empty font will be added to the bottom of the list. 

4 Double-click the new empty cell in the Legacy column and enter a legacy 
font name. 
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5 Double-click the cell in the VIPP column and select a font from the drop-
down list. 
You have now associated the Legacy and VIPP fonts. 

 
Mapping legacy fonts to VIPP font names. 

You have finished setting up the Legacy Fonts properties. 

Font Map Category 
When designing projects or resources in Vitesse, you can use either True Typeor 
PostScript Type 1 fonts.  This font is termed a render font, and is used for display in 
Vitesse.  When the project or resource is complete, you will export it to VIPP format 
for printing.  The export process uses the Font Map to equate the render  font with a 
VIPP font name.  The printer then uses the VIPP font name to locate a printer font for 
printing. 

For example, if you use the True Type font Courier New in your project, the project 
will reference the VIPP font NCR when exported for printing. 

A Font Map, then, associates render fonts with printer fonts.  There are three major 
columns in the Font Map:  

! VIPP 
! PostScript  
! True Type 
Vitesse installs with the most common VIPP font names already set up to match their 
True Type equivalent in the Font Map.  The Font Map is editable, allowing you to 
change the default mappings if necessary to match your font usage. 
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You can install PostScript fonts on your operating system and add them to the Font 
Map so that Vitesse uses the same font for rendering as the printer uses print.  If both 
True Type and PostScript fonts are available, Vitesse will use the PostScript fonts for 
display. 

1 Select the FontMap category. 
The FontMap preferences page displays. 

2 Scroll to the bottom of the table. 

In the Font Mapping table, click  
A new, empty font will be added to the bottom of the list. 

3 Double-click the new empty cell in the VIPP column and enter a VIPP font 
name. 

4 Double-click the cell in the PostScript column and select a font from the 
drop-down list. 
You have now associated the VIPP and PostScript fonts.  The drop-down list 
only includes PostScript fonts that have already been installed on your 
operating system. 

5 Double-click the True Type font and select a font from the drop-down list.  
You have associated a VIPP font with True Type and PostScript fonts.  If the 
True Type font you select is not already bold or italicized, the ‘B’ and ‘I’ 
check boxes become active and you can set the font to Bold and Italic. 

 

VIPP supports PostScript fonts either as PostScript resources or as 
VIPP resources.  Fonts must be accessible to the PostScript interpreter 
on which VIPP is running. 
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Mapping VIPP, Post Script, and True Type fonts. 

You have finished setting up FontMap properties. 

Folder Category 
Under the Folder category you can specify resource directories.  Vitesse will search 
the folders listed here when looking for resources referenced in a Vitesse or VIPP file. 

1 Under the Folder category, select Form. 
The Form preferences page displays. 

2 Click  to add a new Form directory to the list.  
3 Browse to select a folder to be added to the directory list, and click OK. 

The new location is added to the folder directory list. 
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List directories containing forms that you will use in document creation. 

Follow the same steps to specify resource directories for Segment, Image, JDT, 
Project, Encoding, and Misc resources. 

You have completed setting Folder preferences.  

Barcode Category 
1 Select the Barcode category. 

The Barcode preferences page displays.  This category associates barcodes 
with a True Type or PostScript font for printing.  Fonts must be accessible to 
the PostScript interpreter on which VIPP is running. 

2 Select a True Type or Post Script font from the drop-down list to be 
associated with any barcode type you will use in your projects. 
Follow the same steps to associate fonts with the remaining barcode types. 
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Mapping True Type or Post Script fonts to the listed barcodes. 

You have finished setting the Barcode properties. 

Defaults Category 
There are six sections under the Defaults category: 

! Text 
! Dictionary 
! Color 
! Layout 
! Transform 
! Regional 
Defaults are used for new and imported resources and projects.  

Typically, VIPP resources and projects contain all the information required to print.  
However, it is possible that certain pieces of information can be missing, such as the 
default font or page size, because that information is available on the printer.  When 
imported VIPP documents or resources do not contain all the necessary information, 
the defaults set in the Preferences dialog box are used.  For example, if a VIPP form 
does not contain page size information, the default page size set under Defaults will 
be used when importing the form. 

 

When importing, it is good practice to double-check the defaults in 
Preferences.  Then, if any information is missing in your imported file(s), 
the replacement defaults will be correct. 
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Text 

1 Under the Defaults category, select Text. 
The Text preferences page displays. 

2 In the Text area, set the Alignment, Paragraph Spacing, Line Spacing, and 
Spell Checker Depth properties to apply to all text objects. 
Spell Checker Depth spell checks selected text according to the specified 
spell check intensity (0-100), 0 being the lowest and 100 being the highest 
level of checking. 

3 In the Tab area,  specify the Default Size and Alignment of the default tab. 
4 In the Indentation area, specify the Left Indent, Right Indent, and First Line 

Indent in your chosen default unit of measurement. 
5 In the Font area, specify the font Type, Name, and Size of the Vitesse default 

font. 
It is recommended that you select a font that is used in your environment. 

 
Setting default text properties. 

You have finished setting Text properties. 

 

The Dictionary category is used to specify a default dictionary for spell 
checking text within text objects.  You will not use this category in the 
exercises explained later. 
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Color 

1 Under the Defaults category, select Color. 
The Color preferences page displays. 

2 In the Color area, select a Color from the color palette to apply to all objects. 
3 In the Pattern area, select a default Line Pattern and a default Fill Pattern. 

 
Setting default color properties. 

You have finished setting Color properties. 

Layout 

1 Under the Defaults category, select Layout.  
The Layout preferences page displays.  This category defines defaults for 
paper dimensions, media properties, and logical page margins for new 
applications. 

2 In the Grid area, set the number of Characters per line and Lines per page. 
Characters per line and Lines per page settings apply only to Line mode data 
projects.  

3 In the Paper area, define the paper size either by selecting one of the listed 
sizes in the Standard drop-down list, or by selecting Custom and entering the 
page size manually in the W (width) and H (height) entry boxes. 

4 Specify the Orientation of the page by selecting a page orientation from the 
drop-down list. 

5 In the Margins area, set the Top, Bottom, Left, and Right margin values in the 
default unit of measurement. 

6 In the Media area,  define the default paper Type, Weight, and Color.  
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Setting default page layout properties. 

You have completed setting Layout properties. 

Transform 

Under the Transform category, you can specify number formats that will be used in 
Vitesse for numeric fields.  When mapping numeric fields from a data file or entering 
static text, you can apply any of these formats to transform the field to the selected 
format.  Formats may include: currency, dates, etc. 

1 Under the Defaults category, select Transform. 
The Transform preferences page displays. 

2 Click   to add a new Transform format to the list. 
A new, empty Transform format is added to the list.  

3 Enter a number format and click OK to save your settings. 
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Setting default transform properties. 

The Transform formats use two main symbols: 

! @: denotes a number.  Leading and trailing zeros will not be printed. 
! #: denotes a number.  Leading and trailing zeros will be printed. 
Other characters are treated as literals.  Some examples of Transform formats are as 
follows: 

Date 

! Incoming data: 03042003 
! Transform format: @@/@@/@@@@ 
! Result: 03/04/2003 
Currency 

! Incoming data: 1201 
! Transform format: $@,@@@.@@ 
! Result: $1,201.00 
Numeric, Example 1 

! Incoming data: 1201 
! Transform format: ###### 
! Result: 001201 
Numeric, Example 2 

! Incoming data: 053298443 
! Transform format: ###-##-#### 
! Result: 053-29-8443 
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You have completed setting Transform properties. 

Regional 

Under the Regional category, you can select numeric formats for your region. 

1 Under the Defaults category, select Regional. 
2 Select US, Europe, or Custom from the Region drop-down list. 

US and Europe have preset numeric formats.  Select Custom to set your own 
formatting. 

 
Setting default regional properties. 

You have completed setting Regional properties. 

Environment Issues 
There are some issues that you may need to take into consideration when using 
Vitesse: 

! Migrating from VIPP IDE – If you are migrating from the VIPP IDE 
environment 

! Display Issues – If you are having trouble reading text within Vitesse 

Migrating from VIPP IDEfrom VIPP IDE 

If you are migrating from VIPP IDE, reference your resource folders within Vitesse.  
Specify VIPP IDE resource directory paths by choosing Tools>Preferences from the 
menu, and selecting the Folders category.  This will allow you to access your 
resources while working in Vitesse. 
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VIPP IDE applications can be imported using File>Import.  For VIPP applications 
that are not successfully imported, Vitesse provides an error message and the line 
number in the VIPP code in the Message View window.  

Display Issues 

Vitesse is best viewed at 1024 x 768 screen resolution.  You can also customize the 
Vitesse workspace to accommodate different screen resolutions. 

If you find the text in the Vitesse workspace to be unreadable, customize your 
Windows Display Properties to use the Windows Standard theme text specifications. 
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Chapter 4: A Vitesse Tour 

The situation is always the same: your client wants well-designed documents, printed 
by a date that seems unrealistic.  The challenge is to create quality while still meeting 
the deadline. 

Where to start? Every document starts with data and a mockup.  

For the data, you’ll want a sample file, which is representative of the whole data file, 
while not being too big.  This will keep print previews, which combine the data file 
with your work, from being long and cumbersome to review. 

The mockup can be a pencil drawing, an idea, or a full-blown marketing layout.  You 
need to have an idea of the finished product before you start.  Where will the data go? 
What items are static, or don’t change from document to document? What items need 
to change in each document? Is that information available in the data file? What 
conditional logic is needed to change the look of each individual document? 

You also need to gather your resources.  There are three states for resources in 
Vitesse: Local, Shared or Global. 

Local resources are embedded in a document, and cannot be used by another 
document.  An example would be a segment combining information that is only 
needed in one form or application.  Shared resources are used for more than one 
Vitesse document, such as a segment combining the company logo and address 
information that is used on all company documents.  Global resources are used for 
documents both in and out of Vitesse, such as a bitmap image. 

Once you have a mockup, you can start with the form.  Vitesse can create forms from 
scratch, or modify forms you already have in Xerox or VIPP format.  Any Xerox 
form can be imported into Vitesse. 

You can also insert VIPP segments, or create new segments directly in Vitesse.  
Segments are mini-forms, combining form elements for use within forms and project 
modes.  Segments can be scaled and rotated within forms and projects. 

Once the form is complete, you can start designing with data, using one of the four 
project modes: Native mode, Line mode, Database mode, or XML mode.  The mode 
you use depends on the data file you are using to build the application.  Vitesse 
supports Merged Data view, which merges the contents of your data file onscreen 
while designing a project. 

Once the application is complete, use print preview to simulate proofing.  The entire 
data file is combined with the project onscreen.  You can even print the preview to 
your desktop printer for a printed proof. 
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All the resources you have created, from forms, segments and fonts to entire projects, 
can be exported  to VIPP format directly in Vitesse. 

What is the solution to getting to print on time, with quality materials? Vitesse. 

Creating a Form 
You will start your Vitesse Tour by learning how to create a form.  The objective of 
this portion of the Tour is to provide you with comprehensive understanding of form 
design and creation in Vitesse.  The form you will create is a statement for Jefferson 
Bank & Trust.   

For this form you will use various drawing tools such as lines and boxes, add and 
import text objects and insert images.  You will also create a VIPP segment and insert 
it into the form.  Once the form is complete, you will save the completed form under a 
different name.   

To create the Jefferson Bank & Trust statement form, you will:  

! Add lines and boxes 
! Add and import text 
! Add images 
! Create a segment 
! Edit a previously created form  
! Save your form 

 

You will be introduced to various new properties and functionalities.  
You can refer to theVitesse User Guide for details on each individual 
option. 

Understanding the Application  
Jefferson Bank & Trust (JBT) sends out a monthly statement to their clients giving 
them a detailed account of their transactions throughout the month. 

JBT needs a form containing static text and graphical elements, which they can use as 
a background for variable data, to print and send out to their clients.   

A form holds static information, such as graphics, text and drawing objects.  Before 
you start designing, it is a good idea to have a mockup of the form so you can see 
what you are building. 
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A mockup of completed form. 
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Creating a New Form 
To create a new form using Vitesse: 

1 From the Start menu, select Programs>Elixir Applications>Vitesse>Vitesse. 
Vitesse opens.  

2 From the menu, choose File>New. 
The New Project dialog displays.  

 
The New Project dialog displays. 

3 Select Form and click New. 
The Form dialog displays. 
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The Form dialog displays. 

4 Enter GSJBTStatement in the Name entry box. 
Browse to select the working folder, where the form will save, or enter the 
path to the working folder in the Path entry box. 
You can also use the default path provided.  This exercise uses the default 
path. 

5 Click OK. 
The new form opens in the design area. 
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Setting Form Properties 
You will now set up form properties.  You will set the form size to match the physical 
page size, which you will set when you work in project mode.   

1 In the Property View window, select the General tab. 
The name is already GSJBTStatement. 

2 In the Standard drop-down list, select Letter. 
Set the paper Orientation to Portrait. 

3 Check Cache.  
The Cache option loads all resources to the printer’s memory, or cache, 
before printing.  Resources are retrieved from the cache during printing.  
Using this option speeds the printing process.  

 
Setting up form properties in the Property View window. 

You have finished setting up the GSJBTStatement form’s properties.   

Adding Objects to the Form 
You will now start adding objects to the form.  You will add an image, a box and 
several lines to create your form.  You will also import and add text objects. 

Adding an Image 
You will begin your form design by adding the Jefferson Bank & Trust’s logo to your 
statement. 

Vitesse supports many different image file formats.  The image you use should be 
located on your PC or network. 
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To add an image:  

1 On the Insert toolbar, click . 
The Insert Image dialog displays. 

 
Browse to select an image on your PC or network. 

2 Browse to drive:\ program files\elixir technologies\vitesse\imglib\ and 
select gs_logobank.jpg. 

3 Click Open to insert the image in the design area. 
4 GS_logobank adds in the design area.  In the Project Tree window, a new 

image reference node adds and its properties are viewable in the Property 
View window. 

 

To view properties of any object, select it in either the Project Tree 
window or the design area.  You can define the settings of all objects 
inserted in your design using the Property View window. 

5 In the Property View window, enter the following: 
! Name: JBTLogo  
! Position: 

X:  0.50 in Absolute 
Y:  0.50 in Absolute 
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! Size: 
W:  2.00 in 
H:  1.20 in 

 

The Size area shows the default size of the inserted object.  If you type 
in a different dimension, the image resizes.  You do not need to enter 
both the width and the height of the image.  Vitesse maintains the 
image�s aspect ratio automatically: when you change the height, the 
width changes proportionally to the image's original size. 

 
Setting the image’s position and size properties. 

You can turn the grid off by clicking   in the View toolbar above the 
design area.  This exercise has the grid turned off. 

You can leave the Settings and Color tabs at their default settings.  You have added 
the JBT Logo to your design. 

 

The Jefferson Bank & Trust statement form has a mockup that includes 
dimension and location coordinates.  You can visually match size and 
location throughout the exercise, if you do not wish to enter coordinates 
for each object. 

You will now add drawing objects to your form. 
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You have added the image to your design. 

Adding Drawing Objects 
You will add various drawing objects to complete your design.  These drawing 
objects include boxes, lines and text.  You will add these to your design using the 
insert object buttons on the Drawing toolbar and then assign different properties 
and colors to them using the Property View window.   

Adding a Box 
The JBT statement needs a box in the background of the form.  The statement’s 
transactional data will be added within the box area.   

You will now add the box to your design.  This box will cover a significant area of 
the form and will be filled with a color pattern.   

1 On the Drawing toolbar, click . 
2 Click and drag in the design area to draw a large box. 

A box is added to your design area and a corresponding box node is added in 
the Project Tree window.  Do not worry about the exact size and location of 
the box; you will add these using the Property View window. 

3 In the Property View window, select the General tab and specify the 
following: 
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! Position: 
X:  0.00 in  
Y:  4.00 in 

! Size: 
W:  8.50 in 
H:  5.50 in 

 
Setting box properties. 

4 Select the Settings tab and set line specifications as follows: 
! Width:  1 pt 
! Style:  Solid 
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Setting box line style properties. 

5 Select the Color tab and set the following color specification: 
! Outline:   Blank RGB (255,255,255) 
! Background:  XLBLUE RGB (229,229,255) 

! Fill Pattern:  Diagonal Stripes  
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Setting the box’s color specification. 

You can click on the icons at the top left of your window to switch 
between foreground and background. 

You can use left-click to select a color for the selected icon (foreground 
or background), or right-click to select a color for the unselected icon 
(background or foreground). 

6 Zoom out to view the entire box. 
You have added a box object to your design. 
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The box is added to your design. 

Adding Lines 
You will now add lines to your form.  These lines will mark the top and bottom of the 
box, and will also create an area at the top of the box for account summary 
information. 

1 On the Drawing toolbar, click .  
2 Click and drag in the design area to draw a line across the top of the box. 

A line is added to your design area and a corresponding node is added in the 
Project Tree window. 

3 In the Property View window, select the General tab and enter the start and 
end point coordinates as follows: 
! Start Point: 

X:  0.00 in  
Y:  4.00 in 

! End Point: 
X:  8.50 in  
Y:  4.00 in 
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Setting the line’s position and size. 

4 Select the Settings tab and select line specifications as follows: 
! Width:  1 1/2 pt 
! Style:  Solid 

 
Setting the line style. 
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Adding a New Color to the Palette  
For this application you will add a new shade of blue to the color palette.  You will 
use the new color for all of the lines in the form.  You will also use the new color 
when you create a segment. 

1 Select the Color tab and click  
The Color Selector dialog displays. 

 
Define RGB values in the Color Selector dialog. 

2 Select RGB from the Selected Color Model drop-down list. 
3 Enter the following values for RGB: 

! R: 102  
! G: 123  
! B: 179  

4 Enter NewBlue in the Color Name entry box. 
5 Click OK. 

The new color is added to the color palette. 
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NewBlue is added to the palette. 

6 Click  on the Color tab to save the new color in the palette.  
7 Set the following color specification: 

! Outline:   NewBlue RGB (102,123,179) 
! Background:  Blank RGB (255,255,255) 

Using Copy and Paste 
You have added the first line to your application.  You will use copy and paste to 
create the remaining lines for the form.   

1 Right-click the Line node in the Project Tree window and select Copy from 
the pop-up menu. 

2 Right-click the design area and select Paste from the pop-up menu. 

 

You can also use Ctrl + C to copy and Ctrl + V to paste. 

3 Click the new Line node in the Project Tree window to set its properties. 
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4 In the Property View window, select the General tab and enter the start and 
end point coordinates as follows: 
! Start Point: 

X:  0.00 in 
Y:  4.75 in 

! End Point: 
X:  8.50 in 
Y:  4.75 in 

5 Click in the design area and use Ctrl + V to paste another line. 
6 In the Property View window, select the General tab and enter the start and 

end point coordinates as follows: 
! Start Point: 

X:  0.00 in 
Y:  9.50 in 

! End Point: 
X:  8.50 in 
Y:  9.50 in 

You have finished adding lines to your application. 

 
You have finished adding lines to your design. 
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You will now add text objects to your application. 

Adding Text 
Next, you will add text to the application.  You will first import two text objects.  The 
first includes the bank’s contact information, and the second is a marketing message, 
which will be added at the bottom of the form.   

Vitesse can only import RTF files. 

Importing Text 

1 On the Drawing toolbar, click  .   
2 Click and drag in the design area to draw a text box above the shaded box on 

the right side of the form. 
A new text box is added in the design area and a corresponding text node is 
added in the Project Tree window. 

3 Right-click the text box and select Import from the pop-up menu. 
The Import Text dialog displays. 

 
The Import Text dialog displays. 

4 Browse to drive:\ program files\elixir 
technologies\vitesse\clients\gs\tour_form, and select gs-contact.rtf. . 

5 Click Open. 
The text from the RTF file is imported into the text box.   

6 Click outside the text box to place the text. 
Nodes display on the edges of the text box.   
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7 In the Property View window, select the General tab and enter JBTContact 
in the Name entry box. 

8 Specify the Position and Size specifications as follows: 
! Position: 

X:  6.05 in Absolute 
Y:  2.58 in Absolute 

! Size: 
W:  2.05 in 
H: 0.93 in 

All other properties are imported because they were set in the RTF file. 

 
Setting Position and Size settings for the imported RTF text. 

 

You can enter text properties while the cursor is still active inside the 
text object.  The properties won�t be saved to the object, however, until 
you click outside of the text object.  It is recommended to finish typing 
the text, then click outside the text object.  This action updates the text 
object with the specified properties. 

 

You can also set the name and size specifications, then click and drag 
the text box to its position on the letter.  The positioning does not have 
to be exact. 

You have added the first text object.  Now you will import the second RTF file for the 
marketing message text object.   

9 On the Drawing toolbar, click .  
10 Click and drag in the design area below the shaded box to draw a text box. 
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You can use the scroll bars and the zoom to view any portion of the screen. 
11 Right-click the text box and select Import from the pop-up menu. 

The Import Text dialog displays. 

 
Importing the next RTF file for the form’s design. 

12 Browse to drive:\program files\elixir technologies\vitesse\clients\ 
gs\tour_form and select GS-Mktgmsg.rtf. 
The text from the RTF file imports into the text box.   

13 Click outside of the text box to place the text. 
Nodes display on the edges of the text box.   

14 In the Property View window, select the General tab and set the following 
properties: 
! Name: MktgMsg 
! Position: 

X:  1.80 in Absolute 
Y:  9.70 in Absolute 

! Size: 
W:  5.50 in 

You have finished importing text for this exercise.  You will continue adding text 
objects to complete the form. 

 

You can also set the name and size specifications, then click and drag 
the image to its position on the letter.  Positioning does not have to be 
exact. 
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The imported text is added to the form. 

Adding Text 
Now you will add a text object by typing in the text directly in the design area.  You 
will also create a font style that can be used again on other text objects.  This reduces 
the formatting work needed when adding multiple text objects. 

1 On the Drawing toolbar, click . 
2 Click in the design area between the first two lines to start a text box. 
3 Type in Account [Enter] Summary. 

You may want to zoom in to view the text more easily. 
4 Click outside of the text box to place the text. 
5 In the Property View window, select the General tab and enter the following 

specifications: 
! Name:  ACSum  
! Position: 

X:  0.05 in Absolute 
Y:  4.10 in Absolute 
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6 Select the Font tab and specify the following font settings:  
! Type:  True Type 
! Name:  Arial 
! Size:  14.00 pt 

7 Click . 

8 Click . 
9 In the Style entry box, enter Bold14. 

10 Click . 
Bold14 is added to the Style drop-down list.  You have saved the font style 
and can apply it to other text objects using the same font specifications. 

 
Setting a font style on the Font tab. 

 

The BAT font option defines a pre-determined set of background colors 
and formats for text.  BAT stands for Background Attribute. 

11 Select the Spacing tab and select Single from the Line Spacing drop-down 
list. 
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Setting the line spacing attributes. 

You have added the Account Summary heading.  You will now add sub-headings for 
the Account Summary area. 

12 On the Drawing toolbar, click .   
13 Click to the right of Account Summary to start a text box. 
14 Enter Account Type and click outside the text box to place the text. 
15 In the Property View window, select the General tab and enter the following 

specifications: 
! Name:  ACType 
! Position: 

X:  1.50 in Absolute 
Y:  0.00 in Start Same 

 

By selecting Start Same you have applied a relative horizontal position 
to the text object.  This text object will be placed in the same horizontal 
position as the last text object. 
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 You do not need to add a width for a text box when typing directly in the 
design area unless you want the text to wrap to the next line, or want to 
justify the text within specific dimensions.  You do not need to add a 
height unless you are justifying the text vertically; i.e., trying to center 
the text vertically on the page.  If you don�t add a specific height, the 
text automatically top-justifies, and the height is added for you based on 
the font size, the amount of text, etc. 

16 Select the Font tab and specify the following font settings: 
! Type:  True Type 
! Name:  Arial 
! Size:  12.00 pt 

17 Click . 

18 Click  . 
19 In the Style entry box, enter Bold12. 

20 Click  . 
Bold12 is added to the Style drop-down list.  You have saved the font style 
and can reapply it to other text objects using the same font specifications. 

Copying Text Objects 
You have added the Account Type heading.  You will use copy and paste to create the 
remaining headings for this section of the form. 

1 Right-click the text object Account Type and select Copy from the pop-up 
menu. 

2 Right-click the design area and select Paste from the pop-up menu. 

 

You can also use Ctrl + C to copy and Ctrl + V to paste. 

3 Double-click the new text box, delete the existing text, and enter Starting 
Balance. 

4 Click outside the text box to place the text. 
5 In the Property View window, select the General tab and set the following 

specifications: 
! Name:  StartBal 
! Position: 

X:  2.95 in Absolute 
Y:  0.00 in Start Same 
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6 Select the Font tab and select Bold12 from the Style drop-down list. 
You have added the Starting Balance heading. 

 
The first few headings have been added to the statement design. 

7 Use Ctrl + V to paste another text object in the design area. 
8 Double-click the text box, delete the existing text, and enter Credits. 
9 Click outside the text box to place the text. 
10 In the Property View window, select the General tab and enter the following 

specifications: 
! Name:  Credits 
! Position: 

X:  4.70 in Absolute 
Y:  0.00 in Start Same 

11 Select the Font tab and select Bold12 from the Style drop-down list. 
You have added the Credits heading. 

12 Use Ctrl + V to paste another text object in the design area. 
13 Double-click the text box, delete the existing text, and enter Debits. 
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14 In the Property View window, select the General tab and enter the following 
specifications: 
! Name:  Debits 
! Position: 

X:  5.49 in Absolute 
Y:  0.00 in Start Same 

15 Select the Font tab and select Bold12 from the Style drop-down list. 
You have added the Debits heading. 

16 Scroll to view the right side of the page. 
17 Use Ctrl + V to paste another text object in the design area. 
18 Double-click the text box, delete the existing text, and enter Ending Balance. 
19 In the Property View window, select the General tab and enter the following 

specifications: 
! Name:  EndBal 
! Position: 

X:  6.55 in Absolute 
Y:  0.00 in Start Same 

20 Select the Font tab and select Bold12 from the Style drop-down list. 
You have added the Ending Balance heading.  You have completed adding 
headings for the Account Summary section of the form. 

 
The Account Summary area is complete. 

Now you will add the heading and sub-headings for the transactions. 

21 On the Drawing toolbar, click  .   
22 Click in the design area underneath the second line in the shaded box to start 

a text box. 
23 Enter Date and click outside the text box to place the text. 
24 In the Property View window, select the General tab and enter the following 

specifications: 
! Name:  Date 
! Position: 

X:  1.50 in Absolute 
Y:  4.75 in Absolute 



 

Chapter 4: A Vitesse Tour 87 

25 Select the Font tab and specify the following: 
! Type:  True Type 
! Name:  Arial 
! Size:  10.00 pt 

26 Click . 

27 Click . 
28 In the Style entry box, enter Bold10. 

29 Click . 
Bold10 is added to the Style drop-down Style list.  You have saved the font 
style and can apply it to other text objects using the same font specifications. 
You have added the Date heading.   

You will use copy and paste to add the remaining headings. 

30 Select the Date text object and press Ctrl + C. 
31 Press Ctrl + V to paste the text object. 
32 Double-click the new text box, delete the existing text, and enter Description. 
33 Click outside the text box to place the text. 
34 In the Property View window, select the General tab and enter the following 

specifications: 
! Name:  Descr 
! Position: 

X:  2.30 in Absolute 
Y:  0.00 in Start Same 

35 Select the Font tab and select Bold10 from the Style drop-down list. 
You have added the Description heading. 

36 Press Ctrl + C and Ctrl + V to copy/ paste another copy of the Date text 
object. 

37 Double-click the new text box, delete the existing text, and enter Credit. 
38 Click outside the text box to place the text. 
39 In the Property View window, select the General tab and set the following: 

! Name:  Credit 
! Position: 

X:  6.25 in Absolute 
Y:  0.00 in Start Same 

40 Select the Font tab and select Bold10 from the Style drop-down list. 
You have added the Credit heading. 
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Note that there is a Credits (plural) node and a Credit (singular) node.  
The names of each node must be unique within one resource. 

41 Press Ctrl + V to paste another copy of the Date text object. 
42 Double-click the new text box, delete the existing text, and enter Debit. 
43 Click outside the text box to place the text. 
44 In the Property View window, select the General tab and set the following: 

! Name:  Debit 
! Position: 

X:  7.30 in Absolute 
Y:  0.00 in Start Same 

45 Select the Font tab and select Bold10 from the Style drop-down list. 
You have added the Debit heading. 

 
The transaction headings are complete. 

Now you will add the heading for the marketing message at the bottom of the page. 

46 Scroll to the bottom of the page. 

47 On the Drawing toolbar, click .   
48 Click and drag in the design area to draw a text box. 
49 Click the text box and enter Important [Enter] Information. 
50 Click outside the text box to place the text. 
51 In the Property View window, select the General tab and specify the 

following: 
! Name:  ImpInfo 
! Position: 

X:  0.05 in Absolute 
Y:  9.67 in Absolute 

52 Select the Font tab and select Bold14 from the Style drop-down list. 
53 Select the Spacing tab and select Single from the Spacing drop-down list. 

You have added the Important Information heading. 
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The form is almost complete. 

 You have completed adding text to your application. 

Saving the Form 

1 On the Standard toolbar, click . 
Your form saves under the name GSJBTStatement.   

2 From the menu, choose File>Close. 
GSJBTStatement closes. 

Creating a Segment 
Now you will create a segment to use on the form.  A segment can be thought of as a 
small form containing objects that you will use again and again.  Segments can be 
added to forms or projects, and can be scaled or rotated as needed. 

The JBT segment contains a rounded corner box, with a watermark of their logo.  It 
also contains a text object for the text “Account Number” and “Statement Date”.  JBT 
is planning on using this design element on many of their statements, in many 
different sizes.  Therefore, it should be created as a segment. 
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The finished segment. 

3 From the menu, choose File>New. 
The New Project dialog displays. 

 
Opening a new segment. 

4 Select Segment and click New. 
The Segment dialog displays. 
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The Segment dialog displays. 

5 Enter GSJBTSeg in the Name entry box. 
6 Browse to select the working folder where the segment will be saved, or enter 

the path to the working folder in the Path entry box. 
This exercise uses the default folder.  The new segment opens. 

 
The new segment opens. 
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Setting Segment Properties 
To set the segment properties: 

1 In the Property View window, select the General tab. 
The name is already GSJBTSeg. 

2 Set the Size specifications as follows: 
! W:  2.10 in 
! H:  2.10 in 

 
Setting segment properties in the Property View window. 

3 Select the Settings tab and specify the following: 
! Origin: 

X:  0.00 in 
Y:  0.00 in 

! Clip and Cache: Checked 
Clipping truncates any object that is off the page.  Caching loads resources to the 
printer’s memory so they can be retrieved locally during printing. 
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The Settings tab for a new segment. 

You have finished setting up segment properties.  You will now add objects to create 
your segment. 

Adding a Box 
The segment includes a rounded corner box.  You will start the segment by adding 
this box.   

1 On the Drawing toolbar, click . 
2 Click and drag in the design area to draw a box. 

A box is added to your design area and a corresponding node is added in the 
Project Tree window. 

3 In the Property View window, select the General tab and set the position and 
size specifications as follows: 
! Position: 

X:  0.10 in  
Y:  0.10 in 

! Size: 
W:  1.90 in 
H:  1.90 in 
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4 Select the Settings tab and select line specifications as follows: 
! Width:  1/2 pt 
! Style:  Solid 

5 Check Rounded Box and enter 0.30 in the Radius entry box.  

 
Setting a Radius creates a rounded corner box. 

6 Select the Color tab and click . 
NewBlue RGB (102,123,179) adds to the color palette. 

7 Specify the following color settings: 
! Outline:   NewBlue RGB (102,123,179) 
! Background:  Blank RGB (255,255,255) 
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Setting NewBlue as the Box’s color. 

The box object is complete. 

Adding Text 
You will now add the text object for the segment.  This text object will be justified in 
the middle of the box. 

1 On the Drawing toolbar, click . 
2 Click in the design area to start a text box. 

A new text box is added in the design area and a corresponding text node is 
added in the Project Tree window. 

3 Enter the following text:  
Account Number [Enter] 
[Enter] 
[Enter] 
[Enter] 
Statement Date 

4 Click once outside the text box to place the text. 
You have added the text object. 
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Setting Text Properties 
To set the text properties: 

1 In the Property View window, select the General tab and enter the following 
specifications: 
! Name: SegText 
! Position: 

X:  0.10 in Absolute 
Y:  0.20 in Absolute 

! Size: 
W:  1.90 in 

2 Select the Font tab and specify the following: 
! Type:  True Type 
! Name:  Arial 
! Size:  12.00 pt 

3 Click . 

4 Select the Spacing tab and click  . 
5 In the Line Spacing drop-down list, select Single. 

You have set properties for the segment text. 

 
A box and text add to the segment. 
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Adding an Image 
The last step in creating the segment is to add the image.  This is a screened back 
version of the JBT logo that will act as a watermark. 

1 On the Insert toolbar, click .   
The Insert Image dialog displays. 

 
2 Browse to drive:\program files\elixir technologies\vitesse\imglib and select 

GS_LogoOnly.jpg.  
LogoOnly adds in the design area.  In the Project Tree window, a new image 
reference node adds and its properties are viewable in the Property View 
window. 

Setting Image Properties 
1 In the Property View window, select the General tab and enter the following 

specifications: 
! Name: JBTWM  
! Position: 

X:  0.25 in Absolute 
Y:  0.25 in Absolute 

! Size: 
W:  1.60 in 
H:  1.61 in 
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You are resizing the image to fit your application design.   

 

You do not need to enter both the width and the height of the image.  
Vitesse automatically retains the aspect ratio of the image. 

 
Setting the image properties of the watermark.   

You can leave the Settings and Color tabs at their default settings. 

You have added the JBT watermark to your segment. 

Arranging Objects 
The image is placed over the box and text because it was added last.  You need to 
arrange the objects to send the image to the background of the segment, so the text 
becomes visible. 

1 Select the image by clicking either the image in the design area or by clicking 
the JBTWM node in the Project Tree window. 

2 On the Arrangement toolbar, make sure  is selected. 
The image is sent to the background of your segment and the text object 
becomes visible in the foreground. 
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Aligning Objects 
Now you will align the objects to make them appear neater and more defined. 

You will align the box and the image first. 

1 In the Project Tree window, make a multiple selection of the Box and 
JBTWM nodes by clicking on each node while holding down the Ctrl key on 
the keyboard. 
You cannot select them by clicking in the design area because you have sent 
the image to the background.   

2 On the Alignment toolbar, click .  
The box and image are aligned vertically. 

3 Click .  
The box and image are aligned horizontally. 

 
You have completed designing your segment. 

Saving a Segment 

1 On the Standard toolbar, click .   
Your segment saves as GSJBTSeg.  To save the segment under a different 
name, choose File>Save As from the menu. 

2 From the menu, choose File>Close. 
GSJBTSeg closes and you return to the Vitesse workspace. 

 

The segment saves using the internal Vitesse format (EVS).  However, 
printing requires that the segment be exported to VIPP format (SEG).  
The export process is covered later in the Tour.  
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Inserting a Segment in a Form 
The last step in this exercise is modifying the form you created earlier in the section.  
You will add the new segment to the form and save the form under a different name. 

1 From the menu, choose File>Open. 
The New Project dialog displays with the Existing tab selected. 

2 Browse to drive:\program files\elixir technologies\vitesse\formlib and 
select GSJBTStatement.evf.  

3 Click Open. 
The GSJBTStatement form loads in the workspace. 

 
The statement loads. 

4 On the Insert toolbar click .  
The Insert Segment dialog displays. 

5 Select the Existing tab and browse to drive:\program files\elixir 
technologies\vitesse\seglib. 

6 Select gsjbtseg.evs and click Open. 
GSJBTSeg segment adds to the GSJBTStatement form. 
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GSJBTSeg adds to the design area. 

Setting SegRef Properties 
When you add a new or existing segment to a form, the segment is added under the 
Segments node in the Project Tree window and a SegRef reference node is added 
under the Form node. 

1 Click the SegRef1 node and select the General tab in the Property View 
window. 

2 Enter GSJBTSegment in the Name entry box. 
Remember that all tree node names must be unique. 

3 Set the Position and Size specifications as follows: 
! Position: 

X:  5.90 in Absolute 
Y:  0.50 in Absolute 

! Size: 
W:  2.00 in 
H:  2.00 in 
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You can leave all other settings at their default values. 

 
The completed statement form. 

You have finished designing your form.   

Print Preview 
Before saving and closing the form, you will print preview the document.   

1 From the menu, choose File>Print Preview. 
The form displays in the Preview window. 
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Previewing the form. 

You can also print the form to any attached desktop printer for a printed proof. 

2 Click   to close the preview. 

Saving a Form 
You are ready to save and close the form. 

 

In order to save a form under a different name, the Form name must be 
selected in the Project Tree.  It is selected by default when returning 
from a print preview. 

1 From the menu, choose File>Save As. 
The Save As dialog displays. 
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Saving the completed form. 

2 Browse to drive:\program files\elixir technologies\vitesse\formlib. 
3 Enter GSJBTStatement1 in the File name entry box. 
4 Select Form Files (*.evf) from the Save as type drop-down list. 
5 Click Save. 

GSJBTStatement1 saves. 
6 Close the form. 
You have completed the form.  You will use this form in the XML portion of the 
Tour. 

Adding Data in Line Mode Using a Line Data 
File 

Up to this point, you have created forms and segments.  Now you will add data to an 
application using a Line mode project.   Project types are determined based on the 
data available and the type of application needed.  Line mode is typically used for 
transactional type applications such as the Jefferson Bank & Trust annual credit 
report. 

Jefferson Bank & Trust wants their report design to use a fixed length data file where 
the records do not have prefixes.  The static part of this application is already 
provided for you.  
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You will add the variable information to the form to complete the project.  You will 
insert a static form, and then add the Transaction Summary and Purchase information 
using records and fields.  You will represent the client spending data graphically 
using charts.  Finally, you’ll determine if the client’s credit limit may be upgraded, 
depending upon their payment record, and generate a static marketing message.   

 In summary, to create the Jefferson Bank & Trust annual credit report, you will:  

! Insert a previously created form 
! Add records and fields 
! Add charts 
! Apply conditions 
! Save your document 

 

You will be introduced to various new properties and functionality.  You 
can refer to Vitesse User Guide for more details. 

Creating a New Line Mode Document 
Before starting your exercise, you will review the data and the design mockup for the 
application. 

 
The data for the Annual Credit Report application. 
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A mockup of the completed application. 
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To begin the exercise, you will create a new Line mode document and set its 
properties.   

1 From the menu, choose File>New. 
The New Project dialog displays. 

 
Selecting Line Mode in the New Project dialog. 

2 Select Line Mode and click New.  
The Line Mode dialog displays. 

3 On the General tab, enter GS_LineLD in the Name entry box.  

 
Setting the Line mode project properties. 
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4 Select the Layout tab and enter the following specifications: 
! Paper: 

Standard: Letter 
Orientation: Portrait 

! Margins 
Top: 0.00 in 
Bottom: 0.00 in 
Left: 0.00 in 
Right: 0.00 in 

 
Setting specifications in the Layout tab for a Line mode project. 

 

Characters per line and lines per page control the scope of extraction 
on your line data file for data mapping.  Using these settings, you can 
define the number of lines per customer document in the line data.  
Refer to the Vitesse User Guide for more information on these settings. 

5 Select the Data tab and select Acquire Data file. 
By selecting this option you can choose a specific data file. 

6 Next to the Data file entry box, click  . 
7 Browse to drive:\program files\elixir technologies\vitesse\data files and 

select GS_Line.lm.  
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Entering data file specifications in the Data tab. 

8 Click OK. 
The new Line mode project opens. 

. 

The Line mode document GS_LineLD displays. 
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The data file displays in the design area.  This is listing mode.  If you 
export the project now, without records or fields, the data will print as 
seen in the design area.  Listing mode is used when there are no 
formatting requirements and the data just needs to be printed as it is 
laid out in the data file.  Once you add the first record to the Project 
Tree, listing mode closes and the data no longer displays in the design 
area.   

Setting Paper Properties 
You will now set the Paper properties for printing your document.  These properties 
pertain to the physical page: what paper is loaded in the printer, how the printer prints 
on that paper, etc. 

1 Select the Paper1 node in the Project Tree window. 

 
The Paper1 node is selected in the Project Tree. 

2 In the Property View window, select the General tab and set the following 
specifications:  
! Name: PaperRPT 
! Paper, Standard: Letter 
! Simplex: Selected 
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Setting Paper Properties in the Property View window. 

 

Simplex prints on only one side of the paper.  Duplex prints on both 
sides of the paper.  Tumble Duplex prints on both sides of the paper 
head to foot (the back page prints upside down).  For information on 
remaining options, refer to the Vitesse User Guide. 

Setting Page Properties 
Page properties define the logical page settings for your document, or where and how 
the data prints on the physical page.  You will turn off the page numbering option 
here, since this will always be a single-page document. 

1 Select the Page1 node in the Project Tree View window. 
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The Page1 node is selected in the Project Tree.   

2 In the Property View window, select the General tab and enter PageRPT in 
the Name entry box. 

 
Setting page properties. 
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3 Select the Page Number tab and set the following options: 
! Page number: Unchecked 

 
Setting page number properties. 

Inserting an Existing Form 
Now you will insert a previously created form in your project.  For this exercise, you 
will use the GSJBTReport form, which is located in the Vitesse Formlib folder. 

 

This resource is provided with the Vitesse install. 

1 From the menu, choose Insert>Form.  
The Insert Form dialog displays. 

2 Select the Existing tab. 
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Inserting an existing form.  

3 Browse to drive:\program files\elixir technologies\vitesse\formlib and 
select GSJBTReport.evf. . 

4 Click Open. 
The GSJBTReport form adds to your project.  A FormRef node adds to the 
Project Tree window. 
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The GSJBTReport form adds to your project. 

5 On the Standard toolbar, click   to save the application.  
It is a good idea to save often.  

Now you can start adding variable data to your document. 

Adding Records and Fields 
Jefferson Bank & Trust manages their data using a database.  To create the data you 
will work with, they exported the data to a fixed length data file without prefixes.  
You will use this file to add fields containing variable data to your document.   

The data is defined in records and fields.  Generally speaking, a record is one row, or 
line of data, and a field contains one piece of information, such as a date or a name.  
Vitesse finds information by reading vertically (records) and horizontally (fields).  In 
a data file without prefixes, records are numbered to locate specific information.  In a 
file that is fixed length, fields are located using a starting byte and length. 

Example: In the Jefferson Bank and Trust data file, the transaction data starts in the 
10th record.  There are 6 transaction records.  Vitesse treats this as one record, 
because all the data uses the same property settings, and labels it Line 10, Repeat 6.  
The dollar amount in the transaction records starts in byte 14 and continues for 10 
bytes.  In Vitesse shorthand, the dollar amount for transactions is located at Line (10-
6), Field (14-10). 
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You can add fields using one of the three following methods: 

! Insert menu:  
Choose Insert>Record and Insert>Field from the menu. 

! Insert toolbar:  
Click the Insert Record or Insert Field icon from this toolbar, which is located 
vertically between the Project Tree window and the design area.   

! Drag and drop:  
Drag and drop may be used to move data from the Data View window to the 
document.   

For this exercise, you will use all three methods.   

To start adding data, you will first open the Data View window in the design area. 

1 On the status bar, click . 
The status bar is a horizontal bar located at the lower right bottom of the 
screen.  The Show/Hide Data window icon is at the far right of the status bar.   

 
The Data View window displays on the right side of the design area.  The icon on 
the status bar is highlighted with a circle. 
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Adding Records and Fields Using Insert Options 
You will first add the report date to the document.  This first record contains one 
field.  You will add this record and its field using the Insert toolbar and then define 
their settings using the Property View window. 

1 On the Insert toolbar, click   to add a record. 
A record node adds in the Project Tree window.  

 
A record node adds in the Project Tree window. 

 

The data display in the design area disappears with the addition of the 
first record.  All data can still be viewed in the Data View window 

You will now define the record properties using the Property View window. 
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2 In the Property View window, select the Settings tab.  

 
Setting record properties. 

3 Select Line and make the following selections: 
! Line: 1 
! Repeat: 1 
! Variable Spacing: Fixed 
The Fixed Spacing option adjusts the spacing of a field without affecting the 
spacing of other fields under the same record.  Since there is only one field in 
this record, this setting does not affect anything. 

 

This record will pick up one vertical line, starting with the first line. 

You have added the first record to your document.  You will now add a field to this 
record.   

4 On the Insert toolbar, click   to add a field.  
A Field node is added to the Project Tree as a result of this step. 

 

This icon is located directly under the Insert Record icon that you just 
used.  They look similar so be sure to select the correct one.  Hover 
your cursor over the icon and the tool tip will display.  This step uses the 
Insert Field icon. 

5 In the Property View window, select the General tab and enter Date in the 
Name entry box.  
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6 Enter the Position and Spacing specifications as follows: 
! Position: 

X:  1.00 in Absolute 
Y:  1.78 in Absolute 

 
Setting field properties. 

7 Select the Settings tab and set the following specifications: 
! Field Type: Normal  
! Field Data: Fixed 
! Start:  0 
! Length:  16  
The Fixed setting specifies that the data file has fixed length fields.  Once 
Fixed is checked, you can specify the start byte and length of the fields. 
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Specifying the data information for the field. 

8 Select the Font tab and set the following specifications: 
! Type:  True Type 
! Name:  Times New Roman 
! Size:  12.00 pt 
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Setting the font for a field. 

9 Click . 
10 In the Style entry box, enter Regular. 

11 Click . 
You have saved a font style named Regular to the font list.  This font style 
may be applied to other text objects that use the same font specifications. 

 

To view font names in the Name drop-down list, go to 
Options>Preferences dialog, and select Show font names in font combo 
box in the General category.  To enable the B and I options (depending 
on the font Type), ensure that the Show font family members in font 
combo box option is deselected.  For more information on default 
settings, refer to Chapter 3: Configuration. 

 

When you added the record, nothing displayed in the design area.  Data 
needs a vertical and a horizontal location before it is placed.  A record is 
a vertical location, and a field is the horizontal location.  Therefore, the 
data only displays once a field is added. 

You have added the first record and field to your document. 
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The first record and field add to the document. 

Now you will add the next data field using the drag and drop method.   

Using Snap to Grid 
The grid is on by default in the design area.  The grid visually divides the workspace 
into logical divisions, and can be set to facilitate design work.  You will set the grid 
so you can visually place elements on the screen. 

1 From the menu, choose Tools>Preferences. 
The Preferences dialog opens. 
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. 

Setting preferences. 

2 Select the Designer category. . 
Here you will set up the Grids area. 

3 In the Spacing entry box, enter 0.25 in. 
4 Check Snap to Grids. 

When placing or moving objects, they will snap to the grid, meaning that they 
will be placed at grid intersection points. 

5 Make sure Grid is checked under View. 
You have finished setting up the grid. 

Mapping Data Using Drag and Drop  
This method uses the mouse to select data in the Data View window and then drag 
and drop it onto the document. 

You select data directly in the Data View window by clicking and dragging to draw a 
rectangle around the required data.  The rectangle you draw will have eight re-sizing 
points that you can use to stretch, reduce, or resize the rectangle until it fits accurately 
around the data you want to map. 

A shaded box with a green outline displays over the data if it has not been previously 
mapped.  Previously mapped data has a shaded box over the data with a red outline.   

Once you have selected the data that you want to map, drag and drop it into the 
document.  The data maps to your document and corresponding new record and field 
nodes add to the Project Tree.   

1 Select the Name and Address data in the Data View window.  This section 
uses lines 2 to 4 and bytes 0 to 17.   
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Use your mouse and draw a box around the Name and Address.  Boxes can 
be resized using the handles around the box. 

 
Fields that have not been mapped to the document are shaded with a green 
outline in the Data View window. 

2 Drag and drop the selected data underneath the Date in the design area.   
Press and hold the left mouse button and move the data to the required 
location on the document.  Your cursor will indicate the upper-left of the data 
area with an arrow as you drag the data.  Position the arrow where you want 
the data and release the left mouse button. 
The name and address are added in the design area and new record and field 
nodes add in the Project Tree. 

 
Fields that have been mapped to the document are shaded with a red outline in 
the Data View window. 
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Once you have dropped the data in the design area, you can position it 
on the document using your arrow keys. 

 

 

Rollover help displays the data�s line and field information.  To view 
rollover help, position your cursor over the highlighted data in the Data 
View window.  A help message displays the line and field information.  
In this case, the rollover helps displays Line (2-3).  Field (1-17). 
Line information: 
2 is the start line 
3 is the number of lines to read vertically, also called the repeat value 
Field information: 
1 is the field start byte 
17 is the length of the field 

 
The records are selected in Data View window.  The record is dropped onto the 
document, and record and field nodes add to the Project tree. 

Now you will position the added field.  Remember that snap to grid is on, so it will 
make positioning much easier. 

3 Click and drag the name field to approximately 1.00 inches horizontally, 
using the ruler to determine your position. 
Notice that the fields “snap” to intersecting points in the grid. 

You will now use the Property View window to add a name to the field and to make 
the positioning exact. 

4 Select the new field node in the Project Tree window. 
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5 Select the General tab in the Property View window and enter 
Name.Address in the Name entry box. 

6 Enter the Position coordinates as follows: 
! X:  1.00 in Absolute 
! Y:  2.33 in Absolute 
The End Same option ends the current field where the previous field ends, 
aligning them vertically.  If you chose Absolute, all the address lines would 
print on top of one another. 

 

In document design, you will use drag and drop often.  You can use the 
grid or the guidelines to place elements visually.  Use the Property View 
window to specify exact position coordinates. 

7 Select the Font tab and select Regular from the Style drop-down list. 
The field updates with the selected style. 

You have successfully added the Name and Address data to your document using 
drag and drop.  You will add the remaining data using the same method.  The next 
record and field provide the client’s account number. 

8 Select the entire line containing the account number.  This is line 5-1 and 
field bytes 0 to 19.   
For this selection, 5 is the start line and 1 is the number of lines vertically to 
be repeated.  0 is the starting byte and 19 is the length of the field.   

 
The Account Number is selected and ready to be dragged and dropped onto the 
document.  
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9 Drag and drop the selected data onto the design area under the Account 
Number heading. 
The Account Number heading is at the top right of the page; you will need to 
scroll over to view the right side of the page.  The field adds to the design 
area and new record and field nodes add in the Project Tree. 

 

Once you have dropped the data in to place you can position it on the 
document by using your arrow keys or by using click and drag.  it on 

10 In the Property View window, select the General tab and enter the following 
specifications: 
! Name: AcctNumber  
! Position: 

X:  4.95 in Absolute 
Y:  0.75 in Absolute 

 

The Jefferson Bank & Trust report project has a mockup that includes 
dimension and location coordinates.  You can visually match size and 
location throughout the exercise, if you do not wish to enter coordinates 
for each object. 

11 Select the Font tab and choose the following settings: 
! Type:  True Type 
! Name:  Arial  
! Size:  14.00 pt  
! Bold 

12 Select the Spacing tab and select   in the Justification area.  

 
Setting the Justification for a field. 
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In the next few steps, you will add the remaining records and fields to list credit, 
purchase, and payment data.  The specifications are listed below providing only the 
information required to set up the additional records and fields.  Refer back through 
this exercise to review the specific dialogs for record and field insertion and 
definition.   

The next field is the total credit line.  The data is in line 6 of the data file and should 
be placed underneath the Total Credit Line heading within the rounded box in the 
design area. 

13 Add the total credit line field by selecting it, then clicking and dragging it to 
the design area.   
A new record and field are added to the Project Tree. 

 
Selecting the total credit line data.  Once the data is selected, you can click and 
drag it onto the design.  

14 Verify the following in the Project Tree for the record: 
! Record Name: Record4 (keep the default record name) 
! Line (6-1) 
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Remember that Line (6-1) means Line 6, Repeat 1. 

 

Keep the default record name for all records added in this exercise.  
The default name for each record is maintained by the application even 
if you delete the record.  Example: If you delete Record7, the next new 
record will have the default name of Record8. 

 

This exercise refers to specific record names.  Don�t worry if your record 
names do not match the exercise.  This will not affect the outcome of 
the application. 

15 Specify the following information for the record’s field: 
! Field Name: TCLine (enter this field name) 
! Position:  

X:  5.40 in Absolute 
Y:  1.40 in Absolute 

! Field Start/Length (0-10) 
0 is the starting byte and 10 is the length of the field.  This information is 
located on the Settings tab. 

! Font Style:  
Type:  True Type 
Name:  Arial  
Size:  14.00 pt  

! Bold 
The font settings are located on the Font tab. 

16 Select the Transform tab and check Format number. 
The field will be printed in the format specified in the Format number entry 
box. 
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Specifying a number format in the Transform tab. 

17 Enter $@@@,@@@.## in the Format number entry box. 
“$” is a literal character, “@” represents a number in the field, “.”  represents 
a decimal and # represents a number after the decimal from the data field. 

 

Leading zeros in a data field will not print.  For example, �0000123456� 
in the data formats as �$@,@@@,@@� will print as �$1,234,56�. 

 

 
The top information box is complete. 

The next few records and fields add variable data to the Transaction Summary area of 
the design.  You may wish to scroll back to the left side of the page before continuing.   

 

The remaining records and fields will not use drag and drop for 
placement.  These fields are currency and are right justified in the data.  
Due of this, it would be difficult to accurately select them in the Data 
View window.  Instead, you will use the toolbar to add these records 
and fields 

18 Select Record4. 
A record cannot be added underneath a field, so you are selecting the last 
record before adding a new one. 

19 Click  to add the next record, which contains the customer’s charge 
information. 
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20 Select the General tab in the Property View window and specify the 
following record information: 
! Record Name: Record5  
! Line (7-1)   

This information is available in the Settings tab.   

21 Click   to add a field underneath Record5, and enter the following 
specifications: 
! Field Name: TCharges  
! Position:  

X:  2.55 in Absolute 
Y:  4.11 in Absolute 

! Size:  
W:  1.00 in 
Field Start/Length: (0-10)  

! Font Style: Regular 
This is the font style you set up for the first data field entered (Date). 

! Justification: Right   
Justification settings are on the Spacing tab. 

 

The width setting allows you to justify the data contents within a margin, 
or virtual text box.  When you right justify the contents, they will align at 
3.55 in. horizontal (2.55 in. X position + 1.00 in. W size). 

! Format number: $@@@,@@@.## 
Format number settings are on the Transform tab. 

22 Click  to add another field under the same record, and use the following 
specifications: 
! Field Name: FCharges 
! Position:  

X: 2.90 in Start Next 
Y:  0.00 in Start Same 

! Size:  
W:  1.00 in 

! Field Start/Length: (16-10) 
! Font  

Type: True Type 
Style: Regular 
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! Justification: Right  
! Format number: $@@@,@@@.## 

23 Select Record5. 

24 Click  to add the next record, which contains the customer’s payment and 
fee information. 

25 Specify the following record information in the Property View window: 
! Record Name: Record6  
! Line (8-1) 

26 Click  to add a field underneath Record6, and enter the following 
specifications: 
! Field Name: TPayments 
! Position:  

X:  2.55 in Absolute 
Y:  4.38 in Absolute 

! Size:  
W:  1.00 in 

! Field Start/Length: (0-10) 
! Font  

Type: True Type 
Style: Regular 

! Justification: Right  
! Format number: $@@@,@@@.## 

 

You can also use click and drag to move the field from the upper left 
corner to its position on the page.  Remember that snap to grid is on, so 
you will not be able to place it exactly using click and drag.  You can 

turn snap to grid off by clicking . 

27 Click   to add another field under the same record, and use the following 
specifications: 
! Field Name: Fees  
! Position:  

X:  2.90 in Start Next 
Y:  0.00 in Start Same 

! Size:  
W:  1.00 in 

! Field Start/Length: (19-5) 
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! Font  
Type: True Type 
Style: Regular 

! Justification: Right  
! Format number: $@@@,@@@.## 

28 Select Record6. 

29 Click   to add the next record, which contains the customer’s account and 
purchase information. 

30 Specify the following record information in the Property View window: 
! Record Name: Record7  
! Line (9-1) 

31 Click   to add a field underneath Record7, and enter the following 
specifications: 
! Field Name: AcctStanding  
! Position:  

X:  2.54 in Absolute 
Y:  4.74 in Absolute 

! Size:  
W:  1.00 in 

! Field Start/Length  (0-6) 
! Font  

Type: True Type 
Style: Regular 

! Justification: Right  
! Strip Bounding: Checked, select Blanks. 

Strip Bounding is located on the Transform tab.  This option removes extra blanks 
from the field.  The AcctStanding field has blanks to the right and left of the 
characters, which does not allow the field to right justify correctly.  Removing these 
blanks allow correct justification. 
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The Transform tab has additional field operations.  Here you are choosing to 
eliminate extra blanks before and after the field characters. 

Strip Bounding is located on the Transform tab.  This option removes extra blanks 
from the field.  The AcctStanding field has blanks to the right and left of the 
characters, which does not allow the field to right justify correctly.  Removing these 
blanks allows correct justification. 

32 Click   to add another field under the same record, and use the following 
specifications: 
! Field Name: TCharges2  
! Position:  

X:  2.90 in Start Next 
Y:  0.00 in Start Same 

! Size:  
W:  1.00 in  

! Field Start/Length: (16-9) 
! Font  

Type: True Type 
Style: Regular 
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! Justification: Right  
! Format number: $@@@,@@@.## 

 

Remember that all field names must be unique. Since there is a 
previous TCharges, you are adding a �2� to make the name unique. 

 
The Transaction Summary data maps to the design. 

The final record and fields provide client purchase information for the table at the 
bottom left of the page.   

33 Select Record7. 

34 Click  to add the next record, and specify the following record 
information in the Property View window: 
! Record Name: Record8  
! Line (10-6) 

35 Click   to add a field underneath Record8, and enter the following 
specifications: 
! Field Name: Purchase  
! Position:  

X:  2.75 in Absolute 
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Y:  7.00 in Absolute 
! Size:  

W:  1.00 in 
! Spacing:  

Vertical: 0.50 in 
This will double the normal line spacing for the repeating fields.  Note 
how the field placement fits with the table. 

! Field Start/Length: (14-9) 
! Font Style: Regular 
! Justification: Right  
! Format number: $@@@,@@@.## 

 
Purchases information maps onto the design. 

You have completed adding records and fields to the Jefferson Bank and Trust annual 
credit report.  You will now add a chart that reflects the client’s purchasing patterns as 
a graphical representation. 
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Adding Charts 
Data may be represented graphically using bars, lines or pie charts.  Each chart may 
include special effects such as color, shading, patterns, fonts, 3D effects and legends.   

In this exercise you will insert a bar chart that reflects the client’s buying patterns.   

1 Select the PageRPT node. 

 

You must select this node to ensure that the chart adds correctly for the 
project.  If you added the chart under a record, the chart would print 
each time the record printed � in this case, six times.  Instead, you are 
adding it at the Page level, where it prints at the document level.  Here it 
will print only once. 

2 On the Insert toolbar, click . 
A chart node is added to the Project Tree.   

 

You may also use the Insert menu to add a chart.  To use the Insert 
menu, choose Insert>Chart. 

3 Select the General tab in the Property View window and enter the following 
specifications:  
! Name: ChartPurchases 
! Type: Bar 
! Position:  

X:  4.80 in Absolute 
Y:  6.45 in Absolute  

! Size: 
W:  2.15 in 
H:  3.50 in 

4 Select the Data tab, and select Manual data.  

5 Click . 
This icon is located in the middle left of the Data tab.  A new Label/Value 
entry box pair adds to the Data table. 

6 Click the Label entry box. 
An arrow displays to the right of the entry box. 

7 Click the arrow and select Data Mapping>Line(#-#), Field(#-#) from the 
pop-up menus. 
Line and field information is specified as start line/ byte and end line/ byte. 
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Selecting the data directly in the Data View window will achieve the 
correct results and avoid any typing errors. 

8 Click once on the Label entry box, and enter Line (10-15), Field (0-3). 
This will use the first four characters of each record to label the chart.  This 
information will be used to create the chart’s legend. 

 
The Data tab after entering the information into the Label entry box. 

 

You can also select and resize the data in the Data View window.  You 
may find it easier to select data visually than type in the specifications in 
the entry box. 

9 Click the Value entry box. 
An arrow displays to the right of the entry box. 

10 Click the arrow and select Data Mapping>Line(#-#), Field(#-#) from the 
pop-up menus. 

11 In the Value entry box enter the Label: Line (10-15), Field (15-23). 
Again, you may find it easier to select the data in the Data View window, 
rather than typing directly in the entry box.  This is the data used to graph the 
chart. 

When entering field location, the default notation uses a dash to 
separate starting byte and ending byte.  If you prefer to use starting byte 
and length, replace the dash with a comma.  For example, if you specify 
Line (10,6), Field (15, 9), you will be using starting byte and length to 
locate the record and field. 
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If you map data directly from the Data View window, the chart label and 
value information displays as start line/ byte and length in the Property 
View window.  When you type information directly in the Label and 
Value entry boxes, information is specified as start line/ byte and end 
line/ byte. 

 
The Data tab with the Value entry box completed. 

12 Select the Settings tab and set the following specifications: 
! 3D effect: Checked : 
! Legend: Checked  
! Keep ratio: Checked  
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Setting the chart properties. 

13 Click   to add a color option to the color table.  

A color option is added to the color table each time you click .  You will 
need three color options for this exercise. 

14 Add two more colors to the color table. 
15 Click the top color setting in the color table. 

Two arrows display.  The upper arrow opens a pop-up menu with color 
options.  This is the arrow you will use.  The lower arrow opens a pop-up 
menu with pattern options. 

16 Click the upper arrow and select Blue (any shade). 
17 Set the next two colors in the same way, using the following specifications: 

! Center: Yellow 
! Bottom: Green (any shade) 
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Your color table should look similar to this example. 

18 Select the Misc tab and make sure Print Scale is checked.   
19 Select the Font tab and select the following: 

! Type: True Type 
! Name: Times New Roman 
! Size:  10.00 pt 
The chart adds to your report design. 
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The document displays with the chart added in the design area. 

Adding Conditions 
So far the data you have mapped to the document has been imported exactly as it is 
stored in the data file, i.e., Name, Address, etc. 

You will now learn to interpret data in the data file by applying conditions.  A 
condition tests the data, and performs an action depending on whether the test is true 
or false.   

In this exercise, you will add a condition that evaluates the client’s eligibility for a 
credit limit increase.  The client’s credit limit will be increased only if their total 
payments are above $100,000.  If the payment history meets the criteria, a text 
message prints on the document notifying the client of their increased credit limit.   

1 Select the Fees node under Record6. 
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Selecting the Fees node. 

2 On the Insert toolbar, click . 
A condition node, along with If and Else nodes, adds to the Project Tree at the 
bottom of the record. 

3 Click  next to Condition1 to view the If and Else nodes. 

 
The condition expands to display the If and Else nodes. 
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4 Select the If node.  
5 Click the entry box directly under the IF label. 

An arrow displays to the right of the entry box. 
6 Select Data Mapping>Field(#-#) from the pop-up menus. 
7 Enter Field (0-10) in the entry box. 

Remember that you can also select the field in the Data View window.   
8 Click the operator in the center of the first row (equal sign) and select > 

(greater than) from the drop-down menu. 

 
Selecting an operator from the drop-down menu on the General tab. 

9 Click the entry box on the right. 
10 Click the arrow and select Constants>Number from the drop-down menu. 
There are two options for Constants: Number and Text.  The Number option can 
perform numeric comparisons, such as less than 10, greater than or equal to 100.  The 
Text option can only perform string comparisons, which can only be equal or not 
equal to a given string. 

11 Enter 100000 in the entry box. 
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The completed test. 

The test is now complete.  Now you will add the action if the test result is true. 

12 Right-click the If node and select Insert>Field from the pop-up menu. 
13 Select the General tab in the Property View window set the following 

specifications: 
! Name: Static 
! Position:  

X:  1.00 in Absolute 
Y: 3.40 in Absolute 
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Setting field properties. 

14 Select the Settings tab and set the following specifications:  
! Field Type: Static Text 
! Field Data: Const 
! Const entry box: *Congratulations! After reviewing your payment 

history, your total credit limit has been increased to $200,000. 
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Setting field properties for a static text field.  

15 Select the Font tab and set the following specifications: 
! Type:  True Type 
! Name:  Times New Roman 
! Size:  9.00 pt 
! Bold 
! Italic  

16 Select the Color tab and set the color to DMBLUE RGB (0,0,204). 
The static field prints if the condition is found true. 

17 On the Standard toolbar, click   to save the application. 
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The completed application. 
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Viewing Source Code  
You can view and edit the current document source code in Vitesse.  Source code 
includes resource elements such as variables, constants, comments, integers, key 
words, and normal and real numbers. 

To view the source code for your project: 

1 Click the Source View tab at the bottom of the design area to toggle from the 
Design View to the Source View. 
The Source window displays.  

 
Viewing the source code for the open project.  The Data View window has been 
closed. 

You can edit the source code directly in this window.  Click   to compile the 
edited source code.  The source code can be restored to its last valid compilation state 
if for some reason compilation fails. 

To return to the last valid compiled state: 

2 Right-click in the Source window, and select Revert to Last State from the 
pop-up menu.  
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Reverting to the last valid compilation state. 

You have completed the Line mode project using a line data file.  In the next part of 
the Tour, you will create the same application using a prefixed data file.   

3 From the menu, choose File>Close. 
The project closes.   
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Adding Data in Line Mode Using a Prefixed 
Data File 

You have now created a form, a segment and a Line mode project using a fixed 
length, non-prefixed data file.   Now you will create a Line mode project using a fixed 
length, prefixed data file.  Project types are determined based on the data available 
and the type of application needed.  Line mode is typically used for transactional 
applications, such as the Jefferson Bank & Trust annual credit report. 

Jefferson Bank & Trust wants their report design to use a prefixed fixed length data 
file.  A prefixed data file contains prefixes at the beginning of each record to identify 
the record contents.  Vitesse uses this prefix to locate and define each record type for 
printing.  All records with the same prefix use the same properties for printing.  The 
static part of this application is already provided for you.   

 

This application is identical to the Line mode project just completed in 
the Tour.  The difference is in defining and handling the variable data. 

 

This guide can be used sequentially, or you can pick and choose the 
exercises you would like to complete out of the tour.  Explanations have 
been repeated in each exercise to allow skipping through the guide. 

To complete this exercise, you will insert a static form and add the Transaction 
Summary and Purchases information using records and fields.  You will represent the 
client spending data graphically using charts.  Finally, you’ll determine if the client’s 
credit limit may be upgraded, depending upon their payment record, and generate a 
static marketing message.   

In summary, to create the Jefferson Bank & Trust annual credit report, you will:  

! Insert a previously created form 
! Add records and fields 
! Add charts 
! Apply conditions 
! Save your document 

 

You will be introduced to various new properties and functionality.  You 
can refer to the Vitesse User Guide for more details. 
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Creating a New Line Mode Document 
Before starting your exercise, you will review the design mockup and the data for the 
application. 

 
A mockup of completed application. 
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The data for the Annual Credit Report application. 

To begin the exercise, you will create a new Line mode document and set its 
properties. 

1 From the menu, choose File>New. 
The New Project dialog displays. 

 
Selecting Line Mode from the New Project dialog. 

2 Select Line Mode and click New. 
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The Line Mode dialog displays. 
3 On the General tab, enter GS_LinePrefix in the Name entry box. 

 
4 Select the Layout tab and enter the following specifications: 

! Paper: 
Standard: Letter 
Orientation: Portrait 

! Margins 
Top: 0.00 in 
Bottom: 0.00 in 
Left: 0.00 in 
Right: 0.00 in 

 
Setting specifications in the Layout tab for a Line mode project. 

 

Characters per line and lines per page control the scope of extraction 
on your line data file for data mapping.  Using these settings, you can 
define the number of lines per customer document in the line data 

5 Select the Data tab and select Acquire Data file. 
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By selecting this option you can choose a specific data file. 

6 Next to the Data file entry box, click . 
7 Browse to drive:\program files\elixir technologies\vitesse\data files and 

select GS_Prefixed.lm. . 
8 Set the following additional Record specifications on the Data tab: 

! Prefixed: Checked 
! Start:  0 
! Length:  4 

 
Entering data file specifications in the Data tab. 

9 Click OK. 
The new Line mode project opens. 
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. 

The Line mode document GS_LinePrefix displays. 

 

The data file displays in the design area.  This is listing mode.  If you 
export the project now, without records or fields, the data will print as 
seen in the design area.  Listing mode is used when there are no 
formatting requirements and the data just needs to be printed as it is 
laid out in the data file.  Once you add the first record to the Project 
Tree, listing mode closes and the data no longer displays in the design 
area. 

Setting Paper Properties 
You will now set the paper properties for printing your document.  These properties 
pertain to the physical page: what paper is loaded in the printer, how the printer prints 
on that paper, etc. 

1 Select the Paper1 node in the Project Tree window. 
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The Paper1 node is selected in the Project. 

2 In the Property View window, select the General tab and set the following 
specifications:  
! Name: PaperRPT 
! Paper, Standard: Letter 
! Simplex: Selected 
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Setting Paper Properties in the Property View window. 

Simplex prints on only one side of the paper.  Duplex prints on both sides of the 
paper.  Tumble Duplex prints on both sides of the paper head to foot (the back page 
prints upside down). 
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Setting Page Properties 
Page properties define the logical page settings for your document, or where and how 
the data prints on the physical page.  You will turn off the page numbering option 
here, since this will always be a single-page document. 

1 Select the Page1 node in the Project Tree window. 

 
The Page1 node is selected in the Project Tree. 

2 In the Property View window, select the General tab and enter PageRPT in 
the Name entry box. 
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Setting Page properties. 

3 Select the Page Number tab and set the following options: 
! Page number: Unchecked 

 
Setting Page Number properties. 
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Inserting an Existing Form 
Now you will insert a previously created form in your project.  For this exercise, you 
will use the GSJBTReport form, which is located in the Vitesse Formlib folder. 

This resource is provided with the Vitesse install. 

1 From the menu, choose Insert>Form. 
The Insert Form dialog displays. 

2 Select the Existing tab. 

 
Inserting an existing form. 

3 Browse to drive:\program files\elixir technologies\vitesse\formlib and 
select GSJBTReport.evf. . 

4 Select the file name and click Open. 
The GSJBTReport form adds to your project.  A FormRef  node adds in the 
Project Tree window. 
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The GSJBTReport form adds to your project. 

Here, the grid is turned off. 

5 On the Standard toolbar, click  to save the application. 
It is a good idea to save often.  

Now you can start adding variable data to your document. 

Adding Records and Fields 
Jefferson Bank & Trust manages their data using a database.  To create the data you 
will work with, they exported the data to a fixed length data file that includes 
prefixes.  You will use this file to add fields containing variable data to your 
document.   

The data is defined in records and fields.  Generally speaking, a record is one row, or 
line of data, and a field contains one piece of information, such as a date or a name.  
Vitesse finds information by reading vertically (records) and horizontally (fields).  In 
a data file with prefixes, records are located using a specific prefix.  In a file that is 
fixed length, fields are located using a starting byte and length.   

Example: In the Jefferson Bank and Trust data file, the transaction data all uses the 
prefix PRS0.  There are 6 of these transaction records.  Vitesse treats this as one 
record, because all the data uses the same property settings, and labels it PRS0.  The 
amount in the transaction record starts in byte 20 and continues for 9 bytes.  In 
Vitesse shorthand, the amount for transactions is located at PRS0, Field (20,9). 
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You can add fields using one of the three following methods: 

! Insert menu:  
Choose Insert>Record and Insert>Field from the menu. 

! Insert toolbar:  
Click the Insert Record or Insert Field icon from this toolbar, which is located 
vertically between the Project Tree window and the design area.   

! Drag and drop:  
Drag and drop may be used to move data from the Data View window to the 
document.   

For this exercise, you will use all three methods.   

To start adding data, you will first open the Data View window in the design area. 

1 On the Status bar, click . 
The Status bar is a horizontal bar located at the bottom of the screen.  The 
Show/Hide Data window button is at the far right of the Status bar. . 

 
The Data View window displays on the right side of the design area.  The icon on 
the Status bar is highlighted with a circle. 

 

 is located in the lower right of the screen. 
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Adding Records and Fields using Insert Options 
You will first add the report date to the document.  This first record contains one 
field.  You will add this record and its field using the Insert toolbar and then define 
their settings using the Property View window. 

1 On the Insert toolbar, click   to add a record. 
A Record node adds in the Project Tree window.  

 
A record node adds in the Project Tree window. 

 

The data display in the design area disappears with the addition of the 
first record.  All data can still be viewed in the Data View window. 

You will now define the record properties using the Property View window. 

2 In the Property View window, select the General tab and enter DAT0 in the 
Name entry box.  

3 Select the Settings tab and set the following specifications: 
! RPE Key: Selected 
! RPE Key: DAT0 
! Variable Spacing: Variable 
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Variable Spacing adjusts the spacing of all fields under the same record.  Adding 
subsequent fields adds the spacing value of the previous field to the spacing value of 
the new field. 

 
Setting record properties in the Property View window. 

You have added the first record to your document.  You will now add a field to this 
record. 

4 On the Insert toolbar, click   to add a field. 
A Field node adds to the Project Tree window. 

 

This icon is located directly under the Insert Record icon that you just 
used.  They look similar so be sure to select the correct one.  Hover 
your cursor over the icon and a label will display.  This step uses the 
Insert Field icon 

5 In the Property View window, select the General tab and set the following 
specifications:  
! Name: Date 
! Position: 

X:  1.00 in Absolute 
Y:  1.78 in Absolute 
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Setting field properties. 

6 Select the Settings tab and set the following specifications: 
! Field Type: Normal 
! Field Data: Fixed 
! Start:  5 
! Length: 16 
The Fixed setting specifies that the data file has fixed length fields.  Once 
Fixed is checked, you can specify the start byte and length of the fields.   
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Specifying the data information for the field. 

7 Select the Font tab and set the following specifications:  
! Type:  True Type 
! Name:  Times New Roman 
! Size:  12.00 pt 
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Setting the font for a field. 

 

To view font names in the Name drop-down list, go to 
Options>Preferences dialog, and select Show font names in font combo 
box in the General category.  To enable the B and I options (depending 
on the font Type), ensure that the Show font family members in font 
combo box option is deselected.  For more information on default 
settings, refer to Chapter 3: Configuration. 

8 Click . 
9 In the Style entry box, enter Regular. 

10 Click . 
You have saved a font style named Regular to the font list.  This font style 
may be applied to other text objects that use the same font specifications. 

 

When you added the record, nothing displayed in the design area.  Data 
needs a vertical and a horizontal location before it is placed.  A record is 
a vertical location, and a field is the horizontal location.  Therefore, the 
data only displays once a field is added. 

You have added the first record and field to your document. 
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The first record and field add to the document. 

Now you will add the next data field using the drag and drop method. 

Using Snap to Grid 
The grid is on by default in the design area.  The grid visually divides the workspace 
into logical divisions, and can be set to facilitate design work.  You will set the grid 
so you can visually place elements on the screen. 

1 From the menu, choose Tools>Preferences. 
The Preferences dialog opens. 
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. 

Setting preferences. 

2 Select the Designer category.  
Here you will set up the Grids area. 

3 In the Spacing entry box, enter 0.25 in. 
4 Check Snap to Grids. 

When placing or moving objects, they will snap to the grid, meaning that they 
will be placed at grid intersection points. 

5 Make sure Grid is checked in the View area. 
You have finished setting up the grid. 

Mapping Data using Drag and Drop 
This method uses the mouse to select data in the Data View window and then drag 
and drop it onto the document. 

You select data directly in the Data View window by clicking and dragging to draw a 
rectangle around the required data.  The rectangle you draw will have eight re-sizing 
points that you can use to stretch, reduce, or resize the rectangle until it fits accurately 
around the data you want to map. 

A shaded box with a green outline displays over the data if it has not been previously 
mapped.  Previously mapped data has a shaded box over the data with a red outline.   

Once you have selected the data you want to map, drag and drop it into the document.  
The data maps to your document, and corresponding new record and field nodes add 
to the Project Tree.   
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Notice that when you click on any prefixed data content in the Data 
view, all records with the same prefix will automatically be selected. 

1 Select the contents of the ADR0 prefixed record in the Data View window. 
Use your mouse to draw a box around the name and address information in 
the ADR0 record.  A shaded box with a green outline appears around the 
selected data. 

 
Fields that have not been mapped to the document are shaded with a green 
outline in the Data View window. 

2 Drag the selected data underneath the Date in the design area.   
Press and hold the left mouse button and move the data to the required 
location on the document.  Your cursor will indicate the upper-left of the data 
area with an arrow as you drag the data.  Position the arrow where you want 
the data to be placed and release the left mouse button. 
The name and address is added in the design area, and the new record ADRO 
and field nodes are added in the Project Tree. 
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Fields that have been mapped to the document are shaded with a red outline in 
the Data View window. 

Once you have dropped the data in to place, you can position it on the 
document using your arrow keys. 

Rollover help displays the data�s line and field information.  To view 
rollover help, position your cursor over the highlighted data in the Data 
View window.  In this case, the rollover help displays Field1: ADR0. 
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The records are selected in Data View window.  The record is dropped onto the 
document and record and field nodes add to the Project Tree. 

Now you will position the added field.  Remember that snap to grid is on, so it will 
make positioning much easier. 

3 Click and drag the name field to approximately 1.00 inches horizontally, 
using the ruler to determine your position. 
Notice that the fields “snap” to intersecting points in the grid. 

You will now use the Property View window to add a name to the field and to make 
the positioning exact. 

4 Select the new field node in the Project Tree window. 
5 Select the General tab in the Property View window and set the following 

specifications: 
! Name: Name.Address 
! Position:  

X:  1.00 in  
Y:  2.40 in End Same 
The End Same  option ends the current field where the previous field 
ends, aligning them vertically.  If you chose Absolute, all the address 
lines would print on top of one another. 
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The spacing mode for prefixed records is variable.  You cannot use 
Absolute positioning for the Y coordinate with prefixed fields where the 
data has multiple occurrences 

In document design, you will use drag and drop often.  You can use the 
grid or the guidelines to place elements visually.  Use the Property View 
window to specify exact position coordinates 

 
Using relative positioning for the vertical coordinate. 

6 Select the Font tab and select Regular from the Style drop-down list. 
The field updates with the selected style. 

You have successfully added the Name and Address data to your document using 
drag and drop.  You will add the remaining data using the same method.  The next 
record and field provide the client’s account number. 

7 Select the data in the ACR0 record. 
This record contains the client’s account number. 
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Selecting the ACRO record in the Data View window. 

8 Drag and drop the selected data onto the design area under the Account 
Number heading. 
The Account Number heading is at the top right of the page; you will need to 
scroll over to view the right side of the page.  The field adds to the design 
area and new record and field nodes add in the Project Tree. 

 

Once you have dropped the data in to place you can position it on the 
document by using your arrow keys or by using click and drag.  

 
The data is dropped on the document.  Now it needs positioning, spacing and font 
settings. 

9 In the Property View window, select the General tab and enter the following 
specifications: 
! Name: AccNumber 
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! Position:  
X:  4.93 in  
Y:  0.75 in Absolute 

 
Setting general field specifications. 

10 Select the Font tab and set the following specifications: 
! Type:  True Type 
! Name: Arial  
! Size: 14.00 pt 
! Bold 

11 Select the Spacing tab and select   in the Justification area. 
12 Select the data in the ACR1 record. 

This record contains the client’s Total Credit Line. 
13 Drag and drop the selected data onto the design area under the Total Credit 

Line heading. 
The Total Credit Line heading is right underneath the Account Number 
heading. 
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14 In the Property View window, select the General tab and enter the following 
specifications: 
! Name: TCLine 
! Position:  

X:  5.45 in  
Y:  1.30 in Absolute 

15 Select the Font tab and set the following specifications: 
! Type:  True Type 
! Name: Arial  
! Size: 14.00 pt 
! Bold 

16 Select the Spacing tab and select   in the Justification area. 
17 Select the Transform tab and select Format number. 

This option will print the field in the format specified in the Format number 
entry box. 

18 Enter $@@@,@@@.## in the Format number entry box. 

 
The ACR0 and ACR1 records are placed, and the top information box is 
complete. 

In the following steps of this exercise, you will add the remaining records and fields 
to list credit, purchase, and payment data.  The specifications listed below provide 
only the necessary information required to set up the additional records and fields.   

 

Keep the default record name for all records added in this exercise.  
When dragging and dropping data, the record name defaults to the 
record�s prefix. 

19 Select the first amount in the CRS0 record in the Data View window. 
20 Drag and drop it after the Total Charges label in the Transactions Summary. 
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The Total Charges label is on the left side of the page.  You will need to 
scroll back to the left side of the page before dragging and dropping the data. 

21 Make sure the new record’s name is CRS0, to verify you have added the 
correct data to the page. 

 

When dragging and dropping data in the design area, the record 
automatically is named using the record prefix. 

22 Select the field underneath the CRS0 record and specify the following: 
! Field Name: TCharges 
! Position: 

X:  2.25 in  
Y:  4.10 in Absolute 

! Size:  
! W:  1.00 in 
! Field Start/Length (5-10) 

5 is the starting byte and 10 is the length of the field. 
! Font Style: Regular 

This is the font style you set up for the first data field entered (Date). 
! Justification: Right 

Justification settings are on the Spacing tab. 
! Format number: $@@@,@@@.## 

Format number settings are on the Transform tab. 

23 Click  to add another field under the CRS0 record, and use the following 
specifications: 
! Field Name: FCharges 
! Position:  

X:  3.10 in Start Next 
Y:  0.00 in End Same 

! Size:  
W:  1.00 in 

! Field Start/Length: (21-8) 
! Font Style: Regular 
! Justification: Right  
! Format number: $@@@,@@@.## 

This field is for the Finance Charges, which is located on the right side of 
the Transaction Summary. 
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24 Select the first amount in the CRS1 record in the Data View window. 
25 Drag and drop it after the Total Purchases label in the Transactions Summary. 

The Total Purchases label is on the left side of the page.   
26 Make sure the new record’s name is CRS1, to verify you have added the 

correct data to the page. 
27 Select the field underneath the CRS1 record and specify the following: 

! Field Name: TPayments 
! Position: 

X:  2.25 in  
Y:  4.38 in Absolute 

! Size:  
W:  1.00 in 

! Field Start/Length: (5-10) 
! Font Style: Regular 
! Justification: Right  
! Format number: $@@@,@@@.## 

 

You can also use click and drag to move the field from the upper left 
corner to its position on the page.  Remember that snap to grid is on, so 
you will not be able to place it exactly using click and drag.  You can 

turn snap to grid off by clicking . 

28 Click  to add another field under the CRS1 record, and use the following 
specifications: 
! Field Name: Fees 
! Position: 

X:  3.10 in Start Next 
Y:  0.00 in End Same 

! Size:  
! W:  1.00 in 
! Field Start/Length: (19-10) 
! Font Style: Regular 
! Justification: Right  
! Format number: $@@@,@@@.## 

29 Select the word Good in the CRS2 record in the Data View window. 
30 Drag and drop it after the Account Standing label in the Transactions 

Summary. 
The Account Standing label is on the left side of the page.   
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31 Make sure the new record’s name is CRS2, to verify you have added the 
correct data to the page. 

32 Select the field underneath the CRS2 record and specify the following: 
! Field Name: AcctStanding  
! Position:  

X:  2.25 in  
Y:  4.78 in Absolute 

! Size:  
! W:  1.00 in 
! Field Start/Length: (5-11) 
! Font Style: Regular 
! Justification: Right  
! Strip Bounding: Checked, select Blanks 

Strip Bounding is located on the Transform tab.  This option removes 
extra blanks from the field.  The AcctStanding field has blanks to the 
right and left of the characters, which do not allow the field to right 
justify correctly.  Removing these blanks allow correct justification. 

 
The Transform tab has additional field operations.  Here you are choosing to 
eliminate extra blanks before and after the field characters. 
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33 Click   to add another field under the CRS2 record, and use the following 
specifications: 
! Field Name: TCharges2 
! Position: 

X:  3.10 in Start Next 
Y:  0.00 in End Same 

! Size:  
! W:  1.00 in 
! Field Start/Length: (21-8) 
! Font Style: Regular 
! Justification: Right  
! Format number: $@@@,@@@.## 

 

Remember that all field names must be unique.  Since there is a 
previous TCharges, you are adding a �2� to make the name unique. 

 
The Transaction Summary data maps to the design. 

The final record and fields provide client purchase information for the table at the 
bottom left of the page.   

34 Select the currency amounts in the PRS0 record in the Data View window. 
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35 Drag and drop it into the Purchases table at the bottom left of the page. 
36 Make sure the new record’s name is PRS0, to verify you have added the 

correct data to the page. 
37 Select the field underneath the PRS0 record and specify the following: 

! Field Name: Purchase 
! Position:  

X:  2.70 in  
Y:  7.00 in End Same 

! Size:  
W:  1.00 in 

! Spacing:  
Vertical: 0.50 in 
This will double the normal line spacing for the repeating fields.  Note 
how the field placement fits with the table. 

! Field Start/Length: (20-9) 
! Font Style: Regular 
! Justification: Right  
! Format number: $@@@,@@@.## 

 
Purchases information maps onto the design. 

You have completed adding records and fields to the Jefferson Bank and Trust annual 
credit report.  You will now add a chart that reflects the client’s purchasing patterns as 
a graphical representation. 
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Adding Charts 
Data may be represented graphically using bar, line or pie charts.  Each chart may 
include special effects such as color, shading, patterns, fonts, 3D effects and legends. 

In this exercise, you will insert a bar chart that reflects the client’s buying patterns.   

1 Select the PageRPT node. 

 

You must select this node to ensure the chart adds correctly for the 
project.  If you added the chart under a record, the chart would print 
each time the record printed � in this case, six times.  Instead, you are 
adding it at the Page level, where it prints at the document level.  Here it 
will print only once. 

2 On the Insert toolbar, click .. 
A chart node is added to the Project Tree.  

 

You may also use the Insert menu to add a chart.  To use the Insert 
menu, choose Insert>Chart. 

3 Select the General tab in the Property View window and enter the following 
specifications:  
! Name: ChartPurchases 
! Type: Bar 
! Position: 

X:  4.80 in Absolute 
Y:  6.50 in Absolute 

! Size:  
W:  2.15 in 
H:  3.50 in 

4 Select the Data tab and choose Manual data. . 

5 Click . 
This icon is located in the middle left of the Data tab.  A new Label/Value 
entry box pair adds to the Data table. 

6 Click the Label entry box. 
An arrow displays to the right of the entry box. 

7 Click the arrow and select Data Mapping>Rec (“), Field (#-#) from the pop-
up menus. 

8 In the Label entry box enter Rec(PRS0), Field (5-8). 
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This will use the first four characters of each record to label the chart.  This 
information will be used to create the chart’s legend. 
Field information is specified as Start and End byte. 

 

Selecting the data directly in the Data View window will achieve the 
correct results and avoid any typing errors. 

 
Click (“) in the entry box to add the record prefix from the drop-down list.  Select 
PRSO and enter the remainder of the data directly into the entry box. 

9 Click the Value entry box. 
An arrow displays to the right of the entry box. 

10 Click the arrow and select Data Mapping>Rec (“), Field (#-#) from the pop-
up menus. 

11 In the Value entry box, enter the Label: Rec(PRS0), Field (20-28). 
Click (“) in the entry box to add the record prefix from the drop-down list.  
Select PRSO and enter the remainder of the data directly into the entry box. 
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The Data tab with the Value entry box completed. 

 

When entering field location, the default notation uses a dash to 
separate starting byte and ending byte.  If you prefer to use starting byte 
and length, replace the dash with a comma.  For example, if you specify 
Rec (PRS0), Field (5,4), you will be using starting byte and length to 
locate the field. 

 

If you map data directly from the Data View window, the chart label and 
value information displays as record prefix, field start byte and length in 
the Property View window.  When you type information directly in the 
Label and Value entry boxes, information is specified as record prefix, 
field start byte and end byte. 

12 Select the Settings tab and set the following specifications: 
! 3D effect: Checked 
! Legend: Checked 
! Keep ratio: Checked 
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Setting the chart properties. 

13 Click  to add a color option to the color table. 

A color option is added to the color table each time you click .  You will 
need three color options for this exercise. 

14 Add two more colors to the color table. 
15 Click the top color setting in the color table. 

Two arrows display.  The upper arrow opens a pop-up menu with color 
options.  This is the arrow you will use.  The lower arrow opens a pop-up 
menu with pattern options. 

16 Click the upper arrow and select Blue (any shade). 
17 Set the next two colors in the same way, using the following specifications: 

! Center: Yellow 
! Bottom: Green (any shade) 
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Your color table should look similar to this example. 

18 Select the Misc tab and make sure Print Scale is checked.   
19 Select the Font tab and select the following: 

! Type: True Type 
! Name: Times New Roman 
! Size:  10.00 pt 
The chart adds to your report design. 
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The document displays with the chart added in the design area. 

Adding Conditions 
So far the data you have mapped to the document has been imported exactly as it is 
stored in the data file, i.e., Name, and Address, etc. 

You will now learn to interpret data in the data file by applying conditions.  A 
condition tests the data and performs an action depending on whether the test is true 
or false.   

In this exercise, you will add a condition that evaluates the client’s eligibility for a 
credit limit increase.  The client’s credit limit will be increased only if their total 
payments are above $100,000.  If the payment history meets the criteria, a text 
message prints on the document notifying the client of their increased credit limit.   

1 Select the Fees node under the CSR1 record. 
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Selecting the Fees node. 

2 On the Insert toolbar, click .. 
A condition node, along with If and Else nodes, adds to the Project Tree at the 
bottom of the record.  

3 Click  next to Condition1 to view the If and Else nodes. 

 
The condition expands to display the If and Else nodes. 
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4 Select the If node. 
5 Click the entry box under the IF label. 

An arrow displays to the right of the entry box. 
6 Select Data Mapping>Field(#-#) from the pop-up menus. 
7 Enter Field (5-14) in the entry box. 

You can also select the field in the Data View window.   
8 Click the operator in the center of the first row (equal sign) and select > 

(greater than) from the drop-down menu. 

 
Selecting an operator from the drop-down menu on the General tab. 

9 Click the entry box on the right. 
10 Click the arrow and select Constants>Number from the drop-down menu. 
There are two options for Constants: Number and Text.  The Number option can 
perform numeric comparisons, such as less than 10, greater than or equal to 100.  The 
Text option can only perform string comparisons, which can only be equal or not 
equal to a given string. 

11 Enter 100000 in the entry box. 

 
The completed test. 

The test is now complete.  Now you will add the action if the test result is true. 
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12 Right-click the If node and select Insert>Field from the pop-up menu. 
13 Select the General tab in the Property View window set the following 

specifications: 
! Name: Static 
! Position: 

X:  1.00 in Absolute 
Y:  3.40 in Absolute 

 
Setting field properties. 

14 Select the Settings tab and set the following specifications:  
! Field Type: Static Text 
! Field Data: Const 
! Const entry box: *Congratulations! After reviewing your payment 

history, your total credit limit has been increased to $200,000. 
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Setting field properties for a static text field.  

15 Select the Font tab and set the following specifications: 
! Type:  True Type 
! Name:  Times New Roman  
! Size:  9.00 pt 
! Bold  
! Italic 

16 Select the Color tab and set the color to DMBLUE RGB (0,0,204). 
The static field prints if the condition is found true. 

17 On the Standard toolbar, click  to save the application. 
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The completed application. 
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Viewing Source Code 
You can view and edit the current document source code in Vitesse.  Source code 
includes resource elements such as variables, constants, comments, integers, key 
words, and normal and real numbers. 

To view source code of your project: 

1 Click the Source View tab at the bottom of the design area to toggle from the 
Design View to the Source View. 
The Source window displays. 

 
Viewing the source code for the open project.  The Data View window has been 
closed. 

You can edit the source code directly in this window.  Click   to compile the 
edited source code.  The source code can be restored to its last valid compilation state 
if for some reason compilation fails. 

To return to the last valid compiled state: 

2 Right-click in Source window, and select Revert to Last State from pop-up 
menu.  
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Reverting to the last valid compilation state. 

You have completed the Line mode project using a prefixed data file.  In the next part 
of the Tour, you will create a new application using Database mode.   

3 From the menu, choose File>Close. 
The project closes. 
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Adding Data in Database Mode 
You have now created forms, segments and two projects using Line mode.  Now you 
will create a Database mode project.  Project types are determined based on the data 
available and the type of application needed.  Database mode is typically used for 
letters and non-transactional documents. 

Jefferson Bank and Trust needs a promotional letter for their credit cardholders.  The 
bank currently has Gold and Silver credit levels.  Instead of creating two separate 
personalized letters, you will conditionally assign images and text for each letter 
based on the account holder’s level. 

The data for this application was exported from the bank’s database as a variable 
length file.  A variable length file uses delimiters to separate fields within a record.  
Typically each record contains all the data for one document, and the data’s first 
record contains the field names.  The remaining records contain the data in the order 
of field names. 

To complete this exercise, you will insert a static form and add the variable 
information to the form using the data provided.  You will also conditionally assign 
the letter and images based on the promotional card level.   

In summary, to create the Jefferson Bank and Trust letter you will:  

! Insert a previously created form provided in the Vitesse install 
! Add records and fields 
! Apply conditions 
! Save your document 

Creating a New Database Mode Document 
Before starting the exercise, you will review the design mockup and the data for the 
application. 

 
The data for the application. 



 

Chapter 4: A Vitesse Tour 197 

 
A mock up of the finished application.   
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To begin the exercise, you will create a new Database mode document and set its 
properties.   

1 From the menu, choose File>New. 
The New Project dialog displays. 

 
Selecting Database Mode from the New Project dialog. 

2 Select Database Mode and click New. 
The Database Mode dialog displays.  

3 On the General tab, enter GS_DBM in the Name entry box. 

 
The Database Mode dialog displays. 

4 Select the Layout tab and enter the following Paper specifications: 
! Standard: Letter 
! Orientation: Portrait 
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Setting properties in the Layout tab for a Database mode project. 

5 Select the Data tab and select Acquire Data file. 
By selecting this option you can choose a specific data file. 

6 Next to the Data file entry box, click . 
7 Browse to drive:\program files\elixir technologies\vitesse\data files, and 

select GS_Dbm.dbf. . 

 
The delimiter is already set to a colon, so you do not need to change that setting. 

8 Click OK. 
The new Database mode project opens. 
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.. 

The Database mode document GS_DBM displays. 

Setting Paper Properties 
You will now set the paper settings for printing your document.  These properties 
pertain to the physical page: what paper is loaded in the printer, how the printer prints 
on that paper, etc. 

1 Select the Paper1 node in the Project Tree window. 
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The Paper1 node is selected in the Project Tree. 

2 In the Property View window, select the General tab and set the following 
specifications: 
! Name: PaperLetter 
! Paper, Standard: Letter 
! Simplex: Selected 
! Include Paper Dimensions: Checked 
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Setting paper properties in the Property View window. 

 

Simplex prints on only one side of the paper.  Duplex prints on both 
sides of the paper.  Tumble Duplex prints on both sides of the paper 
head to foot (the back page prints upside down). 

Setting Page Properties 
Paper properties define the logical page settings for your document, or where and how 
the data prints on the physical page.  You will turn off the page numbering option 
here, since this will always be a single-page document. 

1 Select the Page1 node in the Project Tree window. 
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The Page1 node is selected in the Project Tree. 

2 In the Property View window, select the General tab and enter PageLetter in 
the Name entry box and set all margins to 0.00 in. 

 
Setting Page properties.  
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3 Select the Page Number tab and uncheck Page number.  

 
Turning off page numbers on the Page Number tab. 

Inserting an Existing Form 
Before you add any data to the page, you will insert a previously created form in your 
document.  For this exercise, you will use the GSJBTLetter form, which is located in 
the Vitesse Formlib folder. 

 

This resource is provided with the Vitesse install. 

1 On the Insert toolbar, click .  You can also select Insert>Form from main 
menu. 
The Insert Form dialog displays.  

2 Select the Existing tab. 
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Inserting an existing form into a Database mode project. 

3 Browse to drive:\program files\elixir technologies\vitesse\formlib and 
select GSJBTLetter.evf..   

4 Click Open. 
The GSJBTLetter form adds to your project.  A FormRef node adds in the 
Project Tree window as shown below. 
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5 On the Standard toolbar, click  to save the application.  
It is a good idea to save often. 

Now you can start adding variable data to your document. 

Adding Fields 
You will now add fields containing variable data to your document.  A database 
contains records and fields.  A record is one row, or line, of data that pertains to the 
same document.  A field contains one piece of information, such as a date or a name. 

To create the data file for this project, Jefferson Bank and Trust exported client data 
from their database into a variable length data file, delimited with a colon.  They 
included the field names as the first record in the data.  You will use this file to add 
data to the project. 

You can add fields using one of the four following methods: 

! Insert menu:  
Choose Insert>Field from the menu. 

! Insert toolbar:  
Click the Insert Field icon from this toolbar, which is located vertically 
between the Project Tree window and the design area.   

! Drag and drop:  
Drag and drop may be used to move data from the Data View window to the 
document.   

! Merge Data toolbar:  
Merge variable data fields with static text using the Merge Data toolbar. 

For this application you will all of these methods.  You will insert the first few fields 
using the Insert toolbar. 

To start adding data, you will first open the Data View window in the design area. 

1 On the status bar, click .. 
The status bar is a horizontal bar located at the bottom of the screen.  The 
Show/Hide Data View window button is at the far right of the status bar. 
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The Data View window displays on the right side of the design area.  The icon on 
the Status bar is highlighted with a circle. 

 

 is located in the lower right corner of the screen. 

Adding Fields using Insert Options 
The first field that you will add to the application is the Date field.  You will add this 
field using the Insert toolbar and define its settings using the Property View window. 

1 On the Insert toolbar, click  to add a field. 
A Field node adds to the Project Tree window.  

2 In the Property View window, select the General tab and enter Date in the 
Name entry box.  

3 Set the Position coordinates as follows: 
! X:  1.00 in Absolute 
! Y:  1.85 in Absolute 
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Setting the general properties for a field. 

You can get coordinates using a ruler on the original mockup.  You can also click and 
drag to place a field on the page visually.  You do not need to match coordinates for 
this exercise. 

Now you will define the data to be placed in the position you specified in the General 
tab. 

4 Select the following in the Settings tab: 
! Field Type: Normal 
! Field Data: Data 
! Field Name: date 
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Selecting a field from the data. 

5 Select the Font tab and select the following font specifications: 
! Type:  True Type 
! Name:  Times New Roman 
! Size:  12.00 pt 
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Setting the font for a field. 

6 Click . 
7 In the Style entry box, enter Regular. 

8 Click . 
Regular is added to the Style drop-down list.  You have saved the font style 
and can reapply it to other text objects using the same font specifications.   

 

You will use the Regular style for the majority of data in this project. 

You have added the first field to your application.   
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The first field adds to the document. 

Now you will add the address block. 

9 On the Insert toolbar, click  to add another field.   
10 In the Property View window, select the General tab and add the following 

specifications: 
! Name: Name 
! Position: 

X:  0.00 in Start Same 
Y:  2.25 in Absolute 

11 Select the Settings tab and select the following specifications: 
! Field Type: Normal 
! Field Data: Data 
! Field Name: name 

12 Select the Font tab and select Regular from the Style drop-down list. 
The field updates with the selected style. 

You have added the second field to your application.  You will now add the rest of the 
address block to your letter the same way. 
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13 Add the following new fields and specify the following: 
! Field Name: Address1 
! Position: 

X:  0.00 Start Same 
Y:  0.00 Start Next 

! Field data: Data 
Field name: address1 

! Font Style: Regular 
 

! Field Name: Address2 
! Position: 

X:  0.00 Start Same 
Y:  0.00 Start Next 

! Field data: Data 
Field Name: address2 

! Font Style: Regular 
 

! Field Name: Zip 
! Position: 

X:  0.00 Start Next 
Y:  0.00 Start Same 

! Field data: Data 
Field Name: zip 

! Font Style: Regular 
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All fields to this point are added using the Insert Field icon on the Insert toolbar. 

Adding Barcodes  
Now you will add a barcode to the letter.  This is a PostNet barcode, used by the 
postal service for mail delivery.  A PostNet barcode includes a zip code, a delivery 
point number and a check digit.  This data is provided for you. 

Barcodes can be added in three different ways: 

! As a barcode object 
! Merged using a text field 

Use this option when you need to add characters to data to create a finished 
barcode. 

! As a regular field using Transform settings to add formatting 
Certain barcodes have mandatory formatting.  These can be added 
automatically using the Transform tab. 

For this exercise, you will use the third method.  Refer to the Vitesse User Guide for 
more information on the other two methods.   
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To add the barcode, you will add the PostNet field.  You will then specify all the 
regular field properties, and then add PostNet formatting using the Transform tab.   

1 On the Insert toolbar, click . 
2 In the Property View window, select the General tab and add the following 

specifications:  
! Name: PostNetBarcode 
! Position: 

X:  1.00 in Absolute 
Y:  0.00 in Start Next 

3 Select the Settings tab and select the following specifications: 
! Field Type: Normal 
! Field Data: Data 
! Field Name: postnet 

4 Select the Transform tab and check Bar Code Types.  
5 From the drop-down list, select PostNet. 

The PostNet barcode formatting applies to the data.  Now the start and end 
characters (asterisks) have been added to the barcode. 
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Selecting the PostNet formatting. 

Now you will select a PostNet font. 

6 Select the Font tab and select the following: 
! Type:  PostScript 
! Name: SAdvPNET 
! Size:  12.00 pt 
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Selecting a PostNet font for the project.  The font provided with the Vitesse install 
is for demo purposes only. 

You have completed the address block.   

Mapping Data using Drag and Drop 
Now you will work on the table, which is in the center of the form.  The interest rate 
from Jefferson Bank and Trust varies depending on the credit level being offered.  
The prospective Gold members, for example, receive the best interest rate.   

You will now use the drag and drop method to add the interest rate field.   

1 Scroll to the end of the data file in the Data View window to locate the 
intrate field. 

 
The intrate field turns blue when selected. 
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The table on the form should have every space in the Jefferson Bank & Trust column 
filled.  Notice the last space, for interest rates, is empty.  This is where the interest 
rate field should be placed. 

2 Scroll to view the table on the screen, if it is not visible. 
3 Drag and drop intrate onto the design area. 
4 Click and drag, or use the arrow keys on your keyboard, to move the field 

into place. 

 

If you do not like placing fields by hand, coordinates are provided in the 
next step. 

5 In the Property View window, select the General tab and enter the following: 
! Name: InterestRate 
! Position: 

X:  3.15 in Absolute 
Y:  7.35 in Absolute 

6 Select the Font tab and select the following font specifications: 
! Type:  True Type 
! Name:  Times New Roman 
! Size:  13.00 pt  
! Bold 
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7 Select the Color tab and select NewBlue from the available colors in the 
palette.  

 
NewBlue is selected from the color palette. 

8 Select the new color. 
The interest rate uses the NewBlue color. 

 
The interest rate adds to the application using the drag and drop method. 
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Merging Variable Data with Static Text 
Now you will create the greeting for the letter.  This will associate variable data with 
static text. 

Using the Merge Data toolbar, you will add a greeting to the letter where “Dear” is 
static text and the client’s title and last name are variable data. 

1 On the Drawing toolbar, click . 
2 Click and drag in the design area underneath the address to draw a text box. 
3 Type in Dear [space]. 
4 On the Merge Data toolbar, select the title field from the drop-down list.   

5 Click . 
6 Click in the text box again and enter a space after $$title. in the text box using 

the space bar on the keyboard. 
7 Select the lname field from the drop-down list on the Merge Data toolbar. 

8 Click . 
9 Click in the text box and enter a comma after $$lname. in the text box using 

your keyboard. 
10 Click outside the text box to place the text. 

 

The Merge Data toolbar adds the correct syntax for merging data.  You 
can also type this syntax directly in the text box, if you prefer. 

11 In the Property View window, select the General tab and enter the following 
specifications: 
! Name: Dear 
! Position: 

X:  1.00 in Absolute 
Y:  3.50 in Absolute 
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Setting general properties for a merged text field. 

12 Select the Font tab and select the following: 
! Font Style: Regular 

13 Select the Settings tab and select the following options:  
! Merge data: Checked 

This will merge data from the data file in the design area.  If left 
unchecked, you can view the syntax instead of actual data. 

 
Merging data with static text in a drawing object. 

You have merged the data fields with static text. 
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The fields have been merged with static text. 

Adding Conditions 
So far the data you have mapped to the document has been imported exactly as it is 
stored in the data file, i.e., Name, and Address, etc. 

Next you need to add the body of the letter to the project.  This letter is variable, 
based on whether the client holds a Gold or Silver credit card.  You will change the 
letter using a condition. 

Conditions are control objects.  Conditions test a section of a data file and specify 
actions to be taken based on the result of the test. 

! Where the Condition is found true, objects placed under the If node are 
processed.   

! Where the Condition is not found true, objects placed under the Else node are 
processed.   

You will set up a test, and then you will set up an action if that test is found true, and 
an action if that test is found false.  The test is whether the field card type equals Gold 
Card.  The action for when the test is true includes printing text and images that 
pertain to Gold Card members. 

1 On the Insert toolbar, click . 
A condition node, along with If and Else nodes, adds to the Project Tree. 

2 Click  next to Condition1 to expand the condition in the Project Tree. 
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The condition expands to display the If and Else nodes. 

3 Select the If node.  
4 Click the entry box under the IF label. 

An arrow displays to the right of the entry box. 
5 Select Data Mapping>Field(“) from the pop-up menus. 

Field(date) displays in the entry box. 
6 Click date and select cardtype from the pop-up menu.   

This is a list of all the fields in the data file. 
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Selecting a field from the pop-up menu. 

The operator for the text is already equals, which is correct.   

7 Click the entry box on the right. 
8 Click the arrow and select Constants>Text from the drop-down menu. 

There are two options for Constants: Number and Text.  The Number option 
can perform numeric comparisons, such as less than 10, greater than or equal 
to 100.  The Text option can only perform string comparisons, which can only 
be equal or not equal to a given string. 

9 Enter Gold Card in the entry box. 

 
The completed test. 
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The test is now complete.   

Now you will add the action if the test result is true. 

10 On the Drawing toolbar, click .. 
11 Click and drag underneath the greeting in the design area to draw a text box. 

Don’t worry if the dimensions and placement of this box are correct; you can 
change these specifications later. 

12 Right-click the text box and select Import from the pop-up menu. 
The Import Text dialog displays. 

 
Selecting an RTF file from the Import Text dialog 

13 Browse to drive:\program files\elixir 
technologies\vitesse\clients\gs\tour_dbm and select GS-Text.rtf. . 

14 Click Open. 
You have imported the text object. 

15 Click to place the text. 
If the text disappears, you have made an error in your condition.  Check your 
condition to ensure the field selection and your typing is correct.  Only true 
condition actions will display in the design area when you are underneath the 
If node. 
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The imported text displays in the design area. 

 

 

The RTF file has data tags already inside the text.  This will merge the 
data into the text. 

16 In the Property View window, select the General tab and enter the following 
information: 
! Name: JBTtext 
! Position: 

X:  1.00 in Absolute 
Y:  3.83 in Absolute 

17 Select the Font tab and select the following font specifications. 
! Font Style: Regular 
18 Select the Settings tab and check Merge data.   
19 Select the Spacing tab and select the following specifications: 

! Line spacing: Single 
! Justification: Left 
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Setting the spacing properties for the imported text. 

You will also add a signature to the bottom of the letter under the If node. 

20 Select the If node and on the Insert toolbar, click . 
The Insert Image dialog displays. 
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The Insert Image dialog displays. 

21 Browse to drive:\program files\elixir technologies\vitesse\imglib and select 
visa_gold.jpg. 

22 Click Open. 
The image adds to the design area. 

23 In the Property View window, select the General tab and enter the following: 
! Name: GoldCard 
! Position: 

X:  4.60 in Absolute 
Y:  0.50 in Absolute 

! Size: 
W:  2.46 in 
H:  1.56 in 

 

Remember, the coordinates for all objects are taken from the mockup.  
Coordinates do not have to be exact for this exercise.  You can also 
click and drag to position the image.  You can resize the image by 
selecting one of the nodes around the image and clicking and dragging.
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Setting image properties. 

Now you will copy and paste the client’s name to appear on the credit card image. 

24 Select the Name field and press CTRL+C to copy the field. 
You can also right-click the field and select Copy from the pop-up menu. 

25 Select the Gold Card image under the If node and press Ctrl + V to paste the 
Name field. 

26 Change the following on the General tab: 
! Name: Name2 
! Positioning: 

X:  4.00 in Start Same  
Y:  1.62 in Absolute 

 

Object names must be unique.  When you paste the field, Vitesse 
automatically gives it a generic name.  When renaming the field, you 
must choose another name so that it is unique in the Project Tree. 

27 Change the following on the Font tab: 
! Type:  True Type 
! Font:  Arial 
! Size:  11.00 pt 

28 Click . 
29 In the Style entry box, enter Card. 

30 Click . 
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The Card style is saved. 
Now you will add a static field for a generic card number to place on the credit card 
image. 

 

Even though the client�s card number is in the data, you will use a 
generic number.  The card is not real, and so the number will not be 
real. 

31 On the Insert toolbar, click . 
32 In the Property View window, select the General tab and enter the following 

specifications: 
! Name: CardNumber 
! Position: 

X:  0.00 in Start Same 
Y:  1.25 in Absolute 

33 Select the Settings tab and specify the following: 
! Field Type: Static Text 
! Field Data: Const 
! Const entry box: 9999-9999-9999-9999 
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Setting field properties for a static text field. 

34 Select the Font tab and select Card from the Style drop-down list. 

 
The card information is now correct. 

Next you will add the signature for the letter.  This is also conditional, based on 
whether the letter is for a Gold or Silver level client. 
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Scroll down to view the end of the letter.  Notice that the spacing from the original 
file is not correct.  You will edit the imported text to make the spacing correct. 

35 Select JBTtext in the Project Tree. 
Selecting an object in the Project Tree also selects it in the design area, so you 
can locate it more easily. 

 
Selecting JBTtext in the Project Tree. 

36 Double-click the text box. 
There are several carriage returns to separate the first part of the letter from 
the last part of the letter.   

37 Using the arrow keys, move to the area between the two pieces of the letter. 
38 Using the Delete and Enter keys, adjust the spacing until it looks correct. 
Now you are ready to add the signature. 

39 On the Insert toolbar, click . 
The Insert Image dialog displays. 

40 Browse to drive:\program files\elixir technologies\vitesse\imglib, and 
select Vanjamill.bmp. 

41 Click Open. 
42 In the Property View window, enter Sign1 in the Name entry box. 
43 Click and drag the signature into place. 
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If you have snap to grid on, it may be difficult to place the image exactly.  

You can turn snap to grid off by clicking . 

When you move the signature on top of text, the text seems to disappear.  To fix this, 
you will use the Arrangement tools to send the signature behind the text of the letter. 

44 On the Arrangement toolbar, make sure if  is selected. 
The Arrangement toolbar is to the right of the design area, underneath the 
Drawing toolbar.  The text is visible again. 

 
The signature adds to the letter. 

You will now edit the imported text object again to change font properties and color 
of the variable $$cardtype.  Every time Gold Card is printed, it should be bolded and 
use a gold color. 

45 Double-click the imported text in the design area. 
You are now able to edit the text.  You can also see the data tags in the text. 

46 Select the first instance of $$cardtype, and select Bold on the Font tab. 
$$cardtype is located at the end of the first sentence. 

47 Select the Color tab and set the variable color as follows: 
! Outline:  Orange RGB (255,165,0) 
! Background:  Black RGB (0,0,0) 
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48 Change the other instance of $$cardtype to be Bold and Orange. 
The second instance of $$cardtype is at the end of the last line of the signer’s 
title.  There are only two instances of $$cardtype in the letter. 

The IF statement is complete. 

 
The letter is complete for Gold cardholders. 

Now you will set up the Else condition.  This is for Silver cardholders.  They need a 
different RTF file, card image and signature.  All instances of $$cardtype in the Silver 
letter will print with a silver bold font. 

49 Select the JBTtext node in the Project Tree. 
50 Press the Ctrl key and drag it to the Else node. 

A text node is added under the Else node in the Project Tree window.   
51 Click  to expand the Else tree and view the new text node. 
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The text is copied from the If node to the Else node. 

52 In the Property View window, select the General tab and enter JBTtext2 in 
the Name entry box. 

53 Click the navigation button in the status bar to view the next page. 

 
The Navigation buttons are located on the bottom left of the Status bar, indicated 
with a circle here. 
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54 Select each $$cardtype instance in the text, and select the Color tab and set 
the variable color as follows: 
! Outline:   Medium RGB (204,204,204) 
! Background:  Black RGB (0,0,0) 

 

Double-click the text to edit the $$cardtype instances. 

55 Select the JBTtext2 node and click  on the Insert toolbar. 
The Insert Image dialogdisplays. 

56 Browse to drive:\program files\elixir technologies\vitesse\imglib, and 
select visa_silver.jpg. 

57 Click Open. 
58 In the Property View window, select the General tab and enter the following 

specifications: 
! Name: SilverCard 
! Position: 

X:  4.60 in Absolute 
Y:  0.50 in Absolute 

! Size: 
W:  2.46 in 
H:  1.56 in 

Now you will copy and paste the client’s name and credit card number to appear on 
the credit card image. 

59 Copy the Name2 field from the IF node. 
You can use Ctrl + C or right-click the Name2 field and select Copy from the 
drop-down menu. 

60 Select the SilverCard node and paste the Name2 field. 
61 Change the following on the General tab: 

! Name: Name3 
! Position: 

X:  0.14 in Start Same 
Y:  1.62 in Absolute 

 

When you copy and paste a field, Vitesse automatically adds an 
incremental step to the position, both horizontally and vertically.  If you 
want the field at the exact same place as the original, you will need to 
edit the positioning in the Property View window. 
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62 Copy the CardNumber field from the IF node. 
63 Select the Name3 node and paste the CardNumber field. 
64 Change the following on the General tab: 

! Name: CardNumber1 
! Position: 

X:  0.00 in Start Same 
Y:  1.25 in Absolute 

Next you will add the signature for the Silver Card letter.   

65 On the Insert toolbar, click . 
The Insert Image dialog displays. 

66 Browse to drive:\program files\elixir technologies\vitesse\imglib, and 
select Johnbrown.bmp. 

67 Click Open. 
68 In the Property View window, select the General tab and enter the following: 

! Name: Sign2 
! Position: 

X:  0.92 in Absolute 
Y:  8.60 in Absolute 

! Size: 
W:  1.13 in 
H:  0.72 in   

 

You can also use click and drag to position the signature. 

69 On the Arrangement toolbar, make sure if  is selected.  
The text is visible again. 
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The signature is placed in the design area. 

70 From the menu, choose File>Print Preview. 
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Scroll through the pages using the navigation buttons to view the conditional 
changes. 

71 Click  when you are done previewing the project. 

72 On the Standard toolbar, click  to save the application. 
You have completed the Database mode project.  In the next part of the Tour, you will 
create a new application using XML mode.   

73 From the menu, choose File>Close. 
The project closes. 

Adding Data in XML Mode 
You have now created projects using Line and Database modes, and created forms 
and segments.  Now you will create an XML mode project.   

Project types are determined based on the data available and the type of application 
needed.  XML mode creates documents using Extensible Markup Language (XML) 
data.  XML mode documents process data files containing tags or elements, attributes, 
values and XML text.  Tags or elements, attributes, values and XML text identify data 
file content.  All information is enclosed between bounding tags or elements. 

Jefferson Bank & Trust wants their printed statement design to use an XML data file 
generated from their web site.  This file includes tags, attributes, values and XML 
text.  All information is enclosed between bounding tags or elements.  You developed 
the form earlier in this Tour 

 

If you did not complete the form earlier in the Tour, a finished form is 
provided for you. 

To complete this exercise, you will insert the Jefferson Bank & Trust statement form, 
add the summary and detail transaction information using records and fields, and 
apply conditional logic to generate warning messages if the account is below its 
minimum balance. 

In summary, to create Jefferson Bank & Trust statement you will:  

! Insert a previously created form 
! Add frames 
! Add records and fields 
! Apply conditions 
! Save your document 



 

Chapter 4: A Vitesse Tour 239 

 

You will be introduced to various properties throughout the Tour.  If you 
would like more information about a particular subject, refer to the 
Vitesse User Guide for more details. 

Creating a New XML Mode Document 
Before starting the document, you will review the data and the design mockup for the 
application. 

 
The XML data for the Jefferson Bank & Trust Statement.  
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A mockup of the completed application. 
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To begin the exercise, you will create a new XML mode document and set its 
properties.   

1 From the menu, choose File>New. 
The New Project dialog displays. 

 
Selecting XML Mode from the New Project dialog. 

2 Select XML Mode and click New. 
The XML Mode dialog displays. 

3 On the General tab, enter GS_XML in the Name entry box. 

 
The XML Mode dialog displays. 

4 Select the Layout tab and enter the following Paper specifications: 
! Standard: Letter 
! Orientation: Portrait 
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Setting properties in the Layout tab for an XML mode project. 

5 Click OK. 
The new XML mode document opens. 

. 

The XML mode document GS_XML displays. 
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Inserting a Data File 
In Line and Database modes, you can open a new document with its chosen data file. 

In XML mode, however, you insert a data file once the new document opens.  To 
insert a data file you will use Insert Data File on the Insert toolbar, browse to the 
location where the data file is placed and insert it into the document. 

1 Click . 
The Insert Data File dialog displays. 

 
Select GS_XML.xml from the Data Files folder. 

2 Browse to drive:\program files\elixir technologies\vitesse\data files and 
select GS_XML.xml. 

3 Click Open. 
The data file adds to your document, though there are no visual changes to the 
design area. 

Viewing the Data File 
You can view XML mode data files in the Data View window.  The XML mode data 
file structure differs from data files used in other document modes.  XML mode data 
files contain simple text and data-driven tags or elements, attributes, values and 
comments arranged in a tree structure.  Tag names are displayed on the left side of the 
tree and their values are displayed on the right side of the tree, next to the associated 
tags. 



 

244 Vitesse Getting Started Guide 

Tags can either remain empty or contain content or other elements as child elements.  
The element containing all the content and child elements is called the root element.  
An XML document can only have one root element.  In an XML mode data view, you 
can expand the root and child nodes to view subsequent data file tags and their values. 

When a data file carries multiple instances of the same tag, selecting that tag 
automatically selects every instance of the same tag. 

1 From the menu, choose Window>Data. 
The Data View window displays to the right of the design area. 

 
The XML data file opens in the Data View window. 

There are two views in the Data View window:  

! Expanded view 
This view displays all tag instances in one page. 

! Compressed view 
This view displays single instances of each tag on each page.   

For example, there are two clients in the Jefferson Bank & Trust file.  If you use the 
compressed view, you will only view the first client.  Then you can use the arrow 
keys to page to the next tag to view the second client. 
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2 On the Data toolbar, click . 
The Data toolbar is located directly above the Data View window.  You can 
switch to the view you want by clicking this button. 

 

You may need to rearrange the windows to see .  Use the vertical 
slide bar between the design area and the Data View window to view 
the entire Data toolbar. 

Setting Paper Properties 
You will now set the paper properties for printing your document.  These properties 
pertain to the physical page: what paper is loaded in the printer, how the printer prints 
on that paper, etc. 

1 Select the Paper1 node in the Project Tree window. 

 
The Paper1 node is selected in the Project Tree. 

2 In the Property View window, select the General tab and set the following 
specifications: 
! Name: PaperStat 
! Paper, Standard: Letter 
! Simplex: Selected 
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! Media: 
Type: Plain 
Color: White 

 
Setting Paper properties in the Property View window. 

Simplex prints on only one side of the paper.  Duplex prints on both 
sides of the paper.  Tumble Duplex  prints on both sides of the paper 
head to foot (the back page prints upside down). 

Paper properties are set by default.  You may not need to set paper 
properties unless you want to specify unique settings for your paper 
requirements. 

Setting Page Properties 
Page properties define the logical page settings for your document, or where and how 
the data prints on the physical page.  You will set the page break and page numbering 
options. 

1 Select the Page1 node in the Project Tree window. 
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The Page1 node is selected in the Project Tree. 

2 In the Property View window, select the General tab and enter PageStat in 
the Name entry box. 

 
Setting Page properties. 
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3 Select the Settings tab and select Customers>Customer from the XML drop-
down tree structure. 
This is the XML Page Break setting.  You are telling Vitesse to start a new 
page for every customer’s record. 

 
Select Customers^ Customer from the XML tree structure. 

4 Select the Page Number tab and set the following options: 
! Page number: Checked 

Format: Page # 
Alignment: Right  
This option is enabled when position is set to Custom. 
Use Start from: Checked 
Start from: 1 

! Positioning: 
Position: Custom 
X:  8.00 
Y:  10.50 
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Setting the Page Number options. 

 

In XML mode, only the data file, forms, records, and frames can be 
inserted at the page level.  Everything else must be added to a record. 

Adding Frames in the Document 
Frame objects control dynamic graphic, text and data flow.  When a frame object is 
full, data, text and graphic objects automatically flow to another frame object on the 
same or next page.   

In this application, data can flow to additional pages, depending on the number of 
transactions for each client.  You will add the frame to the page, and then add objects 
within the frame.  When a frame object is full, Vitesse automatically creates a second 
page following the current page to place the remaining data.  This process continues 
until all the data is placed in the design. 

1 On the Drawing toolbar, click . 
2 Click and drag in the design area to draw a frame. 

Do not worry about the dimensions and positioning.  You will set these in the 
Property View window. 
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3 Select the PageStat node in the Project Tree window. 
4 In the Property View window, select the Frame tab.  

Frame properties are listed under the Page. 
5 Make sure Active is checked. 

The Active option selects, or activates, frames in the design area.  This should 
already be checked. 

6 Set the Position and Size information as follows: 
! X:  0.25 in 
! Y:  0.25 in 
! W:  8.00 in 
! H:  9.25 in 

 
Setting the frame properties in the Page node. 
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7 Click Apply to apply your changes. 

 
The frame adds in the design area. 

Inserting an Existing Form 
Before you add any data to the page, you will insert a previously created form in your 
document.  For this exercise you will use the JBTStatement form, which is located in 
the Vitesse Formlib folder. 

 

If you didn�t complete the form earlier in the Tour, use the JBTStat form.  
The JBTStat form was installed with Vitesse. 
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1 On the Insert toolbar, click . 
The Insert Form dialog displays. 

2 Select the Existing tab. 
3 Browse to drive:\program files\elixir technologies\vitesse\formlib, and 

select GSJBTStatement1.evf. 

 
Selecting an existing form. 

 

Select GSJBTStat.evf if you did not complete the form earlier in the 
Tour. 
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4 Click Open. 
The GSJBTStatement1 form adds to your document.  A FormRef node adds 
in the Project Tree window. 

5 Select the PageStat node in the Project Tree window. 

 
The GSJBTStatement1 form adds to the document. 

6 On the Standard toolbar, click  to save the application. 
It is a good idea to save often. 

Now you can start adding variable data to your document. 

Adding Records and Fields 
You will now add variable information to your document.  XML data files are 
organized using start tags and end tags.  VIPP requires data to be defined using 
records and fields, so the record/field structure is imposed upon the XML data file 
structure. 
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Using the compressed view, and collapsing the fields, you can view all the data 
available in the sample XML data file. 

A record is a group of information that is organized in one area of the data file.  There 
are two ways to define a record using XML data: 

! A record can be any start/end tag pair with nested start/end tag pairs.  For 
example, note the Address “record” in the XML data file.  This record includes 
the City, State and Zip “fields”. 

! A record can also be any start/end tag pair where the record is the tag name, or 
label, and the field is the tag value.  For example, the Street information can be 
added to the project so that the Street label is the “record” and the Street value is 
the “field”. 

A field contains one piece of information, such as a date or a name.  In an XML data 
file, tag values are fields. 

 

Use  (plus) and  (minus) to expand and collapse the records in the 
Data View window. 

You can add data using various methods.  Following are three different techniques: 

! Insert menu:  
Choose Insert>Record and Insert>Field from the menu. 

! Insert toolbar:  
Click the Insert Record and Insert Field icons from this toolbar, which is located 
vertically between the Project Tree window and the design area. 
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! Drag and drop:  
Drag and drop may be used to move data from the Data View window to the 
document.   

For this application, you will use the drag and drop method to place variable data in 
the design area and then set the data properties using Property View window. 

Mapping data in XML mode is done differently than in the other modes.  The data is 
presented in a tree structure format.  The end tags in the data always determine print 
order.  When processing the XML file, the record for the first end tag encountered 
will process/print first. 

For example, using the Jefferson Bank and Trust data file, the first data to print will 
be the Address record, since its end tag is encountered first in the data.  However, the 
Name field will be one of the last printed fields, because it is part of the Customer 
record.  The end tag for the Customer record is at the end of the data file. 

 

VIPP requires the print order to be dependent on the XML data file 
structure.  Vitesse provides a workaround to achieve a preferred print 
order. 

If you would like to print the Name field first, you can change the print order.  You 
can define the Name tag as its own record in the project by dragging the Name tag 
onto the page.  This creates a “record” for the Name information. 

To place the Address record, you will drag the Street, City and Zip values onto the 
design area.  The Project tree will have one record with three nested fields.  Dragging 
the tag's value places the data on the page, and adds record and field nodes to the 
Project Tree, using the parent tag as a record.  This data is placed relative to the last 
data placed, and will print depending upon the data file structure.   

The first field you will add in your project is the client’s name.  The subsequent data 
fields will be positioned relative to this record. 

1 Select the Name tag in the Data View window.   
2 Drag and drop the selected tag onto the design area. 

A record node adds in the Project Tree window. 

 

You cannot see any data being mapped onto the design area.  This is 
because you have not added a value to the project yet. 
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3 Select the Name value in the Data View window. 
4 Drag and drop the selected data onto the design area underneath the Jefferson 

Bank & Trust logo. 

 
The Name tag (record) is specified by “Name” field in the Data View window.  
The name value (field) is specified by “James Smythe”. 

The Name field adds in the design area and new corresponding field node adds in the 
Project Tree window. 
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The data has been dropped onto the design area, and a record (tag) and a field 
(value) is added to the Project Tree. 

Now you will position the added field and set the properties using the Property View 
window. 

5 Select the _Name node in the Project Tree window. 
6 In the Property View window, set the position coordinates as follows: 

! X:  1.25 in 
! Y:  1.77 in 
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Setting general field properties. 

7 Select the Font tab and select the following specifications: 
! Type:  True Type 
! Name:  Times New Roman 
! Size:  11.00 pt 

 

The font name drop-down list allows typing in the first letter of your font.  
This action will scroll quickly to the fonts starting with the letter you 
typed.  For example, you can type �T� to reach Times New Roman 
quickly. 
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Setting font properties. 

 

To view font names in the Name drop-down list, go to 
Options>Preferences dialog, and select Show font names in font combo 
box in the General category.  To enable the B and I options (depending 
on the font Type), ensure that the Show font family members in font 
combo box option is deselected.  For more information on default 
settings, refer to Chapter 3: Configuration. 

8 Click . 
9 In the Style entry box, enter Regular. 

10 Click . 
Regular is added to the Style drop-down list.  You have saved the font style 
and can apply it to other text objects using the same font specifications. 

 

You will use the Regular style for the majority of data in this project. 

You have added the first field to your application. 

Now you will add the entire Address record, using all the nested values as fields.  The 
entire address block is relative to the Name field. 



 

260 Vitesse Getting Started Guide 

11 Select the Street value in the Data View window. 
12 Drag and drop the selected data onto the design area underneath the Jefferson 

Bank & Trust logo. 
The Street field adds in the design area and new corresponding record and 
field nodes add in the Project Tree window. 

 
The field (value) is added in the design area and record (parent tag) and field 
(value) nodes are added in the Project Tree window. 

13 In the Property View window, set the position coordinates as follows for the 
_Street field: 
! X:  1.25 in  
! Y:  0.00 in  

14 On the Font tab, select Regular from the Style drop-down list. 
You will now complete the address portion of the address block.  The City and Zip 
field nodes will automatically add under the Customers_Customer_Address record 
node in the Project Tree window, because that is how the data is sequenced in the data 
file.  Vitesse automatically keeps track of which fields belong to which records, and 
adds them to the tree accordingly. 
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15 Select the City value in the Data View window. 
16 Drag and drop the selected data onto the design area underneath the Street 

field. 
The City field adds in the design area and a new corresponding field node 
adds in the Project Tree window.   

The field automatically adds at the end of the Street field, regardless of where you 
place it.  Now you will change the default field positioning for the City field and set 
its properties. 

17 Select the _City node in the Project Tree window. 
18 In the Property View window, set the position coordinates as follows: 

! X:  0.00 in Start Same 
! Y:  0.00 in Start Next 

19 On the Font tab, select the following: 
! Font Type: True Type 
! Font Style: Regular 

20 Add the Zip field using drag and drop, then specify the following in the 
Property View window: 
! Position: 

X:  0.00 in Start Next 
Y:  0.00 in Start Same 

! Font Style: Regular 

 
The address record is complete. 
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The next two records for the project are the Account Number and Statement date.  
These two fields are in the Customers record.  Remember that the Customers record 
end tag is the last tag in the file.  In order to print these fields before the end tag is 
encountered, you will drag the tag and then the value to the design area. 

21 Select the Account Number tag in the Data View window and drag it onto 
the design area. 

22 Select the Account Number value in the Data View window and drag it onto 
the design area. 

The Account Number should be placed in the upper right corner of the page, under 
the Account Number text.  However, all added fields automatically have default 
relative positioning.  Since this data actually prints above the address block on the 
page, you will add negative positioning in the Property View window. 

 

The Account Number record is placed above the Name record.  Since 
the VIPP printer is using the XML print order to process and print the 
page, the printer is going backwards to print this record.  Therefore, the 
coordinates specified for this record are negative. 

23 In the Property View window, specify the following: 
! Position: 

X:  6.15 in  
Y:  -1.80 in  

! Size: 
W: 1.00 in 

! Font Style: Regular 
! Justification: Center 

 

Justification is located on the Spacing tab. 

24 Select the SDate tag in the Data View window and drag it onto the design 
area. 

25 Select the SDate value in the Data View window and drag it onto the design 
area. 

26 In the Property View window, specify the following: 
! Position: 

X:  5.95 in  
Y:  0.50 in  

! Size: 
W:  1.50 in 
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! Font Style: Regular 
! Justification: Center 

 
The Account information is complete. 

The next end tag encountered in the data is for the Account Summary.  Since all the 
Account Summary fields are nested in the Account Summary begin/end tags, you can 
drag and drop the values of each without disturbing the print order.  You will add 
fields containing the account type, starting balance, total of credit transactions, total 
of debit transactions and the ending balance figures. 

27 Select the Account Type value in the Data View window. 
28 Drag and drop the selected data underneath Account Type in the Account 

Summary area of the form. 
The Account Type field adds in the design area and new, corresponding 
record and field nodes add in the Project Tree. 

29 In the Property View window, set the following specifications: 
! Position: 

X:  1.25 in Absolute 
Y:  2.30 in Start Next 

! Size: 
W:  1.00 in 



 

264 Vitesse Getting Started Guide 

 

The next few fields will be relative to the Account Type field�s horizontal 
position.  Therefore, a consistent size is necessary in order to ensure 
correct placement of the following fields. 

30 On the Font tab, select Regular from the Style drop-down list. 

 
Adding the Account Type information to the Account Summary. 

You will now add four more fields under the same record, filling in the Account 
Summary portion of the application. 

31 Add the following fields by using the drag and drop method: 
! Name: Starting Balance 
! Position: 

X: 0.50 in Start Next 
Y:  0.00 in Start Same 

! Size: 
W: 1.00 in 

! Font Style: Regular 

 

Select the values, drag them onto the design area and position the data 
using Property View window. 

! Name: Credits 
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! Position: 
X:  0.72 in Start Next 
Y:  0.00 in Start Same 

! Size: 
W: 0.75 in 

! Font Style: Regular 
 

! Name: Debits 
! Position: 

X: 0.00 in Start Next 
Y: 0.00 in Start Same 

! Size: 
W: 1.00 in 
Font Style: Regular 

 

! Name: Ending Balance 
! Position: 

X: 0.10 in Start Next 
Y: 0.00 in Start Same 

! Size: 
W: 1.20 in 

! Font Style: Regular 
! Justification: Right 

 

Justification is located on the Spacing tab. 

 
The Account Summary area is complete. 

You have completed adding the Account Summary data to the Jefferson Bank & 
Trust statement.  The Transactions record has the next end tag in the data, so you will 
add it next.  Again, all the fields are in the print order, so you can drag values to the 
page. 
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The Transactions record contains transaction details such as Dates, Details, Debit and 
Credit information.  All these fields carry multiple instances.  You will use relative 
positioning to place these fields in the design. 

32 Select the Dates value under the Transaction record in the Data View 
window. 

33 Drag and drop the selected data onto the design area. 
The Date field adds in the design area and new corresponding record and field 
nodes add in the Project Tree window. 

 
The Transaction Date adds to the design, but the dates would be visible once 
their coordinates are specified. 

This field has multiple occurrences of data.  You will position it using Property View 
window. 

34 In the Property View window, set the position coordinates as follows: 
! Position 

X:  1.25 in  
Y:  0.40 in 

! Size 
W: 0.50 in 
H:  0.15 in 

! Spacing 
Vertical:  0.05 in 
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The height, along with the spacing, determines how the transactions are 
placed vertically on the page. 

35 On the Font tab, select Regular from the Style drop-down list. 
You will now add three more fields under the same record. 

36 Add the following fields using the drag and drop method: 
! Name: Description 
! Position: 

X:  0.30 in Start Next 
Y:  0.00 in Start Same  

! Size: 
W: 3.00 in 
H:  0.15 in 

! Font Style: Regular 

 

Select the values in front of the field names, drag them onto the design 
area and position the data using Property View window. 

! Name: Credit 
! Position: 

X:  0.35 in Start Next 
Y:  0.00 in Start Same 

! Size:  
W: 1.00 in 
H:  0.15 in 

! Font Style: Regular 
! Justification: Right 

 

! Name: Debit 
! Position: 

X:  0.00 in Start Next 
Y:  0.00 Start Same 

! Size: 
W: 1.00 in 
H:  0.15 in 

! Font Style: Regular 
! Justification: Right 
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You have completed adding the transactions. 

The next record with an end tag is the Totals record.  This record includes totals of the 
debit and credit transactions. 

If you take a look at the design mockup, you will notice two dotted lines above and 
below the total figures.  You will add these two lines as a Start Tag segment.  This 
will keep the lines with the Totals record, even if the data flows to the next page.  A 
Tag Start segment is an internal document resource and is part of the Page node in the 
Project Tree.  If a Tag Start is encountered before the end tag is reached, the contents, 
such as segments, images and drawing objects etc., under the Start Tag are processed 
first.   

You will add a Tag Start segment under a record node and add a segment object to it.  
The segment will consist of two dotted lines, which will print above and below the 
Total Credit and Debit figures. 

37 On the Insert toolbar, click  to add a record. 
A record node adds in the Project Tree. 

 

You cannot add a record if a field is selected.  To add a record, select 
another record or the Page node. 
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38 In the Property View window,select the Settings tab and select 
Customers>Customer>Totals from the drop-down tree structure. 

 
Selecting a record from the data file manually in the Settings tab. 
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39 On the Insert toolbar, click . 
The Insert Segment dialog displays. 

 
Inserting a Tag Start.  

40 Select Tag Start on the New tab and click New. 
A Tag Start node adds to the Project Tree. 

41 Select the Start node in the Project Tree window. 

42 On the Insert toolbar, click . 
The Insert Segment dialog displays. 
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Inserting a new linked segment.  Linked segments can be used in other projects, 
because they are saved as a separate resource.  For other segment type 
descriptions, see the Vitesse User Guide. 

43 Select Linked and click New. 
A SegRef node adds under the Start node and a Segment node adds under the 
Segments node in the Project Tree. 

44 Select the Segment node in the Project Tree window. 
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The new segment adds under the Resources>Segments nodes.  To modify a 
project resource, you must select it under the Resources node. 

45 In the Property View window, enter the following specifications: 
! Name: Lines 
! Size: 

W:  7.00 in 
H:  1.00 in 
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Setting segment properties. 

46 On the Drawing toolbar, click . 
47 Click and drag in the design area to draw a horizontal line the length of the 

segment. 
48 In the Property View window select the General tab and enter specifications 

as follows: 
! Start Point: 

X:  0.00 in  
Y:  0.25 in  

! End Point: 
X:  7.00 in  
Y:  0.25 in 
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Setting general line properties. 

49 Select the Settings tab and set the following line specifications. 
! Width: ¾ pt 
! Style:  Dashed 

 
Setting line style properties. 
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50 Select the Color tab and set the line color to XLBLUE RGB (229,229,255). 

 
Setting line color properties. 

51 Copy the line using the keyboard shortcut Ctrl + C. 
52 Paste the line using the keyboard shortcut Ctrl + V. 
53 In the Property View window select the General tab and enter specifications 

as follows: 
! Start Point 

X:  0.00 in 
Y:  0.75 in 

! End Point 
X:  7.00 in 
Y:  0.75 in 
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The segment is complete.  Here the grid is turned off so the lines can be viewed 
more clearly. 

54 Select the SegRef node under the Start tag in the Project Tree. 

 
Selecting the SegRef node. 
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55 In the Property View window set the Position coordinates as follows: 
X:  1.10 in  
Y:  0.00 in  

56 Select the CTotal value in the Data View window. 
57 Drag and drop the selected data onto the design area. 

The CTotal field adds in the design area and new corresponding record and 
field nodes add in the Project Tree window. 

 
Adding the CTotal field. 

58 In the Property View window, set the following: 
! Position: 

X:  5.40 in Absolute 
Y:  0.10 in Start Same 

! Size: 
W:  1.00 in  
H:  0.25 in  

! Font Style: Regular 
! Justification: Right 

59 Add the next field: 
! Name: DTotal 
! Position: 

X:  0.00 in Start Next 
Y:  0.00 in Start Same 
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! Size: 
W: 1.00 in  
H:  0.25 in  

! Font Style: Regular 
! Justification: Right 

 
The Totals record is complete. 

Adding Conditions 
So far the data you have mapped to the document has been imported exactly as it is 
stored in the data file, i.e., Name, and Address, etc. 

Next you will add a warning message that prints only if the ending balance is below 
the account’s minimum balance requirement.  You will add this message using a 
condition. 

Conditions are control objects.  Conditions test a section of a data file and specify 
actions to be taken based on the result of the test. 

! Where the Condition is found true, objects placed under the If node are 
processed. 

! Where the Condition is not found true, objects placed under the Else node are 
processed. 

You will set up a test, and then you will set up an action if that test is found true, and 
an action if that test is found false.  The text is if the ending balance is below $1500.  
The action for when the test is true is to print the warning message in red.   
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1 Select the _EndingBalance field node in the Project Tree. 

 
Selecting the Ending Balance. 

 

The easiest way to find a field in the Project Tree is to select the field in 
the design area. 
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2 On the Insert toolbar, click . 
A condition node, along with If and Else nodes, adds to the Project Tree. 

3 Click  next to Condition1 to expand the condition in the Project Tree. 

 
The condition expands to display the If and Else nodes. 

4 Select the If node.  
5 Click the entry box under the IF label. 

An arrow displays to the right of the entry box. 
6 Select Data Mapping>Field(“) from the pop-up menus. 

Field(^Customers) displays in the entry box. 
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7 Click ^Customers and select 
Customer^Customer^AccountSummary^EndingBalance from the pop-up 
menu. 
The data file’s tree structure displays in the pop-up menu. 

 
Selecting a field from the pop-up menu. 

8 Click the operator in the center of the first row (equal sign) and select < (less 
than) from the drop-down menu 

9 Click the entry box on the right. 
10 Click the arrow and select Constants>Number from the drop-down menu. 

There are two options for Constants: Number and Text.  The Number option 
can perform numeric comparisons, such as less than 10, greater than or equal 
to 100.  The Text option can only perform string comparisons, which can only 
be equal or not equal to a given string. 
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11 Enter 1500 in the entry box. 

 
The completed test. 

The test is now complete.  Now you will add the action if the test result is true. 

12 Select the _EndingBalance field node in the Project Tree window, and drag 
and drop it under the If node. 

13 Drag and drop the same field to the Else node while pressing the Ctrl key on 
the keyboard. 
This creates a copy of the field. 

 
Adding a copy of _EndingBalance to the Else node. 

If the condition test is not found true, the field placed under the Else node will be 
printed.  You will change the field settings to print in red under the If node, and keep 
the field black under the Else node. 
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14 Select the _EndingBalance field under the If node, select the Color tab and 
set the Font color to Red RGB (255,0,0). 

15 Right-click the If node and select Insert>Field. 
A field adds above the _EndingBalance field. 

 

This will change the position of _EndingBalance as all the fields are 
relative here.  You will fix this after you add the message to the design. 

16 Select the General tab and specify the following: 
! Name: MinBal 
! Position: 

X:  0.10 in Absolute 
Y:  -0.90 in Start Same 

! Field Type: Static Text 
! Field Data: Const 
! Const entry box: * You will be charged a transaction fee for each day 

your account is below the minimum balance. 
! Font:  

Type:  True Type 
Name:  Times New Roman 
Size:  9.00 pt  
Italic 

! Color: Red RGB (255,0,0) 
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Adding the settings for a static text field. 

17 Fix the positioning of the _EndingBalance field as follows: 
! X: 5.20 in Start Next 
! Y:  0.70 in Start Same 
If the condition test is found true, the fields placed under the If node will 
print.   

You are ready to save and preview your application. 

18 On the Standard toolbar,  click  to save the application. 
19 From the menu, choose File>Print Preview.  
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Scroll through the pages using the navigation buttons to view the conditional 
changes. 

20 Click  when you are done previewing the project. 
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21 On the Standard toolbar,  click  to save the application. 
You have completed the XML mode project.  In the next part of the Tour, you 
will export a completed project.   

22 From the menu, choose File>Close. 
The project closes. 

Exporting Documents for Printing 
Once you have created a form or document, it needs to be exported to the VIPP 
environment for printing.   

This portion of the Tour will lead you through the steps required for exporting a 
document.  You will use the Jefferson Bank & Trust credit card summary, which was 
created in the first Line Mode section of the Vitesse Tour. 

 

If you did not create the Line Mode application, a finished project is 
provided for you with the Vitesse install. 

To complete this exercise, you will open the existing document in Vitesse, then set 
Export Preferences and export the document with its external resources.  A document 
can be exported with or without its external resources. 

The Vitesse folder contains separate folders for Forms and Segments in internal 
Vitesse format.  The hierarchy for a project and its resources remains the same in the 
pure VIPP environment after exporting.  All exported resources retain their Local, 
Shared or Global scope.   

To export a document, you will: 

! Open an existing document 
! Set Export Preferences 
! Export the document with its external resources 

 

You will be introduced to various properties and concepts.  Refer to the 
Vitesse User Guide for more information about specific functions. 

 

This exercise uses a Line mode project.  You can export all document 
types as well as forms, segments and fonts. 
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Opening an Existing Document 
To begin the exercise, you will first open the previously created Line Mode document 
in Vitesse. 

1 Within Vitesse, choose File>Open from the menu. 
The New Project dialog displays with the Existing tab selected. 

 
The New Project dialog displays. 

2 Browse to drive:\program files\elixir 
technologies\vitesse\clients\default\gs_lineld, and select GS_LineLD.evd.  

 

If you did not complete the Line mode project earlier in the Tour, you 
can use the completed application.  It is located at drive:\program 
files\elixir technologies\vitesse\clients\gs\tour_linedata\gs_lineln.evd. 
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3 Click Open. 
The GS_LineLD Line mode document opens. 

 
The GS_LineLD Line mode document opens. 
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Setting Export Preferences   
Export Preferences define how you want your document to export.  These choices 
determine what information is kept in your print file.  These preferences are 
maintained by the system settings, and only need to be set once.   

1 From the menu, choose Tools>Preferences. 
The Preferences dialog displays.   

2 Select the Export category. 

 
Select Export from the category list. 

3 Select the following options: 
! Comments: Heavily Commented  
! Generate Elixir Comments: Checked 
This option processes non-VIPP commands automatically.  This option is 
used when the project contains Elixir or non-VIPP objects.  These non-VIPP 
objects will be converted into VIPP objects during export.   
! Default unit: Inches 
Use the default unit you prefer. 

4 Click OK to save the new preferences. 
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Exporting Documents 
Now you are ready to export the document, along with all its external resources. 

1 From the menu, choose File>Export. 
The Export dialog displays. 

 
The Export dialog displays. 

2 Enter GS_Line.vpc in the File Name entry box. 
Exported documents use the extension *.vpc for Native mode, Line mode, 
Database mode and XML mode projects, *.frm for forms and *.seg for 
segments. 

 

You do not have to type in the extension.  Vitesse automatically assigns 
the correct extension for each file format. 
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3 Click . 
The Browse for Folder dialog displays. 

 
The Browse to Folder dialog displays. 

4 Browse to drive:\program files\elixir technologies\vitesse\xgf\line and click 
OK. 
This is the location of the exported document.  You can choose another 
location if you wish. 
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5 In the Export dialog, click Export Font. 
The Export Fonts dialog displays. 

 
The Export Fonts dialog displays. 

6 Check all the fonts in the list and click OK. 
You do not need to export fonts that are already available in the printer’s 
Fontlib. 

7 Specify the following in the Export dialog: 
! Export as Zip Container: Checked 

This option bundles all the components of a project as single physical 
file.  This makes projects and their resources easily portable. 

! Overwrite: Prompt  
This option prompts you to confirm overwriting any existing files. 

 

For more information on VPC files, also labeled here as the Zip 
Container, see the Introduction chapter of this guide. 
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8 Click Export. 
The document is successfully exported.  The document can now be loaded to 
the VIPP printer for printing. 

 

In order to view the contents of the ZIP container of the exported job, 
right-click on the GS_line.vpc file and change the extension to ZIP.  The 
file can now be opened in WinZip. 

You have completed exporting the Line mode project.  In the next part of the Tour, 
you will import the project you have just exported.   

9 From the menu, choose File>Close. 
The project closes. 

Importing Documents 
Importing documents into Vitesse is almost as simple as opening a document.  This 
section provides instructions for importing documents in Vitesse.   

You will import GS_Line.vpc.  This is the document just exported. 

To import a document, you will: 

! Set Import Preferences 
! Import the document 

Preparing to Import 
You will first set up the Import Preferences.  These choices determine how the 
imported document is read into Vitesse.  These preferences are maintained by the 
system settings, and only need to be set once. 

1 Within Vitesse, choose Tools>Preferences from the menu. 
The Preferences dialog displays.  

2 Select the Import category. 
The Import preferences display. 

3 Set the following options: 
! Text Grouping: Group 

Group enables text merging on similar text objects, and Maximum 
enables text merging for all text objects. 

! Process Elixir Comments: Checked 
This option automatically processes non-VIPP comments.  This option is 
used when importing a previously exported Vitesse document. 
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Setting Import preferences. 

You can also check the Defaults categories to make sure these are set correctly.  
Defaults are used for new and imported resources and projects.   

Typically, VIPP resources and projects contain all the information required to print.  
However, it is possible that certain pieces of information can be missing, such as the 
default font or page size, because that information is available on the printer.  When 
imported VIPP documents or resources do not contain all the necessary information, 
the defaults set in the Preferences dialog are used.  For example, if a VIPP form does 
not contain page size information, the default page size set under Defaults will be 
used when importing the form. 

 

When importing, it is good practice to double-check the defaults in 
Preferences.  Then, if any information is missing in your imported file(s), 
the replacement defaults will be correct. 

Refer to the Configuration chapter to review the Defaults settings. 

4 Click OK to save the new preferences. 
You return to the Vitesse design area. 



 

Chapter 4: A Vitesse Tour 295 

Importing a Document 
You are ready to import a document. 

1 From the menu, choose File>Import. 
The Import dialog displays. 

 
Selecting a file to import. 

2 Browse to drive:\program files\elixir technologies\vitesse\xgf\line. 
3 Select GS_Line.vpc and click Open. 

GS_Line imports and opens in the Vitesse design area. 

 

Vitesse can import hand-coded VIPP applications and Vitesse projects.  
The success of the import varies from project to project.  It is 
recommended that all Vitesse projects be backed up regularly, to 
prevent the necessity of importing previously-created projects. 

You can also import files in all VIPP IDE, VIPP, XEROX, Vitesse, and PostScript 
formats. 
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Saving the Document 
You will now save the imported document under a different name. 

1 From the menu, choose File>Save As. 
The Save As dialog displays. 

 
Saving the imported document under a different name.  

2 Enter JBTStatement in the File Name entry box. 
3 Select the GS_LineLD project. 

All the projects available in the Default folder are available in the drop-down 
list. 

4 Click OK. 
You have saved the imported document in Vitesse format. 

Vitesse can bring in your existing Xerox centralized resources, such as forms (FRMs, 
FSLs), fonts (FNT) and images (LGOs and IMGs), for use in your VIPP applications.  
To import these native resources, select File>Import from the menu and browse to 
locate your resource.   

All imported forms (FRMs or FSLs) become editable upon import in Vitesse.  You 
can then repurpose or reformat these forms and then export them to VIPP form format 
(also FRM, not to be confused with Xerox native format) and reuse the reformatted 
form for VIPP applications.  All references to Xerox font files and images within the 
forms are maintained in the export. 

To import or insert a Xerox native image on a form, use the Insert Image icon in the 
toolbar. 
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You can bring in PostScript forms, or EPS or PS format files in Vitesse.  In order to 
use a PostScript file, use the Insert Segment feature and then select the Existing tab.  
Browse to the location of the PostScript file and click Open to insert the file.  If a 
form is used, make sure that the form refers to the VIPP segment linked with the 
PostScript file. 

 

PostScript files can be inserted as a segment, but cannot be edited in 
Vitesse. 

You have completed the Vitesse Tour.  For more information about specific 
functions, refer to the Vitesse User Guide.  
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User Notes:
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86, 88, 93, 95, 109, 156, 200, 219, 224, 
242, 249, 273 

duplex, 111, 158, 202, 246 
Dynamic Document Construction, 12 
Dynamic text flow, 12 

E 
EFI DFE's, 14 
Elixir Application Suite, 49 
Elixir comments 

generating, 48 
processing, 47 

Elixir resources, 21 
Elixir training, 16 
Elixir website support, 15 
Encapsulated PostScript, 13 
encodings 

default directory paths, 52 
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end same, 173 
environment issues, 59 

display issues, 60 
migrating from VIPP IDE, 59 

EPS, 13 
EVF format, 104 
EVS format, 99 
Excel, 13 
Export category 

Preferences dialog, 48 
Export dialog, 290 
Export Fonts dialog, 292 
exporting, 62 

documents, 286, 290 
preferences, 289 
VPC format, 14 

Extensible Markup Language, 11, 238 

F 
field definition, 206 
fields, 253 

adding 
Database mode, 206, 207 
Line mode, 115, 117, 162, 164 

definition, 115, 162 
delimiters, 196 
justification, 127, 178, 262, 265 
mapped, 124, 172 
properties, 118, 165 
static text, 147, 192, 230, 284 
Strip bounding, 180 
strip bounding blanks, 133 
unmapped, 124, 171 

fixed records, 11 
FNT, 9 

VIPP fonts, 49 
Xerox legacy fonts, 49 

Folder category 
Preferences dialog, 52 

Font map category 
Preferences dialog, 50 

fonts 
barcodes, 53 
BAT, 82 

default settings, 55 
installing, 51 
Legacy font mapping, 49 
mapping, 49, 50 
PostScript, 50 
printing, 49, 50 
properties, 82 
rendering, 49, 50 
styles, 82 
True Types, 50 
VIPP, 50 
display, 13 
installing, 13 
mapping, 12 
PostScript, 12 
supported in Vitesse, 12 
True Types, 12 
VIPP, 12 

Form category 
Directory, 53 

Form dialog, 65 
formatting 

numeric, 57 
string, 57 

Formlib folder, 113, 161, 204, 251 
FormRefs, 205, 253 
forms, 61 

creating, 62, 64 
default directory paths, 52 
EVF format, 104 
Formlib folder, 161, 251 
formRefs, 114, 161 
inserting 

existing forms, 113, 161, 204 
inserting into a project, 251 
inserting segments, 100 
new, 62, 64 
properties, 66 
saving, 89, 103 
definition, 13 
designing, 9 

frames 
adding, 249 
properties, 250 

frequently asked questions, 12 
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FRM, 9 
full installation, 21 

G 
General category 

Preferences dialog, 39 
Show font names in combo box, 39 
Working Folder, 39 

generate Elixir comments, 48 
getting the answers you need, 14 
global resources, 43, 61 
Grids 

displaying, 42 
printing, 46 
setting preferences for, 42 

Gs_dbm.dbf, 199 
Gs_line.lm, 108 
Gs_lineld.evd, 287 
Gs_LogoOnly.jpg, 97 
Gs_prefixed.lm, 155 
Gs_xml.xml, 243 
Gs-contact.rtf, 78 
Gsjbtletter.evf, 205 
Gsjbtreport.evf, 114, 161 
Gsjbtstat.evf, 252 
Gsjbtstatement.evf, 100 
Gsjbtstatement1.evf, 252 
Gs-text.rtf, 224 
guides 

related, 16 
displaying, 41 
setting preferences for, 41 

H 
hardware requirements, 17 
help, 16 

help pop-ups and jumps, 16 
related guides, 16 
release notes, 16 
What's this? help, 16 

I 
images 

adding, 66, 97 
default directory paths, 52 
low resolution for display, 40 
properties, 68, 97 

IMG, 9 
Import category 

Preferences dialog, 47 
Import dialog, 294, 295 
Import Text dialog, 78, 80, 224 
importing 

defaults for, 54 
documents, 293, 295 
forms, 61 
properties, 293 
text, 78 
Xerox resources, 9 

indentation 
text defaults, 55 

Insert Box tool, 69 
Insert Chart tool, 137, 183 
Insert Condition tool, 143, 189, 221, 280 
Insert Data File dialog, 243 
Insert Data File tool, 243 
Insert Field tool, 118, 133, 135, 165, 207, 

211, 214, 229 
Insert Form dialog, 114, 161, 204, 252 
Insert Form tool, 204, 252 
Insert Frame tool, 249 
Insert Image dialog, 67, 97, 226, 227, 235, 

236 
Insert Image tool, 67, 97, 226, 231, 235 
Insert Line tool, 73, 273 
Insert Record tool, 117, 164, 268 
Insert Segment dialog, 270, 271 
Insert Segment tool, 100, 270 
Insert Text tool, 95, 219, 224 
Insert toolbar, 65, 67, 97, 100, 109, 117, 

118, 137, 143, 156, 164, 165, 183, 189, 
200, 204, 206, 207, 211, 213, 214, 221, 
226, 229, 231, 235, 236, 242, 243, 252, 
268, 270, 280 

inserting 
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box, 93 
boxes, 69 
charts, 137, 183 
conditions, 142, 188, 221, 278 
data, 104, 151 
data files, 243 
existing forms, 113, 161, 204, 251 
fields, 206, 207, 253 
frames, 249 
images, 66, 97 
lines, 73 
records, 253 
segments, 100 
text, 78, 81, 95 

Install license, 27 
installation 

custom, 21 
full, 21 
minimum, 21 

installing Vitesse, 18 
InstallShield Wizard Complete dialog, 33 
InstallShield Wizard Complete dialog, 25 
Internet Explorer, 17 
introduction 

Vitesse, 9 

J 
JDTs, 11, 12 

default directory paths, 52 
Job Descriptor Tickets, 11, 12 
Job processing, 13 
JPEG, 13 
justification, 127, 178, 262, 265 

L 
launching Vitesse, 39, 64 
Layout settings 

Preferences dialog, 56 
Legacy 

Data streams, 11 
legacy comments 

processing, 47 
Legacy fonts category 

Preferences dialog, 49 
LGO, 9 
License Agreement dialog, 20 
License Key Selection dialog, 31 
License Wizard 

Registration Complete, 32 
License Wizard dialog 

licensing options, 27 
Line data, 9, 11 
Line mode 

adding data 
using line data file, 104 
using prefixed data file, 151 

creating new document, 105, 152 
Line Mode dialog, 107, 154 
Line mode projects, 10, 104 
Line number, 11 
line spacing, 83, 226 

text defaults, 55 
line style, 71, 74 
line width, 71, 74 
lines 

adding, 73 
color, 275 
copying, 76 
pasting, 76 
properties, 74, 273 
style, 74 
width, 74 

lines per page, 108, 154 
Listing mode, 110, 156 
local resources, 43, 61 
Login information dialog, 27 

M 
Maintenance Complete dialog, 37 
mapping data, 255 

using drag and drop, 123 
mapping fonts, 49, 50 
margins 

default settings, 56 
masks 

defaults, 57 
Media 
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default settings, 56 
Merge Data tool, 219 
Merge Data toolbar, 65, 109, 156, 200, 206, 

219, 242 
Message View window 

displaying, 41 
Message window, 65, 109, 156, 200, 242 
Microsoft Excel, 13 
Microsoft Word, 13 
migrating from VIPP IDE, 59 
minimum installation, 21 
miscellaneous 

default directory paths, 52 
mockups, 61 
Modify, Repair, or Remove the program 

dialog, 34, 36 

N 
Native mode projects, 10 
New Project dialog, 64, 90, 107, 153, 198, 

241, 287 
nodes 

naming, 88 
Non-prefixed data file, 11 
NPS 8.0 systems, 14 
Nudge settings, 42 
numeric masks, 57 

O 
objects 

aligning, 99 
arranging, 98 
copying, 84 

opening 
existing documents, 287 

opening Vitesse, 39 
operating systems, 17 
Operating systems required by Vitesse, 8 
optimizing printing, 66 
orientation 

default settings, 46, 56 
forms, 66 

origin, 92 

P 
page 

properties, 111, 159, 202, 246 
page background color, 42 
page breaks, 248 
page color, 42 
page numbers, 204 
Page numbers, 113, 160, 204, 248, 249 
PageMaker, 13 
paper 

properties, 110, 156, 200, 245 
paper size 

default settings, 46, 56 
paragraph spacing 

text defaults, 55 
passwords, 28 
pasting 

objects, 76 
PC numbers, 28 
PDF 

Bookmarking, 10 
Printing, 12 
Viewing, 12 
VIPP Thin Printer, 10 

positioning 
relative, 173 
using click and drag, 127, 175 

PostNet barcodes, 213 
PostScript, 12 

Differences from VIPP, 12 
Files as Segments, 13 
fonts, 50 
interpreters, 53 
Interpreters, 12 

Preferences dialog, 39, 123, 289, 293 
Barcode category, 53 
Color sub-category, 56 
Data sub-category, 45 
Defaults category, 54 
Designer sub-category, 123, 170 
Designer sub-catgegory, 41 
Export category, 48 
Folder category, 52 
Font map category, 50 



 

306 Vitesse Getting Started Guide 

General category, 39 
Import category, 47 
Layout sub-category, 56 
Legacy fonts category, 49 
Print category, 46 
Regional sub-category, 59 
Source sub-category, 44 
Text sub-category, 55 
Transform sub-category, 57 
Tree view sub-category, 43 
View category, 41 
Workspace category, 41 

prefixed data, 151 
Print category 

Preferences dialog, 46 
print previewing, 61, 102, 237, 284 
printing 

optimizing, 66 
caching resources, 13 
variable data, 12 

Print-ready data, 11 
Process Elixir Comments, 47 
Process Legacy Comments, 47 
processing 

conditional, 12 
program folders, 23 
project modes, 61 

closing, 286 
database mode, 61 
inserting forms, 113, 161, 204, 251 
line mode, 61 
native mode, 61 
saving, 115, 162, 206, 253 
XML mode, 61 
Database, 11 
Database mode, 10 
Line, 11 
Line mode, 10 
Native, 10, 13 
Native mode, 10 
XML, 11 
XML mode, 10 

Project Tree window, 65, 109, 156, 200, 242 
projects 

Database mode, 196 

default directory paths, 52 
proofing with Vitesse, 61 
properties 

barcodes, 214 
boxes, 70 
charts, 137, 183 
conditions, 144, 189, 222, 280 
exporting, 289 
fields, 118, 165, 207 
fonts, 82 
forms, 66 
frames, 250 
images, 68, 97 
importing, 293 
lines, 74, 273 
page, 111, 159, 202, 246 
paper, 110, 156, 200, 245 
records, 118, 164, 269 
segments, 92 
segRefs, 101 
text, 79, 96 

Property View window, 65, 109, 156, 200, 
242 

R 
radius settings, 94 
Ram requirements, 17 
record definition, 206 
record IDs. See prefixed data 
records, 253 

adding 
Line mode, 115, 117, 162, 164 

database records, 196 
definition, 115, 162, 254 
properties, 118, 164, 269 
repeat value, 118 
Delimited, 11 
Fixed, 11 
Variable length, 11 

Regional settings 
Preferences dialog, 59 

registering Vitesse, 26 
registration 

Deactivate license, 27 
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downloading a product license, 27 
Run password registratin process, 19 
selecting a license source, 31 
View license information, 27 

Registration Completed dialog, 29, 32 
related guides, 16 
relative positioning, 173 

absolute, 67, 79, 80, 81, 83, 84, 85, 
86, 87, 88, 96, 101, 126, 129, 131, 
132, 133, 135, 137, 165, 173, 174, 
176, 177, 178, 179, 180, 207, 211, 
214, 217, 219, 225, 227, 229, 235, 
236, 283 

end same, 126, 173 
start next, 131, 132, 134, 212, 214, 

261, 264 
start same, 83, 84, 85, 86, 87, 88, 131, 

132, 134, 211, 212, 229, 235, 236, 
261, 264, 283 

release notes, 16 
render fonts, 49, 50 
repairing Vitesse, 33 
repeating records, 118 
requirements 

hardware, 17 
software, 17 
system, 17 

resources 
caching, 66, 92 
default directory paths, 52 
Elixir, 21, 49 
fonts, 49 
forms, 61, 62, 64 
scope, 43 
segments, 61, 89 
Xerox, 296 
Finished, 7 
FNT, 9 
Fonts, 12 
Forms, 12, 13 
FRM, 9 
Images, 9, 12, 13 
IMG, 9 
LGO, 9 
Pre-rasterization, 13 

Segments, 10, 13 
Text, 9 

RGB color model, 71, 75, 76, 94, 147, 192, 
232, 235, 275, 283 

RIP, 12, 13 
rounded boxes, 94 
RPE key, 164 
RTF files, 78, 224 
run password registration process, 26 

S 
sample data files, 61 
Save As dialog, 103, 296 
saving 

documents, 296 
forms, 89, 103 
projects, 115, 162, 206, 253 
segments, 99 

Screen resolution requirements, 17 
SEG format, 99 
Segment dialog, 91 
segments, 61 

caching, 92 
creating, 89 
default directory paths, 52 
EVS format, 99 
inserting in a form, 100 
origin, 92 
properties, 92 
saving, 99 
SEG format, 99 
SegRefs, 101, 271 
Definition, 13 
PostScript files as, 13 

segRefs 
properties, 101 

SegRefs, 271 
Select Program Folder dialog, 23 
Select the type of Installation dialog, 20 
selecting a license source, 31 
Send to Back tool, 98, 232, 236 
setting properties 

barcodes, 214 
boxes, 70 
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charts, 137, 183 
conditions, 144, 189, 222, 280 
exporting, 289 
fields, 118, 165, 207 
fonts, 82 
forms, 66 
frames, 250 
images, 68, 97 
importing, 293 
lines, 74, 273 
page, 111, 159, 202, 246 
paper, 110, 156, 200, 245 
records, 118, 164, 269 
segments, 92 
segRefs, 101 
text, 79, 96 

Setup Status dialog, 24, 34, 37 
shared resources, 43, 61 
Show/Hide Data window tool, 206 
Show/Hide Data View window tool, 116, 

163 
simplex, 110, 111, 157, 158, 201, 202, 245, 

246 
snap to grid, 122, 169 

setting preferences for, 42 
Snap to Grid tool, 132, 179, 232 
software requirements, 17 

Internet Explorer, 17 
Windows 2000 service pack, 17 
Windows XP service pack, 17 

source code 
Revert to Last State, 149, 194 
viewing, 149, 194 
Editing, 9 

source settings 
Preferences dialog, 44 

Source View window, 149, 194 
spacing, 83, 226 

text defaults, 55 
variable, 118, 164 

spell checker 
text defaults, 55 

Splitting PDFs, 10 
Standard toolbar, 89, 99, 115, 147, 192, 206, 

238, 253, 284, 286 

Start Copying Files dialog, 23 
start tags, 268 
starting 

forms, 62, 64 
segments, 89 

static fields, 147, 192, 230, 284 
status bar, 116, 163, 206 

displaying, 41 
storing applications 

default path, 39 
string masks, 57 
strip bounding blanks, 133 
Super nudge settings, 42 
support 

customer, 14 
Elixir website, 15 

supported operating systems, 17 
Switch Panel 

displaying, 43 
symbols used in this guide, 9 
system requirements, 17 

T 
tabs 

text defaults, 55 
tags 

Bounding, 11 
XML, 11 

text 
adding, 78, 81, 95 
alignment default settings, 55 
default settings, 55 
dimensions, 84 
fonts default settings, 55 
grouping options, 47 
importing, 78 
importing RTF files, 224 
indentation default settings, 55 
justification, 84 
merging with data, 219 
objects, copying, 84 
pasting, 84 
properties, 79, 96 
spacing, 83 
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spacing default settings, 55 
spell checker default settings, 55 
tabs default settings, 55 
dynamic, 12 

Thin Printer, 12 
VIPP, 10 

TIFF, 13 
toolbars 

Alignment, 65, 109, 156, 200, 242 
Alignment toolbar, 99 
Arrangement, 65, 98, 109, 156, 200, 

232, 242 
Data, 245 
displaying, 41 
Drawing, 65, 69, 73, 78, 79, 81, 83, 

86, 88, 93, 95, 109, 156, 200, 219, 
224, 242, 249, 273 

Insert, 65, 67, 97, 100, 109, 117, 118, 
137, 143, 156, 164, 165, 183, 189, 
200, 204, 207, 211, 214, 221, 229, 
231, 235, 236, 242, 243, 252, 268, 
270, 280 

Insert toolbar, 214, 221 
Merge Data, 65, 109, 156, 200, 206, 

219, 242 
Standard, 89, 99, 115, 147, 192, 206, 

238, 253, 284, 286 
Status, 162 
View, 65, 109, 156, 200, 242 
Zoom, 65, 109, 156, 200, 242 

tools 
Align Horizontally tool, 99 
Align Vertically tool, 99 
Combined Form, 245 
Compile, 149, 194 
displaying, 43 
Insert Box, 69 
Insert Chart, 137, 183 
Insert Condition, 143, 189, 221, 280 
Insert Data File, 243 
Insert Field, 118, 207, 211, 229 
Insert Form, 204, 252 
Insert Frame, 249 
Insert Image, 97, 226, 231 
Insert Line, 73, 273 

Insert Record, 117, 164, 268 
Insert Segment, 100, 270 
Insert Text, 95, 219, 224 
Merge Data, 219 
Send to Back, 98, 232 
Show/Hide Data View window, 116, 

206 
Snap to Grid, 132, 179, 232 

transactional documents, 104, 151 
Transform settings, 214 

Preferences dialog, 57 
Tree view settings 

Preferences dialog, 43 
True Type fonts, 12 
Tumble duplex, 158, 246 
Type 1 fonts, 12 
Type 3 fonts, 12 
typographic conventions, 8 

U 
understanding 

application, 62 
VIPP modes, 10 

uninstalling Vitesse, 35 
unit of measurements, 42 
using 

snap to grid, 122 

V 
values 

XML, 11 
variable data, 219, 253 

Printing, 12 
Variable Data Intelligent Postscript 

Printware. See VIPP 
variable length data file, 196 
variable length records, 11 
variable spacing, 118, 164 
variable-data Intelligent PostScript 

Printware. See VIPP 
View category 

Messages window, 41 
Preferences dialog, 41 
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status bar, 41 
toolbars, 41 

view license information, 27 
View toolbar, 65, 109, 156, 200, 242 
viewing 

data files, 243 
source code, 149, 194 

VIPP, 7 
caching resources, 66 
Caching resources, 13 
differences from traditional 

PostScript, 12 
Font names, 12 
fonts, 50 
forms, 61 
Hand-coded applications, 9 
migrating from VIPP IDE, 59 
Printers, 12 
Project modes, 10 
Projects, 14 
segments, 61 
Thin Printer, 12 
What is VIPP, 12 

VIPP modes 
understanding, 10 

VIPP Project Container. See VPC 
VIPP Thin Printer, 10 
Vitesse 

design area, 65, 109, 156, 200, 242 
Editing JDTs, 11 
Fonts supported, 12 
installation, 18 
interface, 65, 109, 156, 200, 242 
introduction, 9 
Message window, 65, 109, 156, 200, 

242 
opening, 39, 64 
Project Tree window, 65, 109, 156, 

200, 242 
proofing, 61 
Property View window, 65, 109, 156, 

200, 242 
registering, 26 
repairing, 33 
uninstalling, 35 

Vitesse Wizard 
remove Vitesse 

Confirm Uninstall, 36 
VPC, 13, 14, 290 

W 
What’s in this guide, 7 
What’s this? help, 16 
Who should use this guide, 7 
Windows 

2000, 17 
XP, 17 

Windows 2000, 8 
Windows NT, 8 
working folder, 65, 91 
Workspace category 

Preferences dialog, 41 

X 
Xerox, 12 

forms, 61 
Xerox Generic Format. See XGF 
Xerox resources, 296 

Importing, 9 
XGF, 12 
XML 

Attributes, 11 
Bounding Tags, 11 
Tags, 11 
Values, 11 

XML data files, 11, 238 
XML mode 

adding data, 238 
new document, 239 

XML Mode dialog, 241, 242 
XML mode projects, 10, 61, 238, 242, 286 

Data view, 243 
page breaks, 248 

Z 
ZIP container, 14 
Zoom toolbar, 65, 109, 156, 200, 242 
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