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1 Introduction

This chapter provides an introduction to Elixir’s AppBuilder for VIPP (Variable
Data Intelligent PrintWare), describes the contents of this user guide and the
installation process, as well as how to start and exit AppBuilder for VIPP.

APPBUILDER FOR VIPP

Elixir AppBuilder for VIPP is a WYSIWYG tool that gives Xerox VIPP users the
ability to create single page documents and Job Descriptor Tickets (JDTs) using
Xerox’s VIPP format. JDTs are Xerox printer resources that allow you to place
variable data in exact locations on a form, and to specify data attributes such as
font size, field color and print direction.

JDTs work with a data file to produce a document on any PostScript device
(printer, viewer or FAX) that has Xerox’s VIPP software installed. The data stream
can contain callouts to PostScript printer resources (forms, fonts, logos) and to
Xerox resources (JDTs), or the resources can be embedded in the data stream. A
VIPP interpreter processes the data stream to produce a document.

CUSTOMER SUPPORT

Xerox Customer Support Centers provide technical assistance for Elixir users dur-
ing normal business hours.

If you have any problems running or using AppBuilder for VIPP or associated
Elixir applications, you can call the Xerox customer support center in your area.
Before calling, please have the following information available:

• your name, organization, telephone number, and address

• the name and version number of the Elixir application
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• a complete description of the problem, including any error messages displayed
on your monitor or printed on your printer
A central administrator will answer your call, assign you a log number, and
direct you to the appropriate product specialist.

Elixir Web site support

The Elixir Web site at http://www.elixir.com offers the following resources:

• Find answers in the list of Frequently Asked Questions

• Review the latest Tips and Techniques for increasing productivity using Elixir
software

• Download new releases and the latest patches

• View Release Notes for the latest available features

• Learn in the user newsgroup how others are using Elixir products

• Sign up for an Elixir Learning Program

ELIXIR TRAINING

Elixir Technologies Corporation offers training for the full-range of Windows-based
products.  For more information, contact:

Elixir Learning
(805) 641-5900 x 6

WHO SHOULD USE THIS GUIDE

This guide is intended for users familiar with Microsoft Windows, Elixir Desktop
and Elixir Forms Editor; and Xerox printing resources. Users should have access
to Xerox’s Xerox Generic Format Reference Manual. See the on-line documenta-
tion for more detailed information on the procedures described in this document.

HARDWARE AND SOFTWARE REQUIREMENTS

The following section describes hardware and software requirements for running
AppBuilder for VIPP.
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Hardware

Minimum PC hardware: 80486 (or 100% compatible) PC/AT or IBM PS/2; 16MB
RAM; 200+ MB hard drive, 3.5 inch 1.44 MB internal diskette drive, LPT1 parallel
port.

Recommended PC hardware: Pentium (or 100% compatible) with 90 Mhz pro-
cessor; 32 MB RAM; 500+ MB hard drive, 3.5 inch 1.44 MB internal diskette drive,
CD-ROM drive, LPT1 parallel port.

Additional requirements:  

• Any monitor with driver software supporting Windows in VGA or SVGA.

• Any Windows-compatible mouse

Optional requirements:

HP LaserJet II or compatible PCL printer(s)

Software:

Software requirements:  Microsoft Windows 95 or Windows NT version 4.0 or
later.

ElixiKey

Your software comes with an ElixiKey, a parallel port key connector.  This is a
hardware enabler which you connect to the LPT1 parallel port of your PC.  It does
not affect the performance of any devices connected to your PC*. Your supplied
ElixiKey must be connected to enable installation and to save files.

If you have another device currently connected to the parallel port, unplug it, con-
nect your ElixiKey to the port, then connect the device to the ElixiKey.  ElixiKey
operates transparently with other devices connected to it.

If you are running other Elixir applications, connect all ElixiKeys together and con-
nect the assembly to the LPT1 port.

*CAUTION:   ElixiKeys may not be completely transparent when using PC-to-PC
file transfer utilities which use a parallel port interface (such as LapLink).  If you
are using a parallel port PC file transfer package, first disconnect any ElixiKeys.
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CONVENTIONS

This section describes the following:

• display conventions

• typographical conventions

Display conventions

AppBuilder for VIPP follows Microsoft Windows conventions for using menus,
menu commands, dialog boxes, command buttons, icons and a mouse.  See your
Windows manual for more information. 

Typographical conventions

The following typographic conventions are used throughout this guide: 

• Keystrokes are enclosed in <  > (angle brackets).

For example, <Enter>.

• Key combinations are denoted by a plus sign between keys.

For example, <Shift> + <F1> indicates to simultaneously press the <Shift> and
the <F1> keys. 

• Selecting a command series (a sequence of menus and options) is denoted by
“>” (the greater than sign) between the actions.

For example: Select File>Form>Load Form  indicates to pull down the File
menu, select the Form  sub-menu and then select the [Load Form] option.

• Outside of a command series, menu and sub-menu titles are depicted in bold,
and menu options are enclosed in [ ] (square brackets).

For example: The File  menu contains the [Save] and [Save as] options.

• Outside of a command series, dialog box fields are shown in italics, and dialog
box options are enclosed in [ ] (square brackets).

For example: The Grid Setting dialog box Snap Mouse Speed field contains
[Slow], [Moderate] and [Fast] options.

• Command and option buttons that you press are also enclosed in [ ] (square
brackets).

For example: Click on [OK] or [Cancel]. Click on the [Browse] button.
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• Steps in a procedure are shown in numbered bold paragraphs.

For example: 

1. Click on [OK] in the Main Setup dialog box.

Comments relating to a step (such as this paragraph) are shown in regular text
following the bold paragraph.

• Commands, options, actions, and parameters that require description are
shown in bold followed on the next line by the description. For example,

Image Compression
Compresses images in the output data stream.

• Commands you enter at the DOS prompt are shown in larger text. Within DOS
commands, variable data is shown in italics. 

For example: COPY <filename> drive:\ELIXIR <Enter> 

ON-LINE HELP

The Help  menu, <F1> key and all [Help] buttons in dialog boxes are for future
implementation.

ORGANIZATION OF THIS GUIDE

This user guide contains the following chapters:

Chapter 1, "Introduction," provides an introduction to Elixir’s AppBuilder for VIPP,
describes the contents of this user guide and explains the installation process, as
well as how to start and exit AppBuilder for VIPP.

Chapter 2, “AppBuilder for VIPP tutorial”, walks you through the steps required to
create a single VIPP Job Descriptor Ticket (JDT) file.

Chapter 3, "AppBuilder for VIPP basics", provides an overview of the features you
can access from AppBuilder for VIPP's main screen, as well as the basic opera-
tions for creating a document.

Chapter 4, "Toolbar”, gives detailed descriptions of the Toolbar and its options.

Chapter 5, “Toolbox”, provides detailed descriptions of the Toolbox tools and
options.
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Chapter 6, "AppBuilder for VIPP menu bar", provides information on AppBuilder
for VIPP's main menus and sub-menus, and the options they contain. The Data
File and ElixirViewer windows and their features are also documented.

Chapter 7, "Work area menu bar", cover the Work area menu bar's menus and
sub-menus, and the options they contain.

Chapters 8 through 11, “Lines”, "Shapes", "Text operations", and "Images", are
reference sections that describe in detail how to create and edit form elements.

Chapter 12, "Document window", provides a detailed description of the Document
window and its features.

Chapter 13, "Media window", gives a detailed description of the Media window
and its features.

Chapter 14, "Auxiliary dialog boxes”, furnishes detailed descriptions of all of App-
Builder for VIPP’s sub-dialog boxes.

Chapter 15, “How to...”, describes how to perform various operations in App-
Builder for VIPP.

INSTALLING APPBUILDER FOR VIPP

Installation of AppBuilder is a simple, interactive procedure that should take
approximately five minutes. To quit installation at any time, press <Esc>. 

To install AppBuilder for VIPP:

1. Insert the CD-ROM into your CD-ROM drive.

The Elixir Installer - Welcome dialog box displays.

2. Click on [Next].

The Elixir Installer - Programs dialog box displays.

3. Select [Elixir AppBuilder for AFP], then click on [Next] .

The Elixir Installer dialog box displays to confirm your selection.

4. Select [Install] to proceed with the installation, then click on [OK] to
reconfirm.

The Release Notes dialog box displays.

5. Select [Yes] to read the Release Notes now or select [No] to read them at
a later time, then click on [OK]. 

The Release Notes are written to drive:\ELIXIR\RELNOTES.  After installation
you can open the Release Notes by selecting [Release Notes] from the Help
menu.
1-6 Elixir AppBuilder for VIPP



Go To

TOC
The Install Type dialog box displays.

6. Select [Default] to install all files in default directories, [Custom] to install
the program and data files in specified directories, or [Network] to select
whether to install program, data, and/or configuration files.

7. Select a destination drive (C:\ is recommended), then click on [OK].

The Make Backups dialog box displays.

8. Select [Yes] to create backups of all files the installation replaces, or [No]
to overwrite the existing files.

The Program Selector dialog box displays.

9. Select [AppBuilder for AFP] to install the main program, and [Elixir Desk-
top] to install an Elixir Desktop with basic conversion capability.

The Monitor Setup dialog box displays with the resolution of your system
detected during installation.

10.Select the screen font resolution for your system, then click on [OK].

A PDF Documentation dialog box displays asking if you want to install on-line
documentation in PDF format.

11.Select [Yes] to install PDF files in the drive :\ELIXIR\HELP\PDF directory,
or [No] to not install the files.

Installation begins.

Files are copied to your hard disk and the Registration Information dialog box
displays.

12.Enter your name and company name in the Registration Information dia-
log box, then click on [OK].

The Finished Installation dialog box displays.

CHECKING INSTALLATION

You can verify that AppBuilder is installed by clicking on the [Start] button in the
Taskbar, selecting [Programs] and then [Elixir Applications] (or other name if you
changed the default).  An Elixir AppBuilder for VIPP shortcut should display in this
folder.

The Elixir AppBuilder for VIPP icon also displays in the Elixir Desktop.
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STARTING APPBUILDER FOR VIPP

Depending on your operating system, you can start AppBuilder as follows:

• In Windows 3.11, in the Elixir Applications program group in Program Man-
ager, double-click on the Elixir AppBuilder for VIPP icon.

• In Windows 95 or Windows NT, click on the [Start] button, then select Pro-
grams>Elixir Applications>Elixir AppBuilder for VIPP.

• In any operating system, from the Elixir Desktop (if installed), double-click on
the Elixir AppBuilder for VIPP icon, or double-click on an Elixir PageDef or
FormDef resource file in the Jobs folder, Elixir Data Jobs or Elixir Document
Jobs folders.

The AppBuilder window displays.

EXITING APPBUILDER FOR VIPP

To exit AppBuilder for VIPP:

• press <Alt> + <F4>

• select File>Exit

• double-click on the [Close] button (the top left corner of the screen)
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2 AppBuilder for VIPP tutorial

This chapter walks you through the steps required to create a single VIPP Job
Descriptor Ticket (JDT) file using Elixir’s AppBuilder for VIPP. Using an Elixir-sup-
plied form, you will learn to:

• Create the Document

• Define the physical sheet of paper

• Use a form as a data mapping template

• Define the JDT

• Define data

• Copy-and-paste existing definitions

• Map data to a form by:

- Drag-and-drop positioning

- Manual positioning - entering X and Y coordinates

• Define and modify data

• Define a Record Criteria Definition

• Convert the design to a JDT

The form used in this tutorial is provided and located in drive:
\ELIXIR\FORMS\ELIXIR\DEMO\EXAM3US.ELX.

CREATING THE DOCUMENT

1. Start AppBuilder for VIPP.

2. Select File>Document>New Document.

The Document Properties dialog box displays.
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3. Enter the following information, then click on [OK]:

• Document Name - “Sample Applications”

• Document Description - “Elixir Getting Started Designs”

The Document and Media windows display at the bottom of the Work area.

DEFINING THE PHYSICAL SHEET OF PAPER

1. Right-click on the Ruler icon in the main Toolbar.

The Ruler Options dialog box displays.

2. Select [Dots] in the Ruler measure  field, then click on [OK].

3. Right-click on NewMedia in the Media tree in the Media window.

The Media Properties dialog box displays.

4. Enter the following information, then click on [OK]:

• Media name - “Sample Applications”

• Media Description - “Elixir Getting Started Designs”

The new Media displays in the Media tree.

5. Right-click on NewPaper#1 in the Media tree.

The Paper Properties dialog box displays.

6. Select/enter the following options, then click on [OK]:

• Paper Name - “US Letter”

• Width - “2550”

• Height - “3300”

• Presentation - [Landscape]

• Duplex Printing - [Long side]

US Letter displays under Sample Applications in the Media tree.
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USING THE FORM AS A DATA MAPPING TEMPLATE

1. Select NewSheet#1 in the Media tree.

2. Click on [Add Form] (the icon to the right of [+S]) in the Media Toolbar.

The Add Form dialog box displays.

3. Click on the [Select] button.

The Select Form dialog box displays.

4. Select EXAM3US.ELX and click on [OK] until all dialog boxes close.

EXAM3US.ELX displays in the Media tree under NewSheet#1.

5. Select Options>AppBuilder Preferences in the Work area menu bar.

The Preferences dialog box displays.

6. Select the following options, then click on [OK]:

• Active Form Color - [Blue]

• Inactive Form Color - [Gray]

The form displays in the Work area in the selected (display-only) colors.

7. Select Window>Tile.

The Media window redisplays.

DEFINING THE JDT

1. Click on [+P] in the Document window Toolbar.

A new Page displays in the Document tree. This Page corresponds to a single
JDT definition.

You can add multiple Pages to a single AppBuilder for VIPP Document. When
JDT conversion occurs, each Page becomes a separate JDT file.

2. Right-click on NewPage#1 in the Document tree in the Document win-
dow.

The Page Properties dialog box displays.

3. Enter the following information:

• Page name - “Example 3 JDT”

• Short name - “EXAMPLE3”

• Description - “Example 3: Sales report using RPE mode”
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4. Select Use paper dimension  and click on the [Select] button.

The List of Papers dialog box displays.

5. Select [US Letter] in the Paper Names  field, then click on [OK] until all
dialog boxes close.

The Paper defined earlier is now linked to the current Page definition and the
dimensions of the selected Paper display in the Logical Page Dimension field.

The Logical Page Offset and Logical Page Dimension fields correspond to the
VIPP SETMARGIN command.

DEFINING DATA

1. Click on [+R] in the Document window Toolbar.

A new Record displays in the Document tree.

2. Right-click on NewRecord#1 in the Document tree.

The Record Properties dialog box displays.

3. Enter “Record1” in the Record name  field.

4. Select [Line Printer] in the Record Type  field, then click on [OK].

Record1 displays in the Document tree.

5. Click on [+F] in the Document window Toolbar.

A new Field displays in the Document tree.

6. Right-click on NewField#1.

The Field Properties dialog box displays.

7. Select/enter the following information, then click on the [Font] button:

• Field name - “R1/Field1”

• Offset - “0”

• Length - “99”

• Alignment/Align - [Center]

The Font List dialog box displays.

8. Click on the [ATM] button.

The Select ATM Font dialog box displays.

Note:  If ATM fonts are not installed on your machine, the Face Name field is
empty. In this case, close the Select ATM Font dialog box and perform steps 8-
9 by selecting [True Type].
2-4 Elixir AppBuilder for VIPP



Go To

TOC
9. Select the following options, then click on [OK]:

• Face Name - [Helvetica], for TrueType [Arial]

• Size - [18]

The Font List dialog box redisplays.

10.Select /enter the following information, then click on the [Add] button:

• Style - [Bold]

• User name - “F4”

The defined font is added to the List of used Fonts field and is available for
future use.

11.Click on [OK] until all dialog boxes close.

The Field definition is added to Record1.

COPYING-AND-PASTING EXISTING DEFINITIONS

1. Select Record1 in the Document tree.

2. Select Edit>Copy in the Document window menu bar.

The Record and its associated Field definition copy to the Windows Clipboard.

3. Select Edit>Paste Record in the Document window menu bar.

4. Repeat step #3 two more times.

MAPPING DATA TO A FORM

There are two ways to map data to a Form:

• Drag-and-drop positioning

• Manual positioning - entering X and Y coordinates

Drag-and-drop positioning
1. Select the first R1/Field1 and hold down the mouse button.

2. Drag the Field to the upper left corner of the Form (approximate coordi-
nates are X=750, Y=280), center it in the empty box, and release the
mouse button.

The Field maps to the Form and displays in the Work area. The X, Y coordi-
nates display in the [Digital Ruler] in the Work area Toolbar.
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Manual positioning - entering X and Y coordinates
1. Select the second added Record and right-click.

The Record Properties dialog box displays.

2. Change the Record name  to “Record2”, then click on [OK].

3. Double-click on Record2.

The Record expands to show all related Fields.

4. Select R1/Field1 in the Document tree, then right-click.

The Field Properties dialog box displays.

5. Change the Field name  to “R2/Field1”, then click on the [Font] button.

The Font List dialog box displays.

6. Click on the [ATM] button (or the [TrueType] button if you have no ATM
fonts).

The Select ATM Font (or Select TrueType Font) dialog box displays.

7. Select the following options, then click on [OK]:

• Style - [Bold]

• Face Name - [Helvetica], for TrueType [Arial]

• Size - [13]

The Font List dialog box redisplays.

8. Change the User name  to “F1”, then click on the [Add] button.

9. Click on [OK].

The Field Properties dialog box redisplays.

10.Select/enter the following information:

• Color - [White]

• Position/Horizontal - “550”

• Position/Vertical - “510”

11.Select Is Mapped  and click on [OK].

The Field displays in the specified location on the Form.
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DEFINING AND MODIFYING DATA (CONTINUED)

1. Select the third added Record and repeat steps 2-11(manual positioning)
with the following changes:

• Record name - “Record3-8”

• Repeat - “6” - specifies that the next six Records occurring in the data
will use the same formatting.

• Field name - “R3-8/Field1”

Skip steps 6-8 since the referenced font was defined earlier.

• List of used fonts - “F1”

• Displacement/Horizontal - “318” - setting a horizontal displacement
value offsets each successive Record by the amount specified in the
previous Record.

2. Select R3-8/Field1 in the Document tree and hold down the mouse but-
ton.

3. Drag the Field to the Form and drop it into the first solid box to the right
of R2/Field1 (approximate coordinates are X=1125, Y=510).

Fields for the repeated Records are positioned automatically at the specified
displacement.

4. Right-click on R3-8/Field1.

The Field Properties dialog box displays.

5. Select [White] in the Color field, then click on [OK].

6. Select the fourth added Record and make the following changes:

• Record name - “Record9”

• Repeat - “1”

7. Select the attached Field, change the Field name  to “R9/Total” and add a
new font with the following properties to the Font List:

• Style - [Bold]

• Face Name - [Helvetica], for TrueType [Arial]

• Size - [14]

• User name - “F5”

8. Drag the Field to the Form and drop it into the last solid box to the right
of the previous Fields (approximate coordinates are X=3045, Y=510).

9. Right-click on R9/Total.

The Field Properties dialog box displays.
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10.Select [White] in the Color  field, then click on [OK].

11.Select Record9 in the Document tree and click on [+R].

A new Record displays in the Document tree.

12.Select the new Record and make the following changes:

• Record name - “Record10-35”

• Repeat - “25”

13.Select Record10-35 and click on [+F].

A new Field displays in the Document tree.

14.Select the new Field and make the following changes:

• Field name - “Product Division”

• Offset - “0”

• Length - “34”

• Alignment/Align - [Left]

• Displacement/Vertical - “75”

This value is the vertical offset for this Field in each new Record as the data is
processed.

15.Add a new font with the following properties to the Font List:

• Style - [Bold]

• Face Name - [Helvetica], for TrueType [Arial]

• Size - [15], for TrueType [12]

• User name - “F2”

16.Drag the Field to the Form and drop it into the upper left corner of the
large solid box under the R2/Field1 column heading (approximate coordi-
nates are X=150, Y=630).

The repeated Fields display in the Work area under Product Division, with
every two lines alternating shaded/unshaded.
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DEFINING A RECORD CRITERIA DEFINITION

1. Select the Product Division Field and click on [Add new condition] in the
Document window Toolbar (the icon to the right of [+F]).

A new Condition displays in the Document tree.

2. Right-click on the new Condition.

The Field Condition dialog box displays.

3. Select/enter the following information, then click on the [Font] button:

• Name - “Total”

• Short name - “CND1” - this is the Record Criteria Definition identifier
that will be placed in the SETRCD and FROMLINE statements in the
JDT file.

• Start - “0”

• Length - “5”

• Comparison test operators - [==]

• Comparison String - “TOTAL”

The Condition - Font dialog box displays.

4. Select the Font  field, then click on the [ATM] button (or the [TrueType]
button if you have no ATM fonts).

The Select ATM Font (or Select TrueType Font) dialog box displays.

5. Select the following options, then click on [OK]:

• Style - [Bold]

• Face Name - [Helvetica], for TrueType [Arial]

• Size - [18]

The Condition-Font dialog box redisplays.

6. Enter “F2t” in the User name  field, then click on the [Add] button.

The Field prints in this font when the defined Condition is TRUE.

7. Click on [OK] until all dialog boxes close.

8. Add seven new Fields under the Product Division Field.

9. Right-click on the first added Field.

The Field Properties dialog box displays.

10.Click on the [Sample Text] button.

The Text dialog box displays.
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11.Enter “111111.111” in the Text  field, then click on [OK].

12.Modify all seven Fields using the following settings:

* For font "F3", use Helvetica 16 point bold or TrueType Arial 14 point bold.

13.Map each Field to the Work area, with one Field per column, starting in
the column under R3-8/Field4.

The vertical position is the same as that specified for Product Division.

CONVERTING THE DESIGN TO A JDT

1. Select File>Document>Save Document in the main menu bar.

The Document is saved under “Sample Applications”.

2. Select File>Convert>Export JDT.

The Export JDT dialog box displays.

3. Enter the following information, then click on [OK]:

• Output File name - “Exam3”

• Form Extension - “FRM”

AppBuilder for VIPP converts your design to a JDT and writes the file to
drive:\ELIXIR\JOBS\VIPOUT\.

4. Copy the JDT file to the drive :\directory that your printer uses.

5. Copy EXAM3US.FRM to the drive :\directory that your printer uses.

6. Print drive :\ELIXIR\PRNSYS\DATAIN\EXAMPLE3.LM to your VIPP printer.

Field # Field 
name

Offset Length Align-
ment

Disp. - V Font Sample 
Text

1 France 28 10 Right 75 F2 11111.111

2 UK 38 11 Right 75 F2 22222.222

3 Germany 49 11 Right 75 F2 33333.333

4 Spain 60 11 Right 75 F2 44444.444

5 Italy 71 11 Right 75 F2 55555.555

6 Belgium 82 10 Right 75 F2 66666.666

7 Total 92 11 Right 75 F3* 77777.777
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See your Xerox Generic Format Reference Manual for more information on
steps 4-6.
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3 AppBuilder for VIPP basics

This chapter provides an overview of the features you can access from App-
Builder for VIPP's main screen and describes the basic operations for creating a
document.

APPBUILDER FOR VIPP WINDOW

To view the AppBuilder for VIPP main screen, start the program as described in
the “Introduction” chapter or double-click on the Elixir AppBuilder for VIPP icon on
the Elixir Desktop (if installed).

The AppBuilder for VIPP window displays and contains, from right to left, top to
bottom:

• AppBuilder for VIPP menu bar

• Message area

• Toolbox

• Work area menu bar

• Toolbar

• Work area

• Document window*

• Media window*

* These windows may or may not display upon initial opening.
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CREATING FORMS

A form created with AppBuilder for VIPP is the static (or boiler plate) component of
a print job and contains elements such as lines, boxes, text, and images. App-
Builder for VIPP allows you to see each static form element as you add or revise
the element.

This section provides information which may be helpful when designing your form.
See the "Adding form elements" section for information on form elements.

Designing new forms

Sketching the form on paper before drawing it on the screen makes placing the
elements easier. 

Reproducing an existing form 

If you are reproducing an existing form, have the form in front of you as you are
designing it on the screen.  Use a ruler to measure the margins, lines and other
elements of the form, then use the on-screen rulers to get an exact placement of
each element.

Elixir’s ElixirScan product can also be used to scan your existing form into an edit-
able format that can be directly imported in to AppBuilder for VIPP. See the Elixir-
Scan User Guide for more information.

LOADING FORMS

You can only edit one form at a time. Loading a form closes any open Media win-
dow and all displaying overlays.

Loading a new form <F9 >

To load a new form:

1. Select File>Form>New form.

The Form Properties dialog box displays.

2. Select form defaults, then click on [OK].

The Form Databasing dialog box displays.

3. Enter information for the new form (optional), then click on [OK]. 

The new form is loaded in the Work area.
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Loading a saved form <F8 >

To load a previously saved form:

1. Select File>Form>Load form.

The Load Form dialog box displays.

2. Select the form you want to load, then click on [OK].

The form is loaded into the Work area.

If the image referenced in a form is missing, a replacement image displays.  If you
want to delete the image from the form, select the replacement image and press
<Del>.

Loading GEM forms  

If you are using forms that were created in a version of ElixirForm prior to version
3.00, you can select to maintain the original boxed text formatting or use the new
Windows method of box text formatting.  You can also select to maintain the origi-
nal color mode or select a new color mode.

Select the text formatting and color mode options for all subsequently loaded
GEM forms using the Text formatting Compatibility and Color Mode fields in the
GEM Forms Load Defaults dialog box.

Select the text formatting and color mode options for the currently loaded GEM
form only using the Text formatting Compatibility field in the Text and Font Options
dialog box and the Color Mode field in the Page Properties dialog box.

Loading a form template

A form template is a form that is loaded as an overlay or visual guide only for the
purpose of designing new form elements around it.  A form template does not
become a part of the form when the form is saved; only the new elements are
saved with the form.

You can load more than one form file template into the Work area; however,
retrieving multiple form templates uses more memory which may be significant if
your templates contain large images.

Proof printing a form that includes one or more templates also prints the tem-
plates. If you want to proof print a form without the templates, save and reload the
form without the templates, then proof print the reloaded form.
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To load a form template:

1. Select File>Form Group>Load form Template. 

The Load Form Template dialog box displays. 

2. Select the template you want to use, then click on [OK]. 

You can also double-click on the template name.

3. Design a new form using the template as a guide.

SELECTING TEMPLATE DEFAULTS

To select form template defaults:

1. Select [Template Options] from the Options menu.

The Template Options dialog box displays.

2. Select display defaults, then click on [OK].

The Template Options dialog box contains the following options:

Color
Select a display color for the template from the drop-down list.

Object Filters
Select an option to display its associated object in the template, or deselect the
option to hide the associated object.

Disable template object selection
Prevents form template objects from being selected or modified.

Lock template
Keeps the current template loaded at all times.

USING COLOR

Color can be applied to any part of a form.  However, your printer must support
color printing to print in color.

To select the color mode:

1. Select Options>Form Properties.

The Form Properties dialog box displays.

2. Select [Full Color], then click on [OK].
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ADDING FORM ELEMENTS

Forms are created using lines, paths, boxes, circles, text and images - collectively
called form elements.  You can easily apply different attributes and properties to
any element by selecting Toolbox options.  Elements can be placed anywhere on
the form, creating a unique form to fit your needs.

To modify an existing element, right-click on the element and apply new properties
by selecting Toolbox options.  See the "Toolbox" chapter for more information on
individual tools and their options.

See the "Lines", "Shapes", "Text operations" and "Images" chapters for detailed
information on adding and modifying elements.

SELECTING FORM ELEMENTS

To perform an action on a form element, you must first select it.

To select an element:

1. Select the Select tool in the Toolbox.

2. Place the cursor on the element you want to edit and right-click.

The screen pointer changes to a hand. If it does not, the element may be too
small.  If this happens, press and hold the <Ctrl> key as you move the cursor
over the element.

Boxes appear around the element to show it is selected.

To select multiple form elements:

1. Select the Select tool in the Toolbox.

2. Hold down <Shift>, place the cursor on the elements you want to edit and
click.

Boxes appear around the elements to show they are selected.

EDITING FORM ELEMENTS

You can edit individual elements as often as necessary.  This includes moving,
copying, and deleting elements, as well as changing element properties.

See the "Lines", "Shapes", "Text operations" and "Images" chapters for detailed
information on editing elements.
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Shifting form elements

You can shift all or selected elements on a form.  It is easier to see elements shift
when the grid is displayed.

To shift form elements, hold down the <Ctrl> key and use the arrow keys to shift
the elements up, down, left, or right.  You can also use the direction keys (without
the <Ctrl> key) on the numeric keypad if <Num Lock> is engaged.

Only selected elements shift.

CREATING FORM GROUPS

You can group form elements together for editing. A group is two or more ele-
ments. Once a group is defined, you can edit it as if it were a single form element.

If you want to undo a group command, operations are undone one element at a
time. For example, if you delete a form group and then select Toolbar>Undo, the
elements in the group display again, one at a time.

Defining form groups

To define a form group:

1. Select the Select tool in the Toolbox.

2. Move the screen pointer to the elements to be grouped. 

3. Click and drag the dotted line that displays until it encloses all of the ele-
ments you want in the group. 

Boxes appear around or inside each element in the group.  Grouped text
appears in square brackets.

4. Release the mouse button.

You can now move, copy or delete the group as if it were a single element.

Excluding elements from a form group

To exclude all occurrences of an element or any one element from a form group,
<Shift>-click on the element after grouping. To include the element again, <Shift>-
click on the element again.
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EDITING FORM GROUPS

To change the properties of grouped elements, right-click on an element in the
group. The Toolbox for the element type displays, and you can apply new proper-
ties to all like elements in the group.

See the "Lines", "Shapes", "Text operations" and "Images" chapters for detailed
information on editing elements.

MERGING FORM GROUPS

You can load a form into the Work area without replacing the contents of the Work
area. This allows you to save portions of a form, such as standard form headers
and footers, and use these form pieces as part of a new form. See the "Saving
form groups” section in this chapter for information about saving a form group.

To merge a form group:

1. Select File>Form Group>Merge form Group.

 The Load form dialog box displays.

2. Select the form you want to merge, then click on [OK].

Although you can merge the currently loaded form with the same form, this is
not recommended as form elements may overlap.

Objects that fit within the form boundaries are the only ones that can be merged.
Since this operation can not be undone, make sure that enough space is available
in the Work area so that form elements do not fall outside the form boundaries or
overlap one another. 

SAVING FORM GROUPS

You can define a group in an existing form and save it as a form file. You can then
retrieve the file for editing or use it as a form template. 

This feature is useful when standard elements (for example, headers and footers)
are used on several forms. You can also use it to merge parts of one form with
parts of another form. See the "Merging a form group" section for more informa-
tion.

To save a form group:

1. Define the group as described in the “Defining a form group” section.
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2. Select File>Form Group>Save Form Group.

The Save Form Group dialog box displays.

3. Enter a file name, then click on [OK].

The form group is saved in the specified forms directory.

SAVING FORMS

To save your work automatically, select the Autosave field in the Usage Switches
dialog box.

To save a form:

1. Select File>Form>Save Form As. 

The Save Form As dialog box displays. 

2. Enter a form name (no extension) and click on [OK]. 

If you plan to convert your form to other formats you should save the form with
a maximum six-letter file name. Longer file names are truncated upon conver-
sion and could result in overwriting existing files.

After you save a form, you can use <Ctrl> + <S> to quickly save your work.

DELETING FORMS

To delete a form:

1. Select File>Form>Delete Form.

The Delete Form dialog box displays.

2. Select the name of the form to delete, then click on [OK].

The form is deleted.

RENAMING OR MOVING FORMS

To rename or move a form:

1. Select File>Form>Rename/Move Form.

The Rename/Move Form dialog box displays.
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2. Select the form you want to rename or move, then click on [OK].

The Rename/Move Form dialog box displays the directory and name of the
form.

3. Enter a new directory to move the file or enter a new file name to rename
the file, then click on [OK].

The form must have an .ELX extension if you want to load it into ElixiForm.

The file is moved or renamed as specified.

PRINTING FORMS

To print a form:

1. Select File>Print>Using Print Driver. 

The Print dialog box displays.

2. Select printing options, then click on [OK].

Printing a disk print file

To print a form that has been written to disk:

1. Exit AppBuilder for VIPP and go to the DOS prompt.

2. Enter the directory of the print file.

3. Use the DOS COPY command to copy the .PRN file to your active parallel
port (for example, LPT1).

For example:

COPY filename.PRN LPT1 <Enter>

where filename is the stem name of the disk file.

4. Use the COPY/B command when printing HP PCL files from disk.
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USING THE ELIXIR HP PRINT DRIVER

You can use the Elixir HP Driver for optimal proof printing of Elixir forms.  The ben-
efits of using this driver are:

• increased proof-printing speed

• ability to print light, medium and dark shaded boxes using HP printer shading
calls

• support of storing a form as a macro

• ability to call printer resident fonts

• produces files requiring substantially less disk space.

To use the Elixir HP print driver:

1. Select and drag the file to the Printers icon.

The Print dialog box displays.

2. Select [Elixir HP Driver] and click on [Setup].

The Elixir HP Driver dialog box displays.

The Elixir HP Driver dialog box contains the following options.

Printer Type
Select the type of HP LaserJet printer (II, III, or 4).

Printer Port
Select [LPT1], [LPT2], or [LPT3].

Output Mode
Select [Use PCL commands] or [Use rasterization].  The rasterization option
allows you to print some embedded objects (such as circles and paths) that
HP PCL may ignore, or print other objects in their place.

Font Substitution Tables
Select [No] to use printer-resident fonts, or [Selected] to enable the [Fonts]
button and select a font table file from the Select Font Table dialog box.  The
font table name displays in the [Selected Table] option.

User defined shading patterns
Select [No] to use standard shading patterns, or [Selected] to enable the
[Shading] button and select a pattern file from the Select Shading Table dialog
box.  The shading table name displays in the [Selected Table] option.

Inverse Fonts
Select [No] to use standard fonts, or [Selected] to enable the [Inverse] button
and select an inverse font table file from the Select Inversion Table dialog box.
The inverse font table name displays in the [Selected Table] option.
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Create as Macro/Macro ID number
Select, then enter a value in [Macro ID number] to store your form on the
printer for future use.

3. After you select your options, click on [OK].

4. To print the file, click on [OK] in the Print dialog box.
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4 Toolbar

This chapter provides a detailed description of the Toolbar and its options. The
Toolbar displays across the top of the Work area and contains the following
options:

DIGITAL RULER

Displays the horizontal and vertical position of the screen pointer relative to the
top left corner of the screen (0,0).

CURRENT OBJECT - SHAPE

Displays the icon that represents the type of element the cursor is currently clos-
est to.

CURRENT OBJECT - START COORDINATES

Displays the x,y coordinates of the currently selected element.

CURRENT OBJECT - DIMENSIONS

Displays the width and height of the currently selected element.
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GRAPHIC RULER <F3>

To display the graphic ruler along the top and left edges of your Work area:

• select Toolbar>Ruler

• press <F3>

• select View>Ruler

A check mark appears next to the option in the menu when it is selected.  Select
this option a second time to remove the graphic ruler.

Right-click on the Ruler in the Toolbar to display the Ruler Options dialog box:

Ruler measure
Select the unit of measure for display: [Inches], [CM], [MM], [Dots], or
[Points].  Your selection sets the global measurement units used for both
form and Document (JDT) design.

Ruler color
Select the color of the ruler: [Light Gray], [Dark Gray], or [Green].

Graphic ruler
Displays the graphic ruler along the top and left-hand edge of the Work
area.

Digital ruler
Displays the position of the screen pointer relative to the top left corner of
the Work area (0,0).

in Grid Units
Select this field to have the corresponding ruler reflect the grid unit values
specified in the Grid Setting dialog box.

GRID DISPLAY <F4>

The Grid helps you place and align form and data elements accurately.  It displays
on the screen, but does not print.

To display the grid in your Work area:

• select Toolbar>Grid Display

• press <F4>

• select View>Grid

A check mark appears next to the option in the menu when it is selected.  Select
this option a second time to remove the grid.
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Right-click on the [Grid Display] icon in the Toolbar to display the Grid Setting dia-
log box:

Grid units
Enter the number of grid units displayed per unit of measure.  The default
setting is 10 x 6 grid units per inch.

Grid step
Enter a grid step value to define the distance between grid points.

Grid units and Grid step units of measure are defined by your selection in
the Ruler measure field.  The size of the grid units or grid step dimensions
you enter above are maintained even though the value may change
based upon the current unit of measure.

You can enter grid dimensions using either the Grid units or Grid step
fields, but not both.

Ruler measure
Select the unit of measure for display: [Inches], [CM], [MM], [Dots], or
[Points].  Your selection also changes the Ruler measure field in the Ruler
Options and Form Properties dialog boxes.

Graphic Ruler in Grid Units
Select this field to have the graphic ruler reflect the values specified in
Grid units.

For example, if [Grid units] is set to 8.00 per 1 inch for the horizontal set-
ting and 6.00 per 1 inch for the vertical setting, the horizontal graphic ruler
displays 8 divisions (grid units) per inch and the vertical graphic ruler dis-
plays 6 divisions (grid units) per inch.  

Digital Ruler in Grid Units
Select this field to have the digital ruler reflect the values specified in Grid
units.

See the Graphic Ruler in Grid Units field for an example.

Grid Snap to
Select a snap to option:

• Full Grid - form elements snap to grid points

• Half Grid - form elements snap to points halfway between grid points.

In both instances, all elements resize to fit the grid.

Grid Color
Select the grid color: [Black], [Dark Shade], or [Green].

Snap mouse speed
Select the snap speed for the mouse: [Slow], [Moderate], or [Fast].
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Show Grid <F4>
Displays the grid in the Work area.  Select this field a second time to
remove the grid.

Snap to Grid
Select this field to have form elements snap to full grid or half grid points.

SNAP TO GRID <F5>

To place elements accurately on the grid:

• select Toolbar>Snap to Grid

• press <F5>

• select Options >Snap to Grid

Select this option a second time to disable this feature - elements become free
floating and are moveable anywhere on the screen.

LONG CROSSHAIR <F6>

The long crosshair displays horizontally and vertically from the cursor on the form,
and helps you place elements on the form more precisely.

To display the long crosshair:

• select Toolbar>Long Crosshair

• press <F6>

• select View>Long Crosshair

A check mark appears next to the option in the menu when it is selected.  Select
this option a second time to remove the long crosshair.

ZOOM IN/OUT

To zoom in on (magnify) an area of the form, click on the [+] button on the right
side of the Zoom icon in the Toolbar.  The highest magnification is [8x].

To zoom out on (reduce the magnification of) the Work area, click on the [-] button
on the left side of the Zoom icon in the Toolbar.  The lowest reduction is [-8x].

You can also use the <+> and <-> keys on the numeric keyboard to zoom in and
out.
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UNDO/REDO

To cancel your most recent operation:

• select Toolbar>Undo

• press <Ctrl> + <Z>

• select Edit >Undo

To cancel your most recent Undo operation:

• select Toolbar>Redo

• press <Shift> + <Ctrl> + <Z>

• select Edit >Redo

SPELL CHECK

Select this option to check the spelling in the active form. Data elements are not
spell checked. See the "Text operations" chapter for more information on spell
checking.

SHOW/HIDE TOOLBOX

Select this option to hide the Toolbox.

To redisplay the Toolbox:

• select this option a second time

• press <F10>

• select Window >Toolbox

SHOW/HIDE DOCUMENT

Displays Document (data) information in the Work area.  Select this option a sec-
ond time to hide the data layer.
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SHOW/HIDE MEDIA

Displays Media (form) information in the Work area.  Select this option a second
time to hide the form layer.

EDIT DOCUMENT

Select this option to edit the Document (data) layer.

Select this option a second time or immediately select Edit >Undo to exclude the
Document layer from editing.  This locks the data in position and allows you to
modify form elements without disturbing the data.

EDIT MEDIA

Select this option to edit the Media (form) layer.

Select this option a second time to exclude the Media layer from editing.  This
locks the form objects in position and allows you to modify the data without dis-
turbing the form objects.
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5. Toolbox

This chapter provides detailed descriptions of the Toolbox tools and options. The
Toolbox displays to the left of the Work area and contains the following tools:

• Select tool

• Line tool

• Path tool

• Box tool

• Circle tool

• Text tool

• Image tool

• Page tool

• Record tool

• Field tool

Select a tool to display the options for that tool in the Toolbox.  A short description
of the tool displays in the Message panel, and the Preview panel displays your
option selections.

SELECT TOOL

The Select toolbox allows you to select form or data elements for editing.

Copy

Copies form elements or data elements to the Windows Clipboard.

Select the option a second time to turn it off.

See the "Lines", "Shapes" and "Text operations" and “Images” chapters for more
information on copying elements.
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Delete

Deletes the selected element(s).  When a data element is deleted, it is only
removed from the Work area - the Document window entry is preserved.

If you inadvertently delete an element, immediately select Edit>Undo or click on
Undo in the Toolbar to restore the deleted element.

Group filter options

The Group Filter options from left to right are: [Line], [Path], [Box], [Circle], [Text],
[Data tag], [Image], and [Field].

Select one or more options to exclude the corresponding element from group
options such as moving or deleting.  Select the option(s) a second time to turn the
filter off. See the "AppBuilder For VIPP basics" chapter for information on group-
ing elements.

Copy Count

Specify the number of copies you want to create by clicking on the up or down
arrows, or click in the numeric display box and enter a number.

<Ctrl>-click to increase/decrease the value by 10.

Movement Selection

Select a movement direction for moving or copying elements:

• [Horizontal only] - cursor moves horizontally with element(s) attached

• [Vertical only] - cursor moves vertically with element(s) attached

• [Free] - cursor moves in any direction with element(s) attached

Copy Distance

Specify the horizontal and vertical distance between copies of an element by
clicking on the up or down arrows, or click in the numeric display box and enter a
number.

<Ctrl>-click to increase/decrease the value by 10.

Select the option(s) a second time to turn it off. 

Sticky Lines

Enables lines that connect or lines that touch boxes to remain attached when you
move the element the line is attached to.
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Select the option(s) a second time to turn it off. 

See the "Lines" chapter for more information on sticky lines.

LINE TOOL

The Line toolbox allows you to draw horizontal, vertical, and free lines; and spec-
ify line properties. See the "Lines" chapter for more information on the options
described below.

Line Direction

Select the direction of the line you want to draw: [Horizontal only], [Vertical only],
[Horizontal and Vertical], or [Free].

Line Width

Specify a value (in dots) by clicking on the up or down arrows or click in the
numeric display box and enter a value (maximum 99 dots).

You can also select: standard [Thin] 2 dot, [Medium] 4 dot, or [Thick] 6 dot line
widths.

Line Style

Select the line style: [Solid], [Dashed], or [Dotted].

Line Color

(Highlight color) Select a box border color from the palette in the Color dialog box
that displays and click on the [Close] button.  The selected color displays in the
bottom half of the icon.

PATH TOOL

The Path toolbox allows you to draw paths and specify path properties. See the
"Shapes" chapter for more information on the options described below.
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Path Shape

Select a path shape:

• [Open] - path remains open

• [Closed] - path automatically closes when you finish drawing the path

Path Direction

Select a path direction:

• [Snapped] - lines drawn snap to horizontal and vertical lines

• [Free] - lines drawn run in any direction

Path Beginning and End Styles

Select line beginning and end styles: [Square], [Round], or [Mitered].

Border Width

Specify a value (in dots) by clicking on the up or down arrows or click in the
numeric display box and enter a value (maximum 99 dots).

You can also select: [Thin], [Medium], or [Thick] border widths.

Border Style

Select a border style: [Dotted], [Dashed], or [Solid].

Draw/Done Mode

When you click in the Work area to add a path, you are in Draw mode.  When you
complete a path, select this option, double-click in the Work area or right-click in
the Work area to toggle to Done mode.  You can then draw another path or switch
to another drawing tool.

Path Color

(Highlight color/Full color) Select a path border color from the palette in the Color
dialog box that displays and click on the [Close] button.  The selected path color
displays in the bottom half of the icon.
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Path Fill Color

(Full color) Right-click to select a path fill color from the palette in the Color dialog
box that displays and click on the [Close] button.  The selected path fill color dis-
plays in the bottom half of the icon.

Path Pattern/Shading

(Black-and-white, Highlight color, Full color) Select a shade pattern from the Pat-
tern dialog box that displays. This pattern applies each time you draw a new
closed path, until you change it using the same procedure.  Select the Hollow pat-
tern for no shading.

Path Connection Radius

Specify the value of the path connection radius (in pels) by clicking on the up or
down arrows, or click in the numeric display box and enter a value (maximum 299
pels).

You can also select: [Small] 10 pels, [Medium] 20 pels, [Large] 30 pels, [Square],
[Radius Half], or [Radius Maximum].

BOX TOOL

The Box toolbox allows you to draw boxes and specify box properties. See the
"Shapes" chapter for more information on the options described below.

Box Corner Style

Select the box corner style: [Square], [Rounded], [Rounded on the top], [Rounded
on the bottom], [Rounded on the left], or [Rounded on the right ].

Box Positioning

Select the top half of this option to center the top left corner of the box on grid
coordinates or select the bottom half of the option to snap the top left corner of the
box flush to grid coordinates.

Box Shape

Select the top half of this option to draw boxes as rectangles. Select the bottom
half of this option to draw boxes as squares.
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Box Diagonals

Select the diagonal line pattern for inside the box: [None], [Left], [Right], or [Both].

Box Line Width

Specify a value (in dots) by clicking on the up or down arrows or click in the
numeric display box and enter a value (maximum 99 dots).  Specify [0] to apply an
invisible border to a shaded box.  Unshaded boxes must have a border width of
[1] or higher.

You can also select: [Thin], [Medium], or [Thick] box line widths.

Box Line Style

Select the style for the [Box Lines] type: [Solid], [Dashed], or [Dotted].

Box Lines

Select a width and style option:

• [Border Lines] - sets the width and style of the box border

• [Horizontal Lines] - sets the width and style of the horizontal box splits

• [Vertical Lines] - sets the width and style of the vertical box splits

The [Horizontal Lines] and [Vertical Lines] options are used when you apply box
splits using the [Box Splits] option.

Box Splits - Horizontal/Vertical

Select the [Horizontal Splits] or [Vertical Splits] option to divide a box horizontally
or vertically into equal portions. Specify the number of portions by clicking on the
up or down arrows.

You can also select the [Box Splits] option and enter the number of portions in the
numeric display box next to each option.  The minimum value is 1 (hollow) and the
maximum value is 40.

Box Color

(Highlight color, Full color) Select a box border color from the palette in the Color
dialog box that displays and click on the [Close] button.  The selected box color
displays in the bottom half of the icon.
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Box Fill Color

(Full color) Right-click to select a box fill color from the palette in the Color dialog
box that displays and click on the [Close] button.  The selected box fill color dis-
plays in the bottom half of the icon.

Box Pattern/Shading

(Black-and-white, Highlight color, Full color) Select a shade pattern from the Pat-
tern dialog box that displays. All boxes you draw contain this shading until you
change it, using the same procedure.  Select the Hollow pattern for no shading.

Box Corner Radius

Specify a value by clicking on the up or down arrows or click in the numeric dis-
play box and enter a value (maximum 299 pels).

You can also select: [Small] 10 pels, [Medium] 20 pels, [Large] 30 pels, or [Maxi-
mum].

The [Corner Radius] option does not apply when all corner styles are 90 degrees.

CIRCLE TOOL

The Circle toolbox allows you to draw circles and specify circle properties. See the
"Shapes" chapter for more information on the options described below.

Circle Radius

Select one or more of the four circle quarters to compose a circle or partial circle.
Select a quarter a second time to deselect it.

Circle Drawing Method

Select the top half of this option to draw a circle from its center outward, where the
anchor point is the circle center.

Select the bottom half of this option to draw a circle within an unseen box, where
the anchor point is the box corner nearest the starting point. This method allows
you be more precisely place the circle in relation to another element.
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Circle Diagonals

Select the diagonal line pattern for inside the circle: [None], [Left], [Right], or
[Both].

Only 360-degree circles display diagonals. 

Circle Border Width

Specify a value (in dots) by clicking on the up or down arrows or click in the
numeric display box and enter a value (maximum 99 dots).  Specify [0] to apply an
invisible border to a shaded circle.  Unshaded circles must have a border width of
[1] or higher.

You can also select: [Thin], [Medium], or [Thick] border widths.

Circle Border Style

Select the circle line style: [Solid], [Dashed], or [Dotted].

Circle Start and Finish Angle

Specify a value by clicking on the up or down arrows or click in the numeric dis-
play box and enter a value (in degrees) for where you want your circle to begin
and end.

You can also select: [0], [90], [180], or [270] degrees.

Circle Color

(Highlight color, Full color) Select a circle border color from the palette in the Color
dialog box that displays and click on the [Close] button.  The selected circle color
displays in the bottom half of the icon.

Circle Fill Color

(Full color) Right-click to select a circle fill color from the palette in the Color dialog
box that displays and click on the [Close] button.  The selected circle fill color dis-
plays in the bottom half of the icon.

Circle Pattern/Shading

(Black-and-white, Highlight color, Full color) Select a shade pattern from the Pat-
tern dialog box that displays. All circles you draw contain this shading until you
change it, using the same procedure.  Select the Hollow pattern for no shading.
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Circle Printing

Specify the way that dotted or dashed circles print.

TEXT TOOL

The Text toolbox allows you to specify text attributes for form elements. See the
"Text operations" chapter for more information on the options described below.

Text Direction

Select a text display direction:

• [Across] - left to right

• [Down] - top to bottom

• [Back] - right to left

• [Up] - bottom to top

Inter-character/Inter-word Spacing

Select a display spacing option:

• [Inter-character] - justifies all text blocks by increasing or decreasing the
amount of space between characters

• [Inter-word] - justifies all text blocks by increasing or decreasing the amount of
space between words; reduces the complexity of your form - the form prints
faster

The [Inter-character] and [Inter-word] options are global features.  Once you
select an option for one text block, it is applied to all text blocks throughout the
form.

Wrap Text

Wraps text between the boundaries set in the {Column Width] option. You can
also select the [Box Text] option to draw a visual box on your form to contain the
text.  Select this option when text is justified.

Remove Redundant Spaces

Removes redundant spaces, relative shifts and carriage returns from wrapped
text blocks.
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Split Text

Splits a single block of text into two separate text blocks.

Text Justification

Specify the justification for each text block: [Left Justification], [Center Justifica-
tion], [Right Justification], or [Full Justification].

The [Wrap Text] and [Boxed Text] or [Column Width] options must be selected for
text justification.

Text Positioning

When the [Wrap Text] and [Box Text] options are selected, you can specify the
vertical positioning of a text block: [Top], [Center], or [Bottom].

Use this option with the [Text Justification] and [Box Text] options to place text
within the box.

Vertical Text Spacing

Specify a vertical lines per inch (LPI) value by clicking on the up or down arrows or
click in the numeric display box and enter a number. <Ctrl>-click to increase/
decrease the value by 1.0.  This value affects the current block of text and any
subsequent blocks of text entered using the same font.

To return the lines per inch to the default for the current font, use the down arrow
to decrease the LPI value to [0] or press <Del>.

Text Color

(Highlight color/Full color) Select a text color from the palette that displays in the
Color dialog box and click on the [Close] button.  The selected text displays in the
bottom half of the icon.

Data Tags

Displays the Data Tagging dialog box which allows you to add data tags to forms
for use with Elixir's DocuTag or DataMerge products. See your Elixir DocuTag
User Guide or Elixir DataMerge User Guide for more information on creating data
tags and tag lists.
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Column Width and Height

Specify the width and height for a text block by clicking on the up or down arrows
or click in the numeric display boxes and enter a number. <Ctrl>-click to increase/
decrease the value by 1.0.  Values that exceed the form limits are not accepted.

You must select the [Wrap text] option when using these options.  When these
options are set to [0.00], text entered is bound only by the width and height of the
form.

Select the [Box Text] option along with these options to display a visual guide box
with the width and height dimensions you specify.

Draw Text Box

Select this option after selecting the [Box Text] option to define column boundaries
for text by drawing a visual box in the Work area.  Place the cursor in the Work
area and press and hold down the mouse button.  Drag the box that displays and
release the mouse button at the bottom right of the box.  This box does not print.

Select the [Wrap Text] option to wrap text at the boundary of the text box defined
by this option.  Select the [Text Positioning] option to position text within the text
box.

Box Text

Select this option when using the [Draw Text Box] or [Column Width] and [Column
Height] options to enter text in predefined areas or "boxes."  Box boundaries are
defined by entering values in the [Column Width] and [Column Height] options or
by drawing a box manually using the [Draw Text Box] option.

Deselect this option to enter free text which is bound only by the width and height
of the form.

Font Type

Click on this button until the desired font type displays:

• [f] - Elixir-version fonts

• [T] - True Type fonts

• [a] - ATM fonts
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Add/Remove Font

Select a font action. The dialog box that displays depends on your selection in the
[Font Type] option.

• [+] - displays the Add Fonts, Select True Type fonts, or Select ATM fonts dialog
box. Select a font(s) to add it to the current Font List, then click on [OK] or the
[ADD] button

You can select either Elixir-generic fonts (.HDR) or screen fonts (.FNT) when
loading Elixir fonts by selecting .HDR or .FNT from the drop-down list in the
Add Fonts dialog box.

• [-] - displays the Replace font, Select True Type fonts, or Select ATM fonts dia-
log box. Select a font(s) to remove it from the current Font List, then click on
the [DEL] button.  If the font is in use on the form, you are prompted to select a
replacement font from the Replace Font dialog box.

Load Font List/Merge Font List/Save Font List

Select a Font List action:

• [down arrow] - displays the Load Font List dialog box

• [double arrows] - displays the Merge Font List dialog box; add fonts to the cur-
rent Font List by loading another Font List

• [up arrow] - displays the Save Font List dialog box; enter a new file name for
the current font list, or rename an existing font list

Soft Keyboard

This option allows you to enter characters that are not available on a standard
keyboard.  See the "Text operations" chapter for more information on using the
soft keyboard.

Font Preview Panel

Displays the fonts available in the current Font List.  Click on the up or down arrow
or use the scroll bar to scroll through the list to change the current font.

Fonts in use on a form are denoted by a diamond character to the left of the font
name.
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IMAGE TOOL

The Image toolbox allows you to add Elixir-format images (.LP3, .LW8) or bitmaps
(.BMP) to a form. The screen version of an image has a .LW8 extension, while the
printer version of an image has an .LP3 extension. See the "Images" chapter for
more information on the options described below.

Image Name

Displays the name of the selected image.

Image Size
Horizontal/Vertical

Displays the horizontal and vertical sizes of the image in the units selected in the
Graphic Ruler in the Toolbar.

Image Color

(Highlight color/Full color) Select an image border color from the palette in the
Color dialog box that displays and click on the [Close] button.  The selected image
color displays in the bottom half of the icon.

Image Fill Color

(Full color) Right-click to select an image fill color from the palette in the Color dia-
log box that displays and click on the [Close] button.  The selected image fill color
displays in the bottom half of the icon.

Load Image

Select an image to add to your form from the Load Image dialog box that displays.

PAGE TOOL

The Page toolbox allows you to set Page defaults for individual Page (JDT) defini-
tions. The Page tool can also be used to define the outline of a new Page by mov-
ing the cursor to the Work area and dragging the box to the desired size.

Page properties

Select Page defaults in the Page Properties dialog box that display.
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RECORD TOOL

The Record toolbox allows you to set Record properties.

Record Properties

Select Record defaults in the Record Properties dialog box that displays. The
Record name displays to the left of the Properties button in the Toolbox. 

Repeat

Enter the number of times to repeat the current Record (and its Fields) in the
associated Page. Specify a value by clicking on the up or down arrows or click in
the numeric display box and enter a number. The VIPP processor reads succes-
sive data Records (up to the number specified) and applies the same formatting to
each one when Repeat is specified.

Record formatting defaults are set in the Record Properties dialog box. 

Linespacing

Displays the number of lines per inch for text placement.  Specify a value by click-
ing on the up or down arrows or click in the numeric display box and enter a num-
ber.

Hide Record

Hides the selected Record and its related Fields in the Work area. X’s display in
the Document window next to the hidden objects.

Select this option a second time to redisplay the Record and its related objects.

FIELD TOOL

The Field tool allows you to set Field properties.

Field Properties

Select Field defaults in the Field Properties dialog box that displays. The Field
name displays to the left of the Properties button in the Toolbox.
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Field Direction

Select the print direction for the Field, relative to the upper left hand corner of the
Page:

• [Across] - Field rotates 0o; characters added from left to right; lines added from
top to bottom

• [Down] - Field rotates 270o counter-clockwise; characters added from top to
bottom; lines added from right to left

• [Back] - Field rotates 180o counter-clockwise; characters added from right to
left; lines added from bottom to top

• [Up] - Field rotates 90o counter-clockwise; characters added from bottom to
top; lines added from left to right

Offset

Specify the offset (from the start of the Record) for the Field’s starting byte by
clicking on the up or down arrows or click in the numeric display box and enter a
value.

Length

Specify the number of bytes to process, beginning with the Field's starting byte, by
clicking on the up or down arrows or click in the numeric display box and enter a
value.

Hide Field

Hides the selected Field in the Work area. X’s display in the Document window
next to hidden Fields. Fields must be mapped to a Sheet before they can be hid-
den.

Select this option a second time to redisplay the Field.

Font

Select a font in the Font List dialog box that displays. A sample of the selected
font displays in the adjacent message area.

Color

Select a Field display color from the Rotation, Color dialog box that displays. The
selected color displays in the Color icon.
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6 AppBuilder for VIPP menu bar

This chapter provides information on the AppBuilder for VIPP menu bar and its
sub-menus.

The AppBuilder for VIPP menu bar contains the File , System , Window , and Help
menus. Select a menu or sub-menu to display its options, then select an option
from the pull-down menu.

FILE MENU

The File menu contains the following options:

Document

The Document  sub-menu contains the following options:

NEW DOCUMENT

Select Document defaults in the Document Properties dialog box that displays.

LOAD DOCUMENT

Select an existing Document to open in the Load Document dialog box that dis-
plays.

File display options for the Load Document dialog box are set in the Show Docu-
ment with Status field:

• [All] - displays all existing Documents, regardless of status

• [Test] - only displays Documents with TEST status

• [Production] - only displays Documents with PRODUCTION status
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SAVE DOCUMENT

Saves the current Document under its original name specified in the Document
Properties dialog box.

SAVE DOCUMENT AS

Enter a new name and Document ID number to save the open Document under in
the Save Document dialog box that displays.

SAVE NEW VERSION

Saves the current Document under the next consecutive version number with a
different Document ID number.

RELEASE

Set the date when the current Document changes to PRODUCTION status in the
Release Document dialog box that displays. Once the date is set, the Document
is saved to the database and that version of the Document cannot be edited.

UNLOAD DOCUMENT

Closes the current Document without saving any changes.

DELETE DOCUMENT

Deletes the Document selected in the Delete Document dialog box that displays
from the AppBuilder for VIPP database.

Media

The Media  sub-menu contains the following options:

NEW MEDIA

Select Media defaults in the Media Properties dialog box that displays.

LOAD MEDIA 

Select an existing Media to open in the Load Media dialog box that displays.

SAVE MEDIA

Saves the current Media under its original name specified in the Media Properties
dialog box .
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SAVE MEDIA AS

Enter a new name and Media ID number to save the open Media under in the
Media Properties dialog box that displays.

DELETE MEDIA

Deletes the Media selected in the Delete Media dialog box that displays from the
AppBuilder for VIPP database.

Databasing

This options in this sub-menu allow you to import or export a Document and/or
Media as a backup or archived copy. Exporting creates a new set of database files
under the selected subdirectory.  Multiple Documents and Media can be exported
to the backup/archived database.

The Databasing  sub-menu contains the following options:

IMPORT DOCUMENT

Select the subdirectory containing the desired database files in the Select Data-
base Path dialog box that displays.

IMPORT MEDIA

Select the subdirectory containing the desired database files in the Select Data-
base Path dialog box that displays.

EXPORT DOCUMENT

Select the path for the Document to be exported to in the Select Database Path
dialog box that displays.

If a set of database files does not exist in the target subdirectory, AppBuilder for
VIPP creates them for you.

EXPORT MEDIA

Select the path for the Media to be exported to in the Select Database Path dialog
box that displays.

If a set of database files does not exist in the target subdirectory, AppBuilder for
VIPP creates them for you.
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PACK

Select the database file to save with deleted Records removed in the Select Files
to Pack dialog box that displays. This option reduces the selected database’s
size.

Convert

The Convert  sub-menu contains the following options:

EXPORT VIPP

Select conversion defaults in the Export VIPP dialog box that displays. This option
converts the currently loaded Document design to JDT format.

Options in this dialog may or may not display, depending on other selections.

Job Descriptor Ticket
Creates a JDT from the design.

Use RPE Prefix
Writes SETRPEPREFIX statements into the JDT. This field must be
selected if [Prefixed] is selected for the Record Info/Record Type field in
the Record Properties dialog box.

Prefix length
Enter the length of the largest RPE prefix.

Database Masters
For future implementation.

Support %%DocumentMedia
Writes a %%DocumentMedia statement into the JDT.

Use PCC
Writes a SETPCC statement into the JDT.

PCC
Enter the name of the Printer Carriage Control (PCC) table to reference in
the Use PCC field.

Font Mapping File
Enter the path for the font mapping table used for JDT conversion or
select one from the Font Mapping File dialog box that displays from the
[Select] button. The default table is \ELIXIR\PSSTASH\VIPFONT.MAP.

Output File name
Enter a name (6 characters maximum) for the JDT. If there are multiple
Pages in the Document tree, each one converts to a single JDT file, with
sequential numbers added to the file name.
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For example, if there are four Pages in the Document tree and “ELIXIR” is
entered as the output file name for the first Page, it is renamed ELIXIR01.
The next three Pages are then name ELIXIR02, ELIXIR03, and ELIXIR04
respectively.

Form Extension
Enter the file extension (3 characters maximum) for the SETFORM state-
ments.

Form

The Form sub-menu contains the following options:

NEW FORM <F9>

Select form defaults in the Form Properties dialog box that displays.

LOAD FORM <F8>

Select an existing form to open in the Load Form dialog box that displays.

SAVE FORM <CTRL> + <S>

Saves your open form under its original file name specified in the Form Properties
dialog box.

For a form being saved for the first time, this option displays the Save Form dialog
box.

SAVE FORM AS <F7>

Enter a new file name to save the open form under in the Save Form As dialog
box that displays.

RENAME/MOVE FORM

Rename and/or change the path of an existing form in the Rename/Move Form
dialog box that displays.

DELETE FORM

Select a form to delete in the Delete Form dialog box that displays.
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Form Group

The Form Group  sub-menu contains the following options:

MERGE FORM GROUP

Select a group to add into the current form in the Load Form Group dialog box that
displays. See the "AppBuilder for VIPP basics" chapter for more information on
form groups.

SAVE FORM GROUP

Select a group on an existing form to save as a form file in the Save Form Group
dialog box that displays.

LOAD FORM TEMPLATE

Select a form template to load onto the current form in the Load Form Template
dialog box that display.  The template is only a visual guide for designing new form
elements around.  It does not become part of the form when the form is saved.

Proof printing a form that includes one or more templates also prints the tem-
plates. If you want to proof print a form without the templates, save and reload the
form without the templates, then proof print the reloaded form.

REMOVE FORM TEMPLATE

Removes all templates from the current form.

Import Text

Select the file containing the text to be imported in the Import Text dialog box that
displays. See the "Text operations" chapter for more information.
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Print

The Print  sub-menu contains the following option. This option only prints forms.
Fields do not print.

USING PRINT DRIVER

Select form printing defaults in the Print dialog box that displays:

Printer
AppBuilder for VIPP supports the following printers and resolutions:

• HP LaserJet printers (or PCL 4 compatible)

• PostScript printers (or compatible) - all resolutions supported by the
printer

AppBuilder for VIPP also supports Adobe's PDFWriter printer driver. If
you have Adobe's PDFWriter printer driver installed on your PC, you can
convert your form to PDF format by selecting [PDF ON FILE:] from this
window.  When you select this option, you are prompted for the directory
and file name.

For accurate positioning, shift the print image on the page using the Page
Shift field.

Set Elixir HP driver as default printer
Sets the Elixir HP printer driver as your default printer.  See the "Using the
Elixir HP print driver" section for more information.

Orientation
Select the orientation for your page: [Portrait] or [Landscape].

Page Shift
Shifts your printer output horizontally or vertically by the number of dots
specified.  [Xshift] moves your image horizontally and [Yshift] moves your
image vertically.

Use a negative shift value to shift the print output to the left, or up; and a
positive value to shift your print output right, or down.

Copies
Enter the number of copies you want to print.

Print to File
Prints your form to a disk file for proof printing. Specify the path and file
name in the Print to File dialog box that displays once you click on [OK].
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Autogen Output Name
Displays when [Print to File] is selected. Outputs the print (.PRN) and font
(.FON) files into the drive:\ELIXIR\PRINTS\ subdirectory with the same
stem name as the Elixir file (.ELX).

Print Fonts as Graphics
Rasterizes fonts as graphics.   Printing fonts as graphics requires less
printer memory and can speed up printing time.

Load Fonts
Select the soft font disposition for Elixir-generic (raster) fonts in use on a
form. This field may or may not display, depending on your selected print
driver.

• [Always] - downloads fonts every time you print; downloaded fonts are
cleared from the printer's memory when the printer is turned off or
reset

• [Once] - downloads fonts as soft fonts on the printer; fonts are identi-
fied by an index number, and are managed and accessed through the
Print Manager in Windows

• [Never] - uses the soft fonts previously downloaded to your printer;
fonts are referenced by index numbers and no new fonts are down-
loaded

If you select [Once] or [Never], you should use the same font list.  If you
use a different font list, the index number may represent a different font.

Setup
Allows you to specify (Windows) setup parameters for your printer.

Exit

Closes all AppBuilder for VIPP application.
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SYSTEM MENU

The System menu contains the following options:

Usage Switches

Select display defaults in the Usage Switches dialog box that displays:

Save State on Exit
Saves the current menu and option settings when you exit AppBuilder for
VIPP.

Extend Lines by Halfwidth
Displays horizontal and vertical lines with extensions equal to half the line
thickness at each end.  This field affects the screen display only; lines are
printed as drawn.

Show Quick Help
Displays a short description of any icon that your cursor passes over in
the Message area of the screen.

Show Form Dimensions
Display the dimensions of the current paper in the upper right hand corner
of the screen. If these dimensions are unknown, the physical sheet’s
dimensions display.

Show Lines as WYSIWYG
Select a display resolution:

• [240DPI] - lines and shape borders display as WYSIWYG on high-res-
olution monitors.

• [300DPI] - displays lines and shapes at 300 dpi

• [OFF] - for low resolution monitors such as VGA. Light and medium
lines and borders may display as the same thickness on low resolution
monitors if this option is not selected.

FILING OPTIONS

Select filing defaults in the Filing Options dialog box that displays:

Autosave
Enter a time interval from 1 to 9 minutes in the Save interval field to auto-
matically save your currently active form.  The back-up form is saved as
AUTOBACK.ELX in the default forms directory.
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Make  Backup File
Creates a back-up copy of the form which is overwritten only when you
select File>Save. The Autosave feature does not overwrite this file.

The back-up file is written to the default forms directory and has the same
stem name as the original file with a .BAK extension. See the "AppBuilder
for VIPP basics" chapter for information on retrieving a back-up file.

Load Last Form
Automatically loads the form you last worked on when you start a new
AppBuilder for VIPP session.

Write PostScript File on Form Save
Creates a PostScript file in the directory specified in the Doc. Directory
field when the Form is saved.

Forms Directory
Enter the directory for Elixir-format form files (.ELX).  The default is
drive:\ELIXIR\FORMS\ELIXIR\DEMO.

Screen Fonts Directory
Specify the directory for screen font files (.FNT) and width tables (.WDT).
The default directory is drive:\ELIXIR\FONTS\SCREEN\DEMO.

See the "Text operations" chapter for more information on screen and
other fonts.

Elixir Images Directory
Specify the directory for Elixir-format image files (.LP3).  The default  is
drive:\ELIXIR\PICS\PRINTER.

Screen Images Directory
Specify the directory for screen image files (.LW8).  The default is
drive:\ELIXIR\PICS\SCREEN.

Texts Directory
Enter the directory for imported ASCII text files (.TXT).  The default is
drive:\ELIXIR\TEXTS.

Tags Directory
Enter the directory for tag files (.TAG).  Tag files are used with DocuTag
when external tag files are called within a form.  The default is
drive:\ELIXIR.  See your Elixir DocuTag for AFP manual for more informa-
tion.

Doc. Directory
Enter the directory for the AppBuilder for VIPP components database
(.CDX and .DBF).  You can copy or move all .CDX and .DBF files to any
drive or directory.  The default is drive:\ELIXIR\JOBS\VIP.
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RESET TO DEFAULTS

Resets all Toolbox options to their default values.

SAVE CONFIGURATION

Allows you to save the current configuration for your next AppBuilder for VIPP
session.

The settings for the following options are saved:

• [Grid display]

• [Snap to Grid]

• [Graphic Ruler] and its options

WINDOW MENU

The Window  menu contains the following options:

Tile

Tiles the open windows within AppBuilder for VIPP.

Form

Displays the form Work area.  Select this option a second time to hide the form
Work area.

Document

Displays the Document window.  Select this option a second time to hide the Doc-
ument window.

Media

Displays the Media window.  Select this option a second time to hide the Media
window.

Toolbox <F10>

Displays the Toolbox.  Select this option a second time to hide the Toolbox.
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HELP MENU

For future implementation.
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7 Work area menu bar

This chapter provides information on the Work area menu bar and its sub-menus.

The Work area menu bar contains the Document, Paper, Edit, Tools, View,  and
Options  menus. Select a menu to display its options, then select an option from
the pull-down menu.

DOCUMENT MENU

The Document  menu contains the following options:

Page

The Page  sub-menu contains the following options:

NEW PAGE

Add new Pages to the active Document tree in the Document window.

ADD FROM LIBRARY

Select a Page (from all of the Pages stored in the AppBuilder for VIPP database)
to add to the active Document tree in the Document window from the Load Page
dialog box that displays. 

All of the objects associated with the selected Page (Records, Fields) are added
to the active Document definition. Adding a Page from the library causes a unique
copy of the Page definition to be created within the existing Document definition.

SET ACTIVE

Select a Page in the current Document definition to be the active Page in the
Select Active Page dialog box that displays.
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SAVE TO LIBRARY

Saves the current Page to the database.

Record

The Record  sub-menu contains the following options:

NEW RECORD

Adds new Records to the active Document tree in the Document window.

ADD FROM LIBRARY

Select a Record (from all of the Records stored in the AppBuilder for VIPP data-
base) to add to the active Document tree in the Document window from the Load
Record dialog box that displays.

All of the objects associated with the selected Records (Fields, conditions) are
added to the active Document definition. Adding a Record from the library causes
a unique copy of the Record definition to be created within the existing Document
definition.

SAVE TO LIBRARY

Saves the current Record to the database.

New Field

Adds new Fields to the Document tree in the Document window.

Condition

The Condition  sub-menu contains the following options.

Conditional logic is available only at the Field level.

NEW CONDITION

Adds a new condition to the currently active Field.

ADD FROM LIBRARY

Select a condition to add to the to the currently active Field from the Load Condi-
tion dialog box that displays.
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SAVE TO LIBRARY

Saves the current condition to the database.

PAPER

The Paper menu contains the following options:

Paper

The Paper  sub-menu contains the following options:

NEW PAPER

Adds a new Paper to the active Media tree in the Media window.

ADD FROM LIBRARY

Select a Paper to add to the active Media tree in the Media window from the Load
Paper dialog box that displays.

All of the objects associated with the selected Paper (Sheets, forms) are added to
the active Media definition. Adding a Paper from the library causes a unique copy
of the Paper definition to be created within the existing Media definition.

SET ACTIVE

Select a Paper to be the active Paper in the Select Active Paper dialog box that
displays.

SAVE TO LIBRARY

Saves the current Paper to the database.

Sheet

The Sheet  sub-menu contains the following options:

NEW SHEET

Adds a new Sheet to the active Media tree in the Media window.

ADD FROM LIBRARY

Select a Sheet add to the active Media tree in the Media window from the Load
Sheet dialog box that displays.
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All of the objects associated with the selected Sheet (forms) are added to the
active Media definition. Adding a Sheet from the library causes a unique copy of
the Sheet definition to be created within the existing Media definition.

SET ACTIVE

Select a Sheet to be the active Sheet in the Select Active Sheet dialog box that
displays.

SAVE TO LIBRARY

Saves the current Sheet to the database.

EDIT MENU

The Edit  menu contains the following options. Clipboard operations are available
only for form text objects.

Undo <Ctrl> + <Z>

Cancels the most recent action performed.

Redo <Shift> + <Ctrl> + <Z>

Cancels the most recent Undo operation.

Cut <Ctrl> + <X>

Moves the selected element(s) to the Clipboard.

Copy <Ctrl> + <C>

Copies the selected element(s) to the Clipboard.

Paste <Ctrl> + <V>

Inserts cut or copied text from the Clipboard.

Select All <Ctrl> + <A>

Selects all elements on the current form and Document.  This allows you to
delete, copy, or move the elements.
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Unselect All <Ctrl> + <A>

Deselects all previously-selected elements.

Delete <Del>

Deletes the selected element(s) from a form and/or Document.

Delete All <Ctrl> + <Del>

Deletes all selected elements from a form and/or Document.

Find <Alt> + <F3>

Displays the Find text dialog box.  Enter the text you want to find.

See the "Text operations" chapter for more information on the Find text dialog box.

Find Next <F3>

Finds the next occurrence of the text string entered in the Find text dialog box.

See the "Text operations" chapter for more information on the Find text dialog box.

Find Previous <Shift> + <F3>

Finds the previous occurrence of the text string entered in the Find text dialog box.

See the "Text operations" chapter for more information on the Find text dialog box.

Replace

Displays the Replace Text dialog box. Enter the text you want to find, and the text
you want to replace it with.

See the "Text operations" chapter for more information on the Replace text dialog
box.

TOOLS MENU

The options in this menu provide an alternate way to activate the Toolbox for the
tool selected: Select, Line, Path, Box, Circle, Text, Image, Frame, Record, and
Field.
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Spell Check

Checks the spelling in the active form. See the “Text operations” chapter for more
information.

VIEW MENU

The options in this menu provide an alternate way to activate the Toolbar options:
[Graphic Ruler], [Grid Display], and [Long Crosshair].

The [Document] and [Media] options display Document and Media information in
the Work area, respectively.

OPTIONS MENU

The Options  menu contains the following options:

Snap to Grid <F5>

Allows you to place lines, paths and boxes accurately on the grid.

Document Properties

Select Document settings in the Document Properties dialog box that displays.

Options in this dialog box may display only upon the initial opening of this dialog
box.

Document Name
Enter a name for your Document. This is the long name (maximum 32
characters) used for identification in the database.

Document Description
Enter descriptive text for the Document.

Document Info
Document ID
Displays the Document’s ID number, a value which is automatically
assigned.
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Status Info
Status
Displays the Document’s current status: TEST or PRODUCTION.

By default, every new document is created with TEST status. To change
to PRODUCTION status, select File >Document >Release and enter the
production date.

Status Info
Version
Displays the current version number for the Document which is set by
selecting Document >Save New Version.

Status Info
Begin Date
Displays the production starting date set in the Release Document dialog
box. If the Document’s status is set to [Test], the last-saved date displays. 

Status Info
End Date
Displays 2299 (default) until a new version replaces the current one. At
that point, the production ending date displays.

Filing Info
Date/Time
Displays the dates and times that the Document was originally created
and last opened.

Media Properties

Select Media defaults in the Media Properties dialog box that displays:

Media Name
Enter a name for your Media. This is the long name (maximum 32 charac-
ters) that is used to identify the Media in the database.

Media Description
Enter descriptive text for the Media.

Media Info
Media ID
Displays the Media ID number.

Media Info
Status
Displays the Document’s current status: TEST or PRODUCTION. @Link
to Design Preferences db
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Proofing Properties

Select default paper size dimensions in the Proofing Properties dialog box that
displays:

Physical Sheet dimension
Enter the page width and height. This value defines the boundaries in the
Work area when no Paper is defined in the Media.

AppBuilder Preferences

Select display defaults in the Preferences dialog box that displays:

Fields
Display Fields as

• [Name] - Fields display by name in the Work area

• [Replacement characters] - Fields display using the character speci-
fied in the Use character text box.  The length of the displayed string is
equal to the Field length.

Show Borders of
Pages
Displays all Page borders in the color selected in Use color.

Forms
Display Forms
Displays active and inactive forms in the colors selected from the drop-
down lists that display from the Active Form color and Inactive Form color
fields.

Always Reload Data Dictionary
Loads the data dictionary each time an AppBuilder for VIPP session
begins. For future implementation.

GEM Forms Load Defaults

Select GEM form display defaults in the GEM Forms Load Defaults dialog box
that displays. Options in this dialog box may or may not display, depending on the
Color Mode selected.

GEM forms are forms created in versions of ElixirForm prior to version 3.0.

Extend Lines by Halfwidth
Displays horizontal and vertical lines with extensions equal to half the line
thickness at each end. Affects printed output only.
7-8 Elixir AppBuilder for VIPP



Go To

TOC
Text Formatting Compatibility and Grid Step Precision
Select the text formatting and grid precision for loaded GEM forms:

• [GEM] - uses original boxed text formatting of a form created in Elixir-
Form prior to version 3.0; internal grid step precision set to 0.1 dots

• [Windows] - (default) uses Windows boxed text formatting; internal
grid step precision set to 0.01 dots 

Your selection is written to the Elixir SYSTEM.INI file.  This formatting
affects all GEM forms loaded afterwards.

Color Mode
Select the display color for loaded GEM form:

• [Black & White] - GEM form displays in black and white

• [Highlight Color] - GEM form displays with the options selected below:

- [PAL palette] - select a PAL palette from the drop-down list that dis-
plays

- [Catalog] - select your printer’s catalog from the drop-down list that 
displays

- [Printer Palette] - select your printer’s color palette from the drop-
down list that displays

• [Full Color] - GEM form displays with the full color palette selected
below:

- [PLF palette] - select a color palette from the drop-down list that 
displays

• [XDP Grays] - GEM form displays in black or gray shades

Form Properties

Select form defaults in the Form Properties dialog box that displays:

Form size
Select the size and the orientation of the form. The width and length of the
form display in the unit of measurement specified in the Units of Measure
field.

• [8.5 x 11] - U.S. letter size

• [8.5 x 14] - U.S. legal size

• [11 x 17] - 11 x 17 inches

• [A4] - 8.27 x 11.69 inches
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• [A3] - 11.69 x 16.54 inches

• [Custom] - non-standard size; enter a width and height

If you change the size of an existing form, some form elements may
extend beyond the form boundary.  If this happens, the Objects Off Page
dialog box displays when you click on [OK].  

Form Orientation
Select the form’s orientation:

• [Portrait] - short edge dimension along the top of the form

• [Landscape] - long edge dimension along the top of the form

Units of measure
Select the unit of measurement for the Toolbar’s Graphic and Digital Rul-
ers, and the selected page size:  [Inches], [CM], [MM], [Dots], [Points], or
[Pels].

Your selection also changes the Ruler measure options in the Ruler
Options and Grid Setting dialog boxes.

Color mode
Select the color mode supported by your output printer: (for future imple-
mentation)

• [Black and White] - the Color options do not display in the Toolbox

• [Highlight Color] - uses the options selected below:

- [Catalog] - select your printer’s catalog from the drop-down list that 
displays

- [Printer Palette] - select your printer’s color palette from the drop-
down list that displays

- [Ink Dominance] - select the dominant color (if colors overlap):

-[Default] - prints in black or color, depending on your printer’s 
default

-[Black] - prints in black

-[Color] - prints in the currently selected color in the Rot., Color 
dialog box

• [Full color] - uses color for borders, interior fills, texts and logos, if sup-
ported by your printer; colors are defined by their RGB values in the
Rot., Color dialog box
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• [XDP Grays] - uses black or gray shades

Form Databasing

Select form databasing defaults in the Form Databasing dialog box that displays:

Short Page Description
Enter a short description (maximum 60 characters) for the form.

Page Author
Enter the user ID (maximum 8 characters).

Made for
Enter the name of the customer (maximum 13 characters).

Page Version
Enter the version number (maximum two characters).

Page Revision
Enter the form revision or modification identifier (one character only).

Local ID
Enter a local identifier (maximum 8 characters).

Long Page Comments
Enter comments for the form (maximum four lines with 60 characters per
line). Use the mouse to move to another line or any place within the com-
ments box. Comments are saved with each form until they are changed or
deleted.

Store Date/Time Stamp
Assigns a date or time stamp to the form when generated to a printer file
format.

Date Format
Select the month/day/year/ format for the date when the Store Date/Time
Stamp field is selected. 

sc:
The default separator character is /. To enter a new separator character,
backspace over the old character and enter a new one.

Time Format
Select a time format: [12 Hour am/pm] or [24 Hour].

sc:
The default separator character is : . To enter a new separator character,
backspace over the old character and enter a new one.
7-11 Elixir AppBuilder for VIPP



Go To

TOC
Form databasing information is stored with the form until it is changed or deleted.
It is not printed.

Text/Font Options

Select text and font defaults in the Text and Font Options dialog box that displays: 

Text Tab Length
Enter the text tab length. Tab length is based on the width of the space
character in the active font. The default setting is 5.  The tab length setting
applies to all tabs on the current form (including those previously 

Text Formatting Compatibility and Grid Step Precision
Allows you to select the boxed text formatting format when loading GEM
forms.

• [GEM] - maintains the original boxed text formatting for forms created
prior to version 3.0. Internal grid step precision is set to 0.1 dots

• [Windows] - uses Windows version of boxed text formatting. Internal
grid step precision is set to 0.01 dots

This formatting affects only the currently loaded form.

Tag Display
Prints the data tags included in Elixir forms.

• [None] - tags are hidden and do not print

• [Replace Chars] prints the data tag field length and replacement char-
acters.

• [Tag Name] prints the data tag's field name.

See your Elixir DataMerge User Guide or Elixir DocuTag User Guide for
more information.

Font Preference
Select the default font type: [Screen] or [Elixir].

Sort Font List
Alphabetically sorts the font list.

Text Import Options

• [Lock position] - When importing from an ASCII file, locks text in its ini-
tial position in the Work area. Subsequent text blocks are positioned
directly beneath the first text block.
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• [Separate paragraphs] - Places imported text blocks at different loca-
tions on the form. Paragraphs separated by two carriage returns cre-
ate separate blocks that you can place separately if the [Lock position]
option is not selected. 

See the “Text operations” chapter for more information on importing text.

Join Text Using
Select the format to group blocks of text into a single block:

• [Spaces] - each text block displays under the previous text block; orig-
inal line beginnings and endings are maintained.

• [Justify] - joined text displays as one continuous paragraph.  The width
of the joined text is determined by the position of the left-most and
right-most characters in the text blocks.

• [Relatives] - each text block retains its position relative to the previous
text block

To take out unwanted spaces or perform paragraph formatting operations,
deselect then select the [Wrap Text] option in the Text toolbox. See the
"Text operations chapter for information on how to join text.

Filter control codes on input
Prevents entry of control codes from the keyboard.

RTF Paste Options

• [Paste Fonts] - maintains font(s) specified in the imported text file.

• [Paste Colors] - maintains color(s) specified in the  imported text file.

Character Mapping

Specify non-standard mapping in the Character Mapping Options dialog box that
displays. Most TrueType or ATM font users should use the default [None] setting.

Keyboard Mapping

• Select [None] to use Windows ANSI mapping (you must have screen
fonts mapped to Windows ANSI mappings.)

• Select [OEM] to remap ANSI keystrokes to DOS mappings.

• Select [OEM/ISO] to remap ANSI character strokes to DOS ISO map-
pings.  (This option is the same as the [Map IBM to ISO fonts] option in
previous software versions.

• Select [ISO] to remap ANSI keystrokes to DOS ISO mappings.
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• Select [KMP] (default) to translate keystrokes using customized
tables.  When you select [KMP], the Windows and Elixir fields display:

Windows
Select a map from the drop-down list.  Most users should select
T100ANSI.  For Eastern European versions of Windows, select
T10EEURO.

Elixir
Select the setting that matches your DOS code page from the drop-down
list.  To check your DOS code page, at the DOS prompt, type:

CHCP <Enter>

The active code page displays.

Text Import Mapping/Text Paste Mapping
Select an import text/pasted text mapping option:

• [NONE] - when importing or pasting a DOS text file.

• [OEM] - when importing or pasting a Windows text file into DOS
mapped .ELX form

• [OEM/ISO] - when importing a Windows text file that has European
characters mapped into DOS mapped .ELX form

• [ISO] - when importing or pasting a DOS text file that has European S
mapped .ELX form

• [KMP] - when importing or pasting a Windows text file that has interna-
tional characters mapped.

When you select [KMP], the Text File and Elixir fields display:

Text File
Select a text file from the drop-down list that displays.  Most users
should select [T100ANSI].  If you are using an Eastern European ver-
sion of Windows, you should select [T10EEURO].

Elixir
Select the setting that matches your DOS code page from the drop-
down list that displays.  To check your DOS code page, go to the
DOS prompt and type

CHCP <Enter>

The active code page displays.
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Spell Checker Mapping
Select a spell checker character mapping option:

• [None] - use Windows ANSI mapping; select this option if you work
with ATM or True Type fonts

• [OEM] - remaps ANSI keystrokes to DOS mappings

• [OEM/ISO] - remaps ANSI character strokes to DOS ISO mappings

• [KMP] - translates keystrokes using customized tables

When you select [KMP], the Windows and Elixir fields display:

Windows
Select the setting from the drop-down list that displays.  Most users
should select [T100ANSI].  If you are using an Eastern European ver-
sion of Windows, you should select [T10EEURO].

Elixir
Select the setting that matches your DOS code page from the drop-
down list that displays.  To check your DOS code page, go to the
DOS prompt and type

CHCP <Enter>

The active code page displays.

Spell Check Options

Select spell checking defaults in the Spell Check Options dialog box that displays:

Language
Select the language you want to use from the drop-down list that displays.

Dialect/mode
Select the dialect/mode for the selected language from the drop-down list
that displays.

Ligature
This field may or may not display, depending on the language selected.

• [Open] - two-letter character combinations print side-by-side

• [Closed] - two-letter character combinations print together
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Lexicon Supplements
This field is available only when [English standard] is selected in the Lan-
guage field.

• [Business/Insurance/Finance] - dictionary contains business, insur-
ance, or financial terminology

• [Medical] - dictionary contains medical terminology

• [Legal] - dictionary contains legal terminology

• [Science] - dictionary contains scientific terminology

Processing Correction Defaults
These options are used only when errors are found:

• [Provide Alternatives If Not Found] - provides alternative words if a
word is not found in the database

• [Provide Alterns. From Personal Dictionary] - provides alternative
words from active personal dictionaries after alternatives from the
active database are retrieved

• [Perform Space Insertion] - inserts spaces between incorrectly spaced
words; For example, the string "andthe" is corrected to "and the".

• [Remove Final Period] - strips the final period  from a word before it is
submitted for correction

Personal Dictionaries
Displays the dictionary files (*.RD) that are available for use.

• [New] - creates a personal dictionary; enter a name for the new dictio-
nary in the Create Personal Dictionary dialog box that displays.

• [Add] - adds an existing personal dictionary (*.?D) to the list; select the
dictionary from the Add Personal Dictionary dialog box that displays.

• [Remove] - removes the selected dictionary

• [Edit] - edits entries in the selected dictionary. Select [Add], [Delete], or
[Replace] to perform the appropriate action for the word displayed in
the Edit word field in the Edit Personal Dictionary dialog box that dis-
plays.

Spell Check Typing
Activates the spell check option after a word is typed.  Once a word is
entered and the space bar is depressed, the word is spell checked. 
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8 Lines

This chapter describes how to draw and edit lines, and references options in the
Line toolbox.

LINE DISPLAY

The following section provides information on line display.

Setting the screen display

For low resolution monitors such as VGA, select [OFF] in the Show Lines as
WYSIWYG field in the Usage Switches dialog box. This prevents thin lines and
borders from displaying as the same thickness as medium lines and borders when
in WYSIWYG mode.

Screen refresh

After a screen refresh, lines and boxes that overlap may not display or print in the
"front to back" order in which they were drawn. For example, a shaded box drawn
on top of an existing line may display with the line on top of the box after a screen
refresh. This is due to the method of resorting a page (from top left to bottom right)
that is required by certain printers. 

To prevent elements refreshing to an incorrect "front to back" order, avoid drawing
elements that overlap. For example, to draw a box with lines extending from its
borders, connect individual lines to the border of the box instead of drawing the
box on top of a line that extends beneath and beyond its borders. 

DRAWING LINES

If you want a line to start and end at grid points, select the [Grid] and [Snap to
Grid] tools in the Toolbar.
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Lines attached to the outside of a box may not line up exactly with box splits.  If
you want attached lines to do so:

• move the box to line up with the attached line

• draw the box splits as lines extending outside the box

If you want the line to snap to grid mid-points as well as to grid points, select [Half
Grid] in the Grid Snap to field of the Grid Setting dialog box.

To draw a line:

1. Select line attributes in the Line toolbox.

2. Position the screen pointer in the Work area where you want the line to
begin and press and hold the left mouse button. 

3. Drag the screen pointer across the Work area.

A line displays.

4. Release the mouse button to end the line. 

Applying color to a line

To apply color to a line:

1. Select Options>Form Properties.

The Form Properties dialog box displays.

2. Select [Full Color] in the Color Mode  field.

3. In the Line toolbox, select [Color].

The color palette displays.

4. Select a color.

5. Place the cursor in the Work area and draw a line.

The selected color is applied to the line.

SELECTING LINES

To perform an action on a line, you must first select it.

To select a line:

1. Select the Toolbox Select/Edit tool.

2. Place the cursor on the line you want to edit.

Arrows display around the line.
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3. Right-click on the line.

The screen pointer changes to a hand. If it does not, the line may be too small.
If this happens, press and hold the <Ctrl> key as you move the cursor over the
line.

The Line toolbox displays.  Boxes appear at each end of the line (in the Work
area) to show it is selected.

You can now change the line length or the line attributes.

EDITING LINES

To change the properties of a line, you must first select the line.

Changing line length 

You can change the length of a selected line by:

• typing in new dimension coordinates

• stretching the line on the form

CHANGING DIMENSION COORDINATES

To change line dimension coordinates:

1. Select the line you want to change the length of.

2. Click in the [Current object Dimensions] area of the Toolbar.

3. Backspace over the current value or press the <Del> key to delete the
whole number. 

4. Enter new coordinate values, then click or press <Enter>.

Use the <-> key to enter a negative value, if allowed.

The line adjusts to the new coordinates.

STRETCHING A LINE

To stretch a line manually:

1. Select the line you want to change the length of.

2. Place the cursor at the end of the selected line.

The cursor changes to a four-way arrow. 

3. Drag the end of the line until the line reaches the new length.

4. Release the mouse button. 
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Changing line attributes

To change line attributes:

1. Select the line you want to change.

To change the attributes of multiple lines, <Shift>-click on each line or use the
group feature described in the "AppBuilder basics" chapter.

2. Select the desired option(s) from the Line toolbox.

The properties apply to the line(s) you selected.

COPYING LINES

To copy a line:

1. Select the line you want to copy.

2. In the Select/Edit toolbox, select [Copy].

3. Select a [Movement Selection] option.

4. Select the number of copies (between 1 and 99) by clicking on the up or
down arrows, or click in the numeric display box and enter a number.

<Ctrl>-click to increase or decrease the value by 10.  You can also backspace
over the value and enter a new value from the keyboard. 

5. Click on and drag the selected line in the direction you want to place the
duplicate line(s).

6. Release the mouse button.

The line(s) displays in the new position.

Specifying a fixed distance between multiple copies

To specify a fixed horizontal and/or vertical distance between multiple element
copies:

1. Select the Toolbox Select/Edit tool.

2. Select a group of objects in the Work area.

3. Select [Copy] and your copy options as above.

4. Select [Horizontal Copy Distance] or [Vertical Copy Distance] and enter a
value for the distance between copies.

5. Click on the group of objects.

6. The objects separate by the distance specified in the [Horizontal Copy
Distance] or [Vertical Copy Distance] option.
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DELETING LINES  <DEL>

To delete a line:

1. Select the line you want to delete. 

2. Press <Del>.

The line is deleted.

UNDELETING LINES

To restore a deleted line:

• immediately select Edit >Undo

• press <Ctrl> + <Z>

• select [Undo] in the Toolbar

MOVING LINES 

You can move a line by:

• manually moving it

• entering new coordinates

Manually

To move a line manually:

1. Select the line you want to move.

2. Select a [Movement Selection] option.

3. Drag the line to a new position. 

4. Release the mouse button. 

The line locks in the new position.

Changing position coordinates

To move a line by changing its coordinates:

1. Select the line you want to move.

2. Click in the [Current Object Start Coordinates] area of the Toolbar.
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3. Backspace over the current values or press the <Del> key to delete the
whole number.

4. Enter new coordinate values, then click or press <Enter>.

The line adjusts to the new coordinates.

STICKY LINES <CTRL> + <L>

When you select the [Sticky Lines] option in the Select/Edit toolbox, lines that
touch remained attached to one another when either line is moved. Lines attached
to box sides also remain connected when you resize the box.  When the [Sticky
Lines] option is not active, moving a line or resizing a box may separate it from a
previously connected line.

Moving sticky lines/resizing a box with sticky lines

To move sticky lines connected to other lines, or resize a box with sticky lines:

1. Select the line you want to move.

2. Select the [Sticky Lines] option.

3. Perform one of the following options:

• To move a vertical line horizontally: Select [Horizontal only] in the Select/Edit
toolbox. When you move the line left or right, the horizontal lines which are
connected to it remain connected while increasing or decreasing in length.

• To move a horizontal line vertically: Select [Vertical only] in the Select/Edit tool-
box. When you move the line up or down, the vertical lines which are con-
nected to it remain connected while increasing or decreasing in length.

• To resize a box horizontally: When you move its left or right side, the lines
which are connected to it increase or decrease in length as the side moves.

• To resize a box vertically: When you move its top or bottom side, the lines;
which are connected to it increase or decrease in length as the top or bottom
moves.
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9 Shapes

This chapter describes how to draw and edit shapes, and references options in
the Box, Circle, and Path toolboxes.

DRAWING SHAPES

If you want a line to start and end at grid points, select the [Grid] and [Snap to
Grid] tools in the Toolbar.

If you want a box or path to snap to grid mid-points as well as to grid points, select
[Half Grid] in the Grid Snap to field of the Grid Setting dialog box.

Drawing paths

To draw a path:

1. Select path attributes in the Path toolbox.

2. Move the screen pointer into the Work area. 

3. Click and drag the screen pointer to draw one segment of the path.

4. Release the mouse button to finish the segment.  

5. Repeat the above procedure to draw the next segment(s).

The next segment(s) begins where the last segment(s) ends.

6. Double-click or right-click to end the path.

Drawing boxes

To draw a box:

1. Select box attributes in the Box toolbox.

2. Position the screen pointer where you want a box corner in the Work
area.
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3. Press and hold the mouse button.

4. Drag the screen pointer to form the shape of a box.

5. Release the mouse button to finish the box. 

Use the arrow keys to pan around the screen when drawing a box that extends
beyond the Work area.

Drawing circles

To draw a circle:

1. Select circle attributes in the Circle toolbox.

2. Move the screen pointer into the Work area.

3. Click and drag the screen pointer to form a circle. 

4. Release the mouse button to finish the circle.

SELECTING SHAPES

To perform an action on a shape, you must first select it.

To select a shape:

1. Select the Toolbox Select/Edit tool.

2. Place the cursor on the shape you want to edit.

Arrows display around the shape.

3. Right-click on the shape.

The screen pointer changes to a hand. If it does not, the shape may be too
small.  If this happens, press and hold the <Ctrl> key as you move the cursor
over the shape.

The related Toolbox displays.  Boxes appear around or inside the shape (in the
Work area) to show it is selected.

You can now change the shape’s attributes.

EDITING SHAPES 

To change the properties of a shape, you must first select it.
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Changing shape size

You can change the size of a selected shape by:

• typing in new dimension coordinates

• stretching the shape on the form

CHANGING DIMENSION COORDINATES

To change the shape dimension coordinates:

1. Select the shape you want to change the length of.

2. Click in the [Current object Dimensions] area of the Toolbar.

3. Backspace over the current value or press the <Del> key to delete the
whole number. 

4. Enter new coordinate values, then click or press <Enter>.

Use the <-> key to enter a negative value, if allowed.

The shape adjusts to the new coordinates.

STRETCHING A SHAPE

To stretch a shape manually:

1. Select the shape you want to change the size of.

2. Place the cursor on one of the boxes around the shape.

The cursor changes to a four-way arrow.

3. Drag the cursor until the shape reaches the new size.

4. Release the mouse button. 

Changing shape attributes

To change shape attributes:

1. Select the shape you want to change.

To change the attributes of multiple shapes (of the same type), <Shift>-click on
each shape or use the group feature described in the "AppBuilder basics"
chapter.

2. Select the desired options from the shape’s Toolbox.

The properties you select apply to all selected shapes.
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COPYING SHAPES

To copy a shape:

1. Select the shape you want to copy.

2. In the Select/Edit toolbox, select [Copy].

3. Select a [Movement Selection] option.

4. Select the number of copies (between 1 and 99) by clicking on the up or
down arrows, or click in the numeric display box and enter a number.

<Ctrl>-click to increase or decrease the value by 10.  You can also backspace
over the value and enter a new value from the keyboard. 

5. Click on and drag the selected shape in the direction you want to place
the duplicate shape(s).

6. Release the mouse button.

The shape(s) displays in the new position.

Specifying a fixed distance between multiple copies

To specify a fixed horizontal and/or vertical distance between multiple element
copies:

1. Select the Toolbox Select/Edit tool.

2. Select a group of objects in the Work area.

3. Select [Copy] and your copy options as above.

4. Select [Horizontal Copy Distance] or [Vertical Copy Distance] and enter a
value for the distance between copies.

5. Click on the group of objects.

6. The objects separate by the distance specified in the [Horizontal Copy
Distance] or [Vertical Copy Distance] option.

DELETING SHAPES  <DEL>

To delete a shape:

1. Select the shape you want to delete. 

2. Press <Del>.

The shape is deleted.
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UNDELETING SHAPES

To restore a deleted shape:

• immediately select Edit >Undo

• press <Ctrl> + <Z>

• select [Undo] in the Toolbar

MOVING SHAPES 

You can move a shape by:

• manually moving it

• entering new coordinates

Manually

To move a shape manually:

1. Select the shape you want to move.

2. Select a [Movement Selection] option.

3. Drag the shape to a new position. 

4. Release the mouse button. 

The shape locks in the new position.

Changing position coordinates

To move a shape by changing its coordinates:

1. Select the shape you want to move.

2. Click in the [Current object Start Coordinates] area of the Toolbar.

3. Backspace over the current values or press the <Del> key to delete the
whole number.

4. Enter new coordinate values, then click or press <Enter>.

The shape adjusts to the new coordinates.
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10 Text operations

This chapter describes the available text operations, and references options in the
Text toolbox.

ADDING TEXT

You can create text using either Elixir-generic or screen fonts, TrueType fonts, or
ATM fonts. You can insert text either by entering text directly from the keyboard or
by importing text from an ASCII file.

Apply text properties by selecting options from the Text toolbox.

Entering text from the keyboard

To enter text from the keyboard:

1. Select the text attributes in the Text toolbox.

2. Select the [Load Font List] (down arrow) option.

The Load Font List dialog box displays.

3. Select a font list, then click on [OK].

The selected font list displays in the Font Preview Panel.

4. Select a font, then click in the Work area where you want the text to
appear.

You can change the font as you type, to apply the new font to subsequent text.

5. Type your text, then right-click when done. 

Entered text displays in the Work area.
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MOVING A BLOCK BEFORE FINISHED ENTERING TEXT

To move a text block before you finish entering text:

1. Press and hold down the <Ctrl> key.

2. Place the cursor on the text block.

3. Click and drag the text block to a new location.

4. Release the mouse button to place the text.

To move a text block after you finish entering text, see the "Moving text" sec-
tion in this chapter.

Importing text

AppBuilder For VIPP allows you to import ASCII text, one block at a time, from the
directory specified in the Filing Options dialog box. The default directory is
drive:\ELIXIR\TEXTS.

You can change the attributes of an imported text block by selecting the attributes
from the Text tool before importing each block.

BEFORE IMPORTING TEXT

Before importing text:

1. Copy the ASCII file to the texts directory specified in the Filing Options
dialog box.

2. Assign the ASCII file a .TXT extension. 

3. Separate paragraphs (or text blocks) with two carriage returns. 

IMPORTING TEXT BLOCKS

To import text blocks:

1. Select the Text tool in the Toolbox.

The Text toolbox displays.

2. Select text attributes in the Text toolbox.

3. Select [Text/Font Options] from the Options menu.

The Text and Font Options dialog box displays.
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4. In the Text Import Options  field:

• Select [Locked text] to load each text block directly below the previous
block, or

• Select [Separate paragraphs] to load subsequent text blocks wherever
you click in the Work area.

You can also press <F11> to toggle between the two text placement modes.
The Message area displays the current setting.

5. Select File>Import Text.

The Import Text dialog displays the files in the drive:\ELIXIR\TEXTS or
assigned directory.

6. Select the file you want to load, then click on [OK].

7. Press and hold the screen pointer to display the first text block.

• To scroll through the text blocks, continue holding down the mouse
button.

• To scroll to the previous text block, press <F3>.

• To scroll to the next text block, press <F4>.

8. Drag the text and release the mouse button to place the first text block
on the form.

9. Click to display and place the next text block. 

10.Click on [OK] when done.

When you import an ASCII file, the complete file attaches to the cursor for posi-
tioning unless you select the [Lock position] option in the Text and Font Options
dialog box.  When text is locked, the text file attaches to the previous cursor posi-
tion in the Work area.

The selected font size and the amount of loaded text determines whether or not
the whole ASCII file can fit on a form.

IMPORTING TEXT INTO A BOX

When importing text into a text box, you must define the text box size first.   See
the "Drawing a text box" section in this chapter for information about boxed text.

Text imported into a box does not respect original carriage returns.  To maintain
the carriage returns from the original text, make sure [Box Text] and [Wrap Text]
are deselected.
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SPECIFYING COLUMN BOUNDARIES

You can specify column boundaries by:

• entering coordinates

• drawing a box manually

• entering free text

When you enter text with specified column boundaries:

1. In the Text toolbox, select [Wrap Text].

2. Select a [Text Positioning] option.

3. Press <Enter> to insert carriage returns and begin new paragraphs.

4. Right-click to finish entering text in the text box.

Entering coordinates

To enter values for column boundaries: 

1. In the Text toolbox, select [Wrap Text].

2. Enter [Column Width] and [Column Height] values.

3. Click in the Work area.

A temporary text box with the specified boundaries displays.

Drawing a text box

 To draw a text box manually:

1. In the Text toolbox, select [Wrap Text].

2. Select [Draw Text Box].

3. Place the cursor in the Work area, then click and drag the box to the
desired size.

This box is not the same as a box you draw using the Box tool.  It is used only
as a visual aid for defining the column width and height for a text block.

You can now enter text in the box.
10-4 Elixir AppBuilder for VIPP



Go To

TOC
RESIZING A TEXT BOX

To resize an existing text box:

1. Select the existing text box.

2. Place the cursor on the right or bottom edge of the box, then click and
drag the box to the desired size.

The box resizes to the new dimensions.

Entering free text

When the [Box Text] option is deselected, you can enter free text.  Free text is
bound by the width and height of the form or by the width and height specified in
the [Column Width] and [Column Height] options.  If you use the [Column Width]
and [Column Height] options, make sure you select [Wrap Text].  When entering
free text, press <Enter> to move to a new line.

SELECTING A FONT

You can select a font from either the current Font List or a new font list you load.
You can also merge, modify, and save font lists.

The current Font List displays in the Toolbox Preview panel with the font in use
highlighted.  You can normally recognize the font family and the size, style, and
orientation of a font from the file name. 

The Font List displays one or more of the following fonts:

• Elixir-generic format .(HDR) or screen font files (.FNT)

• ATM fonts

• TrueType fonts

You can use contour fonts to generate additional fonts for use in AppBuilder.  See
the ElixiSys Desktop User Guide for more information.

You can also create or edit fonts using the ElixiFont application.  See the ElixiFont
User Guide for more information.

Selecting a font from the current Font List

To select a font from the current list, click on a font name in the Preview panel.
Use the up or down arrows on the keyboard or the scroll bar on the right of the dis-
play window to scroll through the list.
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Loading a new font list

To load a different font list:

1. Click on the down arrow under the [Font List] option.

The Load Font List dialog box displays.

2. Select a Font List, then click on [OK]. 

The selected font list displays in the Toolbox preview panel. 

3. Select a font.

Merging font lists

To merge a font list with the current Font List:

1. Click on the double arrows under the [Font List] option. 

The Merge Font List dialog box displays. 

2. Select the Font List you want to merge into the current Font List, then
click on [OK]. 

The fonts in the file you merge are added to the current Font List.

Adding fonts to the Font List

You can add Elixir, TrueType, or ATM fonts individually or in groups to the Font
List.

To add fonts to a Font List:

1. Click on the [Font Type] option until the desired font type displays
(a=ATM, f=Elixir, T=TrueType).

2. Click on the [Add Font] option ([+]).

Depending on the [Font Type] selected, either the Select ATM Font, Select
TrueType Fonts, or Add Fonts dialog box displays.

3. Select the font you want to add, (and font characteristics, if applicable)
then click on [OK]. To multi-select fonts, <Ctrl>-click on subsequent
fonts.

The font(s) is added to the current Font List.

Repeat these steps for each font type you want to add.
10-6 Elixir AppBuilder for VIPP



Go To

TOC
Removing fonts from the Font List

To remove a font from the current Font List: 

1. Select the font name in the Preview panel. 

2. Click on the [Delete Fonts] button([-]).

The font is removed from the Font List. You cannot remove a font that is in use
on your form

You can also use <Ctrl> + <-> to delete all unused fonts from the Font List.

Saving custom font lists

You can change an existing Font List and save it with a new name, or overwrite
the existing Font List.

To save a custom font list:  

1. Click on the up arrow under the [Font List] option.

The Save Font List dialog box displays.

2. Enter a new file name to save a custom Font List with a unique name, or
enter an existing file name to overwrite the existing Font List.

The Font List saves with the new fonts.

SELECTING TEXT

To perform an action on a text block, you must first select it.

To select text:
1. Select the Select/Edit tool in the Toolbox.

2. Place the cursor on the text block you want to edit and right-click.

The Text toolbox displays. Boxes appear around the text (in the Work area) to
show it is selected.

You can now change the text’s attributes. See the "Keyboard shortcuts" section
for more information.
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EDITING TEXT

To change the properties of a text block, you must first select it. When editing text,
the name of the font used to create the text is highlighted in the Font List window.

Changing text attributes

To change the attributes of a selected text block, select options in the Text toolbox.
The new attribute(s) is applied to the selected text block.

Applying color to text

You can apply color to new text you type, or to existing text.

NEW TEXT

1. Select the Text tool.

The Text toolbox displays.

2. Select a font.

3. Select the [Color] option.

The Color dialog box displays.

4. Select a color.

5. Click in the Work area and begin to type.

Text displays in the color you selected, and continues for all subsequent text
blocks until you select another color.

6. Right-click to end text entry.

EXISTING TEXT

You can add color to existing text; partial blocks or full blocks.

1. Select the text or text block and right-click.

The Text toolbox displays.

2. Select the [Color] option.

The Color dialog box displays.

3. Select a color.

The color is applied to the selected text.
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Changing the font in an entire text block

To change the font throughout a text block:

1. Select the text block, then right-click on it.

The Text toolbox displays.

2. Place the cursor at the beginning of the text block. 

3. Select a font in the Font List.

The new font applies to all text in the text block.

Changing the font within a text block

To change the font of a word or phrase in a text block:

1. Select the text block and right-click.

2. Click in front of the word or phrase you want to change and drag the
mouse to highlight the text.

3. Select a new font from the Font List. 

The selected text reflects the new font.

MULTIPLE FONTS IN A TEXT BLOCK

If multiple fonts are used within a text block, the font highlighted in the Font List
window changes as the cursor moves through the different fonts.

All fonts in the text block must have the same orientation.  If you want to use a font
with a different orientation, place the cursor at the beginning of the text block and
apply the orientation to all fonts in the text block.

CHANGING THE FONT FROM A SPECIFIC LOCATION FORWARD

To change the font from a specific location in a text block to the end of the block:

1. Select the text block and right-click.

2. Click in the location where you want the new font to start.

3. Select a font from the Font List. 

All text following the text cursor changes to the font you select.

When changing the font in this manner, AppBuilder adds a hidden control charac-
ter just before the changed text. The character contains font information, and you
can delete it by placing the cursor at the beginning of the changed text and press-
ing <Del>.  Deleting the control character changes the text back to its original font.
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Replacing fonts in a text block

To replace every occurrence of a font with a new font:

1. Select the font you want to replace in the Font List.

2. Click on the [Delete Fonts] button ([-]).

If the font is in use in the document, the Replace Font dialog box displays.

3. Select a replacement font.

You cannot replace a font with a font that is already in use on the form.  If the
replacement font is not currently in use on the form, all occurrences of the font
are replaced by the replacement font.

If the font you try to replace is not used on the form, it is removed from the Font
List. 

Joining text

You can rejoin text that was broken up when converting a form to .ELX format. 

To join text:

1. Select Options>Text/Font Options.

The Text and Font Options dialog box displays.

2. Select an option in the Join Text Using  field, then click on [OK].

3. Group the text you want to join.  

The [Join Text] option displays in the Select toolbox.

See the "AppBuilder For VIPP basics" chapter for information on defining a
group.

4. Select the [Join Text] option.

The text in the group joins.

Splitting text

To split a text block into two separate blocks:

1. Select the text block and right-click.

The Text toolbox displays.

2. Place the cursor where you want the text to split. 

3. Select the [Split String] option in the Text toolbox.

The text splits and the cursor displays in the upper left corner of the new text
block.
10-10 Elixir AppBuilder for VIPP



Go To

TOC
Moving text

You can move a text block before or after you finish entering it by:

• manually moving it on the form

• entering new coordinates

MOVING EXISTING TEXT MANUALLY

To move an existing text block manually:

1. Select the Select/Edit tool in the Toolbox.

2. Select a [Movement Selection] option.

3. Select the text block you want to move. 

The cursor changes to a hand. 

4. Click and drag the text block to where you want it on the form.

5. Release the mouse button to accept the text position.

MOVING TEXT BY CHANGING POSITION COORDINATES

You can also move the text block by entering new coordinates:

1. Click in the [Current object Start Coordinates] area of the Toolbar.

If you cannot click on the current object coordinates, make sure the text block
is selected, then right-click.

2. Backspace over the current values or press <Del> to delete the whole
number.

3. Enter new coordinate values, then click or press <Enter>.

The text adjusts to the new coordinates.

Copying text

You can copy a text block using the Toolbox [Copy] option or the Edit  menu
options.

To copy a text block using the Toolbox:

1. Select the Toolbox Select/Edit tool.

2. Select the [Copy] option.

3. Select a [Movement Selection] option.

4. Select the text block you want to copy.

Brackets appear around the text to show it is selected.
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5. Enter a value in the [Copies] option or click on the up or down arrows to
select the number of copies (between 1 and 99).

<Ctrl>-click on the up or down arrows to increase or decrease the value by 10.
You can also backspace over the value and enter a new value from the key-
board. 

6. Drag the text block in the direction you want to place the copies.

7. Release the mouse button at the desired location.

The text displays in the new position.

To cut, copy, and paste text using the Edit  menu:

1. Select the Toolbox Select/Edit tool.

2. Right-click on the text block.

3. Select the text you want to cut or copy by clicking and then dragging the
mouse over the text.

4. Select [Cut] or[Copy] from the Edit menu. Alternatively, press <Ctrl>+<X>
or <Ctrl>+<C>.

5. Right-click to end text selection.

6. Select the Toolbox Text tool.

7. Click at the new location.

8. Select [Paste] from the Edit menu. Alternatively, press <Ctrl> + <V> to
paste text.

SPECIFYING A FIXED DISTANCE BETWEEN MULTIPLE COPIES

To specify a fixed horizontal and/or vertical distance between multiple element
copies:

1. Select the Toolbox Select/Edit tool.

2. Select a group of objects in the Work area.

3. Select [Copy] and your copy options.

4. Select [Horizontal Copy Distance] or [Vertical Copy Distance] and enter a
value for the distance between copies.

5. Click on the group of objects.

The objects separate by the distance specified in the [Horizontal Copy Dis-
tance] or [Vertical Copy Distance] option.
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Deleting text <DEL>

To delete text:

1. Select the text you want to delete. 

2. Press <Del>.

The text is deleted.

Undeleting text

To restore deleted text:

• immediately select Edit >Undo

• press <Ctrl> + <Z>

• select [Undo] in the Toolbar

Finding/replacing text

AppBuilder allows you to find text and non-standard keyboard characters, and to
replace occurrences of word(s) on a form.

FINDING TEXT

To find text:

1. Select Edit>Find.

The Find Text dialog box displays.

2. In the Find Text field, enter the text you want to find, then click on the
[Find] button.

To find non-standard keyboard characters:

1. Select Edit>Find.

The Find Text dialog box displays.

2. In the Find Text  field, enter the character’s decimal value (from the Win-
dows character mapping table), then click on the [Find] button.

The Find Text dialog box contains the following options:

Find Text
Enter a search text string or select one from the drop-down list.

Case Sensitive
Searches for text with the same capitalization as the text in the [Find Text]
option.
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Whole Words
Searches for complete words that match the text in the [Find Text] option.

For example, searching for “the” returns only “the” and not words contain-
ing “the”, such as “there”.

Find
Searches the open form for the text selected/entered in the [Find Text]
option.

Cancel
Closes the Find Text dialog box.

Help
For future implementation.

Once you start a Find session, you can press <Ctrl> + <F3> to find the
next occurrence of the target text; and <Ctrl> + <Shift> + <F3> to find the
previous occurrence of the target text.

REPLACING TEXT

To replace occurrences of a word:

1. Select Edit>Replace.

The Replace Text dialog box displays.

2. Select/enter search and replace options, then click on the [Replace] or
[Replace All] button.

The Replace Text dialog box contains the following options:

Find text
Enter a search text string or select one from the drop-down list.

Replace by
Enter a replacement text string or select one from the drop-down list.

Case Sensitive
Searches for text with the same capitalization as the text in the [Find text]
option.

Whole Words
Searches for complete words that match the text in the [Find text] option.

For example, searching for “the” returns only “the” and not words contain-
ing “the”, such as “there”.

Replace
Replaces the current instance of text in the [Find text] option text with the
text in the [Replace by] option.
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Replace Al l
Replaces all instances of text in the [Find text] option with the text in the
[Replace by] option.

Cancel
Closes the Replace Text dialog box.

Help
For future implementation.

INSERTING DATA TAGS

AppBuilder For VIPP allows you to add data tags for use with DocuTag or Data-
Merge, if installed.  See your DocuTag User Guide or DataMerge User Guide for
more information.

SOFT KEYBOARD

The soft keyboard allows you to enter characters that are not available on a stan-
dard keyboard.

Typing extended characters

To type an extended character:

1. Place the cursor in the Work area where you want the character to dis-
play.

2. Select [Soft Keyboard] in the Text toolbox.

The soft keyboard displays.

3. Select a character from the soft keyboard.

The character displays in the selected position. 

4. Deselect the [Soft Keyboard] option when complete.

The soft keyboard displays characters in the current font size, so small fonts may
be difficult to read.

You can also access non-standard keyboard characters by typing the decimal
value of the character.  Press <Alt> and enter the decimal value using the numeric
keypad.
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SPELL CHECKING

If installed, the AppBuilder Spell Checker option allows you to identify misspelled
words in your form.

Setting defaults

To set spell check defaults:

1. Select [Spell Check Options] from the Options menu.

The Spell Check Options dialog box displays.

2. Select spell check options, then click on [OK].

The Spell Check Options dialog box contains the following options:

Language
Select the language to use from the drop-down list.

Dialect/mode
Select the dialect/mode for the selected language from the drop-down list.

Lexicon Supplements
Select a terminology dictionary:

[Business/Insurance/Finance] - contains business, insurance, or financial
terminology

[Medical] - contains medical terminology

[Legal] - contains legal terminology

[Science] - contains scientific terminology

Processing Correction Defaults
These options are used only when errors are found:

[Provide Alternatives If Not Found] - provides alternative words if a word
is not found in the database

[Provide Alterns. From Personal Dictionary] - provides alternative words
from active personal dictionaries after alternatives from the active data-
base are retrieved

[Perform Space Insertion] - inserts spaces between incorrectly spaced
words; For example, the string "andthe" is corrected to "and the".

[Remove Final Period] - strips the final period  from a word before it is
submitted for correction
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Personal Dictionaries
Displays the dictionary files (*.RD) available for use.

New
Enter a name for the new personal dictionary in the Create Personal Dic-
tionary dialog box.

Add
Select an existing personal dictionary (*.?D) to add to the Personal Dictio-
naries field in the Add Personal Dictionary dialog box.

Remove
Removes the selected dictionary from the Personal Dictionaries field.

Edit
Edits entries in the dictionary selected in the Personal Dictionaries field.

Click on the [Add], [Delete], or [Replace] button to perform the appropriate
action for the word that displays in the Edit word field in the Edit Personal
Dictionary dialog box.

Spell Check Typing
Activates the spell check option after you type a word.  Once you enter a
word and press the space bar, the word is spell checked. 

Using the Spell Checker

To use the Spell Checker:

1. Click on the Toolbar Spell Check icon or select Tools>Spell Check.

The Spell Checker checks all text in the current form for misspelled words. 

If Spell Checker does not recognize a word, the Spell Check dialog box dis-
plays. The unrecognized word displays in the Edit field, and if applicable, an
alternate word displays in the Guess field.

2. If the word displayed in the Guess  field is not correct, select an alternate
word from the drop-down list.

3. If the word is not found in the drop-down list, backspace over the mis-
spelled word in the Edit  field, then enter the correct spelling. 

Select one of the following options:

Replace
Replaces the misspelled word with the word in the Edit  field.

Replace All
Replaces all instances of the misspelled word with the word in the Edit
field.
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Ignore
Ignores the first occurrence of the word in the Edit  field.

Ignore All
Ignores all occurrences of the word in the Edit  field.

Stop
Stops spell checking and closes the Spell Check dialog box.

A 'beep' indicates the spell check operation is complete.

KEYBOARD SHORTCUTS

The following fast keys are used for text operations:

• <Left arrow> - cursor moves left one character

• <Up arrow> - cursor moves up one line

• <Right arrow> - cursor moves right one character

• <Down arrow> - cursor moves down one line

• <Home> - cursor moves to start of line

• <End> - cursor moves to end of line

• <Ctrl> + <Left arrow> - cursor moves left one word

• <Ctrl> + <Right arrow> - cursor moves right one word

• <Ins> - insert/overwrite toggle

• <Del> - deletes right character

• <Backspace> - deletes left character

• <Ctrl> + <Del> - deletes next word

• <Ctrl> + <Bksp> - deletes previous word

• <Ctrl> + <K> - deletes to end of line

• <Ctrl> + <E> - deletes to end of text block

• <Ctrl> + <Home> - cursor moves to start of text block

• <Ctrl> + <End> - cursor moves to end of text block
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• <F11> - lock/free text toggle

• <Ctrl> + <T> - show/hide data tags

• <Ctrl> + <X> - cuts text

• <Ctrl> + <C> - copies text

• <Ctrl> + <V> - pastes text

• <Alt> + <F3> - Find

• <F3> - Find Next

• <Shift> + <F3> - Find Previous

• <Ctrl> + <F3> - Find Selected (forward)

• <Ctrl>+<Shift>+<F3> - Find Selected (reverse)
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11 Images

This chapter describes how to load, edit, move, copy, and delete images, and ref-
erences options in the Image toolbox.

OVERVIEW

AppBuilder for VIPP allows you to add the following to your forms:

• Elixir-format black-and-white, highlight color, and full color images (.LP3,
.LW8)

• bitmap images (.BMP)

Screen versions of images are stored in the drive:\ELIXIR\PICS\SCREEN direc-
tory with .LW8 extensions, and printer versions of images are stored in the
drive:\ELIXIR\PICS\PRINTER directory with .LP3 extensions. You can only edit
images using ElixiGraphics software. See the ElixiGraphics User Guide for more
information.

You can use the ElixiSys Desktop to convert .PCX and .TIF files to Elixir format. 

LOADING IMAGES

To add an image to your form: 

1. Select the Image tool in the Toolbox.

The Image toolbox displays.

2. Select [Load Image].

The Load Image dialog box display.
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3. At the bottom of the dialog box, select the extension for the file type you
want to load.

Screen versions have .LW8 extensions; printer versions have .LP3 extensions.

4. Select an image, then click on [OK].

5. Press and hold the left mouse button. 

The image attaches to the screen pointer. 

6. Position the image on the form and release the left mouse button to fix it
in place.

SELECTING IMAGES

To perform an action on an image, you must first select it.

To select an image:

1. Select the Select/Edit tool in the Toolbox.

2. Place the cursor on the image you want to edit and right-click.

The screen pointer changes to a hand. If it does not, the image may be too
small.  If this happens, press and hold the <Ctrl> key as you move the cursor
over the image.

The Image toolbox displays.  Boxes appear around the image (in the Work
area) to show it is selected.

COPYING IMAGES

To copy an image:

1. Select the Select tool in the Toolbox.

2. Select the image you want to copy.

Boxes appear around the image to show it is selected.

3. Select the [Copy] option.

4. Select the number of copies (between 1 and 99) by clicking on the up or
down arrows, or click in the numeric display box and enter a number.

<Ctrl>-click to increase or decrease the value by 10.  You can also backspace
over the value and enter a new value from the keyboard. 

5. Select a [Movement Selection] option.
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6. Select the image and drag it in the direction you want the duplicate
images to display, then release the mouse button.

The image displays in the new positions.

Specifying a fixed distance between multiple copies
To specify a fixed horizontal and/or vertical distance between multiple element
copies:

1. Select the Select tool in the Toolbox or pull down the Tools menu and
select [Select].

2. Select a group of objects in the Work area.

3. Select [Copy] and your copy options as above.

4. Select [Horizontal Copy Distance] or [Vertical Copy Distance] and enter a
value for the distance between copies.

5. Click on the group of objects.

The objects separate by the distance specified in the [Horizontal Copy Dis-
tance] or [Vertical Copy Distance] option.

DELETING IMAGES <DEL>

To delete an image:

1. Select the image you want to delete. 

2. Press <Del>.

The image is deleted.

UNDELETING IMAGES

To restore a deleted image:

• immediately select Edit >Undo

• press <Ctrl> + <Z>

• select Toolbar>Undo
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MOVING IMAGES

You can move an image by:

• manually moving it on the form

• entering new coordinates

Moving an image manually

To move an image manually:

1. Select the Select tool in the Toolbox. 

2. Select a [Movement Selection] option.

3. Click on the image you want to move.

Boxes appear around the image to show it is selected.

4. Drag the image to the new location. 

5. Release the mouse button to lock the image on the form.

Moving an image by changing position coordinates

To move an image by changing its position coordinates:

1. Click in the Toolbar [Current Object-Start Coordinates] area.

If you cannot click on the current object coordinates, select the image again,
then right-click.

2. Backspace over the current values, or press the <Del> key to delete the
whole number.

3. Enter new coordinate values, then press <Enter>.

The image adjusts to the new coordinates.
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12 Document window

This chapter provides a detailed description of the Document window and its fea-
tures.

OPENING THE DOCUMENT WINDOW

To open the Document window, select File>Document>New Document or Load
Document.  You can also select Window>Document if a Document is already
open.

When only a Document is loaded (the Media window is closed), Pages display
with the 0,0 origin in the top left corner of the Work area. To set physical sheet
dimensions, select Options>Proofing Properties. The Document window displays
below the Work area and displays the Document tree.  See the "Adding objects to
the Document tree" section for more information.

Overview of the features

The following is an overview of the Document window features.  This section
refers you to other sections in this chapter where the features are explained in
detail.

DOCUMENT MENU BAR

AppBuilder for VIPP provides menus and sub-menus to access Document
options.  Document menu bar options are described in the "Document menu bar"
section and the "Work area menu bar" chapter.

DOCUMENT TOOLBAR

The Document Toolbar displays across the top of the Document window and
includes +P, +R, +F, Condition, Properties, and Delete options.  Document Toolbar
options are described in the "Document Toolbar" section.
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DOCUMENT TREE

The Document tree displays below the Document Toolbar and provides a hierar-
chical breakdown of the elements in the current Document.  See the "Adding
objects to the Document tree" section for more information.

DOCUMENT MENU BAR

The Document menu bar contains the Document , Edit , and View menus.

Select a menu or sub-menu to display its options, then select an option from the
pull-down menu.

Document

Options in this menu allow you to set the Document properties and options.  See
the "AppBuilder for VIPP menu bar" chapter for more information.

Edit

Options in this menu allow you to cut, copy, paste, and delete Document window
contents, as well as transfer objects between two Documents.

When you copy a Page, AppBuilder automatically changes the Short name of the
copy to prevent two Pages from having the same name.

View

The View menu controls the column headings in the Document window and con-
tains the following options:

PAGES

Displays Page names as column headings.

RECORDS

Displays Record names as column headings.

FIELDS

Displays Field names as column headings.

CONDITIONS

Displays condition names as column headings.
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NONE

Displays no column headings.

EXPAND ALL  <SHIFT> + <*>

Expands the Document tree to all levels.

COLLAPSE ALL  <SHIFT> + </>

Displays the Document tree with only the Page names visible.

WINDOW ON TOP

Always keeps the Document window on top in the display.

DOCUMENT TOOLBAR

The  Document Toolbar displays across the top of the Document window and con-
tains the following options. See the "Adding objects to the Document tree" section
for more information on adding objects to the Document tree.

+P

Adds a Page to the Document tree.  Each Page defined in an AppBuilder docu-
ment corresponds to a single Job Descriptor Ticket (JDT) definition. Multiple Page
descriptions can be defined in a single Document. Each Page becomes a single
JDT file when converted to JDT format. 

+R

Adds a Record to the Document tree. Each added Record is written as either a
FROMLINE or RPEKEY statement in the JDT.

+F

Adds a Field to the Document tree.
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Condition

Adds a condition entry to the currently selected Field in the Document tree. Each
condition is written as a Record Criteria Definition statement in the JDT.

To add a condition:

1. Select the Field in the Document tree to add the conditional test to.

2. Select Document Toolbar>Add new Condition.

The condition displays under the Field in the Document tree.

3. Right-click on the added condition.

The Field Condition dialog box appears.

4. Select/enter the appropriate information in the dialog box, then click on
[OK].

To edit a condition: 

1. Select the condition and right-click.

The Field Condition dialog box appears.

2. Edit the appropriate information in the dialog box, then click on [OK].

See the "Conditional Logic" section for more information.

Properties

Displays the properties of a selected object in the Document window. You can
also right-click on an object to display the related Properties dialog box.

The following objects/properties are available for viewing and are listed hierarchi-
cally:

• Document

• Page

• Frame

• Record

• Field

• Condition

See the "Viewing element properties" and ”Conditional Logic” sections for more
information.

DOCUMENT

Select Document settings in the Document Properties dialog box that displays.
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PAGE

Select Page settings in the Page Properties dialog box that displays.

Options in this dialog box may or may not display, depending on your selection in
the [Page Number - Position] option.

Page Name
Enter a name for the Page (maximum 32 characters). This name displays
in the Document tree.

Short Name
Enter a name for the Page (maximum 8 characters) or use the system-
supplied name that displays. Select the Use Page Name field in the
Export VIPP dialog box at conversion time to use this name for the JDT
file name.

When you copy a Page, AppBuilder automatically changes the [Short
name] of the copy to prevent two Pages from having the same name.

Description
Enter descriptive text for the Page.

Logical Page Dimension
Enter the width and height values for the logical Page in the unit of mea-
surement set in the Form Properties dialog box.

This value can also be directly set from the physical paper dimensions by
selecting the [Connected Paper - Use Paper Dimension] option in this dia-
log box.

Logical Page Offset
Enter the horizontal and vertical offsets for the logical Page and its
objects. Offset values are from the physical sheet’s origin.

The [Logical Page Dimension] and the [Logical Page Offset] options com-
bine to create the VIPP SETMARGIN statement when the Page is con-
verted to a JDT.

Page Number
Position
Select a page number positioning option from the drop-down list that dis-
plays: [None], [Bottom Center], [Bottom Right], [Top Center], [Top Right],
[Left], [Right], or [Center].

Page Number
Horizontal/Vertical
Enter the absolute horizontal and vertical coordinates for the page num-
ber. Set units of measurement in the Form Properties dialog box.
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Page Number
Start on
Enter the starting page number.

Page Number
Format
Enter a format string, where “#” stands for the page number. For example,
(Page #) prints as “Page 1”.

Font
Select the page number’s display font in the Font List dialog box that dis-
plays when you click on this button.

Color
Select the page number’s display color in the Rotation, Color dialog box
that displays when you click on this button.

Connected Paper
Name
Select a Paper type in the List of Papers dialog box that displays from the
[Select] button.

Connected Paper
Use Paper Dimension
Automatically posts the physical sheet dimensions from the [Connected
Paper - Name] option into the [Logical Page Dimension] option entry
boxes.

If the [Presentation] option in the Paper Properties dialog box is set to
landscape, the width and height values in the [Logical Page Dimension]
option reflect this.

Date/Time
Displays the dates and times that the Page was originally created and last
opened.

FRAME

Select Frame and zebra defaults in the Frame and Zebra Settings dialog box that
displays:

Page name
Displays the name of the Page containing this Frame.

Zebra
Lines With
Enter the number of lines using the shading set in the [Color] option. No
zebra is created if set to zero or [White] is selected in the [Color] option.
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Zebra
Lines Without
Enter the number of lines with no shading.

Zebra
Linespacing
Enter the value for calculating the height of the zebra boxes.

Color
Select a color for the Zebra frame from the drop down list that displays or
create a custom color using the [Edit RGB] option. If [White] is selected,
no zebra is created.

Edit RGB
Displays the Color RGB Editor dialog box. Move the slider next to the
RGB values or click in the numeric display boxes and enter a value
between 0 and 255 to alter the color. Click on [OK] once the desired color
displays in the [Result] area. (for future implementation)

Preview
Displays the color used for zebra striping.

Red
Displays the Red value set in the Color RGB Editor dialog box. (for future
implementation)

Green
Displays the Green value set in the Color RGB Editor dialog box. (for
future implementation)

Blue
Displays the Blue value set in the Color RGB Editor dialog box. (for future
implementation)

Frame
Draws an outline box around the page.

Offset
Enter the distance between the logical Page edge and the Frame. The
same offset value applies to all four sides

Corner Type
Select the Frame’s corner type from the drop-down list that display:
[Square], [Small Radius], [Medium Radius], [Large Radius], [ Half
Radius], or [Custom Radius].

Border Width
Enter a value (maximum 9999) for the thickness of the Frame border. A
value of zero means that no Frame will be drawn.
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Radius
Enter a value for the radius’ corner. This value applies only when the
[Custom Type] option is set to [Custom Radius]. 

RECORD

Select Record settings in the Record Properties dialog box that displays:

Page name
Displays the name of the Page that the Record is tied to.

Record name
Enter a name for the current Record.  This name displays to the left of the
Properties button in the Toolbox.

Record Info
Record Type
Select the type of Record to process:

• [Line Printer] - standard line printer Record; creates an VIPP FROM-
LINE statement when the document is converted to a JDT

• [Prefixed] - data Record contains a unique identifying key; enter a
character value (maximum 10 characters) for the key in the [Prefix]
option that displays; creates an VIPP RPEKEY statement when the
document is converted to a JDT

Repeat
Enter the number of times to reuse the current Record definition in the
associated Page. The VIPP processor reads successive data Records
(up to the number specified) and applies the same formatting for each
one.

Related Fields are incrementally positioned on the Page based on the
displacement values entered in the Field Properties dialog box.

Count
Displays the current Record’s sequence number. When the [Repeat]
option is selected, this value increments to reflect the repeated Records.

For example, a value of 5 means that the current Record is the fifth record
the VIPP processor will encounter when reading the data for the Page. 

Hidden
Hides the selected Record and its related Fields in the Work area. X’s dis-
play in the Document window next to the hidden objects.

Select this option a second time to redisplay the Record and its related
objects.
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Comment
Enter any comments for the Record here. These comments are for docu-
mentation purposes only.

FIELD

Select Field settings in the Field Properties dialog box that displays.

Options in this dialog box may or may not display, depending on your selection in
the [Alignment - Align] option. Set units of measurement in the Form Properties
dialog box.

Page name
Displays the name of the Page this Field is tied to.

Record name
Displays the name of the Record which contains this Field.

Field name
Enter a name for the current Field.  This name displays to the left of the
Properties button in the Toolbox.

Offset
Enter an offset value for the starting point of a Field in the Record.  This
value is the number of bytes from the first data byte in the Record.

Length
Enter the number of bytes in the Field.

Alignment
Align
Select a Field alignment position from the drop-down list that displays:
[Left], [Right], [Center], [Justify], [Left/Strip], [Right/Strip], [String], or
[Show On].

Alignment
Colwidth
Enter the Field’s column width.

Alignment
String
Enter the character(s) to align the string on when the Field is prints/dis-
plays.
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Rotation
Select a Field rotation direction:

• [Across (0*)] - no rotation

• [Back (180*)] - Field rotates 180o counter clockwise

• [Down (270*)] - Field rotates 270o counter clockwise

• [Up (90*)] - Field rotates 90o counter clockwise

Position
Enter the absolute horizontal and vertical positions. These values are
automatically filled in if the Field dragged-and-dropped into the Work
area.

Displacement
Enter the relative horizontal and/or vertical offsets value for Field place-
ment when using repeating Records.

Color
Select a Field color from the drop down list that displays or create a cus-
tom color using the [Edit RGB] option.

Edit RGB
Displays the Color RGB Editor dialog box. Move the slider next to the
RGB values or click in the numeric display boxes and enter a value
between 0 and 255 to alter the color. Click on [OK] once the desired color
displays in the [Result] area. (for future implementation)

Preview
Displays the color to be applied to the current Field. (for future implemen-
tation)

Red
Displays the Red value set in the Color RGB Editor dialog box. (for future
implementation)

Green
Displays the Green value set in the Color RGB Editor dialog box. (for
future implementation)

Blue
Displays the Blue value set in the Color RGB Editor dialog box. (for future
implementation)

Is Mapped
Places the Field in the Work area at the coordinates defined in the [Posi-
tion] option. Dragging-and-dropping the Field in the Work area automati-
cally selects this option.
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Selecting this option a second time removes the mapped Field from the
Work area but does not delete it from the Page in the Document window.

Hidden
Hides the selected Field in the Work area. X’s display in the Document
window next to hidden Fields. Fields must be mapped to a Sheet before
they can be hidden.

Select this option a second time to redisplay the Field.

Font
Select a font in the Font List dialog box that displays. This font applies to
the current Field.

Sample Text
Enter sample text in the Text dialog box that displays. Specified text dis-
plays only.

Comment
Enter any comments for the Field here.

Sample Text
Displays the text specified in the Text dialog box.

Delete

Deletes the currently selected object in the Document tree.

CONDITIONAL LOGIC

Conditional logic is available only at the Field level. A condition must be added for
each unique test performed on a Field. AppBuilder conditions correspond to VIPP
Record Criteria Definition statements.

The Field Condition dialog box contains the following options. Set units of mea-
surement in the Form Properties dialog box.

Name
Enter a reference name for the condition (25 characters maximum).  This
name displays in the Document window.

Short name
Enter a name with 1-8 alphanumeric characters.  This name is used as
the RCDkey name for the SETRCD statement when the Document is
converted to a JDT.
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IF/ELSE IF
Select the initial test condition:

• [IF] - for each unique test to perform on a Field

• [ELSE] - default action taken when all previous IF tests fail

Field Name
Displays the name of the Field that the test applies to.

Start
Enter the position (in the data Record) of the starting character of the
Field being tested. This value usually is the same as the offset value used
in the Field that the Condition applies to.

Length
Enter the length of the Field being tested.

Comparison operators
Select an operator to use when comparing the data Field with the text
string specified in the [Comparison String] option:

• [=] - Field and string are equal

• [!=] - Field and string are not equal

• [>] - Field is greater than string

• [>=] - Field is greater than or equal to string

• [<] - Field is less than string

• [<=] - Field is less than or equal to string

Comparison String
Enter the alphanumeric string to compare to the Field.

THEN
Select the actions to be performed if the test is true. To activate the
options in this section, click on the checkbox for the specific attribute to
modify.

THEN
Start/Length
Prints the specified section of the Record that is different from the original
Field being tested.
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THEN
Align
Align
Select a Field alignment position from the drop-down list that displays:
[Left], [Right], [Center], [Justify], [Left/Strip], [Right/Strip], [String], or
[Show On].

THEN
Align
Colwidth
Enter the Field’s column width.

THEN
Rotation
Select a Field rotation direction:

• [Across (0*)] - no rotation

• [Back (180*)] - Field rotates 180o counter clockwise

• [Down (270*)] - Field rotates 270o counter clockwise

• [Up (90*)] - Field rotates 90o counter clockwise

THEN
Position
Enter the absolute horizontal and vertical positions. These values are
automatically filled in if the Field dragged-and-dropped into the Work
area.

THEN
Displacement
Enter the relative horizontal and/or vertical offsets value for Field place-
ment when using repeating Records.

THEN
Color
Color
Select a Field color from the drop down list that displays or create a cus-
tom color using the [THEN - Color - Edit RGB] option.

THEN
Color
Edit RGB
Displays the Color RGB Editor dialog box. Move the slider next to the
RGB values or click in the numeric display boxes and enter a value
between 0 and 255 to alter the color. Click on [OK] once the desired color
displays in the [Result] area. (for future implementation)
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THEN
Color
Preview
Displays the color to be applied to the current Field. (for future implemen-
tation)

THEN
Color
Red
Displays the Red value set in the Color RGB Editor dialog box. (for future
implementation)

THEN
Color
Green
Displays the Green value set in the Color RGB Editor dialog box. (for
future implementation)

THEN
Color
Blue
Displays the Blue value set in the Color RGB Editor dialog box. (for future
implementation)

ADDING OBJECTS TO THE DOCUMENT TREE

The following is a hierarchical breakdown of a Document:

• Document

• Page

• Frame

• Record

• Field

Conditional logic is available only at the Field level.

Objects are added to the Document tree by:

• selecting the appropriate option in the Document Toolbar; for example, select-
ing [+P] adds a Page to the Document that contains the currently selected
object

• using the Document  menu

• adding the object manually
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Once added to the Document tree, objects display according to the following
guidelines:

- If the selected object is of the same type or lower in hierarchy than the new 
object, the new object is added after the selected object.

- If the selected object is one level higher than the new object, the new object 
is added as a first to the list.

- If the selected object is two or more levels higher than the new object, add-
ing is impossible.

Using the Document Toolbar

To add an object using the Document Toolbar:

1. Select the object in the Document tree to add an object to.

2. Select Document Toolbar>[+object you want to add].

The added object displays in the Document tree.

Using the Document menu

To add an object using the Document  menu, select Document >one of the follow-
ing options:

• Page>New Page

• Record >New Record

• New Field

• Condition >New Condition

The added object displays in the Document tree.

Adding manually

Records and Fields can also be added manually.

PAGES

To add a Page manually:

1. Select a Page in the Document tree.

2. Place the cursor in the Work area.

3. Press and hold <Ctrl>, and click.

4. Drag the box and release the mouse button when the desired Page out-
line displays.
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The new Page displays in the Document tree.  Any objects in the Work area
prior to this addition are cleared from the screen, as they belong to the previ-
ously selected Page.

RECORDS

To add a new Record manually:

1. Select a Record within an existing Page in the Document tree.

2. Place the cursor in the Work area.

3. Press and hold <Ctrl>, click and drag the cursor a short distance.

A new Record displays at the cursor location in the Work area and in the Doc-
ument tree.

FIELDS

To add a new Field manually:

1. Select an existing Field within a Record in the Document tree.

2. Place the cursor in the Work area.

3. Perform one of the following actions:

1. Press and hold <Ctrl>, click and drag the cursor a short distance.

The new Field displays at the cursor location in the Work area and in the
Document tree. The width and height of the new Field are zero.

or 

1. Press and hold the left mouse button.

2. Drag the screen pointer to create a box.

3. Release the mouse button to finish the box.

VIEWING ELEMENT PROPERTIES

To view the properties of an element in the Document tree, select the item you
want and right-click or select [i] from the Document Toolbar.  Elements available
for viewing include Documents, Pages, Records, and Fields.
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LOCATING OBJECTS IN THE DOCUMENT TREE

AppBuilder for VIPP allows you to visually locate a Document tree object in the
main Work area.

To locate an object:

1. Place the cursor on the object in the Document tree you want to locate.

2. <Shift>-click on the selected object.

The selected object displays, highlighted with arrows:

• Pages and Records display as boxes

• Fields display as text
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13 Media window

This chapter provides a detailed description of the Media window and its features. 

OPENING THE MEDIA WINDOW

To open the Media window, select File>Media >New Media or Load Media.  You
can also select Window >Media if a Media is already open.

When a Media is loaded, Media formatting applies to the Work area and displays
the exact physical sheet layout. The Media window displays below the Work area
and displays the Media tree.  See the "Adding objects to the Media tree" section
for more information.

Overview of the features

The following is an overview of the Media window features.  This section refers
you to other sections in this chapter where the features are explained in detail.

MEDIA MENU BAR

AppBuilder For VIPP provides menus and sub-menus to access Media options.
Media menu bar options are described in the "Media menu bar" section and the
"Work area menu bar" chapter.

MEDIA TOOLBAR

The Media Toolbar displays across the top of the Media window and includes +P,
+S, Forms, Properties, and Delete options.  Media Toolbar options are described
in the "Media  Toolbar" section.
13-1 Elixir AppBuilder for VIPP



Go To

TOC
MEDIA TREE

The Media tree displays below the Media Toolbar and provides a hierarchical
breakdown of the elements in the current Media.  See the "Adding objects to the
Media tree" section for more information.

MEDIA MENU BAR

The Media menu bar contains the Paper, Edit , and View menus.

Select a menu or sub-menu to display its option, then select an option from the
pull-down menu.

Paper

Options in this menu allow you to set the Paper properties and options.  See the
"Work area menu bar" chapter for more information.

Edit

Options in this menu allow you to cut, copy, paste, and delete Media window con-
tents, as well as transfer objects between two Media.

When you copy a Paper, AppBuilder automatically changes the Short name of the
copy to prevent two Papers from having the same name.

View

The View menu controls the column headings in the Media window and contains
the following options:

PAPERS

Displays Paper information as column headings.

SHEETS

Displays Sheet information as column headings.

FORMS

Displays form information as column headings.

NONE

Displays no column headings.
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EXPAND ALL  <SHIFT> + <*>

Expands the Media tree to all levels.

COLLAPSE ALL  <SHIFT> + </>

Displays the Media tree with only the Media and Paper names visible.

WINDOW ON TOP

Always keeps the Media window on top in the display.

MEDIA TOOLBAR

The Media Toolbar displays across the top of the Media window and contains the
following options:

+P

Adds a Paper to the Media tree.  All of the formatting parameters specified in the
Paper are applied to the Work area.  Whenever you add a Paper, a Sheet is auto-
matically placed below it.

+S

Adds a Sheet to the selected Paper. The number of sheets that can be added to a
Paper depend on the [Duplex printing] option selected in the Paper Properties dia-
log box:

• [None] - only one Sheet can be added

• [Long side] or [Short side] - two Sheets can be added

Form

Adds a form(s) (maximum 8 per Sheet) to the current Sheet from the Add Form
dialog box that displays:

Form name
Enter a form name or select one from the Select Form dialog box that dis-
plays from the [Select] button.

Offset
Horizontal/Vertical
Enter the horizontal and vertical starting points for the form on the physi-
cal sheet.
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If the form already has an offset set in the Form Properties dialog box, the
value displays and is applied to the form displayed in the Work area.

Offset values specified in the Sheet Properties dialog box only affect the
form display.  Offset values for the actual form must be applied when the
you convert forms from Elixir format (.ELX) to VIPP format.  See your
Elixir Forms Editor Desktop User Guide for more information on convert-
ing forms.

Properties

Displays the properties of a selected object in the Media tree. You can also right-
click on an object to display the related Properties dialog box.

The following objects are available for viewing and are listed hierarchically:

• Media

• Paper

• Sheet

• Form

See the "Viewing element properties" section for more information.

MEDIA

Select Media settings in the Media Properties dialog box that displays:

Media Name
Enter a name for your Media. This is the long name (maximum 32 charac-
ters) that is used to identify the Media in the database.

Media Description
Enter descriptive text for the Media.

Media Info
Displays information on the Media.

Filing Info
Date/Time
Displays the dates and times that the Media was originally created and
last opened.

PAPER

Select Paper settings in the Paper Properties dialog box that displays:

Paper name
Enter a name for the Paper (maximum 32 characters).  This name dis-
plays in the Media tree.
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Short name
Enter a name for the Paper (maximum 8 characters) or use the system-
supplied one that displays.

When you copy a Paper, AppBuilder automatically changes the short
name of the copy to prevent two Papers from having the same name.

Description
Enter descriptive text for the Paper.

Presentation
Select the print orientation:

• [Portrait] - pages print with the short edges at the top and bottom and
the long edges along the sides

• [Landscape] - pages print with the long edges at the top and bottom
and the short edges along the sides

Presentation
Inverse
Prints pages in inverse portrait or inverse landscape mode, depending on
the orientation selected in the [Presentation] option.

Paper
Number
Displays the Paper number which is automatically set by AppBuilder for
VIPP.

Paper
Width/Height
Enter the Paper’s physical dimensions. Width refers to the short edge and
height refers to the long edge of the Paper.

Post Processing
Staple
Enables switching of sets within a job.

Post Processing
Offset
Enables offsetting of sets within a job.

Duplex Printing
Select a duplex printing option:

• [None] - single-sided (simplex) printing

• [Long side] - head-to-head (portrait) or head-to-foot (landscape) print-
ing
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• [Short side] - head-to-foot (portrait) or head-to-head (landscape) print-
ing

Tray
Select your printer’s paper tray from the drop-down list that displays or
select one from the Tray Names dialog box that displays from the [Select]
button.

Page Shift
Front/Back
Enter the horizontal and vertical (positive or negative) offsets for the front
and back sides of the physical sheet of Paper. Set units of measurement
in the Form Properties dialog box.

Filing Info
Date/Time
Displays the dates and times that the file was originally created and last
opened.

SHEET

Select Sheet defaults in the Sheet Properties dialog box that displays.

Options in this dialog box may or may not display, depending on your selection in
the [Sheet Side] option.

Paper Name
Displays the name of the associated Paper.

Sheet Name
Enter a name for the Sheet (32 characters maximum).

Sheet Side
Select which side(s) of the Paper the Sheet applies to:

• [Front] - front side of the sheet

• [Back] - back side of the sheet

• [Both] - both sides of the sheet

You must specify [Front] or [Back] if a form appears on one side, but not
the other.  [Front] and [Back] Sheets must occur in pairs.

Constant Form
Prints a form on the back side of the paper without variable data.

FORM

Select form defaults in the Form Properties dialog box that displays.
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Delete

Deletes the currently selected object in the Media tree.

ADDING OBJECTS TO THE MEDIA TREE

The following is a hierarchical breakdown of Media:

• Media

• Paper

• Sheet

- Forms

Objects are added to the Media tree by selecting the appropriate option in the
Media Toolbar.  For example, selecting [+S] adds a Sheet to the currently selected
Paper.

To add an object to the Media tree:

1. Select the object in the Media tree to add an object to.

2. Select Media Toolbar>[+object you want to add].

The added object displays under its related object in the Media tree.

VIEWING ELEMENT PROPERTIES

To view the properties of an element in the Media window, select the item you
want and right-click or select [i] from the Media Toolbar.  Elements available for
viewing include Media, Papers, Sheets, and forms.
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14 Auxiliary dialog boxes

This chapter provides detailed descriptions of all AppBuilder for VIPP sub-dialog
boxes. 

FONT LIST

Options in this dialog box may or may not display, depending on the font selected
in the List of used Fonts field.

See the “How to...” chapter for more information on adding fonts to the Font List.

Current Font
Type
Displays the font selected in the List of used Fonts field.

Current Font
Select Font
Select the font type to add to the List of used Fonts field:

• [True Type] - select a font from the Select True Type Font dialog box that dis-
plays

• [ATM] - select a font from the Select ATM Font dialog box that displays

• [Elixir] - select a font from the Select Font dialog box that displays

Current Font
Name
Displays the name of the currently selected font.

Current Font
Style
Displays the current font’s style: [Bold], [Italic], [Underline], or [Overstrike].
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Current Font
Pointsize
Displays the current font’s point size.

User name
Enter a reference name for the font.

Add
Adds the defined font to the currently selected object and the List of used Fonts
field.

Apply
Applies the defined font to the currently selected font in the List of used Fonts
field.

Delete
Deletes the font selected in the List of used Fonts field.

List of used Fonts
Displays all fonts used in the document and their characteristics.

ROTATION, COLOR

Color
Select an object color from the drop down list that displays or create a custom
color using the RGB Editor (available through the [Edit RGB] button).

Red
Displays the Red value set in the Color RGB Editor dialog box.

Green
Displays the Green value set in the Color RGB Editor dialog box.

Blue
Displays the Blue value set in the Color RGB Editor dialog box.

Edit RGB
Displays the Color RGB Editor dialog box. Move the slider next to the RGB values
or click in the numeric display boxes and enter a value between 0 and 255 to alter
the color. Click on [OK] once the desired color displays in the [Result] area.

Preview
Displays the color to be applied to the current object.
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Direction
Select the print direction:

• [Across] - left to right

• [Down] - top to bottom

• [Back] - right to left

• [Up] - bottom to top

Rotation
All rotations are with respect to the baseline.  When rotating characters, the print
direction remains the same.

• [0] (default) - characters rotate 0o

• [90] - characters rotate 90o clockwise

• [180] - characters rotate 180o clockwise

• [270] - characters rotate 270o clockwise

SELECT ATM FONT

Message box
Displays the number of available fonts.

Elixir Font Name
Name Prefix
Displays the first two characters of the font selected in the Face Name field.

AppBuilder for VIPP stores font callouts internally as six-character names with
unique two-character prefixes. Each font callout must have a unique prefix.

Elixir Font Name
Name
Displays the six-character name of the font selected in the Face Name field.

Style
Select a font style: [Bold], [Underline], [Italic], or [Overstrike].

Orientation
Select a font orientation:

• [Portrait] - left-to-right

• [Landscape] - top-to-bottom

• [Inv Portrait] - right-to-left

• [Inv Landscape] - bottom-to-top
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Face Name
Select a font style from the list that displays.

Size
Select a font size from the list that displays.

Sample Text
Displays the font selected in the Face Name field.

SELECT TRUE TYPE FONT

Message box
Displays the number of available fonts.

Elixir Font Name
Name Prefix
Displays the first two characters of the font selected in the Face Name field.

AppBuilder for VIPP stores font callouts internally as six-character names with
unique two-character refixes. Each font callout must have a unique prefix.

Elixir Font Name
Name
Displays the six-character name of the font selected in the Face Name field.

Style
Select a font style: [Bold], [Underline], [Italic], or [Overstrike].

Orientation
Select a font orientation:

• [Portrait] - left-to-right

• [Landscape] - top-to-bottom

• [Inv Portrait] - right-to-left

• [Inv Landscape] - bottom-to-top

Face Name
Select a font style from the list that displays.

Size
Select a font size from the list that displays.

Sample Text
Displays the font selected in the Face Name field.
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TEXT

Text
Enter sample text for the current Field. Entered text is for display purposes only.

Length
Enter the length of the text string.

TRAY NAMES

Tray Name
Enter a name for the tray (maximum 30 characters).

Add
Adds the tray specified in the Tray Name field to the List of Tray names field.

Apply
Applies the name entered in the Tray Name field to the tray selected in the List of
Tray names field.

Delete
Deletes the tray selected in the List of Tray names field.

List of Tray names
Displays a list of all trays that are defined in the data dictionary.
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15 How to...

This chapter provides instruction on how to perform various operations in App-
Builder For VIPP.

MAPPING FONTS TO VIPP FONTS

AppBuilder for VIPP uses any combination of ATM, TrueType, and Elixir-generic
fonts. When you convert a design to a JDT, you can map fonts to a specific VIPP
encoding name. When using Elixir fonts, you should add them to the VIP-
FONT.MAP or user-defined mapping table. A modifiable font table is provided in
drive:\ELIXIR\PSSTASH\VIPFONT.MAP.

To use this table during the conversion, select it in the Font Mapping File field in
the Export JDT dialog box. 

The basic format of the table is as follows:

[ATM]

Helvetica=NHE

Helvetica-Bold=NHEB

Helvetica@Bold=NHEB

Helvetica-Oblique=NHEO

Helvetica@Italic=NHEO

Helvetica-BoldOblique=NHEBO

Helvetica@Bold@Italic=NHEBO 
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[TrueType ]

Arial=NHE

Arial Bold=NHEB

Arial Italic=NHEO

Arial Bold Italic=NHEBO         

[Elixir]

HE11NP=NHE 11

HE11BP=NHEB 11

The VIPP converter looks in the mapping table and attempts to make an exact
match with a font name in the AppBuilder font list. If it finds a match, it uses the
name specified in the right half of the "equation". 

If a font in the AppBuilder font list has special attributes set (BOLD or ITALIC) and
no specific font name exists for it, you can set up the mapping table to recognize
the attributes and map them to the correct VIPP key name.

For example, in the sample above, the entry Helvetica@Bold is used when the
AppBuilder font list references the ATM Helvetica font with the bold attribute set.

POSITIONING FIELDS IN A DOCUMENT

You can position a Field in a Document by:

• dragging and dropping the Field into the Work area

• manually positioning the Field

To manually position a Field in a Record:

1. Load an existing Document or create a new one.

See the “AppBuilder for VIPP basics” chapter for more information.

2. Select a Field in the Document tree.

3. Right-click on the Field.

The Field Properties dialog box displays.
15-2 Elixir AppBuilder for VIPP



Go To

TOC
4. Select the following options:

• [Position and Dimension-Horizontal/Absolute]: enter the Field’s hori-
zontal offset

• [Position and Dimension-Vertical/Absolute]: enter the Field’s vertical
offset

• [Is Mapped]: select this option to print the Field(s)

5. Click on [OK].
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