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CentreWare Printer Drivers for 
Macintosh

The CentreWare printer drivers enable printing from a Macintosh workstation to a 
Xerox system in a network environment. They contain a variety of feature options 
that enable you to customize your print jobs. 

CentreWare 5.59 provides enhanced support for Xerox DocuSP printers. It also 
includes watermark and booklet printing plug-in modules.
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CentreWare Printer Drivers
Features supported in this release include stapling, offsetting, hole punched paper, 
booklet fold, booklet staple, and watermark printing.

CentreWare Macintosh printer drivers for OS 9 use the following components:

Generic Printer Description files (PPDs)

Adobe PostScript printer driver

Xerox Job Ticket PlugIn

CentreWare Macintosh Printer Drivers for OS X 10.3 and above consist of a single 
.DMG file that includes the following components:

Custom PostScript Printer Description files (PPDs)

Filters

Plug-ins (PDEs)
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Printer Driver Documentation
CentreWare Printer Drivers Guide for Macintosh
This guide is intended for administrators who install and configure CentreWare 
printer drivers. 

The CentreWare Printer Drivers Guide is available on the CentreWare Printer 
Drivers CD in electronic (PDF) format. 

Help System
The CentreWare printer driver and PPD for Macintosh OS 9 supports balloon help.  
Enable balloon help on your system and help will be available.

OS X has a fully-featured help system that is accessed by clicking a Help button from 
the Macintosh Help menu and the ? icons on the driver dialog boxes.
Printer Driver Documentation 1-3



CentreWare Printer Driver Support
Internet Support
Please consult the Xerox Web site (http://www.Xerox.com), and follow the product 
links for your Xerox system. The Web site contains product support information, 
product overviews, updates, and links to specific product sites. Printer drivers can 
also be downloaded from this site. 

Telephone Support
For additional assistance, you may contact the Xerox Welcome Center by telephone 
to speak with a Product Support Analyst. Locate your product’s serial number, and 
record it in the space below before you make your call.

The Xerox Welcome Center telephone numbers are listed in the following table. If the 
Welcome Center telephone number for your country is not listed, it will be provided 
to you when your Xerox system is installed. For future reference, please record the 
telephone number in the space provided below. 

DocuSP Printer Serial Number

Welcome Center Telephone Numbers

UNITED STATES 800-821-2797

UNITED STATES (TTY) 800-855-2880

CANADA 800-939-3769 (800-93-XEROX)
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Installing OS X 
Custom Printer Drivers

The CentreWare Printer Drivers CD contains a variety of disk image (.DMG) files 
that support printing to Xerox systems from a Macintosh workstation running  
OS X versions 10.3 (Panther) and above.

This chapter explains how to install the printer drivers for a Xerox system. 

What’s in this chapter:

Workstation Requirements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2-2

Installing Custom Printer Drivers in OS X . . . . . . . . . . . . . . . . . . . . . . . .  2-3

Connecting to a Printer in OS X . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  2-5

Uninstalling OS X Custom Printer Drivers. . . . . . . . . . . . . . . . . . . . . . .  2-10
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Workstation Requirements
The minimum hardware requirements for the Macintosh printer drivers are:

4 MB of memory

6.2 MB of hard disk space
CD-ROM drive or access to a network
OS X custom drivers require OS X version 10.3 (Panther) or later.

NOTE: The CentreWare Macintosh printer drivers will not operate on 
Macintosh 68K computers. 
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Installing Custom Printer Drivers in OS X 
Drivers for OS X version 10.3 and later consist of the following elements:

PPD—A PostScript Printer Description (PPD) file is a readable text file that 
provides a uniform approach for specifying special features and installable 
options for printer drivers that interpret PostScript. 

PDE—Printers with features that the standard Macintosh interface does not 
support require additional screens, referred to as Printer Dialog Extensions or 
PDEs.

Filters—A filter or converter accepts input in one format, such as PDF, and 
converts it into a format, such as Postscript, that the printer can interpret.

Drivers for OS X combine these elements into one disk image (.DMG) that consists 
of several package (.mpkg) files. Xerox supplies an installation program for installing 
printer drivers in OS X environments.

NOTE: Installing printer drivers on a Macintosh running OS X requires  
Administrator privileges with Root access.
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To install custom printer drivers in Mac OS X:

1 Browse the CentreWare Printer Drivers CD to locate the .DMG (disk image) 
icon for the driver being installed.

2 Double-click the .DMG icon.

You will see a <printer_name>.mpkg (package) icon that contains the PPD, 
filters, and plug-ins associated with the printer.

3 Double-click the .mpkg icon and follow the instructions in the installer.

The driver files are copied to:

[Root] /Library/Printers/Xerox/filter

[Root] /Library/Printers/Xerox/PDEs

[Root] /Library/Printers/PPDs/Contents/Resources/<language>
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Connecting to a Printer in OS X
OS X, version 10.3, supports the following protocols:

AppleTalk

Bluetooth

IP Printing

LPD / LPR

Internet Printing Protocol (IPP)

Socket / HP JetDirect

Open Directory (Example: Microsoft Windows Active Directory)

USB

Windows Printing (Windows print queue)
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To connect a Macintosh running OS X to a printer location via 
AppleTalk:

1 Open the Printer Setup Utility. The Printers List appears.

2 Click Printers > Add Printer. A dialog box appears.

3 In the topmost pop-up menu, select AppleTalk.

4 Choose the appropriate zone. Printer locations within the selected zone appear.

5 Click a printer location to assign a driver.

6 Choose a driver from the Printer Model pop-up menu.

7 Click Add.

8 Open a document in an application and select File > Print to test the connection.

NOTE: If choosing Auto Select failed to locate a driver, then a new dialog 
box appears. Click Manually Select and choose a printer model.
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To connect a Macintosh running OS X to a printer location via Bluetooth, 
Open Directory, or USB:

1 Open the Printer Setup Utility. The Printers List appears.

2 Click Printers > Add Printer. A dialog box appears.

3 Select a protocol. A list of printer locations that support the selection appears.

4 Click a printer location to assign a driver.

5 Choose a driver from the Printer Model pop-up menu.

6 Click Add.

7 Open a document in an application and select File > Print to test the connection.

NOTE: If choosing Auto Select failed to locate a driver, then a new dialog 
box appears. Click Manually Select and choose a printer model.
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IP Printing
IP Printing includes the following protocols:

LPD / LPR

Internet Printing Protocol (IPP)

Socket / HP JetDirect

To connect a Macintosh running OS X to a printer location via  
LPD / LPR, Internet Printing Protocol, or Socket / HP Direct:

1 Start the Printer Selection Utility. The Printer List appears.

2 Click Printers > Add Printer. A dialog box appears.

3 Select IP Printing.

4 Select an IP protocol as the Printer Type.

5 Enter the IP address of the printer as the Printer Address.

6 (Optional) Enter a Queue Name.

7 Choose a driver from the Printer Model pop-up menu.

8 Click Add.

9 Open a document in an application and select File > Print to test the connection.

NOTE: If choosing Auto Select failed to locate a driver, then a new dialog 
box appears. Click Manually Select and choose a printer model.
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To connect a Macintosh running OS X to a Windows print queue:

1 Open the Printer Setup Utility. The Printers List appears.

2 Click Printers > Add Printer. A dialog box appears.

3 In the topmost pop-up menu, select Windows Printing.

4 Choose the appropriate workgroup or domain and log in as necessary. Printer 
locations within the selection appear.

5 Click a print queue to assign a driver.

6 Choose a driver from the Printer Model pop-up menu.

7 Click Add.

8 Open a document in an application and select File > Print to test the connection.

NOTE: This procedure requires user access to Windows drivers and print queues.

NOTE: If choosing Auto Select failed to locate a driver, then a new dialog 
box appears. Click Manually Select and choose a printer model.
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Uninstalling OS X Custom Printer Drivers 
Uninstalling OS X drivers requires removing them from the system manually.

 To delete Xerox printer drivers from a Macintosh running OS X:

1 Open the Printer Setup Utility. The Printers List appears.

2 Select the printers that you want to delete and click Delete.

3 Exit the Printer Setup Utility.

4 Open the hard drive where the printer driver files reside.

5 Delete PPDs and .gz files associated with the printer from  
[Root] /Library/Printers/PPDs/Contents/Resources/<language>  
by dragging them to the Trash.

6 Delete filters from [Root] /Library/Printers/Xerox/filter.

7 Delete Xerox PDEs from [Root] /Library/Printers/Xerox/PDEs.

8 Delete .mpkg files from [Root] /Library/Receipts.

NOTE: Plugins for Xerox printers have filenames such as 
XeroxAccounting.plugin, XeroxBooklet.plugin, XeroxFeatures.plugin, or 
XeroxWatermark.plugin. If you are not uninstalling all Xerox printers, be 
careful not to remove plugins needed by an active device.
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Installing Generic Printer Drivers 

The CentreWare Printer Drivers CD contains a variety of tools that support printing 
to a Xerox production system from a Macintosh workstation running OS 8.6 through 
OS 9, or OS X in Classic mode.  These tools include the Adobe PostScript printer 
driver, the Xerox Job Ticket PlugIn, Xerox Document Submission (XDS) client 
software, and a variety of  printer page description files (PPDs).

This chapter explains how to install these tools into a Macintosh running OS 8.6 
through OS 9, or OS X in Classic mode. 

What’s in this chapter:

Workstation Requirements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-2

Understanding Printer Drivers and PPDs . . . . . . . . . . . . . . . . . . . . . . . .  3-3

Printer Driver Installation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-4

Installing and Configuring Generic PPDs . . . . . . . . . . . . . . . . . . . . . . . .  3-6

Installing the Xerox Job Ticket PlugIn  . . . . . . . . . . . . . . . . . . . . . . . . . .  3-10

Configuring the Printers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-11

Installing XDS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-12

Installing Additional Products  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3-13

Uninstalling Printer Drivers and PPDs . . . . . . . . . . . . . . . . . . . . . . . . .  3-14
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Workstation Requirements
The minimum system requirements for the Macintosh printer drivers are:

4 MB of memory

Approximately 6.2 MB of hard disk space

2.1 MB disk space for the AdobePS printer driver

500 KB disk space for each PPD and plug-in to be installed

1.5 MB disk space for the XDS application
CD-ROM drive or access to a network

OS 8.6 and above.

Additional software requirements based on workstation platform, as stated in the 
Read Me First file on the CentreWare Printer Drivers CD. The Read Me First 
document is located in the AdobePS folder, which is in the AdobePS Driver 
folder.

NOTE: The CentreWare Macintosh printer drivers will not operate on 
Macintosh 68K computers. 

NOTE: A Macintosh running OS X must be in Classic mode to use these 
drivers.
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Understanding Printer Drivers and PPDs
A PostScript Printer Description (PPD) file is a readable text file that provides a 
uniform approach for specifying special features for printer drivers that interpret 
PostScript. Custom PPDs support a specific driver and printer model, offering access 
to all of that model’s capabilities. Generic PPDs only support those features available 
through model-independent print drivers, such as the AdobePS driver. They do not 
support all of the special features of Xerox systems, but can be used to enable all 
basic features and many advanced PostScript printing capabilities. Access to more 
advanced features of Xerox systems is achieved by combining generic PPDs with the 
AdobePS driver, the Xerox Job Ticket plug-in, and Xerox Document Submission 
(XDS) software.

Generic PPD
A generic PPD is available for each supported Xerox system. The generic PPD 
requires that a user print by using either the Adobe PostScript 8.x or the Apple 
LaserWriter 8.x printer driver. Keep in mind that the generic PPDs support limited 
print options, such as stapling, duplexing, adjusting image quality, and resolution. 
They do not support some of the special print options included in the custom driver, 
such as printing transparencies, banner pages, or covers.

NOTE:  The DocuSP PPDs can use the LaserWriter 8 driver for basic printing. 
However, print jobs that use the advanced features of Xerox production printers 
require the Xerox Job Ticket PlugIn. This plug-in must use the AdobePS driver, 
version 8.8 or later.
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Printer Driver Installation
This section describes the procedures for installation and configuration of the 
AdobePS PostScript print driver, Xerox PPD files, and Xerox Job Ticket PlugIn using 
the CentreWare Printer Drivers CD.

To install the PPDs or drivers from the Web, access www.xerox.com

Driver Support
The following drivers are supported for the Macintosh:

AdobePS Native with PPD

AdobePS Native with PPD and Xerox Job Ticket PlugIn

The printer drivers are located in separate folders within the .../Drivers/Mac folder on 
the CentreWare Printer Drivers CD. 

NOTE: Installation of the AdobePS printer driver requires agreement with the 
Adobe license and registration conditions. The installer displays the license and 
requests agreement before proceeding.
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Installing the AdobePS Driver
Ensure that the printer driver to be installed is available either locally or on a mounted 
network drive. If installing from a CD-ROM, double-click the CD icon when it is 
displayed on the Desktop. 

To locate and execute the printer driver installation file:

1 Browse the CD contents or directory structure to locate the Drivers folder. 

2 Double-click the Drivers folder. 

3 Double-click the Mac folder.

4 Double-click the folder for your Xerox system.

5 Double-click the OS9.x_Custom  folder. 

6 Open the AdobePS Driver folder.

7 Open the AdobePS folder.

8 Double-click the AdobePS Installer icon.

9 On the Adobe PostScript Driver screen, select Continue....

10 Select Accept on the license screen. The Adobe Installer screen is displayed.

11 Select Install to perform the easy install. The AdobePS driver is installed.

12 Select Continue if you want to install additional drivers.

13 When the installation is complete, select Quit to exit the installation program.
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Installing and Configuring Generic PPDs
Generic Print Emulation PPDs
Xerox PostScript Printer Description (PPD) files must be installed for every printer 
model used. An appropriate Xerox PPD is necessary to send jobs to the printer using 
the AdobePS printer driver. 

There is no installation program for generic PPDs. The files must be copied to the 
appropriate directory.

Installing Generic PPDs in OS 8.6-9.x Environments

To install PPDs in OS 8.6-9.x environments:

1 Select the Xerox PPDs that match the printers being installed from the  
.../OS9.x_Custom/GenericPPD_<printer_name>_Mac folder on the CentreWare 
Printer Drivers CD.

2 Copy the files to the following directory:

[HD]:/System Folder/Extensions/Printer Descriptions

The PPD is available for use with the printer driver.

NOTE: For information about installing custom drivers for OS X 10.3 and above, 
see Chapter 2, Installing OS X Custom Printer Drivers.

NOTE: For example, PPDs for the DocuColor 8000 are in the  
.../OS9.x_Custom/GenericPPD_8000_5252_2045_2060_6060_Mac folder.
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Setting Up and Configuring Generic PPDs in  
OS 8.6-9.x Environments

To set up and configure generic PPDs in OS 8.6-9.x environments:

1 In the Apple Chooser, select the AdobePS printer driver.

2 Ensure that the appropriate AppleTalk zone is selected. If the computer is 
connected to a network with only one zone, there will not be an y zones 
available.

3 In the Select a PostScript Printer list, select the AppleTalk name for the Xerox 
system.

4 Click Create. In the dialog that opens, select a PPD for the Xerox system.

5 Click Select. 

6 Click Setup and select the PPD for the Xerox system if the correct filename is 
not displayed.

7 Click Configure.

8 Use the Installable Options list to select the hardware options available on the 
printer.

9 Click OK twice to return to the Chooser. 

10 Close the Chooser. A new printer icon appears on the Desktop.

11 Open a document and select File > Print to test the connection.

NOTE: Do not use the generic PPDs with the Xerox custom printer drivers.
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Installing Generic PPDs in OS X 10.1 or 10.2 
Environments
You must have administrative rights to place the PPDs in the necessary directory.

To install PPDs in OS X 10.1 or 10.2 environments:

1 Insert the CentreWare Printer Drivers CD into the CD ROM drive.

2 Double-click the CD icon to open it.

3 Open the OS9.x_Custom folder.

4 Open the GenericPPD_<printer_name>_Mac folder.

5 Select the Xerox PPDs that match the printers being installed from the  
.../OS9.x_Custom/GenericPPD_<printer_name>_Mac folder on the CD.

6 On the hard drive, open the Library folder.

7 Open the Printers folder.

8 Open the PPDs folder.

9 Drag the selected icons from the  
.../OS9.x_Custom/GenericPPD_<printer_name>_Mac folder on the CD to the 
[HD]:/Library/Printers/PPDs folder.

10 The PPDs are installed and ready to be set up using the Print Center.

NOTE: For example, PPDs for the DocuColor 8000 are in the  
.../OS9.x_Custom/GenericPPD_8000_5252_2045_2060_6060_Mac folder.
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Setting Up and Configuring Generic PPDs  in  
OS X 10.1 or 10.2 Environments

To set up and configure generic PPDs by using the OS X Print Center:

1 Double-click on the hard drive icon.

2 In the open window, select the Applications folder.

3 Select the Utilities folder.

4 Select the Print Center icon.

5 Select Add Printer....

6 Select the type of protocol (AppleTalk, etc.).

7 Select the correct zone.

8 Choose the printer to set up.

9 Select the printer model (Choose the PPD for your printer).

10 Select Add.

11 Close the Print Center.

12 Open a document and select File > Print to test the connection.
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Installing the Xerox Job Ticket PlugIn
The Xerox Job Ticket PlugIn is not required to print to a Xerox production printer. 
However, the plug-in is required to utilize the production printer’s full feature set.

To install the Xerox Job Ticket PlugIn:

1 Insert the CentreWare Printer Drivers CD into the CD ROM drive.

2 Double-click the CD icon to open it.

3 Double-click the folder for the Xerox system.

4 Open the OS9.x_Custom folder.

5 On the hard drive, open the System Folder.  (Open the folder titled System Folder, 
not the folder titled System.)

6 Open the Extensions folder.

7 Open the Printer Descriptions folder.

8 From the OS9.x_Custom folder, open the AdobePS PlugIn folder.

9 Select the Xerox Job Ticket PlugIn icon.

10 Drag the Xerox Job Ticket PlugIn icon to the Printer Descriptions folder in the 
Extensions folder.

11 Drag the CD icon to the trash can icon, then release it. The CD is ejected.

12 Use the Desktop Printer Utility to set up and configure the printers.
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Configuring the Printers
After installing the AdobePS driver, PPDs, and Xerox Job Ticket PlugIn, use the 
Adobe Desktop Printer Utility to set up and configure the printers for use with 
applications and XDS. The following instructions assume that a network printer 
communicates with the Macintosh using either AppleTalk or LPR.

To configure a printer with the Adobe Desktop Printer Utility:

1 In the workstation hard disk directory, open the Adobe PS Components folder.

2 Open the Desktop Printer Utility. The New Desktop Printer dialog box appears.

3 If the Desktop Printer Utility does not open to a new printer dialog box, select 
File > New from the pull-down menus on the workstation menu bar.

4 From the With pop-up menu, select AdobePS.

5 In the Create Desktop... scrolling list, select either Printer (AppleTalk) or 
Printer (LPR), depending on which protocol the network is using. Select OK.

6 Click the Change button associated with PostScript Printer Description (PPD) 
File to select a PPD.

7 Scroll to the bottom of the printer list, and select the appropriate Xerox printer.

8 Click Select.

9 Close the Desktop Printer Utility.

10 Click the desktop printer icon to select the printer as the system default.

11 Open a document and select File > Print to test the connection.
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Installing XDS
This section explains how to install the Xerox Document Submission (XDS) 
application, using the CentreWare Printer Drivers CD. 

Installing the XDS Software

To install the XDS software:

1 Delete any existing Xerox Document Submission client software by selecting the 
icon, then dragging it to the Trash.

2 Delete the Xerox Printer Preferences file from the Preferences folder.

3 Insert the CentreWare Printer Drivers CD into the CD ROM drive.

4 Double-click the CD icon to open it.

5 Open the OS9.x_Custom folder.

6 Open the XDS folder.

7 Drag the XDS 4.x icon from the XDS folder to the desired location on the 
workstation, then release it.

8 Close all of the windows that are open from the CD. Drag the CD icon to the 
Trash, then release it. The CD is ejected.

9 Double-click the XDS 4.x icon to open it.

10 Select OK. The Document Submission window opens. Use this utility to 
assemble and submit print jobs.

Use the Desktop Printer Utility to configure the printers for the application prior to 
submitting a document. See Configuring the Printers on page 3-11. 

NOTE: To configure the printers and to print documents using XDS, you need to 
install the AdobePS 8.8 printer driver.
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Installing Additional Products
If printing to additional supported printers, their configurations may be added to an 
XDS installation.

To add products to an XDS installation:

1 Open the XDS icon.

2 From the XDS Splash screen, select OK. The Document Submission window 
opens.

3 Select Options > Product Configuration from the pull-down menus.

4 Select the check boxes for the additional products that will be used, then click 
OK.

5 Close the Document Submission window.
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Uninstalling Printer Drivers and PPDs
Uninstalling printer drivers and PPDs requires deleting them from the system 
manually. Always uninstall existing drivers prior to installing updated versions.

 To uninstall the printer drivers and PPDs:

1 Select Chooser from the Apple menu, and ensure that the printer driver to be 
deleted is not the default driver.

2 Drag the desktop icons for the printers to be deleted to the Trash.

3 Drag the XDS icon to the Trash.

4 Open the System Folder and double-click Printing Plug-ins. Locate the files 
specific to the Xerox system or to the AdobePS driver. 

5 Select the files to be removed and drag them to the Trash.

6 Open the Printer Descriptions folder located in the Extensions folder, and select 
the PPD files for the Xerox system.

7 Move the file to the Trash.

8 If there is a Xerox Printing Preferences file in the Preferences folder, drag that 
icon to the Trash. 

9 Empty the Trash.

The driver uninstallation is complete.

NOTE: On a Macintosh running OS X 10.1 or OS X 10.2, the PPDs are in the 
[HD]:/Library/Printers/PPDs folder.
3-14 Installing Generic Printer Drivers



4

Problem Solving

Application, device, and network errors can occur in a variety of printing situations. 
In many cases, simply restarting the application, the workstation, or the printer will 
resolve the problem.

What’s in this chapter:

Troubleshooting a Problem . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4-2
4-1



Troubleshooting a Problem
When a problem persists, document the error messages and gather information to 
define the problem. The following problem-solving procedures are recommended:

Accurately define the problem. When, where, and how does the problem occur?

Reproduce the problem. Can the problem be reproduced consistently or is it an 
intermittent problem?

Ask other users if they have encountered the problem, and keep a log to track 
problem occurrences. 

Examine the data for trends and the common attributes that may be related to the 
problem. For example, does the problem occur only with a specific printer or on 
a specific workstation/network configuration?

Review the product documentation, including the README files and the 
Problem Solving topics, to see if any similar problems are documented. 

If a cause and solution to the problem cannot be identified, call the Xerox Welcome 
Center to report the error information. Provide the support representative with the 
documentation that you have gathered to define the problem.
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