DocuColor 240/250 with built-in Fiery controller

DocuColor 240/250 with built-in Fiery controller Support & Drivers

Supported Platforms: Mac OS X 10.5 or lower

Supported Languages: Brazilian Portuguese, Danish, Dutch, English (Global), English (N. America), Finnish, French, French Canadian, German, Italian, Norwegian, Portuguese, Russian, Spanish, Swedish, Turkish

Supported Products: DocuColor 240/250 built-in controller

File Download: DocuColor 240/250 PostScript Printer Description (PPD) for Version 1.2 of EFI Controller

Contains only the PPD( DocuColor 240-250 PS v1.2), in multiple languages. For use with PageMaker and othe programs requiring the PPD.

Click "Start" to download

Start