DocuColor 2060 with Fiery EX2000

DocuColor 2060 with Fiery EX2000 Support & Drivers

Supported Platforms: Mac OS X 10.5 or lower, Macintosh 7, Macintosh 8, Macintosh 9, Windows 2000, Windows 95, Windows 98, Windows Me, Windows NT 4.0, Windows XP

Supported Languages: English (Global), English (N. America)

Supported Products: Fiery EX2000

File Download: Fiery EX2000 ICM files

ICM Color Profiles. For both MAC and PC For the DocuColor 2045/2060 with EX2000.

Click "Start" to download

Start