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1 Getting Started 
There are four ways to start working on a Workflow in Asset DB. You can create a new Workflow 

for an existing project, import a project via data import, open an existing project or synchronise an 

existing project with Asset DB Cloud. Please refer to the Auditor manual in order to learn more 

about Asset DB Cloud. 

  

1.1 Creating a New Workflow 

 

To create a new Workflow, first either create a new Asset DB project or open an existing one then 

select Workflow > Add Workflow as shown in Figure 1. 

 

 

Figure 1. Add new Workflow 

A new Workflow tab will be displayed to the right of the Data Preparation tab as shown in Figure 

2.  

 

Figure 2. Overview of new Workflow 

Once a new Workflow has been created via the menu in the top bar, you can add further 

Workflows to the project by using the  button in the Organisation Console in the top right 

corner. 



Workflow User Manual 

 

 - 2 -  Asset DB v4.8.1 

1.2 Importing a Workflow Project 

If an Asset DB project file with Workflow has been supplied, it is imported by selecting File > 

Import > Project1  and navigating to the supplied file. Asset DB project files have the extension 

“.atd”. Importing the project will automatically import any associated Workflows. 

 

 

Figure 3. Import Project with Workflow 

Note: As for any project in Asset DB, Import Project should only be used for loading new or 

backup project files rather than each time the application is used. For day to day use of an 

existing project, use Open Project instead. 

 

1.3 Opening an Existing Project and associated Workflow 

 

To open an existing project with a Workflow, select File > Open or click the Open Project button 

at the top left. This will open a dialogue box which contains a list of available projects. Select the 

desired project from the list and click OK to open.  

 

1.4 Organising Workflow Projects  

An Asset DB project can have multiple Workflows associated with it. The organisation console in 

the top right corner of the workspace shows all Workflows which have been created for the 

project. To navigate between the different Workflow projects simply click on the desired Workflow 

in the Organisation Console (see Figure 4 below). 

Workflows can be added, duplicated or deleted using the buttons in the tool bar at the top of the 

Organisation Console.  

 

 

1 Import of .atd files is not available with all licence types 
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Figure 4. Workflow organisation console 

 

The same functions are available in the top menu as displayed in Figure 5 below: 

 

Figure 5. Workflow section in top menu 

 

A duplicated Workflow is automatically added to the same project. This saves time as particular 

features do not need to be created multiple times. 

  

 

Duplicate 
Workflow 

Add new 
Workflow 

Delete 
Workflow 
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2 Workflow Overview 
The centre section of the Workflow tab has two main views; the Flowchart View and the Macro 

View. The Flowchart View shows each step of each mapped process while the Macro View 

summarises Workflow strings in the form of a cog wheel to give a clearer overview of the 

situation. 

 

3 The Flowchart View 
Within the Flowchart View key characteristics of the Workflow can be entered in the Details panel, 

on the left of the workspace. Steps and symbols are added to the Workflow via the Tool Console. 

In addition, the Workflow Navigation panel in the bottom right corner allows any user to easily pan 

to the Workflow section of interest while zoomed in.  

 

 

 

Figure 6.  Workspace Overview: Flowchart view  

Details Console Organisation Console 

Workflow Navigation 
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Zoom Control 

Steps and 

Symbols 



Workflow User Manual 

 

 - 5 -  Asset DB v4.8.1 

3.1 Workflow Details 

 

The left panel provides space for all necessary information regarding the Workflow, such as 

Workflow name, business function, project completion status, a description and entry and exit 

criteria.  

Lists of Systems and Documents used in the process being mapped can also be captured and 

used throughout the process mapping procedure. An additional field is available to capture the 

different processes to be identified. 

The colour representation of the Workflow in the Organisation Console can also be changed in 

this area. 

 

 

Figure 7.  Workflow details 

These details, including the Workflow name, can be accessed by moving the bar down. They can 

be amended at any time by selecting the Workflow in the Organisation Console, modifying the 

field in the Details fields and then clicking Update.  
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3.2 Adding New Steps to the Workflow 

 

Workflows are made up of a sequence of Steps and Symbols that represent actions within the 

process. The Asset DB Workflow module provides a number of pre-designed steps in the Tool 

Console. 

A tooltip explaining what step type each icon represents can be seen by hovering over the icon. 

 

 

Figure 8.  The Tool Console 

 

New steps are added to the Workflow in three different ways: 

a. Double-clicking on the step in the Tool Console, the new step will then be placed in the 

Flowchart view of the Workflow tab and will be automatically linked to the last step in the 

current flowchart.  

b. Left-clicking on the step so that it is “glued” to the cursor and then clicking again in the 

desired location on the Flowchart view. Steps added in this way will not be automatically 

linked to any other steps.  

c. Copying Existing steps via the Workflow menu in the top bar or via right-clicking on the 

mouse cursor and selecting “Copy Step”. A duplicated step can be pasted into the 

Flowchart view by selecting “Paste Step” via the Workflow menu in the top bar or via right 

mouse click. 

Linking of steps is covered further in section 3.5. 

Once the step has been added to the Flowchart the Details panel will update to show a number of 

tabs of information that can be entered for that step type. The fields of information to be entered 

and therefore the tabs in the details panel will change depending on the step chosen. Details on 

adding and changing information in this panel can be found in section 3.3 
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Each step will be automatically given a unique identifier which cannot be changed manually. The 

unique identifier is displayed in the Step Details under the Default tab, as well as under the step 

icon in the Flowchart. 

 

 

 

Figure 9.  Add steps to the Flowchart 

 

Each Step that is added to the Flowchart will have a coloured border to signify the category of 

Step. Standard symbols have a blue border, Wait Steps  will have an orange border and 

Transit  and External  Steps have a grey border to represent that they are external 

processes.  

 

Figure 10 below shows each of the default step types. 

Unique Identifier 



Workflow User Manual 

 

 - 8 -  Asset DB v4.8.1 

 

Figure 10. Colour range of available steps in the Flowchart field 

 

Steps that have not been linked to another Step (see section 3.5) can be moved by simply 

hovering over it until the mouse becomes a Size All cursor . Then left-click on the symbol and 

drag the step to a different position in the flowchart. 

 

3.3 Adding and Changing Information to the Workflow steps 

 

As mentioned in section 3.2 various pieces of information can be added to the steps. This is done 

via the Details Console which is located in the top left corner. 

To add or change data for a step simply select the step in the Flowchart. A description of the data 

to be entered into each field can be shown by selecting the question mark button next to each 

field. 

 

1. The Default tab contains fields regarding the key details of a Step, such as a description, 

the name of the owner2, the duration of the step and any documents or systems involved. 

To save any information entered or changed click the Update button.  

 

 

2 To add an owner to a step, users must have been mapped in the Current State of the project. 
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2. The Participants tab is used to add information about the people or groups of people who 

are involved in this process3. Click on the Edit button  in theParticipants tab in order to 

add users or user groups. 

 

 

Figure 11. Adding users and user groups to a step 

 

3. The Costs tab contains fields to which Labour, Material, Service and Other Costs can be 

added by selecting the button as shown in Figure 12. To delete costs, select the bin 

symbol . 

 

 

3 In order to add participant information to a Step, users must have been mapped in the Current 

State tab. 
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Figure 12. Adding or deleting costs in the Costs tab 

 

4. The Assets tab is available for certain steps, such as Print or Copy. It is possible to add 

project assets to this step or to remove them if necessary by using the button and then 

selecting or deselecting assets from the list. 

 

 

Figure 13. Adding or removing assets to a step in Workflow 

 

5. The Analysis tab allows the user to determine whether a step forms part of the shortest, 

typical or longest path of the flowchart. It is possible to select more than one option here. 

In addition, the step can be marked as Customer, Business or Non- Value Add in the 

Analysis tab. This selection will then add an additional border to the step to represent its 

Value-Add status:  

•  Not applicable – no additional border  

• Customer Value Add – Green additional border 

• Business Value Add – Orange additional border 

• Non-Value Add – Red additional border 

The default setting is “Not applicable” and can be modified on an individual basis. 
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Figure 14. Selecting “Typical path”, “longest path” and “Value Add: Customer” in Workflow 

 

 

3.4 Adding Symbols in Workflow 

 

Symbols are used to signify indicate the start and end of the flowchart as well as any breaks in 

the flowchart.  Click on the Symbols tab in the bottom left corner to review the available elements 

in a Workflow project. 

 

Figure 15. Available symbols in Workflow 
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There are currently five different symbols available: The first ones mark the start and the end 

of a project. Like for the steps, a description and notes can be added to these symbols. It is 

possible to add more than one connector to exit a step. This is shown in the screenshot below: 

 

 

 

Figure 16. More than one connector is allowed to exit a step 

 

Symbols for Go-to  and  Label  are also available. 

They are added in the same way as the different Step icons explained in section 3.2.  

 

Users can select the Go-to and Label symbols to break up a longer linear chain and to re-arrange 

a workflow as in Figure 17 below.  
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Figure 17. Breaking up a linear workflow into smaller parts 

 

In order to re-arrange a longer chain and to break it down into smaller parts, a Go-to symbol at 

the end of a chain can be added. In a second step a “Label is placed at the top of a new part. 

Both parts are connected by dragging the mouse cursor from the Go-to symbol to the Label. 

 

The last icon in the Symbols tab, which consists of three dots as illustrated underneath the 

‘Meeeting’ step in Figure 17, allows the user to add information about any interview that was used 

to create the Workflow. This symbol can be added to any individual step if appropriate. 

It’s possible to add a description and notes, for example a link to the existing interview. 
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3.5 Linking Steps in Workflow 

 

Steps can be linked in the flowchart in several ways: The first one is to hover over the centre of 

an icon in the flowchart. The mouse will change from the pointer to a hand and the selected step 

will get a pink outline. In this mode you will be able to drag new lines between the different step 

icons. 

. 

 
Figure 18. Dragging a line from one step to another. 

 

A connection between two steps performed by the same user will be black. Where a handover 

occurs (a change of user) this will have a red arrow. Any step after the Decision step will be 

dashed. 

 

It is also possible to add details to the connector. After two steps have been connected, the label 

for this connector can be edited in the upper left field of the Workflow workspace. If any existing 

connectors need to be edited the users canthe user can single double click on the connector and 

add additional information to the label. Figure 19 below illustrates this: 

 

 
Figure 19. Adding information to a Workflow step connector. 

 

 

3.6 Inserting Steps to existing structures in Workflow 

 

Click and drag an unconnected step onto a connector line (the connector will turn blue) in order to 

place it in between the two existing steps. 
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Figure 20. Dragging a step between two existing steps 

 

3.7 Deleting Steps in Workflow 

 

There are three ways to delete individual steps from a Workflow project. Once a step has been 

added to a Flowchart, the Delete Steps symbol in the top bar becomes available. 

A Delete Step option will also become available in the Workflow menu as shown in Figure 21. 

 

Figure 21. Deleting individual steps in Workflow from the top bar 

 

The final way is to right-click on an existing step and to select Delete Workflow. 
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Figure 22. Deleting individual steps with right-click 

  

3.8  Exporting a Flowchart 

 

To export a Flowchart select Workflow > Export Flowchart. This will enable you to export a PNG 

image. 

 

 

Figure 23. Exporting a Flowchart from the top bar 

 

Alternatively, right-click anywhere on the workspace and select Export Flowchart. This will also 

export the entirety of the Flowchart for the Workflow selected in PNG format. 

 

 

Figure 24. Exporting a Flowchart by right-clicking the mouse 

 

3.9 Exporting Workflow Data 

 

It is also possible to export Workflow data as an Excel file by selecting Workflow > Export > 

Export Workflow Data. Each Workflow field is a column header with each step of the Workflow in 

a separate row. 
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Figure 25. Exporting Workflow Data in Excel 

4 The Macro View 
The second view in the Workflow tab is the Macro view. It is represented by a cog to the right of 

the Flowchart symbol. The Macro view can be used as a review tool: It helps identifying cost-

intensive processes and provides an overview of the different processes that are associated to 

individuals or groups. 

  

 

Figure 26. Workspace Overview: Macro view 

 

Processes that are linked to an individual user or a user group are displayed in a vertical order. A 

black arrow connects two different processes. Dashed arrows appear after each decision step. A 

red arrow indicates a change of owner. All owners of a process are arranged from left to right.  

 

It is possible to navigate within the Macro view via the Workflow Navigation panel in the bottom 

right corner. The zoom is available via the mouse and touchpad, and via the zoom function in the 

top right corner. Use of the Navigation panel is explored in further detail in section 6.2. 

 

 

Organisation Console 

Workflow Navigation 

Macro View 

Workflow Details 

Zoom 
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4.1 The Cogs  

 

The cogs bundle Workflow strings made up of several steps into one Cog. The first number in the 

top left corner is the unique number assigned to the cog. The second number on the top right 

corner refers to the number of steps involved in this section of the Workflow. The name of the cog 

which is displayed in its centre can be changed by double-clicking on in. This is described further 

down in this section.  The numbers in the lower corners of the cogs show the costs and duration 

of the section of process represented. 

The cogs are linked by arrows indicating either a change of owner or a change of department, 

depending on the view selected. Please refer to section 4.2 for more information regarding the 

various options of a Macro view. 

 

 

 

 

Figure 27. The Cog 

 

You can access the more complete version of the information summarised 

by the cog in two ways -either by double-clicking on it or by right-clicking and selecting Show Cog 

Sequence. 

 

This will open the Cog Details dialogue box. Here you can view the Workflow steps represented 

by the cog with their connectors. A legend located on the right-hand side gives the names of all 

the steps involved next to their symbols. You can change the name of a cog by entering it into the 

Cog Name field at the bottom of the dialogue box. Click Update in order to apply the changes as 

shown in Figure 28. 
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Figure 28. The Cog Details View 

 

4.2 Choosing what to Display in Macro View 

 

There are different options which determine how the cogs are organised in the Macro View. Click 

on the  button to display the list.  

 

Figure 29. Macro View Options 

 

The two handover options determine what sequence of steps make up each cog. Choosing 

“Handovers by owner” means that consecutive steps by the same owner will be grouped together 

into a cog, while “Handovers by department” means that the steps will be grouped by department. 

Change Your Cog 

Name Here 
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In order to have meaningful groupings in these views it is necessary that steps be assigned to 

owners and that these owners belong to a department in the Current State (they have the 

Department field filled in). Please refer to section 3.2 for more information regarding the owner of 

a process. For more information regarding the departments please refer to the Asset DB Auditor 

manual. 

 

Where a Workflow is large and has many parallel paths it can be clearer to view them a few at a 

time instead of all at once. This can be done by selecting to view just the Typical Paths, the 

Shortest Paths, the Longest Paths, Paths 1 or Paths 2. For any cogs to be displayed in any view 

other than “All Paths”, path details must have been added to the Analysis tab for each step of the 

Workflow. 

 

4.3 Exporting Macro View 

 

In order to export the Macro view select Workflow > Export > Export Macro Process View. This 

will export the Macro View as a PNG image file, see Figure 30 below. The exported image will 

show all the cogs in the Workflow regardless of any specific Macro View Options previously 

selected. 

 

 

Figure 30. Exporting the Macro View 

 

5 The Current State Tab 

5.1 Workflow in the Current State tab 

In order to see Workflow elements in the Current State tab the processes need to have been 

linked to mapped users or user groups by setting owners for the steps. 

The display options can be changed by following the instructions in section 6.1.  
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As a default setting, all Workflows are set as visible in the Current State. This can be changed via 

the Filter option in the Current State tab. It is possible to select all Workflows, to select individual 

ones or to de-select all Workflows. The same filter can be set for the different paths that have 

been added with the Workflow steps. This is illustrated in the following Figure 31. 

 

 

Figure 31. Filtering Workflows and Paths in the Current State  

 

5.2 The Workflow Petals 

 

Selecting a plotted person or person group in the Current State View displays their associated 

Workflow activities in the form of Workflow Petals. 

The Workflow petals provide various pieces of Workflow related information directly in the Current 

State tab.  

The different petals show the amount of time the user has spent on Workflow processes, how 

many Workflows they are involved in, the number of steps they carry out, the total costs 

associated with those steps and the number of documents involved. Users who interact in the 

course of a Workflow process are connected by a line. A fine line indicates a unilateral interaction 

while a thicker line indicates a bilateral one. Hovering over a user or group shows the direction of 

the information stream in the form of an animated dotted line.  
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Figure 32. The Workflow Petals and Information Stream 

 

Please refer to section 6.1 for how to change the colours and how to switch the animations on or 

off. 

6 General 

6.1 Display Options 

 

The display options for the Workflow petals in the Current State can be amended by selecting 

Options > Display Options and then going to the Workflow tab. Here all options can be changed 

as shown in Figure 33 below. Among others, it is possible to decide if handovers, animations and 

asset links should be displayed and whether the colour displaying handovers should change. The 

default colour is purple and orange for handovers but it can be changed to any other colour 

available in Asset DB. Moreover, it is possible to select different colours for the handovers, asset 

links, and the petals background and foreground. 
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Figure 33. Overview: Default display options for Workflow 

 

6.2 Navigating in the Flowchart and Macro Views 

 

Some Workflow projects tend to be rather large. Therefore the outline window in the bottom right 

corner will help you to navigate within the Flowchart and Macro views.  

Users can click within the blue frame and the mouse will change into a Size All cursor .  It is 

now possible to drag the blue frame to a different area in order to view it. 
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Figure 34. Navigating in the Flowchart view 

 

The same functionality is available in the Macro view, as shown in Figure 35 below. 

 

 

Figure 35. Navigating in the Macro view 
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It is also possible to zoom in and out by using the Navigation window. Hover over the bottom right 

corner of the blue frame so that the mouse changes into a pointing hand cursor . Click and 

drag the corner of the frame in or out to enlarge or minimize the Flowchart or Macro views. 

 

6.3 Setting a Workflow project as Complete 

 

When Workflows are created, they have a symbol showing a white triangle in an orange circle to 

the right of their names. In order to set a Workflow process as complete and update this triangle 

symbol, one can select the Flowchart view and then select the Workflow from the list in the right-

hand panel (see Figure 36 below).  

 

 

Figure 36. Reviewing the status of a Workflow project 

 

It is now possible to navigate to the Workflow Details panel on the left side of the screen and to 

tick the box saying Complete. Once you click Update, the triangle symbol next to the Workflow 

name will change to a green tick, as displayed in Figure 37. 

 

 

Figure 37. Setting a Workflow project as Complete 

 

6.4 Activating the Workflow licence 

 

Before activating your Workflow licence, you must have activated your Auditor, Analyst or 

Architect licence using the Asset DB Online Licencing System (OLS).  

In the top menu of Asset DB, go to Help > Licensing > Activate. Then copy the serial number in 

the pop-up window by clicking the “…” button. Do not close the window. 

Paste the serial number into an email and send it to your Support Team requesting a Workflow 

licence. When you receive your response back from the team, copy your licence key from the 

email.  Return to Asset DB. If you still have the Activate pop-up open, go to Help > Licensing > 

Activate. Paste the licence key (using CTRL+V) into the Asset DB pop-up window and click OK. 

This will activate your Workflow licence. 


