Passer directement au contenu principal Cliquez pour consulter notre Déclaration d'accessibilité, ou contactez-nous pour toute question relative à l'accessibilité.

WC 3210 Drivers and Utilities

Description

Earlier driver versions MUST be uninstalled before installation of these print drivers.
These drivers require minimum firmware version of 2.50.00.95.
Firmware version 2.50.00.95 and higher requires use of these drivers.

Installation package includes PCL6, PS, and TWAIN/WIA drivers. Also includes PCFax, Printer Settings Utility, SetIP Utility, and Status Monitor.

Supported platforms

  • Windows Server 2008

Supported languages

  • Arabic
  • Bulgarian
  • Czech
  • Danish
  • German
  • Greek
  • English (N. America)
  • English (Global)
  • Spanish
  • Finnish
  • French
  • French Canadian
  • Hungarian
  • Italian
  • Dutch
  • Norwegian
  • Polish
  • Portuguese
  • Brazilian Portuguese
  • Romanian
  • Russian
  • Slovenian
  • Slovakian
  • Swedish
  • Turkish
  • Ukrainian

Supported products

  • WorkCentre 3210/3220

Besoin d’une aide supplémentaire ?

Rejoignez le forum de support de la communauté

Participer à la conversation
Participer à la conversation
Participer à la conversation