Skip to main content

Windows PostScript PPD Driver Files

Description

Optional Windows 2000/XP/2003/2008/Vista/Windows 7 32-bit PostScript PPD driver files for the Phaser 6360. Microsoft WHQL Certified.

Supported platforms

  • Windows 7
  • Windows Server 2008
  • Windows Server 2003
  • Windows Vista
  • Windows XP
  • Windows 2000

Supported languages

  • English (N. America)
  • English (Global)

Supported products

  • Phaser 6360

Need more support?

Get answers in the Community Support Forum

Join the conversation
Join the conversation
Join the conversation