Skip to main content

MAC OS 9.x/8.x client driver for EX12 v2.0 running Service Pack 2(SP2)

Description

The EX12 MUST be running version 2.0 SP2. If not, you may receive unexpected results or errors.
Fiery EX12 v2.0 SP2 AdobePS Printer Driver for Macintosh 8 and 9

Supported platforms

  • Macintosh 9
  • Macintosh 7
  • Macintosh 8

Supported languages

  • English (N. America)
  • English (Global)

Supported products

  • DocuColor 12 Copier/Printer
  • DocuColor 12 Printer
  • Fiery EX12

Digital Front End

  • Fiery EX12

Need more support?

Get answers in the Community Support Forum

Join the conversation
Join the conversation
Join the conversation