Skip to main content

Software update to address cross site scripting vulnerability

Description

The Firmware Update Tool is supported by the Windows Operating System only.
Xerox has provided an executable file to fix a persistent cross site scripting vulnerability that exists on the 4110, 4590, and 4595 Copier/Printer. If exploited this vulnerability could allow code injection by malicious web users into the web pages viewed by other users. Customer and user passwords are not exposed.

Supported platforms

  • Windows Server 2008
  • Windows Server 2003 x64
  • Windows Server 2003
  • Windows Vista
  • Windows Vista x64
  • Windows XP
  • Windows XP x64
  • Windows 2000

Supported languages

  • German
  • English (N. America)
  • English (Global)
  • Spanish
  • French
  • French Canadian
  • Italian
  • Dutch
  • Brazilian Portuguese

Supported products

  • Xerox 4110 Copier/Printer
  • integrated Copy/Print Server
  • Xerox 4590 Copier/Printer
  • Xerox 4595 Copier/Printer

Digital Front End

  • integrated Copy/Print Server
  • integrated Copy/Print Server

Need more support?

Get answers in the Community Support Forum

Join the conversation
Join the conversation
Join the conversation