Skip to main content Click to view our Accessibility Statement or contact us with accessibility-related questions.

PostScript Driver - 64-bit

Description

Caution: Earlier driver versions MUST be uninstalled before installation of these print drivers. These drivers require minimum firmware version of 1.70.02.40. Firmware version 1.70.02.40 and higher requires use of these drivers.
64-bit PostScript Driver for the Phaser 3600. Supports Windows Server 2003 x64, XP x64, and Vista x64. This driver uses the Add Printer Wizard. WHQL Certified.

Supported platforms

  • Windows Server 2003 x64
  • Windows Vista x64
  • Windows XP x64

Supported languages

  • English (N. America)
  • English (Global)

Supported products

  • Phaser 3600

Need more support?

Get answers in the Community Support Forum

Join the conversation
Join the conversation
Join the conversation