Skip to main content Click to view our Accessibility Statement or contact us with accessibility-related questions.

Phaser 3600 Linux Driver

Description

Earlier driver versions MUST be uninstalled before installation of these print drivers.
These drivers require minimum firmware version of 1.70.02.40.
Firmware version 1.70.02.40 and higher requires use of these drivers.

Linux Postscript driver

Download

End User License Agreement

Supported platforms

  • Linux

Supported languages

  • Catalan
  • Danish
  • German
  • Greek
  • English (N. America)
  • English (Global)
  • Spanish
  • Español (CO)
  • Finnish
  • French
  • French Canadian
  • Hebrew
  • Hungarian
  • Italian
  • Dutch
  • Norwegian
  • Polish
  • Brazilian Portuguese
  • Russian
  • Swedish
  • Turkish

Supported products

  • Phaser 3600

Need more support?

Get answers in the Community Support Forum

Join the conversation
Join the conversation
Join the conversation