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1. Introduction 

This chapter describes Xerox Web Document Submission Software 
Version 2.1 and how to use this guide. 

Xerox Web Document Submission Software 

Web Document Submission allows end users to submit print jobs 
electronically using industry standard browsers. Once submitted, 
production personnel efficiently update job status as documents move 
through the production cycle, providing users with information about their 
jobs. Web-based printing generates cost savings and improvements in 
quality, productivity, and turnaround time. 

The system uses several services that can be loaded on one or more 
servers, depending on the print shop configuration. 

Intended Audience 

This manual is intended for use by personnel who are responsible for the 
administration of the Web Document Submission system.   

Assumptions 

The person administering Web Document Submission should have 
experience in the following areas: 

• Web Document Submission  
• Windows 2000 server administration  
• Applicable workstation operating systems experience 
• Hypertext Markup Language (HTML) 
• Extensible Markup Language (XML) 
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• JavaServer Pages (JSP) 
• Structured Query Language (SQL) 

Conventions 

This guide uses the following conventions:  

• Menu items and buttons appear in bold text. 
• Screen, text box, and drop-down list titles are spelled and 

punctuated exactly as they appear on the screen.  
• Document titles appear in italics. 
• Content representative of text that is displayed on a computer 

monitor is displayed in Courier New font and enclosed in a shaded 
table as shown in Table 1-1. 

Table 1-1. Example of text displayed on a computer monitor 

INSERT INTO Field {field_name,custom_name} 

 

Related Documentation 

The following manuals provide further information on the  
Web Document Submission system: 

• Xerox Web Document Submission Software Version 2.1 
Installation Planning Guide – Part Number 701P39392 

• Xerox Web Document Submission Software Version 2.1 –  Adobe 
PDF Transit Installation and Configuration Supplement (Optional) 
– Part Number 701P39393 

Note: Operator / Administrator and User instructions are available as 
online help while using the Web Document Submission system. 
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2. Product Overview 

Web Document Submission is a web-based application used to submit and 
track jobs.  

System users access the software via three web interfaces: 

• A User interface for submitting print jobs 
• An Operator interface for printing jobs 
• A Printer Administrator interface for setting up printers and 

templates, customizing the user interface, and establishing pricing 

Responsibilities 

System Administrator 

The System Administrator manages user, operator, and print shop 
administrative permissions for a print shop installation. Specific tasks 
include: 

• Managing Web Document Submission software 
• Customizing the Web Document Submission user interface  
• Managing user / operator permissions for a single print shop 

The System Administrator will have a detailed understanding how the Web 
Document Submission software works. 
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Print Shop Administrator 

The Printer Administrator is a user who manages a print shop. Specific 
tasks include: 

• Establishing specific print shop policies 
• Configuring printers 
• Generating reports using Web Document Submission tools 
• Load pricing data into Web Document Submission 

The Print Shop Administrator must understand how to configure a printer 
and how printer communications work. 

Print Shop Operator 

The Print Shop Operator is a user who manages the printing workflow in a 
print shop. Specific tasks include: 

• Printing jobs sent by end users 
• Modifying the job status as jobs move through the workflow 
• Distributing printed materials 

The Print Shop Operator must have detailed knowledge of scheduling and 
prioritizing print jobs as well as a solid understanding of the capabilities 
and capacities of the print shop. 

User 

The User submits documents and jobs to Web Document Submission over 
the Internet using a web browser, the Xpress Print Driver (XPD), the 
optional PDF Transit driver, or through DocuShare.  
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Specific user tasks include: 

• Using Web Document Submission as the interface to the print 
shop 

• Uploading documents into Web Document Submission  
• Requesting printing and conversion services using  

Web Document Submission  
• Converting documents to Portable Document Format (PDF) 

format using Web Document Submission  

The User must be knowledgeable about basic web browser use, general 
Internet use (downloading, uploading, and navigation), and printer driver 
installation. 





 

INSTALLATION AND SYSTEM ADMINISTRATION GUIDE 3-1 

3. Installation Requirements 

Web Document Submission requires a specific combination of hardware, 
software, and information to ensure a successful installation. These 
requirements are documented in the  
Xerox Web Document Submission Software Installation Planning Guide. 

These installation instructions assume that the Web Document Submission 
server has had the proper operating system installed and has a working 
connection to the Internet. 

Hardware Requirements 

Server Requirements 

• One Windows 2000 server 
• 18-GB hard disk  
• 512-MB random access memory (RAM)  
• One 10 / 100 Megabytes per second (MB/s) network interface 

card (NIC)  
• One available drop on a 100 MB/s network  
• Simple Mail Transfer Protocol (SMTP) server supporting 

Anonymous SMTP connections for outgoing mail 
• An uninterruptible power supply (UPS) for the server 

Client Requirements 

• Workstation capable of using a supported operating system and a 
supported browser  
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Software Requirements 

Server Requirements 

• Microsoft Windows 2000 Server 

CAUTION: Ensure that Microsoft Internet Information Services (IIS) are 
disabled on the Web Document Submission server. The Web 
Document Submission server uses Apache as the web server 
software and will not function with IIS installed.  
Consult article Q321141 – HOW TO: Disable or Remove 
Unnecessary IIS Services – on the Knowledge Base section of 
the Microsoft support site (http://support.microsoft.com) for 
instructions on how to stop IIS services. 
 

• Microsoft Office XP  
• Adobe Acrobat Reader 5.x (or later) 
• Web Document Submission software 
• Internet Explorer 5.5 (or later) or Netscape Navigator 4.75 (or 

later)  
• WinZip or equivalent 
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Client Requirements  

Any one of the following operating systems: 

• Windows NT Workstation 4.0 
• Windows 2000 Professional 
• Windows 95 / 98 / ME 
• Windows XP 
• Macintosh OS 9.1.x or OS 9.2.x  
• Adobe Acrobat Reader 5.x (or later) 

• Internet Explorer 5.5 (or later) or Netscape Navigator 4.75 (or 
later) 

• WinZip or equivalent 

Information Requirements 

See the Xerox Web Document Submission Software – Installation 
Planning Guide for a complete list of the information requirements. 
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4. Installing the Software 

Obtain the Xerox Web Document Submission Software Version 2.1 – 
Installation Planning Guide before installing the software. The following 
figure, Figure 4-1 gives an overall look at the workflow for the complete 
installation process. 

Figure 4-1. Web Document Submission installation process 

Installation
process

Gather customer
installation information

Schedule installation

Install software

 Configure and test
software as required

Software training as
required
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When performing an installation, the following, including third-party 
software and printer driver, must be present and properly configured on the 
server before installing Web Document Submission software: 

• Adobe Acrobat Reader 
• PostScript print driver - xwdss-pdfpreview  
• Microsoft Office XP 

It is recommended that the server be assigned a name and physically 
labeled with the applicable name and machine IP address. An example is 
shown in Figure 4-2. 

Figure 4-2. Example server label 
Example label 

Web Document Submission
Server  

IP: xxx.xxx.xxx.xxx 

Display File Extensions 

In order to simplify product installation it is recommended that file 
extensions be turned on. When Windows 2000 is installed file extensions 
are turned off by default. 

Displaying File Extensions 

Perform the following to display file extensions: 
1. Double-click My Computer. Click Tools > Folder Options. 

2. Click the View tab. Locate Hide file extensions for known file types. 
Ensure that the check box is cleared. Click OK. Close all open 
windows. 
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Third-party Software and Printer Driver Installation 

Installing Adobe Acrobat Reader  

The system requires Adobe Acrobat Reader to be installed on the server If 
Adobe Acrobat Reader is not already installed on the Web Document 
Submission server, it must be downloaded from Adobe and then installed. 

Perform the following to install Adobe Acrobat Reader: 
1. Go to http://www.adobe.com and download a copy of Acrobat 

Reader. Choose either the base version, or the version that can search 
PDF files. Either free version will work with Web Document 
Submission. 

2. Follow the instructions from Adobe to install Adobe Acrobat Reader. 

Note: Restarting the server is not necessary at this time. The server 
will be restarted as part of the final installation procedure. 

Adding the Print Driver 

A PostScript print driver is used to convert documents to PostScript before 
they are sent to the printer. 

Perform the following to add a PostScript Driver: 
1. Click Start > Settings > Printers. 

2. Double-click Add Printer. 
3. The Add Printer Wizard appears. Click Next. 
4. The Local or Network Printer window appears. Click Local Printer. 

Clear Automatically detect and install my Plug and Play Printer. 
Click Next. 

5. For the port select File. Click Next. 
6. The list of manufacturers of printers appears. Select Apple as the 

manufacturer and Apple Color LaserWriter 12/600 as the printer. 
Click Next. 
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7. Click Next. The Name your printer window appears. Rename the 
printer xwdss-pdfpreview. 

Note: It is very important to name the driver exactly as shown above.  

8. Click Next > Next > Finish. 

9. Close any open windows. The PostScript printer driver that is used for 
PDF conversions has been installed. 

Installing PostScript Printer Drivers for Print Shop Printers 

Install printer drivers on the Web Document Submission server for all 
printers that the print shop personnel will access. Install only PostScript 
printer drivers since the system will ignore non-PostScript drivers. 

Use standard printer installation procedures to install the drivers. 

Installing Microsoft Office XP 

Microsoft Office XP must be installed in order for print drivers to process 
Office documents. 

Perform the following to install Microsoft Office: 
1. Insert the Microsoft Office XP CD in the CD-ROM drive. 

Note: If the Microsoft Office installation does not begin after inserting 
the CD, follow the instructions distributed with Microsoft Office 
on manually starting an installation.  

2. Start the installation process and choose Typical installation. 

3. Accept all defaults ensuring that Word, Excel, and PowerPoint are 
installed. 

4. Remove the CD from the CD-ROM drive.  

5. Restart Windows when prompted. 
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Post Third-party Software Installation Tasks 

In order for the Web Document Submission system to operate, Adobe 
Acrobat Reader and Microsoft Office must be started to accept license 
agreements. Failure to do so will keep the system from operating. 

Before installing Web Document Submission Start both Adobe Acrobat 
and Microsoft Office. Accept their licensing agreements, activate the 
products, and then close Acrobat and Office Submission. 

Note: Microsoft Office must be activated. Failure to activate the product will 
cause Microsoft Office to reduce features after 30 days resulting in a 
malfunction of Web Document 
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Installing Web Document Submission  

This section gives procedures on installing the core Web Document 
Submission software. Figure 4-3 illustrates the workflow for installing the 
core product. 

Figure 4-3. Web Document Submission software installation workflow 

Manually install and
configure third party

applications
1. Adobe Acrobat Reader
2. PostScript driver for
    conversion:
    xwdss-pdfpreview
3. PostScript drivers for print
    shop printers
3. Microsoft Office

Install Web Document
Submission software

Validate installation
1. Log on as Admin
2. Create User
3. Test UI configuration
4. Submit jobs
5. Test Operator functions

Web Document
Submission Server

Core Installation
Complete

Configure core Web
Documents Submission

1. System E-mail
2. Apache Admin E-mail

Additional Configuration
Consult the Installation and
System Administration Guide
or the Adobe PDF Transit
Installation and Configuration
Supplement
1. User management
2. Configure UI
3. Set system parameters
4. Backup strategy
5. Optional DocuShare link
6. Optional Adobe PDF
    Transit software

Begin Core
Installation
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Web Document Submission Software Installation 

Perform the following to install Web Document Submission software 
on the server: 
1. Insert the Web Document Submission installation CD into the CD-ROM 

drive of the server. 

2. Double-click My Computer.  
3. Double-click the CD-ROM drive where the Web Document Submission 

software appears.  

4. Double-click runInstaller.bat. 
5. A command window appears followed the XWDSS Installation 

window. Click Install. 

 
Note: The XWDSS Installation window may appear behind the 

command window. Minimize the command window to see the 
Installation window. 
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6. The License window appears. Type the supplied license key for the 
Web Document Submission software and click Next. 
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7. Ensure the Select installation directory is correct. The default 
directory is C:\xwdss. If this is not correct, type the correct directory 
path or click Browse to locate the correct folder.  

Note: If the default directory is not chosen, ensure that any new 
installation directory is off the root directory. 

 
The Server address is automatically populated. Ensure this is the 
correct IP address for the Web Document Submission server.  
 
Unless otherwise instructed to do so, ensure that Install as Windows 
Service is selected. 
 
Click Install. 

 

 

Tip: The Command Window will disappear behind the installation window. 
Move the command window in front of the installation window in order 
to monitor the status of the installation. The message BUILD 
SUCCESSFUL will appear several times. This does not mean the 
installation is complete. 
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8. After several minutes, the Installation Complete window appears. 
Click Done and all installation windows will close. 

 

If there were problems and the installation did not complete properly, 
consult the Troubleshooting section on page 24-1. 

Configuring the Web Document Submission Core Installation 

Perform the following tasks to configure the Web Document Submission 
system.  

Set up the xwdss-service System User 

A user must be set up on the server for the Web Document Submission 
system to operate correctly as a service. 

Note: If the Web Document Submission system is being reinstalled, 
the following procedure can be skipped since this user only has 
to be created once on a server. 

To Create a System User for Web Document Submission: 
1. Click Start > Programs > Administrative Tools > Computer 

Management. 
2. The Computer Management window opens. Click + beside Local 

Users and Groups. The menu tree expands.  
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3. Click Users and then right-click users to open the pop-up menu. Select 
New User. 

 
4. The New User window opens. Type xwdss-service in the User name 

box and xwdss-service in the Full name box. 

5. Type 1  for the Password and confirmation password. 

6. Clear User must change password at next logon. 

7. Select User cannot change password. 

8. Select Password never expires. Click Close. 

9. The user appears in the right panel of the Computer Management 
window. Click the icon beside xwdss-service and then right-click to 
open the pop-up menu. 
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10. The xwdss-service Properties window opens. Click the Member Of 
tab. 

11. The Member Of window appears. Click Add. 

12. The Select Groups window appears. Click Power Users and then 
click Add. The path to the Power Users object will appear in the lower 
portion of the window. Click OK. 

13. The window refreshes and shows that xwdss-service is now a member 
of the Power Users group. Click OK. 

14. Close the Computer Management window. 

Associate the System User with Services 

The Web Document Submission software services must be associated 
with the system user xwdss-service. 

To Associate the System User with Web Document Submission 
Services: 
1. Click Start > Programs > Administrative Tools > Services. 

2. The Services window opens. Locate xwdss and right-click to open the 
pop-up menu. Select Properties 
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3. The xwdss Properties (Local Computer) window opens. Click the 
Log On tab. 

4. Under Log on as select This account and click Browse.  

5. The Select User window opens. Select xwdss-service and click OK. 

6. The xwdss Properties (Local Computer) window reappears. Click in 
the Password box, delete any text present, and type 1. 

7. Click in the Confirm password box, delete any text present, and  
type 1. Click OK. 

8. A message appears that “The account .\xwdss-service has been 
granted the Log On As A Service right.” Click OK. 

9. A message appears that “The new login name will not take effect until 
you stop and restart the service.” Click OK. 

Note: The messages in step 8 and 9 only appear the first time the 
service has been granted “log on as service” rights. The 
messages will not appear if the system is being reinstalled. 

10. Right-click Web Document Submission Print Service in the 
Services window to open the pop-up menu. Select Properties 

11. The Web Document Submission Print Service Properties (Local 
Computer) window opens. Click the Log On tab. 

12. Under Log on as select This account and click Browse.  

13. The Select User window opens. Select xwdss-service and click OK. 

14. The xwdss Properties (Local Computer) window reappears. Click in 
the Password box, delete any text present, and type 1. 

15. Click in the Confirm password box, delete any text present, and  
type 1. 

16. Click OK. 

17. A message appears that “The account .\xwdss-service has been 
granted the Log On As A Service right.” Click OK. 
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Note: The message in step 17 only appears the first time the service 
is granted “log on as service” rights. The messages will not 
appear if the system is being reinstalled 

18. Close any open windows and restart the server. 

19. Once the server has restarted, log in as xwdss-service with the 
password 1. 

20. In order for the services to access programs properly, open and close 
Adobe Acrobat Reader, Microsoft Internet Explorer, and Microsoft 
Word. 

21. Log out of the server and log back in as the Administrator. 

Set up E-mail Addresses 

The addresses for the E-mail server and administrator must be configured 
for the Web Document Submission system to operate properly.  

CAUTION: Without these addresses configured, the Web Document 
Submission system will not accept any new users. 

Perform the following to set E-mail server and administrator 
addresses for the system: 

Note: This next set of configuration items deals with E-mail 
properties. Consult the Web Document Submission Installation 
Planning Guide to confirm the required information for this 
section. 

1. If the server was restarted in the last procedure, the system should be 
operational.  

Note: If the system is not operational, click Start > Run. In the Open 
box type net start xwdss and click OK 

2. Open a browser window on a workstation connected to the network or 
on the Web Document Submission server. 

3. In the address line, type the IP address that will point to the Web 
Document Submission Web server. In most cases, it is the IP address 
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of the Web Document Submission server, which hosts the web server 
software. 

http:// <Web Document Submission server IP address>/xdx/admin 
4. Log in with user name Admin and password 22222. 

5. Click Administrator tools > Choose option > Configuration 
manager. 

6. The Configuration manager page opens. Move down the page to the 
E-mail section. 

7. Click Admin E-mail address. Type the Web Document Submission 
administrator E-mail address in place of the default property value. 

8. Click E-mail enabled. Ensure that the value is set to true if users are 
to be notified by the system about the status of their jobs. 

9. Click E-mail footer. Type the text that is appended to the end of every 
outgoing E-mail message. 

10. Click Printshop name. Type the name of the print shop, used in  
E-mails to users in place of the default property value. 

WARNING! Do not use an ampersand (&) or an apostrophe ( ‘ ) in the 
Print Shop name. Doing so will cause the Web Document 
Submission system to malfunction. 

11. Click E-mail server. Type the IP address of the designated E-mail 
server. 

12. Move to the bottom of the page and click Update to save the changes. 

13. Click Log off to log off the system. 

14. Click X to close the browser window.  
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Configure Apache Administrator E-mail Address 

An E-mail link for the system administrator can be set in Apache that 
appears on the error message page if there was a problem with Apache.  

Perform the following to configure the Apache Administrator E-mail 
address: 
1. Click Start > Programs > Accessories > Notepad.  

 

2. Click File > Open. From the Files of type drop-down list select All 
Files. 

3. Go to C:\xwdss\etc\Apache2\conf and double-click httpd.conf. 
4. Search for the line ServerAdmin user@domain.com and replace 

user@domain.com with the System Administrator E-mail address. 

 
5. Save the file, overwriting the existing httpd.conf. 

6. Close Notepad. 
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Testing Web Document Submission  

Once Web Document Submission has been installed, test the software to 
ensure that it is operating correctly. The following steps are only a basic 
test to see if the software is functioning. To test system operations 
completely, consult the Install Verification Procedure chapter in  
Appendix C. 

Testing Web Document Submission  

Log On as a User 

Perform the following to test the Web Document Submission user log 
on: 
1. Open a browser window on a workstation connected to the network or 

on the Web Document Submission server. 

2. In the address line, type the IP address that will point to the Web 
Document Submission Web server. In most cases, it is the IP address 
of the Web Document Submission server, which hosts the web server 
software. 

http:// <Web Document Submission server IP address>/xdx 
3. The initial log on screen appears after several moments. Log on with 

the User name admin and the Password 22222. Submit a job.  

Log On as an Administrator 

Perform the following to test the Web Document Submission 
administrator log on: 
1. Open a browser window on a workstation connected to the network or 

on the Web Document Submission server. 

2. In the address line, type the IP address that will point to the Web 
Document Submission Web server. In most cases, it is the IP address 
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of the Web Document Submission server, which hosts the web server 
software. 

http:// <Web Document Submission server IP address>/xdx/admin 

3. The initial log on screen appears after several moments. Log on with 
the User name admin and the Password 22222. View the job that was 
submitted in the procedure above. 

Shutting Down Web Document Submission  

To shut down the system, first close the XWDSS Admin Tools, if open, and 
then run a network command to shut down Web Document Submission.  

Shutting Down Web Document Submission 

Perform the following to shut down Web Document Submission 
components: 
1. On the server, click Start > Settings > Control Panel > 

Administrative Tools > Services.  

2. Locate and click xwdss in the list of services.  

3. Click the Stop Service icon at the top of the screen  

  
 
A Service Control window will appear and display the progress of the 
service shutdown. When complete, the status of xwdss and its 
companion service Web Document Submission Print Service will be 
blank, indicating that the services have stopped. 
 
The system is now shut down. 
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5. Starting Up and Shutting Down 

Web Document Submission is started and shut down from the Web 
Document Submission server. 

Starting and Stopping Web Document Submission Services 

There are two methods of starting and stopping Web Document 
Submission services: 

• Using the Windows 2000 server Services administrative tool.  
• Using batch files 

The preferred method of starting and stopping the system is using the 
Services Administrative Tool. This chapter will discuss the preferred 
method first, and then give the batch file method. Only use the batch file 
method if instructed by Support. 

Starting Web Document Submission Services 

If installed as a service, Web Document Submission will automatically start 
when the server is started. To check if the system has started, simply open 
a browser window and log on to the Web Document Submission system. 

The instructions that follow illustrate how to start the system if it has not 
started. 

Perform the following to start Web Document Submission as a 
Service: 
1. On the server, click Start > Settings > Control Panel > 

Administrative Tools > Services.  

Tip: Create a shortcut to Services and place it on the desktop.  
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2. Locate and click xwdss in the list of services.  

3. Click the Start Service icon at the top of the screen  

  
 
A Service Control window will appear and display the progress of the 
service startup. When complete, the status of xwdss, Web Document 
Submission Print Service, and Apache will be Started. 

Tip: A quick way to start the services is to click Start > Run and in the 
Open box type net start xwdss-startup. Click OK and the services 
will begin as if you had opened the Services window. 

Stopping Web Document Submission Services 

The instructions that follow illustrate how to stop the system services. 

Perform the following to start Web Document Submission as a 
Service: 
1. On the server, click Start > Settings > Control Panel > 

Administrative Tools > Services.  

2. Locate and click xwdss in the list of services.  

3. Click the Stop Service icon at the top of the screen  

  
 
A Service Control window will appear and display the progress of the 
service shutdown. When complete, the status of xwdss, Web 
Document Submission Print Service, and Apache will be blank, 
indicating that the services have stopped. 
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Tip: A quick way to stop the services is to click Start > Run and in the 
Open box type net stop xwdss-startup. Click OK and the services 
will stop as if you had performed this procedure from the Services 
window. 

Starting and Stopping Web Document Submission Using Batch Files 

The following procedure should be used under instructions from Support. 
Only use this method if services have either been deactivated or shut 
down. 

WARNING! Do not shut down Web Document Submission using a batch 
file if the system was started as a service. Data loss could 
occur. 

Starting Web Document Submission using a Batch File 

Perform the following to start Web Document Submission using a 
batch file: 
1. On the server, double-click My Computer. Go to C:\xwdss\scripts 

and double-click xwdss-startup.bat. 
2. As Web Document Submission services begin, taskbar buttons appear 

on the taskbar to show running processes. Processes started are 
APACHE, MYSQL, RMID, and TOMCAT.  

 
3. Almost instantly, the APACHE button disappears from the taskbar. To 

see any system messages delivered to any of these processes, simply 
click the button to view the window for the desired process. The 
window may have to be resized in order to see the system messages. 
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The following figure, Figure 5-1, describes the components started. 

Figure 5-1. Description of components started with the Control 
Center 

Component Description 

RMID (Remote Method 
Invocation Daemon) 

A utility that Web Document Submission services 
use for activation 

MySQL (Database Server) The database management system that tracks 
users and jobs in the system 

Tomcat (used by Web 
Server) 

Tomcat is a servlet container with a Java Server 
Pages (JSP) environment. A servlet container is a 
runtime shell that manages and invokes servlets 

on behalf of users. 

Apache (Web Server) The web server for the Web Document 
Submission system 

Stopping Web Document Submission using a Batch File 

Perform the following to shut down Web Document Submission 
using a batch file: 
1. If open, close the Control Center by clicking X. 

 
2. Go to C:\xwdss\scripts and double-click xwdss-shutdown.bat. 

All processes close their corresponding command windows and the 
Web Document Submission system stops. 
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6. System Administration Tasks 

This chapter outlines tasks that must take place after installation. Most of 
these are ongoing System Administrator tasks. Figure 6-1 shows the post-
installation process. 

Figure 6-1. Post-installation process 

Post installation
process

1. Add users to the system

2. Customize the User
Interface

3. Establish back up
procedures

4. Set / modify system
parameters

5. Maintain Web Document
Submission system

6. Install XPD on client
workstations
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Adding users to the system  
(Chapter 7 – Managing Users) 

Users must be added to the system and assigned proper Group 
Memberships and Permissions. These tasks are accomplished through the 
User Group Directory (UGD) Admin tool in the  
XWDSS Admin Tools. 

Customizing the User Interface  
(Chapter 8 – Customizing the User Interface) 

As installed, Web Document Submission has a generic user interface. The 
existing interface can be customized by using the User Interface (UI) 
Config tool in the XWDSS Admin Tools. 

Establishing a backup strategy  
(Chapter 10 – System Backup) 

It is important to establish a backup strategy to protect the system and the 
customers using Web Document Submission. The instructions given in the 
System Backup chapter are generic, but provide enough information to 
back up the correct files. 

Setting or modifying system parameters  
(Chapter 12 – Configuring System Parameters) 

The Configuration Manager tool in the XWDSS Admin Tools allows system 
parameters must be modified should the need arise. The Configuring 
Parameters chapter details how to make these changes. 

Creating or Modifying Templates  
(Chapter 14 – Modifying Job Templates) 

The Template Manager tool allows the System Administrator to create or 
modify cover sheet and delivery sheet templates. The templates can be 
modified at any time to meet the needs of a customer 

Maintaining the Web Document Submission System 
(Chapter 11 – Maintaining the Web Document Submission System) 

This chapter outlines some basic file maintenance topics such as 
monitoring the PrintJobs folder. It is the responsibility of the System 
Administrator to ensure the system is operating properly. 
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Installing the Xpress Print Driver on client workstations  
(Chapter 9 – Installing the Xpress Print Driver) 

Instructions are available online for users to install the Xpress Print Driver 
(XPD) on their own client workstation. For users that are uneasy with the 
process, it is repeated here for the System Administrator. 

The XPD driver for Windows 95 / 98 / ME must be updated on the Web 
Document Submission server before any of these clients can use the 
driver. The instructions on performing this setup task are detailed in this 
chapter.  
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7. Managing Users 

Once the Web Document Submission system has been installed, users 
must be added. This chapter describes the processes for: 

• importing users 
• adding users 
• modifying user information 
• deleting / inactivating users 
• setting permissions and group memberships 

User Group Directory Administration Tool (UGD Admin tool) 

All user management is done through the use of the UGD Admin tool, 
which is found in the XWDSS Admin Tools. The tool is shown in  
Figure 7-1. 

Figure 7-1. User Group Directory Administration Tool 
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Users are added to the Web Document Submission system in two ways: 

• By importing an external user data file. 
• By entering users on a one-by-one basis through the UGD Admin 

tool. 

Importing Users from an External User Data File 

Users may be imported from an external data file. This data file can be 
used to initially place users in the Web Document Submission system, and 
then to keep the system updated. Using the Update Users, 
Synchronization Mode, and Create Batch File functions of the import 
module, an external file can be set up to automatically add, update, and 
inactivate users. 

Importing an External User Data File 

The following instructions assume Web Document Submission has been 
installed and is operating correctly. 

If a data file has been supplied with the installation CD, skip to  
Step 4 – Import Users on page 7-15. 

Note: When importing a customer data file for Web Document 
Submission users, work on a small sample of the file if 
possible. This allows for rapid error detection without the delay 
of a long user file load. 

Perform the following steps to import a user data file: 
1. Modify or build the user file. 
2. Modify the User Field Configuration to add required user fields to 

those that Web Document Submission uses.  

3. Modify or build the User Import Mappings either to add additional 
fields from the user file that are not already present in the Web 
Document Submission fields or to create mappings from scratch. 

4. Import the user data. 
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Data File Format for the User File 

Comma-delimited is the only data format Web Document Submission uses 
for importing user files. Each customer will have a different set of 
requirements for the user file and the default set of fields for the user 
database will have to be modified. 

Comma-delimited File Format 

Use a plain text editor, such as Notepad, or a spreadsheet, such as Excel, 
to create or modify the user file. Ensure that there is only one line break at 
the end of each line. An example file is shown in Figure 7-2. 

Figure 7-2. Example of a comma-delimited user file 

User Name,Email Address,First Name,Last Name,Phone 
istravinsky,igor.stravinsky@tasc.sk.edu,Igor,Stravinsky,513-366-1015 
jthorsteinson,jeff.thorsteinson@tasc.sk.edu,Jeff,Thorsteinson,513-366-1016 
slaing,scott.laing@tasc.sk.edu,Scott,Laing,513-366-1018 
 

The first line of the data file is the data definition for the lines that follow as 
shown in Figure 7-3. 

Figure 7-3. Data definition for comma-delimited file 

User Name,Email Address,First Name,Last Name,Phone 

In the example above, the first field is User Name. Each line that follows 
represents a new record for a user, istravinsky for example. This means 
that the first data element (field) in a line must always be the user name. 
Email Address is the next field name in the first line, so in every line that 
follows the second data element (field) is the user’s E-mail address. Figure 
7-4 shows this pattern repetition. 
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Figure 7-4. Pattern for records and fields in comma-delimited file 
User Name Email Address 

istravinsky igor.stravinsky@tasc.sk.edu 

jthorsteinson jeff.thorsteinson@tasc.sk.edu 

slaing scott.laing@tasc.sk.edu 

This pattern repeats with a line break at the end of each user to be 
included. There may be fewer or more fields required for any particular 
customer. 

Note: Ensure there are no trailing blank lines in any of the files to be 
modified in this chapter. Blank lines may appear harmless, but 
can cause large problems later.  

Step 1 – Modifying or Building the User File 

Using the information from the previous section, ensure that the user data 
file that is modified or built is clean of extra line breaks. If possible, select a 
small sample to test the import of the data. Once the test data file has 
loaded successfully, load the entire user file. 

Note: All users must have a unique user name or ID number.  

The new user file can be located anywhere on the file system. 

Have a printed copy of the first page of the new user data file available for 
reference. Ensure that the first line of the file includes the file’s field names. 
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 Step 2 – Modifying the User Field Configuration 

System User Fields 

Web Document Submission has the following system user fields that 
cannot be changed: 

user_id  
first_name 
last_name 
phone 
email 

A user file can be built using these default fields but it is more likely that a 
customer would have additional fields included. 

Added Default User Fields 

As installed, Web Document Submission has the following user fields 
added: 

address_line_1 
address_line_2 
mail_code 
city 
state 
zip 
e-mail 
phone 
ext 
location 
department 
cost_center 

Note: Any of these fields may be modified or deleted as required to 
meet customer specifications.  

Examine which fields in the new user file will map to existing fields in the 
system. Any fields that cannot be mapped must be added to the user file. 
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If the previous example of a comma-delimited file shown in Figure 7-2 on 
page 7-3 is expanded to include an extra field, supervisor, the file would 
look like Figure 7-5 shown below. 

Figure 7-5: Sample user file 
User Name,Email Address,First Name,Last Name,Phone,Supervisor 
istravinsky,igor.stravinsky@tasc.sk.edu,Igor,Stravinsky,513-366-1015,A. Jones 
jthorsteinson,jeff.thorsteinson@tasc.sk.edu,Jeff,Thorsteinson,513-366-1016,B. Bo 
slaing,scott.laing@tasc.sk.edu,Scott,Laing,513-366-1018,C. Clements 

Upon examination, all the fields map to existing fields in Web Document 
Submission with the exception of Supervisor. This field will have to be 
added to Web Document Submission. 

Adding a Field to the User Field Configuration 

This example will add Supervisor to the list of User Fields. 

Perform the following to add a field to the User Field configuration: 
Note: Ensure the Web Document Submission system is running 

before performing this procedure. 

1. From the XWDSS Admin Tools click Tools > UDG Admin. 

2. Click Tools > User Field Config. 

3. The User Field Configuration window appears.  

Note: The 11 User Field Mappings listed in the previous section are 
present if this there was no pre-configuration done for Web 
Document Submission. If there are other fields listed, then a  
pre-configuration has been done and the fields are the those a 
customer has requested.  
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Double-click in the next available blank line under the User Field 
Mapping column. Type supervisor as the field name.  

 
There can be a maximum of 20 user fields. 

Note: User Field Mapping names must contain no spaces. In place of 
a space, use an underscore. 

4. Press Enter on the keyboard. Web Document Submission 
accepts the entry. 

Note: When the last field has been added, ensure that Enter is 
pressed on the keyboard to force Web Document Submission 
to accept the entry. If Enter is not pressed, the last entry will be 
lost. 

CAUTION: The Clear Data button erases all data for all users in the user 
field where the cursor appears. It does not clear a field name 
that has been typed. 

5. To accept the User Field Configuration additions, click Save. The 
UGD Admin – User Field Config window appears saying that the 
mappings are updated. Click OK. Click Close. 
 
The User Group Directory Admin window refreshes to show the 
modifications to the user fields. In this example, supervisor 
appears as the last field listed. 
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Removing a Field from the User Field Configuration 

Unneeded user fields, or fields that were added in error, can be removed. 

Perform the following to remove fields from the User Field 
Configuration: 

Note: Ensure the Web Document system is running before completing 
this procedure. 

1. Go to My Computer > C:  > xwdss > scripts. Double-Click 
ControlCenter.bat. 

2. The XWDSS Admin Tools window opens. From the XWDSS Admin 
Tools click Tools > UDG Admin. 

3. Click Tools > User Field Config. 

4. The User Field Configuration window appears. Double-click the 
name of the field that is to be removed. 

5. Delete the name of the field that is to be removed and press Enter on 
the keyboard. 

6. Click Save. The UDG Admin – User Field Config window appears 
stating that field mappings have been removed.  
Click Yes to complete the deletion of the field. 

7. A window appears to confirm the deletion of the field. Click OK. Click 
Close. 

Step 3 – Building or Modifying the User Import Mappings  

Once the desired fields have been added to Web Document Submission, 
the field names in the user data file need to be mapped to field names 
that Web Document Submission uses.  

Continuing to use the data file example from the last step, a new Import 
Mapping will be created. 
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Creating and Saving New Mappings 

The default mapping is provided as a starting point for development of a 
user database. If a different mapping is needed, it can be created and 
saved. 

Figure 7-7 shows the user data file field names and how they will map to 
Web Document Submission names. 

Figure 7-7. User file field names that map to Web Document 
Submission field names 

User File  
Field Names  

Web Document 
Submission Field 

Names 

User Name maps to user_id* 

Email Address maps to email* 

First Name maps to first_name* 

Last Name maps to last_name* 

Phone maps to phone* 

Supervisor maps to supervisor 

* system fields 

Perform the following to create and save a new mapping: 
1. Go to My Computer > C:  > xwdss > scripts. Double-Click 

ControlCenter.bat. 
2. The XWDSS Admin Tools window opens. From the XWDSS Admin 

Tools click Tools > UDG Admin. 

3. The User Group Directory Admin window opens.  
Click Tools > User Import Mappings. 

4. The UGD Admin - User Import Mappings Window opens. The 
screen is divided into three sections: a window showing any saved 
mappings, the Import Field Label, and the User Field Mapping. 

5. Click Add under the column where the default mapping is listed. 
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6. The UGD Admin - New User Mapping window appears. Type a 
mapping name. For this example, type Test as the mapping name. 
Click OK.  

7. A blank UGD Admin - User Import Mappings window appears. Click 
Add. 

8. The UGD Admin - User Field Import Mapping window appears. The 
field names from the user data file must be entered, one at a time, 
and matched with a Web Document Submission field. Using the chart 
in figure 7-6, six import mappings must be created. Type the field 
name as it appears in the user file in the Imported field name text 
box. 
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9. Scroll through the list of UGD User Defined Fields to find the Web 
Document Submission field that maps to Imported field name. Use 
the >> button to move the field into the Import Mapping window. Use 
the << button to remove a field moved in error. Click OK. 

 
10. The updated UGD Admin - User Import Mappings window 

reappears. Click Add to add an additional mapping. Repeat steps 7 
and 8 to add all the required mappings. 

Fields can be combined. An example of this is where the import file 
has both first and last names contained a single field. In a case like 
this, create a mapping and move one name field and then the other 
name field, in the order used in the import file. 
 

 
11. To save the mappings, click Actions > Save. A confirmation message 

appears that the mappings were saved. Click OK. 

12. Click X to exit the UGD Admin – User Import Mappings window. 
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Modifying User Import Mappings 

If additional fields are added or removed from a user import file, the 
mapping for that import file will have to be modified. 

Perform the following to modify the default User Import Mappings: 
1. Go to My Computer > C:  > xwdss > scripts. Double-Click 

ControlCenter.bat. 
2. The XWDSS Admin Tools window opens. From the XWDSS Admin 

Tools click Tools > UDG Admin. 

3. The User Group Directory Admin window opens.  
Click Tools > User Import Mappings. 

4. The UGD Admin - User Import Mappings Window opens as shown 
below. The screen is divided into three sections – a window showing 
any saved mappings, the Import Field Label, and the User Field 
Mapping.  
 
The Import Field Label matches the field name in the import file. The 
User Field Mapping is the Web Document Submission field where 
the user data will be placed.  
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To see the structure of the mappings, click the line that begins 
with First Name and then click Modify. 

 
5. A new UGD Admin - User Field Import Mapping window opens. 

This window is where the field names in the import file are matched 
with the Web Document Submission system uses for field names 
internally. 
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Type the name of any new Import filed name and then scroll through 
the list of UGD User Defined Fields to find the Web Document 
Submission field into which that particular field will be imported. Use 
the >> button to move the field into the Import Mapping window. Use 
the << button to remove a field moved in error. 

6. When finished modifying the mappings, click OK. 

Fields can be combined. An example of this is where the import file 
has both first and last names contained a single field. In a case like 
this, create a mapping and move one name field and then the other 
name field, in the order used in the import file. 
 

 
7. The UGD Admin - User Import Mappings window reappears. 

8. To save the mappings, click Actions > Save. A confirmation message 
appears that the mappings were saved. Click OK. 
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9. Click X to exit the UGD Admin - User Import Mappings window. 

 

Additional Menus in UGD Admin – Import Mappings Window 

There are two additional menu choices listed under the Actions menu. 

1. Reload – reloads the default user mappings. 

2. Default Mapping – allows the selection of which mapping will be the 
default mapping on the UGD Admin - Import Users window. 

Step 4 – Import Users 

Once the user file has been mapped to data that Web Document 
Submission will use, importing the file is the last step. 

Perform the following to import users: 
1. Go to My Computer > C:  > xwdss > scripts. Double-Click 

ControlCenter.bat. 
2. The XWDSS Admin Tools window opens. From the XWDSS Admin 

Tools click Tools > UDG Admin. 

3. The User Group Directory Admin window opens.  
Click Tools > Import Users.  
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4. The UGD Admin - Import Users window opens.  

 
5. Click Browse and locate the user file to be imported. 

6. Click the User mapping drop-down menu and select the mapping to 
be used for the import. Continuing with the example file, select test. 

 
Click View to ensure this is the correct mapping to be used for the 
import. Click X to close the view window. 

7. Click Import. A summary screen appears when the process is 
complete. Click OK.  

8. The User Group Directory Admin window reappears. All imported 
users appear and are active. 

9. Click X to exit the User Group Directory Admin window. 
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Users that are imported from the system are in the database  
permanently. Once they are made inactive, they still appear in the 
user list unless their names are filtered. Filtering is accomplished 
by right-clicking on any user name. A Filter Users menu appears. 
Clear the Inactive Users choice and only the active users will 
appear. 

 

Choices Available in the Import Users Window 

• User mapping – Allow the selection of a previously configured 
mapping if other than the default mapping is required. 

• View – View the selected User mapping. 
• Update users – If selected, any users information that already exists 

in the database will be updated if the user is listed in the import file. 
• Synchronization mode – If selected, any users that exist in the 

database, but are not listed in the import file will be inactivated. This 
synchronizes the database users with the import file users. 

• Import – Begin the import process. 
• Create Batch File – If clicked, creates a batch file that can be used to 

run the import process outside of the UGD Admin tool. This file can be 
used to schedule imports on Windows by the System Administrator. 
The batch file stores the information selected in the import dialog. 

• Cancel – Exit from this window without taking any action. 

Troubleshooting a Faulty Import 

If the user file did not import properly, there may be a database of users 
with incorrect or incomplete information. Web Document Submission 
does not allow these users to be deleted. They can only be inactivated. 

If the system has not been put into production, all the Web Document 
Submission databases, including users and jobs, can be re-initialized. 
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Read, and use with caution, the Re-initializing the User Database section 
in Chapter 14 – Troubleshooting on page 24-1 of this guide. 

Adding Users One at a Time 

The UGD tool can also add users one at a time. This procedure assumes 
that the user database has already been configured. If it has not been 
configured, use Step 2 Modifying the User Field Configuration on page 7-
5 in this chapter. 

Adding a User to Web Document Submission 

Perform the following to add a user to Web Document Submission: 
1. Run the XWDSS Admin Tools application by double-clicking on 

ControlCenter.bat contained in the c:\xwdss\scripts directory. 

2. From the XWDSS Admin Tools click Tools > UDG Admin. 

3. The User Group Directory Admin window opens. 

4. Click Add User. 
5. Select Active in the top left corner of the New User window. 

 
6. Click in the user-id field and type a unique user identification for the 

user being entered. 

7. Press the Tab key twice to move to the next field. Type in all the 
required user information. 

Note: Clicking the mouse in the Field Value column will also allow 
data entry for a particular field. This may speed up data entry if 
not all the fields are required for a user. 



XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.1 MANAGING USERS 

INSTALLATION AND SYSTEM ADMINISTRATION GUIDE 7-19 

8. When the last field value is typed for a user, press Enter on the 
keyboard. Pressing Enter forces Web Document Submission to 
accept the last field entered. 

9. Click OK. A confirmation message appears. Click OK. The User 
Group Directory Admin window reappears and refreshes to show 
the newly added user. 

Modifying User Information 

User information can be modified in a batch by importing an updated user 
file, or one at a time. 

Modifying User Information for a Group of Users 

If there are a large number of users to be modified, Web Document 
Submission can import a modified user list and update users whose user 
profiles have changed. 

Perform the following to modify a group of users: 
1. Open the latest version of the user list and modify the user profile for 

any user that requires updating. 

2. Run the XWDSS Admin Tools application by double-clicking on 
ControlCenter.bat contained in the c:\xwdss\scripts directory. 

3. From the XWDSS Admin Tools click Tools > UDG Admin. 

4. The User Group Directory Admin window opens.  
Click Tools > Import Users.  

5. The UGD Admin - Import Users window opens. Click Browse and 
locate the updated user file. 

6. Select the correct User mapping. 

7. Ensure that Yes is selected for Update Users. 

8. Ensure that No is selected for Synchronization mode. 

9. Click Import. A summary screen appears when the process is 
complete. Click OK.  
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10. The User Group Directory Admin window reappears. All users with 
new profile information are updated. 

11. Click X to exit the User Group Directory Admin window. 

 

Modifying User Information for a Single User 

Perform the following to modify a group of users: 
1. Run the XWDSS Admin Tools application by double-clicking on 

ControlCenter.bat contained in the c:\xwdss\scripts directory. 

2. From the XWDSS Admin Tools click Tools > UDG Admin. 

3. The User Group Directory Admin window opens. Click the line 
where the user to be modified appears. The line becomes highlighted. 

4. Click Modify User. The Modify User window opens.  

5. Click in the Field Value and change any information that requires 
modification. Press Enter on the keyboard when the last modification 
has been made to force Web Document Submission to accept the last 
change made to a field. 

6. Click Update. A confirmation window appears. Click OK. 

7. To exit the Modify User window, click Close. 

8. The User Group Directory Admin window reappears. The user with 
the updated profile information appears with the updated information. 

9. Click X to exit the User Group Directory Admin window. 
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Changing a User Password 

Users select their own password during registration. If they forget their 
password, they can request the password be sent to them through a link 
on the User log on page. If the E-mail address of the user has changed, 
however, the System Administrator must change the password for them 
since a request for a password from the user will be sent to the wrong E-
mail address.  

Perform the following to change a user password: 
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UDG Admin. 

3. The User Group Directory Admin window opens. Click the line 
where the user to be modified appears. The line highlights. 

4. Click Modify User. The Modify User window opens. 

5. Click Change Password.   

6. The UGD Admin - Modify User window opens. Type the new 
password for the user and click OK. 

7. A confirmation window appears. Click OK. 

8. To exit the Modify User window, click Close. 

9. The User Group Directory Admin window reappears. 

10. Click X to exit the User Group Directory Admin window. 

 

Deleting / Inactivating Users 

Web Document Submission users are never deleted from the system. 
Since there may still be jobs in process associated with the user, they are 
inactivated instead. 
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Inactivating Users 

Users may be inactivated individually, or in a group by re-importing the 
user file. 

Inactivating an Individual User 

Perform the following to inactivate individual users: 
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UDG Admin. 

3. The User Group Directory Admin window opens. Locate the user to 
be inactivated and click on the line containing their name. The line 
should be highlighted. Click Inactivate User. 

4. The UGD - Inactivate User window appears. Click Yes.  

5. A confirmation window appears. Click OK. If the user list is set to filter 
out inactivated users, the name just inactivated will disappear. 

Inactivating a Group of Users 

If there are a large number of users to be inactivated Web Document 
Submission can import a user list and inactivate users not in the updated 
user list. 

Note: If selected, any users that exist in the database, but are not 
listed in the import file will be inactivated. This synchronizes the 
database users with the import file users 

Perform the following to inactivate a group of users: 
1. Open the latest version of the user list that was imported and remove 

any users that should be inactivated. 

2. From the XWDSS Admin Tools click Tools > UDG Admin. 

3. The User Group Directory Admin window opens.  
Click Tools > Import Users.  

4. The UGD Admin - Import Users window opens. Click Browse and 
locate the updated user file. 
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5. Select the correct User mapping. 

6. For the Synchronization mode select Yes. 

7. Click Import. A summary screen appears when the process is 
complete. Click OK.  

8. The User Group Directory Admin window reappears. All imported 
users should appear and be active while those removed from the 
imported user file should be inactivated. 

9. Click X to exit the User Group Directory Admin window. 

 

Assigning Privileges and Groups to Users 

By default, there are only two accounts established during installation:  

• admin, the administrator account  
• operator, the print operator account 

These two accounts are placed, respectively, into the Xerox Business 
Systems (XBS) Admin and XBS Operator groups.  

Users, when they register for access to the Web Document Submission 
system, are placed in the user group. Because users should not have 
access to the admin or operator accounts directly, users can be 
reassigned to one of these groups to better reflect their job position.  

Figure 7-7 shows the default list of user groups and permissions available 
in the Web Document Submission system. If these groupings are 
insufficient, they can be added to or modified. 
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Figure 7-7. Default list of user groups and permissions 
Permissions 

User Groups Resource 
Type 

Resource 
Name Right 

printshop default Printer Administration 

printshop default Run Jobs XBS Admin 

system system Use 

printshop default Run Jobs XBS 
Operator system system Use 

user system system Use 

Resource Types 

System – The system resource type refers to resources using the Web 
Document Submission system via the Web Document Submission user 
interface. 

Printshop – The printshop resource type refers to resources related to 
the printshop itself such as adding printers. 

Rights 

Printer Administration – A user with this right can add printers to Web 
Document Submission. 

Run Jobs – A user with this right can perform tasks using the 
Administrator interface. 

Use – A user with this right can perform any tasks using the User 
interface. 



XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.1 MANAGING USERS 

INSTALLATION AND SYSTEM ADMINISTRATION GUIDE 7-25 

Viewing the Permissions and Group Memberships Assigned to a 
User 

Users may be members of more than one group. It is possible to view 
what permissions a user has and with what groups they are associated. 

Perform the following to view the permissions and group 
memberships assigned to a user:  
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UDG Admin. 

3. The User Group Directory Admin window opens. 

4. Click on the name of the user. The line is highlighted. 

5. Click Group Membership to view the groups a user has been 
assigned. Click X to close the User Group Membership window. 

6. Click Permissions to view the permissions a user has been assigned. 
Click X to close the User Permissions window. 

Assigning a User to a Group 

All users, when they register for access to the system, are placed in the 
user group. Any user can be reassigned to a new group. This example 
will place a user in the XBS Operator group. To place a user in the XBS 
Admin group follow the same steps except choose XBS Admin as the 
Group Name. 

Perform the following to assign a user to a group: 
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UDG Admin. 
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3. The User Group Directory Admin window opens. Click the Groups 
tab. 

 
4. The window refreshes and the user groups appear. Click XBS 

Operator. The XBS Operator line becomes highlighted. Click Users. 

5. The User Group Membership window opens. Locate the user, or 
users, that need the rights of an operator. Click the user name to 
select the user or hold the Ctrl key down and click to select multiple 
user names. 

6. Click >> to move the user names to the Group User Names column. 
If an error is made, select the erroneous name in the Group User 
Names column and click <<. 

7. Click Save. A confirmation message appears. Click OK. Click Close. 

8. The User Group Directory Admin window reappears. To exit the 
User Group Directory Admin window, click X. 

 

Removing Users from a Group 

Perform the following to remove a user from a group: 
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UDG Admin. 
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3. The User Group Directory Admin window opens. Click the Groups 
tab. 

 
4. The window refreshes and the user groups appear. Click the name of 

the group from which the user is to be removed. The selected line 
becomes highlighted. Click Users. 

5. The User Group Membership window opens. Locate the user, or 
users in the Group User Names window. Click the user name to 
select the user or hold the Ctrl key down and click to select multiple 
user names. 

6. Click << to move the user names to the User Names column. If an 
error is made, select the erroneous name in the User Names column 
and click >>. 

7. Click Save. A confirmation message appears. Click OK. Click Close. 

8. The User Group Directory Admin window reappears. To exit the 
User Group Directory Admin window, click X. 

 

Adding a New User Group 

New user groups can be added to the Web Document Submission 
system. 

Perform the following to add a new user group: 
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UDG Admin. 
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3. The User Group Directory Admin window opens. Click the Groups 
tab. 

 
4. The window refreshes and the user groups appear. Click Add Group. 

5. The UGD - Add Group window appears. Type the name of the new 
user group and click OK. 

6. A confirmation window appears. Click OK. 

Note: This user group will have no users or permissions assigned to it.  

7. The User Group Directory Admin window reappears. To exit the 
User Group Directory Admin window, click X. 

 

Adding Permissions to a Group 

Once a group is established, it needs to have permissions assigned.  

Perform the following to add permissions to a group: 
1. From the XWDSS Admin Tools click Tools > UDG Admin. 

2. The User Group Directory Admin window opens. Click the Groups 
tab. 
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3. The window refreshes and the user groups appear. Click the name of 
the group that requires permissions. The line becomes highlighted. 
Click Permissions. 

4. The Group Permissions window opens. 

 
Click Add Permission. 

5. The UGD - Permissions window opens. Using Figure 7-5, on page 7-
6 as a guide, along with the explanation of Resource Types that follow 
it, construct a new permission for this type of user. 

6. When done adding permissions, click Save. 

7. A confirmation window appears. Click OK. Click Close. 

8. Add users to this group by following the instructions on assigning a 
user to a group given above. 

Deleting a User Group 

If a group is no longer required, it can be deleted.  

CAUTION: DO NOT delete XBS Admin, XBS Operator, or user groups 
since these are required by the system. 

Perform the following to delete a user group: 
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UDG Admin. 
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3. The User Group Directory Admin window opens. Click the Groups 
tab. 

 
4. The window refreshes and the user groups appear. Click the name of 

the group that is to be deleted. The name of the group becomes 
highlighted. Click Delete Group. 

5. A confirmation window appears. Click Yes. 

6. A second confirmation window appears confirming the removal of the 
user group. Click OK.  

7. The User Group Directory Admin window reappears. To exit the 
User Group Directory Admin window, click X. 

 

Modifying a Group Name 

An existing group name can be modified.  

CAUTION:  Do NOT delete XBS Admin, XBS Operator, or user groups. 

Perform the following to modify a group name: 
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UDG Admin. 
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3. The User Group Directory Admin window opens. Click the Groups 
tab. 

 
4. The window refreshes and the user groups appear. Click the name of 

the group that is to be modified. The name of the group becomes 
highlighted. Click Modify Group. 

5. The UGD - Modify Group window appears with the existing group 
name. Press the Backspace key on the keyboard to clear the existing 
name. Type the new group name and click OK. 

6. A confirmation window appears. Click OK. 

7. The User Group Directory Admin window reappears. To exit the 
User Group Directory Admin window, click X. 
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8. Customizing the User Interface 

The User Interface (UI) Configuration tool in the XWDSS Admin Tools 
and the Administrator Tools available on the web UI customize elements 
of the user interface for Web Document Submission. There are five areas 
of the user interface that can be customized: 

• Colors – Text, links, and navigation bars can have colors modified. 
• Image – The header image can be changed to a new image. 
• Text – Any text visible on the screen in the user interface can be 

modified for font, font size and font style. 
• Main Page Text – Once logged on to the system, there is a 

section of the Home page where text can be modified. 
• Labels – Text labels on the user as well as the admin page can be 

modified as well as messages on some of the pages 

If dissatisfied with changes, the original interface configuration can be 
restored. 

Starting the UI Configuration Tool 

Perform the following to start the UI Configuration tool: 
1. Go to c:\xwdss\scripts and double-click ControlCenter.bat. 
2. The XWDSS Admin Tools start. Click Tools > UI Config. 



CUSTOMIZING THE USER INTERFACE XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.1 

8-2 INSTALLATION AND SYSTEM ADMINISTRATION GUIDE 

3. The uiconfi_control_panel window opens.  
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Configurable Sections of the User Interface 

The sections of the user interface referred to in the UI Configuration Tool 
are shown below in Figures 8-1 and 8-2. 

Figure 8-1. User Interface Items that can be selected in the UI 
Configuration Tool 
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Figure 8-2. User Interface Items that can be selected in the UI 
Configuration Tool 

 

Configuring Colors 

To change colors for any of the configurable user interface sections follow 
the general procedure outlined below. This procedure assumes that the 
User Interface Configuration tool has been opened. 

The default values for the Configure Colors section of the User Interface 
Configuration tool follow at the end of this chapter. 
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Perform the following to modify a configurable color item:  
1. From the Configure Colors drop-down menu, select the item to be 

changed. This example will change the Main Page Text Color. 

 
2. The Current Color text box refreshes to show the color currently 

selected for the Main Page Text Color. Click Color Browse.  

3. The Color Chooser opens. There are three methods of choosing a 
color, each selectable by clicking their respective tab. 
 
Swatches – Select a color from the palette presented. 
HSB – Move the slider up or down to select a hue, then click the 
mouse in the color block to select the saturation and brightness 
desired. 
RGB – If the red, blue, and green values are known for a desired 
color, move the sliders or type the values to obtain that color.  
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Note: Only the Foreground color can be selected. 

1. Once the desired color has been selected, click OK. The Current 
Color text box refreshes to show the modification. 

2. To see the modification, click Commit Changes. A Login window will 
appear if this is the first modification made this session. Type Admin 
for the Username and 22222 for the Password. Click OK. 

3. Open a browser window and go to the Web Document Submission 
home page. Logon and move to the page where the change has been 
made. If the change is unsatisfactory, repeat the steps to choose a 
new color. 

Note: If a new color is selected to replace a color that was selected in 
the procedure above, commit the changes and click Refresh 
on the browser window to see the new changes. A new 
browser window does not have to be opened. 
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4. When the desired color changes are completed, click X to exit the 
User Interface Configuration tool. 

 

Configuring the Header Image 

The header image can be changed to a different image with these 
restrictions: 

• The image must be 700 X 82 pixels. 
• The image must be saved as either a GIF or JPG format 

picture. 
• The image must use web-safe colors. 
• The image may be located outside of the Web Document 

Submission program folder but should reside on the Web 
Document Submission server. 

When creating an image for the header, be aware that large company 
logos will not scale well to the small size required in the header. Use an 
image-editing program to create the best possible header image. 

This procedure assumes that the User Interface Configuration tool has 
been opened. 

The default value for the Configure Image section of the User Interface 
Configuration tool follows at the end of this chapter on  
page 8-18. 

Perform the following to modify a header image item: 
1. From the Configure Image drop-down menu, select Header Image. 

2. The Open dialog box appears. Browse to the folder where the new 
image is located by clicking the Look in drop-down menu.  

3. When the image has been located, click the name of the image. The 
image name appears in the File name text box. Click Open. 
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4. The Current Image text box refreshes with the new image file name. 
Click Commit Changes. A Login window will appear if this is the first 
modification made this session. Type Admin for the Username and 
22222 for the Password. Click OK. 

5. Open a browser window and go to the Web Document Submission 
home page. The new header image is now present. If the change is 
unsatisfactory, repeat the steps to choose a different header image. 

Note: If a browser window is already open and on a Web Document 
Submission page, click Refresh on the browser window to see 
the new header image. A new browser window does not have 
to be opened. 

6. When the desired header changes are complete, click X to exit the 
User Interface Configuration tool. 

 

Configuring Text 

To change the text attributes for any of the configurable user interface 
sections follow the general procedure outlined below. This procedure 
assumes that the User Interface Configuration tool has been opened. 

The default values for the Configure Text section of the User Interface 
Configuration tool follow at the end of this chapter. 
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Perform the following to modify a configurable text item:  
From the Configure Text drop-down menu, select the item to be 
changed. This example will change the Main Page Text Weight. 

 
1. The Current Value text box refreshes to show the color currently 

selected for the Main Page Text Weight. Type the new text weight 
desired into the Current Value text box. 

2. Click Commit Changes. A Login window will appear if this is the first 
modification made this session. Type Admin for the Username and 
22222 for the Password. Click OK. 

3. Open a browser window and go to the Web Document Submission 
home page. The new change in text weight is now present. If the 
change is unsatisfactory, repeat the steps to choose a different text 
weight. 

Note: If a browser window is already open and on a Web Document 
Submission page, click Refresh on the browser window to see 
the new change. A new browser window does not have to be 
opened. 

4. When the desired text changes are complete, click X to exit the User 
Interface Configuration tool. 
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Table 8-1 shows acceptable attribute values for text. 

Table 8-1. Values that can be used for Text attributes 

Acceptable Values for Text  

Text Family Text Weight Text Size 

Use standard 
browser fonts such 
as arial and times 

new roman 
Note: There is no 

capitalization of font 
names 

bold 
normal 

xx-small 
x-small 
small 

normal 
large 

x-large 

Configuring the Main Page Text 

The Main Page Text is a configurable section of text that appears on the 
user home page. This procedure must be performed on the Web 
Document Sumbission server. 

Figure 8-3 illustrates a home page that has been modified by changing 
colors, header image, and main page text. This procedure will illustrate 
how to modify the main page text. 
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Figure 8-3. Home page with modified header image, modified 
mainGroup.jpg image, and modified main page text 
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Perform the following to modify the main page text: 
1. Go to the Web Document Submission server. Go to 

C:\xwdss\Properties\Resources and open XwdssMessage.xml in 
Notepad. 

2. At the top of the resource file is this section: 

 
3. Copy the text from the highlighted line, table width=”500”...>, as 

shown above down to </table>. 

4. Using standard HTML, modify the code to reflect any required 
customer text. 
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5. When the code changes have been completed save 
XwdssMessage.xml 

5. Go to the Web Document Submission home page using the browser 
window already open or a new browser window. After logging in as a user 
the changes to the main page text are now present. If the change is 
unsatisfactory, repeat the steps to change the HTML code. 

CAUTION: If a browser window is already open and on a Web Document 
Submission page, click Refresh on the browser window to 
see the new change. A new browser window does not have to 
be opened. 

Tips about creating the Main Page Text 

• Create the code in a visual HTML editor, like Dreamweaver™ 
including any desired images. The code created in a visual editor 
can be cut and pasted directly into the xdwssMessages.xml code. 
Ensure the editor does not add any additional code to the top of 
the HTML. 

• Save all images for Main Page Text as GIF or JPG images in the 
following folder on the Web Document Submission server: 
c:\xwdss\etc\Apache2\htdocs\images\2_0_images. 
Save a copy of these files outside the c:\xwdss folder. 

• Allowable changes inside the HTML code include: 
o color and size of text 
o font 
o justification of text and images 
o insertion of images 

• Use a utility, like EyeDropper 3.0™, to assist with picking colors. 
These utilities allow a user to obtain color values for any onscreen 
images making color matching with customer supplied images a 
simpler process. 

• The code for the sample Main Page Text in Figure 8-3 follows in  
Figure 8-4. 
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Figure 8-4. HTML code sample for the Main Page Text in Figure 7-3.  
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• Do not include any of the standard required HTML tags in the Main 
Page Text. These tags include <html>, <head>, <title>, and <body>. 

 

Changing the mainGroup.jpg Image 

The extra image on the User home page is mainGroup.jpg located at 
c:\xwdss\Apache2\htdocs\images\2_0_images. This image may be 
replaced with another image. 

Tips about creating the mainGroup.jpg image 

• Create a new image that is approximately the same size as the 
original image – 163 x 216 pixels. 

• The new file must have the same name and extension as the original. 
Save the original jpg with a new name in case it is needed again. 

Restoring the Default User Interface Configuration 

The default interface can be restored to the Web Document Submission 
system. This procedure assumes that the UI Configuration tool has been 
opened. 

CAUTION: This procedure will cancel all changes made to the user 
interface. It is not a reversible procedure. 

Perform the following to restore the default user interface: 
1. Click Restore Defaults. 

2. A Confirm window appears. Click Yes to restore the default system 
values. 
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3. Close the UI Configuration tool window by clicking X. 

 
4. Reopen the UI Configuration tool and click Commit Changes. A 

Login window will appear if this is the first modification made this 
session. Type Admin for the Username and 22222 for the Password. 
Click OK. 

5. Open a browser window and go to the Web Document Submission 
home page. The default user interface is now present.  

Note: This restores all colors and font information to defaults, it does 
not change the configurable text changes that have been made 
in the Resource File Manager Tool. 
 
If a browser window is already open and on a Web Document 
Submission page, click Refresh on the browser window to see 
the restored default interface. A new browser window does not 
have to be opened. 
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User Interface Configuration Defaults 

The following tables contain the default values for the User Interface. 

Table 8-2. Configure Colors 

Configure Colors 

Configurable Section Default 

Default Text Color #000000 

Main Page Text Color #000000 

Warnings and Information Text 
Color 

#FF0000 

Top Navigational Links Text Color #000000 

Title Bar Text Color #FF0000 

Sub Title Bar Text Color #000000 

Title Bar Color #FF0000 

Sub Title Bar Color #EFEFEF 

Alternating Colored Bars I #EFEFEF 

Alternating Colored Bars II #CCCCCC 

Button Bar #666666 

Link Color #0000FF 

Active Link Color #0000FF 

Visited Link Color #0000FF 

Link Hover Color #9999FF 
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Table 8-3. Configure Image 

Configure Image 

Configurable Section Default 

Header Image 2_0_images/ 
logo.gif 

Copyright Text Color #CCCCCC 
 

Table 8-4. Configure Text 

Configure Text 

Configurable Section Default 

Default Text Family arial 

Default Text Weight bold 

Default Text Size x-small 

Main Page Text Family arial 

Main Page Text Weight bold 

Main Page Text Size x-small 

Warnings and Informational 
Text Family 

arial 

Warnings and Informational 
Text Weight 

bold 

Copyright Text Family arial 

Copyright Text Weight normal 

Copyright Text Size xx-small 
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Table 8-4. Configure Text (continued) 

Configure Text 

Configurable Section Default 

Top Navigational Links Text 
Family 

arial 

Top Navigational Links Text 
Weight 

bold 

Top Navigational Links Text 
Size 

x-small 

Title Bar Text Family arial 

Title Bar Text Weight bold 

Title Bar Text Size x-small 

Sub Title Bar Text Family arial 

Sub Title Bar Text Weight bold 

Sub Title Bar Text Size small 
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9. Installing the Xpress Print Driver 

The Xpress Print Driver (XPD) allows the uploading and conversion of 
documents from within a Windows application. There are three separate 
setups: 

• Windows 2000 / XP client machines 
• Windows NT Workstation client machines 
• Windows 95 / 98 / ME client machines (this client needs the 

XPD file configured on the server before allowing users to 
download it). 

 
The System Administrator should set this driver up on client workstations 
for users to send jobs to Web Document Submission directly from 
Windows applications. 

 

Note: WinZip or equivalent is needed for installing the XPD. A copy of 
WinZip may be downloaded from www.winzip.com. 

Windows 2000/ XP XPD Setup 

Windows 2000 Professional / XP Client Setup 

Installing the XPD print driver 

Perform the following to install the XPD print driver on a Window 
2000 Professional / XP computer: 

1. Create a folder named XPD on the C: drive of your computer.  
2. From the Web Document Submission home page, click Download 

Software and download the Windows 2000/XP XPD driver to the 
newly created XPD folder.  

3. Double-click setup.exe in the C:\XPD folder on your computer. The 
InstallShield Wizard starts.  

4. Click Next. The XPD installs.  
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5. Click Finish to complete the installation.  

Setting the Printer Properties for Windows 2000 Professional / XP 
XPD  

1. Click Start > Settings > Printers.  
2. Right-click Xerox Web Document Submission Software PS Color 

Plugin. 
3. A shortcut menu appears. Select Properties.  
4. Click the Configuration tab from the Properties window. 
5. Click Server is Available.  

 
In the appropriate fields, type the following: 
 
Server Name:  
<Web Document Submission server IP address> 
 
Port: 80 
 
URL Post Path: 
/xdx/servlet/simple?request.action=upd.action.upload 
 
URL Get Path: 
/xdx/upd.jsp?request.action=upd.action.dt&DT=%s&AG=%s&PD=%s
&PK=%s&NP=%d&NC=%d  
 
Write to Spool: Do not select  

4. Click OK.  
5. Configure the default browser by starting Internet Explorer or 

Netscape before using the driver, especially if using a proxy server on 
the network. Check with a system administrator if you are not sure 
about the proxy settings. 

The installation is now complete. Test the installation by opening a 
Windows application. Print to Web Document Submission with the XPD 
driver by clicking File > Print and then selecting the Xerox Web 
Document Submission Software PS Color Plugin driver. 
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Windows NT Workstation XPD Setup 

Windows NT Workstation Computer Setup 

This procedure assumes that WinZip, or equivalent, is installed on the 
client workstation. 

Installing the XPD print driver 

Perform the following to install the XPD print driver on a Windows 
NT Workstation computer: 
1. Create a folder named XPD on the C: drive of the workstation.  

2. From the Web Document Submission home page, click Download 
Driver and download the Windows NT XPD driver to the newly 
created XPD folder. 

3. Unzip xpd-1.1.3.zip to C:\XPD on the client workstation. 

4. Click Start > Settings > Printers. Double-click Add Printer. 
5. Click My Computer to install a local printer. Click Next. 
6. Choose LPT1 for the printer port. Click Next. 
7. Click Have Disk and browse to C:\XPD. 

8. Click webxpd.inf. Click Open. 

9. Click OK. 

10. Select DocumentsXpress PS Color Plugin. Click Next.  

Note: Only the color driver is required since it will handle both color and 
black and white jobs. 

11. To complete the installation click Next. 
12. Keep the default printer name. Click Next. 
13. Click Not Shared. Click Next. 
14. Click No to skip printing a test page. Click Finish. 
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Setting the Printer Properties 

Perform the following to set the printer properties: 
1. Right-click the installed printer name in the Printer folder (Start > 

Settings > Printers). Click Properties. 

2. Select the Configuration tab from the Properties Dialog box. 

3. Select Server is Available.  
 
In the appropriate fields, type the following: 

Server Name = <Web Document Submission server IP address>  
 
Port = 80 

URL Post Path = 
/xdx/servlet/simple?request.action=upd.action.uploa
d 

URL Get Path =  

/xdx/upd.jsp?request.action=upd.action.dt&DT=%s&AG=
%s&PD=%s&PK=%s&NP=%d&NC=%d 

Write to Spool = Do not select 

4. Click OK.  

5. Configure the default browser by selecting IE or Netscape before 
using the driver, especially if using a proxy server on the network. 
Check with a system administrator if you are not sure about the proxy 
settings. 

Test the installation by opening up a Windows application. Print to 
Web Document Submission with the XPD print driver by using File > 
Print and then selecting the DocumentsXpress PS Color Plugin 
driver. 
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Windows 95 / 98 / ME XPD Setup 

The Windows 95 / 98 / ME XPD installation files must be configured on 
the server before they can be downloaded by each individual workstation. 
This is a one-time change on the server. 

XWDSS Server Setup 

Modifying XWDSS Server File For Windows 95 / 98 / ME Installation 

This procedure assumes that WinZip, or equivalent, is installed on the 
server. 

Perform the following to modify the Windows NT Server file for 
Windows 95 / 98 XPD installation: 
1. On the Web Document Submission server, locate and double-click 

C:\xwdss\etc\Apache2\htdocs\xpd\UPD.zip. The zip file will open in 
a window and list all files contained in the zip file. 

2. Double-click Docsxprs.inf. A text editor opens the inf file. 

3. Scroll down to the end of the file to the [AddReg.Url] header. Replace 
both instances of MACHINE2 with the IP address for the Web 
Document Submission server. See the example below: 

[AddReg.Url] 

HKLM,"Software\Xerox\DocumentsXpress\Post 
URL",,0,"http://MACHINE2:80/xdx/servlet/simple?request.action=up
d.action.upload" 

HKLM,"Software\Xerox\DocumentsXpress\Get 
URL",,0,http://MACHINE2:80/xdx/upd.jsp?request.action=upd.action
.dt&DT=%s&AG=%s&PD=%s&PK=%s&NP=%d&NC=%d” 

Note: If the [AddReg.Url] section does not resemble the text above, 
replace the existing [AddReg.Url] section with the one above. 

4. Click File > Save to save the modified file in the Zip archive. Close 
the text editor. 
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5. A confirmation window appears asking to Update archive with this 
file. Click Yes. Close WinZip. The UPD.zip file is now ready to be 
downloaded by Windows 95 / 98 / ME users. 

Windows 95 / 98 / ME XPD Setup 

Caution: WordPad documents uploaded with the  
Windows 95 / 98 / ME XPD driver will not print. 

Windows 95 / 98 / ME Client Setup 

This procedure assumes that WinZip, or equivalent, is installed on the 
client workstation. 

Installing the XPD printer driver 

Perform the following to install the XPD printer driver on a Windows 
95 / 98 computer: 
1. Create a folder named XPD on the C: drive of the workstation.  

2. From the Web Document Submission home page, click Download 
Driver and download the Windows 95/98/ME XPD driver to the newly 
created XPD folder. 

3.  Unzip UPD.zip to C:\XPD on the client workstation. 

4. Click Start > Settings > Printers. Double-click Add Printer. Click 
Next. 

5. Click Local Printer. Click Next. 
6. Click Have Disk and browse to C:\XPD. 

7. Highlight Docsxprs.inf. Click Open. 

8. Click OK. 

9. Select DocumentsXpress Color Plugin. Click Next.  
Note: Only the color driver needs to be selected since it will handle 

both color and black and white jobs. 

10. Select LPT1 for the printer port. Click Next. 
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11. Leave the default printer name. Ensure that No for the default printer 
choice is selected. Click Next. 

12. Do not print a test page. Click Finish. 

At this point, the installation is now complete. 

Test the installation by opening up a Windows application. Print to 
Web Document Submission with the XPD printer driver by using 
File > Print and then selecting the DocumentsXpress Color Plugin 
driver. 
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10. System Backup 

The System Administrator is responsible for ensuring regular completion 
of backups for Web Document Submission. Schedule backups to occur at  
non-peak hours. Depending upon the backup method chosen, system 
performance may be degraded or clients may be prevented from using 
Web Document Submission. 

The instructions in this chapter are generic backup instructions. Specific 
instructions depend on the type of backup software and hardware used. 

Backing up Web Document Submission 

Perform the following to back up Web Document Submission: 

1. On the Web Document Submission server, shut down all the Web 
Document Submission services and close the XWDSS Admin Tools.  

CAUTION: Any files flagged as in use will not be backed up, therefore all 
software programs on the Web Document Submission server 
should be closed. 

2. Follow the instructions provided by the backup software and perform a 
backup of the complete server. At a minimum the C:\xwdss folder and 
its subfolders needs to be backed up. 

3. Once the backup is complete, restart Web Document Submission by 
restarting the XWDSS Admin Tools and services on the server. 
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Restoring Web Document Submission from a Backup 

Perform the following to restore Web Document Submission: 
15. Following the instructions included with the backup software, restore 

all hard drives from the backup. 

16. Reboot the server. 
17. Restart the services using the procedure found in this guide.  
18. Test the system to confirm a user can perform tasks such as logging 

on, printing, and converting. 
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11. Maintaining the Web Document 
Submission System 

Maintenance of the Web Document Submission system is the 
responsibility of the System Administrator  

Succeeded / Failed Print job Folder 

In the C:\xdx\printJobs folder are two are two folders: 

• succeeded 
• failed 

These folders contain information on jobs that have had their status 
changed to either succeeded or failed by the Print Operator or System 
Administrator. 

Over time, these folders will grow in size, so it is recommended that they 
be emptied out periodically, depending on the amount of traffic that goes 
through the Web Document Submission system. If the folders become 
large, they occupy hard drive space that, with incoming jobs, can affect 
the system. 

Schedule a regular time to examine the folders – every week or month. 
Use standard Windows procedures to delete the files in the folder.  
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Copyjob Folder 

The Copyjob folder is located on a remote server and is used by print 
shop personnel to copy jobs that need to be processed outside the Web 
Document Submission system. The folder is set up using the procedure 
outlined on page 17-1 

The folder may contain a number of sub-folders; each named after the 
print job id that originated the copy job. 

Over time, this folder will fill with jobs that have been copied from Web 
Document Submission. While how full this folder is will have no effect on 
the Web Document Submission server, it may affect the remote server. 

Schedule a regular time to examine the folders – every week or month. 
Use standard Windows procedures to delete the files in the folder.  
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12. Configuring System Parameters 

This chapter outlines how to use the Configuration Manager to make 
changes to the default system parameter values in Web Document 
Submission.  

All configurable values are modified through the XWDSS Admin Tool, the 
web-based Configuration Manager, or manually through editing XML files. 
Configuration tools are outlined in Figure 12-1.  

Figure 12-1. Configuration Tools in Web Document Submission 
XWDSS Admin Tools 

XWDSS Tool 

UGD Admin 
(see Chapter 7) 

 

User Group Directory Administration – User and group 
management. This tool can also import user database 
information from customer-supplied files. 

UI Config  
(see Chapter 8) 

User Interface Configuration – The User interface can 
be customized using the UI Config tool. 

Administrator Tools – Web-based  

Configuration 
Manager 

(this chapter) 

Configuration Manager – Allows changes to the system 
parameters in the Web Document Submission system. 

Resource File 
Manager  

(see Chapter 13) 

Resource File Manager – Allows changes to the test 
strings in error and constraint messages. 

Manually Configured Files 

Configurable XML 
Files 

(see Chapter 21) 

E-mail – System messages that are configurable by 
modifying XML files. 
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Configuration Manager Tool 

The Configuration Manager Tool is used to modify system parameters in 
Web Document Submission. 

Perform the following to start the Configuration Manager Tool: 
1. From the XWDSS Admin Home Page click Administration tools and 

select Configuration manager from the tools pull-down menu. 

2. The Configuration manager page appears.  

3. After any configuration changes are made, ensure the changes are 
saved by clicking the Update button at the bottom of the page. Stop 
and restart the system for the changes to take effect. 

Modifying the Configuration  

Each section in the Configuration Manager contains values that are either 
editable or not editable. Refer to these following sections, along with 
Appendix A – Default Configuration Manager Values to change the 
editable configuration values. These instructions will illustrate how to 
change values in each section, and how to save those changes. 

System Properties 

The properties section in the Configuration Manager is where the system 
properties for Web Document Submission are found. This section is non-
editable and is only included for reference 

Application Homes 

This section displays the home directories from the external applications 
used by XWDSS. This section is displayed for reference only and is non 
editable 
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Users 

This section contains information about managing the user database. The 
only editable item in this section is User Import File, which is the location 
of the file used during a user import operation. 

Note: The variable ${WXPRESS_HOME} is the location of the XWDSS 
install, in most cases you will only modify the path after this variable.  

Database 

This section contains information on the internal database XWDSS uses. 
This section is for reference only, none of the parameters are editable. 

Documents 

This section contains information on where XWDSS stores the users 
documents as well as number of days to keep documents. There are 2 
editable fields in this section, Document Lifetime and Warning Days. To 
modify these values simply replace the text in the text box with the new 
value. 

Web Server 

This section contains properties that control the web server. In this 
section you can set the following: 

• Default Due date – This is the default number of days between a 
job request’s start date and it’s due date 

• User Page Size – Number of users to display per page in the 
Global Address Book 

• Display Variables – This flag turns on debug information that is 
displayed in the user’s browser. Used for troubleshooting only. 

• Session Timeout – The number of minutes a web session lasts 
before timing out requiring the user to log in again. 
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• Operator Default Job State Filter – This is a list of job states that 
by default are displayed on the operator/admin home page. 

• Job View List Size – This sets the maximum number of jobs to 
show per screen on the operator/admin home page. 

Configuration Files 

Exceptions 

The Exception Messages section in the Resource File Manager is where 
the error messages for Web Document Submission can be modified. For 
a listing of all the error messages, see Appendix A – Default 
Configuration Manager Values.  

Configuring an Exceptions Parameter 

This example will show how to modify and then save an Exceptions 
parameter. The example used is changing the message that appears 
when there is an error when canceling a job. All other Exceptions 
parameters are changed in the same manner. 

Perform the following to configure an Exceptions parameter: 
1. Locate the parameter to be changed. Change the text in the text box 

to reflect the error that you would like displayed for this exception. 

2. When you have configured all of the exception messages, press 
Update at the bottom of the page. 

Job States 

The JobStateStrings section of the Resource File Manager allows 
customization of the text that displays to show job notification states. 

Configuring Job States Parameters 

This example will show how to modify and then save a System Job States 
parameter. In this example, the createdState property will be changed. 
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All other System Job States parameters are changed in the same 
manner. 

Perform the following to configure a System Jobs States parameter: 
1. Locate the parameter to be changed. Enter the text that you would 

like displayed for the selected Job State. 

2. After all changes have been made click Update at the bottom of the 
page.   
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13. Modifying Error Messages Using 
Resource File Manager 

This chapter outlines how to use the Resource File Manager to make 
changes to the error messages displayed on the Document and Job 
option screens during a job submission 

Resource File Manager Tool 

The Resource File Manager Tool allows an administrator to modify some 
the text strings displayed to a user while they are filling out the Job and 
Document option screens. 
 

Perform the following to open the Job Control Panel Tool: 
1. Open a web browser to the XWDSS Operator / Administrator page.  

2. From the Administrator page click Administrator tools. 

3. Select Resource File Manager from the Tools pull-down menu. 

4. Select ConstraintMessages or ExceptionMessages from the 
Resource File Manager pull-down menu and click View resource file. 

5. Make any changes to the labels. 

6. Click Update at the bottom of page when all edits are complete. 

7. Click Home to return to the Administrator Home page. 
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14. Modifying Templates 

The Template Manager allows the System Administrator to modify 
existing create, edit and delete Job Templates. Job templates are 
predefined job options that a user can select when submitting a job.  

Template Tools 

The Template tools are available from the Administrator tools pull-down 
menu.  

Creating a Template 

Perform the following to create a template: 
1. Select Create new template from the Administrator tools pull-down 

menu. 

2. In the first text box type the name of this template. Try to use a name 
that will describe the type of job for which the template is being 
created. This will be the text the user sees in the template pull-down 
menu. 

3. Enter the job options for this template. 

4. Click Create Template when all template job options have been 
selected. 

5. Click Finish to return to the Home page. 
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Editing an existing Template 

Perform the following to edit a template: 
1. Select Edit existing templates from the Administrator tools  

pull-down menu. 

2. Select the template to edit from the Edit existing templates  
pull-down menu and click Edit Template. 

3. Change any of the features that need to be changed and click Edit 
Template at the bottom of the page. 

4. Click Finish to return to the Home page. 

Deleting an existing Template 

Perform the following to edit a template: 
1. Select Delete template from the Administrator tools  

pull-down menu. 

2. Select the template you would like to delete from the Select a 
template to delete pull-down menu and click Delete Template. 

3. Click Finish to return to the Home page. 
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15. Installing the Web Document 
Submission Link to DocuShare 
(Optional) 

DocuShare 2.2 Service Pack 2 (SP2) users can gain direct access to 
Web Document Submission by installing additional Web Document 
Submission software components to the DocuShare server. Obtain 
administrative access to the DocuShare server in order to complete the 
following installation. These steps assume that installation is taking place 
at the DocuShare server. 

DocuShare 2.2 and DocuShare 2.2 Service Pack 1 (SP1) servers must 
be upgraded to use the Web Document Submission Link. 

Note: DocuShare 3.0 customers should contact Web Document 
Submission Support for additional information and 
documentation on installing the link on DocuShare 3.0. 

Copying Web Document Submission Files to DocuShare 

The Web Document Submission CD contains two files that must be 
installed on DocuShare server. One of the files, dslib.vdf, requires a 
modification to point to the current Web Document Submission 
installation. 

CAUTION: The dslib.vdf file is quite often already modified on an 
operational DocuShare server. If the Web Document 
Submission version of the dslib.vdf file is being installed on a 
new DocuShare server, proceed with the steps detailed in the 
following section.  
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CAUTION: If modifications have already been made to an existing 
dslib.vdf file, replacing it with the Web Document Submission 
customized file will lose all other customizations. If the Web 
Document Submission link to DocuShare is being installed on 
a DocuShare server with a previously customized dslib.vdf, 
proceed to the section Modifying an existing dslib.vdf file. 

Copying the customized Web Document Submission files to a floppy 
disk 

Two files, dslib.vdf and printer.gif, must be copied from the Web 
Document Submission CD to a floppy disk. These files are in a 
compressed form on the CD. 

Perform the following to copy the custom Web Document 
Submission files to a floppy disk: 
1. Insert the Web Document Submission CD into the CD drive. 

2. Insert a blank floppy disk into a floppy disk drive. 

3. Go to My Computer \<CD ROM Drive> 
\documentation\docushare_integration. 

4.  Select and copy the dslib.vdf and the printer.gif file to the floppy 
disk. 

Note: Copying the files can be done using a variety of methods in 
Windows. Please refer to your Windows documentation for 
details. 

Perform the following to copy the custom Web Document 
Submission files to DocuShare: 
Make a back up copy of the dslib.vdf file that is on the DocuShare server 
before performing this procedure. 

1. At the DocuShare server, insert the floppy disk with dslib.vdf and 
printer.gif into the floppy drive. 

2. Go to My Computer > 3 ½ Floppy (A:). 
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3. Copy the file dslib.vdf to  
C:\Program Files\Xerox Corporation\DocuShare\templates\en-us. 

4. Copy the file printer.gif to 
C:\Program Files\Xerox Corporation\DocuShare\root 
\images\small. 

5. Go to  
C:\Program Files\Xerox Corporation\DocuShare\templates\en-us. 

6. Open dslib.vdf with a text editor. Search for xdx. The line that 
appears should be as follows (fragment of the line shown in  
Figure 15-1): 

Note: The DocuShare directories given here are the default locations 
for a DocuShare install. On some installations, these directories 
may have been changed, contact your DocuShare 
administrator for details. 

Figure 15-1. Fragment of dslib.vdf showing the line to be edited 

<TD VALIGN="TOP"><FONT SIZE="-1"><A HREF="http://(server ip)/xdx/docushare_display.jsp? 

7. Change the IP address 127.0.0.1 to the current Web Document 
Submission IP address. 

8. On the same line as the one modified above is an ALT tag for the 
printer icon on the DocuShare screen. This may be modified to reflect 
any customization required such as – Print with Xerox WDSS. The 
example below, Figure 15-2, shows the line with the text as was 
originally installed. 

Figure 15-2. ALT tag with original installed text 

<IMG BORDER="0" ALT="Print with Xerox Web Document Submission Software" 

9. Save the file dslib.vdf, overwriting the old file. 

10. Close all open windows. Remove the Web Document Submission CD. 

11. Proceed to the Changing the DocuShare Schema section. 
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Modifying an existing dslib.vdf file 

Perform the following to modify an existing DocuShare dslib.vdf: 
1. At the DocuShare server, insert the Web Document Submission CD 

into the CD drive. 

2. Go to My Computer\<CD ROM Drive> 
\documentation\docushare_integration. 

3. Copy the file printer.gif to 
C:\Program Files\Xerox Corporation\DocuShare\root 
\images\small. 

4. Go to  
C:\Program Files\Xerox Corporation\DocuShare\templates\en-us. 

5. Open dslib.vdf with a text editor. Search for: 
 
 /small/html.gif"/ 
 
The line where  this text appears is at the end of the second line of 
code in Figure 15-3: 
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Figure 15-3. Searched text and added Web Document Submission 
code 

 
The highlighted text is the code to be added to the existing dslib.vdf 
file. This text can be found in the dslib.vdf file on the Web Document 
Submission installation CD. 

6. Change the IP address shown in Figure 15-4 to the current Web 
Document Submission web server IP address.  

Figure 15-4. Fragment of dslib.vdf showing the line to be edited 

<TD VALIGN="TOP"><FONT SIZE="-1"><A HREF="http:// (server ip)/xdx/docushare_display.jsp? 

7. On the same line as the one modified above is an ALT tag for the 
printer icon on the DocuShare screen. This may be modified to reflect 
any customization required such as – Print with Xerox WDSS. The 
example below, Figure 15-5, shows the line with the text as was 
originally installed. 
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Figure 15-5. ALT tag with original installed text 

<IMG BORDER="0" ALT="Print with Xerox Web Document Submission 
Software" 

8. Save the file dslib.vdf, overwriting the old file. 

9. Close all open windows. Remove the Web Document Submission 
CD. 

Changing the DocuShare Schema 

User properties must be modified on DocuShare for the Web Document 
Submission printer icon to appear. 

Perform the following to make changes to the DocuShare schema: 
1. Log in to DocuShare as an administrator. 

2. Go to the Administration interface by clicking Administration or click 
the screwdriver icon in the navigation bar. 

3. Click Object Properties > User. 
4. Click Add… Select Boolean. 

5. In the Name text box type edocument.  
6. In the Label text box type Web Document Submission User. 
7. Click Add. 

8. A message appears to Rebuild Schema. Click the word here. 

Perform the following to rebuild the DocuShare Schema: 
1. Click Server Maintenance. 

2. Under Server Maintenance, on the left side of the screen, click 
Rebuild Search Schema. 

3. An informational screen appears. Click Rebuild Schema. 

4. The message The schema has been successfully rebuilt appears. 
Run dsindex to rebuild search databases. 
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5. Click Start > Programs > Command Prompt. Click Command 
Prompt. A Command Prompt window appears. 

6. Type: 

dsindex 
index_all 

7. Press Enter on the keyboard. 

8. An informational screen appears. Press Enter on the keyboard to 
continue. 

9. A confirmation appears on the screen indicating completion of the  
re-indexing process. Click X to close the Command Prompt window. 

Perform the following to change Default User Property: 
1. Click Object Properties > User. The User Default Property Values 

window appears. 

2.  At the bottom of the window is a choice for Web Document 
Submission User. Change the default for this property to No (the 
default will be Yes). Click Apply. Close all open windows. 

Note: Changing this default to No is important. If it remained as Yes, 
all users would be assumed to be Web Document Submission 
users by default.  
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16. Adding Additional Applications 

Web Document Submission natively translates Microsoft Office 
documents into PDF. If there is a specific application that is used by 
customers that is not a Microsoft product, documents for this application 
can be translated by adding the application to the Web Document 
Submission server. 

Guidelines for Adding Applications 

In order to ensure that Web Document Submission will recognize and use 
new applications, ensure that these guidelines are followed: 

• All additional applications must be installed on the Web Document 
Submission server 

• Log on to Web Document Submission as the services account  
xwdss-service before installing any software 

• Open any newly installed applications after installation while still 
logged on as xwdss-service so they can be associated with the 
xwdss-service account. 

• Shut down and restart the Web Document Submission system for the 
changes to take effect. 
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There is no way of knowing, short of installing the software on the Web 
Document Submission system, if a particular software package will work 
with Web Document Submission.  

CAUTION: After installing a new software package on the server, locate a PDF 
file on the server and double-click the file. If the fie does not open 
using Adobe PDF Reader, Web Document Submission will not display 
PDF previews. 
 
To correct this error, see the Troubleshooting chapter on page 24-1.
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17. Implementing the Copy Job Link 

The Web Document Submission system can be set to enable the Copy 
Job link on the Operator / Administrator View Job Details page.  

The purpose of the Job Copy link is to send a copy of the file submitted 
by a user, along with a copy of the job ticket and delivery ticket, to an 
external server. Print shop personnel open this folder, which has a folder 
name that matches the Job ID of the Web Document Submission job, and 
manually prepare the job outside of the Web Document Submission 
system. 

This chapter describes how to establish the link and how it is used. The 
online help system also describes, for Operators and Administrators, how 
to use the Copy Job link. 

Note: It is the responsibility of the print shop personnel to update the 
Web Document Submission system as a job is proceeding, 
even though the job is being processed outside of the system. 
Keep a user informed by attaching operator notes to the job. 

Copy Job Link Setup 

 Create User on the External Server 

Establish the Web Document Submission service user xwdss-service as 
a Power User on the external server. It is assumed that the external 
server is a Windows NT or Windows 2000 server.  
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To Create a System User for Web Document Submission: 
1. Click Start > Programs > Administrative Tools > Computer 

Management. 
2. The Computer Management window opens. Click + beside Local 

Users and Groups. The menu tree expands.  

3. Click Users and then right-click users to open the pop-up menu. 
Select New User. 

 
4. The New User window opens. Type xwdss-service in the User 

name box and xwdss-service in the Full name box. 

5. Type 1 for the Password and confirmation password. 

6. Clear User must change password at next logon. 

7. Select User cannot change password. 

8. Select Password never expires. Click Close. 
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9. The user appears in the right panel of the Computer Management 
window. Click the icon beside xwdss-service and then right-click to 
open the pop-up menu. 

 
10. The xwdss-service Properties window opens. Click the Member Of 

tab. 

11. The Member Of window appears. Click Add. 

12. The Select Groups window appears. Click Power Users and then 
click Add. The path to the Power Users object will appear in the lower 
portion of the window. Click OK. 

13. The window refreshes and shows that xwdss-service is now a 
member of the Power Users group. Click OK. 

Close the Computer Management window. 

Establish and Share a Folder on the External Server 

Establish a folder called CopyJob on the external server. This folder 
must be shared. For ease of maintenance, place this folder off the root of 
the C: drive.  
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To create and share a folder on the external server: 
1. Double-click My Computer. 
2. Double-click the C: drive. 

3. The C: drive folder opens. Click File > New > Folder. 
4. Name the folder CopyJob and press Return. 

5. Click the CopyJob folder and then right-click to open the pop-up 
menu. 

6. Click Sharing. 

7. The CopyJob Properties window opens. Click Share this folder. 
8. The Share name box is populated with CopyJob. Click OK. 

9. The CopyJob folder now has a sharing symbol on it. Close any open 
windows. 

Map to the External Folder on the Web Document Submission Server 

A drive mapping must be established on the Web Document Submission 
server to the CopyJob folder on the external server. The drive mapping 
cannot be a UNC path. 

To create a drive mapping on the Web Document Submission 
server: 
1. Right-click My Network Places on the desktop. 

2. Select Map Network Drive. 

3. The Map Network Drive window opens. Click Browse to browse for 
the Web Document Submission server and CopyJob folder or type the 
UNC path in the Folder box. 

4. Click the Drive drop-down menu and select an unused drive letter. 
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5. Click Finish. The new drive letter appears in My Computer and the 
drive window opens. Close any open drive windows and note the 
drive letter chosen. 

Add the Mapping Information to Configuration Manager 

To add the mapping to Configuration Manager: 
1. Open a browser window and log on to the Operator / Administrator 

Web Document Submission page. 

2. Click Administrator tools. 

3. The Administrator tools window opens. Click Choose option and 
select Configuration manager. 

4. Locate the Job Export options area. 

5. Type the mapped drive letter, and path if needed, to the external 
server in the Working jobs directory box. 

6. If job ticket and deliver sheet are not required, change true to false in 
the Job ticket/delivery sheet box. 

7. After these changes are made, scroll to the bottom of the page and 
click Update. 

8. The changes are saved. Click Home to return to the Operator / 
Administrator home page. 

Validate the Copy Job Link 

The last step is to validate that the Copy Job link is present in Web 
Document Submission. 

To validate the Copy Job link on Web Document Submission: 
1. Open a browser window and log on to the Operator / Administrator 

page. 
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2. Select any job by click its Job ID. 

3. At the top of the screen, look for the Copy Job link.  

4. Click Copy Job. The system will respond with a message that the job 
was copied. 

5. Go to the remote server and verify that the job ticket, delivery sheet, 
and job file were copied. 

If there was an error, check the steps up to this point and try copying 
the job again. 
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18. ASCII Job Ticket 

The print service for Web Document Submission provides support for the 
ASCII Job Ticket (XJT). The XJT is always pre-pended to generated 
PostScript files and the XJT mapping values are substituted in the XJT. 

It is the responsibility of the System Administrator to configure the 
mappings properly. 

Creating ASCII Job Ticket (XJT) Mappings 

XJT mappings are specified in the C:\xwdss\properties\job.xml file.  

Figure 18-1 shows an example of the values for stapling without XJT 
mappings. 

Figure 18-1. Values for stapling in job.xml 

 

Each item has an item name and various value names representing the 
allowable states for the value. 
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Figure 18-2 shows the changes made to the item name and value names 
to insert the XJT mappings. 

Figure 18-2. XJT mappings added to stapling in job.xml 

 
Use a text editor to insert the mappings into job.xml. Preview the xml file 
in Internet Explorer to make sure there are no errors in the file before 
placing the file in the Web Document Submission. 

Stop the Web Document Submission services, replace the job.xml file 
and then restart the Web Document Submission services to activate the 
changes. 

 

ASCII Job Ticket Values 

Refer to the Job Ticketing Guide or the support line for the particular 
device that requires XJT mappings. 
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19. Upgrade for Web Document 
Submission Version 2.0.1 to  
Version 2.1 

Follow this procedure to upgrade Web Document Submission from 
version 2.0.1 to 2.1. 

Note: This upgrade is supported only for full installations of 2.0.1, not 
customized installations. All other configurations and 
customizations will require a manual upgrade process. Contact 
Web Document Submission support for additional assistance. 

The upgrade process will migrate the following data files and some 
configuration files automatically: 

1. MySQL databases 

2. System templates 

3. User Interface configuration 

4. Repository files. 

Web Document Submission 2.0.1 Upgrade 

Perform the following to upgrade Web Document Submission 
version 2.0.1 to 2.1: 
1. If running, shut down Web Document Submission 2.0.1. 
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2. Install Web Document Submission 2.1 into a different directory than 
that used by 2.0.1. By default, version 2.0.1 installs in the C:\xdx 
folder, while 2.1 installs in the C:\xwdss folder. 

3. Set up Web Document Submission 2.1 as required by the Installation 
Planning Guide.  
 
Examine 2.0.1 job.xml and jobStates.xml files and modify the 2.1 
job.xml and jobStates.xml files to include any customizations that 
were implemented in 2.0.1. 

CAUTION: Do not simply copy the 2.0.1 job.xml and jobStates.xml files and 
place them into 2.1. The system will not function. 

4. Open a command window by clicking Start > Programs > 
Accessories > Command Prompt. 

5. Type cd c:\xwdss\scripts and press Enter on the keyboard. 
Substitute the correct Web Document Submission directory if it differs 
from xwdss. 

6. A command window opens. Type: 
 
upgrade2_0_sp1.bat <xwdss 2.0.1 home dir> <xwdss 2.1 home 
dir> 
 
Substitute <xwdss 2.0.1 home dir> with the drive and path to the 2.0.1 
files (for example: c:\xdx) 
 
Substitute <xwdss 2.1 home dir> with the drive and path to the 2.1 
files (for example: c:\xwdss 

7. Press Enter on the keyboard. 

8. As the data migration process runs, prompts will appear with 
instructions on starting and stopping the MySQL database server. 
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9. When the process is complete, restart the Web Document Submission 
server. Open a web browser and log on to Web Document 
Submission to verify that the upgrade was successful.
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20. Internationalization 

Web Document Submission 2.1 has been updated to include the ability to 
for administrators to chose or create language files. The language 
resource files that the system uses is determined in the 
Internationalization section of the Configuration Manager tool. 

The default language set is en_US – American English. 

Configuration Tool Settings 

Date time format 

Valid values are: SHORT, MEDIUM ,LONG, FULL.  

The default date time format is SHORT. 

Language code 

Valid values are ISO Language Codes. These codes are the lower-case, 
two-letter codes as defined by ISO-639. 

A full list of these codes can be found at 
http://www.unicode.org/unicode/onlinedat/languages.html.  

The default language code is <blank>. 

Country code 

Valid values are ISO Country Codes. These codes are the upper-case, 
two-letter codes as defined by ISO-3166. A full list of these codes can be 



INTERNATIONALIZATION XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.1 

20-2 INSTALLATION AND SYSTEM ADMINISTRATION GUIDE 

found at: 
http://www.din.de/gremien/nas/nabd/iso3166ma/codlstp1/en_listp1.html 

The default country code is <blank>. 

Variant 

The variant field is a vendor or browser-specific code. For example, use 
WIN for Windows, MAC for Macintosh, and POSIX for POSIX.  

Where there are two variants, separate them with an underscore, and put 
the most important one first. For example, a Traditional Spanish collation 
might construct a locale with parameters for language, country and 
variant as: es, ES, Traditional_WIN. 

The default variant is <blank>. 

Date display pattern 

The Date display pattern overrides the default date format pattern to be 
displayed to the user on the GUI. 

The default date display pattern is the system date pattern. 

Time display pattern 

 The Time display pattern overrides default date format pattern to be 
displayed to the user on the GUI. 

The default time display pattern is the system time pattern 

Date constraint pattern order 

The default date constraint pattern order is MDY. 
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Date constraint pattern delimiter 

The default date constraint pattern delimiter is a slash mark ( / ). The 
system will validate the date based on this delimiter. 

Resource file directory 

The directory where all resource files reside is: 
${WXPRESS_HOME}/properties/resources  

Creating a Language Set 

Two language resource files can be edited to add additional languages: 

• XwdssAdminMessages.xml 
• XwdssMessages.xml 

This example will modify XwdssMessages.xml to add French language 
strings. This would be repeated for all the strings in the resource file. 

To add a new language to a string in a resource file: 
1. Open a XwdssMessages.xml in a text or XML editor.  

2. Locate the string that needs language added and highlight the English 
string. In the example below, the resource name is 
button.addAnotherDoc, The string that needs to be copied is 
highlighted, begins with <locale name and ends with the closing tag 
</locale>. 
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3. Paste the highlighted text below itself. Change the language and 
location code appropriately. In this case it is fr_FR. Substitute the 
French phrase for the English phrase. 

 
4. When all the language changes have been made save the file and 

open it in Internet Explorer. If the file opens completely without 
warning, stop Web Document Submission services, and replace the 
existing resource file with this new one. 

5. Shut down and restart the Web Document Submission services. 

6. Open a browser window and log on to the Operator / Administrator 
Web Document Submission page. 

7. Click Administrator tools. 

8. The Administrator tools window opens. Click Choose option and 
select Configuration manager. 

9. Locate the Internationalization area. 

10. In the Language code box type fr. In the Country code box type FR. 
The French language messages will override the English messages. 

11. Shut down and restart the Web Document Submission services. 

12. Open a browser window and log on to the Operator / Administrator 
and the User Web Document Submission pages and ensure that the 
language changes made are functional. 

CAUTION: It is very important to check all pages and functions when adding 
another language. Strings with the same English verbiage may be 
used in different contexts on different pages and so translation may 
not be correct depending on the page the translation appears. 
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21. Manually Configurable XML Files 

There are XML files that can be manually configured for a customer. 
Unless specified in the Installation Planning Guide these messages will 
be the standard installed messages.  

 

E-Mail Configuration Files 

email-conf.xml 

The email-conf.xml file contains messages that the system sends to users 
by E-mail. A list of the messages follows: 

Registration 

Subject: XWDSS Registration 

This message has been sent to you from the Xerox Web Document 
Submission Software system. 

If you have received this message in error, please contact your system 
administrator. 

Please click on the following link to complete your registration process: 
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Job Complete 

Subject: Print Job is ready 

Your print job has been completed at the xxxx printshop. 

Lost Password 

Subject: Xerox Web Documents Submission Software password 

This message has been sent to you from the Xerox Web Documents 
Submission Software system. 

If you have received this message in error, please contact your system 
administrator. 

Repository Courtesy Warning 

Subject: XWDSS: Repository Courtesy Warning 

<Document.title> will be removed from the XWDSS repository soon, or 
after the job(s) it is involved with complete.    

To extend the length of time this document remains in your repository, log 
on to XWDSS, go to your repository, and follow the instructions on the 
screen 

Changing an E-mail message 

To change an E-mail message: 
1. Use Notepad to open C:\xwdss\properties\email-conf.xml. 
2. Look through the file to locate the message to be change. 

3. Only change the text between the E-mail subject t between the 
<subject> and </subject> tags and the E-mail message between the 
<![CDATA[ and the matching ]]> tags. 
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4. When the messages have been modified, save the file. Click Save As 
in Notepad. The Save As window appears. In the Filename box is 
email-conf.xml. Place quotation marks at the beginning and end of 
the filename or Notepad will save it as text instead of XML code. The 
filename will look like “email-conf.xml”. 

5. Click Save. Changes will be in effect after a restart of the Web 
Document Submission system. 

 

Job State Strings 

JobStateStrings.xml 

The JobStateStrings.xml file contains the test strings that are used by the 
print shop personnel to indicate the state of a job. 

If the language is unfamiliar to users, the messages can be modified. The 
only allowable change is the text string that follows the <![CDATA[ tag. 

Changing a Job State String 

To change a job state string: 
1. Use Notepad to open C:\xwdss\properties\ JobStateStrings.xml. 
2. Look through the file to locate the message to be change. 

3. Only change the text that follows the <![CDATA[ tag as shown below. 
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4. When the messages have been modified, save the file. Click Save As 
in Notepad. The Save As window appears. In the Filename box is 
JobStateStrings.xml. Place quotation marks at the beginning and 
end of the filename or Notepad will save it as text instead of XML 
code. The filename will look like “JobStateStrings.xml”. 

5. Click Save. Changes will be in effect after a restart of the Web 
Document Submission system. 
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22. Pricing 

Pricing is modified by using the Pricing configuration tool found at 
Administrator Tools > Pricing configuration on the Administrator 
Home page. 

The procedures for modifying prices on the Pricing configuration page are 
discussed by clicking Help on the Operator / Administrator web interface. 

This chapter deals with how to add or remove options that are available 
on the Pricing configuration screen. It also details how to make the 
additional changes required on other Web Document Submission web 
pages that will complete the addition of an option. 

Note: These procedures are performed on the Web Document 
Submission server. 

WARNING! Make a copy of the C:\xwdss\properties folder before 
attempting to make any changes to pricing. If errors are 
made, the system can be restored to the original values. 

Adding an Option to Pricing 

If a customer requires an option added to the pricing scheme, the 
examples and accompanying code that follow will show how this is done.  
The examples that follow add the option “Shoe size” along with five 
different sizes that will appear in a drop-down menu. Use the example as 
a model of how to add pricing options. 
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Add an optionName to job.xml 

The first step in adding an option to pricing is to add an optionName.  
An optionName is a variable name for a job option. 

Perform the following to add an optionName as a drop-down menu: 
1. Using Notepad, a text editor, or an XML editor, open 

c:/xwdss/properties/job.xml. 
2. Move to the section of the code where the new option will be added.  

3. Copy and paste a section of existing code and modify it. In the 
example below, the highlighted area was copied and pasted just 
below and then modified to be the new code that is shown 
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4. The item name= is modified to add special_paper. This variable will 

contain the type of special paper that a user selects. 

5. Insert a value name for each value that will appear in the special 
paper drop-down menu. In this case each value is simply the type of 
special paper being used. 
 
Instead of hard-coding the actual sizes in this code, these are 
variables that stand in for real sizes that are defined in 
jobOptionlabel.xml. 

6. Save job.xml. 
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Add string values to jobOptionlabels.xml 

The jobOptionslabels.xml file contains all the string values for Web 
Document Submission. The optionName and value names just added in 
the last procedure must be added to jobOptionlabels.xml with their 
accompanying English text. 

Perform the following to add string values to jobOptionlabels.xml 
1. Using Notepad, a text editor, or an XML editor, open 

c:/xwdss/properties/resources/jobOptionlabels.xml. 
2. Move to the end of the code where the new strings will be added. 
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3. Copy and paste a section of existing code and modify it. In the 
example below, the highlighted area was copied and pasted just 
below and then modified to be the new code that is shown.  

 
4. In the example above, the optionName special_paper was added as 

a resource name and the English data string Special paper was 
added between the CDATA brackets [ ].  
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5. The value names for the different special paper types were added as 
resource names and their English data strings were added. 
 
Each time the Web Document System sees a variable name, it goes 
to this file to display the string that was entered. For example, the 
program sees two_tone but displays Two tone. This way changes 
can be made quickly without having to hard code anything but 
variable names. 

6. Save jobOptionlabels.xml. 

Add pricing information to pricing.xml 

Perform the following to add pricing information to pricing xml: 
1. Using Notepad, a text editor, or an XML editor, open 

c:/xwdss/properties/resources/pricing.xml. 
2. Move to the end of the code where the new code will be added. 
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3. Copy and paste a section of existing code and modify it. In the 
example below, the highlighted area was copied and pasted just 
below and then modified to be the new code that is shown. 

 
4. The optionName value= is the same as has been used for the 

optionName used in job.xml.  
5. The optionValue value= is the same as has been used for value 

names in job.xml. The difference here is to add a cost for each value. 
If a cost has not yet been given for the values, type 0.00 and the 
values can be added later in the Pricing configuration tool. 
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6. If tiered pricing is required, after adding an optionValue value= two 
or more lines are required to establish the values for the tiers. 
 
Shown below, impression_count value requires a price break value, 
op requires an operator, and cost requires the cost of the value if 
true. 
 
When inserting the code for tiered pricing, be sure to remove cost= 
and the value for the cost and the closing slash ( / ) after 
isResourceString=”true” 
 
Operator values can be le (less than), lte (less than or equal to), e 
(equals), gt (greater than), or gte (greather than or equal to). 
 
Cost can be any amount and is not limited to just two decimal places. 
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Tiered pricing is not limited to just two prices. There can be as many 
tiers as desired for a particular option value. For example, a price 
break could be given after 50, 100, 150, 200, 1000, or 2000 
impressions. These could be constructed using the operator values. 
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The resulting pricing page from the code, as modified above, is shown 
below. 

 
7. Save pricing.xml. 
8. In order to see and validate the changes for the Pricing configuration 

page, restart the Web Document Submission system. 
9. Log on to the Administrator Home page and click Administrator 

Tools > Pricing configuration. Look for the changes that have been 
made. If there are any errors, go back through the code changes to 
locate and correct the mistakes. The system must be restarted for any 
changes to take effect. 
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Add the new option to xbsPrintOptions.jsp 

In order for the new option to be available to users, the option has to be 
added to the xbsPrintOption.jsp page. 

Perform the following to add the new option to xbsPrintOptions.xml: 
1. Select a page for the location of the new option. In this example, the 

new option drop-down menu will appear on xbsPrintOptions.jsp. 

2. Decide where on the page the new option will appear. The drop-down 
menu for special paper will appear to the right of Produce on color 
device. 

 
3. Using Notepad, a text editor, or an XML editor, open 

c:/xwdss/etc/tomcat4.0/webapps/xdx/htmlCode/xbsPrintOptions.jsp. 

4. Locate the code for Produce on color device. 

 

Each new line on the user interface begins with the code  
<tr class=”trStyleA”> or <tr class=”trStyleB”>. This tag starts a new 
table row and colors the background of each line. The StyleA tag is the 
light background and the Style B tag is the dark background. Pay close 
attention to these tags if adding complete new lines since all the following 
lines will be incorrect with respect to shading. 
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5. The next line sets up the code for the text that is visible to the user. 
 
<td><xdx:label name="produce_on_color_device" /></td> 
 
The html tag <td> describes that the code that follows is table data. 
 
The tag xdx:label name= will show the text string for the Web 
Document Submission variable between the quotations marks. In this 
case, the text string that is associated with the variable 
"produce_on_color_device" will be displayed on the user interface. 
 
The final tag </td> closes this piece of the table data. 

6. The third line is the code to accept the value that the user will input. 

<td colspan="3"><xdx:input scope="document"  type="select" 
name="produce_on_color_device" /></td> 

A row is defined as having four columns on this page. Since there are 
only two pieces of data being shown – the text “Produce on color 
device” and the checkbox that accompanies the text, there is not 
enough data to fill out the line.  The result would be that the gray bar 
for that row would not carry across to the right side. 

<td colspan="3"> places the next piece of data on the screen – the 
checkbox -  and then fills or “spans” the next three columns with the 
correct gray bar.  

Another way to fill the rest of the line with the appropriate color is to 
add two sets of tags that are simply table data with a blank space in 
between. The code looks like this: <td>&nbsp;</td> <td>&nbsp;</td>  

xdx:input scope= indicates what type of data option follows. The 
scope can be job, document, or recipient. If the scope is not given, the 
default is job.  
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The type= tag indicates what type of input is to be expected. The 
default value is “select,” which is for a drop-down menu. Since “select” 
is a default value, it could have been left out of the code above. 
 
The type= values are text, text area, checkbox, and select. 

7. The last tag shown is </tr>, which will end the row. 

8. Putting this all together, construct the new code to add the Special 
paper drop-down menu. Copy the section of code for 
“produce_on_color_device and paste it below itself. 
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9. Modify the pasted code.  Delete the <td colspan="3"> tags since 
they are no longer needed and replace them with  <td> tags because 
the shoe size code fills out the row. Change the label name to 
“special_paper” and the input name to “special_paper.” Since 
there was no type specified, the program assumes is a drop-down 
menu. 

10. Save the changes to xbsPrintOptions.jsp 

11. Stop and restart the Web Document Submission system. 

12. Open a browser window and log in to the system as a user. 

13. Submit a hardcopy job and examine the first option screen. If all the 
coding is correct, the label and the accompanying drop-down menu 
will appear with the correct values.  

 
14. If there are errors on the page, check the coding done in this section 

Stop and restart the system for any changes to take effect. 
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Add the new option to job summary or print option pages 

Next to be modified are either the xbsPrintOptionsSummary.jsp page, 
which deals with print options, or the xbsJobSummaryScreen.jsp page, 
which deals with recipient options. These two pages are actually 
combined on the Summary page. 

The example being shown will appear with the print options section. The 
process is much like adding to the xbsPrintOptions.jsp page. 

Perform the following to modify the Summary.jsp pages: 
1. Decide where on the page the new option will appear. The 

confirmation information for shoe size will appear to the right of 
Produce on color device. 

2. Using Notepad, a text editor, or an XML editor, open 
c:/xwdss/etc/tomcat4.0/webapps/xdx/htmlCode 
/xbsPrintOptionsSummary.jsp. 

3. Locate the code for Produce on color device. 

 
4. This code resembles the xbsPrintOptions.jsp page with some 

differences 
 
span style= indicates the weight of the font. In this case the font-
weight of 400 is bold-faced type. 
 
type= indicates the data is for display only, not for input. 
 
/span ends the bold-faced typed. 
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5. Construct the new code to add the Special paper to the summary 
page. Copy the section of code for “produce_on_color_device and 
paste it below itself. 

6. Modify the pasted code.  Delete the <td colspan="3"> tags since 
they are no longer needed and replace them with  <td> tags because 
the shoe size code fills out the row. Change the label name to 
“special_paper” and the display name to “special_paper”.  

7. Save the changes to xbsPrintOptionsSummary.jsp. 

8. Stop and restart the Web Document Submission system. 

9. Open a browser window and log in to the system as a user. 

10. Submit a hardcopy job and select a value for Shoe size. If all the 
coding is correct, the value chosen will appear on the summary page. 

 
11. If there are errors on the page, check the coding done in this section 

Stop and restart the system for any changes to take effect. 
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Add new option to templates 

The final step is to modify the two template files, if needed. In this case 
only coversheet.tpl needs to be modified since the addition of shoe size 
does not affect the delivery sheet. 

Perform the following to modify a template to add the new option: 
1. Decide where on the page the new option will appear. The information 

for shoe size will appear along with Produce on color device. 

2. Using Notepad, a text editor, or an XML editor, open 
C:\xwdss\etc\tomcat4.0\webapps\xdx\templates\coversheet.tpl 

3. Locate the code for Produce on color device. 

 
4. By now, this code should look familiar. Since 

produce_on_color_device used to be alone on a line, it has the  
<td colspan="3"> tag, which will be replaced with a <td> tag. 
 
type= is “display” since this code is designed to display results rather 
than input data. 
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5. Construct the new code to add the Special paper to the coversheet 
page. Copy the section of code for “produce_on_color_device and 
paste it below itself. 

 
6. Modify the pasted code.  Delete the <td colspan="3"> tags since 

they are no longer needed and replace them with  <td> tags because 
the shoe size code fills out the row. Change the label name to 
“special_paper” and the display name to “Special paper”. 

7. Save the changes to coversheet.tpl. 
8. Stop and restart the Web Document Submission system. 

9. Open a browser window and log in to the system as a user. 

10. Submit a hardcopy job and select a value for Special paper. Log out 
as a user and log in again as the Administrator. Print the coversheet 
for the job just submitted. If all the coding is correct, the value chosen 
will appear on the coversheet. 

11. If there are errors on the page, check the coding done in this section 
Stop and restart the system for any changes to take effect. 

Summary 

This set of procedures has been designed to show how to add a new 
option to the Pricing page and how code must be added to a variety of 
other Web Document Submission pages in order for it to take effect. 
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Modify the procedures to add checkboxes, text fields, but follow the 
procedure as shown here. 

Removing an Option from Pricing 

If a customer requires an option removed from the pricing scheme, use 
the examples and the workflow detailed above in the section on Adding a 
Option to Pricing. The code can be physically deleted, but another 
method is to add comment code to any sections of code that need to be 
removed. This way, if a customer changes their mind, the comment tags 
just have to be removed. 

There are different comment code tags depending on the type of file. JSP 
pages require a different comment tag than XML pages. 

Remember that if complete lines are removed, it will probably change the 
code for TrStyle color bars.  

JSP 

<%-- code to be commented out --%> 

Enclose the code to commented out in the characters shown above. 
When the system encounters code enclosed in the comment tags, it 
ignores the code between the comment tags. 

XML 

<!-- code to be commented out --> 

A subtle difference, but for any XML pages, use the example given above 
to comment out any code that is no longer needed. 
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23. Removing Web Document 
Submission 

This chapter describes how to remove Web Document Submission. 

CAUTION: This procedure will delete the entire Web Document Submission 
system and all documents, jobs, and user files that are currently in the 
system. 

Removing Web Document Submission 

Perform the following to remove Web Document Submission if 
Installation CD is available: 
1. Shut down Web Document Submission by clicking Start > Run. Type 

in the Open box net stop xwdss and click OK. 

2. Insert the Web Document Submission installation CD in the CD drive 

3. Open My Computer and the CD drive where the Web Document 
Submission CD resides. 

4. Double-click runInstaller.bat. 
5. The XWDSS Installation window appears. Click Uninstall. 
6. The Select XWDSS directory window appears. Browse and select 

the directory where Web Document Submission was installed. This 
will typically be c:\xwdss. 

7. A message appears that “XWDSS Services must not be running 
during the uninstall process.” Click OK. 
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8. After a few minutes, a message will appear that the process 
completed successfully. Click OK. 

9. The Web Document Submission system is now closed.  
 
If there was an error during uninstall, try the procedure again. If 
uninstall fails again, use the manual procedure for uninstall that 
follows. 

Perform the following to remove Web Document Submission is 
installation CD is not available 
1. Shutdown the Web Document Submission system by either stopping 

the service (if installed) or running xwdss-shutdown.bat. 
2. Open the Installation directory, typically c:\xwdss. 

3. Open the c:\xwdss\scripts directory 

4. Double-click uninstall-service.bat. 
5. Double-click uninstall-apache.bat. 
6. Double click uninstall-conversion-services.bat. 
7. Go to c:\. 
8. Locate the xwdss folder. Click once on the folder to highlight it.  

Press the Delete key on the keyboard 

9. The Confirm Folder Delete window appears. Click Yes. 

10. If a Confirm File Delete window appears, click Yes to All. 
 
The removal of Web Document Submission is complete. 
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Removing Third-party Software  

Installed with Web Document Submission were: 

• Microsoft Office 
• Adobe Acrobat Reader 
• WinZip (or equivalent) 

Use the Add / Remove Programs Control Panel application to remove 
these programs. 
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24. Troubleshooting 

This section describes two methods for helping to diagnose problems that 
may occur. For further assistance with troubleshooting problems, consult 
Chapter 18 – Contacts and Escalation Process. 

Installation Problems 

The simplest way to ensure there are no installation problems is to have a 
clean server. Remove all old versions of Web Document Submission or 
Documents Xpress. Any existing versions of MySQL and any Java must 
also be removed using their own uninstall programs. 

Ensure that Microsoft Internet Information Services (IIS) is disabled. 

If an installation is not working, often it is easier to uninstall the software 
and begin the installation again. Shut down Web Document Submission 
and restart the server. After the server has restarted, insert the installation 
CD and reinstall the software. 

Re-initializing the User Database 

CAUTION: Use the following instructions with caution since they cannot 
be reversed. All existing Web Document Submission user 
data will be lost and all jobs associated with the user. System 
configuration changes and user interface changes are 
unaffected. 

If a user list is imported in error, the standard method of cleaning up the 
list is to inactivate the undesired users.  
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If a user list is imported incorrectly BEFORE the system has been placed 
into production, the entire user database, along with the repository and 
any Web Document Submission information can be removed. NEVER 
use this procedure on an operational system. 

Note: Re-initialization can also be accomplished by reinstalling the 
complete Web Document Submission system. All system configuration 
and user interface changes will be lost. 

Ensure that the Web Document Submission system is running in order to 
perform the next procedure. 

Perform the following to re-initialize all the Web Document 
Submission databases: 
1. Go to C:\xwdss\scripts and click, in order: 

Init-02-EraseAllTables.bat 
Init-01-ConfigMySQL.bat 
 

Executing these batch files will restore all databases to the state they 
were in when the system was first installed. 

2. Any field configuration and mappings customization will have to be 
redone. 

Re-establishing PDF Files with Adobe Acrobat 

If a software package that has been installed on the server opens PDF 
files, the PDF preview links will not function. 

Follow this procedure to re-establish Adobe Acrobat Reader as the 
program that opens PDF files. 
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To select Adobe Acrobat Reader to open PDF files: 
1. Go to C:\xwdss\repository. 

2. Click on a PDF file to highlight it. Right-click to open the pop-up menu. 

3. Select Open with > Choose Program. 

4. The Open With window opens. Locate Adobe Reader in the list and 
click once to highlight it. 

5. Select Always use this program to open these files. 

6. Click OK.  

7. The file selected will open in Acrobat reader and the icon for PDF files 
will change to the Adobe PDF icon. 

8. Close any open windows. 

Known Issues 

Netscape as Default Browser 

If Netscape is chosen as the default browser and Internet Explorer is 
open and a user uploads a file using Adobe PDF Transit, the upload will 
appear to be successful, but a new browser window for the user to log on 
will never appear. When the user checks, their document has not been 
uploaded to the repository. 

The workaround it to only have one type of browser open at any time 
while using Web Document Submission. In this case, close the Internet 
Explorer window and resubmit the job. The log on window will appear 
once the document has been uploaded. 
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Using XPD for upload and then trying to preview PDF 

If the XPD has been used to upload a file and the user clicks the PDF 
preview link, a preview will not appear. 

A new browser window will appear, but it is a browser with system 
settings instead of the settings that belong to the user. The new browser 
window has none of the settings that the user has, including proxy 
settings. As a result, no preview will appear. 

The workaround is to close the window. Open a new browser session, 
except this time it will have the settings that belong to the user. If the user 
goes to Job status, they can see a preview of the file uploaded.
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25. Contacts and Escalation Process 

This chapter describes the support process and support contacts 
available for Web Document Submission. 

Web Document Submission Support Process 

At the time of installation, a Customer Solution Administrator (CSA) will 
be identified. The CSA is available to manage all software-related issues. 
The CSA, who has the skills of a system administrator, handles the  
day-to-day service and support operations at the customer site. The CSA 
is the main interface to the Web Document Submission Support Center. 

CAUTION: If a problem relates to a Xerox output device and not the software 
please contact the appropriate Xerox Support Center for that product. 
If a problem relates to the computer server hardware, contact the 
manufacturer of the server. 

Here is the process for initiating support: 

1. When the end user or operator encounters an error with the software, 
they should contact the CSA.  

2. The CSA performs system level isolation and problem resolution for 
Web Document Submission.  

3. If the CSA is not able to resolve the problem, the problem is escalated 
to Web Document Submission Support Center for support. 

CAUTION: Only the CSA can call the hotline for support. 
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Support Contacts 

Web Document Submission has an e-Support website available at 
http://www.xerox.com/webdocumentsubmission/support. The e-Support 
website provides a searchable knowledge base, Frequently Asked 
Questions (FAQs), and the ability to submit a support request via E-mail. 

Contact the designated CSA for support. The CSA will contact the Web 
Document Submission Support Center if they require additional 
assistance. The Support Center can be reached at  
1-888-508-5244, 8:00 a.m. to 5:00 p.m., Monday through Friday, local 
time, continental USA. 
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A. Default Configuration Manager 
Values 

This section details the default values of all the fields in the XWDSS 
Admin Tools – Configuration Manager. To view these default values, start 
the XWDSS Admin Tools. Click Administrator tools > Configuration 
manager.  

When modifications are made, ensure that the modifications are saved 
from within the Configuration Manager. For the changes to take effect, 
restart the Web Document Submission system. 

The following tables follow the order of the Configuration Manager page. 

 System Properties 

Table A-1 contains the most basic information about the system, such as 
the server’s IP address and the directory where Web Document 
Submission is installed.  

Table A-1. System Properties 

Property Name Default Value Description Editable? 

Install directory C:/xwdss The directory path where Web 
Document Submission is 

installed 

no 

Server IP <Server IP address> The IP address of the server no 

Temp dir ${WXPRESS_Home}/temp The directory used to store 
temporary files 

no 

XWDSS version <software version number> The current release version 
number 

no 
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Application Homes 

Information about where various applications are installed that Web 
Document Submission depends on. Table A-2 contains information where 
the various applications are installed. 

Table A-2. Application Homes 

Property Name Default Value Description Editable? 

Tomcat home ${WXPRESS_HOME}/etc/To
mcat4.0 

Location where Tomcat is 
installed 

no 

Java Runtime 
home 

${WXPRESS_HOME}/etc/jre Location where the Java 
runtime environment is 

installed 

no 

Java executable ${JRE_HOME}/bin/java.exe Path to the Java executable 
file 

no 

Users 

Table A-3 contains information about managing the User Group Directory 
database. 

Table A-3. Users 

Property Name Default Value Description Editable? 

User import file ${WXPRESS_HOME}/scripts
/system_users.txt 

Location of file that holds 
information about users to be 

imported into the Web 
Document Submission system 

no 

User mappings file ${WXPRESS_HOME}/proper
ties/UserMappings.xml 

Location of file that hold 
information about user import 

field mappings 

no 
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Database 

Table A-4 contains Database Configuration properties. 

Table A-4. Database 

Property Name Default Value Description Editable? 

Database server ${SERVER_IP} IP address of the database 
server 

no 

Database 
username 

dxroot Username used to log into 
database 

no 

Database 
password 

dxroot Password used to log into the 
database 

no 

JDBC protocol mysql 
 

Protocol used to connect to 
the database 

no 

JDBC driver org.gjt.mm.mysql.Driver Driver used to connect to 
database 

no 

Max database 
connections 

75 Maximum number of allowed 
open concurrent database 

connections 

no 

Max database 
connection usage 

1000 Maximum number of allowed 
times a database connection 

can be used before closing the 
connection 

no 

Document table DOCUMENTS Name of the table in the 
database that stores document 

information 

no 

Accounting 
database 

DocumentsXpress Name of the database used to 
store job information 

no 
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Table A-4. Database (continued) 

Property Name Default Value Description Editable? 

Address book 
database 

UserGroupDirectory Name of the database used to 
store personal address book 

information 

no 

Authorization 
database 

DocumentsXpress Name of the database used to 
store user passwords 

no 

Authorization table AUTH Name of the table used to 
store user passwords 

no 

Printer table PRINTERS Name of the table used to 
store information about 

printers 

no 

Printer database DocumentsXpress Name of the database used to 
store information about 

printers 
 

no 

User database UserGroupDirectory Name of the database used to 
store information about users 

no 

User table GROUPS Name of table used to store 
information about users 

no 

Document 
database 

Repository Name of database used to 
store information about 

documents 

no 
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Documents 

Table A-5 contains properties dealing with document management. 
These properties control what types of documents Web Document 
Submission accepts, what conversions are available, how long 
documents are stored, warning day limits, and where the document 
directory resides. 

Table A-5. Documents 

Property Name Default Value Description Editable? 

Document Lifetime 2 Number of days the system 
keeps documents before 

deleting 

yes 

Warning Days 2 The system sends a warning 
message to users prior to 

deleting their documents. This 
property determines how this 
message is sent (number of 
days before the document is 

deleted) 

yes 

Document 
Directory 

${WXPRESS_HOME}/reposit
ory 

The directory where the 
system stores uploaded 

documents 

no 
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Web Server 

Table A-6 contains properties that control the behavior of the web server. 

Table A-6. Web Server 

Property Name Default Value Description Editable? 

Admin URL http://${SERVER_IP}/xdx/ad
min 

URL to the Admin login page no 

User page size 40 Number of users to display per 
page for the global address 

yes 

User URL http://${SERVER_IP}/xdx URL to the User login page no 

Servlet URL http://${SERVER_IP}/xdx/ser
vlet 

URL to the servlet directory 
where all the utility servlets are 

located 

no 

Login page login.jsp Default login page no 

Routing false Flag to indicate whether 
routing is enabled 

no 

Fetch servlet fetch Name of servlet used to 
download documents 

no 

Password required true Flag indicated whether users 
are required to have 

passwords to get into the 
system 

no 

Root directory ${WXPRESS_HOME} Web Document Submission 
install directory 

no 

Session timeout 30 The number of minutes a web 
session lasts before timing out, 
and thus requiring the user to 

re-logon 

yes 
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Table A-6. Web Server (continued) 

Property Name Default Value Description Editable? 

Operator default 
job state filter 

created, held Comma delimited list of job 
state names. Use “All Jobs” to 

view all jobs. 

yes 

Job view list size 50 Maximum number of jobs to 
display per page 

yes 

 

Configuration Files 

Table A-7 contains additional configuration files that the system requires. 

Table A-7. Configuration Files 

Property Name Default Value Description Editable? 

Template directory ${WXPRESS_HOME}/templa
tes 

Directory where job templates 
are stored 

no 

Job descriptions ${WXPRESS_HOME}/proper
ties/job.xml 

File that describes print jobs 
for the print shop 

no 

UI default values ${WXPRESS_HOME}/proper
ties/uiconfig.properties 

File where the default UI 
configuration values are stored 

no 

Delivery sheet 
template 

${WXPRESS_HOME}/proper
ties/deliverysheet.tpl 

File that describes format of 
printed delivery sheets 

no 

Job ticket template ${WXPRESS_HOME}/proper
ties/coversheet.tpl 

File that describes format for 
printed job ticket 

no 

XSL cache ${WXPRESS_HOME}/proper
ties/xslt-cache.xml 

XSL Cache file keeps list of xsl 
files available for use by the 

system 

no 

E-mail conf ${WXPRESS_HOME}/proper
ties/email-conf.xml  

File that describes the E-mail 
configuration. 

no 

Job states conf ${WXPRESS_HOME}/proper
ties/jobStates.xml  

File that describes the job 
states configuration. 

no 
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Property Name Default Value Description Editable? 

Conversion Config 
File 

${WXPRESS_HOME}/proper
ties/xwdss-conversion.ini  

File that describes the 
conversions the system can 

perform. 

no 

Pricing Config File ${WXPRESS_HOME}/proper
ties/pricing.xml  

File that describes the pricing 
structure and costs associated 

with priced items. 

no 

 

E-mail 

Table A-8 contains properties to control how the system handles and 
sends E-mail. 

Table A-8. E-mail 

Property Name Default Value Description Editable? 

E-mail subject XWDSS repository courtesy 
warning 

The subject line of E-mail 
messages sent to warn users 
that their documents will be 

deleted 

yes 

Admin E-mail 
address 

user@domain.com The from E-mail address used 
by the system when sending 

E-mail to users 

yes 

E-mail enabled true Flag to indicate the enabling 
/disabling of E-mail messages 

to users 

yes 

E-mail footer <blank> Text appended to the end of 
every outgoing E-mail 

message 

yes 

Printshop name XBS  Name of the print shop, used 
in E-mails to users 

yes 

E-mail server <IP address of email server> IP address of an E-mail server 
that can forward E-mail 

yes 
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DocuShare 

Table A-9 contains information about DocuShare integration. 

Table A-9. DocuShare 

Property Name Default Value Description Editable? 

DocuShare eerver <blank> URL for the DocuShare server yes 

DocuShare 
username 

<blank> Username used to log into 
DocuShare 

yes 

DocuShare 
password 

<blank> Password used to log into 
DocuShare 

yes 

DocuShare 
timeout 

30000 Timeout (in milliseconds) for 
retrieval of DocuShare 

document from the DocuShare 
system 

yes 
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Printing 

Table A-10 contains configurable printing properties. 

Table A-10. Printing 

Property Name Default Value Description Editable? 

CPS deliverer com.xerox.xdx.services.print.
deliver.cps.CpsDeliverer 

CPS print deliverer no 

CPS deliverer 
donfig 

${WXPRESS_HOME}/proper
ties/cps.deliverer.xml 

Configuration file for CPS print 
deliverer 

no 

Default deliverer com.xerox.xdx.services.print.
deliver.StandardDeliverer 

Default printer deliverer no 

Default deliverer 
config 

${WXPRESS_HOME}/proper
ties/standard_deliverer.xml 

Configuration file for the 
default print deliverer 

no 

Printing dropbox ${WXPRESS_HOME}/temp Directory where print jobs are 
archived for downloading from 
the web server. Used primarily 

for remote printshops that 
want to print jobs 

no 

Job ticket auto 
print 

False If true, then job tickets will 
automatically be printed for 

every job when the user 
submits it 

no 

Print job spool 
directory 

${WXPRESS_HOME}/printJo
bs 

Directory where print jobs are 
spooled. 

no 
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Internationalization 

Table A-11 contains configurable internationalization values. 

Table A-11. Internationalization 

Property Name Default Value Description Editable? 

Date time format SHORT Valid values are: 
{SHORT,MEDIUM,LONG,FUL

L} 

yes 

Language code <blank> The language argument is a 
valid ISO Language Code. 
These codes are the lower-
case, two-letter codes as 

defined by ISO-639. You can 
find a full list of these codes at 

a number of sites, such as: 
http://www.ics.uci.edu/pub/ietf/

http/related/iso639.txt 

yes 

Country code <blank> The country argument is a 
valid ISO Country Code. 

These codes are the upper-
case, two-letter codes as 

defined by ISO-3166. A full list 
of these codes can be found at 

a number of sites, such as: 
http://www.chemie.fu-

berlin.de/diverse/doc/ISO_316
6.html 

yes 
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Table A-11. Internationalization (continued) 
 

Property Name Default Value Description Editable? 

Variant <blank> The variant argument is a 
vendor or browser-specific 

code. For example, use WIN 
for Windows, MAC for 

Macintosh, and POSIX for 
POSIX. Where there are two 
variants, separate them with 
an underscore, and put the 
most important one first. For 

example, a Traditional Spanish 
collation might construct a 
locale with parameters for 

language, country and variant 
as: es, ES, Traditional_WIN. 

yes 

Date display 
pattern 

<blank> Overrides default date format 
pattern to be displayed to the 

user. 

yes 

Time display 
pattern 

<blank> Overrides default date format 
pattern to be displayed to the 

user. 

yes 

Date constraint 
pattern order 

MDY Example MDY yes 

Date constraint 
pattern delimiter 

/  yes 

Resource file 
directory 

${WXPRESS_HOME}/proper
ties/resources  

 no 
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B. Default Resource File Manager 
Values 

This section details the default values of all the fields in the XWDSS 
Admin Tools – Resource File Manager. To view these default values, 
start the XWDSS Admin Tools. Click  Administrator tools > Resource 
file manager.  

When modifications are made, ensure that the modifications are saved 
from within the Resource File Manager. For the changes to take effect, 
restart the Web Document Submission system. 

The following tables follow the order of the Resource File Manager page. 

Exceptions 

Table B-1 contains configurable error messages for exceptions that may 
occur in Web Document Submission. Any of these messages may be 
modified. 

Note: All values are editable in the following table. The Property 
Name and Default Values provide enough information that a 
description is not necessary for this section. 
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Table B-1. Exception Messages for system locale en_US 

Property Name Default Value 

InvalidRegistrationException Invalid registration information. 

NoAddressBookInformationException User address book not found. 

NoPrintManagerServiceException Print manager service not found. 

InactiveUserException This user has been marked as inactive. 

NoConverterServiceException Conversion service not found. 

UpdatePropertiesFailedException Properties update failed. 

DocumentRequiredException No document was selected. 

FirstNameRequiredException First name is a required field. 

TemplateNameInUseException Template name already exists. 

NoSuchAddressBookEntryException Requested address book entry not found. 

PrinterSelectionRequired No printer selected. 

InvalidRecipientException Invalid recipient. 

TemplateEditException Failed to edit template. 

InvalidReportNameChars Report name cannot contain the following 
characters: \ / ; : , < > " ' 

ReportLoadingException Failed to load report. 

InvalidCredentialException Invalid password. 

ReportSaveFailedException Failed to save report. 

ReportDoesNotExistException Report does not exist. 

InvalidTemplateException Invalid template selections. 

InvalidPasswordException Invalid password change. 
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Table B-1. Exceptions (continued) 

Property Name Default Value 

NoSuchUserException User not found. 

CopiesNumberFormatException Number of copies must be a valid number greater 
than or equal to 0. 

FailedToRefeshReportingTablesException Failed to refresh reporting tables. 

JobStatusUpdateFailedException Job status update failed. 

FnameLnameRequiredForRecipient Address Book entries must have a first and last 
name. 

NotLoggedInException You are not currently logged on. 

NoRecipientsException No recipients have been chosen. 

DuplicatePrinterInfoException This printer already exists. 

UnableToRetrieveReportException Unable to retrieve report at this time. 

FaileduserRegistrationException We are not able to process the registration 
request. Please try again. 

RequiredFieldNullException Required field not populated. 

CancelJobException Cancel job failed. 

NoAuthenticatorServiceException Authenticator service not found. 

PrinterAddFailedException Add printer failed. 

InvalidEmailException Invalid E-mail address. 

PreviewFailedException Preview failed. 

PasswordConfirmException Your password entries did not match. 

ReportingFieldsRequiredException No reporting fields were selected. 

DuplicateDocumentException Cannot add same document to job twice. 

RepositoryFailedException Error in the document repository. 

NoPrinterInfoException Printer information not found. 

UnknownEntryException Address book entry not found. 
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Table B-1. Exceptions (continued) 

Property Name Default Value 

PrintServiceException Printing service has failed. 

NoRepositoryServiceException Repository service not found. 

UserAlreadyRegisteredException User already registered. 

TemplateCreateException Failed to create template. 

UserDoesNotOwnException You are not the owner of this job. 

NoDocumentSelectedException Document not selected. 

EmptyResourceListException Permission denied. 

MultipleLoginException Multiple log on exception. 

ReportNameRequiredException The report name cannot be empty. 

UpdateProfileException First name and last name are required fields. 

InvalidJobIdException Invalid Job ID. 

DataCorruptedException The database may be corrupted. 

NoUGDServiceException User group directory service not found. 

TemplateDeletionException Failed to delete template. 

RecipientInUseException Recipient not deleted. Cannot delete a recipient 
assigned to an active job. 

InvalidPageCountException Invalid page count. 

JobPriceMustBeGreaterThanZeroException The job price must be greater than or equal to 
zero. 

SessionTimeOutException The session has timed out. Please log on again. 

InvalidTemplateNameChars Template name cannot contain the following 
characters: \ / : < > " ' 

InvalidLoginException The log on information was incorrect. Please try 
again. 

InvalidReportingFieldOrderNumberException Field order must be an integer. 
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Table B-1. Exceptions (continued) 

Property Name Default Value 

NoAddressBookServiceException Address book service not found. 

InvalidDocumentHandleException Invalid document handle. 

InvalidJobPriceFormatException The job price must be a valid numeric format. 

FileUploadFailedException File upload failed. 

InvalidReportingFieldOrderNumber Ordering fields must contain integers. 

NoSuchPropertyException Property not found. 

UnableToCreateReportException Unable to create report at this time 

NoAccountingServiceException Accounting service not found. 

XDXConversionFailedException Document conversion failed. Please verify the 
document format is valid. 

LastNameRequiredException Last name is a required field. 

RegistrationEmailExpiredException The registration E-mail has expired. Please re-
register. 

UserUnregisteredException You are not a registered user. 

InvalidJobException Invalid job selections. 

InvalidLicenseException Invalid license key. 

UnsupportedFileTypeException File type not supported. 

TemplateNameRequired Template name is a required field. 

NoJobCreatedException Job creation failed. 

InvalidPrintShopException Invalid print shop. 

UnknownSystemErrorException An unknown error occurred. 

UserNameAlreadyUsedException User name is already in use. 

PricingXMLSaveException Failed to store pricing configuration. 

InvalidateRecDocCopyCountException The following documents have no recipients: 

RecHasNoDocumentsException The following recipients have no documents: 

DocumentUpdateFailedException Document update failed. 
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Table B-1. Exceptions (continued) 

Property Name Default Value 

RequiredFieldsException Please review required fields. 

NoPostScriptPrintersFoundException No PostScript printers are installed on the 
XWDSS server. 

 

Constraint Messages 

Table B-2 contains configurable error messages for constraints that may 
occur in Web Document Submission. Any of these messages may be 
modified. 

Note: All values are editable in the following table. The Property 
Name and Default Values provide enough information that a 
description is not necessary for this section. 

Table B-2. Constraint Messages for system locale en_US 

Property Name Default Value 

msg.DateDataType Format should be a valid date. 

msg.TimeDataType Format should be a valid time. 

msg.requiredField This is a required field. 

msg.NumberDataType Format should be numeric. 

(msg.CharDataType) Numeric characters are not permitted. 

(msg.IntegerDataType) Format should be an integer. 

(msg.requiredFields) Required fields: 

(msg.ComplexConstraint) The following selection combination is not 
allowed: 
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C. Install Verification Procedure 

Use this appendix to verify a successful installation of Web Document 
Submission. Record all test results pertinent to a specific install in the 
worksheets provided in this chapter. 

Functional Areas Being Verified 

This section provides an overview of the functional areas verified after 
software installation. 

Administrative Functions 

Administrative functions that will be tested are listed in Table C-1. 

Table C-1. Administrative functions and procedures 
Function Test Procedure 

Log on as Administrator 1.1 

Add Printer (Default and others in print shop) 1.2 

Edit User Interface Using Admin Tools 1.3 
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Client Functions 

Client functions that will be tested are listed in Table C-2. 

Table C-2. Client functions and procedures 
Function Test Procedure 

Register Your Account 2.1 

Log on as End User 2.2 

Edit User Profile 2.3 

Submit Print Job Request – MS Word Document 2.4 

Submit a Print Job Request – MS Excel Document 2.5 

Submit a Print Job Request – Hard copy Document 2.6 

Edit Personal Address Book 2.7 

Edit Document Repository 2.8 
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Operator Functions 

Operator functions that will be tested are listed in Table C-3. 

Table C-3. Operator functions and procedures 
Function Test Procedure 

Log on as Operator 3.1 

Edit a Client Job Request – MS Word Document 3.2 

Fulfill a Client Job Request – MS Word Document 3.3 

Fulfill a Client Job Request – MS Excel Document 3.4 

Fulfill a Client Job Request – Hard copy Document 3.5 

Send a Print Job to Each Installed Printer 3.6 
 

Install Verification Procedures 

These install verification procedures test the basic system functionality of 
Web Document Submission. Run the Administrator and Operator 
verification procedures from any workstation on the system network 
except where noted. Test the Client verification procedures from a 
corporate client workstation.  

Record all Pass / Fail results and provide a summary in the Install 
Verification Record at the end of this chapter.  

1. Administrator Verification Procedures 

The Administrator verification procedures test the major functions of a 
System Administrator using Web Document Submission.  
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1.1 Logging on as Administrator 

Perform the following to log on as Administrator: 
1. Open a browser window on a workstation connected to the network, 

or one of the Web Document Submission servers. 

2. In the address line, type the IP address for the Web Document 
Submission server: 
 
http:// <Web Document Submission server IP address>/xdx/admin 

3. Type admin in the Username text box, type the admin password 
22222 in the Password text box and click Log On. 

Verify that the log on was successful. If unsuccessful, please note the 
observed system response. 

__________________________________________________________  

__________________________________________________________  

1.2 Adding a Printer 

Perform the following to add a printer: 
1. While logged on as Administrator, click Printers. From the Manage 

Printers drop-down menu chose Add Printer.  
2. Type the Printer Name, Server Address, Printer Location, and 

Printer Description in the text boxes provided and select a printer 
from the Windows Printer Name drop-down menu. Select and click 
Add Printer to save the printer data.  

3. On the Manage Printers drop-down menu, click View Printers. 

Verify that the added printer is displayed according to the definition just 
supplied. If unsuccessful, please note the observed system response. 

__________________________________________________________  

__________________________________________________________  
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1.3 Editing the User Interface Using Admin Tools 

Perform the following to edit the user interface using the Admin 
tools: 
1. Move to the Web Document Submission server and open the XWDSS 

Admin tools. 

2. Click Tools > UI Config. From the Configure Colors drop-down 
menu, select Main Page Text Color. 

3. In the Current Color text box type:  

#0000ff 

4. Click Commit Changes and type the Admin Username and Password 
if requested.  

5. Open a web browser to verify that, after logging on, the welcome 
message has blue text. 

6. Change the Current Color for the Main Page Text Color back to: 

#000000 

7. Click Commit Changes and type the Admin Username and Password 
if requested. 

8. Click Start > Run and in the Open box type net stop xwdss and click 
OK. Close the XWDSS Admin tools. 

9. Click Start > Run and in the Open box type net stop xwdss and click 
OK to restart Web Document Submission and return to the Home 
page. 

Verify that the changes were saved and UI updates are visible on the 
affected web pages. If unsuccessful, please note the observed system 
response. 

__________________________________________________________  

__________________________________________________________  
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2. Client Verification Procedures 

The Client verification procedures exercise the major end user functions 
of Web Document Submission.  

2.1 Registering a Client Account – Self Registration 

Perform the following to register a client account: 
1. Open a browser window on a workstation connected to the network, 

or one of the Web Document Submission servers. 

2. In the address line, type the IP address for the Web Document 
Submission server: 
 
http:// <Web Document Submission server IP address>/xdx 

3. Click Self Registration. 

4. Type a user name and a valid E-mail address. To send the 
registration request click Continue. 

5. Retrieve the E-mail that the system sent for registration. Click on the 
link provided. 

6. In the New Password and the Verify Password fields, type a new 
password. 

7. To log on to Web Document Submission click Finish. 

Verify that a system-generated E-mail was sent to the registering end 
user containing the assigned system password. If unsuccessful, please 
note the observed system response. 

__________________________________________________________  

__________________________________________________________  
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2.2 Logging on as a User 

Perform the following to log in as an end user: 
1. Close the browser window from procedure 2.1. Open a new browser 

window. 

2. In the address line, type the IP address for the Web Document 
Submission server: 
 
http:// <Web Document Submission server IP address>/xdx 

3. Type the user name registered in procedure 2.1. 

4. Type the registered password in the Password box. Click Log On. 

Verify that the log on was successful. If unsuccessful, please note 
observed the system response. 

__________________________________________________________  

__________________________________________________________  

2.3 Editing a User Profile 

Perform the following to edit a user profile: 
1. From the Home page, click User Profile.  

2. Fill in or modify User Profile fields for the user.  

3. Click Update Profile. Click Finish to save the updates. 

Verify that the user profile updates were successful by clicking Log Off, 
logging back on as the same user, and selecting User Profile from the 
menu. If unsuccessful, please note the observed system response. 

__________________________________________________________  

__________________________________________________________  
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2.4 Submitting a Print Job Request – MS Word Document 

Perform the following to submit an MS Word document print job 
request: 
1. From the User Home page, click Submit.  
2. Click Browse. Select any MS Word document and click Open.  

3. Click Next to upload the MS Word document to the repository on the 
Web Document Submission server. 

4. Type Test description in the Description text box. Click Next. 
5. The recipients for the job appear. Click Next.  
6. Type These are special instructions in the Special Instructions 

text box. Click Next.  
7. The Verify your order window appears. Review the order and then 

click Submit Order. Wait for the screen to refresh. 

8. Record the Job ID for this job. This Job ID will be required for test 
procedure 3.2. Click Finish 

Verify that the submitted job was successful. If unsuccessful, please note 
the observed system response. 

__________________________________________________________  

__________________________________________________________  

2.5 Submitting a Print Job Request – MS Excel Document 

Perform the following to submit an MS Excel document print job 
request: 
1. From the User Home page, click Submit.  
2. Click Browse. Select any MS Excel document and click Open.  

3. Click Next to upload the MS Excel document to the repository on the 
Web Document Submission server. 
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4. Select any print options for this document job. Click Next. 
5. The recipients for the job appear. Click Next.  
6. Type These are special instructions in the Special Instructions 

text box. Click Next.  
7. The Verify your order window appears. Review the order and then 

click Submit Order. Wait for the screen to refresh. 

Verify that the submitted job was successful. If unsuccessful, please note 
the observed system response. 

__________________________________________________________  

__________________________________________________________  

2.6 Submitting a Print Job Request – Hard Copy Document 

Perform the following to submit a hard copy document print job 
request: 
1. From the User Home page click Submit. 
2. Click Hard Copy. 

3. Select the print options for this document. Click Next. 
4. The Choose recipients for this job window appears. Click Next. 
5. Type These are special instructions in the Special Instructions 

text box. Click Next.  
6. The Verify your order window appears. Review the order. 

7. Click Submit Order to submit the print job order to the print shop. 
Wait for the screen to refresh. 

Verify that the submitted job was successful. If unsuccessful, please note 
the observed system response 

__________________________________________________________  

__________________________________________________________  
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2.7 Editing the Personal Address Book 

Perform the following to edit the Personal Address Book: 
1. From the User Home page, click Personal Address Book. 

2. Click Add User.  
3. Fill in the fields with an imaginary user. When finished click Add User. 

Verify that the new address was successful saved by clicking the name 
link of the user just added. Ensure the edits made were saved. If 
unsuccessful, please note the observed system response. 

__________________________________________________________  

__________________________________________________________  

2.8 Editing the Document Repository 

Perform the following to edit the Document Repository: 
1. From the User Home page, click Repository. 

2. Select a document from the repository. Select Extend. Click Delete 
or Extend Document. 

Verify that the document selected for extension was extended from the 
repository. Typically, since there is just one document in the repository 
from these tests, the number of days remaining should not change. If 
unsuccessful, please note the observed system response. 

__________________________________________________________  

__________________________________________________________  

3. Operator Verification Procedures 

The Operator verification procedures test the major functions of an 
Operator using Web Document Submission.  
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3.1 Logging on as Operator 

Perform the following to log on as Operator: 
1. Open a browser window on a workstation connected to the network. 

2. In the address line, type the IP address for the Web Document 
Submission server: 
 
http:// <Web Document Submission server IP address>/xdx /admin 

3. Type operator in the User Name text box. 

4. Type the operator password 22222 in the Password text box and click 
Log On. 

Verify that the log on was successful. If unsuccessful, please note the 
observed system response. 

__________________________________________________________  

__________________________________________________________  

3.2 Editing a Client Job Request – MS Word Document 

Perform the following to edit an MS Word document client job 
request: 
1. From the Operator Home page locate the Job ID of the MS Word 

document previously submitted. 

2. From the Options drop-down menu, choose Edit Job. Make some 
type of change to the job. 

3. Click Submit Edits. The screen refreshes. Click Finish. 

4. From the Options drop-down menu, choose Inspect Job. 

Verify that the job properties were updated. If unsuccessful, please note 
the observed system response. 

__________________________________________________________  

__________________________________________________________  



INSTALL VERIFICATION PROCEDURE XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.1 

INDEX C-12 INSTALLATION AND SYSTEM ADMINISTRATION GUIDE 

3.3 Fulfilling a Client Job Request – MS Word Document 

A printer must already be added to the Web Document Submission 
system and the installer logged in as Administrator for this test to work. 

Perform the following to fulfill an MS Word document client job 
request: 
1. Using the job just edited in 3.2, from the Options drop-down menu, 

choose Print Job. 

2. Under Print Full Job, select a printer from the drop-down menu. 

3. Clear the Skip Job Ticket checkbox and click Print. 
4. Click Job Status. Select Succeeded from the Change Status to: 

drop-down menu. 

5. Click Submit to update the job status. 

6. Click Set Page Count to confirm status change and update the page 
count if necessary. 

7. Click Job Status Page. 

Verify that the Job Status is Succeeded. If unsuccessful, please note the 
observed system response.  

Note: If E-mail notification is activated, verify that the end user 
received an E-mail notification of job completion. 

__________________________________________________________  

__________________________________________________________  

3.4 Fulfilling a Client Job Request – MS Excel Document 

Perform the following to fulfill an MS Excel document client job 
request: 
1. Using the job just edited in 3.2, from the Options drop-down menu, 

choose Print Job. 

2. Under Print Full Job, select a printer from the drop-down menu. 
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3. Clear the Skip Job Ticket checkbox and click Print. 
4. Click Job Status. Select Succeeded from the Change Status to: 

drop-down menu. 

5. Click Submit to update the job status. 

6. Click Set Page Count to confirm status change and update the page 
count if necessary. 

7. Click Job Status Page. 

Verify that the Job Status is Succeeded. If unsuccessful, please note 
the observed system response.  

Note: If E-mail notification is activated, verify that the end user 
received an E-mail notification of job completion. 

__________________________________________________________  

__________________________________________________________  

3.5 Fulfilling a Client Job Request – Hard copy Document 

Perform the following to fulfill a hard copy document client job 
request: 
1. From the Operator Home page, locate the Job ID of the hard copy 

document previously submitted. 

2. From the Options drop-down menu, click Inspect Job. 

3. Click Edit job ticket to examine the job options selected for the hard 
copy document. 

4. Print the job according to the client print request. 

5. On the Web Document Submission Operator page click Job Status. 
Select Succeeded from the Change Status to: drop-down menu. 

6. Click Submit to update the job status. 

7. Click Set Page Count to confirm status change and update the page 
count if necessary. 
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8. Click Job Status Page. 

Verify that the Job Status is Succeeded. If unsuccessful, please note 
the observed system response.  
Note: If E-mail notification is activated, verify that the end user 

received an E-mail notification of job completion. 

__________________________________________________________  

__________________________________________________________  

3.6 Sending a Job to Each Installed Printer 

Perform the following to send a job to each installed printer: 
1. From the Operator Home page, locate any Job ID with status of 

Received in Print Shop. 

Note: If there is no job with the status of Received in Print Shop, 
change the status of any job to Received in Print Shop. 

2. From the Options drop-down menu, click Inspect Job to view the job 
properties. 

3. Click Print Job. 

4. Under the heading Print Full Job, select a printer from the  
drop-down menu. 

5. Click Print to send the job to the selected printer.  

6. Repeat steps 4 and 5 for each installed printer. 

7. Click Job Status. Select Succeeded from the Change Status to: 
drop-down menu. 

8. Click Submit to update the job status. 

9. Click Set Page Count to confirm status change and update the page 
count if necessary. 

10. Click Job Status Page. 



XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.1 INSTALL VERIFICATION PROCEDURE 

INSTALLATION AND SYSTEM ADMINISTRATION GUIDE C-15 

Verify that the job was successful and all printers could print job requests. 
If unsuccessful, please note the observed system response. 

__________________________________________________________  

__________________________________________________________  

Install Verification Record 

Use the following section to record results of the installation verification 
procedures. Comments concerning failure observations are recorded at 
the bottom of each procedure the previous section. 

Results 

Record results using the following tables. Describe what is observed if a 
procedure fails. 

Administrative Functions 

Test results for Administrative functions are recorded in Table C-4. 

Table C-4. Administrative functions and test procedures 
Function Test 

Procedure 
Results 

P – Pass or F – Fail 

Log on as Administrator 2.1.1  

Add Printers (Default and others in print shop) 2.1.2  

Edit User Interface Using Admin Tools 2.1.3  
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Client Functions 

Test results for Client functions are recorded in Table C-5. 

Table C-5. Client functions and test procedures 
Function Test 

Procedure 
Results 

P – Pass or F – Fail 

Register Your Account 2.2.1  

Log on as End User 2.2.2  

Edit User Profile 2.2.3  

Submit Print Job Request – MS Word 
Document 

2.2.4  

Submit a Print Job Request – MS Excel 
Document 

2.2.5  

Submit a Print Job Request – Hardcopy 
Document 

2.2.6  

Submit a File Conversion Job Request – PDF 2.2.7  
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Table C-5. Client functions and test procedures (continued) 
Function Test 

Procedure 
Results 

P – Pass or F – Fail 

Submit a File Conversion Job Request – 
PostScript 

2.2.8  

Edit Personal Address Book 2.2.9  

Edit Document Repository 2.2.10  

Operator Functions 

Test results for Operator functions are recorded in Table C-6. 

Table C-6. Operator functions and test procedures 
Function Test 

Procedure 
Results 

P – Pass or F – Fail 

Log on  as Operator 2.3.1  

Edit a Client Job Request – MS Word 
Document 

2.3.2  

Fulfill a Client Job Request – MS Word 
Document 

2.3.3  

Fulfill a Client Job Request – MS Excel 
Document 

2.3.4  

Fulfill a Client Job Request – Hard copy 
Document 

2.3.5  

Send a Job to Each Installed Printer 2.3.6  
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